Novacode Namespace

[image]

DocX - A Sandcastle Documented Class Library
Novacode Namespace
Send Feedback

[Missing <summary> documentation for "N:Novacode"]

Classes

 | Class | Description
Public class | Axis | Axis base class
Public class | BarChart | This element contains the 2-D bar or column series on this chart. 21.2.2.16 barChart (Bar Charts)
Public class | Border | Represents a border of a table or table cell Added by lckuiper @ 20101117
Public class | CategoryAxis | Represents Category Axes
Public class | Cell |
Public class | Chart | Represents every Chart in this document.
Public class | ChartLegend | Represents a chart legend More: http://msdn.microsoft.com/ru-ru/library/cc845123.aspx
Public class | Container |
Public class | CustomProperty |
Public class | DocProperty | Represents a field of type document property. This field displays the value stored in a custom property.
Public class | DocX | Represents a document.
Public class | DocXElement | All DocX types are derived from DocXElement. This class contains properties which every element of a DocX must contain.
Public class | Footer |
Public class | Footers |
Public class | FormattedText |
Public class | Formatting | A text formatting.
Public class | Header |
Public class | Headers |
Public class | Hyperlink | Represents a Hyperlink in a document.
Public class | Image | Represents an Image embedded in a document.
Public class | InsertBeforeOrAfter | This class provides functions for inserting new DocXElements before or after the current DocXElement. Only certain DocXElements can support these functions without creating invalid documents, at the moment these are Paragraphs and Table.
Public class | LineChart | This element contains the 2-D line chart series. 21.2.2.97 lineChart (Line Charts)
Public class | List | Represents a List in a document.
Public class | PageLayout |
Public class | Paragraph | Represents a document paragraph.
Public class | Picture | Represents a Picture in this document, a Picture is a customized view of an Image.
Public class | PieChart | This element contains the 2-D pie series for this chart. 21.2.2.141 pieChart (Pie Charts)
Public class | Row | Represents a single row in a Table.
Public class | Run |
Public class | Section |
Public class | Series | Represents a chart series
Public class | Table | Represents a Table in a document.
Public class | TableLook |
Public class | ValueAxis | Represents Values Axes

Enumerations

 | Enumeration | Description
Public enumeration | Alignment | Text alignment of a Paragraph.
Public enumeration | AutoFit | How a Table should auto resize.
Public enumeration | BarDirection | Specifies the possible directions for a bar chart. 21.2.3.3 ST_BarDir (Bar Direction)
Public enumeration | BarGrouping | Specifies the possible groupings for a bar chart. 21.2.3.4 ST_BarGrouping (Bar Grouping)
Public enumeration | BasicShapes |
Public enumeration | BlockArrowShapes |
Public enumeration | BorderSize |
Public enumeration | BorderStyle | Table Cell Border styles Added by lckuiper @ 20101117 source: http://msdn.microsoft.com/en-us/library/documentformat.openxml.wordprocessing.tablecellborders.aspx
Public enumeration | CalloutShapes |
Public enumeration | CapsStyle | Change the caps style of text, for use with Append and AppendLine.
Public enumeration | ChartLegendPosition | Specifies the possible positions for a legend. 21.2.3.24 ST_LegendPos (Legend Position)
Public enumeration | ContainerType |
Public enumeration | Direction |
Public enumeration | DisplayBlanksAs | Specifies the possible ways to display blanks. 21.2.3.10 ST_DispBlanksAs (Display Blanks As)
Public enumeration | EditRestrictions |
Public enumeration | EquationShapes |
Public enumeration | FlowchartShapes |
Public enumeration | Grouping | Specifies the kind of grouping for a column, line, or area chart. 21.2.2.76 grouping (Grouping)
Public enumeration | Highlight |
Public enumeration | ListItemType |
Public enumeration | MatchFormattingOptions |
Public enumeration | Misc |
Public enumeration | Orientation |
Public enumeration | PageNumberFormat |
Public enumeration | RectangleShapes |
Public enumeration | RunTextType | Text types in a Run
Public enumeration | Script |
Public enumeration | SectionBreakType |
Public enumeration | StarAndBannerShapes |
Public enumeration | StrikeThrough |
Public enumeration | TableBorderType | Table Border Types Added by lckuiper @ 20101117 source: http://msdn.microsoft.com/en-us/library/documentformat.openxml.wordprocessing.tableborders.aspx
Public enumeration | TableCellBorderType | Table Cell Border Types Added by lckuiper @ 20101117 source: http://msdn.microsoft.com/en-us/library/documentformat.openxml.wordprocessing.tablecellborders.aspx
Public enumeration | TableDesign | Designs\Styles that can be applied to a table.
Public enumeration | UnderlineStyle |
Public enumeration | VerticalAlignment |
Public enumeration | XmlDocument |

Send comments on this topic to coffey.cathal@gmail.com


Alignment Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Alignment Enumeration
See Also Send Feedback
Text alignment of a Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Alignment
Visual Basic
Public Enumeration Alignment
Visual C++
public enum class Alignment

Members

Member name | Value | Description
left | 0 | Align Paragraph to the left.
center | 1 | Align Paragraph as centered.
right | 2 | Align Paragraph to the right.
both | 3 | (Justified) Align Paragraph to both the left and right margins, adding extra space between content as necessary.

See Also

Novacode Namespace


AutoFit Enumeration

[image]

DocX - A Sandcastle Documented Class Library
AutoFit Enumeration
See Also Send Feedback
How a Table should auto resize.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum AutoFit
Visual Basic
Public Enumeration AutoFit
Visual C++
public enum class AutoFit

Members

Member name | Value | Description
Contents | 0 | Autofit to Table contents.
Window | 1 | Autofit to Window.
ColumnWidth | 2 | Autofit to Column width.

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Axis Class

[image]

DocX - A Sandcastle Documented Class Library
Axis Class
Members See Also Send Feedback
Axis base class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public abstract class Axis
Visual Basic
Public MustInherit Class Axis
Visual C++
public ref class Axis abstract

Inheritance Hierarchy

System..::..Object
Novacode..::..Axis
Novacode..::..CategoryAxis
Novacode..::..ValueAxis

See Also

Axis Members


Axis Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Axis Members
Axis Class Constructors Methods Properties See Also Send Feedback

The Axis type exposes the following members.

Constructors

 | Name | Description
Public method | Axis | Initializes a new instance of the Axis class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | ID of this Axis
Public property | IsVisible | Return true if this axis is visible

See Also

Axis Class


Axis Constructor

[image]

DocX - A Sandcastle Documented Class Library
Axis Constructor
Axis Class See Also Send Feedback
Initializes a new instance of the Axis class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Axis(
    string id
)
Visual Basic
Public Sub New (
    id As String
)
Visual C++
public:
Axis(
    String^ id
)

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:Novacode.Axis.#ctor(System.String)"]

See Also

Axis Class
Axis Members


Axis Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Axis Methods
Axis Class See Also Send Feedback

The Axis type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Axis Class


Axis Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Axis Properties
Axis Class See Also Send Feedback

The Axis type exposes the following members.

Properties

 | Name | Description
Public property | Id | ID of this Axis
Public property | IsVisible | Return true if this axis is visible

See Also

Axis Class


Axis.Id Property

[image]

DocX - A Sandcastle Documented Class Library
Axis..::..Id Property
Axis Class See Also Send Feedback
ID of this Axis

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

Property Value

Type: String

See Also

Axis Class
Axis Members


Axis.IsVisible Property

[image]

DocX - A Sandcastle Documented Class Library
Axis..::..IsVisible Property
Axis Class See Also Send Feedback
Return true if this axis is visible

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Axis Class
Axis Members


BarChart Class

[image]

DocX - A Sandcastle Documented Class Library
BarChart Class
Members See Also Send Feedback
This element contains the 2-D bar or column series on this chart. 21.2.2.16 barChart (Bar Charts)

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class BarChart : Chart
Visual Basic
Public Class BarChart
    Inherits Chart
Visual C++
public ref class BarChart : public Chart

Inheritance Hierarchy

System..::..Object
Novacode..::..Chart
Novacode..::..BarChart

See Also

BarChart Members


BarChart Members

[image] [image]

DocX - A Sandcastle Documented Class Library
BarChart Members
BarChart Class Constructors Methods Properties See Also Send Feedback

The BarChart type exposes the following members.

Constructors

 | Name | Description
Public method | BarChart | Initializes a new instance of the BarChart class

Methods

 | Name | Description
Public method | AddLegend()()()() | Add standart legend to the chart. (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | Add a legend with parameters to the chart. (Inherited from Chart.)
Public method | AddSeries | Add a new series to this chart (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | Remove the legend from the chart. (Inherited from Chart.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BarDirection | Specifies the possible directions for a bar chart.
Public property | BarGrouping | Specifies the possible groupings for a bar chart.
Public property | CategoryAxis | Represents the category axis (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | Specifies how blank cells shall be plotted on a chart (Inherited from Chart.)
Public property | GapWidth | Specifies that its contents contain a percentage between 0% and 500%.
Public property | IsAxisExist | Represents existing the axis (Inherited from Chart.)
Public property | Legend | Chart's legend. If legend doesn't exist property is null. (Inherited from Chart.)
Public property | MaxSeriesCount | Return maximum count of series (Inherited from Chart.)
Public property | Series | Chart's series (Inherited from Chart.)
Public property | ValueAxis | Represents the values axis (Inherited from Chart.)
Public property | View3D | Get or set 3D view for this chart (Inherited from Chart.)
Public property | Xml | The xml representation of this chart (Inherited from Chart.)

See Also

BarChart Class


BarChart Constructor

[image]

DocX - A Sandcastle Documented Class Library
BarChart Constructor
BarChart Class See Also Send Feedback
Initializes a new instance of the BarChart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public BarChart()
Visual Basic
Public Sub New
Visual C++
public:
BarChart()

See Also

BarChart Class
BarChart Members


BarChart Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
BarChart Methods
BarChart Class See Also Send Feedback

The BarChart type exposes the following members.

Methods

 | Name | Description
Public method | AddLegend()()()() | Add standart legend to the chart. (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | Add a legend with parameters to the chart. (Inherited from Chart.)
Public method | AddSeries | Add a new series to this chart (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | Remove the legend from the chart. (Inherited from Chart.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarChart Class


BarChart.CreateChartXml Method

[image]

DocX - A Sandcastle Documented Class Library
BarChart..::..CreateChartXml Method
BarChart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.BarChart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected override XElement CreateChartXml()
Visual Basic
Protected Overrides Function CreateChartXml As XElement
Visual C++
protected:
virtual XElement^ CreateChartXml() override

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.BarChart.CreateChartXml"]

See Also

BarChart Class
BarChart Members


BarChart Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
BarChart Properties
BarChart Class See Also Send Feedback

The BarChart type exposes the following members.

Properties

 | Name | Description
Public property | BarDirection | Specifies the possible directions for a bar chart.
Public property | BarGrouping | Specifies the possible groupings for a bar chart.
Public property | CategoryAxis | Represents the category axis (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | Specifies how blank cells shall be plotted on a chart (Inherited from Chart.)
Public property | GapWidth | Specifies that its contents contain a percentage between 0% and 500%.
Public property | IsAxisExist | Represents existing the axis (Inherited from Chart.)
Public property | Legend | Chart's legend. If legend doesn't exist property is null. (Inherited from Chart.)
Public property | MaxSeriesCount | Return maximum count of series (Inherited from Chart.)
Public property | Series | Chart's series (Inherited from Chart.)
Public property | ValueAxis | Represents the values axis (Inherited from Chart.)
Public property | View3D | Get or set 3D view for this chart (Inherited from Chart.)
Public property | Xml | The xml representation of this chart (Inherited from Chart.)

See Also

BarChart Class


BarChart.BarDirection Property

[image]

DocX - A Sandcastle Documented Class Library
BarChart..::..BarDirection Property
BarChart Class See Also Send Feedback
Specifies the possible directions for a bar chart.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public BarDirection BarDirection { get; set; }
Visual Basic
Public Property BarDirection As BarDirection
    Get
    Set
Visual C++
public:
property BarDirection BarDirection {
    BarDirection get ();
    void set (BarDirection value);
}

Property Value

Type: BarDirection

See Also

BarChart Class
BarChart Members


BarChart.BarGrouping Property

[image]

DocX - A Sandcastle Documented Class Library
BarChart..::..BarGrouping Property
BarChart Class See Also Send Feedback
Specifies the possible groupings for a bar chart.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public BarGrouping BarGrouping { get; set; }
Visual Basic
Public Property BarGrouping As BarGrouping
    Get
    Set
Visual C++
public:
property BarGrouping BarGrouping {
    BarGrouping get ();
    void set (BarGrouping value);
}

Property Value

Type: BarGrouping

See Also

BarChart Class
BarChart Members


BarChart.GapWidth Property

[image]

DocX - A Sandcastle Documented Class Library
BarChart..::..GapWidth Property
BarChart Class See Also Send Feedback
Specifies that its contents contain a percentage between 0% and 500%.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int GapWidth { get; set; }
Visual Basic
Public Property GapWidth As Integer
    Get
    Set
Visual C++
public:
property int GapWidth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarChart Class
BarChart Members


BarDirection Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BarDirection Enumeration
See Also Send Feedback
Specifies the possible directions for a bar chart. 21.2.3.3 ST_BarDir (Bar Direction)

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BarDirection
Visual Basic
Public Enumeration BarDirection
Visual C++
public enum class BarDirection

Members

Member name | Value | Description
Column | 0 |
Bar | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


BarGrouping Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BarGrouping Enumeration
See Also Send Feedback
Specifies the possible groupings for a bar chart. 21.2.3.4 ST_BarGrouping (Bar Grouping)

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BarGrouping
Visual Basic
Public Enumeration BarGrouping
Visual C++
public enum class BarGrouping

Members

Member name | Value | Description
Clustered | 0 |
PercentStacked | 1 |
Stacked | 2 |
Standard | 3 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


BasicShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BasicShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.BasicShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BasicShapes
Visual Basic
Public Enumeration BasicShapes
Visual C++
public enum class BasicShapes

Members

Member name | Value | Description
ellipse | 0 |
triangle | 1 |
rtTriangle | 2 |
parallelogram | 3 |
trapezoid | 4 |
diamond | 5 |
pentagon | 6 |
hexagon | 7 |
heptagon | 8 |
octagon | 9 |
decagon | 10 |
dodecagon | 11 |
pie | 12 |
chord | 13 |
teardrop | 14 |
frame | 15 |
halfFrame | 16 |
corner | 17 |
diagStripe | 18 |
plus | 19 |
plaque | 20 |
can | 21 |
cube | 22 |
bevel | 23 |
donut | 24 |
noSmoking | 25 |
blockArc | 26 |
foldedCorner | 27 |
smileyFace | 28 |
heart | 29 |
lightningBolt | 30 |
sun | 31 |
moon | 32 |
cloud | 33 |
arc | 34 |
backetPair | 35 |
bracePair | 36 |
leftBracket | 37 |
rightBracket | 38 |
leftBrace | 39 |
rightBrace | 40 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


BlockArrowShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BlockArrowShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.BlockArrowShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BlockArrowShapes
Visual Basic
Public Enumeration BlockArrowShapes
Visual C++
public enum class BlockArrowShapes

Members

Member name | Value | Description
rightArrow | 0 |
leftArrow | 1 |
upArrow | 2 |
downArrow | 3 |
leftRightArrow | 4 |
upDownArrow | 5 |
quadArrow | 6 |
leftRightUpArrow | 7 |
bentArrow | 8 |
uturnArrow | 9 |
leftUpArrow | 10 |
bentUpArrow | 11 |
curvedRightArrow | 12 |
curvedLeftArrow | 13 |
curvedUpArrow | 14 |
curvedDownArrow | 15 |
stripedRightArrow | 16 |
notchedRightArrow | 17 |
homePlate | 18 |
chevron | 19 |
rightArrowCallout | 20 |
downArrowCallout | 21 |
leftArrowCallout | 22 |
upArrowCallout | 23 |
leftRightArrowCallout | 24 |
quadArrowCallout | 25 |
circularArrow | 26 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Border Class

[image]

DocX - A Sandcastle Documented Class Library
Border Class
Members See Also Send Feedback
Represents a border of a table or table cell Added by lckuiper @ 20101117

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Border
Visual Basic
Public Class Border
Visual C++
public ref class Border

Inheritance Hierarchy

System..::..Object
Novacode..::..Border

See Also

Border Members


Border Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Border Members
Border Class Constructors Methods Properties See Also Send Feedback

The Border type exposes the following members.

Constructors

 | Name | Description
Public method | Border()()()() | Initializes a new instance of the Border class
Public method | Border(BorderStyle, BorderSize, Int32, Color) | Initializes a new instance of the Border class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color |
Public property | Size |
Public property | Space |
Public property | Tcbs |

See Also

Border Class


Border Constructor

[image] [image]

DocX - A Sandcastle Documented Class Library
Border Constructor
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Border()()()() | Initializes a new instance of the Border class
Public method | Border(BorderStyle, BorderSize, Int32, Color) | Initializes a new instance of the Border class

See Also

Border Class
Border Members


Border Constructor

[image]

DocX - A Sandcastle Documented Class Library
Border Constructor
Border Class See Also Send Feedback
Initializes a new instance of the Border class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Border()
Visual Basic
Public Sub New
Visual C++
public:
Border()

See Also

Border Class
Border Members
Border Overload


Border Constructor (BorderStyle, BorderSize, Int32, Color)

[image]

DocX - A Sandcastle Documented Class Library
Border Constructor (BorderStyle, BorderSize, Int32, Color)
Border Class See Also Send Feedback
Initializes a new instance of the Border class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Border(
    BorderStyle tcbs,
    BorderSize size,
    int space,
    Color color
)
Visual Basic
Public Sub New (
    tcbs As BorderStyle,
    size As BorderSize,
    space As Integer,
    color As Color
)
Visual C++
public:
Border(
    BorderStyle tcbs,
    BorderSize size,
    int space,
    Color color
)

Parameters

tcbs
Type: Novacode..::..BorderStyle

[Missing <param name="tcbs"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

size
Type: Novacode..::..BorderSize

[Missing <param name="size"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

space
Type: System..::..Int32

[Missing <param name="space"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

color
Type: System.Drawing..::..Color

[Missing <param name="color"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

See Also

Border Class
Border Members
Border Overload


Border Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Border Methods
Border Class See Also Send Feedback

The Border type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Border Class


Border Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Border Properties
Border Class See Also Send Feedback

The Border type exposes the following members.

Properties

 | Name | Description
Public property | Color |
Public property | Size |
Public property | Space |
Public property | Tcbs |

See Also

Border Class


Border.Color Property

[image]

DocX - A Sandcastle Documented Class Library
Border..::..Color Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Border.Color"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

Border Class
Border Members


Border.Size Property

[image]

DocX - A Sandcastle Documented Class Library
Border..::..Size Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Border.Size"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public BorderSize Size { get; set; }
Visual Basic
Public Property Size As BorderSize
    Get
    Set
Visual C++
public:
property BorderSize Size {
    BorderSize get ();
    void set (BorderSize value);
}

Property Value

Type: BorderSize

See Also

Border Class
Border Members


Border.Space Property

[image]

DocX - A Sandcastle Documented Class Library
Border..::..Space Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Border.Space"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int Space { get; set; }
Visual Basic
Public Property Space As Integer
    Get
    Set
Visual C++
public:
property int Space {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

Border Class
Border Members


Border.Tcbs Property

[image]

DocX - A Sandcastle Documented Class Library
Border..::..Tcbs Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Border.Tcbs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public BorderStyle Tcbs { get; set; }
Visual Basic
Public Property Tcbs As BorderStyle
    Get
    Set
Visual C++
public:
property BorderStyle Tcbs {
    BorderStyle get ();
    void set (BorderStyle value);
}

Property Value

Type: BorderStyle

See Also

Border Class
Border Members


BorderSize Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BorderSize Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.BorderSize"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BorderSize
Visual Basic
Public Enumeration BorderSize
Visual C++
public enum class BorderSize

Members

Member name | Value | Description
one | 0 |
two | 1 |
three | 2 |
four | 3 |
five | 4 |
six | 5 |
seven | 6 |
eight | 7 |
nine | 8 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


BorderStyle Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BorderStyle Enumeration
See Also Send Feedback
Table Cell Border styles Added by lckuiper @ 20101117 source: http://msdn.microsoft.com/en-us/library/documentformat.openxml.wordprocessing.tablecellborders.aspx

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BorderStyle
Visual Basic
Public Enumeration BorderStyle
Visual C++
public enum class BorderStyle

Members

Member name | Value | Description
Tcbs_none | 0 |
Tcbs_single | 1 |
Tcbs_thick | 2 |
Tcbs_double | 3 |
Tcbs_dotted | 4 |
Tcbs_dashed | 5 |
Tcbs_dotDash | 6 |
Tcbs_dotDotDash | 7 |
Tcbs_triple | 8 |
Tcbs_thinThickSmallGap | 9 |
Tcbs_thickThinSmallGap | 10 |
Tcbs_thinThickThinSmallGap | 11 |
Tcbs_thinThickMediumGap | 12 |
Tcbs_thickThinMediumGap | 13 |
Tcbs_thinThickThinMediumGap | 14 |
Tcbs_thinThickLargeGap | 15 |
Tcbs_thickThinLargeGap | 16 |
Tcbs_thinThickThinLargeGap | 17 |
Tcbs_wave | 18 |
Tcbs_doubleWave | 19 |
Tcbs_dashSmallGap | 20 |
Tcbs_dashDotStroked | 21 |
Tcbs_threeDEmboss | 22 |
Tcbs_threeDEngrave | 23 |
Tcbs_outset | 24 |
Tcbs_inset | 25 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


CalloutShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
CalloutShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.CalloutShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum CalloutShapes
Visual Basic
Public Enumeration CalloutShapes
Visual C++
public enum class CalloutShapes

Members

Member name | Value | Description
wedgeRectCallout | 0 |
wedgeRoundRectCallout | 1 |
wedgeEllipseCallout | 2 |
cloudCallout | 3 |
borderCallout1 | 4 |
borderCallout2 | 5 |
borderCallout3 | 6 |
accentCallout1 | 7 |
accentCallout2 | 8 |
accentCallout3 | 9 |
callout1 | 10 |
callout2 | 11 |
callout3 | 12 |
accentBorderCallout1 | 13 |
accentBorderCallout2 | 14 |
accentBorderCallout3 | 15 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


CapsStyle Enumeration

[image]

DocX - A Sandcastle Documented Class Library
CapsStyle Enumeration
See Also Send Feedback
Change the caps style of text, for use with Append and AppendLine.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum CapsStyle
Visual Basic
Public Enumeration CapsStyle
Visual C++
public enum class CapsStyle

Members

Member name | Value | Description
none | 0 | No caps, make all characters are lowercase.
caps | 1 | All caps, make every character uppercase.
smallCaps | 2 | Small caps, make all characters capital but with a small font size.

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


CategoryAxis Class

[image]

DocX - A Sandcastle Documented Class Library
CategoryAxis Class
Members See Also Send Feedback
Represents Category Axes

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class CategoryAxis : Axis
Visual Basic
Public Class CategoryAxis
    Inherits Axis
Visual C++
public ref class CategoryAxis : public Axis

Inheritance Hierarchy

System..::..Object
Novacode..::..Axis
Novacode..::..CategoryAxis

See Also

CategoryAxis Members


CategoryAxis Members

[image] [image]

DocX - A Sandcastle Documented Class Library
CategoryAxis Members
CategoryAxis Class Constructors Methods Properties See Also Send Feedback

The CategoryAxis type exposes the following members.

Constructors

 | Name | Description
Public method | CategoryAxis | Initializes a new instance of the CategoryAxis class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | ID of this Axis (Inherited from Axis.)
Public property | IsVisible | Return true if this axis is visible (Inherited from Axis.)

See Also

CategoryAxis Class


CategoryAxis Constructor

[image]

DocX - A Sandcastle Documented Class Library
CategoryAxis Constructor
CategoryAxis Class See Also Send Feedback
Initializes a new instance of the CategoryAxis class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CategoryAxis(
    string id
)
Visual Basic
Public Sub New (
    id As String
)
Visual C++
public:
CategoryAxis(
    String^ id
)

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:Novacode.CategoryAxis.#ctor(System.String)"]

See Also

CategoryAxis Class
CategoryAxis Members


CategoryAxis Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
CategoryAxis Methods
CategoryAxis Class See Also Send Feedback

The CategoryAxis type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategoryAxis Class


CategoryAxis Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
CategoryAxis Properties
CategoryAxis Class See Also Send Feedback

The CategoryAxis type exposes the following members.

Properties

 | Name | Description
Public property | Id | ID of this Axis (Inherited from Axis.)
Public property | IsVisible | Return true if this axis is visible (Inherited from Axis.)

See Also

CategoryAxis Class


Cell Class

[image]

DocX - A Sandcastle Documented Class Library
Cell Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Cell"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Cell : Container
Visual Basic
Public Class Cell
    Inherits Container
Visual C++
public ref class Cell : public Container

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Cell

See Also

Cell Members


Cell Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Cell Members
Cell Class Methods Fields Properties See Also Send Feedback

The Cell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetBorder | Get a table cell border Added by lckuiper @ 20101117
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Overrides Container..::..InsertTable(Int32, Int32).)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetBorder |
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

Properties

 | Name | Description
Public property | FillColor | Gets or Sets the fill color of this Cell.
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | MarginBottom | BottomMargin in pixels. // Added by lckuiper
Public property | MarginLeft | LeftMargin in pixels. // Added by lckuiper
Public property | MarginRight | RightMargin in pixels. // Added by lckuiper
Public property | MarginTop | TopMargin in pixels. // Added by lckuiper
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Shading |
Public property | Tables | (Inherited from Container.)
Public property | VerticalAlignment |
Public property | Width | Width in pixels. // Added by Joel, refactored by Cathal
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Cell Class


Cell Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Cell Fields
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

See Also

Cell Class


Cell Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Cell Methods
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetBorder | Get a table cell border Added by lckuiper @ 20101117
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Overrides Container..::..InsertTable(Int32, Int32).)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetBorder |
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Cell Class


Cell.GetBorder Method

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..GetBorder Method
Cell Class See Also Send Feedback
Get a table cell border Added by lckuiper @ 20101117

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Border GetBorder(
    TableCellBorderType borderType
)
Visual Basic
Public Function GetBorder (
    borderType As TableCellBorderType
) As Border
Visual C++
public:
Border^ GetBorder(
    TableCellBorderType borderType
)

Parameters

borderType
Type: Novacode..::..TableCellBorderType
The table cell border to get

Return Value

Type: Border

[Missing <returns> documentation for "M:Novacode.Cell.GetBorder(Novacode.TableCellBorderType)"]

See Also

Cell Class
Cell Members


Cell.InsertTable Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Cell..::..InsertTable Method
Cell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Overrides Container..::..InsertTable(Int32, Int32).)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)

See Also

Cell Class
Cell Members


Cell.InsertTable Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..InsertTable Method (Int32, Int32)
Cell Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTable(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overrides Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTable(
    int rowCount,
    int columnCount
) override

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

See Also

Cell Class
Cell Members
InsertTable Overload


Cell.SetBorder Method

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..SetBorder Method
Cell Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Cell.SetBorder(Novacode.TableCellBorderType,Novacode.Border)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetBorder(
    TableCellBorderType borderType,
    Border border
)
Visual Basic
Public Sub SetBorder (
    borderType As TableCellBorderType,
    border As Border
)
Visual C++
public:
void SetBorder(
    TableCellBorderType borderType,
    Border^ border
)

Parameters

borderType
Type: Novacode..::..TableCellBorderType

[Missing <param name="borderType"/> documentation for "M:Novacode.Cell.SetBorder(Novacode.TableCellBorderType,Novacode.Border)"]

border
Type: Novacode..::..Border

[Missing <param name="border"/> documentation for "M:Novacode.Cell.SetBorder(Novacode.TableCellBorderType,Novacode.Border)"]

See Also

Cell Class
Cell Members


Cell Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Cell Properties
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Properties

 | Name | Description
Public property | FillColor | Gets or Sets the fill color of this Cell.
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | MarginBottom | BottomMargin in pixels. // Added by lckuiper
Public property | MarginLeft | LeftMargin in pixels. // Added by lckuiper
Public property | MarginRight | RightMargin in pixels. // Added by lckuiper
Public property | MarginTop | TopMargin in pixels. // Added by lckuiper
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Shading |
Public property | Tables | (Inherited from Container.)
Public property | VerticalAlignment |
Public property | Width | Width in pixels. // Added by Joel, refactored by Cathal
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Cell Class


Cell.FillColor Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..FillColor Property
Cell Class Example See Also Send Feedback
Gets or Sets the fill color of this Cell.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Color FillColor { get; set; }
Visual Basic
Public Property FillColor As Color
    Get
    Set
Visual C++
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
   // Insert a table into this document.
   Table t = document.InsertTable(3, 3);

   // Fill the first cell as Blue.
   t.Rows[0].Cells[0].FillColor = Color.Blue;
   // Fill the middle cell as Red.
   t.Rows[1].Cells[1].FillColor = Color.Red;
   // Fill the last cell as Green.
   t.Rows[2].Cells[2].FillColor = Color.Green;

   // Save the document.
   document.Save();
}

See Also

Cell Class
Cell Members


Cell.MarginBottom Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..MarginBottom Property
Cell Class Example See Also Send Feedback
BottomMargin in pixels. // Added by lckuiper

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double MarginBottom { get; set; }
Visual Basic
Public Property MarginBottom As Double
    Get
    Set
Visual C++
public:
property double MarginBottom {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Examples

Copy image Copy
 // Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Insert table into this document.
    Table t = document.InsertTable(3, 3);
    t.Design = TableDesign.TableGrid;

    // Get the center cell.
    Cell center = t.Rows[1].Cells[1];

    // Insert some text so that we can see the effect of the Margins.
    center.Paragraphs[0].Append("Center Cell");

    // Set the center cells Top, Margin to 10.
    center.MarginBottom = 25;

    // Save the document.
    document.Save();
}

See Also

Cell Class
Cell Members


Cell.MarginLeft Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..MarginLeft Property
Cell Class Example See Also Send Feedback
LeftMargin in pixels. // Added by lckuiper

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double MarginLeft { get; set; }
Visual Basic
Public Property MarginLeft As Double
    Get
    Set
Visual C++
public:
property double MarginLeft {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Examples

Copy image Copy
 // Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Insert table into this document.
    Table t = document.InsertTable(3, 3);
    t.Design = TableDesign.TableGrid;

    // Get the center cell.
    Cell center = t.Rows[1].Cells[1];

    // Insert some text so that we can see the effect of the Margins.
    center.Paragraphs[0].Append("Center Cell");

    // Set the center cells Left, Margin to 10.
    center.MarginLeft = 25;

    // Save the document.
    document.Save();
}

See Also

Cell Class
Cell Members


Cell.MarginRight Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..MarginRight Property
Cell Class Example See Also Send Feedback
RightMargin in pixels. // Added by lckuiper

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double MarginRight { get; set; }
Visual Basic
Public Property MarginRight As Double
    Get
    Set
Visual C++
public:
property double MarginRight {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Examples

Copy image Copy
 // Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Insert table into this document.
    Table t = document.InsertTable(3, 3);
    t.Design = TableDesign.TableGrid;

    // Get the center cell.
    Cell center = t.Rows[1].Cells[1];

    // Insert some text so that we can see the effect of the Margins.
    center.Paragraphs[0].Append("Center Cell");

    // Set the center cells Right, Margin to 10.
    center.MarginRight = 25;

    // Save the document.
    document.Save();
}

See Also

Cell Class
Cell Members


Cell.MarginTop Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..MarginTop Property
Cell Class Example See Also Send Feedback
TopMargin in pixels. // Added by lckuiper

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double MarginTop { get; set; }
Visual Basic
Public Property MarginTop As Double
    Get
    Set
Visual C++
public:
property double MarginTop {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Examples

Copy image Copy
 // Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Insert table into this document.
    Table t = document.InsertTable(3, 3);
    t.Design = TableDesign.TableGrid;

    // Get the center cell.
    Cell center = t.Rows[1].Cells[1];

    // Insert some text so that we can see the effect of the Margins.
    center.Paragraphs[0].Append("Center Cell");

    // Set the center cells Top, Margin to 10.
    center.MarginTop = 25;

    // Save the document.
    document.Save();
}

See Also

Cell Class
Cell Members


Cell.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..Paragraphs Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Paragraph> Paragraphs { get; }
Visual Basic
Public Overrides ReadOnly Property Paragraphs As List(Of Paragraph)
    Get
Visual C++
public:
virtual property List<Paragraph^>^ Paragraphs {
    List<Paragraph^>^ get () override;
}

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

Cell Class
Cell Members


Cell.Shading Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..Shading Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.Shading"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Color Shading { get; set; }
Visual Basic
Public Property Shading As Color
    Get
    Set
Visual C++
public:
property Color Shading {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

Cell Class
Cell Members


Cell.VerticalAlignment Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..VerticalAlignment Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.VerticalAlignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public VerticalAlignment VerticalAlignment { get; set; }
Visual Basic
Public Property VerticalAlignment As VerticalAlignment
    Get
    Set
Visual C++
public:
property VerticalAlignment VerticalAlignment {
    VerticalAlignment get ();
    void set (VerticalAlignment value);
}

Property Value

Type: VerticalAlignment

See Also

Cell Class
Cell Members


Cell.Width Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..Width Property
Cell Class See Also Send Feedback
Width in pixels. // Added by Joel, refactored by Cathal

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Cell Class
Cell Members


Chart Class

[image]

DocX - A Sandcastle Documented Class Library
Chart Class
Members See Also Send Feedback
Represents every Chart in this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public abstract class Chart
Visual Basic
Public MustInherit Class Chart
Visual C++
public ref class Chart abstract

Inheritance Hierarchy

System..::..Object
Novacode..::..Chart
Novacode..::..BarChart
Novacode..::..LineChart
Novacode..::..PieChart

See Also

Chart Members


Chart Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Chart Members
Chart Class Constructors Methods Properties See Also Send Feedback

The Chart type exposes the following members.

Constructors

 | Name | Description
Public method | Chart | Create an Chart for this document

Methods

 | Name | Description
Public method | AddLegend()()()() | Add standart legend to the chart.
Public method | AddLegend(ChartLegendPosition, Boolean) | Add a legend with parameters to the chart.
Public method | AddSeries | Add a new series to this chart
Protected method | CreateChartXml | An abstract method which creates the current chart xml
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | Remove the legend from the chart.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryAxis | Represents the category axis
Protected property | ChartRootXml |
Protected property | ChartXml |
Public property | DisplayBlanksAs | Specifies how blank cells shall be plotted on a chart
Public property | IsAxisExist | Represents existing the axis
Public property | Legend | Chart's legend. If legend doesn't exist property is null.
Public property | MaxSeriesCount | Return maximum count of series
Public property | Series | Chart's series
Public property | ValueAxis | Represents the values axis
Public property | View3D | Get or set 3D view for this chart
Public property | Xml | The xml representation of this chart

See Also

Chart Class


Chart Constructor

[image]

DocX - A Sandcastle Documented Class Library
Chart Constructor
Chart Class See Also Send Feedback
Create an Chart for this document

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Chart()
Visual Basic
Public Sub New
Visual C++
public:
Chart()

See Also

Chart Class
Chart Members


Chart Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Chart Methods
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Methods

 | Name | Description
Public method | AddLegend()()()() | Add standart legend to the chart.
Public method | AddLegend(ChartLegendPosition, Boolean) | Add a legend with parameters to the chart.
Public method | AddSeries | Add a new series to this chart
Protected method | CreateChartXml | An abstract method which creates the current chart xml
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | Remove the legend from the chart.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Chart Class


Chart.AddLegend Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Chart..::..AddLegend Method
Chart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddLegend()()()() | Add standart legend to the chart.
Public method | AddLegend(ChartLegendPosition, Boolean) | Add a legend with parameters to the chart.

See Also

Chart Class
Chart Members


Chart.AddLegend Method

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..AddLegend Method
Chart Class See Also Send Feedback
Add standart legend to the chart.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddLegend()
Visual Basic
Public Sub AddLegend
Visual C++
public:
void AddLegend()

See Also

Chart Class
Chart Members
AddLegend Overload


Chart.AddLegend Method (ChartLegendPosition, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..AddLegend Method (ChartLegendPosition, Boolean)
Chart Class See Also Send Feedback
Add a legend with parameters to the chart.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddLegend(
    ChartLegendPosition position,
    bool overlay
)
Visual Basic
Public Sub AddLegend (
    position As ChartLegendPosition,
    overlay As Boolean
)
Visual C++
public:
void AddLegend(
    ChartLegendPosition position,
    bool overlay
)

Parameters

position
Type: Novacode..::..ChartLegendPosition

[Missing <param name="position"/> documentation for "M:Novacode.Chart.AddLegend(Novacode.ChartLegendPosition,System.Boolean)"]

overlay
Type: System..::..Boolean

[Missing <param name="overlay"/> documentation for "M:Novacode.Chart.AddLegend(Novacode.ChartLegendPosition,System.Boolean)"]

See Also

Chart Class
Chart Members
AddLegend Overload


Chart.AddSeries Method

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..AddSeries Method
Chart Class See Also Send Feedback
Add a new series to this chart

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddSeries(
    Series series
)
Visual Basic
Public Sub AddSeries (
    series As Series
)
Visual C++
public:
void AddSeries(
    Series^ series
)

Parameters

series
Type: Novacode..::..Series

[Missing <param name="series"/> documentation for "M:Novacode.Chart.AddSeries(Novacode.Series)"]

See Also

Chart Class
Chart Members


Chart.CreateChartXml Method

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..CreateChartXml Method
Chart Class See Also Send Feedback
An abstract method which creates the current chart xml

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected abstract XElement CreateChartXml()
Visual Basic
Protected MustOverride Function CreateChartXml As XElement
Visual C++
protected:
virtual XElement^ CreateChartXml() abstract

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.Chart.CreateChartXml"]

See Also

Chart Class
Chart Members


Chart.RemoveLegend Method

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..RemoveLegend Method
Chart Class See Also Send Feedback
Remove the legend from the chart.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveLegend()
Visual Basic
Public Sub RemoveLegend
Visual C++
public:
void RemoveLegend()

See Also

Chart Class
Chart Members


Chart Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Chart Properties
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Properties

 | Name | Description
Public property | CategoryAxis | Represents the category axis
Protected property | ChartRootXml |
Protected property | ChartXml |
Public property | DisplayBlanksAs | Specifies how blank cells shall be plotted on a chart
Public property | IsAxisExist | Represents existing the axis
Public property | Legend | Chart's legend. If legend doesn't exist property is null.
Public property | MaxSeriesCount | Return maximum count of series
Public property | Series | Chart's series
Public property | ValueAxis | Represents the values axis
Public property | View3D | Get or set 3D view for this chart
Public property | Xml | The xml representation of this chart

See Also

Chart Class


Chart.CategoryAxis Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..CategoryAxis Property
Chart Class See Also Send Feedback
Represents the category axis

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CategoryAxis CategoryAxis { get; private set; }
Visual Basic
Public Property CategoryAxis As CategoryAxis
    Get
    Private Set
Visual C++
public:
property CategoryAxis^ CategoryAxis {
    CategoryAxis^ get ();
    private: void set (CategoryAxis^ value);
}

Property Value

Type: CategoryAxis

See Also

Chart Class
Chart Members


Chart.ChartRootXml Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..ChartRootXml Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.ChartRootXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected XElement ChartRootXml { get; private set; }
Visual Basic
Protected Property ChartRootXml As XElement
    Get
    Private Set
Visual C++
protected:
property XElement^ ChartRootXml {
    XElement^ get ();
    private: void set (XElement^ value);
}

Property Value

Type: XElement

See Also

Chart Class
Chart Members


Chart.ChartXml Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..ChartXml Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.ChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected XElement ChartXml { get; private set; }
Visual Basic
Protected Property ChartXml As XElement
    Get
    Private Set
Visual C++
protected:
property XElement^ ChartXml {
    XElement^ get ();
    private: void set (XElement^ value);
}

Property Value

Type: XElement

See Also

Chart Class
Chart Members


Chart.DisplayBlanksAs Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..DisplayBlanksAs Property
Chart Class See Also Send Feedback
Specifies how blank cells shall be plotted on a chart

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public DisplayBlanksAs DisplayBlanksAs { get; set; }
Visual Basic
Public Property DisplayBlanksAs As DisplayBlanksAs
    Get
    Set
Visual C++
public:
property DisplayBlanksAs DisplayBlanksAs {
    DisplayBlanksAs get ();
    void set (DisplayBlanksAs value);
}

Property Value

Type: DisplayBlanksAs

See Also

Chart Class
Chart Members


Chart.IsAxisExist Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..IsAxisExist Property
Chart Class See Also Send Feedback
Represents existing the axis

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual bool IsAxisExist { get; }
Visual Basic
Public Overridable ReadOnly Property IsAxisExist As Boolean
    Get
Visual C++
public:
virtual property bool IsAxisExist {
    bool get ();
}

Property Value

Type: Boolean

See Also

Chart Class
Chart Members


Chart.Legend Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..Legend Property
Chart Class See Also Send Feedback
Chart's legend. If legend doesn't exist property is null.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ChartLegend Legend { get; private set; }
Visual Basic
Public Property Legend As ChartLegend
    Get
    Private Set
Visual C++
public:
property ChartLegend^ Legend {
    ChartLegend^ get ();
    private: void set (ChartLegend^ value);
}

Property Value

Type: ChartLegend

See Also

Chart Class
Chart Members


Chart.MaxSeriesCount Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..MaxSeriesCount Property
Chart Class See Also Send Feedback
Return maximum count of series

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual short MaxSeriesCount { get; }
Visual Basic
Public Overridable ReadOnly Property MaxSeriesCount As Short
    Get
Visual C++
public:
virtual property short MaxSeriesCount {
    short get ();
}

Property Value

Type: Int16

See Also

Chart Class
Chart Members


Chart.Series Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..Series Property
Chart Class See Also Send Feedback
Chart's series

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Series> Series { get; }
Visual Basic
Public ReadOnly Property Series As List(Of Series)
    Get
Visual C++
public:
property List<Series^>^ Series {
    List<Series^>^ get ();
}

Property Value

Type: List <(Of <(<' Series >)>)>

See Also

Chart Class
Chart Members


Chart.ValueAxis Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..ValueAxis Property
Chart Class See Also Send Feedback
Represents the values axis

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ValueAxis ValueAxis { get; private set; }
Visual Basic
Public Property ValueAxis As ValueAxis
    Get
    Private Set
Visual C++
public:
property ValueAxis^ ValueAxis {
    ValueAxis^ get ();
    private: void set (ValueAxis^ value);
}

Property Value

Type: ValueAxis

See Also

Chart Class
Chart Members


Chart.View3D Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..View3D Property
Chart Class See Also Send Feedback
Get or set 3D view for this chart

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool View3D { get; set; }
Visual Basic
Public Property View3D As Boolean
    Get
    Set
Visual C++
public:
property bool View3D {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Chart Class
Chart Members


Chart.Xml Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..Xml Property
Chart Class See Also Send Feedback
The xml representation of this chart

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public XDocument Xml { get; private set; }
Visual Basic
Public Property Xml As XDocument
    Get
    Private Set
Visual C++
public:
property XDocument^ Xml {
    XDocument^ get ();
    private: void set (XDocument^ value);
}

Property Value

Type: XDocument

See Also

Chart Class
Chart Members


ChartLegend Class

[image]

DocX - A Sandcastle Documented Class Library
ChartLegend Class
Members See Also Send Feedback
Represents a chart legend More: http://msdn.microsoft.com/ru-ru/library/cc845123.aspx

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class ChartLegend
Visual Basic
Public Class ChartLegend
Visual C++
public ref class ChartLegend

Inheritance Hierarchy

System..::..Object
Novacode..::..ChartLegend

See Also

ChartLegend Members


ChartLegend Members

[image] [image]

DocX - A Sandcastle Documented Class Library
ChartLegend Members
ChartLegend Class Methods Properties See Also Send Feedback

The ChartLegend type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Overlay | Specifies that other chart elements shall be allowed to overlap this chart element
Public property | Position | Specifies the possible positions for a legend

See Also

ChartLegend Class


ChartLegend Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
ChartLegend Methods
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartLegend Class


ChartLegend Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
ChartLegend Properties
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Properties

 | Name | Description
Public property | Overlay | Specifies that other chart elements shall be allowed to overlap this chart element
Public property | Position | Specifies the possible positions for a legend

See Also

ChartLegend Class


ChartLegend.Overlay Property

[image]

DocX - A Sandcastle Documented Class Library
ChartLegend..::..Overlay Property
ChartLegend Class See Also Send Feedback
Specifies that other chart elements shall be allowed to overlap this chart element

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool Overlay { get; set; }
Visual Basic
Public Property Overlay As Boolean
    Get
    Set
Visual C++
public:
property bool Overlay {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ChartLegend Class
ChartLegend Members


ChartLegend.Position Property

[image]

DocX - A Sandcastle Documented Class Library
ChartLegend..::..Position Property
ChartLegend Class See Also Send Feedback
Specifies the possible positions for a legend

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ChartLegendPosition Position { get; set; }
Visual Basic
Public Property Position As ChartLegendPosition
    Get
    Set
Visual C++
public:
property ChartLegendPosition Position {
    ChartLegendPosition get ();
    void set (ChartLegendPosition value);
}

Property Value

Type: ChartLegendPosition

See Also

ChartLegend Class
ChartLegend Members


ChartLegendPosition Enumeration

[image]

DocX - A Sandcastle Documented Class Library
ChartLegendPosition Enumeration
See Also Send Feedback
Specifies the possible positions for a legend. 21.2.3.24 ST_LegendPos (Legend Position)

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum ChartLegendPosition
Visual Basic
Public Enumeration ChartLegendPosition
Visual C++
public enum class ChartLegendPosition

Members

Member name | Value | Description
Top | 0 |
Bottom | 1 |
Left | 2 |
Right | 3 |
TopRight | 4 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Container Class

[image]

DocX - A Sandcastle Documented Class Library
Container Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Container"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public abstract class Container : DocXElement
Visual Basic
Public MustInherit Class Container
    Inherits DocXElement
Visual C++
public ref class Container abstract : public DocXElement

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Cell
Novacode..::..DocX
Novacode..::..Footer
Novacode..::..Header
Novacode..::..Row
Novacode..::..Section

See Also

Container Members


Container Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Container Members
Container Class Methods Fields Properties See Also Send Feedback

The Container type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation |
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertParagraph()()()() |
Public method | InsertParagraph(String) |
Public method | InsertParagraph(Paragraph) |
Public method | InsertParagraph(Int32, Paragraph) |
Public method | InsertParagraph(String, Boolean) |
Public method | InsertParagraph(Int32, String, Boolean) |
Public method | InsertParagraph(String, Boolean, Formatting) |
Public method | InsertParagraph(Int32, String, Boolean, Formatting) |
Public method | InsertSection()()()() |
Public method | InsertSection(Boolean) |
Public method | InsertSectionPageBreak |
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceText |
Public method | SetDirection | Sets the Direction of content.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer |

Properties

 | Name | Description
Public property | Hyperlinks |
Public property | Lists |
Public property | Paragraphs |
Public property | Pictures |
Public property | Sections |
Public property | Tables |
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Container Class


Container Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Container Fields
Container Class See Also Send Feedback

The Container type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer |

See Also

Container Class


Container.ParentContainer Field

[image]

DocX - A Sandcastle Documented Class Library
Container..::..ParentContainer Field
Container Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Container.ParentContainer"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ContainerType ParentContainer
Visual Basic
Public ParentContainer As ContainerType
Visual C++
public:
ContainerType ParentContainer

Field Value

Type: ContainerType

See Also

Container Class
Container Members


Container Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Container Methods
Container Class See Also Send Feedback

The Container type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation |
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertParagraph()()()() |
Public method | InsertParagraph(String) |
Public method | InsertParagraph(Paragraph) |
Public method | InsertParagraph(Int32, Paragraph) |
Public method | InsertParagraph(String, Boolean) |
Public method | InsertParagraph(Int32, String, Boolean) |
Public method | InsertParagraph(String, Boolean, Formatting) |
Public method | InsertParagraph(Int32, String, Boolean, Formatting) |
Public method | InsertSection()()()() |
Public method | InsertSection(Boolean) |
Public method | InsertSectionPageBreak |
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceText |
Public method | SetDirection | Sets the Direction of content.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Container Class


Container.FindAll Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Container..::..FindAll Method
Container Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |

See Also

Container Class
Container Members


Container.FindAll Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..FindAll Method (String)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.FindAll(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<int> FindAll(
    string str
)
Visual Basic
Public Overridable Function FindAll (
    str As String
) As List(Of Integer)
Visual C++
public:
virtual List<int>^ FindAll(
    String^ str
)

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Novacode.Container.FindAll(System.String)"]

Return Value

Type: List <(Of <(<' Int32 >)>)>

[Missing <returns> documentation for "M:Novacode.Container.FindAll(System.String)"]

See Also

Container Class
Container Members
FindAll Overload


Container.FindAll Method (String, RegexOptions)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..FindAll Method (String, RegexOptions)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<int> FindAll(
    string str,
    RegexOptions options
)
Visual Basic
Public Overridable Function FindAll (
    str As String,
    options As RegexOptions
) As List(Of Integer)
Visual C++
public:
virtual List<int>^ FindAll(
    String^ str,
    RegexOptions options
)

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressions..::..RegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List <(Of <(<' Int32 >)>)>

[Missing <returns> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Container Class
Container Members
FindAll Overload


Container.FindUniqueByPattern Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..FindUniqueByPattern Method
Container Class See Also Send Feedback
Find all unique instances of the given Regex Pattern, returning the list of the unique strings found

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<string> FindUniqueByPattern(
    string pattern,
    RegexOptions options
)
Visual Basic
Public Overridable Function FindUniqueByPattern (
    pattern As String,
    options As RegexOptions
) As List(Of String)
Visual C++
public:
virtual List<String^>^ FindUniqueByPattern(
    String^ pattern,
    RegexOptions options
)

Parameters

pattern
Type: System..::..String

[Missing <param name="pattern"/> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressions..::..RegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List <(Of <(<' String >)>)>

[Missing <returns> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Container Class
Container Members


Container.InsertEquation Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertEquation Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertEquation(
    string equation
)
Visual Basic
Public Overridable Function InsertEquation (
    equation As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertEquation(
    String^ equation
)

Parameters

equation
Type: System..::..String

[Missing <param name="equation"/> documentation for "M:Novacode.Container.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertEquation(System.String)"]

See Also

Container Class
Container Members


Container.InsertList Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertList Method
Container Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |

See Also

Container Class
Container Members


Container.InsertList Method (List)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertList Method (List)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertList(Novacode.List)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    List list
)
Visual Basic
Public Function InsertList (
    list As List
) As List
Visual C++
public:
List^ InsertList(
    List^ list
)

Parameters

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.Container.InsertList(Novacode.List)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.Container.InsertList(Novacode.List)"]

See Also

Container Class
Container Members
InsertList Overload


Container.InsertList Method (Int32, List)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertList Method (Int32, List)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    int index,
    List list
)
Visual Basic
Public Function InsertList (
    index As Integer,
    list As List
) As List
Visual C++
public:
List^ InsertList(
    int index,
    List^ list
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

See Also

Container Class
Container Members
InsertList Overload


Container.InsertParagraph Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method
Container Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraph()()()() |
Public method | InsertParagraph(String) |
Public method | InsertParagraph(Paragraph) |
Public method | InsertParagraph(Int32, Paragraph) |
Public method | InsertParagraph(String, Boolean) |
Public method | InsertParagraph(Int32, String, Boolean) |
Public method | InsertParagraph(String, Boolean, Formatting) |
Public method | InsertParagraph(Int32, String, Boolean, Formatting) |

See Also

Container Class
Container Members


Container.InsertParagraph Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph()
Visual Basic
Public Overridable Function InsertParagraph As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph()

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (String)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    string text
)
Visual Basic
Public Overridable Function InsertParagraph (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.String)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (Paragraph)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    Paragraph p
)
Visual Basic
Public Overridable Function InsertParagraph (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
)

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Container.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(Novacode.Paragraph)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (Int32, Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (Int32, Paragraph)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Visual Basic
Public Overridable Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (String, Boolean)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Visual Basic
Public Overridable Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (Int32, String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (Int32, String, Boolean)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Visual Basic
Public Overridable Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (String, Boolean, Formatting)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overridable Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (Int32, String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (Int32, String, Boolean, Formatting)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overridable Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertSection Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertSection Method
Container Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertSection()()()() |
Public method | InsertSection(Boolean) |

See Also

Container Class
Container Members


Container.InsertSection Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertSection Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertSection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertSection()
Visual Basic
Public Overridable Sub InsertSection
Visual C++
public:
virtual void InsertSection()

See Also

Container Class
Container Members
InsertSection Overload


Container.InsertSection Method (Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertSection Method (Boolean)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertSection(System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertSection(
    bool trackChanges
)
Visual Basic
Public Overridable Sub InsertSection (
    trackChanges As Boolean
)
Visual C++
public:
virtual void InsertSection(
    bool trackChanges
)

Parameters

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertSection(System.Boolean)"]

See Also

Container Class
Container Members
InsertSection Overload


Container.InsertSectionPageBreak Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertSectionPageBreak Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertSectionPageBreak(System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertSectionPageBreak(
    bool trackChanges = false
)
Visual Basic
Public Overridable Sub InsertSectionPageBreak (
    Optional trackChanges As Boolean = false
)
Visual C++
public:
virtual void InsertSectionPageBreak(
    bool trackChanges = false
)

Parameters

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertSectionPageBreak(System.Boolean)"]

See Also

Container Class
Container Members


Container.InsertTable Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertTable Method
Container Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |

See Also

Container Class
Container Members


Container.InsertTable Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertTable Method (Table)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    Table t
)
Visual Basic
Public Function InsertTable (
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    Table^ t
)

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Container.InsertTable(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(Novacode.Table)"]

See Also

Container Class
Container Members
InsertTable Overload


Container.InsertTable Method (Int32, Table)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertTable Method (Int32, Table)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    Table t
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    Table^ t
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

See Also

Container Class
Container Members
InsertTable Overload


Container.InsertTable Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertTable Method (Int32, Int32)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Table InsertTable(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overridable Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTable(
    int rowCount,
    int columnCount
)

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

See Also

Container Class
Container Members
InsertTable Overload


Container.InsertTable Method (Int32, Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertTable Method (Int32, Int32, Int32)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    int rowCount,
    int columnCount
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    int rowCount,
    int columnCount
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

See Also

Container Class
Container Members
InsertTable Overload


Container.ReplaceText Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..ReplaceText Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void ReplaceText(
    string oldValue,
    string newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions.None,
    Formatting newFormatting = null,
    Formatting matchFormatting = null,
    MatchFormattingOptions fo = MatchFormattingOptions.SubsetMatch
)
Visual Basic
Public Overridable Sub ReplaceText (
    oldValue As String,
    newValue As String,
    Optional trackChanges As Boolean = false,
    Optional options As RegexOptions = RegexOptions.None,
    Optional newFormatting As Formatting = Nothing,
    Optional matchFormatting As Formatting = Nothing,
    Optional fo As MatchFormattingOptions = MatchFormattingOptions.SubsetMatch
)
Visual C++
public:
virtual void ReplaceText(
    String^ oldValue,
    String^ newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions::None,
    Formatting^ newFormatting = nullptr,
    Formatting^ matchFormatting = nullptr,
    MatchFormattingOptions fo = MatchFormattingOptions::SubsetMatch
)

Parameters

oldValue
Type: System..::..String

[Missing <param name="oldValue"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newValue
Type: System..::..String

[Missing <param name="newValue"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

options (Optional)
Type: System.Text.RegularExpressions..::..RegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newFormatting (Optional)
Type: Novacode..::..Formatting

[Missing <param name="newFormatting"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

matchFormatting (Optional)
Type: Novacode..::..Formatting

[Missing <param name="matchFormatting"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

fo (Optional)
Type: Novacode..::..MatchFormattingOptions

[Missing <param name="fo"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

See Also

Container Class
Container Members


Container.SetDirection Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..SetDirection Method
Container Class Example See Also Send Feedback
Sets the Direction of content.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void SetDirection(
    Direction direction
)
Visual Basic
Public Overridable Sub SetDirection (
    direction As Direction
)
Visual C++
public:
virtual void SetDirection(
    Direction direction
)

Parameters

direction
Type: Novacode..::..Direction
Direction either LeftToRight or RightToLeft

Examples

Set the Direction of content in a Paragraph to RightToLeft.
Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"Test.docx"))
{
   // Get the first Paragraph from this document.
   Paragraph p = document.InsertParagraph();

   // Set the Direction of this Paragraph.
   p.Direction = Direction.RightToLeft;

   // Make sure the document contains at lest one Table.
   if (document.Tables.Count() > 0)
   {
       // Get the first Table from this document.
       Table t = document.Tables[0];

       /*
        * Set the direction of the entire Table.
        * Note: The same function is available at the Row and Cell level.
        */
       t.SetDirection(Direction.RightToLeft);
   }

   // Save all changes to this document.
   document.Save();
}// Release this document from memory.

See Also

Container Class
Container Members


Container Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Container Properties
Container Class See Also Send Feedback

The Container type exposes the following members.

Properties

 | Name | Description
Public property | Hyperlinks |
Public property | Lists |
Public property | Paragraphs |
Public property | Pictures |
Public property | Sections |
Public property | Tables |
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Container Class


Container.Hyperlinks Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Hyperlinks Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Hyperlinks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Hyperlink> Hyperlinks { get; }
Visual Basic
Public Overridable ReadOnly Property Hyperlinks As List(Of Hyperlink)
    Get
Visual C++
public:
virtual property List<Hyperlink^>^ Hyperlinks {
    List<Hyperlink^>^ get ();
}

Property Value

Type: List <(Of <(<' Hyperlink >)>)>

See Also

Container Class
Container Members


Container.Lists Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Lists Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Lists"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<List> Lists { get; }
Visual Basic
Public Overridable ReadOnly Property Lists As List(Of List)
    Get
Visual C++
public:
virtual property List<List^>^ Lists {
    List<List^>^ get ();
}

Property Value

Type: List <(Of <(<' List >)>)>

See Also

Container Class
Container Members


Container.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Paragraphs Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Paragraph> Paragraphs { get; }
Visual Basic
Public Overridable ReadOnly Property Paragraphs As List(Of Paragraph)
    Get
Visual C++
public:
virtual property List<Paragraph^>^ Paragraphs {
    List<Paragraph^>^ get ();
}

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

Container Class
Container Members


Container.Pictures Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Pictures Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Pictures"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Picture> Pictures { get; }
Visual Basic
Public Overridable ReadOnly Property Pictures As List(Of Picture)
    Get
Visual C++
public:
virtual property List<Picture^>^ Pictures {
    List<Picture^>^ get ();
}

Property Value

Type: List <(Of <(<' Picture >)>)>

See Also

Container Class
Container Members


Container.Sections Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Sections Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Sections"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Section> Sections { get; }
Visual Basic
Public Overridable ReadOnly Property Sections As List(Of Section)
    Get
Visual C++
public:
virtual property List<Section^>^ Sections {
    List<Section^>^ get ();
}

Property Value

Type: List <(Of <(<' Section >)>)>

See Also

Container Class
Container Members


Container.Tables Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Tables Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Table> Tables { get; }
Visual Basic
Public Overridable ReadOnly Property Tables As List(Of Table)
    Get
Visual C++
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get ();
}

Property Value

Type: List <(Of <(<' Table >)>)>

See Also

Container Class
Container Members


ContainerType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
ContainerType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.ContainerType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum ContainerType
Visual Basic
Public Enumeration ContainerType
Visual C++
public enum class ContainerType

Members

Member name | Value | Description
None | 0 |
TOC | 1 |
Section | 2 |
Cell | 3 |
Table | 4 |
Header | 5 |
Footer | 6 |
Paragraph | 7 |
Body | 8 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


CustomProperty Class

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.CustomProperty"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class CustomProperty
Visual Basic
Public Class CustomProperty
Visual C++
public ref class CustomProperty

Inheritance Hierarchy

System..::..Object
Novacode..::..CustomProperty

See Also

CustomProperty Members


CustomProperty Members

[image] [image]

DocX - A Sandcastle Documented Class Library
CustomProperty Members
CustomProperty Class Constructors Methods Properties See Also Send Feedback

The CustomProperty type exposes the following members.

Constructors

 | Name | Description
Public method | CustomProperty(String, Boolean) | Create a new CustomProperty to hold a bool.
Public method | CustomProperty(String, DateTime) | Create a new CustomProperty to hold a DateTime.
Public method | CustomProperty(String, Double) | Create a new CustomProperty to hold a double.
Public method | CustomProperty(String, Int32) | Create a new CustomProperty to hold an int.
Public method | CustomProperty(String, String) | Create a new CustomProperty to hold a string.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | The name of this CustomProperty.
Public property | Value | The value of this CustomProperty.

See Also

CustomProperty Class


CustomProperty Constructor

[image] [image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor
CustomProperty Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomProperty(String, Boolean) | Create a new CustomProperty to hold a bool.
Public method | CustomProperty(String, DateTime) | Create a new CustomProperty to hold a DateTime.
Public method | CustomProperty(String, Double) | Create a new CustomProperty to hold a double.
Public method | CustomProperty(String, Int32) | Create a new CustomProperty to hold an int.
Public method | CustomProperty(String, String) | Create a new CustomProperty to hold a string.

See Also

CustomProperty Class
CustomProperty Members


CustomProperty Constructor (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor (String, Boolean)
CustomProperty Class See Also Send Feedback
Create a new CustomProperty to hold a bool.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CustomProperty(
    string name,
    bool value
)
Visual Basic
Public Sub New (
    name As String,
    value As Boolean
)
Visual C++
public:
CustomProperty(
    String^ name,
    bool value
)

Parameters

name
Type: System..::..String
The name of this CustomProperty.
value
Type: System..::..Boolean
The value of this CustomProperty.

See Also

CustomProperty Class
CustomProperty Members
CustomProperty Overload


CustomProperty Constructor (String, DateTime)

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor (String, DateTime)
CustomProperty Class See Also Send Feedback
Create a new CustomProperty to hold a DateTime.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CustomProperty(
    string name,
    DateTime value
)
Visual Basic
Public Sub New (
    name As String,
    value As DateTime
)
Visual C++
public:
CustomProperty(
    String^ name,
    DateTime value
)

Parameters

name
Type: System..::..String
The name of this CustomProperty.
value
Type: System..::..DateTime
The value of this CustomProperty.

See Also

CustomProperty Class
CustomProperty Members
CustomProperty Overload


CustomProperty Constructor (String, Double)

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor (String, Double)
CustomProperty Class See Also Send Feedback
Create a new CustomProperty to hold a double.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CustomProperty(
    string name,
    double value
)
Visual Basic
Public Sub New (
    name As String,
    value As Double
)
Visual C++
public:
CustomProperty(
    String^ name,
    double value
)

Parameters

name
Type: System..::..String
The name of this CustomProperty.
value
Type: System..::..Double
The value of this CustomProperty.

See Also

CustomProperty Class
CustomProperty Members
CustomProperty Overload


CustomProperty Constructor (String, Int32)

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor (String, Int32)
CustomProperty Class See Also Send Feedback
Create a new CustomProperty to hold an int.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CustomProperty(
    string name,
    int value
)
Visual Basic
Public Sub New (
    name As String,
    value As Integer
)
Visual C++
public:
CustomProperty(
    String^ name,
    int value
)

Parameters

name
Type: System..::..String
The name of this CustomProperty.
value
Type: System..::..Int32
The value of this CustomProperty.

See Also

CustomProperty Class
CustomProperty Members
CustomProperty Overload


CustomProperty Constructor (String, String)

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor (String, String)
CustomProperty Class See Also Send Feedback
Create a new CustomProperty to hold a string.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CustomProperty(
    string name,
    string value
)
Visual Basic
Public Sub New (
    name As String,
    value As String
)
Visual C++
public:
CustomProperty(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The name of this CustomProperty.
value
Type: System..::..String
The value of this CustomProperty.

See Also

CustomProperty Class
CustomProperty Members
CustomProperty Overload


CustomProperty Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
CustomProperty Methods
CustomProperty Class See Also Send Feedback

The CustomProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomProperty Class


CustomProperty Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
CustomProperty Properties
CustomProperty Class See Also Send Feedback

The CustomProperty type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of this CustomProperty.
Public property | Value | The value of this CustomProperty.

See Also

CustomProperty Class


CustomProperty.Name Property

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty..::..Name Property
CustomProperty Class See Also Send Feedback
The name of this CustomProperty.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String

See Also

CustomProperty Class
CustomProperty Members


CustomProperty.Value Property

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty..::..Value Property
CustomProperty Class See Also Send Feedback
The value of this CustomProperty.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Object Value { get; }
Visual Basic
Public ReadOnly Property Value As Object
    Get
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

Property Value

Type: Object

See Also

CustomProperty Class
CustomProperty Members


Direction Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Direction Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Direction"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Direction
Visual Basic
Public Enumeration Direction
Visual C++
public enum class Direction

Members

Member name | Value | Description
LeftToRight | 0 |
RightToLeft | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


DisplayBlanksAs Enumeration

[image]

DocX - A Sandcastle Documented Class Library
DisplayBlanksAs Enumeration
See Also Send Feedback
Specifies the possible ways to display blanks. 21.2.3.10 ST_DispBlanksAs (Display Blanks As)

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum DisplayBlanksAs
Visual Basic
Public Enumeration DisplayBlanksAs
Visual C++
public enum class DisplayBlanksAs

Members

Member name | Value | Description
Gap | 0 |
Span | 1 |
Zero | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


DocProperty Class

[image]

DocX - A Sandcastle Documented Class Library
DocProperty Class
Members See Also Send Feedback
Represents a field of type document property. This field displays the value stored in a custom property.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class DocProperty : DocXElement
Visual Basic
Public Class DocProperty
    Inherits DocXElement
Visual C++
public ref class DocProperty : public DocXElement

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..DocProperty

See Also

DocProperty Members


DocProperty Members

[image] [image]

DocX - A Sandcastle Documented Class Library
DocProperty Members
DocProperty Class Methods Properties See Also Send Feedback

The DocProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | The custom property to display.
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

DocProperty Class


DocProperty Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
DocProperty Methods
DocProperty Class See Also Send Feedback

The DocProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocProperty Class


DocProperty Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
DocProperty Properties
DocProperty Class See Also Send Feedback

The DocProperty type exposes the following members.

Properties

 | Name | Description
Public property | Name | The custom property to display.
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

DocProperty Class


DocProperty.Name Property

[image]

DocX - A Sandcastle Documented Class Library
DocProperty..::..Name Property
DocProperty Class See Also Send Feedback
The custom property to display.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String

See Also

DocProperty Class
DocProperty Members


DocX Class

[image]

DocX - A Sandcastle Documented Class Library
DocX Class
Members See Also Send Feedback
Represents a document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class DocX : Container, IDisposable
Visual Basic
Public Class DocX
    Inherits Container
    Implements IDisposable
Visual C++
public ref class DocX : public Container,
    IDisposable

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..DocX

See Also

DocX Members


DocX Members

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX Members
DocX Class Methods Fields Properties See Also Send Feedback

The DocX type exposes the following members.

Methods

 | Name | Description
Public method | AddCoreProperty | Add a core property to this document. If a core property already exists with the same name it will be replaced. Core property names are case insensitive.
Public method | AddCustomProperty | Add a custom property to this document. If a custom property already exists with the same name it will be replace. CustomProperty names are case insensitive.
Public method | AddFooters | Adds three new Footers to this document. One for the first page, one for odd pages and one for even pages.
Public method | AddHeaders | Adds three new Headers to this document. One for the first page, one for odd pages and one for even pages.
Public method | AddHyperlink | Adds a hyperlink to a document and creates a Paragraph which uses it.
Public method | AddImage(Stream) | Add an Image into this document from a Stream.
Public method | AddImage(String) | Add an Image into this document from a fully qualified or relative filename.
Public method | AddList | Create a new list with a list item.
Public method | AddListItem | Add a list item to an already existing list.
Public method | AddProtection | Add editing protection to this document.
Public method | AddTable |
Public method | ApplyTemplate(Stream) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Public method | ApplyTemplate(String) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Public method | ApplyTemplate(Stream, Boolean) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Public method | ApplyTemplate(String, Boolean) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Protected method | clonePackagePart |
Protected method | clonePackageRelationship |
 | Create(Stream) | Creates a document using a Stream.
 | Create(String) | Creates a document using a fully qualified or relative filename.
Public method | Dispose | Releases all resources used by this document.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMD5HashFromStream |
Public method | GetProtectionType | Returns the type of editing protection imposed on this document.
Public method | GetSections |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertChart | Insert a chart in document
Public method | InsertDocument | Insert the contents of another document at the end of this document.
Public method | InsertEquation | Create an equation and insert it in the new paragraph (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) | Insert list into the document.
Public method | InsertList(Int32, List) | Insert a list at an index location in the document.
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertParagraphs |
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | Insert a Table into this document. The Table's source can be a completely different document.
Public method | InsertTable(Int32, Table) | Insert a Table into this document. The Table's source can be a completely different document.
Public method | InsertTable(Int32, Int32) | Insert a new Table at the end of this document.
Public method | InsertTable(Int32, Int32, Int32) | Insert a new Table at the end of this document.
 | Load(Stream) | Loads a document into a DocX object using a Stream.
 | Load(String) | Loads a document into a DocX object using a fully qualified or relative filename.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveProtection | Remove editing protection from this document.
Public method | ReplaceText | (Inherited from Container.)
Public method | Save | Save this document back to the location it was loaded from.
Public method | SaveAs(Stream) | Save this document to a Stream.
Public method | SaveAs(String) | Save this document to a file.
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

Properties

 | Name | Description
Public property | CoreProperties | Returns the list of document core properties with corresponding values.
Public property | CustomProperties | Returns a list of custom properties in this document.
Public property | DifferentFirstPage | Should the Document use an independent Header and Footer for the first page?
Public property | DifferentOddAndEvenPages |
Public property | Footers | Returns a collection of Footers in this Document. A document typically contains three Footers. A default one (odd), one for the first page and one for even pages.
Public property | Headers | Returns a collection of Headers in this Document. A document typically contains three Headers. A default one (odd), one for the first page and one for even pages.
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images | Returns a list of Images in this document.
Public property | isProtected | Returns true if any editing restrictions are imposed on this document.
Public property | Lists | (Overrides Container..::..Lists.)
Public property | MarginBottom |
Public property | MarginLeft |
Public property | MarginRight |
Public property | MarginTop |
Public property | PageHeight |
Public property | PageLayout |
Public property | PageWidth |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Text | Get the Text of this document.
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

DocX Class


DocX Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX Fields
DocX Class See Also Send Feedback

The DocX type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

See Also

DocX Class


DocX Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX Methods
DocX Class See Also Send Feedback

The DocX type exposes the following members.

Methods

 | Name | Description
Public method | AddCoreProperty | Add a core property to this document. If a core property already exists with the same name it will be replaced. Core property names are case insensitive.
Public method | AddCustomProperty | Add a custom property to this document. If a custom property already exists with the same name it will be replace. CustomProperty names are case insensitive.
Public method | AddFooters | Adds three new Footers to this document. One for the first page, one for odd pages and one for even pages.
Public method | AddHeaders | Adds three new Headers to this document. One for the first page, one for odd pages and one for even pages.
Public method | AddHyperlink | Adds a hyperlink to a document and creates a Paragraph which uses it.
Public method | AddImage(Stream) | Add an Image into this document from a Stream.
Public method | AddImage(String) | Add an Image into this document from a fully qualified or relative filename.
Public method | AddList | Create a new list with a list item.
Public method | AddListItem | Add a list item to an already existing list.
Public method | AddProtection | Add editing protection to this document.
Public method | AddTable |
Public method | ApplyTemplate(Stream) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Public method | ApplyTemplate(String) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Public method | ApplyTemplate(Stream, Boolean) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Public method | ApplyTemplate(String, Boolean) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Protected method | clonePackagePart |
Protected method | clonePackageRelationship |
 | Create(Stream) | Creates a document using a Stream.
 | Create(String) | Creates a document using a fully qualified or relative filename.
Public method | Dispose | Releases all resources used by this document.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMD5HashFromStream |
Public method | GetProtectionType | Returns the type of editing protection imposed on this document.
Public method | GetSections |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertChart | Insert a chart in document
Public method | InsertDocument | Insert the contents of another document at the end of this document.
Public method | InsertEquation | Create an equation and insert it in the new paragraph (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) | Insert list into the document.
Public method | InsertList(Int32, List) | Insert a list at an index location in the document.
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertParagraphs |
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | Insert a Table into this document. The Table's source can be a completely different document.
Public method | InsertTable(Int32, Table) | Insert a Table into this document. The Table's source can be a completely different document.
Public method | InsertTable(Int32, Int32) | Insert a new Table at the end of this document.
Public method | InsertTable(Int32, Int32, Int32) | Insert a new Table at the end of this document.
 | Load(Stream) | Loads a document into a DocX object using a Stream.
 | Load(String) | Loads a document into a DocX object using a fully qualified or relative filename.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveProtection | Remove editing protection from this document.
Public method | ReplaceText | (Inherited from Container.)
Public method | Save | Save this document back to the location it was loaded from.
Public method | SaveAs(Stream) | Save this document to a Stream.
Public method | SaveAs(String) | Save this document to a file.
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocX Class


DocX.AddCoreProperty Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddCoreProperty Method
DocX Class Example See Also Send Feedback
Add a core property to this document. If a core property already exists with the same name it will be replaced. Core property names are case insensitive.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddCoreProperty(
    string propertyName,
    string propertyValue
)
Visual Basic
Public Sub AddCoreProperty (
    propertyName As String,
    propertyValue As String
)
Visual C++
public:
void AddCoreProperty(
    String^ propertyName,
    String^ propertyValue
)

Parameters

propertyName
Type: System..::..String
The property name.
propertyValue
Type: System..::..String
The property value.

Examples

Add a core properties of each type to a document.
Copy image Copy
// Load Example.docx
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // If this document does not contain a core property called 'forename', create one.
    if (!document.CoreProperties.ContainsKey("forename"))
    {
        // Create a new core property called 'forename' and set its value.
        document.AddCoreProperty("forename", "Cathal");
    }

    // Get this documents core property called 'forename'.
    string forenameValue = document.CoreProperties["forename"];

    // Print all of the information about this core property to Console.
    Console.WriteLine(string.Format("Name: '{0}', Value: '{1}'\nPress any key...", "forename", forenameValue));

    // Save all changes made to this document.
    document.Save();
} // Release this document from memory.

// Wait for the user to press a key before exiting.
Console.ReadKey();

See Also

DocX Class
DocX Members
Novacode Namespace
DocX..::..CoreProperties
Novacode..::..CustomProperty
DocX..::..CustomProperties


DocX.AddCustomProperty Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddCustomProperty Method
DocX Class Example See Also Send Feedback
Add a custom property to this document. If a custom property already exists with the same name it will be replace. CustomProperty names are case insensitive.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddCustomProperty(
    CustomProperty cp
)
Visual Basic
Public Sub AddCustomProperty (
    cp As CustomProperty
)
Visual C++
public:
void AddCustomProperty(
    CustomProperty^ cp
)

Parameters

cp
Type: Novacode..::..CustomProperty
The CustomProperty to add to this document.

Examples

Add a custom properties of each type to a document.
Copy image Copy
// Load Example.docx
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // A CustomProperty called forename which stores a string.
    CustomProperty forename;

    // If this document does not contain a custom property called 'forename', create one.
    if (!document.CustomProperties.ContainsKey("forename"))
    {
        // Create a new custom property called 'forename' and set its value.
        document.AddCustomProperty(new CustomProperty("forename", "Cathal"));
    }

    // Get this documents custom property called 'forename'.
    forename = document.CustomProperties["forename"];

    // Print all of the information about this CustomProperty to Console.
    Console.WriteLine(string.Format("Name: '{0}', Value: '{1}'\nPress any key...", forename.Name, forename.Value));

    // Save all changes made to this document.
    document.Save();
} // Release this document from memory.

// Wait for the user to press a key before exiting.
Console.ReadKey();

See Also

DocX Class
DocX Members
Novacode Namespace
Novacode..::..CustomProperty
DocX..::..CustomProperties


DocX.AddFooters Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddFooters Method
DocX Class Example See Also Send Feedback
Adds three new Footers to this document. One for the first page, one for odd pages and one for even pages.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddFooters()
Visual Basic
Public Sub AddFooters
Visual C++
public:
void AddFooters()

Examples

// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Add footer support to this document.
    document.AddFooters();

    // Get a collection of all footers in this document.
    Footers footers = document.Footers;

    // The footer used for the first page of this document.
    Footer first = footers.first;

    // The footer used for odd pages of this document.
    Footer odd = footers.odd;

    // The footer used for even pages of this document.
    Footer even = footers.even;

    // Force the document to use a different footer for first, odd and even pages.
    document.DifferentFirstPage = true;
    document.DifferentOddAndEvenPages = true;

    // Content can be added to the Footers in the same manor that it would be added to the main document.
    Paragraph p = first.InsertParagraph();
    p.Append("This is the first pages footer.");

    // Save all changes to this document.
    document.Save();
}// Release this document from memory.

See Also

DocX Class
DocX Members


DocX.AddHeaders Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddHeaders Method
DocX Class Example See Also Send Feedback
Adds three new Headers to this document. One for the first page, one for odd pages and one for even pages.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddHeaders()
Visual Basic
Public Sub AddHeaders
Visual C++
public:
void AddHeaders()

Examples

// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Add header support to this document.
    document.AddHeaders();

    // Get a collection of all headers in this document.
    Headers headers = document.Headers;

    // The header used for the first page of this document.
    Header first = headers.first;

    // The header used for odd pages of this document.
    Header odd = headers.odd;

    // The header used for even pages of this document.
    Header even = headers.even;

    // Force the document to use a different header for first, odd and even pages.
    document.DifferentFirstPage = true;
    document.DifferentOddAndEvenPages = true;

    // Content can be added to the Headers in the same manor that it would be added to the main document.
    Paragraph p = first.InsertParagraph();
    p.Append("This is the first pages header.");

    // Save all changes to this document.
    document.Save();
}// Release this document from memory.

See Also

DocX Class
DocX Members


DocX.AddHyperlink Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddHyperlink Method
DocX Class Example See Also Send Feedback
Adds a hyperlink to a document and creates a Paragraph which uses it.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Hyperlink AddHyperlink(
    string text,
    Uri uri
)
Visual Basic
Public Function AddHyperlink (
    text As String,
    uri As Uri
) As Hyperlink
Visual C++
public:
Hyperlink^ AddHyperlink(
    String^ text,
    Uri^ uri
)

Parameters

text
Type: System..::..String
The text as displayed by the hyperlink.
uri
Type: System..::..Uri
The hyperlink itself.

Return Value

Type: Hyperlink
Returns a hyperlink that can be inserted into a Paragraph.

Examples

Adds a hyperlink to a document and creates a Paragraph which uses it.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
   // Add a hyperlink to this document.
   Hyperlink h = document.AddHyperlink("Google", new Uri("http://www.google.com"));

   // Add a new Paragraph to this document.
   Paragraph p = document.InsertParagraph();
   p.Append("My favourite search engine is ");
   p.AppendHyperlink(h);
   p.Append(", I think it's great.");

   // Save all changes made to this document.
   document.Save();
}

See Also

DocX Class
DocX Members


DocX.AddImage Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddImage Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddImage(Stream) | Add an Image into this document from a Stream.
Public method | AddImage(String) | Add an Image into this document from a fully qualified or relative filename.

See Also

DocX Class
DocX Members


DocX.AddImage Method (Stream)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddImage Method (Stream)
DocX Class Example See Also Send Feedback
Add an Image into this document from a Stream.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Image AddImage(
    Stream stream
)
Visual Basic
Public Function AddImage (
    stream As Stream
) As Image
Visual C++
public:
Image^ AddImage(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
A Stream stream.

Return Value

Type: Image
An Image file.

Examples

Add an Image into a document using a Stream.
Copy image Copy
// Open a FileStream fs to an Image.
using (FileStream fs = new FileStream(@"C:\Example\Image.jpg", FileMode.Open))
{
    // Load a document.
    using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
    {
        // Add an Image from a filestream fs.
        document.AddImage(fs);

        // Save all changes made to this document.
        document.Save();
    }// Release this document from memory.
}

See Also

DocX Class
DocX Members
AddImage Overload
Novacode Namespace
DocX..::..AddImage(String)
Paragraph..::..InsertPicture(Picture, Int32)


DocX.AddImage Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddImage Method (String)
DocX Class Example See Also Send Feedback
Add an Image into this document from a fully qualified or relative filename.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Image AddImage(
    string filename
)
Visual Basic
Public Function AddImage (
    filename As String
) As Image
Visual C++
public:
Image^ AddImage(
    String^ filename
)

Parameters

filename
Type: System..::..String
The fully qualified or relative filename.

Return Value

Type: Image
An Image file.

Examples

Add an Image into this document from a fully qualified filename.
Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Add an Image from a file.
    document.AddImage(@"C:\Example\Image.png");

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

DocX Class
DocX Members
AddImage Overload
Novacode Namespace
DocX..::..AddImage(Stream)
Paragraph..::..InsertPicture(Picture, Int32)


DocX.AddList Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddList Method
DocX Class See Also Send Feedback
Create a new list with a list item.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List AddList(
    string listText = null,
    int level = 0,
    ListItemType listType = ListItemType.Numbered,
    Nullable<int> startNumber = null,
    bool trackChanges = false
)
Visual Basic
Public Function AddList (
    Optional listText As String = Nothing,
    Optional level As Integer = 0,
    Optional listType As ListItemType = ListItemType.Numbered,
    Optional startNumber As Nullable(Of Integer) = Nothing,
    Optional trackChanges As Boolean = false
) As List
Visual C++
public:
List^ AddList(
    String^ listText = nullptr,
    int level = 0,
    ListItemType listType = ListItemType::Numbered,
    Nullable<int> startNumber = nullptr,
    bool trackChanges = false
)

Parameters

listText (Optional)
Type: System..::..String
The text of the first element in the created list.
level (Optional)
Type: System..::..Int32
The indentation level of the element in the list.
listType (Optional)
Type: Novacode..::..ListItemType
The type of list to be created: Bulleted or Numbered.
startNumber (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
The number start number for the list.
trackChanges (Optional)
Type: System..::..Boolean
Enable change tracking

Return Value

Type: List
The created List. Call AddListItem(...) to add more elements to the list. Write the list to the Document with InsertList(...) once the list has all the desired elements, otherwise the list will not be included in the working Document.

See Also

DocX Class
DocX Members


DocX.AddListItem Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddListItem Method
DocX Class See Also Send Feedback
Add a list item to an already existing list.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List AddListItem(
    List list,
    string listText,
    int level = 0,
    ListItemType listType = ListItemType.Numbered,
    Nullable<int> startNumber = null,
    bool trackChanges = false
)
Visual Basic
Public Function AddListItem (
    list As List,
    listText As String,
    Optional level As Integer = 0,
    Optional listType As ListItemType = ListItemType.Numbered,
    Optional startNumber As Nullable(Of Integer) = Nothing,
    Optional trackChanges As Boolean = false
) As List
Visual C++
public:
List^ AddListItem(
    List^ list,
    String^ listText,
    int level = 0,
    ListItemType listType = ListItemType::Numbered,
    Nullable<int> startNumber = nullptr,
    bool trackChanges = false
)

Parameters

list
Type: Novacode..::..List
The list to add the new list item to.
listText
Type: System..::..String
The run text that should be in the new list item.
level (Optional)
Type: System..::..Int32
The indentation level of the new list element.
listType (Optional)
Type: Novacode..::..ListItemType
Numbered or Bulleted list type.
startNumber (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
The number start number for the list.
trackChanges (Optional)
Type: System..::..Boolean
Enable change tracking

Return Value

Type: List
The created List. Call AddListItem(...) to add more elements to the list. Write the list to the Document with InsertList(...) once the list has all the desired elements, otherwise the list will not be included in the working Document.

See Also

DocX Class
DocX Members


DocX.AddProtection Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddProtection Method
DocX Class Example See Also Send Feedback
Add editing protection to this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddProtection(
    EditRestrictions er
)
Visual Basic
Public Sub AddProtection (
    er As EditRestrictions
)
Visual C++
public:
void AddProtection(
    EditRestrictions er
)

Parameters

er
Type: Novacode..::..EditRestrictions
The type of protection to add to this document.

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Allow no editing, only the adding of comment.
    document.AddProtection(EditRestrictions.comments);

    // Save the document.
    document.Save();
}

See Also

DocX Class
DocX Members
Novacode Namespace
DocX..::..RemoveProtection()()()()
DocX..::..GetProtectionType()()()()
DocX..::..isProtected


DocX.AddTable Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddTable Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table AddTable(
    int rowCount,
    int columnCount
)
Visual Basic
Public Function AddTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ AddTable(
    int rowCount,
    int columnCount
)

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

See Also

DocX Class
DocX Members


DocX.ApplyTemplate Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..ApplyTemplate Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyTemplate(Stream) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Public method | ApplyTemplate(String) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Public method | ApplyTemplate(Stream, Boolean) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.
Public method | ApplyTemplate(String, Boolean) | Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.

See Also

DocX Class
DocX Members


DocX.ApplyTemplate Method (Stream)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..ApplyTemplate Method (Stream)
DocX Class See Also Send Feedback
Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void ApplyTemplate(
    Stream templateStream
)
Visual Basic
Public Sub ApplyTemplate (
    templateStream As Stream
)
Visual C++
public:
void ApplyTemplate(
    Stream^ templateStream
)

Parameters

templateStream
Type: System.IO..::..Stream
The stream of the document template file.

See Also

DocX Class
DocX Members
ApplyTemplate Overload


DocX.ApplyTemplate Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..ApplyTemplate Method (String)
DocX Class See Also Send Feedback
Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void ApplyTemplate(
    string templateFilePath
)
Visual Basic
Public Sub ApplyTemplate (
    templateFilePath As String
)
Visual C++
public:
void ApplyTemplate(
    String^ templateFilePath
)

Parameters

templateFilePath
Type: System..::..String
The path to the document template file.

Exceptions

Exception | Condition
System.IO..::..FileNotFoundException | The document template file not found.

See Also

DocX Class
DocX Members
ApplyTemplate Overload


DocX.ApplyTemplate Method (Stream, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..ApplyTemplate Method (Stream, Boolean)
DocX Class See Also Send Feedback
Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void ApplyTemplate(
    Stream templateStream,
    bool includeContent
)
Visual Basic
Public Sub ApplyTemplate (
    templateStream As Stream,
    includeContent As Boolean
)
Visual C++
public:
void ApplyTemplate(
    Stream^ templateStream,
    bool includeContent
)

Parameters

templateStream
Type: System.IO..::..Stream
The stream of the document template file.
includeContent
Type: System..::..Boolean
Whether to copy the document template text content to document.

See Also

DocX Class
DocX Members
ApplyTemplate Overload


DocX.ApplyTemplate Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..ApplyTemplate Method (String, Boolean)
DocX Class See Also Send Feedback
Applies document template to the document. Document template may include styles, headers, footers, properties, etc. as well as text content.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void ApplyTemplate(
    string templateFilePath,
    bool includeContent
)
Visual Basic
Public Sub ApplyTemplate (
    templateFilePath As String,
    includeContent As Boolean
)
Visual C++
public:
void ApplyTemplate(
    String^ templateFilePath,
    bool includeContent
)

Parameters

templateFilePath
Type: System..::..String
The path to the document template file.
includeContent
Type: System..::..Boolean
Whether to copy the document template text content to document.

Exceptions

Exception | Condition
System.IO..::..FileNotFoundException | The document template file not found.

See Also

DocX Class
DocX Members
ApplyTemplate Overload


DocX.clonePackagePart Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..clonePackagePart Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.clonePackagePart(System.IO.Packaging.PackagePart)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected PackagePart clonePackagePart(
    PackagePart pp
)
Visual Basic
Protected Function clonePackagePart (
    pp As PackagePart
) As PackagePart
Visual C++
protected:
PackagePart^ clonePackagePart(
    PackagePart^ pp
)

Parameters

pp
Type: System.IO.Packaging..::..PackagePart

[Missing <param name="pp"/> documentation for "M:Novacode.DocX.clonePackagePart(System.IO.Packaging.PackagePart)"]

Return Value

Type: PackagePart

[Missing <returns> documentation for "M:Novacode.DocX.clonePackagePart(System.IO.Packaging.PackagePart)"]

See Also

DocX Class
DocX Members


DocX.clonePackageRelationship Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..clonePackageRelationship Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected void clonePackageRelationship(
    DocX remote_document,
    PackagePart pp,
    XDocument remote_mainDoc
)
Visual Basic
Protected Sub clonePackageRelationship (
    remote_document As DocX,
    pp As PackagePart,
    remote_mainDoc As XDocument
)
Visual C++
protected:
void clonePackageRelationship(
    DocX^ remote_document,
    PackagePart^ pp,
    XDocument^ remote_mainDoc
)

Parameters

remote_document
Type: Novacode..::..DocX

[Missing <param name="remote_document"/> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

pp
Type: System.IO.Packaging..::..PackagePart

[Missing <param name="pp"/> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

remote_mainDoc
Type: System.Xml.Linq..::..XDocument

[Missing <param name="remote_mainDoc"/> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

See Also

DocX Class
DocX Members


DocX.Create Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..Create Method
DocX Class See Also Send Feedback

Overload List

Name | Description
Create(Stream) | Creates a document using a Stream.
Create(String) | Creates a document using a fully qualified or relative filename.

See Also

DocX Class
DocX Members


DocX.Create Method (Stream)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Create Method (Stream)
DocX Class Example See Also Send Feedback
Creates a document using a Stream.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public static DocX Create(
    Stream stream
)
Visual Basic
Public Shared Function Create (
    stream As Stream
) As DocX
Visual C++
public:
static DocX^ Create(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The Stream to create the document from.

Return Value

Type: DocX
Returns a DocX object which represents the document.

Examples

Creating a document from a FileStream.
Copy image Copy
// Use a FileStream fs to create a new document.
using(FileStream fs = new FileStream(@"C:\Example\Test.docx", FileMode.Create))
{
    // Load the document using fs
    using (DocX document = DocX.Create(fs))
    {
        // Do something with the document here.

        // Save all changes made to this document.
        document.Save();
    }// Release this document from memory.
}

Examples

Creating a document in a SharePoint site.
Copy image Copy
using(SPSite mySite = new SPSite("http://server/sites/site"))
{
    // Open a connection to the SharePoint site
    using(SPWeb myWeb = mySite.OpenWeb())
    {
        // Create a MemoryStream ms.
        using (MemoryStream ms = new MemoryStream())
        {
            // Create a document using ms.
            using (DocX document = DocX.Create(ms))
            {
                // Do something with the document here.

                // Save all changes made to this document.
                document.Save();
            }// Release this document from memory

            // Add the document to the SharePoint site
            web.Files.Add("filename", ms.ToArray(), true);
        }
    }
}

See Also

DocX Class
DocX Members
Create Overload
Novacode Namespace
DocX..::..Create(String)
DocX..::..Load(Stream)
DocX..::..Load(String)
DocX..::..Save()()()()


DocX.Create Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Create Method (String)
DocX Class Example See Also Send Feedback
Creates a document using a fully qualified or relative filename.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public static DocX Create(
    string filename
)
Visual Basic
Public Shared Function Create (
    filename As String
) As DocX
Visual C++
public:
static DocX^ Create(
    String^ filename
)

Parameters

filename
Type: System..::..String
The fully qualified or relative filename.

Return Value

Type: DocX
Returns a DocX object which represents the document.

Examples

Copy image Copy
// Create a document using a relative filename.
using (DocX document = DocX.Create(@"..\Test.docx"))
{
    // Do something with the document here.

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory
Copy image Copy
// Create a document using a relative filename.
using (DocX document = DocX.Create(@"..\Test.docx"))
{
    // Do something with the document here.

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory

See Also

DocX Class
DocX Members
Create Overload
Novacode Namespace
DocX..::..Create(Stream)
DocX..::..Load(Stream)
DocX..::..Load(String)
DocX..::..Save()()()()


DocX.Dispose Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Dispose Method
DocX Class Example See Also Send Feedback
Releases all resources used by this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

Examples

If you take advantage of the using keyword, Dispose() is automatically called for you.
Copy image Copy
// Load document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
     // The document is only in memory while in this scope.

}// Dispose() is automatically called at this point.

Examples

This example is equilivant to the one above example.
Copy image Copy
// Load document.
DocX document = DocX.Load(@"C:\Example\Test.docx");

// Do something with the document here.

// Dispose of the document.
document.Dispose();

See Also

DocX Class
DocX Members


DocX.GetMD5HashFromStream Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..GetMD5HashFromStream Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.GetMD5HashFromStream(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected string GetMD5HashFromStream(
    Stream stream
)
Visual Basic
Protected Function GetMD5HashFromStream (
    stream As Stream
) As String
Visual C++
protected:
String^ GetMD5HashFromStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.GetMD5HashFromStream(System.IO.Stream)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Novacode.DocX.GetMD5HashFromStream(System.IO.Stream)"]

See Also

DocX Class
DocX Members


DocX.GetProtectionType Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..GetProtectionType Method
DocX Class Example See Also Send Feedback
Returns the type of editing protection imposed on this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public EditRestrictions GetProtectionType()
Visual Basic
Public Function GetProtectionType As EditRestrictions
Visual C++
public:
EditRestrictions GetProtectionType()

Return Value

Type: EditRestrictions
The type of editing protection imposed on this document.

Examples

Copy image Copy
Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Make sure the document is protected before checking the protection type.
    if (document.isProtected)
    {
        EditRestrictions protection = document.GetProtectionType();
        Console.WriteLine("Document is protected using " + protection.ToString());
    }

    else
        Console.WriteLine("Document is not protected.");

    // Save the document.
    document.Save();
}

See Also

DocX Class
DocX Members
Novacode Namespace
DocX..::..AddProtection(EditRestrictions)
DocX..::..RemoveProtection()()()()
DocX..::..isProtected


DocX.GetSections Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..GetSections Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.GetSections"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Section> GetSections()
Visual Basic
Public Function GetSections As List(Of Section)
Visual C++
public:
List<Section^>^ GetSections()

Return Value

Type: List <(Of <(<' Section >)>)>

[Missing <returns> documentation for "M:Novacode.DocX.GetSections"]

See Also

DocX Class
DocX Members


DocX.InsertChart Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertChart Method
DocX Class See Also Send Feedback
Insert a chart in document

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertChart(
    Chart chart
)
Visual Basic
Public Sub InsertChart (
    chart As Chart
)
Visual C++
public:
void InsertChart(
    Chart^ chart
)

Parameters

chart
Type: Novacode..::..Chart

[Missing <param name="chart"/> documentation for "M:Novacode.DocX.InsertChart(Novacode.Chart)"]

See Also

DocX Class
DocX Members


DocX.InsertDocument Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertDocument Method
DocX Class Example See Also Send Feedback
Insert the contents of another document at the end of this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertDocument(
    DocX remote_document
)
Visual Basic
Public Sub InsertDocument (
    remote_document As DocX
)
Visual C++
public:
void InsertDocument(
    DocX^ remote_document
)

Parameters

remote_document
Type: Novacode..::..DocX

[Missing <param name="remote_document"/> documentation for "M:Novacode.DocX.InsertDocument(Novacode.DocX)"]

Examples

Create a new document and insert an old document into it.
Copy image Copy
// Create a new document.
using (DocX newDocument = DocX.Create(@"NewDocument.docx"))
{
    // Load an old document.
    using (DocX oldDocument = DocX.Load(@"OldDocument.docx"))
    {
        // Insert the old document into the new document.
        newDocument.InsertDocument(oldDocument);

        // Save the new document.
        newDocument.Save();
    }// Release the old document from memory.
}// Release the new document from memory.

Remarks

If the document being inserted contains Images, CustomProperties and or custom styles, these will be correctly inserted into the new document. In the case of Images, new ID's are generated for the Images being inserted to avoid ID conflicts. CustomProperties with the same name will be ignored not replaced.

See Also

DocX Class
DocX Members


DocX.InsertEquation Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertEquation Method
DocX Class See Also Send Feedback
Create an equation and insert it in the new paragraph

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertEquation(
    string equation
)
Visual Basic
Public Overrides Function InsertEquation (
    equation As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertEquation(
    String^ equation
) override

Parameters

equation
Type: System..::..String

[Missing <param name="equation"/> documentation for "M:Novacode.DocX.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertEquation(System.String)"]

See Also

DocX Class
DocX Members


DocX.InsertList Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertList Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertList(List) | Insert list into the document.
Public method | InsertList(Int32, List) | Insert a list at an index location in the document.

See Also

DocX Class
DocX Members


DocX.InsertList Method (List)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertList Method (List)
DocX Class See Also Send Feedback
Insert list into the document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    List list
)
Visual Basic
Public Function InsertList (
    list As List
) As List
Visual C++
public:
List^ InsertList(
    List^ list
)

Parameters

list
Type: Novacode..::..List
The list to insert into the document.

Return Value

Type: List
The list that was inserted into the document.

See Also

DocX Class
DocX Members
InsertList Overload


DocX.InsertList Method (Int32, List)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertList Method (Int32, List)
DocX Class See Also Send Feedback
Insert a list at an index location in the document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    int index,
    List list
)
Visual Basic
Public Function InsertList (
    index As Integer,
    list As List
) As List
Visual C++
public:
List^ InsertList(
    int index,
    List^ list
)

Parameters

index
Type: System..::..Int32
Index in document to insert the list.
list
Type: Novacode..::..List
The list that was inserted into the document.

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.InsertList(System.Int32,Novacode.List)"]

See Also

DocX Class
DocX Members
InsertList Overload


DocX.InsertParagraph Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)

See Also

DocX Class
DocX Members


DocX.InsertParagraph Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph()
Visual Basic
Public Overrides Function InsertParagraph As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph() override

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (String)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text
) override

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.String)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (Paragraph)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
) override

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.DocX.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(Novacode.Paragraph)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (Int32, Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (Int32, Paragraph)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
) override

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (String, Boolean)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
) override

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (Int32, String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (Int32, String, Boolean)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
) override

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (String, Boolean, Formatting)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (Int32, String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (Int32, String, Boolean, Formatting)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraphs Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraphs Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraphs(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph[] InsertParagraphs(
    string text
)
Visual Basic
Public Function InsertParagraphs (
    text As String
) As Paragraph()
Visual C++
public:
array<Paragraph^>^ InsertParagraphs(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraphs(System.String)"]

Return Value

Type: array< Paragraph >[]()[][]

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraphs(System.String)"]

See Also

DocX Class
DocX Members


DocX.InsertTable Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertTable Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTable(Table) | Insert a Table into this document. The Table's source can be a completely different document.
Public method | InsertTable(Int32, Table) | Insert a Table into this document. The Table's source can be a completely different document.
Public method | InsertTable(Int32, Int32) | Insert a new Table at the end of this document.
Public method | InsertTable(Int32, Int32, Int32) | Insert a new Table at the end of this document.

See Also

DocX Class
DocX Members


DocX.InsertTable Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertTable Method (Table)
DocX Class Example See Also Send Feedback
Insert a Table into this document. The Table's source can be a completely different document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    Table t
)
Visual Basic
Public Function InsertTable (
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    Table^ t
)

Parameters

t
Type: Novacode..::..Table
The Table to insert.

Return Value

Type: Table
The Table now associated with this document.

Examples

Extract a Table from document a and insert it at the end of document b.
Copy image Copy
// Place holder for a Table.
Table t;

// Load document a.
using (DocX documentA = DocX.Load(@"C:\Example\a.docx"))
{
    // Get the first Table from this document.
    t = documentA.Tables[0];
}

// Load document b.
using (DocX documentB = DocX.Load(@"C:\Example\b.docx"))
{
    /*
     * Insert the Table that was extracted from document a, into document b.
     * This creates a new Table that is now associated with document b.
     */
    Table newTable = documentB.InsertTable(t);

    // Save all changes made to document b.
    documentB.Save();
}// Release this document from memory.

See Also

DocX Class
DocX Members
InsertTable Overload


DocX.InsertTable Method (Int32, Table)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertTable Method (Int32, Table)
DocX Class Example See Also Send Feedback
Insert a Table into this document. The Table's source can be a completely different document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    Table t
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    Table^ t
)

Parameters

index
Type: System..::..Int32
The index to insert this Table at.
t
Type: Novacode..::..Table
The Table to insert.

Return Value

Type: Table
The Table now associated with this document.

Examples

Extract a Table from document a and insert it into document b, at index 10.
Copy image Copy
// Place holder for a Table.
Table t;

// Load document a.
using (DocX documentA = DocX.Load(@"C:\Example\a.docx"))
{
    // Get the first Table from this document.
    t = documentA.Tables[0];
}

// Load document b.
using (DocX documentB = DocX.Load(@"C:\Example\b.docx"))
{
    /*
     * Insert the Table that was extracted from document a, into document b.
     * This creates a new Table that is now associated with document b.
     */
    Table newTable = documentB.InsertTable(10, t);

    // Save all changes made to document b.
    documentB.Save();
}// Release this document from memory.

See Also

DocX Class
DocX Members
InsertTable Overload


DocX.InsertTable Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertTable Method (Int32, Int32)
DocX Class Example See Also Send Feedback
Insert a new Table at the end of this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int rowCount,
    int columnCount
)
Visual Basic
Public Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ InsertTable(
    int rowCount,
    int columnCount
)

Parameters

rowCount
Type: System..::..Int32
The number of rows to create.
columnCount
Type: System..::..Int32
The number of columns to create.

Return Value

Type: Table
A new Table.

Examples

Insert a new Table with 2 columns and 3 rows, at the end of a document.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"C:\Example\Test.docx"))
{
    // Create a new Table with 2 columns and 3 rows.
    Table newTable = document.InsertTable(2, 3);

    // Set the design of this Table.
    newTable.Design = TableDesign.LightShadingAccent2;

    // Set the column names.
    newTable.Rows[0].Cells[0].Paragraph.InsertText("Ice Cream", false);
    newTable.Rows[0].Cells[1].Paragraph.InsertText("Price", false);

    // Fill row 1
    newTable.Rows[1].Cells[0].Paragraph.InsertText("Chocolate", false);
    newTable.Rows[1].Cells[1].Paragraph.InsertText("€3:50", false);

    // Fill row 2
    newTable.Rows[2].Cells[0].Paragraph.InsertText("Vanilla", false);
    newTable.Rows[2].Cells[1].Paragraph.InsertText("€3:00", false);

    // Save all changes made to document b.
    document.Save();
}// Release this document from memory.

See Also

DocX Class
DocX Members
InsertTable Overload


DocX.InsertTable Method (Int32, Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertTable Method (Int32, Int32, Int32)
DocX Class Example See Also Send Feedback
Insert a new Table at the end of this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    int rowCount,
    int columnCount
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    int rowCount,
    int columnCount
)

Parameters

index
Type: System..::..Int32
The index to insert this Table at.
rowCount
Type: System..::..Int32
The number of rows to create.
columnCount
Type: System..::..Int32
The number of columns to create.

Return Value

Type: Table
A new Table.

Examples

Insert a new Table with 2 columns and 3 rows, at index 37 in this document.
Copy image Copy
// Create a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Create a new Table with 3 rows and 2 columns. Insert this Table at index 37.
    Table newTable = document.InsertTable(37, 3, 2);

    // Set the design of this Table.
    newTable.Design = TableDesign.LightShadingAccent3;

    // Set the column names.
    newTable.Rows[0].Cells[0].Paragraph.InsertText("Ice Cream", false);
    newTable.Rows[0].Cells[1].Paragraph.InsertText("Price", false);

    // Fill row 1
    newTable.Rows[1].Cells[0].Paragraph.InsertText("Chocolate", false);
    newTable.Rows[1].Cells[1].Paragraph.InsertText("€3:50", false);

    // Fill row 2
    newTable.Rows[2].Cells[0].Paragraph.InsertText("Vanilla", false);
    newTable.Rows[2].Cells[1].Paragraph.InsertText("€3:00", false);

    // Save all changes made to document b.
    document.Save();
}// Release this document from memory.

See Also

DocX Class
DocX Members
InsertTable Overload


DocX.Load Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..Load Method
DocX Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads a document into a DocX object using a Stream.
Load(String) | Loads a document into a DocX object using a fully qualified or relative filename.

See Also

DocX Class
DocX Members


DocX.Load Method (Stream)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Load Method (Stream)
DocX Class Example See Also Send Feedback
Loads a document into a DocX object using a Stream.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public static DocX Load(
    Stream stream
)
Visual Basic
Public Shared Function Load (
    stream As Stream
) As DocX
Visual C++
public:
static DocX^ Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The Stream to load the document from.

Return Value

Type: DocX
Returns a DocX object which represents the document.

Examples

Loading a document from a FileStream.
Copy image Copy
// Open a FileStream fs to a document.
using (FileStream fs = new FileStream(@"C:\Example\Test.docx", FileMode.Open))
{
    // Load the document using fs.
    using (DocX document = DocX.Load(fs))
    {
        // Do something with the document here.

        // Save all changes made to the document.
        document.Save();
    }// Release this document from memory.
}

Examples

Loading a document from a SharePoint site.
Copy image Copy
// Get the SharePoint site that you want to access.
using (SPSite mySite = new SPSite("http://server/sites/site"))
{
    // Open a connection to the SharePoint site
    using (SPWeb myWeb = mySite.OpenWeb())
    {
        // Grab a document stored on this site.
        SPFile file = web.GetFile("Source_Folder_Name/Source_File");

        // DocX.Load requires a Stream, so open a Stream to this document.
        Stream str = new MemoryStream(file.OpenBinary());

        // Load the file using the Stream str.
        using (DocX document = DocX.Load(str))
        {
            // Do something with the document here.

            // Save all changes made to the document.
            document.Save();
        }// Release this document from memory.
    }
}

See Also

DocX Class
DocX Members
Load Overload
Novacode Namespace
DocX..::..Load(String)
DocX..::..Create(Stream)
DocX..::..Create(String)
DocX..::..Save()()()()


DocX.Load Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Load Method (String)
DocX Class Example See Also Send Feedback
Loads a document into a DocX object using a fully qualified or relative filename.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public static DocX Load(
    string filename
)
Visual Basic
Public Shared Function Load (
    filename As String
) As DocX
Visual C++
public:
static DocX^ Load(
    String^ filename
)

Parameters

filename
Type: System..::..String
The fully qualified or relative filename.

Return Value

Type: DocX
Returns a DocX object which represents the document.

Examples

Copy image Copy
// Load a document using its fully qualified filename
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Do something with the document here

    // Save all changes made to document.
    document.Save();
}// Release this document from memory.
Copy image Copy
// Load a document using its relative filename.
using(DocX document = DocX.Load(@"..\..\Test.docx"))
{
    // Do something with the document here.

    // Save all changes made to document.
    document.Save();
}// Release this document from memory.

See Also

DocX Class
DocX Members
Load Overload
Novacode Namespace
DocX..::..Load(Stream)
DocX..::..Create(Stream)
DocX..::..Create(String)
DocX..::..Save()()()()


DocX.RemoveProtection Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..RemoveProtection Method
DocX Class Example See Also Send Feedback
Remove editing protection from this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveProtection()
Visual Basic
Public Sub RemoveProtection
Visual C++
public:
void RemoveProtection()

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Remove any editing restrictions that are imposed on this document.
    document.RemoveProtection();

    // Save the document.
    document.Save();
}

See Also

DocX Class
DocX Members
Novacode Namespace
DocX..::..AddProtection(EditRestrictions)
DocX..::..GetProtectionType()()()()
DocX..::..isProtected


DocX.Save Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Save Method
DocX Class Example See Also Send Feedback
Save this document back to the location it was loaded from.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Save()
Visual Basic
Public Sub Save
Visual C++
public:
void Save()

Examples

Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Add an Image from a file.
    document.AddImage(@"C:\Example\Image.jpg");

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

DocX Class
DocX Members
Novacode Namespace
DocX..::..SaveAs(String)
DocX..::..Create(Stream)
DocX..::..Create(String)
DocX..::..Load(Stream)
DocX..::..Load(String)


DocX.SaveAs Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..SaveAs Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveAs(Stream) | Save this document to a Stream.
Public method | SaveAs(String) | Save this document to a file.

See Also

DocX Class
DocX Members


DocX.SaveAs Method (Stream)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..SaveAs Method (Stream)
DocX Class Example See Also Send Feedback
Save this document to a Stream.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SaveAs(
    Stream stream
)
Visual Basic
Public Sub SaveAs (
    stream As Stream
)
Visual C++
public:
void SaveAs(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The Stream to save this document to.

Examples

Load a document from a file and save it to a Stream.
Copy image Copy
// Place holder for a document.
DocX document;

using (FileStream fs1 = new FileStream(@"C:\Example\Test1.docx", FileMode.Open))
{
    // Load a document using a stream.
    document = DocX.Load(fs1);

    // Insert a new Paragraph
    document.InsertParagraph("Hello world again!", false);
}

using (FileStream fs2 = new FileStream(@"C:\Example\Test2.docx", FileMode.Create))
{
    // Save the document to a different stream.
    document.SaveAs(fs2);
}

// Release this document from memory.
document.Dispose();

Examples

Load a document from one Stream and save it to another.
Copy image Copy
DocX document;
using (FileStream fs1 = new FileStream(@"C:\Example\Test1.docx", FileMode.Open))
{
    // Load a document using a stream.
    document = DocX.Load(fs1);

    // Insert a new Paragraph
    document.InsertParagraph("Hello world again!", false);
}

using (FileStream fs2 = new FileStream(@"C:\Example\Test2.docx", FileMode.Create))
{
    // Save the document to a different stream.
    document.SaveAs(fs2);
}

See Also

DocX Class
DocX Members
SaveAs Overload
Novacode Namespace
DocX..::..Save()()()()
DocX..::..Create(Stream)
DocX..::..Create(String)
DocX..::..Load(Stream)
DocX..::..Load(String)


DocX.SaveAs Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..SaveAs Method (String)
DocX Class Example See Also Send Feedback
Save this document to a file.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SaveAs(
    string filename
)
Visual Basic
Public Sub SaveAs (
    filename As String
)
Visual C++
public:
void SaveAs(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename to save this document as.

Examples

Load a document from one file and save it to another.
Copy image Copy
// Load a document using its fully qualified filename.
DocX document = DocX.Load(@"C:\Example\Test1.docx");

// Insert a new Paragraph
document.InsertParagraph("Hello world!", false);

// Save the document to a new location.
document.SaveAs(@"C:\Example\Test2.docx");

Examples

Load a document from a Stream and save it to a file.
Copy image Copy
DocX document;
using (FileStream fs1 = new FileStream(@"C:\Example\Test1.docx", FileMode.Open))
{
    // Load a document using a stream.
    document = DocX.Load(fs1);

    // Insert a new Paragraph
    document.InsertParagraph("Hello world again!", false);
}

// Save the document to a new location.
document.SaveAs(@"C:\Example\Test2.docx");

See Also

DocX Class
DocX Members
SaveAs Overload
Novacode Namespace
DocX..::..Save()()()()
DocX..::..Create(Stream)
DocX..::..Create(String)
DocX..::..Load(Stream)
DocX..::..Load(String)


DocX Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX Properties
DocX Class See Also Send Feedback

The DocX type exposes the following members.

Properties

 | Name | Description
Public property | CoreProperties | Returns the list of document core properties with corresponding values.
Public property | CustomProperties | Returns a list of custom properties in this document.
Public property | DifferentFirstPage | Should the Document use an independent Header and Footer for the first page?
Public property | DifferentOddAndEvenPages |
Public property | Footers | Returns a collection of Footers in this Document. A document typically contains three Footers. A default one (odd), one for the first page and one for even pages.
Public property | Headers | Returns a collection of Headers in this Document. A document typically contains three Headers. A default one (odd), one for the first page and one for even pages.
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images | Returns a list of Images in this document.
Public property | isProtected | Returns true if any editing restrictions are imposed on this document.
Public property | Lists | (Overrides Container..::..Lists.)
Public property | MarginBottom |
Public property | MarginLeft |
Public property | MarginRight |
Public property | MarginTop |
Public property | PageHeight |
Public property | PageLayout |
Public property | PageWidth |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Text | Get the Text of this document.
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

DocX Class


DocX.CoreProperties Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..CoreProperties Property
DocX Class See Also Send Feedback
Returns the list of document core properties with corresponding values.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Dictionary<string, string> CoreProperties { get; }
Visual Basic
Public ReadOnly Property CoreProperties As Dictionary(Of String, String)
    Get
Visual C++
public:
property Dictionary<String^, String^>^ CoreProperties {
    Dictionary<String^, String^>^ get ();
}

Property Value

Type: Dictionary <(Of <(<' String, String >)>)>

See Also

DocX Class
DocX Members


DocX.CustomProperties Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..CustomProperties Property
DocX Class Example See Also Send Feedback
Returns a list of custom properties in this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Dictionary<string, CustomProperty> CustomProperties { get; }
Visual Basic
Public ReadOnly Property CustomProperties As Dictionary(Of String, CustomProperty)
    Get
Visual C++
public:
property Dictionary<String^, CustomProperty^>^ CustomProperties {
    Dictionary<String^, CustomProperty^>^ get ();
}

Property Value

Type: Dictionary <(Of <(<' String, CustomProperty >)>)>

Examples

Method 1: Get the name, type and value of each CustomProperty in this document.
Copy image Copy
// Load Example.docx
DocX document = DocX.Load(@"C:\Example\Test.docx");

/*
 * No two custom properties can have the same name,
 * so a Dictionary is the perfect data structure to store them in.
 * Each custom property can be accessed using its name.
 */
foreach (string name in document.CustomProperties.Keys)
{
    // Grab a custom property using its name.
    CustomProperty cp = document.CustomProperties[name];

    // Write this custom properties details to Console.
    Console.WriteLine(string.Format("Name: '{0}', Value: {1}", cp.Name, cp.Value));
}

Console.WriteLine("Press any key...");

// Wait for the user to press a key before closing the Console.
Console.ReadKey();

Examples

Method 2: Get the name, type and value of each CustomProperty in this document.
Copy image Copy
// Load Example.docx
DocX document = DocX.Load(@"C:\Example\Test.docx");

/*
 * No two custom properties can have the same name,
 * so a Dictionary is the perfect data structure to store them in.
 * The values of this Dictionary are CustomProperties.
 */
foreach (CustomProperty cp in document.CustomProperties.Values)
{
    // Write this custom properties details to Console.
    Console.WriteLine(string.Format("Name: '{0}', Value: {1}", cp.Name, cp.Value));
}

Console.WriteLine("Press any key...");

// Wait for the user to press a key before closing the Console.
Console.ReadKey();

See Also

DocX Class
DocX Members
Novacode Namespace
DocX..::..AddCustomProperty(CustomProperty)


DocX.DifferentFirstPage Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..DifferentFirstPage Property
DocX Class Example See Also Send Feedback
Should the Document use an independent Header and Footer for the first page?

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool DifferentFirstPage { get; set; }
Visual Basic
Public Property DifferentFirstPage As Boolean
    Get
    Set
Visual C++
public:
property bool DifferentFirstPage {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Examples

// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Add header support to this document.
    document.AddHeaders();

    // The header used for the first page of this document.
    Header first = document.Headers.first;

    // Force the document to use a different header for first page.
    document.DifferentFirstPage = true;

    // Content can be added to the Headers in the same manor that it would be added to the main document.
    Paragraph p = first.InsertParagraph();
    p.Append("This is the first pages header.");

    // Save all changes to this document.
    document.Save();
}// Release this document from memory.

See Also

DocX Class
DocX Members


DocX.DifferentOddAndEvenPages Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..DifferentOddAndEvenPages Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.DifferentOddAndEvenPages"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool DifferentOddAndEvenPages { get; set; }
Visual Basic
Public Property DifferentOddAndEvenPages As Boolean
    Get
    Set
Visual C++
public:
property bool DifferentOddAndEvenPages {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DocX Class
DocX Members


DocX.Footers Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Footers Property
DocX Class Example See Also Send Feedback
Returns a collection of Footers in this Document. A document typically contains three Footers. A default one (odd), one for the first page and one for even pages.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Footers Footers { get; }
Visual Basic
Public ReadOnly Property Footers As Footers
    Get
Visual C++
public:
property Footers^ Footers {
    Footers^ get ();
}

Property Value

Type: Footers

Examples

Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
   // Add footer support to this document.
   document.AddFooters();

   // Get a collection of all footers in this document.
   Footers footers = document.Footers;

   // The footer used for the first page of this document.
   Footer first = footers.first;

   // The footer used for odd pages of this document.
   Footer odd = footers.odd;

   // The footer used for even pages of this document.
   Footer even = footers.even;
}

See Also

DocX Class
DocX Members


DocX.Headers Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Headers Property
DocX Class Example See Also Send Feedback
Returns a collection of Headers in this Document. A document typically contains three Headers. A default one (odd), one for the first page and one for even pages.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Headers Headers { get; }
Visual Basic
Public ReadOnly Property Headers As Headers
    Get
Visual C++
public:
property Headers^ Headers {
    Headers^ get ();
}

Property Value

Type: Headers

Examples

Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
   // Add header support to this document.
   document.AddHeaders();

   // Get a collection of all headers in this document.
   Headers headers = document.Headers;

   // The header used for the first page of this document.
   Header first = headers.first;

   // The header used for odd pages of this document.
   Header odd = headers.odd;

   // The header used for even pages of this document.
   Header even = headers.even;
}

See Also

DocX Class
DocX Members


DocX.Images Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Images Property
DocX Class Example See Also Send Feedback
Returns a list of Images in this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Image> Images { get; }
Visual Basic
Public ReadOnly Property Images As List(Of Image)
    Get
Visual C++
public:
property List<Image^>^ Images {
    List<Image^>^ get ();
}

Property Value

Type: List <(Of <(<' Image >)>)>

Examples

Get the unique Id of every Image in this document.
Copy image Copy
// Load a document.
DocX document = DocX.Load(@"C:\Example\Test.docx");

// Loop through each Image in this document.
foreach (Novacode.Image i in document.Images)
{
    // Get the unique Id which identifies this Image.
    string uniqueId = i.Id;
}

See Also

DocX Class
DocX Members
Novacode Namespace
DocX..::..AddImage(String)
DocX..::..AddImage(Stream)
Paragraph..::..Pictures
Paragraph..::..InsertPicture(Picture, Int32)


DocX.isProtected Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..isProtected Property
DocX Class Example See Also Send Feedback
Returns true if any editing restrictions are imposed on this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool isProtected { get; }
Visual Basic
Public ReadOnly Property isProtected As Boolean
    Get
Visual C++
public:
property bool isProtected {
    bool get ();
}

Property Value

Type: Boolean

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    if(document.isProtected)
        Console.WriteLine("Protected");
    else
        Console.WriteLine("Not protected");

    // Save the document.
    document.Save();
}

See Also

DocX Class
DocX Members
Novacode Namespace
DocX..::..AddProtection(EditRestrictions)
DocX..::..RemoveProtection()()()()
DocX..::..GetProtectionType()()()()


DocX.Lists Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Lists Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.Lists"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<List> Lists { get; }
Visual Basic
Public Overrides ReadOnly Property Lists As List(Of List)
    Get
Visual C++
public:
virtual property List<List^>^ Lists {
    List<List^>^ get () override;
}

Property Value

Type: List <(Of <(<' List >)>)>

See Also

DocX Class
DocX Members


DocX.MarginBottom Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..MarginBottom Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.MarginBottom"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float MarginBottom { get; set; }
Visual Basic
Public Property MarginBottom As Single
    Get
    Set
Visual C++
public:
property float MarginBottom {
    float get ();
    void set (float value);
}

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.MarginLeft Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..MarginLeft Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.MarginLeft"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float MarginLeft { get; set; }
Visual Basic
Public Property MarginLeft As Single
    Get
    Set
Visual C++
public:
property float MarginLeft {
    float get ();
    void set (float value);
}

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.MarginRight Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..MarginRight Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.MarginRight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float MarginRight { get; set; }
Visual Basic
Public Property MarginRight As Single
    Get
    Set
Visual C++
public:
property float MarginRight {
    float get ();
    void set (float value);
}

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.MarginTop Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..MarginTop Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.MarginTop"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float MarginTop { get; set; }
Visual Basic
Public Property MarginTop As Single
    Get
    Set
Visual C++
public:
property float MarginTop {
    float get ();
    void set (float value);
}

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.PageHeight Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..PageHeight Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.PageHeight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float PageHeight { get; set; }
Visual Basic
Public Property PageHeight As Single
    Get
    Set
Visual C++
public:
property float PageHeight {
    float get ();
    void set (float value);
}

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.PageLayout Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..PageLayout Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.PageLayout"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public PageLayout PageLayout { get; }
Visual Basic
Public ReadOnly Property PageLayout As PageLayout
    Get
Visual C++
public:
property PageLayout^ PageLayout {
    PageLayout^ get ();
}

Property Value

Type: PageLayout

See Also

DocX Class
DocX Members


DocX.PageWidth Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..PageWidth Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.PageWidth"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float PageWidth { get; set; }
Visual Basic
Public Property PageWidth As Single
    Get
    Set
Visual C++
public:
property float PageWidth {
    float get ();
    void set (float value);
}

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Paragraphs Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Paragraph> Paragraphs { get; }
Visual Basic
Public Overrides ReadOnly Property Paragraphs As List(Of Paragraph)
    Get
Visual C++
public:
virtual property List<Paragraph^>^ Paragraphs {
    List<Paragraph^>^ get () override;
}

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

DocX Class
DocX Members


DocX.Tables Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Tables Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Table> Tables { get; }
Visual Basic
Public Overrides ReadOnly Property Tables As List(Of Table)
    Get
Visual C++
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get () override;
}

Property Value

Type: List <(Of <(<' Table >)>)>

See Also

DocX Class
DocX Members


DocX.Text Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Text Property
DocX Class Example See Also Send Feedback
Get the Text of this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

Property Value

Type: String

Examples

Write to Console the Text from this document.
Copy image Copy
// Load a document
DocX document = DocX.Load(@"C:\Example\Test.docx");

// Get the text of this document.
string text = document.Text;

// Write the text of this document to Console.
Console.Write(text);

// Wait for the user to press a key before closing the console window.
Console.ReadKey();

See Also

DocX Class
DocX Members


DocXElement Class

[image]

DocX - A Sandcastle Documented Class Library
DocXElement Class
Members See Also Send Feedback
All DocX types are derived from DocXElement. This class contains properties which every element of a DocX must contain.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public abstract class DocXElement
Visual Basic
Public MustInherit Class DocXElement
Visual C++
public ref class DocXElement abstract

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..DocProperty
Novacode..::..Hyperlink
Novacode..::..InsertBeforeOrAfter
Novacode..::..PageLayout
Novacode..::..Picture
Novacode..::..Run

See Also

DocXElement Members


DocXElement Members

[image] [image]

DocX - A Sandcastle Documented Class Library
DocXElement Members
DocXElement Class Constructors Methods Properties See Also Send Feedback

The DocXElement type exposes the following members.

Constructors

 | Name | Description
Public method | DocXElement | Store both the document and xml so that they can be accessed by derived types.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World!

See Also

DocXElement Class


DocXElement Constructor

[image]

DocX - A Sandcastle Documented Class Library
DocXElement Constructor
DocXElement Class See Also Send Feedback
Store both the document and xml so that they can be accessed by derived types.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public DocXElement(
    DocX document,
    XElement xml
)
Visual Basic
Public Sub New (
    document As DocX,
    xml As XElement
)
Visual C++
public:
DocXElement(
    DocX^ document,
    XElement^ xml
)

Parameters

document
Type: Novacode..::..DocX
The document that this element belongs to.
xml
Type: System.Xml.Linq..::..XElement
The Xml that gives this element substance

See Also

DocXElement Class
DocXElement Members


DocXElement Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
DocXElement Methods
DocXElement Class See Also Send Feedback

The DocXElement type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocXElement Class


DocXElement Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
DocXElement Properties
DocXElement Class See Also Send Feedback

The DocXElement type exposes the following members.

Properties

 | Name | Description
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World!

See Also

DocXElement Class


DocXElement.Xml Property

[image]

DocX - A Sandcastle Documented Class Library
DocXElement..::..Xml Property
DocXElement Class See Also Send Feedback
This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following

Hello World!

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public XElement Xml { get; set; }
Visual Basic
Public Property Xml As XElement
    Get
    Set
Visual C++
public:
property XElement^ Xml {
    XElement^ get ();
    void set (XElement^ value);
}

Property Value

Type: XElement

See Also

DocXElement Class
DocXElement Members


EditRestrictions Enumeration

[image]

DocX - A Sandcastle Documented Class Library
EditRestrictions Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.EditRestrictions"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum EditRestrictions
Visual Basic
Public Enumeration EditRestrictions
Visual C++
public enum class EditRestrictions

Members

Member name | Value | Description
none | 0 |
readOnly | 1 |
forms | 2 |
comments | 3 |
trackedChanges | 4 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


EquationShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
EquationShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.EquationShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum EquationShapes
Visual Basic
Public Enumeration EquationShapes
Visual C++
public enum class EquationShapes

Members

Member name | Value | Description
mathPlus | 0 |
mathMinus | 1 |
mathMultiply | 2 |
mathDivide | 3 |
mathEqual | 4 |
mathNotEqual | 5 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


FlowchartShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
FlowchartShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.FlowchartShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum FlowchartShapes
Visual Basic
Public Enumeration FlowchartShapes
Visual C++
public enum class FlowchartShapes

Members

Member name | Value | Description
flowChartProcess | 0 |
flowChartAlternateProcess | 1 |
flowChartDecision | 2 |
flowChartInputOutput | 3 |
flowChartPredefinedProcess | 4 |
flowChartInternalStorage | 5 |
flowChartDocument | 6 |
flowChartMultidocument | 7 |
flowChartTerminator | 8 |
flowChartPreparation | 9 |
flowChartManualInput | 10 |
flowChartManualOperation | 11 |
flowChartConnector | 12 |
flowChartOffpageConnector | 13 |
flowChartPunchedCard | 14 |
flowChartPunchedTape | 15 |
flowChartSummingJunction | 16 |
flowChartOr | 17 |
flowChartCollate | 18 |
flowChartSort | 19 |
flowChartExtract | 20 |
flowChartMerge | 21 |
flowChartOnlineStorage | 22 |
flowChartDelay | 23 |
flowChartMagneticTape | 24 |
flowChartMagneticDisk | 25 |
flowChartMagneticDrum | 26 |
flowChartDisplay | 27 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Footer Class

[image]

DocX - A Sandcastle Documented Class Library
Footer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Footer"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Footer : Container
Visual Basic
Public Class Footer
    Inherits Container
Visual C++
public ref class Footer : public Container

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Footer

See Also

Footer Members


Footer Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer Members
Footer Class Methods Fields Properties See Also Send Feedback

The Footer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation | (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Footer Class


Footer Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer Fields
Footer Class See Also Send Feedback

The Footer type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

See Also

Footer Class


Footer Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer Methods
Footer Class See Also Send Feedback

The Footer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation | (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Footer Class


Footer.InsertEquation Method

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertEquation Method
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertEquation(
    string equation
)
Visual Basic
Public Overrides Function InsertEquation (
    equation As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertEquation(
    String^ equation
) override

Parameters

equation
Type: System..::..String

[Missing <param name="equation"/> documentation for "M:Novacode.Footer.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertEquation(System.String)"]

See Also

Footer Class
Footer Members


Footer.InsertParagraph Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method
Footer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)

See Also

Footer Class
Footer Members


Footer.InsertParagraph Method

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph()
Visual Basic
Public Overrides Function InsertParagraph As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph() override

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (String)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text
) override

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.String)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (Paragraph)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
) override

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Footer.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(Novacode.Paragraph)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (Int32, Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (Int32, Paragraph)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
) override

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (String, Boolean)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
) override

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (Int32, String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (Int32, String, Boolean)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
) override

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (String, Boolean, Formatting)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (Int32, String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (Int32, String, Boolean, Formatting)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer Properties
Footer Class See Also Send Feedback

The Footer type exposes the following members.

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Footer Class


Footer.PageNumbers Property

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..PageNumbers Property
Footer Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Footer.PageNumbers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool PageNumbers { get; set; }
Visual Basic
Public Property PageNumbers As Boolean
    Get
    Set
Visual C++
public:
property bool PageNumbers {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Footer Class
Footer Members


Footer.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..Paragraphs Property
Footer Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Footer.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Paragraph> Paragraphs { get; }
Visual Basic
Public Overrides ReadOnly Property Paragraphs As List(Of Paragraph)
    Get
Visual C++
public:
virtual property List<Paragraph^>^ Paragraphs {
    List<Paragraph^>^ get () override;
}

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

Footer Class
Footer Members


Footer.Tables Property

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..Tables Property
Footer Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Footer.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Table> Tables { get; }
Visual Basic
Public Overrides ReadOnly Property Tables As List(Of Table)
    Get
Visual C++
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get () override;
}

Property Value

Type: List <(Of <(<' Table >)>)>

See Also

Footer Class
Footer Members


Footers Class

[image]

DocX - A Sandcastle Documented Class Library
Footers Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Footers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Footers
Visual Basic
Public Class Footers
Visual C++
public ref class Footers

Inheritance Hierarchy

System..::..Object
Novacode..::..Footers

See Also

Footers Members


Footers Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Footers Members
Footers Class Methods Fields See Also Send Feedback

The Footers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | even |
Public field | first |
Public field | odd |

See Also

Footers Class


Footers Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Footers Fields
Footers Class See Also Send Feedback

The Footers type exposes the following members.

Fields

 | Name | Description
Public field | even |
Public field | first |
Public field | odd |

See Also

Footers Class


Footers.even Field

[image]

DocX - A Sandcastle Documented Class Library
Footers..::..even Field
Footers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Footers.even"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Footer even
Visual Basic
Public even As Footer
Visual C++
public:
Footer^ even

Field Value

Type: Footer

See Also

Footers Class
Footers Members


Footers.first Field

[image]

DocX - A Sandcastle Documented Class Library
Footers..::..first Field
Footers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Footers.first"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Footer first
Visual Basic
Public first As Footer
Visual C++
public:
Footer^ first

Field Value

Type: Footer

See Also

Footers Class
Footers Members


Footers.odd Field

[image]

DocX - A Sandcastle Documented Class Library
Footers..::..odd Field
Footers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Footers.odd"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Footer odd
Visual Basic
Public odd As Footer
Visual C++
public:
Footer^ odd

Field Value

Type: Footer

See Also

Footers Class
Footers Members


Footers Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Footers Methods
Footers Class See Also Send Feedback

The Footers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Footers Class


FormattedText Class

[image]

DocX - A Sandcastle Documented Class Library
FormattedText Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.FormattedText"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class FormattedText : IComparable
Visual Basic
Public Class FormattedText
    Implements IComparable
Visual C++
public ref class FormattedText : IComparable

Inheritance Hierarchy

System..::..Object
Novacode..::..FormattedText

See Also

FormattedText Members


FormattedText Members

[image] [image]

DocX - A Sandcastle Documented Class Library
FormattedText Members
FormattedText Class Constructors Methods Fields See Also Send Feedback

The FormattedText type exposes the following members.

Constructors

 | Name | Description
Public method | FormattedText | Initializes a new instance of the FormattedText class

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | formatting |
Public field | index |
Public field | text |

See Also

FormattedText Class


FormattedText Constructor

[image]

DocX - A Sandcastle Documented Class Library
FormattedText Constructor
FormattedText Class See Also Send Feedback
Initializes a new instance of the FormattedText class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public FormattedText()
Visual Basic
Public Sub New
Visual C++
public:
FormattedText()

See Also

FormattedText Class
FormattedText Members


FormattedText Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
FormattedText Fields
FormattedText Class See Also Send Feedback

The FormattedText type exposes the following members.

Fields

 | Name | Description
Public field | formatting |
Public field | index |
Public field | text |

See Also

FormattedText Class


FormattedText.formatting Field

[image]

DocX - A Sandcastle Documented Class Library
FormattedText..::..formatting Field
FormattedText Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.FormattedText.formatting"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Formatting formatting
Visual Basic
Public formatting As Formatting
Visual C++
public:
Formatting^ formatting

Field Value

Type: Formatting

See Also

FormattedText Class
FormattedText Members


FormattedText.index Field

[image]

DocX - A Sandcastle Documented Class Library
FormattedText..::..index Field
FormattedText Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.FormattedText.index"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int index
Visual Basic
Public index As Integer
Visual C++
public:
int index

Field Value

Type: Int32

See Also

FormattedText Class
FormattedText Members


FormattedText.text Field

[image]

DocX - A Sandcastle Documented Class Library
FormattedText..::..text Field
FormattedText Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.FormattedText.text"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string text
Visual Basic
Public text As String
Visual C++
public:
String^ text

Field Value

Type: String

See Also

FormattedText Class
FormattedText Members


FormattedText Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
FormattedText Methods
FormattedText Class See Also Send Feedback

The FormattedText type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormattedText Class


FormattedText.CompareTo Method

[image]

DocX - A Sandcastle Documented Class Library
FormattedText..::..CompareTo Method
FormattedText Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.FormattedText.CompareTo(System.Object)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo (
    obj As Object
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Novacode.FormattedText.CompareTo(System.Object)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Novacode.FormattedText.CompareTo(System.Object)"]

Implements

IComparable..::..CompareTo(Object)

See Also

FormattedText Class
FormattedText Members


Formatting Class

[image]

DocX - A Sandcastle Documented Class Library
Formatting Class
Members See Also Send Feedback
A text formatting.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Formatting : IComparable
Visual Basic
Public Class Formatting
    Implements IComparable
Visual C++
public ref class Formatting : IComparable

Inheritance Hierarchy

System..::..Object
Novacode..::..Formatting

See Also

Formatting Members


Formatting Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Formatting Members
Formatting Class Constructors Methods Properties See Also Send Feedback

The Formatting type exposes the following members.

Constructors

 | Name | Description
Public method | Formatting | A text formatting.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bold | This formatting will apply Bold.
Public property | CapsStyle | Capitalization style.
Public property | FontColor | The colour of the text.
Public property | FontFamily | The font familt of this formatting.
Public property | Hidden | Is this text hidden or visible.
Public property | Highlight | Highlight colour.
Public property | Italic | This formatting will apply Italic.
Public property | Kerning | The Kerning to apply to this text must be one of the following values 8, 9, 10, 11, 12, 14, 16, 18, 20, 22, 24, 26, 28, 36, 48, 72.
Public property | Language | Text language
Public property | Misc | Misc settings.
Public property | PercentageScale | Percentage scale must be one of the following values 200, 150, 100, 90, 80, 66, 50 or 33.
Public property | Position | Text position must be in the range (-1585 - 1585).
Public property | Script | The script that this formatting should be, normal, superscript or subscript.
Public property | Size | The Size of this text, must be between 0 and 1638.
Public property | Spacing | Text spacing must be in the range (-1585 - 1585).
Public property | StrikeThrough | This formatting will apply StrickThrough.
Public property | UnderlineColor | The underline colour.
Public property | UnderlineStyle | The Underline style that this formatting applies.

See Also

Formatting Class


Formatting Constructor

[image]

DocX - A Sandcastle Documented Class Library
Formatting Constructor
Formatting Class See Also Send Feedback
A text formatting.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Formatting()
Visual Basic
Public Sub New
Visual C++
public:
Formatting()

See Also

Formatting Class
Formatting Members


Formatting Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Formatting Methods
Formatting Class See Also Send Feedback

The Formatting type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Formatting Class


Formatting.CompareTo Method

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..CompareTo Method
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Formatting.CompareTo(System.Object)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo (
    obj As Object
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Novacode.Formatting.CompareTo(System.Object)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Novacode.Formatting.CompareTo(System.Object)"]

Implements

IComparable..::..CompareTo(Object)

See Also

Formatting Class
Formatting Members


Formatting.Parse Method

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Parse Method
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Formatting.Parse(System.Xml.Linq.XElement)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public static Formatting Parse(
    XElement rPr
)
Visual Basic
Public Shared Function Parse (
    rPr As XElement
) As Formatting
Visual C++
public:
static Formatting^ Parse(
    XElement^ rPr
)

Parameters

rPr
Type: System.Xml.Linq..::..XElement

[Missing <param name="rPr"/> documentation for "M:Novacode.Formatting.Parse(System.Xml.Linq.XElement)"]

Return Value

Type: Formatting

[Missing <returns> documentation for "M:Novacode.Formatting.Parse(System.Xml.Linq.XElement)"]

See Also

Formatting Class
Formatting Members


Formatting Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Formatting Properties
Formatting Class See Also Send Feedback

The Formatting type exposes the following members.

Properties

 | Name | Description
Public property | Bold | This formatting will apply Bold.
Public property | CapsStyle | Capitalization style.
Public property | FontColor | The colour of the text.
Public property | FontFamily | The font familt of this formatting.
Public property | Hidden | Is this text hidden or visible.
Public property | Highlight | Highlight colour.
Public property | Italic | This formatting will apply Italic.
Public property | Kerning | The Kerning to apply to this text must be one of the following values 8, 9, 10, 11, 12, 14, 16, 18, 20, 22, 24, 26, 28, 36, 48, 72.
Public property | Language | Text language
Public property | Misc | Misc settings.
Public property | PercentageScale | Percentage scale must be one of the following values 200, 150, 100, 90, 80, 66, 50 or 33.
Public property | Position | Text position must be in the range (-1585 - 1585).
Public property | Script | The script that this formatting should be, normal, superscript or subscript.
Public property | Size | The Size of this text, must be between 0 and 1638.
Public property | Spacing | Text spacing must be in the range (-1585 - 1585).
Public property | StrikeThrough | This formatting will apply StrickThrough.
Public property | UnderlineColor | The underline colour.
Public property | UnderlineStyle | The Underline style that this formatting applies.

See Also

Formatting Class


Formatting.Bold Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Bold Property
Formatting Class See Also Send Feedback
This formatting will apply Bold.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool Bold { get; set; }
Visual Basic
Public Property Bold As Boolean
    Get
    Set
Visual C++
public:
property bool Bold {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Formatting Class
Formatting Members


Formatting.CapsStyle Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..CapsStyle Property
Formatting Class See Also Send Feedback
Capitalization style.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CapsStyle CapsStyle { get; set; }
Visual Basic
Public Property CapsStyle As CapsStyle
    Get
    Set
Visual C++
public:
property CapsStyle CapsStyle {
    CapsStyle get ();
    void set (CapsStyle value);
}

Property Value

Type: CapsStyle

See Also

Formatting Class
Formatting Members


Formatting.FontColor Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..FontColor Property
Formatting Class See Also Send Feedback
The colour of the text.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<Color> FontColor { get; set; }
Visual Basic
Public Property FontColor As Nullable(Of Color)
    Get
    Set
Visual C++
public:
property Nullable<Color> FontColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}

Property Value

Type: Nullable <(Of <(<' Color >)>)>

See Also

Formatting Class
Formatting Members


Formatting.FontFamily Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..FontFamily Property
Formatting Class See Also Send Feedback
The font familt of this formatting.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public FontFamily FontFamily { get; set; }
Visual Basic
Public Property FontFamily As FontFamily
    Get
    Set
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}

Property Value

Type: FontFamily

See Also

Formatting Class
Formatting Members


Formatting.Hidden Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Hidden Property
Formatting Class See Also Send Feedback
Is this text hidden or visible.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool Hidden { get; set; }
Visual Basic
Public Property Hidden As Boolean
    Get
    Set
Visual C++
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Formatting Class
Formatting Members


Formatting.Highlight Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Highlight Property
Formatting Class See Also Send Feedback
Highlight colour.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Highlight Highlight { get; set; }
Visual Basic
Public Property Highlight As Highlight
    Get
    Set
Visual C++
public:
property Highlight Highlight {
    Highlight get ();
    void set (Highlight value);
}

Property Value

Type: Highlight

See Also

Formatting Class
Formatting Members


Formatting.Italic Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Italic Property
Formatting Class See Also Send Feedback
This formatting will apply Italic.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool Italic { get; set; }
Visual Basic
Public Property Italic As Boolean
    Get
    Set
Visual C++
public:
property bool Italic {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Formatting Class
Formatting Members


Formatting.Kerning Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Kerning Property
Formatting Class See Also Send Feedback
The Kerning to apply to this text must be one of the following values 8, 9, 10, 11, 12, 14, 16, 18, 20, 22, 24, 26, 28, 36, 48, 72.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<int> Kerning { get; set; }
Visual Basic
Public Property Kerning As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> Kerning {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

Formatting Class
Formatting Members


Formatting.Language Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Language Property
Formatting Class See Also Send Feedback
Text language

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CultureInfo Language { get; set; }
Visual Basic
Public Property Language As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ Language {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

Property Value

Type: CultureInfo

See Also

Formatting Class
Formatting Members


Formatting.Misc Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Misc Property
Formatting Class See Also Send Feedback
Misc settings.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Misc Misc { get; set; }
Visual Basic
Public Property Misc As Misc
    Get
    Set
Visual C++
public:
property Misc Misc {
    Misc get ();
    void set (Misc value);
}

Property Value

Type: Misc

See Also

Formatting Class
Formatting Members


Formatting.PercentageScale Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..PercentageScale Property
Formatting Class See Also Send Feedback
Percentage scale must be one of the following values 200, 150, 100, 90, 80, 66, 50 or 33.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<int> PercentageScale { get; set; }
Visual Basic
Public Property PercentageScale As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> PercentageScale {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

Formatting Class
Formatting Members


Formatting.Position Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Position Property
Formatting Class See Also Send Feedback
Text position must be in the range (-1585 - 1585).

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<int> Position { get; set; }
Visual Basic
Public Property Position As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> Position {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

Formatting Class
Formatting Members


Formatting.Script Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Script Property
Formatting Class See Also Send Feedback
The script that this formatting should be, normal, superscript or subscript.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Script Script { get; set; }
Visual Basic
Public Property Script As Script
    Get
    Set
Visual C++
public:
property Script Script {
    Script get ();
    void set (Script value);
}

Property Value

Type: Script

See Also

Formatting Class
Formatting Members


Formatting.Size Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Size Property
Formatting Class See Also Send Feedback
The Size of this text, must be between 0 and 1638.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<double> Size { get; set; }
Visual Basic
Public Property Size As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> Size {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable <(Of <(<' Double >)>)>

See Also

Formatting Class
Formatting Members


Formatting.Spacing Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Spacing Property
Formatting Class See Also Send Feedback
Text spacing must be in the range (-1585 - 1585).

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<double> Spacing { get; set; }
Visual Basic
Public Property Spacing As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> Spacing {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable <(Of <(<' Double >)>)>

See Also

Formatting Class
Formatting Members


Formatting.StrikeThrough Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..StrikeThrough Property
Formatting Class See Also Send Feedback
This formatting will apply StrickThrough.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public StrikeThrough StrikeThrough { get; set; }
Visual Basic
Public Property StrikeThrough As StrikeThrough
    Get
    Set
Visual C++
public:
property StrikeThrough StrikeThrough {
    StrikeThrough get ();
    void set (StrikeThrough value);
}

Property Value

Type: StrikeThrough

See Also

Formatting Class
Formatting Members


Formatting.UnderlineColor Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..UnderlineColor Property
Formatting Class See Also Send Feedback
The underline colour.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<Color> UnderlineColor { get; set; }
Visual Basic
Public Property UnderlineColor As Nullable(Of Color)
    Get
    Set
Visual C++
public:
property Nullable<Color> UnderlineColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}

Property Value

Type: Nullable <(Of <(<' Color >)>)>

See Also

Formatting Class
Formatting Members


Formatting.UnderlineStyle Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..UnderlineStyle Property
Formatting Class See Also Send Feedback
The Underline style that this formatting applies.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public UnderlineStyle UnderlineStyle { get; set; }
Visual Basic
Public Property UnderlineStyle As UnderlineStyle
    Get
    Set
Visual C++
public:
property UnderlineStyle UnderlineStyle {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}

Property Value

Type: UnderlineStyle

See Also

Formatting Class
Formatting Members


Grouping Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Grouping Enumeration
See Also Send Feedback
Specifies the kind of grouping for a column, line, or area chart. 21.2.2.76 grouping (Grouping)

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Grouping
Visual Basic
Public Enumeration Grouping
Visual C++
public enum class Grouping

Members

Member name | Value | Description
PercentStacked | 0 |
Stacked | 1 |
Standard | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Header Class

[image]

DocX - A Sandcastle Documented Class Library
Header Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Header"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Header : Container
Visual Basic
Public Class Header
    Inherits Container
Visual C++
public ref class Header : public Container

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Header

See Also

Header Members


Header Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Header Members
Header Class Methods Fields Properties See Also Send Feedback

The Header type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation | (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | PageNumberParagraph |
Public field | ParentContainer | (Inherited from Container.)

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images |
Public property | Lists | (Inherited from Container.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Header Class


Header Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Header Fields
Header Class See Also Send Feedback

The Header type exposes the following members.

Fields

 | Name | Description
Public field | PageNumberParagraph |
Public field | ParentContainer | (Inherited from Container.)

See Also

Header Class


Header.PageNumberParagraph Field

[image]

DocX - A Sandcastle Documented Class Library
Header..::..PageNumberParagraph Field
Header Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Header.PageNumberParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph PageNumberParagraph
Visual Basic
Public PageNumberParagraph As Paragraph
Visual C++
public:
Paragraph^ PageNumberParagraph

Field Value

Type: Paragraph

See Also

Header Class
Header Members


Header Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Header Methods
Header Class See Also Send Feedback

The Header type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation | (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Header Class


Header.InsertEquation Method

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertEquation Method
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertEquation(
    string equation
)
Visual Basic
Public Overrides Function InsertEquation (
    equation As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertEquation(
    String^ equation
) override

Parameters

equation
Type: System..::..String

[Missing <param name="equation"/> documentation for "M:Novacode.Header.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertEquation(System.String)"]

See Also

Header Class
Header Members


Header.InsertParagraph Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method
Header Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)

See Also

Header Class
Header Members


Header.InsertParagraph Method

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph()
Visual Basic
Public Overrides Function InsertParagraph As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph() override

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (String)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text
) override

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.String)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (Paragraph)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
) override

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Header.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(Novacode.Paragraph)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (Int32, Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (Int32, Paragraph)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
) override

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (String, Boolean)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
) override

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (Int32, String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (Int32, String, Boolean)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
) override

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (String, Boolean, Formatting)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (Int32, String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (Int32, String, Boolean, Formatting)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Header Properties
Header Class See Also Send Feedback

The Header type exposes the following members.

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images |
Public property | Lists | (Inherited from Container.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Header Class


Header.Images Property

[image]

DocX - A Sandcastle Documented Class Library
Header..::..Images Property
Header Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Header.Images"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Image> Images { get; }
Visual Basic
Public ReadOnly Property Images As List(Of Image)
    Get
Visual C++
public:
property List<Image^>^ Images {
    List<Image^>^ get ();
}

Property Value

Type: List <(Of <(<' Image >)>)>

See Also

Header Class
Header Members


Header.PageNumbers Property

[image]

DocX - A Sandcastle Documented Class Library
Header..::..PageNumbers Property
Header Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Header.PageNumbers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool PageNumbers { get; set; }
Visual Basic
Public Property PageNumbers As Boolean
    Get
    Set
Visual C++
public:
property bool PageNumbers {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Header Class
Header Members


Header.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Header..::..Paragraphs Property
Header Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Header.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Paragraph> Paragraphs { get; }
Visual Basic
Public Overrides ReadOnly Property Paragraphs As List(Of Paragraph)
    Get
Visual C++
public:
virtual property List<Paragraph^>^ Paragraphs {
    List<Paragraph^>^ get () override;
}

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

Header Class
Header Members


Header.Tables Property

[image]

DocX - A Sandcastle Documented Class Library
Header..::..Tables Property
Header Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Header.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Table> Tables { get; }
Visual Basic
Public Overrides ReadOnly Property Tables As List(Of Table)
    Get
Visual C++
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get () override;
}

Property Value

Type: List <(Of <(<' Table >)>)>

See Also

Header Class
Header Members


Headers Class

[image]

DocX - A Sandcastle Documented Class Library
Headers Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Headers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Headers
Visual Basic
Public Class Headers
Visual C++
public ref class Headers

Inheritance Hierarchy

System..::..Object
Novacode..::..Headers

See Also

Headers Members


Headers Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Headers Members
Headers Class Methods Fields See Also Send Feedback

The Headers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | even |
Public field | first |
Public field | odd |

See Also

Headers Class


Headers Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Headers Fields
Headers Class See Also Send Feedback

The Headers type exposes the following members.

Fields

 | Name | Description
Public field | even |
Public field | first |
Public field | odd |

See Also

Headers Class


Headers.even Field

[image]

DocX - A Sandcastle Documented Class Library
Headers..::..even Field
Headers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Headers.even"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Header even
Visual Basic
Public even As Header
Visual C++
public:
Header^ even

Field Value

Type: Header

See Also

Headers Class
Headers Members


Headers.first Field

[image]

DocX - A Sandcastle Documented Class Library
Headers..::..first Field
Headers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Headers.first"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Header first
Visual Basic
Public first As Header
Visual C++
public:
Header^ first

Field Value

Type: Header

See Also

Headers Class
Headers Members


Headers.odd Field

[image]

DocX - A Sandcastle Documented Class Library
Headers..::..odd Field
Headers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Headers.odd"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Header odd
Visual Basic
Public odd As Header
Visual C++
public:
Header^ odd

Field Value

Type: Header

See Also

Headers Class
Headers Members


Headers Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Headers Methods
Headers Class See Also Send Feedback

The Headers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Headers Class


Highlight Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Highlight Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Highlight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Highlight
Visual Basic
Public Enumeration Highlight
Visual C++
public enum class Highlight

Members

Member name | Value | Description
yellow | 0 |
green | 1 |
cyan | 2 |
magenta | 3 |
blue | 4 |
red | 5 |
darkBlue | 6 |
darkCyan | 7 |
darkGreen | 8 |
darkMagenta | 9 |
darkRed | 10 |
darkYellow | 11 |
darkGray | 12 |
lightGray | 13 |
black | 14 |
none | 15 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Hyperlink Class

[image]

DocX - A Sandcastle Documented Class Library
Hyperlink Class
Members See Also Send Feedback
Represents a Hyperlink in a document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Hyperlink : DocXElement
Visual Basic
Public Class Hyperlink
    Inherits DocXElement
Visual C++
public ref class Hyperlink : public DocXElement

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Hyperlink

See Also

Hyperlink Members


Hyperlink Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Hyperlink Members
Hyperlink Class Methods Fields Properties See Also Send Feedback

The Hyperlink type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Remove a Hyperlink from this Paragraph only.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | mainPart |

Properties

 | Name | Description
Public property | Text |
Public property | Uri |
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Hyperlink Class


Hyperlink Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Hyperlink Fields
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Fields

 | Name | Description
Public field | mainPart |

See Also

Hyperlink Class


Hyperlink.mainPart Field

[image]

DocX - A Sandcastle Documented Class Library
Hyperlink..::..mainPart Field
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Hyperlink.mainPart"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public PackagePart mainPart
Visual Basic
Public mainPart As PackagePart
Visual C++
public:
PackagePart^ mainPart

Field Value

Type: PackagePart

See Also

Hyperlink Class
Hyperlink Members


Hyperlink Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Hyperlink Methods
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Remove a Hyperlink from this Paragraph only.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Hyperlink Class


Hyperlink.Remove Method

[image]

DocX - A Sandcastle Documented Class Library
Hyperlink..::..Remove Method
Hyperlink Class Example See Also Send Feedback
Remove a Hyperlink from this Paragraph only.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Remove()
Visual Basic
Public Sub Remove
Visual C++
public:
void Remove()

Examples

Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
   // Add a hyperlink to this document.
   Hyperlink h = document.AddHyperlink("link", new Uri("http://www.google.com"));

   // Add a Paragraph to this document and insert the hyperlink
   Paragraph p1 = document.InsertParagraph();
   p1.Append("This is a cool ").AppendHyperlink(h).Append(" .");

   /*
    * Remove the hyperlink from this Paragraph only.
    * Note a reference to the hyperlink will still exist in the document and it can thus be reused.
    */
   p1.Hyperlinks[0].Remove();

   // Add a new Paragraph to this document and reuse the hyperlink h.
   Paragraph p2 = document.InsertParagraph();
   p2.Append("This is the same cool ").AppendHyperlink(h).Append(" .");

   document.Save();
}// Release this document from memory.

See Also

Hyperlink Class
Hyperlink Members


Hyperlink Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Hyperlink Properties
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Properties

 | Name | Description
Public property | Text |
Public property | Uri |
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Hyperlink Class


Hyperlink.Text Property

[image]

DocX - A Sandcastle Documented Class Library
Hyperlink..::..Text Property
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Hyperlink.Text"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Hyperlink Class
Hyperlink Members


Hyperlink.Uri Property

[image]

DocX - A Sandcastle Documented Class Library
Hyperlink..::..Uri Property
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Hyperlink.Uri"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Uri Uri { get; set; }
Visual Basic
Public Property Uri As Uri
    Get
    Set
Visual C++
public:
property Uri^ Uri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri

See Also

Hyperlink Class
Hyperlink Members


Image Class

[image]

DocX - A Sandcastle Documented Class Library
Image Class
Members See Also Send Feedback
Represents an Image embedded in a document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Image
Visual Basic
Public Class Image
Visual C++
public ref class Image

Inheritance Hierarchy

System..::..Object
Novacode..::..Image

See Also

Image Members


Image Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Image Members
Image Class Methods Properties See Also Send Feedback

The Image type exposes the following members.

Methods

 | Name | Description
Public method | CreatePicture()()()() | Add an image to a document, create a custom view of that image (picture) and then insert it into a Paragraph using append.
Public method | CreatePicture(Int32, Int32) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FileName | Returns the name of the image file.
Public property | Id | Returns the id of this Image.

See Also

Image Class


Image Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Image Methods
Image Class See Also Send Feedback

The Image type exposes the following members.

Methods

 | Name | Description
Public method | CreatePicture()()()() | Add an image to a document, create a custom view of that image (picture) and then insert it into a Paragraph using append.
Public method | CreatePicture(Int32, Int32) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Image Class


Image.CreatePicture Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Image..::..CreatePicture Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreatePicture()()()() | Add an image to a document, create a custom view of that image (picture) and then insert it into a Paragraph using append.
Public method | CreatePicture(Int32, Int32) |

See Also

Image Class
Image Members


Image.CreatePicture Method

[image]

DocX - A Sandcastle Documented Class Library
Image..::..CreatePicture Method
Image Class Example See Also Send Feedback
Add an image to a document, create a custom view of that image (picture) and then insert it into a Paragraph using append.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Picture CreatePicture()
Visual Basic
Public Function CreatePicture As Picture
Visual C++
public:
Picture^ CreatePicture()

Return Value

Type: Picture

[Missing <returns> documentation for "M:Novacode.Image.CreatePicture"]

Examples

Add an image to a document, create a custom view of that image (picture) and then insert it into a Paragraph using append.
Copy image Copy
using (DocX document = DocX.Create("Test.docx"))
{
   // Add an image to the document.
   Image     i = document.AddImage(@"Image.jpg");

   // Create a picture i.e. (A custom view of an image)
   Picture   p = i.CreatePicture();
   p.FlipHorizontal = true;
   p.Rotation = 10;

   // Create a new Paragraph.
   Paragraph par = document.InsertParagraph();

   // Append content to the Paragraph.
   par.Append("Here is a cool picture")
      .AppendPicture(p)
      .Append(" don't you think so?");

   // Save all changes made to this document.
   document.Save();
}

See Also

Image Class
Image Members
CreatePicture Overload


Image.CreatePicture Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Image..::..CreatePicture Method (Int32, Int32)
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Picture CreatePicture(
    int height,
    int width
)
Visual Basic
Public Function CreatePicture (
    height As Integer,
    width As Integer
) As Picture
Visual C++
public:
Picture^ CreatePicture(
    int height,
    int width
)

Parameters

height
Type: System..::..Int32

[Missing <param name="height"/> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

Return Value

Type: Picture

[Missing <returns> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

See Also

Image Class
Image Members
CreatePicture Overload


Image.GetStream Method

[image]

DocX - A Sandcastle Documented Class Library
Image..::..GetStream Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Stream GetStream(
    FileMode mode,
    FileAccess access
)
Visual Basic
Public Function GetStream (
    mode As FileMode,
    access As FileAccess
) As Stream
Visual C++
public:
Stream^ GetStream(
    FileMode mode,
    FileAccess access
)

Parameters

mode
Type: System.IO..::..FileMode

[Missing <param name="mode"/> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

access
Type: System.IO..::..FileAccess

[Missing <param name="access"/> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

Return Value

Type: Stream

[Missing <returns> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

See Also

Image Class
Image Members


Image Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Image Properties
Image Class See Also Send Feedback

The Image type exposes the following members.

Properties

 | Name | Description
Public property | FileName | Returns the name of the image file.
Public property | Id | Returns the id of this Image.

See Also

Image Class


Image.FileName Property

[image]

DocX - A Sandcastle Documented Class Library
Image..::..FileName Property
Image Class See Also Send Feedback
Returns the name of the image file.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get
Visual C++
public:
property String^ FileName {
    String^ get ();
}

Property Value

Type: String

See Also

Image Class
Image Members


Image.Id Property

[image]

DocX - A Sandcastle Documented Class Library
Image..::..Id Property
Image Class See Also Send Feedback
Returns the id of this Image.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

Property Value

Type: String

See Also

Image Class
Image Members


InsertBeforeOrAfter Class

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter Class
Members See Also Send Feedback
This class provides functions for inserting new DocXElements before or after the current DocXElement. Only certain DocXElements can support these functions without creating invalid documents, at the moment these are Paragraphs and Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public abstract class InsertBeforeOrAfter : DocXElement
Visual Basic
Public MustInherit Class InsertBeforeOrAfter
    Inherits DocXElement
Visual C++
public ref class InsertBeforeOrAfter abstract : public DocXElement

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..InsertBeforeOrAfter
Novacode..::..List
Novacode..::..Paragraph
Novacode..::..Table

See Also

InsertBeforeOrAfter Members


InsertBeforeOrAfter Members

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter Members
InsertBeforeOrAfter Class Constructors Methods Properties See Also Send Feedback

The InsertBeforeOrAfter type exposes the following members.

Constructors

 | Name | Description
Public method | InsertBeforeOrAfter | Initializes a new instance of the InsertBeforeOrAfter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf |
Public method | InsertPageBreakBeforeSelf |
Public method | InsertParagraphAfterSelf(String) |
Public method | InsertParagraphAfterSelf(Paragraph) |
Public method | InsertParagraphAfterSelf(String, Boolean) |
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) |
Public method | InsertParagraphBeforeSelf(String) |
Public method | InsertParagraphBeforeSelf(Paragraph) |
Public method | InsertParagraphBeforeSelf(String, Boolean) |
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) |
Public method | InsertTableAfterSelf(Table) |
Public method | InsertTableAfterSelf(Int32, Int32) |
Public method | InsertTableBeforeSelf(Table) |
Public method | InsertTableBeforeSelf(Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

InsertBeforeOrAfter Class


InsertBeforeOrAfter Constructor

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter Constructor
InsertBeforeOrAfter Class See Also Send Feedback
Initializes a new instance of the InsertBeforeOrAfter class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public InsertBeforeOrAfter(
    DocX document,
    XElement xml
)
Visual Basic
Public Sub New (
    document As DocX,
    xml As XElement
)
Visual C++
public:
InsertBeforeOrAfter(
    DocX^ document,
    XElement^ xml
)

Parameters

document
Type: Novacode..::..DocX

[Missing <param name="document"/> documentation for "M:Novacode.InsertBeforeOrAfter.#ctor(Novacode.DocX,System.Xml.Linq.XElement)"]

xml
Type: System.Xml.Linq..::..XElement

[Missing <param name="xml"/> documentation for "M:Novacode.InsertBeforeOrAfter.#ctor(Novacode.DocX,System.Xml.Linq.XElement)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter Methods
InsertBeforeOrAfter Class See Also Send Feedback

The InsertBeforeOrAfter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf |
Public method | InsertPageBreakBeforeSelf |
Public method | InsertParagraphAfterSelf(String) |
Public method | InsertParagraphAfterSelf(Paragraph) |
Public method | InsertParagraphAfterSelf(String, Boolean) |
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) |
Public method | InsertParagraphBeforeSelf(String) |
Public method | InsertParagraphBeforeSelf(Paragraph) |
Public method | InsertParagraphBeforeSelf(String, Boolean) |
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) |
Public method | InsertTableAfterSelf(Table) |
Public method | InsertTableAfterSelf(Int32, Int32) |
Public method | InsertTableBeforeSelf(Table) |
Public method | InsertTableBeforeSelf(Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertBeforeOrAfter Class


InsertBeforeOrAfter.InsertPageBreakAfterSelf Method

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertPageBreakAfterSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertPageBreakAfterSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertPageBreakAfterSelf()
Visual Basic
Public Overridable Sub InsertPageBreakAfterSelf
Visual C++
public:
virtual void InsertPageBreakAfterSelf()

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertPageBreakBeforeSelf Method

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertPageBreakBeforeSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertPageBreakBeforeSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertPageBreakBeforeSelf()
Visual Basic
Public Overridable Sub InsertPageBreakBeforeSelf
Visual C++
public:
virtual void InsertPageBreakBeforeSelf()

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertParagraphAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphAfterSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphAfterSelf(String) |
Public method | InsertParagraphAfterSelf(Paragraph) |
Public method | InsertParagraphAfterSelf(String, Boolean) |
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) |

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphAfterSelf Method (String)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphAfterSelf(
    string text
)
Visual Basic
Public Overridable Function InsertParagraphAfterSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphAfterSelf Method (Paragraph)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphAfterSelf(
    Paragraph p
)
Visual Basic
Public Overridable Function InsertParagraphAfterSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    Paragraph^ p
)

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(Novacode.Paragraph)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphAfterSelf Method (String, Boolean)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overridable Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphAfterSelf Method (String, Boolean, Formatting)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overridable Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphBeforeSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphBeforeSelf(String) |
Public method | InsertParagraphBeforeSelf(Paragraph) |
Public method | InsertParagraphBeforeSelf(String, Boolean) |
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) |

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphBeforeSelf Method (String)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphBeforeSelf(
    string text
)
Visual Basic
Public Overridable Function InsertParagraphBeforeSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphBeforeSelf Method (Paragraph)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphBeforeSelf(
    Paragraph p
)
Visual Basic
Public Overridable Function InsertParagraphBeforeSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    Paragraph^ p
)

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphBeforeSelf Method (String, Boolean)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overridable Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphBeforeSelf Method (String, Boolean, Formatting)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overridable Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertTableAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableAfterSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableAfterSelf(Table) |
Public method | InsertTableAfterSelf(Int32, Int32) |

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertTableAfterSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableAfterSelf Method (Table)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Table InsertTableAfterSelf(
    Table t
)
Visual Basic
Public Overridable Function InsertTableAfterSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    Table^ t
)

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(Novacode.Table)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertTableAfterSelf Overload


InsertBeforeOrAfter.InsertTableAfterSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableAfterSelf Method (Int32, Int32)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Table InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overridable Function InsertTableAfterSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    int rowCount,
    int columnCount
)

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertTableAfterSelf Overload


InsertBeforeOrAfter.InsertTableBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableBeforeSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableBeforeSelf(Table) |
Public method | InsertTableBeforeSelf(Int32, Int32) |

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertTableBeforeSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableBeforeSelf Method (Table)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Table InsertTableBeforeSelf(
    Table t
)
Visual Basic
Public Overridable Function InsertTableBeforeSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    Table^ t
)

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(Novacode.Table)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertTableBeforeSelf Overload


InsertBeforeOrAfter.InsertTableBeforeSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableBeforeSelf Method (Int32, Int32)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Table InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overridable Function InsertTableBeforeSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertTableBeforeSelf Overload


InsertBeforeOrAfter Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter Properties
InsertBeforeOrAfter Class See Also Send Feedback

The InsertBeforeOrAfter type exposes the following members.

Properties

 | Name | Description
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

InsertBeforeOrAfter Class


LineChart Class

[image]

DocX - A Sandcastle Documented Class Library
LineChart Class
Members See Also Send Feedback
This element contains the 2-D line chart series. 21.2.2.97 lineChart (Line Charts)

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class LineChart : Chart
Visual Basic
Public Class LineChart
    Inherits Chart
Visual C++
public ref class LineChart : public Chart

Inheritance Hierarchy

System..::..Object
Novacode..::..Chart
Novacode..::..LineChart

See Also

LineChart Members


LineChart Members

[image] [image]

DocX - A Sandcastle Documented Class Library
LineChart Members
LineChart Class Constructors Methods Properties See Also Send Feedback

The LineChart type exposes the following members.

Constructors

 | Name | Description
Public method | LineChart | Initializes a new instance of the LineChart class

Methods

 | Name | Description
Public method | AddLegend()()()() | Add standart legend to the chart. (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | Add a legend with parameters to the chart. (Inherited from Chart.)
Public method | AddSeries | Add a new series to this chart (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | Remove the legend from the chart. (Inherited from Chart.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryAxis | Represents the category axis (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | Specifies how blank cells shall be plotted on a chart (Inherited from Chart.)
Public property | Grouping | Specifies the kind of grouping for a column, line, or area chart.
Public property | IsAxisExist | Represents existing the axis (Inherited from Chart.)
Public property | Legend | Chart's legend. If legend doesn't exist property is null. (Inherited from Chart.)
Public property | MaxSeriesCount | Return maximum count of series (Inherited from Chart.)
Public property | Series | Chart's series (Inherited from Chart.)
Public property | ValueAxis | Represents the values axis (Inherited from Chart.)
Public property | View3D | Get or set 3D view for this chart (Inherited from Chart.)
Public property | Xml | The xml representation of this chart (Inherited from Chart.)

See Also

LineChart Class


LineChart Constructor

[image]

DocX - A Sandcastle Documented Class Library
LineChart Constructor
LineChart Class See Also Send Feedback
Initializes a new instance of the LineChart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public LineChart()
Visual Basic
Public Sub New
Visual C++
public:
LineChart()

See Also

LineChart Class
LineChart Members


LineChart Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
LineChart Methods
LineChart Class See Also Send Feedback

The LineChart type exposes the following members.

Methods

 | Name | Description
Public method | AddLegend()()()() | Add standart legend to the chart. (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | Add a legend with parameters to the chart. (Inherited from Chart.)
Public method | AddSeries | Add a new series to this chart (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | Remove the legend from the chart. (Inherited from Chart.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineChart Class


LineChart.CreateChartXml Method

[image]

DocX - A Sandcastle Documented Class Library
LineChart..::..CreateChartXml Method
LineChart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.LineChart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected override XElement CreateChartXml()
Visual Basic
Protected Overrides Function CreateChartXml As XElement
Visual C++
protected:
virtual XElement^ CreateChartXml() override

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.LineChart.CreateChartXml"]

See Also

LineChart Class
LineChart Members


LineChart Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
LineChart Properties
LineChart Class See Also Send Feedback

The LineChart type exposes the following members.

Properties

 | Name | Description
Public property | CategoryAxis | Represents the category axis (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | Specifies how blank cells shall be plotted on a chart (Inherited from Chart.)
Public property | Grouping | Specifies the kind of grouping for a column, line, or area chart.
Public property | IsAxisExist | Represents existing the axis (Inherited from Chart.)
Public property | Legend | Chart's legend. If legend doesn't exist property is null. (Inherited from Chart.)
Public property | MaxSeriesCount | Return maximum count of series (Inherited from Chart.)
Public property | Series | Chart's series (Inherited from Chart.)
Public property | ValueAxis | Represents the values axis (Inherited from Chart.)
Public property | View3D | Get or set 3D view for this chart (Inherited from Chart.)
Public property | Xml | The xml representation of this chart (Inherited from Chart.)

See Also

LineChart Class


LineChart.Grouping Property

[image]

DocX - A Sandcastle Documented Class Library
LineChart..::..Grouping Property
LineChart Class See Also Send Feedback
Specifies the kind of grouping for a column, line, or area chart.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Grouping Grouping { get; set; }
Visual Basic
Public Property Grouping As Grouping
    Get
    Set
Visual C++
public:
property Grouping Grouping {
    Grouping get ();
    void set (Grouping value);
}

Property Value

Type: Grouping

See Also

LineChart Class
LineChart Members


List Class

[image]

DocX - A Sandcastle Documented Class Library
List Class
Members See Also Send Feedback
Represents a List in a document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class List : InsertBeforeOrAfter
Visual Basic
Public Class List
    Inherits InsertBeforeOrAfter
Visual C++
public ref class List : public InsertBeforeOrAfter

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..InsertBeforeOrAfter
Novacode..::..List

See Also

List Members


List Members

[image] [image]

DocX - A Sandcastle Documented Class Library
List Members
List Class Methods Properties See Also Send Feedback

The List type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds an item to the list.
Public method | AddItemWithStartValue |
Public method | CanAddListItem | Determine if it is able to add the item to the list
Public method | ContainsLevel |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertPageBreakBeforeSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Items | This is a list of paragraphs that will be added to the document when the list is inserted into the document. The paragraph needs a numPr defined to be in this items collection.
Public property | ListType | The ListItemType (bullet or numbered) of the list.
Public property | NumId | The numId used to reference the list settings in the numbering.xml
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

List Class


List Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
List Methods
List Class See Also Send Feedback

The List type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds an item to the list.
Public method | AddItemWithStartValue |
Public method | CanAddListItem | Determine if it is able to add the item to the list
Public method | ContainsLevel |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertPageBreakBeforeSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

List Class


List.AddItem Method

[image]

DocX - A Sandcastle Documented Class Library
List..::..AddItem Method
List Class See Also Send Feedback
Adds an item to the list.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddItem(
    Paragraph paragraph
)
Visual Basic
Public Sub AddItem (
    paragraph As Paragraph
)
Visual C++
public:
void AddItem(
    Paragraph^ paragraph
)

Parameters

paragraph
Type: Novacode..::..Paragraph

[Missing <param name="paragraph"/> documentation for "M:Novacode.List.AddItem(Novacode.Paragraph)"]

Exceptions

Exception | Condition
System..::..InvalidOperationException | Throws an InvalidOperationException if the item cannot be added to the list.

See Also

List Class
List Members


List.AddItemWithStartValue Method

[image]

DocX - A Sandcastle Documented Class Library
List..::..AddItemWithStartValue Method
List Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.List.AddItemWithStartValue(Novacode.Paragraph,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddItemWithStartValue(
    Paragraph paragraph,
    int start
)
Visual Basic
Public Sub AddItemWithStartValue (
    paragraph As Paragraph,
    start As Integer
)
Visual C++
public:
void AddItemWithStartValue(
    Paragraph^ paragraph,
    int start
)

Parameters

paragraph
Type: Novacode..::..Paragraph

[Missing <param name="paragraph"/> documentation for "M:Novacode.List.AddItemWithStartValue(Novacode.Paragraph,System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Novacode.List.AddItemWithStartValue(Novacode.Paragraph,System.Int32)"]

See Also

List Class
List Members


List.CanAddListItem Method

[image]

DocX - A Sandcastle Documented Class Library
List..::..CanAddListItem Method
List Class See Also Send Feedback
Determine if it is able to add the item to the list

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool CanAddListItem(
    Paragraph paragraph
)
Visual Basic
Public Function CanAddListItem (
    paragraph As Paragraph
) As Boolean
Visual C++
public:
bool CanAddListItem(
    Paragraph^ paragraph
)

Parameters

paragraph
Type: Novacode..::..Paragraph

[Missing <param name="paragraph"/> documentation for "M:Novacode.List.CanAddListItem(Novacode.Paragraph)"]

Return Value

Type: Boolean
Return true if AddItem(...) will succeed with the given paragraph.

See Also

List Class
List Members


List.ContainsLevel Method

[image]

DocX - A Sandcastle Documented Class Library
List..::..ContainsLevel Method
List Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.List.ContainsLevel(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool ContainsLevel(
    int ilvl
)
Visual Basic
Public Function ContainsLevel (
    ilvl As Integer
) As Boolean
Visual C++
public:
bool ContainsLevel(
    int ilvl
)

Parameters

ilvl
Type: System..::..Int32

[Missing <param name="ilvl"/> documentation for "M:Novacode.List.ContainsLevel(System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.List.ContainsLevel(System.Int32)"]

See Also

List Class
List Members


List Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
List Properties
List Class See Also Send Feedback

The List type exposes the following members.

Properties

 | Name | Description
Public property | Items | This is a list of paragraphs that will be added to the document when the list is inserted into the document. The paragraph needs a numPr defined to be in this items collection.
Public property | ListType | The ListItemType (bullet or numbered) of the list.
Public property | NumId | The numId used to reference the list settings in the numbering.xml
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

List Class


List.Items Property

[image]

DocX - A Sandcastle Documented Class Library
List..::..Items Property
List Class See Also Send Feedback
This is a list of paragraphs that will be added to the document when the list is inserted into the document. The paragraph needs a numPr defined to be in this items collection.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Paragraph> Items { get; private set; }
Visual Basic
Public Property Items As List(Of Paragraph)
    Get
    Private Set
Visual C++
public:
property List<Paragraph^>^ Items {
    List<Paragraph^>^ get ();
    private: void set (List<Paragraph^>^ value);
}

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

List Class
List Members


List.ListType Property

[image]

DocX - A Sandcastle Documented Class Library
List..::..ListType Property
List Class See Also Send Feedback
The ListItemType (bullet or numbered) of the list.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<ListItemType> ListType { get; private set; }
Visual Basic
Public Property ListType As Nullable(Of ListItemType)
    Get
    Private Set
Visual C++
public:
property Nullable<ListItemType> ListType {
    Nullable<ListItemType> get ();
    private: void set (Nullable<ListItemType> value);
}

Property Value

Type: Nullable <(Of <(<' ListItemType >)>)>

See Also

List Class
List Members


List.NumId Property

[image]

DocX - A Sandcastle Documented Class Library
List..::..NumId Property
List Class See Also Send Feedback
The numId used to reference the list settings in the numbering.xml

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int NumId { get; private set; }
Visual Basic
Public Property NumId As Integer
    Get
    Private Set
Visual C++
public:
property int NumId {
    int get ();
    private: void set (int value);
}

Property Value

Type: Int32

See Also

List Class
List Members


ListItemType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
ListItemType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.ListItemType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum ListItemType
Visual Basic
Public Enumeration ListItemType
Visual C++
public enum class ListItemType

Members

Member name | Value | Description
Bulleted | 0 |
Numbered | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


MatchFormattingOptions Enumeration

[image]

DocX - A Sandcastle Documented Class Library
MatchFormattingOptions Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.MatchFormattingOptions"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum MatchFormattingOptions
Visual Basic
Public Enumeration MatchFormattingOptions
Visual C++
public enum class MatchFormattingOptions

Members

Member name | Value | Description
ExactMatch | 0 |
SubsetMatch | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Misc Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Misc Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Misc"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Misc
Visual Basic
Public Enumeration Misc
Visual C++
public enum class Misc

Members

Member name | Value | Description
none | 0 |
shadow | 1 |
outline | 2 |
outlineShadow | 3 |
emboss | 4 |
engrave | 5 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Orientation Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Orientation Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Orientation"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Orientation
Visual Basic
Public Enumeration Orientation
Visual C++
public enum class Orientation

Members

Member name | Value | Description
Portrait | 0 |
Landscape | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


PageLayout Class

[image]

DocX - A Sandcastle Documented Class Library
PageLayout Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.PageLayout"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class PageLayout : DocXElement
Visual Basic
Public Class PageLayout
    Inherits DocXElement
Visual C++
public ref class PageLayout : public DocXElement

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..PageLayout

See Also

PageLayout Members


PageLayout Members

[image] [image]

DocX - A Sandcastle Documented Class Library
PageLayout Members
PageLayout Class Methods Properties See Also Send Feedback

The PageLayout type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Orientation |
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

PageLayout Class


PageLayout Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
PageLayout Methods
PageLayout Class See Also Send Feedback

The PageLayout type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageLayout Class


PageLayout Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
PageLayout Properties
PageLayout Class See Also Send Feedback

The PageLayout type exposes the following members.

Properties

 | Name | Description
Public property | Orientation |
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

PageLayout Class


PageLayout.Orientation Property

[image]

DocX - A Sandcastle Documented Class Library
PageLayout..::..Orientation Property
PageLayout Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.PageLayout.Orientation"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

Property Value

Type: Orientation

See Also

PageLayout Class
PageLayout Members


PageNumberFormat Enumeration

[image]

DocX - A Sandcastle Documented Class Library
PageNumberFormat Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.PageNumberFormat"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum PageNumberFormat
Visual Basic
Public Enumeration PageNumberFormat
Visual C++
public enum class PageNumberFormat

Members

Member name | Value | Description
normal | 0 |
roman | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Paragraph Class

[image]

DocX - A Sandcastle Documented Class Library
Paragraph Class
Members See Also Send Feedback
Represents a document paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Paragraph : InsertBeforeOrAfter
Visual Basic
Public Class Paragraph
    Inherits InsertBeforeOrAfter
Visual C++
public ref class Paragraph : public InsertBeforeOrAfter

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..InsertBeforeOrAfter
Novacode..::..Paragraph

See Also

Paragraph Members


Paragraph Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph Members
Paragraph Class Methods Fields Properties See Also Send Feedback

The Paragraph type exposes the following members.

Methods

 | Name | Description
Public method | Append | Append text to this Paragraph.
Public method | AppendDocProperty |
Public method | AppendEquation | Add an equation to a document.
Public method | AppendHyperlink | Append a hyperlink to a Paragraph.
Public method | AppendLine()()()() | Append a new line to this Paragraph.
Public method | AppendLine(String) | Append text on a new line to this Paragraph.
Public method | AppendPageCount | Append a PageCount place holder onto the end of a Paragraph.
Public method | AppendPageNumber | Append a PageNumber place holder onto the end of a Paragraph.
Public method | AppendPicture | Add an image to a document, create a custom view of that image (picture) and then insert it into a Paragraph using append.
Public method | Bold | For use with Append() and AppendLine()
Public method | CapsStyle | For use with Append() and AppendLine()
Public method | Color | For use with Append() and AppendLine()
Public method | Culture | For use with Append() and AppendLine()
Public method | CurentCulture | For use with Append() and AppendLine()
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | Find all instances of a string in this paragraph and return their indexes in a List.
Public method | FindAll(String, RegexOptions) | Find all instances of a string in this paragraph and return their indexes in a List.
Public method | FindAllByPattern | Find all unique instances of the given Regex Pattern
Public method | Font | For use with Append() and AppendLine()
Public method | FontSize | For use with Append() and AppendLine()
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | For use with Append() and AppendLine()
Public method | Highlight | For use with Append() and AppendLine()
Public method | InsertDocProperty | Insert a field of type document property, this field will display the custom property cp, at the end of this paragraph.
Public method | InsertHyperlink(Int32, Hyperlink) | Obsolete.
Public method | InsertHyperlink(Hyperlink, Int32) | This function inserts a hyperlink into a Paragraph at a specified character index.
Public method | InsertPageBreakAfterSelf | Insert a page break after a Paragraph. (Overrides InsertBeforeOrAfter..::..InsertPageBreakAfterSelf()()()().)
Public method | InsertPageBreakBeforeSelf | Insert a page break before a Paragraph. (Overrides InsertBeforeOrAfter..::..InsertPageBreakBeforeSelf()()()().)
Public method | InsertPageCount | Insert a PageCount place holder into a Paragraph. This place holder should only be inserted into a Header or Footer Paragraph. Word will not automatically update this field if it is inserted into a document level Paragraph.
Public method | InsertPageNumber | Insert a PageNumber place holder into a Paragraph. This place holder should only be inserted into a Header or Footer Paragraph. Word will not automatically update this field if it is inserted into a document level Paragraph.
Public method | InsertParagraphAfterSelf(String) | Insert a new Paragraph after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | Insert a Paragraph after this Paragraph, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | Insert a new Paragraph after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | Insert a new Paragraph after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | Insert a new Paragraph before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | Insert a Paragraph before this Paragraph, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | Insert a new Paragraph before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | Insert a new Paragraph before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertPicture | Insert a Picture into a Paragraph at the given text index. If not index is provided defaults to 0.
Public method | InsertTableAfterSelf(Table) | Insert a new Table after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | Insert a new Table into this document after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | Insert a new Table before this Paragraph, this Table can be from this document or another document. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | Insert a new Table into this document before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)
Public method | InsertText(String, Boolean, Formatting) | Inserts a specified instance of System.String into a Novacode.DocX.Paragraph at a specified index position.
Public method | InsertText(Int32, String, Boolean, Formatting) | Inserts a specified instance of System.String into a Novacode.DocX.Paragraph at a specified index position.
Public method | Italic | For use with Append() and AppendLine()
Public method | Kerning |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Misc | For use with Append() and AppendLine()
Public method | PercentageScale |
Public method | Position |
Public method | Remove | Remove this Paragraph from the document.
Public method | RemoveHyperlink | Remove the Hyperlink at the provided index. The first hyperlink is at index 0. Using a negative index or an index greater than the index of the last hyperlink will cause an ArgumentOutOfRangeException() to be thrown.
Public method | RemoveText(Int32, Boolean) | Removes characters from a Novacode.DocX.Paragraph.
Public method | RemoveText(Int32, Int32, Boolean) | Removes characters from a Novacode.DocX.Paragraph.
Public method | ReplaceText | Replaces all occurrences of a specified System.String in this instance, with another specified System.String.
Public method | Script | For use with Append() and AppendLine()
Public method | Spacing |
Public method | SpacingAfter |
Public method | SpacingBefore |
Public method | StrikeThrough | For use with Append() and AppendLine()
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnderlineColor | For use with Append() and AppendLine()
Public method | UnderlineStyle | For use with Append() and AppendLine()

Fields

 | Name | Description
Public field | ListItemType | Determine if the list element is a numbered list of bulleted list element
Public field | ParentContainer |

Properties

Name | Description
Public property Alignment
Gets or set this Paragraphs text alignment.
Public property Direction
Gets or Sets the Direction of content in this Paragraph.

Examples

Create a Paragraph with content that flows right to left. Default is left to right.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Create a new Paragraph with the text "Hello World".
    Paragraph p = document.InsertParagraph("Hello World.");

    // Make this Paragraph flow right to left. Default is left to right.
    p.Direction = Direction.RightToLeft;

    // Save all changes made to this document.
    document.Save();
}
Public property DocumentProperties
Returns a list of field type DocProperty in this document.
Public property FollowingTable
Returns table following the paragraph. Null if the following element isn't table.
Public property | Hyperlinks
Public property IndentationAfter
Set the after indentation in cm for this Paragraph.
Public property IndentationBefore
Set the before indentation in cm for this Paragraph.
Public property IndentationFirstLine
Get or set the indentation of the first line of this Paragraph.
Public property IndentationHanging
Get or set the indentation of all but the first line of this Paragraph.
Public property IndentLevel
If this element is a list item, get the indentation level of the list item.
Public property IsListItem
Determine if this paragraph is a list element.
Public property | LineSpacing
Public property | LineSpacingAfter
Public property | LineSpacingBefore
Public property MagicText
Gets the formatted text value of this Paragraph.
Public property | PackagePart
Public property ParagraphNumberProperties
Fetch the paragraph number properties for a list element.
Public property | Pictures
Public property StyleName
The style name of the paragraph.
Public property Text
Gets the text value of this Paragraph.
Public property Xml
This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following

Hello World!

(Inherited from DocXElement.)

See Also

Paragraph Class


Paragraph Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph Fields
Paragraph Class See Also Send Feedback

The Paragraph type exposes the following members.

Fields

 | Name | Description
Public field | ListItemType | Determine if the list element is a numbered list of bulleted list element
Public field | ParentContainer |

See Also

Paragraph Class


Paragraph.ListItemType Field

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..ListItemType Field
Paragraph Class See Also Send Feedback
Determine if the list element is a numbered list of bulleted list element

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ListItemType ListItemType
Visual Basic
Public ListItemType As ListItemType
Visual C++
public:
ListItemType ListItemType

Field Value

Type: ListItemType

See Also

Paragraph Class
Paragraph Members


Paragraph.ParentContainer Field

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..ParentContainer Field
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Paragraph.ParentContainer"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ContainerType ParentContainer
Visual Basic
Public ParentContainer As ContainerType
Visual C++
public:
ContainerType ParentContainer

Field Value

Type: ContainerType

See Also

Paragraph Class
Paragraph Members


Paragraph Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph Methods
Paragraph Class See Also Send Feedback

The Paragraph type exposes the following members.

Methods

 | Name | Description
Public method | Append | Append text to this Paragraph.
Public method | AppendDocProperty |
Public method | AppendEquation | Add an equation to a document.
Public method | AppendHyperlink | Append a hyperlink to a Paragraph.
Public method | AppendLine()()()() | Append a new line to this Paragraph.
Public method | AppendLine(String) | Append text on a new line to this Paragraph.
Public method | AppendPageCount | Append a PageCount place holder onto the end of a Paragraph.
Public method | AppendPageNumber | Append a PageNumber place holder onto the end of a Paragraph.
Public method | AppendPicture | Add an image to a document, create a custom view of that image (picture) and then insert it into a Paragraph using append.
Public method | Bold | For use with Append() and AppendLine()
Public method | CapsStyle | For use with Append() and AppendLine()
Public method | Color | For use with Append() and AppendLine()
Public method | Culture | For use with Append() and AppendLine()
Public method | CurentCulture | For use with Append() and AppendLine()
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | Find all instances of a string in this paragraph and return their indexes in a List.
Public method | FindAll(String, RegexOptions) | Find all instances of a string in this paragraph and return their indexes in a List.
Public method | FindAllByPattern | Find all unique instances of the given Regex Pattern
Public method | Font | For use with Append() and AppendLine()
Public method | FontSize | For use with Append() and AppendLine()
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | For use with Append() and AppendLine()
Public method | Highlight | For use with Append() and AppendLine()
Public method | InsertDocProperty | Insert a field of type document property, this field will display the custom property cp, at the end of this paragraph.
Public method | InsertHyperlink(Int32, Hyperlink) | Obsolete.
Public method | InsertHyperlink(Hyperlink, Int32) | This function inserts a hyperlink into a Paragraph at a specified character index.
Public method | InsertPageBreakAfterSelf | Insert a page break after a Paragraph. (Overrides InsertBeforeOrAfter..::..InsertPageBreakAfterSelf()()()().)
Public method | InsertPageBreakBeforeSelf | Insert a page break before a Paragraph. (Overrides InsertBeforeOrAfter..::..InsertPageBreakBeforeSelf()()()().)
Public method | InsertPageCount | Insert a PageCount place holder into a Paragraph. This place holder should only be inserted into a Header or Footer Paragraph. Word will not automatically update this field if it is inserted into a document level Paragraph.
Public method | InsertPageNumber | Insert a PageNumber place holder into a Paragraph. This place holder should only be inserted into a Header or Footer Paragraph. Word will not automatically update this field if it is inserted into a document level Paragraph.
Public method | InsertParagraphAfterSelf(String) | Insert a new Paragraph after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | Insert a Paragraph after this Paragraph, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | Insert a new Paragraph after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | Insert a new Paragraph after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | Insert a new Paragraph before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | Insert a Paragraph before this Paragraph, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | Insert a new Paragraph before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | Insert a new Paragraph before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertPicture | Insert a Picture into a Paragraph at the given text index. If not index is provided defaults to 0.
Public method | InsertTableAfterSelf(Table) | Insert a new Table after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | Insert a new Table into this document after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | Insert a new Table before this Paragraph, this Table can be from this document or another document. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | Insert a new Table into this document before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)
Public method | InsertText(String, Boolean, Formatting) | Inserts a specified instance of System.String into a Novacode.DocX.Paragraph at a specified index position.
Public method | InsertText(Int32, String, Boolean, Formatting) | Inserts a specified instance of System.String into a Novacode.DocX.Paragraph at a specified index position.
Public method | Italic | For use with Append() and AppendLine()
Public method | Kerning |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Misc | For use with Append() and AppendLine()
Public method | PercentageScale |
Public method | Position |
Public method | Remove | Remove this Paragraph from the document.
Public method | RemoveHyperlink | Remove the Hyperlink at the provided index. The first hyperlink is at index 0. Using a negative index or an index greater than the index of the last hyperlink will cause an ArgumentOutOfRangeException() to be thrown.
Public method | RemoveText(Int32, Boolean) | Removes characters from a Novacode.DocX.Paragraph.
Public method | RemoveText(Int32, Int32, Boolean) | Removes characters from a Novacode.DocX.Paragraph.
Public method | ReplaceText | Replaces all occurrences of a specified System.String in this instance, with another specified System.String.
Public method | Script | For use with Append() and AppendLine()
Public method | Spacing |
Public method | SpacingAfter |
Public method | SpacingBefore |
Public method | StrikeThrough | For use with Append() and AppendLine()
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnderlineColor | For use with Append() and AppendLine()
Public method | UnderlineStyle | For use with Append() and AppendLine()

See Also

Paragraph Class


Paragraph.Append Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Append Method
Paragraph Class Example See Also Send Feedback
Append text to this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Append(
    string text
)
Visual Basic
Public Function Append (
    text As String
) As Paragraph
Visual C++
public:
Paragraph^ Append(
    String^ text
)

Parameters

text
Type: System..::..String
The text to append.

Return Value

Type: Paragraph
This Paragraph with the new text appened.

Examples

Add a new Paragraph to this document and then append some text to it.
Copy image Copy
// Load a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph and Append some text to it.
    Paragraph p = document.InsertParagraph().Append("Hello World!!!");

    // Save this document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendDocProperty Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendDocProperty Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendDocProperty(
    CustomProperty cp,
    bool trackChanges = false,
    Formatting f = null
)
Visual Basic
Public Function AppendDocProperty (
    cp As CustomProperty,
    Optional trackChanges As Boolean = false,
    Optional f As Formatting = Nothing
) As Paragraph
Visual C++
public:
Paragraph^ AppendDocProperty(
    CustomProperty^ cp,
    bool trackChanges = false,
    Formatting^ f = nullptr
)

Parameters

cp
Type: Novacode..::..CustomProperty

[Missing <param name="cp"/> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

f (Optional)
Type: Novacode..::..Formatting

[Missing <param name="f"/> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendEquation Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendEquation Method
Paragraph Class Example See Also Send Feedback
Add an equation to a document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendEquation(
    string equation
)
Visual Basic
Public Function AppendEquation (
    equation As String
) As Paragraph
Visual C++
public:
Paragraph^ AppendEquation(
    String^ equation
)

Parameters

equation
Type: System..::..String
The Equation to append.

Return Value

Type: Paragraph
The Paragraph with the Equation now appended.

Examples

Add an equation to a document.
Copy image Copy
using (DocX document = DocX.Create("Test.docx"))
{
   // Add an equation to the document.
   document.AddEquation("x=y+z");

   // Save all changes made to this document.
   document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendHyperlink Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendHyperlink Method
Paragraph Class Example See Also Send Feedback
Append a hyperlink to a Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendHyperlink(
    Hyperlink h
)
Visual Basic
Public Function AppendHyperlink (
    h As Hyperlink
) As Paragraph
Visual C++
public:
Paragraph^ AppendHyperlink(
    Hyperlink^ h
)

Parameters

h
Type: Novacode..::..Hyperlink
The hyperlink to append.

Return Value

Type: Paragraph
The Paragraph with the hyperlink appended.

Examples

Creates a Paragraph with some text and a hyperlink.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
   // Add a hyperlink to this document.
   Hyperlink h = document.AddHyperlink("Google", new Uri("http://www.google.com"));

   // Add a new Paragraph to this document.
   Paragraph p = document.InsertParagraph();
   p.Append("My favourite search engine is ");
   p.AppendHyperlink(h);
   p.Append(", I think it's great.");

   // Save all changes made to this document.
   document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendLine Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendLine Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AppendLine()()()() | Append a new line to this Paragraph.
Public method | AppendLine(String) | Append text on a new line to this Paragraph.

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendLine Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendLine Method
Paragraph Class Example See Also Send Feedback
Append a new line to this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendLine()
Visual Basic
Public Function AppendLine As Paragraph
Visual C++
public:
Paragraph^ AppendLine()

Return Value

Type: Paragraph
This Paragraph with a new line appeneded.

Examples

Add a new Paragraph to this document and then append a new line to it.
Copy image Copy
// Load a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph and Append a new line with some text to it.
    Paragraph p = document.InsertParagraph().AppendLine();

    // Save this document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members
AppendLine Overload


Paragraph.AppendLine Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendLine Method (String)
Paragraph Class Example See Also Send Feedback
Append text on a new line to this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendLine(
    string text
)
Visual Basic
Public Function AppendLine (
    text As String
) As Paragraph
Visual C++
public:
Paragraph^ AppendLine(
    String^ text
)

Parameters

text
Type: System..::..String
The text to append.

Return Value

Type: Paragraph
This Paragraph with the new text appened.

Examples

Add a new Paragraph to this document and then append a new line with some text to it.
Copy image Copy
// Load a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph and Append a new line with some text to it.
    Paragraph p = document.InsertParagraph().AppendLine("Hello World!!!");

    // Save this document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members
AppendLine Overload


Paragraph.AppendPageCount Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendPageCount Method
Paragraph Class Example See Also Send Feedback
Append a PageCount place holder onto the end of a Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AppendPageCount(
    PageNumberFormat pnf
)
Visual Basic
Public Sub AppendPageCount (
    pnf As PageNumberFormat
)
Visual C++
public:
void AppendPageCount(
    PageNumberFormat pnf
)

Parameters

pnf
Type: Novacode..::..PageNumberFormat
The PageNumberFormat can be normal: (1, 2, ...) or Roman: (I, II, ...)

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Add Headers to the document.
    document.AddHeaders();

    // Get the default Header.
    Header header = document.Headers.odd;

    // Insert a Paragraph into the Header.
    Paragraph p0 = header.InsertParagraph();

    // Appemd place holders for PageNumber and PageCount into the Header.
    // Word will replace these with the correct value for each Page.
    p0.Append("Page (");
    p0.AppendPageNumber(PageNumberFormat.normal);
    p0.Append(" of ");
    p0.AppendPageCount(PageNumberFormat.normal);
    p0.Append(")");

    // Save the document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members
Novacode Namespace
Paragraph..::..AppendPageNumber(PageNumberFormat)
Paragraph..::..InsertPageNumber(PageNumberFormat, Int32)
Paragraph..::..InsertPageCount(PageNumberFormat, Int32)


Paragraph.AppendPageNumber Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendPageNumber Method
Paragraph Class Example See Also Send Feedback
Append a PageNumber place holder onto the end of a Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AppendPageNumber(
    PageNumberFormat pnf
)
Visual Basic
Public Sub AppendPageNumber (
    pnf As PageNumberFormat
)
Visual C++
public:
void AppendPageNumber(
    PageNumberFormat pnf
)

Parameters

pnf
Type: Novacode..::..PageNumberFormat
The PageNumberFormat can be normal: (1, 2, ...) or Roman: (I, II, ...)

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Add Headers to the document.
    document.AddHeaders();

    // Get the default Header.
    Header header = document.Headers.odd;

    // Insert a Paragraph into the Header.
    Paragraph p0 = header.InsertParagraph();

    // Appemd place holders for PageNumber and PageCount into the Header.
    // Word will replace these with the correct value for each Page.
    p0.Append("Page (");
    p0.AppendPageNumber(PageNumberFormat.normal);
    p0.Append(" of ");
    p0.AppendPageCount(PageNumberFormat.normal);
    p0.Append(")");

    // Save the document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members
Novacode Namespace
Paragraph..::..AppendPageCount(PageNumberFormat)
Paragraph..::..InsertPageNumber(PageNumberFormat, Int32)
Paragraph..::..InsertPageCount(PageNumberFormat, Int32)


Paragraph.AppendPicture Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendPicture Method
Paragraph Class Example See Also Send Feedback
Add an image to a document, create a custom view of that image (picture) and then insert it into a Paragraph using append.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendPicture(
    Picture p
)
Visual Basic
Public Function AppendPicture (
    p As Picture
) As Paragraph
Visual C++
public:
Paragraph^ AppendPicture(
    Picture^ p
)

Parameters

p
Type: Novacode..::..Picture
The Picture to append.

Return Value

Type: Paragraph
The Paragraph with the Picture now appended.

Examples

Add an image to a document, create a custom view of that image (picture) and then insert it into a Paragraph using append.
Copy image Copy
using (DocX document = DocX.Create("Test.docx"))
{
   // Add an image to the document.
   Image     i = document.AddImage(@"Image.jpg");

   // Create a picture i.e. (A custom view of an image)
   Picture   p = i.CreatePicture();
   p.FlipHorizontal = true;
   p.Rotation = 10;

   // Create a new Paragraph.
   Paragraph par = document.InsertParagraph();

   // Append content to the Paragraph.
   par.Append("Here is a cool picture")
      .AppendPicture(p)
      .Append(" don't you think so?");

   // Save all changes made to this document.
   document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.Bold Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Bold Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Bold()
Visual Basic
Public Function Bold As Paragraph
Visual C++
public:
Paragraph^ Bold()

Return Value

Type: Paragraph
This Paragraph with the last appended text bold.

Examples

Append text to this Paragraph and then make it bold.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("Bold").Bold()
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.CapsStyle Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..CapsStyle Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph CapsStyle(
    CapsStyle capsStyle
)
Visual Basic
Public Function CapsStyle (
    capsStyle As CapsStyle
) As Paragraph
Visual C++
public:
Paragraph^ CapsStyle(
    CapsStyle capsStyle
)

Parameters

capsStyle
Type: Novacode..::..CapsStyle
The caps style to apply to the last appended text.

Return Value

Type: Paragraph
This Paragraph with the last appended text's caps style changed.

Examples

Append text to this Paragraph and then set it to full caps.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("Capitalized").CapsStyle(CapsStyle.caps)
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.Color Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Color Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Color(
    Color c
)
Visual Basic
Public Function Color (
    c As Color
) As Paragraph
Visual C++
public:
Paragraph^ Color(
    Color c
)

Parameters

c
Type: System.Drawing..::..Color
A color to use on the appended text.

Return Value

Type: Paragraph
This Paragraph with the last appended text colored.

Examples

Append text to this Paragraph and then color it.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("Blue").Color(Color.Blue)
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.Culture Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Culture Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Culture(
    CultureInfo culture
)
Visual Basic
Public Function Culture (
    culture As CultureInfo
) As Paragraph
Visual C++
public:
Paragraph^ Culture(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::..CultureInfo
The CultureInfo for text

Return Value

Type: Paragraph
This Paragraph in curent culture

Examples

Add a new Paragraph with russian text to this document and then set language of text to local culture.
Copy image Copy
// Load a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph with russian text and set specific culture to it.
    Paragraph p = document.InsertParagraph("Привет мир").Culture(CultureInfo.CreateSpecificCulture("ru-RU"));

    // Save this document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.CurentCulture Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..CurentCulture Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph CurentCulture()
Visual Basic
Public Function CurentCulture As Paragraph
Visual C++
public:
Paragraph^ CurentCulture()

Return Value

Type: Paragraph
This Paragraph in curent culture

Examples

Add a new Paragraph with russian text to this document and then set language of text to local culture.
Copy image Copy
// Load a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph with russian text and set curent local culture to it.
    Paragraph p = document.InsertParagraph("Привет мир!").CurentCulture();

    // Save this document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.FindAll Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FindAll Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindAll(String) | Find all instances of a string in this paragraph and return their indexes in a List.
Public method | FindAll(String, RegexOptions) | Find all instances of a string in this paragraph and return their indexes in a List.

See Also

Paragraph Class
Paragraph Members


Paragraph.FindAll Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FindAll Method (String)
Paragraph Class Example See Also Send Feedback
Find all instances of a string in this paragraph and return their indexes in a List.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<int> FindAll(
    string str
)
Visual Basic
Public Function FindAll (
    str As String
) As List(Of Integer)
Visual C++
public:
List<int>^ FindAll(
    String^ str
)

Parameters

str
Type: System..::..String
The string to find

Return Value

Type: List <(Of <(<' Int32 >)>)>
A list of indexes.

Examples

Find all instances of Hello in this document and insert 'don't' in frount of them.
Copy image Copy
// Load a document
using (DocX document = DocX.Load(@"Test.docx"))
{
    // Loop through the paragraphs in this document.
    foreach(Paragraph p in document.Paragraphs)
    {
        // Find all instances of 'go' in this paragraph.
        List<int> gos = document.FindAll("go");

        /*
         * Insert 'don't' in frount of every instance of 'go' in this document to produce 'don't go'.
         * An important trick here is to do the inserting in reverse document order. If you inserted
         * in document order, every insert would shift the index of the remaining matches.
         */
        gos.Reverse();
        foreach (int index in gos)
        {
            p.InsertText(index, "don't ", false);
        }
    }

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
FindAll Overload


Paragraph.FindAll Method (String, RegexOptions)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FindAll Method (String, RegexOptions)
Paragraph Class Example See Also Send Feedback
Find all instances of a string in this paragraph and return their indexes in a List.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<int> FindAll(
    string str,
    RegexOptions options
)
Visual Basic
Public Function FindAll (
    str As String,
    options As RegexOptions
) As List(Of Integer)
Visual C++
public:
List<int>^ FindAll(
    String^ str,
    RegexOptions options
)

Parameters

str
Type: System..::..String
The string to find
options
Type: System.Text.RegularExpressions..::..RegexOptions
The options to use when finding a string match.

Return Value

Type: List <(Of <(<' Int32 >)>)>
A list of indexes.

Examples

Find all instances of Hello in this document and insert 'don't' in frount of them.
Copy image Copy
// Load a document
using (DocX document = DocX.Load(@"Test.docx"))
{
    // Loop through the paragraphs in this document.
    foreach(Paragraph p in document.Paragraphs)
    {
        // Find all instances of 'go' in this paragraph (Ignore case).
        List<int> gos = document.FindAll("go", RegexOptions.IgnoreCase);

        /*
         * Insert 'don't' in frount of every instance of 'go' in this document to produce 'don't go'.
         * An important trick here is to do the inserting in reverse document order. If you inserted
         * in document order, every insert would shift the index of the remaining matches.
         */
        gos.Reverse();
        foreach (int index in gos)
        {
            p.InsertText(index, "don't ", false);
        }
    }

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
FindAll Overload


Paragraph.FindAllByPattern Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FindAllByPattern Method
Paragraph Class See Also Send Feedback
Find all unique instances of the given Regex Pattern

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<string> FindAllByPattern(
    string str,
    RegexOptions options
)
Visual Basic
Public Function FindAllByPattern (
    str As String,
    options As RegexOptions
) As List(Of String)
Visual C++
public:
List<String^>^ FindAllByPattern(
    String^ str,
    RegexOptions options
)

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressions..::..RegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List <(Of <(<' String >)>)>

[Missing <returns> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Font Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Font Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Font(
    FontFamily fontFamily
)
Visual Basic
Public Function Font (
    fontFamily As FontFamily
) As Paragraph
Visual C++
public:
Paragraph^ Font(
    FontFamily^ fontFamily
)

Parameters

fontFamily
Type: System.Drawing..::..FontFamily
The font to use for the appended text.

Return Value

Type: Paragraph
This Paragraph with the last appended text's font changed.

Examples

Append text to this Paragraph and then change its font.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("Times new roman").Font(new FontFamily("Times new roman"))
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.FontSize Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FontSize Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph FontSize(
    double fontSize
)
Visual Basic
Public Function FontSize (
    fontSize As Double
) As Paragraph
Visual C++
public:
Paragraph^ FontSize(
    double fontSize
)

Parameters

fontSize
Type: System..::..Double
The font size to use for the appended text.

Return Value

Type: Paragraph
This Paragraph with the last appended text resized.

Examples

Append text to this Paragraph and then resize it.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("Big").FontSize(20)
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.Hide Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Hide Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Hide()
Visual Basic
Public Function Hide As Paragraph
Visual C++
public:
Paragraph^ Hide()

Return Value

Type: Paragraph
This Paragraph with the last appended text hidden.

Examples

Append text to this Paragraph and then hide it.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("hidden").Hide()
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.Highlight Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Highlight Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Highlight(
    Highlight highlight
)
Visual Basic
Public Function Highlight (
    highlight As Highlight
) As Paragraph
Visual C++
public:
Paragraph^ Highlight(
    Highlight highlight
)

Parameters

highlight
Type: Novacode..::..Highlight
The highlight to apply to the last appended text.

Return Value

Type: Paragraph
This Paragraph with the last appended text highlighted.

Examples

Append text to this Paragraph and then highlight it.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("highlighted").Highlight(Highlight.green)
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertDocProperty Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertDocProperty Method
Paragraph Class Example See Also Send Feedback
Insert a field of type document property, this field will display the custom property cp, at the end of this paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public DocProperty InsertDocProperty(
    CustomProperty cp,
    bool trackChanges = false,
    Formatting f = null
)
Visual Basic
Public Function InsertDocProperty (
    cp As CustomProperty,
    Optional trackChanges As Boolean = false,
    Optional f As Formatting = Nothing
) As DocProperty
Visual C++
public:
DocProperty^ InsertDocProperty(
    CustomProperty^ cp,
    bool trackChanges = false,
    Formatting^ f = nullptr
)

Parameters

cp
Type: Novacode..::..CustomProperty
The custom property to display.
trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

f (Optional)
Type: Novacode..::..Formatting
The formatting to use for this text.

Return Value

Type: DocProperty

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Examples

Create, add and display a custom property in a document.
Copy image Copy
// Load a document
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Create a custom property.
    CustomProperty name = new CustomProperty("name", "Cathal Coffey");

    // Add this custom property to this document.
    document.AddCustomProperty(name);

    // Create a text formatting.
    Formatting f = new Formatting();
    f.Bold = true;
    f.Size = 14;
    f.StrikeThrough = StrickThrough.strike;

    // Insert a new paragraph.
    Paragraph p = document.InsertParagraph("Author: ", false, f);

    // Insert a field of type document property to display the custom property name and track this change.
    p.InsertDocProperty(name, true, f);

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertHyperlink Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertHyperlink Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertHyperlink(Int32, Hyperlink) | Obsolete.
Public method | InsertHyperlink(Hyperlink, Int32) | This function inserts a hyperlink into a Paragraph at a specified character index.

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertHyperlink Method (Int32, Hyperlink)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertHyperlink Method (Int32, Hyperlink)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
[ObsoleteAttribute("Instead use: InsertHyperlink(Hyperlink h, int index)")]
public Paragraph InsertHyperlink(
    int index,
    Hyperlink h
)
Visual Basic
<ObsoleteAttribute("Instead use: InsertHyperlink(Hyperlink h, int index)")>
Public Function InsertHyperlink (
    index As Integer,
    h As Hyperlink
) As Paragraph
Visual C++
public:
[ObsoleteAttribute(L"Instead use: InsertHyperlink(Hyperlink h, int index)")]
Paragraph^ InsertHyperlink(
    int index,
    Hyperlink^ h
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

h
Type: Novacode..::..Hyperlink

[Missing <param name="h"/> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

See Also

Paragraph Class
Paragraph Members
InsertHyperlink Overload


Paragraph.InsertHyperlink Method (Hyperlink, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertHyperlink Method (Hyperlink, Int32)
Paragraph Class See Also Send Feedback
This function inserts a hyperlink into a Paragraph at a specified character index.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph InsertHyperlink(
    Hyperlink h,
    int index = 0
)
Visual Basic
Public Function InsertHyperlink (
    h As Hyperlink,
    Optional index As Integer = 0
) As Paragraph
Visual C++
public:
Paragraph^ InsertHyperlink(
    Hyperlink^ h,
    int index = 0
)

Parameters

h
Type: Novacode..::..Hyperlink
The hyperlink to insert.
index (Optional)
Type: System..::..Int32
The index to insert at.

Return Value

Type: Paragraph
The Paragraph with the Hyperlink inserted at the specified index.

See Also

Paragraph Class
Paragraph Members
InsertHyperlink Overload


Paragraph.InsertPageBreakAfterSelf Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertPageBreakAfterSelf Method
Paragraph Class Example See Also Send Feedback
Insert a page break after a Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override void InsertPageBreakAfterSelf()
Visual Basic
Public Overrides Sub InsertPageBreakAfterSelf
Visual C++
public:
virtual void InsertPageBreakAfterSelf() override

Examples

Insert 2 Paragraphs into a document with a page break between them.
Copy image Copy
using (DocX document = DocX.Create(@"Test.docx"))
{
   // Insert a new Paragraph.
   Paragraph p1 = document.InsertParagraph("Paragraph 1", false);

   // Insert a page break after this Paragraph.
   p1.InsertPageBreakAfterSelf();

   // Insert a new Paragraph.
   Paragraph p2 = document.InsertParagraph("Paragraph 2", false);

   // Save this document.
   document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertPageBreakBeforeSelf Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertPageBreakBeforeSelf Method
Paragraph Class Example See Also Send Feedback
Insert a page break before a Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override void InsertPageBreakBeforeSelf()
Visual Basic
Public Overrides Sub InsertPageBreakBeforeSelf
Visual C++
public:
virtual void InsertPageBreakBeforeSelf() override

Examples

Insert 2 Paragraphs into a document with a page break between them.
Copy image Copy
using (DocX document = DocX.Create(@"Test.docx"))
{
   // Insert a new Paragraph.
   Paragraph p1 = document.InsertParagraph("Paragraph 1", false);

   // Insert a new Paragraph.
   Paragraph p2 = document.InsertParagraph("Paragraph 2", false);

   // Insert a page break before Paragraph two.
   p2.InsertPageBreakBeforeSelf();

   // Save this document.
   document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertPageCount Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertPageCount Method
Paragraph Class Example See Also Send Feedback
Insert a PageCount place holder into a Paragraph. This place holder should only be inserted into a Header or Footer Paragraph. Word will not automatically update this field if it is inserted into a document level Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertPageCount(
    PageNumberFormat pnf,
    int index = 0
)
Visual Basic
Public Sub InsertPageCount (
    pnf As PageNumberFormat,
    Optional index As Integer = 0
)
Visual C++
public:
void InsertPageCount(
    PageNumberFormat pnf,
    int index = 0
)

Parameters

pnf
Type: Novacode..::..PageNumberFormat
The PageNumberFormat can be normal: (1, 2, ...) or Roman: (I, II, ...)
index (Optional)
Type: System..::..Int32
The text index to insert this PageCount place holder at.

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Add Headers to the document.
    document.AddHeaders();

    // Get the default Header.
    Header header = document.Headers.odd;

    // Insert a Paragraph into the Header.
    Paragraph p0 = header.InsertParagraph("Page ( of )");

    // Insert place holders for PageNumber and PageCount into the Header.
    // Word will replace these with the correct value for each Page.
    p0.InsertPageNumber(PageNumberFormat.normal, 6);
    p0.InsertPageCount(PageNumberFormat.normal, 11);

    // Save the document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members
Novacode Namespace
Paragraph..::..AppendPageCount(PageNumberFormat)
Paragraph..::..AppendPageNumber(PageNumberFormat)
Paragraph..::..InsertPageNumber(PageNumberFormat, Int32)


Paragraph.InsertPageNumber Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertPageNumber Method
Paragraph Class Example See Also Send Feedback
Insert a PageNumber place holder into a Paragraph. This place holder should only be inserted into a Header or Footer Paragraph. Word will not automatically update this field if it is inserted into a document level Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertPageNumber(
    PageNumberFormat pnf,
    int index = 0
)
Visual Basic
Public Sub InsertPageNumber (
    pnf As PageNumberFormat,
    Optional index As Integer = 0
)
Visual C++
public:
void InsertPageNumber(
    PageNumberFormat pnf,
    int index = 0
)

Parameters

pnf
Type: Novacode..::..PageNumberFormat
The PageNumberFormat can be normal: (1, 2, ...) or Roman: (I, II, ...)
index (Optional)
Type: System..::..Int32
The text index to insert this PageNumber place holder at.

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Add Headers to the document.
    document.AddHeaders();

    // Get the default Header.
    Header header = document.Headers.odd;

    // Insert a Paragraph into the Header.
    Paragraph p0 = header.InsertParagraph("Page ( of )");

    // Insert place holders for PageNumber and PageCount into the Header.
    // Word will replace these with the correct value for each Page.
    p0.InsertPageNumber(PageNumberFormat.normal, 6);
    p0.InsertPageCount(PageNumberFormat.normal, 11);

    // Save the document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members
Novacode Namespace
Paragraph..::..AppendPageCount(PageNumberFormat)
Paragraph..::..AppendPageNumber(PageNumberFormat)
Paragraph..::..InsertPageCount(PageNumberFormat, Int32)


Paragraph.InsertParagraphAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphAfterSelf Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphAfterSelf(String) | Insert a new Paragraph after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | Insert a Paragraph after this Paragraph, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | Insert a new Paragraph after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | Insert a new Paragraph after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertParagraphAfterSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphAfterSelf Method (String)
Paragraph Class Example See Also Send Feedback
Insert a new Paragraph after this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.

Return Value

Type: Paragraph
A new Paragraph inserted after this Paragraph.

Examples

Insert a new paragraph after the first Paragraph in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Paragraph into this document.
    Paragraph p = document.InsertParagraph("I am a Paragraph", false);

    p.InsertParagraphAfterSelf("I was inserted after the previous Paragraph.");

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Paragraph Class
Paragraph Members
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphAfterSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphAfterSelf Method (Paragraph)
Paragraph Class Example See Also Send Feedback
Insert a Paragraph after this Paragraph, this Paragraph may have come from the same or another document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    Paragraph^ p
) override

Parameters

p
Type: Novacode..::..Paragraph
The Paragraph to insert.

Return Value

Type: Paragraph
The Paragraph now associated with this document.

Examples

Take a Paragraph from document a, and insert it into document b after this Paragraph.
Copy image Copy
// Place holder for a Paragraph.
Paragraph p;

// Load document a.
using (DocX documentA = DocX.Load(@"a.docx"))
{
    // Get the first paragraph from this document.
    p = documentA.Paragraphs[0];
}

// Load document b.
using (DocX documentB = DocX.Load(@"b.docx"))
{
    // Get the first Paragraph in document b.
    Paragraph p2 = documentB.Paragraphs[0];

    // Insert the Paragraph from document a after this Paragraph.
    Paragraph newParagraph = p2.InsertParagraphAfterSelf(p);

    // Save all changes made to document b.
    documentB.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphAfterSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphAfterSelf Method (String, Boolean)
Paragraph Class Example See Also Send Feedback
Insert a new Paragraph after this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.
trackChanges
Type: System..::..Boolean
Should this insertion be tracked as a change?

Return Value

Type: Paragraph
A new Paragraph inserted after this Paragraph.

Examples

Insert a new paragraph after the first Paragraph in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Paragraph into this document.
    Paragraph p = document.InsertParagraph("I am a Paragraph", false);

    p.InsertParagraphAfterSelf("I was inserted after the previous Paragraph.", false);

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Paragraph Class
Paragraph Members
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphAfterSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphAfterSelf Method (String, Boolean, Formatting)
Paragraph Class Example See Also Send Feedback
Insert a new Paragraph after this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.
trackChanges
Type: System..::..Boolean
Should this insertion be tracked as a change?
formatting
Type: Novacode..::..Formatting
The formatting to apply to this insertion.

Return Value

Type: Paragraph
A new Paragraph inserted after this Paragraph.

Examples

Insert a new paragraph after the first Paragraph in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Paragraph into this document.
    Paragraph p = document.InsertParagraph("I am a Paragraph", false);

    Formatting boldFormatting = new Formatting();
    boldFormatting.Bold = true;

    p.InsertParagraphAfterSelf("I was inserted after the previous Paragraph.", false, boldFormatting);

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Paragraph Class
Paragraph Members
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphBeforeSelf Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphBeforeSelf(String) | Insert a new Paragraph before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | Insert a Paragraph before this Paragraph, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | Insert a new Paragraph before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | Insert a new Paragraph before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertParagraphBeforeSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphBeforeSelf Method (String)
Paragraph Class Example See Also Send Feedback
Insert a new Paragraph before this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.

Return Value

Type: Paragraph
A new Paragraph inserted before this Paragraph.

Examples

Insert a new paragraph before the first Paragraph in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Paragraph into this document.
    Paragraph p = document.InsertParagraph("I am a Paragraph", false);

    p.InsertParagraphBeforeSelf("I was inserted before the next Paragraph.");

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Paragraph Class
Paragraph Members
InsertParagraphBeforeSelf Overload


Paragraph.InsertParagraphBeforeSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphBeforeSelf Method (Paragraph)
Paragraph Class Example See Also Send Feedback
Insert a Paragraph before this Paragraph, this Paragraph may have come from the same or another document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    Paragraph^ p
) override

Parameters

p
Type: Novacode..::..Paragraph
The Paragraph to insert.

Return Value

Type: Paragraph
The Paragraph now associated with this document.

Examples

Take a Paragraph from document a, and insert it into document b before this Paragraph.
Copy image Copy
// Place holder for a Paragraph.
Paragraph p;

// Load document a.
using (DocX documentA = DocX.Load(@"a.docx"))
{
    // Get the first paragraph from this document.
    p = documentA.Paragraphs[0];
}

// Load document b.
using (DocX documentB = DocX.Load(@"b.docx"))
{
    // Get the first Paragraph in document b.
    Paragraph p2 = documentB.Paragraphs[0];

    // Insert the Paragraph from document a before this Paragraph.
    Paragraph newParagraph = p2.InsertParagraphBeforeSelf(p);

    // Save all changes made to document b.
    documentB.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
InsertParagraphBeforeSelf Overload


Paragraph.InsertParagraphBeforeSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphBeforeSelf Method (String, Boolean)
Paragraph Class Example See Also Send Feedback
Insert a new Paragraph before this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.
trackChanges
Type: System..::..Boolean
Should this insertion be tracked as a change?

Return Value

Type: Paragraph
A new Paragraph inserted before this Paragraph.

Examples

Insert a new paragraph before the first Paragraph in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Paragraph into this document.
    Paragraph p = document.InsertParagraph("I am a Paragraph", false);

    p.InsertParagraphBeforeSelf("I was inserted before the next Paragraph.", false);

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Paragraph Class
Paragraph Members
InsertParagraphBeforeSelf Overload


Paragraph.InsertParagraphBeforeSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphBeforeSelf Method (String, Boolean, Formatting)
Paragraph Class Example See Also Send Feedback
Insert a new Paragraph before this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.
trackChanges
Type: System..::..Boolean
Should this insertion be tracked as a change?
formatting
Type: Novacode..::..Formatting
The formatting to apply to this insertion.

Return Value

Type: Paragraph
A new Paragraph inserted before this Paragraph.

Examples

Insert a new paragraph before the first Paragraph in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Paragraph into this document.
    Paragraph p = document.InsertParagraph("I am a Paragraph", false);

    Formatting boldFormatting = new Formatting();
    boldFormatting.Bold = true;

    p.InsertParagraphBeforeSelf("I was inserted before the next Paragraph.", false, boldFormatting);

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Paragraph Class
Paragraph Members
InsertParagraphBeforeSelf Overload


Paragraph.InsertPicture Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertPicture Method
Paragraph Class Example See Also Send Feedback
Insert a Picture into a Paragraph at the given text index. If not index is provided defaults to 0.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph InsertPicture(
    Picture p,
    int index = 0
)
Visual Basic
Public Function InsertPicture (
    p As Picture,
    Optional index As Integer = 0
) As Paragraph
Visual C++
public:
Paragraph^ InsertPicture(
    Picture^ p,
    int index = 0
)

Parameters

p
Type: Novacode..::..Picture
The Picture to insert.
index (Optional)
Type: System..::..Int32
The text index to insert at.

Return Value

Type: Paragraph
The modified Paragraph.

Examples

Copy image Copy
Load test document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Add Headers and Footers into this document.
    document.AddHeaders();
    document.AddFooters();
    document.DifferentFirstPage = true;
    document.DifferentOddAndEvenPages = true;

    // Add an Image to this document.
    Novacode.Image img = document.AddImage(directory_documents + "purple.png");

    // Create a Picture from this Image.
    Picture pic = img.CreatePicture();

    // Main document.
    Paragraph p0 = document.InsertParagraph("Hello");
    p0.InsertPicture(pic, 3);

    // Header first.
    Paragraph p1 = document.Headers.first.InsertParagraph("----");
    p1.InsertPicture(pic, 2);

    // Header odd.
    Paragraph p2 = document.Headers.odd.InsertParagraph("----");
    p2.InsertPicture(pic, 2);

    // Header even.
    Paragraph p3 = document.Headers.even.InsertParagraph("----");
    p3.InsertPicture(pic, 2);

    // Footer first.
    Paragraph p4 = document.Footers.first.InsertParagraph("----");
    p4.InsertPicture(pic, 2);

    // Footer odd.
    Paragraph p5 = document.Footers.odd.InsertParagraph("----");
    p5.InsertPicture(pic, 2);

    // Footer even.
    Paragraph p6 = document.Footers.even.InsertParagraph("----");
    p6.InsertPicture(pic, 2);

    // Save this document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertTableAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableAfterSelf Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableAfterSelf(Table) | Insert a new Table after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | Insert a new Table into this document after this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertTableAfterSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableAfterSelf Method (Table)
Paragraph Class Example See Also Send Feedback
Insert a new Table after this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableAfterSelf(
    Table t
)
Visual Basic
Public Overrides Function InsertTableAfterSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    Table^ t
) override

Parameters

t
Type: Novacode..::..Table
The Table t to be inserted.

Return Value

Type: Table
A new Table inserted after this Paragraph.

Examples

Insert a new Table after this Paragraph.
Copy image Copy
// Place holder for a Table.
Table t;

// Load document a.
using (DocX documentA = DocX.Load(@"a.docx"))
{
    // Get the first Table from this document.
    t = documentA.Tables[0];
}

// Load document b.
using (DocX documentB = DocX.Load(@"b.docx"))
{
    // Get the first Paragraph in document b.
    Paragraph p2 = documentB.Paragraphs[0];

    // Insert the Table from document a after this Paragraph.
    Table newTable = p2.InsertTableAfterSelf(t);

    // Save all changes made to document b.
    documentB.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
InsertTableAfterSelf Overload


Paragraph.InsertTableAfterSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableAfterSelf Method (Int32, Int32)
Paragraph Class Example See Also Send Feedback
Insert a new Table into this document after this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overrides Function InsertTableAfterSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    int rowCount,
    int columnCount
) override

Parameters

rowCount
Type: System..::..Int32
The number of rows this Table should have.
columnCount
Type: System..::..Int32
The number of columns this Table should have.

Return Value

Type: Table
A new Table inserted after this Paragraph.

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    //Insert a Paragraph into this document.
    Paragraph p = document.InsertParagraph("Hello World", false);

    // Insert a new Table after this Paragraph.
    Table newTable = p.InsertTableAfterSelf(2, 2);
    newTable.Design = TableDesign.LightShadingAccent2;
    newTable.Alignment = Alignment.center;

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
InsertTableAfterSelf Overload


Paragraph.InsertTableBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableBeforeSelf Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableBeforeSelf(Table) | Insert a new Table before this Paragraph, this Table can be from this document or another document. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | Insert a new Table into this document before this Paragraph. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertTableBeforeSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableBeforeSelf Method (Table)
Paragraph Class Example See Also Send Feedback
Insert a new Table before this Paragraph, this Table can be from this document or another document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableBeforeSelf(
    Table t
)
Visual Basic
Public Overrides Function InsertTableBeforeSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    Table^ t
) override

Parameters

t
Type: Novacode..::..Table
The Table t to be inserted.

Return Value

Type: Table
A new Table inserted before this Paragraph.

Examples

Insert a new Table before this Paragraph.
Copy image Copy
// Place holder for a Table.
Table t;

// Load document a.
using (DocX documentA = DocX.Load(@"a.docx"))
{
    // Get the first Table from this document.
    t = documentA.Tables[0];
}

// Load document b.
using (DocX documentB = DocX.Load(@"b.docx"))
{
    // Get the first Paragraph in document b.
    Paragraph p2 = documentB.Paragraphs[0];

    // Insert the Table from document a before this Paragraph.
    Table newTable = p2.InsertTableBeforeSelf(t);

    // Save all changes made to document b.
    documentB.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
InsertTableBeforeSelf Overload


Paragraph.InsertTableBeforeSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableBeforeSelf Method (Int32, Int32)
Paragraph Class Example See Also Send Feedback
Insert a new Table into this document before this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overrides Function InsertTableBeforeSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    int rowCount,
    int columnCount
) override

Parameters

rowCount
Type: System..::..Int32
The number of rows this Table should have.
columnCount
Type: System..::..Int32
The number of columns this Table should have.

Return Value

Type: Table
A new Table inserted before this Paragraph.

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    //Insert a Paragraph into this document.
    Paragraph p = document.InsertParagraph("Hello World", false);

    // Insert a new Table before this Paragraph.
    Table newTable = p.InsertTableBeforeSelf(2, 2);
    newTable.Design = TableDesign.LightShadingAccent2;
    newTable.Alignment = Alignment.center;

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
InsertTableBeforeSelf Overload


Paragraph.InsertText Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertText Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertText(String, Boolean, Formatting) | Inserts a specified instance of System.String into a Novacode.DocX.Paragraph at a specified index position.
Public method | InsertText(Int32, String, Boolean, Formatting) | Inserts a specified instance of System.String into a Novacode.DocX.Paragraph at a specified index position.

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertText Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertText Method (String, Boolean, Formatting)
Paragraph Class Example See Also Send Feedback
Inserts a specified instance of System.String into a Novacode.DocX.Paragraph at a specified index position.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertText(
    string value,
    bool trackChanges = false,
    Formatting formatting = null
)
Visual Basic
Public Sub InsertText (
    value As String,
    Optional trackChanges As Boolean = false,
    Optional formatting As Formatting = Nothing
)
Visual C++
public:
void InsertText(
    String^ value,
    bool trackChanges = false,
    Formatting^ formatting = nullptr
)

Parameters

value
Type: System..::..String
The System.String to insert.
trackChanges (Optional)
Type: System..::..Boolean
Flag this insert as a change.
formatting (Optional)
Type: Novacode..::..Formatting
The text formatting.

Examples

Copy image Copy
// Create a document using a relative filename.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Create a text formatting.
    Formatting f = new Formatting();
    f.FontColor = Color.Red;
    f.Size = 30;

    // Iterate through the Paragraphs in this document.
    foreach (Paragraph p in document.Paragraphs)
    {
        // Insert the string "Start: " at the begining of every Paragraph and flag it as a change.
        p.InsertText("Start: ", true, f);
    }

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

Examples

Inserting tabs using the \t switch.
Copy image Copy
// Create a document using a relative filename.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
     // Create a text formatting.
     Formatting f = new Formatting();
     f.FontColor = Color.Red;
     f.Size = 30;

     // Iterate through the paragraphs in this document.
     foreach (Paragraph p in document.Paragraphs)
     {
         // Insert the string "\tEnd" at the end of every paragraph and flag it as a change.
         p.InsertText("\tEnd", true, f);
     }

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
InsertText Overload
Novacode Namespace
Paragraph..::..RemoveText(Int32, Boolean)
Paragraph..::..RemoveText(Int32, Int32, Boolean)
[!:Paragraph.ReplaceText(string, string, bool)]
[!:Paragraph.ReplaceText(string, string, bool, RegexOptions)]


Paragraph.InsertText Method (Int32, String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertText Method (Int32, String, Boolean, Formatting)
Paragraph Class Example See Also Send Feedback
Inserts a specified instance of System.String into a Novacode.DocX.Paragraph at a specified index position.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertText(
    int index,
    string value,
    bool trackChanges = false,
    Formatting formatting = null
)
Visual Basic
Public Sub InsertText (
    index As Integer,
    value As String,
    Optional trackChanges As Boolean = false,
    Optional formatting As Formatting = Nothing
)
Visual C++
public:
void InsertText(
    int index,
    String^ value,
    bool trackChanges = false,
    Formatting^ formatting = nullptr
)

Parameters

index
Type: System..::..Int32
The index position of the insertion.
value
Type: System..::..String
The System.String to insert.
trackChanges (Optional)
Type: System..::..Boolean
Flag this insert as a change.
formatting (Optional)
Type: Novacode..::..Formatting
The text formatting.

Examples

Copy image Copy
// Create a document using a relative filename.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Create a text formatting.
    Formatting f = new Formatting();
    f.FontColor = Color.Red;
    f.Size = 30;

    // Iterate through the Paragraphs in this document.
    foreach (Paragraph p in document.Paragraphs)
    {
        // Insert the string "Start: " at the begining of every Paragraph and flag it as a change.
        p.InsertText(0, "Start: ", true, f);
    }

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

Examples

Inserting tabs using the \t switch.
Copy image Copy
// Create a document using a relative filename.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Create a text formatting.
    Formatting f = new Formatting();
    f.FontColor = Color.Red;
    f.Size = 30;

    // Iterate through the paragraphs in this document.
    foreach (Paragraph p in document.Paragraphs)
    {
        // Insert the string "\tStart:\t" at the begining of every paragraph and flag it as a change.
        p.InsertText(0, "\tStart:\t", true, f);
    }

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
InsertText Overload
Novacode Namespace
Paragraph..::..RemoveText(Int32, Boolean)
Paragraph..::..RemoveText(Int32, Int32, Boolean)
[!:Paragraph.ReplaceText(string, string, bool)]
[!:Paragraph.ReplaceText(string, string, bool, RegexOptions)]


Paragraph.Italic Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Italic Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Italic()
Visual Basic
Public Function Italic As Paragraph
Visual C++
public:
Paragraph^ Italic()

Return Value

Type: Paragraph
This Paragraph with the last appended text italic.

Examples

Append text to this Paragraph and then make it italic.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("Italic").Italic()
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.Kerning Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Kerning Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Kerning(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Kerning(
    int kerning
)
Visual Basic
Public Function Kerning (
    kerning As Integer
) As Paragraph
Visual C++
public:
Paragraph^ Kerning(
    int kerning
)

Parameters

kerning
Type: System..::..Int32

[Missing <param name="kerning"/> documentation for "M:Novacode.Paragraph.Kerning(System.Int32)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Kerning(System.Int32)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Misc Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Misc Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Misc(
    Misc misc
)
Visual Basic
Public Function Misc (
    misc As Misc
) As Paragraph
Visual C++
public:
Paragraph^ Misc(
    Misc misc
)

Parameters

misc
Type: Novacode..::..Misc
The miscellaneous property to set.

Return Value

Type: Paragraph
This Paragraph with the last appended text changed by a miscellaneous property.

Examples

Append text to this Paragraph and then apply a miscellaneous property.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("outlined").Misc(Misc.outline)
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.PercentageScale Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..PercentageScale Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.PercentageScale(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph PercentageScale(
    int percentageScale
)
Visual Basic
Public Function PercentageScale (
    percentageScale As Integer
) As Paragraph
Visual C++
public:
Paragraph^ PercentageScale(
    int percentageScale
)

Parameters

percentageScale
Type: System..::..Int32

[Missing <param name="percentageScale"/> documentation for "M:Novacode.Paragraph.PercentageScale(System.Int32)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.PercentageScale(System.Int32)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Position Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Position Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Position(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Position(
    double position
)
Visual Basic
Public Function Position (
    position As Double
) As Paragraph
Visual C++
public:
Paragraph^ Position(
    double position
)

Parameters

position
Type: System..::..Double

[Missing <param name="position"/> documentation for "M:Novacode.Paragraph.Position(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Position(System.Double)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Remove Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Remove Method
Paragraph Class Example See Also Send Feedback
Remove this Paragraph from the document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Remove(
    bool trackChanges
)
Visual Basic
Public Sub Remove (
    trackChanges As Boolean
)
Visual C++
public:
void Remove(
    bool trackChanges
)

Parameters

trackChanges
Type: System..::..Boolean
Should this remove be tracked as a change?

Examples

Remove a Paragraph from a document and track it as a change.
Copy image Copy
// Create a document using a relative filename.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Create and Insert a new Paragraph into this document.
    Paragraph p = document.InsertParagraph("Hello", false);

    // Remove the Paragraph and track this as a change.
    p.Remove(true);

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.RemoveHyperlink Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..RemoveHyperlink Method
Paragraph Class Example See Also Send Feedback
Remove the Hyperlink at the provided index. The first hyperlink is at index 0. Using a negative index or an index greater than the index of the last hyperlink will cause an ArgumentOutOfRangeException() to be thrown.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveHyperlink(
    int index
)
Visual Basic
Public Sub RemoveHyperlink (
    index As Integer
)
Visual C++
public:
void RemoveHyperlink(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the hyperlink to be removed.

Examples

Copy image Copy
// Crete a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Add a Hyperlink into this document.
    Hyperlink h = document.AddHyperlink("link", new Uri("http://www.google.com"));

    // Insert a new Paragraph into the document.
    Paragraph p1 = document.InsertParagraph("AC");

    // Insert the hyperlink into this Paragraph.
    p1.InsertHyperlink(1, h);
    Assert.IsTrue(p1.Text == "AlinkC"); // Make sure the hyperlink was inserted correctly;

    // Remove the hyperlink
    p1.RemoveHyperlink(0);
    Assert.IsTrue(p1.Text == "AC"); // Make sure the hyperlink was removed correctly;
}

See Also

Paragraph Class
Paragraph Members


Paragraph.RemoveText Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..RemoveText Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveText(Int32, Boolean) | Removes characters from a Novacode.DocX.Paragraph.
Public method | RemoveText(Int32, Int32, Boolean) | Removes characters from a Novacode.DocX.Paragraph.

See Also

Paragraph Class
Paragraph Members


Paragraph.RemoveText Method (Int32, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..RemoveText Method (Int32, Boolean)
Paragraph Class Example See Also Send Feedback
Removes characters from a Novacode.DocX.Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveText(
    int index,
    bool trackChanges = false
)
Visual Basic
Public Sub RemoveText (
    index As Integer,
    Optional trackChanges As Boolean = false
)
Visual C++
public:
void RemoveText(
    int index,
    bool trackChanges = false
)

Parameters

index
Type: System..::..Int32
The position to begin deleting characters.
trackChanges (Optional)
Type: System..::..Boolean
Track changes

Examples

Copy image Copy
// Create a document using a relative filename.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Iterate through the paragraphs
    foreach (Paragraph p in document.Paragraphs)
    {
        // Remove all but the first 2 characters from this Paragraph.
        p.RemoveText(2, false);
    }

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
RemoveText Overload
Novacode Namespace
[!:Paragraph.ReplaceText(string, string, bool)]
[!:Paragraph.ReplaceText(string, string, bool, RegexOptions)]
Paragraph..::..InsertText(Int32, String, Boolean, Formatting)
Paragraph..::..InsertText(String, Boolean, Formatting)


Paragraph.RemoveText Method (Int32, Int32, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..RemoveText Method (Int32, Int32, Boolean)
Paragraph Class Example See Also Send Feedback
Removes characters from a Novacode.DocX.Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveText(
    int index,
    int count,
    bool trackChanges = false
)
Visual Basic
Public Sub RemoveText (
    index As Integer,
    count As Integer,
    Optional trackChanges As Boolean = false
)
Visual C++
public:
void RemoveText(
    int index,
    int count,
    bool trackChanges = false
)

Parameters

index
Type: System..::..Int32
The position to begin deleting characters.
count
Type: System..::..Int32
The number of characters to delete
trackChanges (Optional)
Type: System..::..Boolean
Track changes

Examples

Copy image Copy
// Create a document using a relative filename.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Iterate through the paragraphs
    foreach (Paragraph p in document.Paragraphs)
    {
        // Remove the first two characters from every paragraph
        p.RemoveText(0, 2, false);
    }

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
RemoveText Overload
Novacode Namespace
[!:Paragraph.ReplaceText(string, string, bool)]
[!:Paragraph.ReplaceText(string, string, bool, RegexOptions)]
[!:Paragraph.InsertText(string, bool)]
[!:Paragraph.InsertText(int, string, bool)]
Paragraph..::..InsertText(Int32, String, Boolean, Formatting)
Paragraph..::..InsertText(String, Boolean, Formatting)


Paragraph.ReplaceText Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..ReplaceText Method
Paragraph Class Example See Also Send Feedback
Replaces all occurrences of a specified System.String in this instance, with another specified System.String.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void ReplaceText(
    string oldValue,
    string newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions.None,
    Formatting newFormatting = null,
    Formatting matchFormatting = null,
    MatchFormattingOptions fo = MatchFormattingOptions.SubsetMatch
)
Visual Basic
Public Sub ReplaceText (
    oldValue As String,
    newValue As String,
    Optional trackChanges As Boolean = false,
    Optional options As RegexOptions = RegexOptions.None,
    Optional newFormatting As Formatting = Nothing,
    Optional matchFormatting As Formatting = Nothing,
    Optional fo As MatchFormattingOptions = MatchFormattingOptions.SubsetMatch
)
Visual C++
public:
void ReplaceText(
    String^ oldValue,
    String^ newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions::None,
    Formatting^ newFormatting = nullptr,
    Formatting^ matchFormatting = nullptr,
    MatchFormattingOptions fo = MatchFormattingOptions::SubsetMatch
)

Parameters

oldValue
Type: System..::..String
A System.String to be replaced.
newValue
Type: System..::..String
A System.String to replace all occurances of oldValue.
trackChanges (Optional)
Type: System..::..Boolean
Track changes
options (Optional)
Type: System.Text.RegularExpressions..::..RegexOptions
A bitwise OR combination of RegexOption enumeration options.
newFormatting (Optional)
Type: Novacode..::..Formatting
The formatting to apply to the text being inserted.
matchFormatting (Optional)
Type: Novacode..::..Formatting
The formatting that the text must match in order to be replaced.
fo (Optional)
Type: Novacode..::..MatchFormattingOptions
How should formatting be matched?

Examples

Copy image Copy
// Load a document using a relative filename.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // The formatting to match.
    Formatting matchFormatting = new Formatting();
    matchFormatting.Size = 10;
    matchFormatting.Italic = true;
    matchFormatting.FontFamily = new FontFamily("Times New Roman");

    // The formatting to apply to the inserted text.
    Formatting newFormatting = new Formatting();
    newFormatting.Size = 22;
    newFormatting.UnderlineStyle = UnderlineStyle.dotted;
    newFormatting.Bold = true;

    // Iterate through the paragraphs in this document.
    foreach (Paragraph p in document.Paragraphs)
    {
        /*
         * Replace all instances of the string "wrong" with the string "right" and ignore case.
         * Each inserted instance of "wrong" should use the Formatting newFormatting.
         * Only replace an instance of "wrong" if it is Size 10, Italic and Times New Roman.
         * SubsetMatch means that the formatting must contain all elements of the match formatting,
         * but it can also contain additional formatting for example Color, UnderlineStyle, etc.
         * ExactMatch means it must not contain additional formatting.
         */
        p.ReplaceText("wrong", "right", false, RegexOptions.IgnoreCase, newFormatting, matchFormatting, MatchFormattingOptions.SubsetMatch);
    }

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members
Novacode Namespace
Paragraph..::..RemoveText(Int32, Int32, Boolean)
Paragraph..::..RemoveText(Int32, Boolean)
[!:Paragraph.InsertText(string, bool)]
[!:Paragraph.InsertText(int, string, bool)]
Paragraph..::..InsertText(Int32, String, Boolean, Formatting)
Paragraph..::..InsertText(String, Boolean, Formatting)


Paragraph.Script Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Script Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Script(
    Script script
)
Visual Basic
Public Function Script (
    script As Script
) As Paragraph
Visual C++
public:
Paragraph^ Script(
    Script script
)

Parameters

script
Type: Novacode..::..Script
The script style to apply to the last appended text.

Return Value

Type: Paragraph
This Paragraph with the last appended text's script style changed.

Examples

Append text to this Paragraph and then set it to superscript.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("superscript").Script(Script.superscript)
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.Spacing Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Spacing Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Spacing(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Spacing(
    double spacing
)
Visual Basic
Public Function Spacing (
    spacing As Double
) As Paragraph
Visual C++
public:
Paragraph^ Spacing(
    double spacing
)

Parameters

spacing
Type: System..::..Double

[Missing <param name="spacing"/> documentation for "M:Novacode.Paragraph.Spacing(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Spacing(System.Double)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.SpacingAfter Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..SpacingAfter Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.SpacingAfter(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph SpacingAfter(
    double spacingAfter
)
Visual Basic
Public Function SpacingAfter (
    spacingAfter As Double
) As Paragraph
Visual C++
public:
Paragraph^ SpacingAfter(
    double spacingAfter
)

Parameters

spacingAfter
Type: System..::..Double

[Missing <param name="spacingAfter"/> documentation for "M:Novacode.Paragraph.SpacingAfter(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.SpacingAfter(System.Double)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.SpacingBefore Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..SpacingBefore Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.SpacingBefore(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph SpacingBefore(
    double spacingBefore
)
Visual Basic
Public Function SpacingBefore (
    spacingBefore As Double
) As Paragraph
Visual C++
public:
Paragraph^ SpacingBefore(
    double spacingBefore
)

Parameters

spacingBefore
Type: System..::..Double

[Missing <param name="spacingBefore"/> documentation for "M:Novacode.Paragraph.SpacingBefore(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.SpacingBefore(System.Double)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.StrikeThrough Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..StrikeThrough Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph StrikeThrough(
    StrikeThrough strikeThrough
)
Visual Basic
Public Function StrikeThrough (
    strikeThrough As StrikeThrough
) As Paragraph
Visual C++
public:
Paragraph^ StrikeThrough(
    StrikeThrough strikeThrough
)

Parameters

strikeThrough
Type: Novacode..::..StrikeThrough
The strike through style to used on the last appended text.

Return Value

Type: Paragraph
This Paragraph with the last appended text striked.

Examples

Append text to this Paragraph and then strike it.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("striked").StrikeThrough(StrikeThrough.doubleStrike)
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.UnderlineColor Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..UnderlineColor Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph UnderlineColor(
    Color underlineColor
)
Visual Basic
Public Function UnderlineColor (
    underlineColor As Color
) As Paragraph
Visual C++
public:
Paragraph^ UnderlineColor(
    Color underlineColor
)

Parameters

underlineColor
Type: System.Drawing..::..Color
The underline color to use, if no underline is set, a single line will be used.

Return Value

Type: Paragraph
This Paragraph with the last appended text underlined in a color.

Examples

Append text to this Paragraph and then underline it using a color.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("color underlined").UnderlineStyle(UnderlineStyle.dotted).UnderlineColor(Color.Orange)
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph.UnderlineStyle Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..UnderlineStyle Method
Paragraph Class Example See Also Send Feedback
For use with Append() and AppendLine()

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph UnderlineStyle(
    UnderlineStyle underlineStyle
)
Visual Basic
Public Function UnderlineStyle (
    underlineStyle As UnderlineStyle
) As Paragraph
Visual C++
public:
Paragraph^ UnderlineStyle(
    UnderlineStyle underlineStyle
)

Parameters

underlineStyle
Type: Novacode..::..UnderlineStyle
The underline style to use for the appended text.

Return Value

Type: Paragraph
This Paragraph with the last appended text underlined.

Examples

Append text to this Paragraph and then underline it.
Copy image Copy
// Create a document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p = document.InsertParagraph();

    p.Append("I am ")
    .Append("Underlined").UnderlineStyle(UnderlineStyle.doubleLine)
    .Append(" I am not");

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Paragraph Class
Paragraph Members


Paragraph Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph Properties
Paragraph Class See Also Send Feedback

The Paragraph type exposes the following members.

Properties

Name | Description
Public property Alignment
Gets or set this Paragraphs text alignment.
Public property Direction
Gets or Sets the Direction of content in this Paragraph.

Examples

Create a Paragraph with content that flows right to left. Default is left to right.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Create a new Paragraph with the text "Hello World".
    Paragraph p = document.InsertParagraph("Hello World.");

    // Make this Paragraph flow right to left. Default is left to right.
    p.Direction = Direction.RightToLeft;

    // Save all changes made to this document.
    document.Save();
}
Public property DocumentProperties
Returns a list of field type DocProperty in this document.
Public property FollowingTable
Returns table following the paragraph. Null if the following element isn't table.
Public property | Hyperlinks
Public property IndentationAfter
Set the after indentation in cm for this Paragraph.
Public property IndentationBefore
Set the before indentation in cm for this Paragraph.
Public property IndentationFirstLine
Get or set the indentation of the first line of this Paragraph.
Public property IndentationHanging
Get or set the indentation of all but the first line of this Paragraph.
Public property IndentLevel
If this element is a list item, get the indentation level of the list item.
Public property IsListItem
Determine if this paragraph is a list element.
Public property | LineSpacing
Public property | LineSpacingAfter
Public property | LineSpacingBefore
Public property MagicText
Gets the formatted text value of this Paragraph.
Public property | PackagePart
Public property ParagraphNumberProperties
Fetch the paragraph number properties for a list element.
Public property | Pictures
Public property StyleName
The style name of the paragraph.
Public property Text
Gets the text value of this Paragraph.
Public property Xml
This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following

Hello World!

(Inherited from DocXElement.)

See Also

Paragraph Class


Paragraph.Alignment Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Alignment Property
Paragraph Class See Also Send Feedback
Gets or set this Paragraphs text alignment.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Alignment Alignment { get; set; }
Visual Basic
Public Property Alignment As Alignment
    Get
    Set
Visual C++
public:
property Alignment Alignment {
    Alignment get ();
    void set (Alignment value);
}

Property Value

Type: Alignment

See Also

Paragraph Class
Paragraph Members


Paragraph.Direction Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Direction Property
Paragraph Class See Also Send Feedback
Gets or Sets the Direction of content in this Paragraph.

Examples

Create a Paragraph with content that flows right to left. Default is left to right.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Create a new Paragraph with the text "Hello World".
    Paragraph p = document.InsertParagraph("Hello World.");

    // Make this Paragraph flow right to left. Default is left to right.
    p.Direction = Direction.RightToLeft;

    // Save all changes made to this document.
    document.Save();
}

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Direction Direction { get; set; }
Visual Basic
Public Property Direction As Direction
    Get
    Set
Visual C++
public:
property Direction Direction {
    Direction get ();
    void set (Direction value);
}

Property Value

Type: Direction

See Also

Paragraph Class
Paragraph Members


Paragraph.DocumentProperties Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..DocumentProperties Property
Paragraph Class See Also Send Feedback
Returns a list of field type DocProperty in this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<DocProperty> DocumentProperties { get; }
Visual Basic
Public ReadOnly Property DocumentProperties As List(Of DocProperty)
    Get
Visual C++
public:
property List<DocProperty^>^ DocumentProperties {
    List<DocProperty^>^ get ();
}

Property Value

Type: List <(Of <(<' DocProperty >)>)>

See Also

Paragraph Class
Paragraph Members


Paragraph.FollowingTable Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FollowingTable Property
Paragraph Class See Also Send Feedback
Returns table following the paragraph. Null if the following element isn't table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table FollowingTable { get; internal set; }
Visual Basic
Public Property FollowingTable As Table
    Get
    Friend Set
Visual C++
public:
property Table^ FollowingTable {
    Table^ get ();
    internal: void set (Table^ value);
}

Property Value

Type: Table

See Also

Paragraph Class
Paragraph Members


Paragraph.Hyperlinks Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Hyperlinks Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.Hyperlinks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Hyperlink> Hyperlinks { get; }
Visual Basic
Public ReadOnly Property Hyperlinks As List(Of Hyperlink)
    Get
Visual C++
public:
property List<Hyperlink^>^ Hyperlinks {
    List<Hyperlink^>^ get ();
}

Property Value

Type: List <(Of <(<' Hyperlink >)>)>

See Also

Paragraph Class
Paragraph Members


Paragraph.IndentationAfter Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IndentationAfter Property
Paragraph Class Example See Also Send Feedback
Set the after indentation in cm for this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float IndentationAfter { get; set; }
Visual Basic
Public Property IndentationAfter As Single
    Get
    Set
Visual C++
public:
property float IndentationAfter {
    float get ();
    void set (float value);
}

Property Value

Type: Single

Examples

// Indent an entire Paragraph from the right.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Create a new Paragraph.
    Paragraph p = document.InsertParagraph("Line 1\nLine 2\nLine 3");

    // Make the content of this Paragraph flow right to left.
    p.Direction = Direction.RightToLeft;

    // Indent this entire Paragraph from the right.
    p.IndentationAfter = 2.0f;

    // Save all changes made to this document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.IndentationBefore Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IndentationBefore Property
Paragraph Class Example See Also Send Feedback
Set the before indentation in cm for this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float IndentationBefore { get; set; }
Visual Basic
Public Property IndentationBefore As Single
    Get
    Set
Visual C++
public:
property float IndentationBefore {
    float get ();
    void set (float value);
}

Property Value

Type: Single

Examples

// Indent an entire Paragraph from the left.
Copy image Copy
 // Create a new document.
 using (DocX document = DocX.Create("Test.docx"))
 {
    // Create a new Paragraph.
    Paragraph p = document.InsertParagraph("Line 1\nLine 2\nLine 3");

    // Indent this entire Paragraph from the left.
    p.IndentationBefore = 2.0f;

    // Save all changes made to this document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.IndentationFirstLine Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IndentationFirstLine Property
Paragraph Class Example See Also Send Feedback
Get or set the indentation of the first line of this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float IndentationFirstLine { get; set; }
Visual Basic
Public Property IndentationFirstLine As Single
    Get
    Set
Visual C++
public:
property float IndentationFirstLine {
    float get ();
    void set (float value);
}

Property Value

Type: Single

Examples

Indent only the first line of a Paragraph.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Create a new Paragraph.
    Paragraph p = document.InsertParagraph("Line 1\nLine 2\nLine 3");

    // Indent only the first line of the Paragraph.
    p.IndentationFirstLine = 2.0f;

    // Save all changes made to this document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.IndentationHanging Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IndentationHanging Property
Paragraph Class Example See Also Send Feedback
Get or set the indentation of all but the first line of this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float IndentationHanging { get; set; }
Visual Basic
Public Property IndentationHanging As Single
    Get
    Set
Visual C++
public:
property float IndentationHanging {
    float get ();
    void set (float value);
}

Property Value

Type: Single

Examples

Indent all but the first line of a Paragraph.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Create a new Paragraph.
    Paragraph p = document.InsertParagraph("Line 1\nLine 2\nLine 3");

    // Indent all but the first line of the Paragraph.
    p.IndentationHanging = 1.0f;

    // Save all changes made to this document.
    document.Save();
}

See Also

Paragraph Class
Paragraph Members


Paragraph.IndentLevel Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IndentLevel Property
Paragraph Class See Also Send Feedback
If this element is a list item, get the indentation level of the list item.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<int> IndentLevel { get; }
Visual Basic
Public ReadOnly Property IndentLevel As Nullable(Of Integer)
    Get
Visual C++
public:
property Nullable<int> IndentLevel {
    Nullable<int> get ();
}

Property Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

Paragraph Class
Paragraph Members


Paragraph.IsListItem Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IsListItem Property
Paragraph Class See Also Send Feedback
Determine if this paragraph is a list element.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool IsListItem { get; }
Visual Basic
Public ReadOnly Property IsListItem As Boolean
    Get
Visual C++
public:
property bool IsListItem {
    bool get ();
}

Property Value

Type: Boolean

See Also

Paragraph Class
Paragraph Members


Paragraph.LineSpacing Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..LineSpacing Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.LineSpacing"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float LineSpacing { get; set; }
Visual Basic
Public Property LineSpacing As Single
    Get
    Set
Visual C++
public:
property float LineSpacing {
    float get ();
    void set (float value);
}

Property Value

Type: Single

See Also

Paragraph Class
Paragraph Members


Paragraph.LineSpacingAfter Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..LineSpacingAfter Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.LineSpacingAfter"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float LineSpacingAfter { get; set; }
Visual Basic
Public Property LineSpacingAfter As Single
    Get
    Set
Visual C++
public:
property float LineSpacingAfter {
    float get ();
    void set (float value);
}

Property Value

Type: Single

See Also

Paragraph Class
Paragraph Members


Paragraph.LineSpacingBefore Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..LineSpacingBefore Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.LineSpacingBefore"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float LineSpacingBefore { get; set; }
Visual Basic
Public Property LineSpacingBefore As Single
    Get
    Set
Visual C++
public:
property float LineSpacingBefore {
    float get ();
    void set (float value);
}

Property Value

Type: Single

See Also

Paragraph Class
Paragraph Members


Paragraph.MagicText Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..MagicText Property
Paragraph Class See Also Send Feedback
Gets the formatted text value of this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<FormattedText> MagicText { get; }
Visual Basic
Public ReadOnly Property MagicText As List(Of FormattedText)
    Get
Visual C++
public:
property List<FormattedText^>^ MagicText {
    List<FormattedText^>^ get ();
}

Property Value

Type: List <(Of <(<' FormattedText >)>)>

See Also

Paragraph Class
Paragraph Members


Paragraph.PackagePart Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..PackagePart Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.PackagePart"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public PackagePart PackagePart { get; set; }
Visual Basic
Public Property PackagePart As PackagePart
    Get
    Set
Visual C++
public:
property PackagePart^ PackagePart {
    PackagePart^ get ();
    void set (PackagePart^ value);
}

Property Value

Type: PackagePart

See Also

Paragraph Class
Paragraph Members


Paragraph.ParagraphNumberProperties Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..ParagraphNumberProperties Property
Paragraph Class See Also Send Feedback
Fetch the paragraph number properties for a list element.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public XElement ParagraphNumberProperties { get; }
Visual Basic
Public ReadOnly Property ParagraphNumberProperties As XElement
    Get
Visual C++
public:
property XElement^ ParagraphNumberProperties {
    XElement^ get ();
}

Property Value

Type: XElement

See Also

Paragraph Class
Paragraph Members


Paragraph.Pictures Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Pictures Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.Pictures"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Picture> Pictures { get; }
Visual Basic
Public ReadOnly Property Pictures As List(Of Picture)
    Get
Visual C++
public:
property List<Picture^>^ Pictures {
    List<Picture^>^ get ();
}

Property Value

Type: List <(Of <(<' Picture >)>)>

See Also

Paragraph Class
Paragraph Members


Paragraph.StyleName Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..StyleName Property
Paragraph Class See Also Send Feedback
The style name of the paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string StyleName { get; set; }
Visual Basic
Public Property StyleName As String
    Get
    Set
Visual C++
public:
property String^ StyleName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Paragraph Class
Paragraph Members


Paragraph.Text Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Text Property
Paragraph Class See Also Send Feedback
Gets the text value of this Paragraph.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

Property Value

Type: String

See Also

Paragraph Class
Paragraph Members


Picture Class

[image]

DocX - A Sandcastle Documented Class Library
Picture Class
Members See Also Send Feedback
Represents a Picture in this document, a Picture is a customized view of an Image.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Picture : DocXElement
Visual Basic
Public Class Picture
    Inherits DocXElement
Visual C++
public ref class Picture : public DocXElement

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Picture

See Also

Picture Members


Picture Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Picture Members
Picture Class Methods Properties See Also Send Feedback

The Picture type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Remove this Picture from this document.
Public method | SetPictureShape(BasicShapes) | Set the shape of this Picture to one in the BasicShapes enumeration.
Public method | SetPictureShape(BlockArrowShapes) | Set the shape of this Picture to one in the BlockArrowShapes enumeration.
Public method | SetPictureShape(CalloutShapes) | Set the shape of this Picture to one in the CalloutShapes enumeration.
Public method | SetPictureShape(EquationShapes) | Set the shape of this Picture to one in the EquationShapes enumeration.
Public method | SetPictureShape(FlowchartShapes) | Set the shape of this Picture to one in the FlowchartShapes enumeration.
Public method | SetPictureShape(RectangleShapes) | Set the shape of this Picture to one in the RectangleShapes enumeration.
Public method | SetPictureShape(StarAndBannerShapes) | Set the shape of this Picture to one in the StarAndBannerShapes enumeration.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets the description for this Image.
Public property | FileName | Returns the name of the image file for the picture.
Public property | FlipHorizontal | Flip this Picture Horizontally.
Public property | FlipVertical | Flip this Picture Vertically.
Public property | Height | Get or sets the height of this Image.
Public property | Id | A unique id that identifies an Image embedded in this document.
Public property | Name | Gets or sets the name of this Image.
Public property | Rotation | The rotation in degrees of this image, actual value = value % 360
Public property | Width | Get or sets the Width of this Image.
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Picture Class


Picture Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Picture Methods
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Remove this Picture from this document.
Public method | SetPictureShape(BasicShapes) | Set the shape of this Picture to one in the BasicShapes enumeration.
Public method | SetPictureShape(BlockArrowShapes) | Set the shape of this Picture to one in the BlockArrowShapes enumeration.
Public method | SetPictureShape(CalloutShapes) | Set the shape of this Picture to one in the CalloutShapes enumeration.
Public method | SetPictureShape(EquationShapes) | Set the shape of this Picture to one in the EquationShapes enumeration.
Public method | SetPictureShape(FlowchartShapes) | Set the shape of this Picture to one in the FlowchartShapes enumeration.
Public method | SetPictureShape(RectangleShapes) | Set the shape of this Picture to one in the RectangleShapes enumeration.
Public method | SetPictureShape(StarAndBannerShapes) | Set the shape of this Picture to one in the StarAndBannerShapes enumeration.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Picture Class


Picture.Remove Method

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Remove Method
Picture Class See Also Send Feedback
Remove this Picture from this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Remove()
Visual Basic
Public Sub Remove
Visual C++
public:
void Remove()

See Also

Picture Class
Picture Members


Picture.SetPictureShape Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method
Picture Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPictureShape(BasicShapes) | Set the shape of this Picture to one in the BasicShapes enumeration.
Public method | SetPictureShape(BlockArrowShapes) | Set the shape of this Picture to one in the BlockArrowShapes enumeration.
Public method | SetPictureShape(CalloutShapes) | Set the shape of this Picture to one in the CalloutShapes enumeration.
Public method | SetPictureShape(EquationShapes) | Set the shape of this Picture to one in the EquationShapes enumeration.
Public method | SetPictureShape(FlowchartShapes) | Set the shape of this Picture to one in the FlowchartShapes enumeration.
Public method | SetPictureShape(RectangleShapes) | Set the shape of this Picture to one in the RectangleShapes enumeration.
Public method | SetPictureShape(StarAndBannerShapes) | Set the shape of this Picture to one in the StarAndBannerShapes enumeration.

See Also

Picture Class
Picture Members


Picture.SetPictureShape Method (BasicShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (BasicShapes)
Picture Class See Also Send Feedback
Set the shape of this Picture to one in the BasicShapes enumeration.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    BasicShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As BasicShapes
)
Visual C++
public:
void SetPictureShape(
    BasicShapes shape
)

Parameters

shape
Type: Novacode..::..BasicShapes
A shape from the BasicShapes enumeration.

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (BlockArrowShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (BlockArrowShapes)
Picture Class See Also Send Feedback
Set the shape of this Picture to one in the BlockArrowShapes enumeration.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    BlockArrowShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As BlockArrowShapes
)
Visual C++
public:
void SetPictureShape(
    BlockArrowShapes shape
)

Parameters

shape
Type: Novacode..::..BlockArrowShapes
A shape from the BlockArrowShapes enumeration.

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (CalloutShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (CalloutShapes)
Picture Class See Also Send Feedback
Set the shape of this Picture to one in the CalloutShapes enumeration.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    CalloutShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As CalloutShapes
)
Visual C++
public:
void SetPictureShape(
    CalloutShapes shape
)

Parameters

shape
Type: Novacode..::..CalloutShapes
A shape from the CalloutShapes enumeration.

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (EquationShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (EquationShapes)
Picture Class See Also Send Feedback
Set the shape of this Picture to one in the EquationShapes enumeration.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    EquationShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As EquationShapes
)
Visual C++
public:
void SetPictureShape(
    EquationShapes shape
)

Parameters

shape
Type: Novacode..::..EquationShapes
A shape from the EquationShapes enumeration.

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (FlowchartShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (FlowchartShapes)
Picture Class See Also Send Feedback
Set the shape of this Picture to one in the FlowchartShapes enumeration.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    FlowchartShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As FlowchartShapes
)
Visual C++
public:
void SetPictureShape(
    FlowchartShapes shape
)

Parameters

shape
Type: Novacode..::..FlowchartShapes
A shape from the FlowchartShapes enumeration.

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (RectangleShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (RectangleShapes)
Picture Class See Also Send Feedback
Set the shape of this Picture to one in the RectangleShapes enumeration.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    RectangleShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As RectangleShapes
)
Visual C++
public:
void SetPictureShape(
    RectangleShapes shape
)

Parameters

shape
Type: Novacode..::..RectangleShapes
A shape from the RectangleShapes enumeration.

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (StarAndBannerShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (StarAndBannerShapes)
Picture Class See Also Send Feedback
Set the shape of this Picture to one in the StarAndBannerShapes enumeration.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    StarAndBannerShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As StarAndBannerShapes
)
Visual C++
public:
void SetPictureShape(
    StarAndBannerShapes shape
)

Parameters

shape
Type: Novacode..::..StarAndBannerShapes
A shape from the StarAndBannerShapes enumeration.

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Picture Properties
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the description for this Image.
Public property | FileName | Returns the name of the image file for the picture.
Public property | FlipHorizontal | Flip this Picture Horizontally.
Public property | FlipVertical | Flip this Picture Vertically.
Public property | Height | Get or sets the height of this Image.
Public property | Id | A unique id that identifies an Image embedded in this document.
Public property | Name | Gets or sets the name of this Image.
Public property | Rotation | The rotation in degrees of this image, actual value = value % 360
Public property | Width | Get or sets the Width of this Image.
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Picture Class


Picture.Description Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Description Property
Picture Class See Also Send Feedback
Gets or sets the description for this Image.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Picture Class
Picture Members


Picture.FileName Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..FileName Property
Picture Class See Also Send Feedback
Returns the name of the image file for the picture.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get
Visual C++
public:
property String^ FileName {
    String^ get ();
}

Property Value

Type: String

See Also

Picture Class
Picture Members


Picture.FlipHorizontal Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..FlipHorizontal Property
Picture Class See Also Send Feedback
Flip this Picture Horizontally.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool FlipHorizontal { get; set; }
Visual Basic
Public Property FlipHorizontal As Boolean
    Get
    Set
Visual C++
public:
property bool FlipHorizontal {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Picture Class
Picture Members


Picture.FlipVertical Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..FlipVertical Property
Picture Class See Also Send Feedback
Flip this Picture Vertically.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool FlipVertical { get; set; }
Visual Basic
Public Property FlipVertical As Boolean
    Get
    Set
Visual C++
public:
property bool FlipVertical {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Picture Class
Picture Members


Picture.Height Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Height Property
Picture Class See Also Send Feedback
Get or sets the height of this Image.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int Height { get; set; }
Visual Basic
Public Property Height As Integer
    Get
    Set
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

Picture Class
Picture Members


Picture.Id Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Id Property
Picture Class See Also Send Feedback
A unique id that identifies an Image embedded in this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

Property Value

Type: String

See Also

Picture Class
Picture Members


Picture.Name Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Name Property
Picture Class See Also Send Feedback
Gets or sets the name of this Image.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Picture Class
Picture Members


Picture.Rotation Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Rotation Property
Picture Class See Also Send Feedback
The rotation in degrees of this image, actual value = value % 360

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public uint Rotation { get; set; }
Visual Basic
Public Property Rotation As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Rotation {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32

See Also

Picture Class
Picture Members


Picture.Width Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Width Property
Picture Class See Also Send Feedback
Get or sets the Width of this Image.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

Picture Class
Picture Members


PieChart Class

[image]

DocX - A Sandcastle Documented Class Library
PieChart Class
Members See Also Send Feedback
This element contains the 2-D pie series for this chart. 21.2.2.141 pieChart (Pie Charts)

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class PieChart : Chart
Visual Basic
Public Class PieChart
    Inherits Chart
Visual C++
public ref class PieChart : public Chart

Inheritance Hierarchy

System..::..Object
Novacode..::..Chart
Novacode..::..PieChart

See Also

PieChart Members


PieChart Members

[image] [image]

DocX - A Sandcastle Documented Class Library
PieChart Members
PieChart Class Constructors Methods Properties See Also Send Feedback

The PieChart type exposes the following members.

Constructors

 | Name | Description
Public method | PieChart | Initializes a new instance of the PieChart class

Methods

 | Name | Description
Public method | AddLegend()()()() | Add standart legend to the chart. (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | Add a legend with parameters to the chart. (Inherited from Chart.)
Public method | AddSeries | Add a new series to this chart (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | Remove the legend from the chart. (Inherited from Chart.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryAxis | Represents the category axis (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | Specifies how blank cells shall be plotted on a chart (Inherited from Chart.)
Public property | IsAxisExist | (Overrides Chart..::..IsAxisExist.)
Public property | Legend | Chart's legend. If legend doesn't exist property is null. (Inherited from Chart.)
Public property | MaxSeriesCount | (Overrides Chart..::..MaxSeriesCount.)
Public property | Series | Chart's series (Inherited from Chart.)
Public property | ValueAxis | Represents the values axis (Inherited from Chart.)
Public property | View3D | Get or set 3D view for this chart (Inherited from Chart.)
Public property | Xml | The xml representation of this chart (Inherited from Chart.)

See Also

PieChart Class


PieChart Constructor

[image]

DocX - A Sandcastle Documented Class Library
PieChart Constructor
PieChart Class See Also Send Feedback
Initializes a new instance of the PieChart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public PieChart()
Visual Basic
Public Sub New
Visual C++
public:
PieChart()

See Also

PieChart Class
PieChart Members


PieChart Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
PieChart Methods
PieChart Class See Also Send Feedback

The PieChart type exposes the following members.

Methods

 | Name | Description
Public method | AddLegend()()()() | Add standart legend to the chart. (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | Add a legend with parameters to the chart. (Inherited from Chart.)
Public method | AddSeries | Add a new series to this chart (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | Remove the legend from the chart. (Inherited from Chart.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PieChart Class


PieChart.CreateChartXml Method

[image]

DocX - A Sandcastle Documented Class Library
PieChart..::..CreateChartXml Method
PieChart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.PieChart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected override XElement CreateChartXml()
Visual Basic
Protected Overrides Function CreateChartXml As XElement
Visual C++
protected:
virtual XElement^ CreateChartXml() override

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.PieChart.CreateChartXml"]

See Also

PieChart Class
PieChart Members


PieChart Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
PieChart Properties
PieChart Class See Also Send Feedback

The PieChart type exposes the following members.

Properties

 | Name | Description
Public property | CategoryAxis | Represents the category axis (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | Specifies how blank cells shall be plotted on a chart (Inherited from Chart.)
Public property | IsAxisExist | (Overrides Chart..::..IsAxisExist.)
Public property | Legend | Chart's legend. If legend doesn't exist property is null. (Inherited from Chart.)
Public property | MaxSeriesCount | (Overrides Chart..::..MaxSeriesCount.)
Public property | Series | Chart's series (Inherited from Chart.)
Public property | ValueAxis | Represents the values axis (Inherited from Chart.)
Public property | View3D | Get or set 3D view for this chart (Inherited from Chart.)
Public property | Xml | The xml representation of this chart (Inherited from Chart.)

See Also

PieChart Class


PieChart.IsAxisExist Property

[image]

DocX - A Sandcastle Documented Class Library
PieChart..::..IsAxisExist Property
PieChart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.PieChart.IsAxisExist"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override bool IsAxisExist { get; }
Visual Basic
Public Overrides ReadOnly Property IsAxisExist As Boolean
    Get
Visual C++
public:
virtual property bool IsAxisExist {
    bool get () override;
}

Property Value

Type: Boolean

See Also

PieChart Class
PieChart Members


PieChart.MaxSeriesCount Property

[image]

DocX - A Sandcastle Documented Class Library
PieChart..::..MaxSeriesCount Property
PieChart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.PieChart.MaxSeriesCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override short MaxSeriesCount { get; }
Visual Basic
Public Overrides ReadOnly Property MaxSeriesCount As Short
    Get
Visual C++
public:
virtual property short MaxSeriesCount {
    short get () override;
}

Property Value

Type: Int16

See Also

PieChart Class
PieChart Members


RectangleShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
RectangleShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.RectangleShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum RectangleShapes
Visual Basic
Public Enumeration RectangleShapes
Visual C++
public enum class RectangleShapes

Members

Member name | Value | Description
rect | 0 |
roundRect | 1 |
snip1Rect | 2 |
snip2SameRect | 3 |
snip2DiagRect | 4 |
snipRoundRect | 5 |
round1Rect | 6 |
round2SameRect | 7 |
round2DiagRect | 8 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Row Class

[image]

DocX - A Sandcastle Documented Class Library
Row Class
Members See Also Send Feedback
Represents a single row in a Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Row : Container
Visual Basic
Public Class Row
    Inherits Container
Visual C++
public ref class Row : public Container

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Row

See Also

Row Members


Row Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Row Members
Row Class Methods Fields Properties See Also Send Feedback

The Row type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCells | Merge cells starting with startIndex and ending with endIndex.
Public method | Remove |
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

Properties

 | Name | Description
Public property | Cells | A list of Cells in this Row.
Public property | ColumnCount | Calculates columns count in the row, taking spanned cells into account
Public property | Height | Height in pixels. // Added by Joel, refactored by Cathal.
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Inherited from Container.)
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Row Class


Row Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Row Fields
Row Class See Also Send Feedback

The Row type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

See Also

Row Class


Row Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Row Methods
Row Class See Also Send Feedback

The Row type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCells | Merge cells starting with startIndex and ending with endIndex.
Public method | Remove |
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Row Class


Row.MergeCells Method

[image]

DocX - A Sandcastle Documented Class Library
Row..::..MergeCells Method
Row Class See Also Send Feedback
Merge cells starting with startIndex and ending with endIndex.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void MergeCells(
    int startIndex,
    int endIndex
)
Visual Basic
Public Sub MergeCells (
    startIndex As Integer,
    endIndex As Integer
)
Visual C++
public:
void MergeCells(
    int startIndex,
    int endIndex
)

Parameters

startIndex
Type: System..::..Int32

[Missing <param name="startIndex"/> documentation for "M:Novacode.Row.MergeCells(System.Int32,System.Int32)"]

endIndex
Type: System..::..Int32

[Missing <param name="endIndex"/> documentation for "M:Novacode.Row.MergeCells(System.Int32,System.Int32)"]

See Also

Row Class
Row Members


Row.Remove Method

[image]

DocX - A Sandcastle Documented Class Library
Row..::..Remove Method
Row Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Row.Remove"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Remove()
Visual Basic
Public Sub Remove
Visual C++
public:
void Remove()

See Also

Row Class
Row Members


Row Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Row Properties
Row Class See Also Send Feedback

The Row type exposes the following members.

Properties

 | Name | Description
Public property | Cells | A list of Cells in this Row.
Public property | ColumnCount | Calculates columns count in the row, taking spanned cells into account
Public property | Height | Height in pixels. // Added by Joel, refactored by Cathal.
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Inherited from Container.)
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Row Class


Row.Cells Property

[image]

DocX - A Sandcastle Documented Class Library
Row..::..Cells Property
Row Class See Also Send Feedback
A list of Cells in this Row.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Cell> Cells { get; }
Visual Basic
Public ReadOnly Property Cells As List(Of Cell)
    Get
Visual C++
public:
property List<Cell^>^ Cells {
    List<Cell^>^ get ();
}

Property Value

Type: List <(Of <(<' Cell >)>)>

See Also

Row Class
Row Members


Row.ColumnCount Property

[image]

DocX - A Sandcastle Documented Class Library
Row..::..ColumnCount Property
Row Class See Also Send Feedback
Calculates columns count in the row, taking spanned cells into account

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int ColumnCount { get; }
Visual Basic
Public ReadOnly Property ColumnCount As Integer
    Get
Visual C++
public:
property int ColumnCount {
    int get ();
}

Property Value

Type: Int32

See Also

Row Class
Row Members


Row.Height Property

[image]

DocX - A Sandcastle Documented Class Library
Row..::..Height Property
Row Class See Also Send Feedback
Height in pixels. // Added by Joel, refactored by Cathal.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Row Class
Row Members


Row.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Row..::..Paragraphs Property
Row Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Row.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Paragraph> Paragraphs { get; }
Visual Basic
Public Overrides ReadOnly Property Paragraphs As List(Of Paragraph)
    Get
Visual C++
public:
virtual property List<Paragraph^>^ Paragraphs {
    List<Paragraph^>^ get () override;
}

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

Row Class
Row Members


Run Class

[image]

DocX - A Sandcastle Documented Class Library
Run Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Run"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Run : DocXElement
Visual Basic
Public Class Run
    Inherits DocXElement
Visual C++
public ref class Run : public DocXElement

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Run

See Also

Run Members


Run Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Run Members
Run Class Methods Properties See Also Send Feedback

The Run type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndIndex | Gets the end index of this Text (text length before this text + this texts length)
Public property | StartIndex | Gets the start index of this Text (text length before this text)
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Run Class


Run Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Run Methods
Run Class See Also Send Feedback

The Run type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Run Class


Run Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Run Properties
Run Class See Also Send Feedback

The Run type exposes the following members.

Properties

 | Name | Description
Public property | EndIndex | Gets the end index of this Text (text length before this text + this texts length)
Public property | StartIndex | Gets the start index of this Text (text length before this text)
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Run Class


Run.EndIndex Property

[image]

DocX - A Sandcastle Documented Class Library
Run..::..EndIndex Property
Run Class See Also Send Feedback
Gets the end index of this Text (text length before this text + this texts length)

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int EndIndex { get; }
Visual Basic
Public ReadOnly Property EndIndex As Integer
    Get
Visual C++
public:
property int EndIndex {
    int get ();
}

Property Value

Type: Int32

See Also

Run Class
Run Members


Run.StartIndex Property

[image]

DocX - A Sandcastle Documented Class Library
Run..::..StartIndex Property
Run Class See Also Send Feedback
Gets the start index of this Text (text length before this text)

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int StartIndex { get; }
Visual Basic
Public ReadOnly Property StartIndex As Integer
    Get
Visual C++
public:
property int StartIndex {
    int get ();
}

Property Value

Type: Int32

See Also

Run Class
Run Members


RunTextType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
RunTextType Enumeration
See Also Send Feedback
Text types in a Run

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum RunTextType
Visual Basic
Public Enumeration RunTextType
Visual C++
public enum class RunTextType

Members

Member name | Value | Description
Text | 0 | System.String
DelText | 1 | System.String

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Script Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Script Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Script"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Script
Visual Basic
Public Enumeration Script
Visual C++
public enum class Script

Members

Member name | Value | Description
superscript | 0 |
subscript | 1 |
none | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Section Class

[image]

DocX - A Sandcastle Documented Class Library
Section Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Section"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Section : Container
Visual Basic
Public Class Section
    Inherits Container
Visual C++
public ref class Section : public Container

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Section

See Also

Section Members


Section Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Section Members
Section Class Methods Fields Properties See Also Send Feedback

The Section type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Public field | SectionBreakType |

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | Paragraphs | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | SectionParagraphs |
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Inherited from Container.)
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Section Class


Section Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Section Fields
Section Class See Also Send Feedback

The Section type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Public field | SectionBreakType |

See Also

Section Class


Section.SectionBreakType Field

[image]

DocX - A Sandcastle Documented Class Library
Section..::..SectionBreakType Field
Section Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Section.SectionBreakType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public SectionBreakType SectionBreakType
Visual Basic
Public SectionBreakType As SectionBreakType
Visual C++
public:
SectionBreakType SectionBreakType

Field Value

Type: SectionBreakType

See Also

Section Class
Section Members


Section Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Section Methods
Section Class See Also Send Feedback

The Section type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | Find all unique instances of the given Regex Pattern, returning the list of the unique strings found (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | Sets the Direction of content. (Inherited from Container.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Section Class


Section Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Section Properties
Section Class See Also Send Feedback

The Section type exposes the following members.

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | Paragraphs | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | SectionParagraphs |
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Inherited from Container.)
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Section Class


Section.SectionParagraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Section..::..SectionParagraphs Property
Section Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Section.SectionParagraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Paragraph> SectionParagraphs { get; set; }
Visual Basic
Public Property SectionParagraphs As List(Of Paragraph)
    Get
    Set
Visual C++
public:
property List<Paragraph^>^ SectionParagraphs {
    List<Paragraph^>^ get ();
    void set (List<Paragraph^>^ value);
}

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

Section Class
Section Members


SectionBreakType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
SectionBreakType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.SectionBreakType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum SectionBreakType
Visual Basic
Public Enumeration SectionBreakType
Visual C++
public enum class SectionBreakType

Members

Member name | Value | Description
defaultNextPage | 0 |
evenPage | 1 |
oddPage | 2 |
continuous | 3 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Series Class

[image]

DocX - A Sandcastle Documented Class Library
Series Class
Members See Also Send Feedback
Represents a chart series

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Series
Visual Basic
Public Class Series
Visual C++
public ref class Series

Inheritance Hierarchy

System..::..Object
Novacode..::..Series

See Also

Series Members


Series Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Series Members
Series Class Constructors Methods Properties See Also Send Feedback

The Series type exposes the following members.

Constructors

 | Name | Description
Public method | Series | Initializes a new instance of the Series class

Methods

 | Name | Description
Public method | Bind(IList, IList) |
Public method | Bind(ICollection, String, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color |

See Also

Series Class


Series Constructor

[image]

DocX - A Sandcastle Documented Class Library
Series Constructor
Series Class See Also Send Feedback
Initializes a new instance of the Series class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Series(
    string name
)
Visual Basic
Public Sub New (
    name As String
)
Visual C++
public:
Series(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Novacode.Series.#ctor(System.String)"]

See Also

Series Class
Series Members


Series Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Series Methods
Series Class See Also Send Feedback

The Series type exposes the following members.

Methods

 | Name | Description
Public method | Bind(IList, IList) |
Public method | Bind(ICollection, String, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Series Class


Series.Bind Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Series..::..Bind Method
Series Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Bind(IList, IList) |
Public method | Bind(ICollection, String, String) |

See Also

Series Class
Series Members


Series.Bind Method (IList, IList)

[image]

DocX - A Sandcastle Documented Class Library
Series..::..Bind Method (IList, IList)
Series Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Series.Bind(System.Collections.IList,System.Collections.IList)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Bind(
    IList categories,
    IList values
)
Visual Basic
Public Sub Bind (
    categories As IList,
    values As IList
)
Visual C++
public:
void Bind(
    IList^ categories,
    IList^ values
)

Parameters

categories
Type: System.Collections..::..IList

[Missing <param name="categories"/> documentation for "M:Novacode.Series.Bind(System.Collections.IList,System.Collections.IList)"]

values
Type: System.Collections..::..IList

[Missing <param name="values"/> documentation for "M:Novacode.Series.Bind(System.Collections.IList,System.Collections.IList)"]

See Also

Series Class
Series Members
Bind Overload


Series.Bind Method (ICollection, String, String)

[image]

DocX - A Sandcastle Documented Class Library
Series..::..Bind Method (ICollection, String, String)
Series Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Bind(
    ICollection list,
    string categoryPropertyName,
    string valuePropertyName
)
Visual Basic
Public Sub Bind (
    list As ICollection,
    categoryPropertyName As String,
    valuePropertyName As String
)
Visual C++
public:
void Bind(
    ICollection^ list,
    String^ categoryPropertyName,
    String^ valuePropertyName
)

Parameters

list
Type: System.Collections..::..ICollection

[Missing <param name="list"/> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

categoryPropertyName
Type: System..::..String

[Missing <param name="categoryPropertyName"/> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

valuePropertyName
Type: System..::..String

[Missing <param name="valuePropertyName"/> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

See Also

Series Class
Series Members
Bind Overload


Series Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Series Properties
Series Class See Also Send Feedback

The Series type exposes the following members.

Properties

 | Name | Description
Public property | Color |

See Also

Series Class


Series.Color Property

[image]

DocX - A Sandcastle Documented Class Library
Series..::..Color Property
Series Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Series.Color"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

Series Class
Series Members


StarAndBannerShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
StarAndBannerShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.StarAndBannerShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum StarAndBannerShapes
Visual Basic
Public Enumeration StarAndBannerShapes
Visual C++
public enum class StarAndBannerShapes

Members

Member name | Value | Description
irregularSeal1 | 0 |
irregularSeal2 | 1 |
star4 | 2 |
star5 | 3 |
star6 | 4 |
star7 | 5 |
star8 | 6 |
star10 | 7 |
star12 | 8 |
star16 | 9 |
star24 | 10 |
star32 | 11 |
ribbon | 12 |
ribbon2 | 13 |
ellipseRibbon | 14 |
ellipseRibbon2 | 15 |
verticalScroll | 16 |
horizontalScroll | 17 |
wave | 18 |
doubleWave | 19 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


StrikeThrough Enumeration

[image]

DocX - A Sandcastle Documented Class Library
StrikeThrough Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.StrikeThrough"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum StrikeThrough
Visual Basic
Public Enumeration StrikeThrough
Visual C++
public enum class StrikeThrough

Members

Member name | Value | Description
none | 0 |
strike | 1 |
doubleStrike | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Table Class

[image]

DocX - A Sandcastle Documented Class Library
Table Class
Members See Also Send Feedback
Represents a Table in a document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Table : InsertBeforeOrAfter
Visual Basic
Public Class Table
    Inherits InsertBeforeOrAfter
Visual C++
public ref class Table : public InsertBeforeOrAfter

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..InsertBeforeOrAfter
Novacode..::..Table

See Also

Table Members


Table Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Table Members
Table Class Methods Properties See Also Send Feedback

The Table type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBorder | Get a table border Added by lckuiper @ 20101117
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertColumn()()()() | Insert a column to the right of a Table.
Public method | InsertColumn(Int32) | Insert a column into a table.
Public method | InsertPageBreakAfterSelf | Insert a page break after a Table. (Overrides InsertBeforeOrAfter..::..InsertPageBreakAfterSelf()()()().)
Public method | InsertPageBreakBeforeSelf | Insert a page break before a Table. (Overrides InsertBeforeOrAfter..::..InsertPageBreakBeforeSelf()()()().)
Public method | InsertParagraphAfterSelf(String) | Insert a new Paragraph after this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | Insert a Paragraph after this Table, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | Insert a new Paragraph after this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | Insert a new Paragraph after this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | Insert a new Paragraph before this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | Insert a Paragraph before this Table, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | Insert a new Paragraph before this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | Insert a new Paragraph before this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertRow()()()() | Insert a row at the end of this table.
Public method | InsertRow(Int32) | Insert a row into this table.
Public method | InsertRow(Row) | Insert a copy of a row at the end of this table.
Public method | InsertRow(Row, Int32) | Insert a copy of a row into this table.
Public method | InsertTableAfterSelf(Table) | Insert a new Table after this Table, this Table can be from this document or another document. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | Insert a new Table into this document after this Table. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | Insert a new Table before this Table, this Table can be from this document or another document. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | Insert a new Table into this document before this Table. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCellsInColumn | Merge cells in given column starting with startRow and ending with endRow.
Public method | Remove | Remove this Table from this document.
Public method | RemoveColumn()()()() | Remove the last column for this Table.
Public method | RemoveColumn(Int32) | Remove a column from this Table.
Public method | RemoveRow()()()() | Remove the last row from this Table.
Public method | RemoveRow(Int32) | Remove a row from this Table.
Public method | SetBorder | Set a table border Added by lckuiper @ 20101117
Public method | SetDirection | Set the direction of all content in this Table.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Alignment |
Public property | AutoFit | Auto size this table according to some rule.
Public property | ColumnCount | Returns the number of columns in this table.
Public property | CustomTableDesignName | Extra property for Custom Table Style provided by carpfisher - Thanks
Public property | Design | The design\style to apply to this table. Patch1. Patch to code for Custom Table Style support by carpfisher
Public property | Hyperlinks |
Public property | Index | Returns the index of this Table.
Public property | Paragraphs | Returns a list of all Paragraphs inside this container.
Public property | Pictures |
Public property | RowCount | Returns the number of rows in this table.
Public property | Rows | Returns a list of rows in this table.
Public property | TableLook |
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Table Class


Table Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Table Methods
Table Class See Also Send Feedback

The Table type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBorder | Get a table border Added by lckuiper @ 20101117
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertColumn()()()() | Insert a column to the right of a Table.
Public method | InsertColumn(Int32) | Insert a column into a table.
Public method | InsertPageBreakAfterSelf | Insert a page break after a Table. (Overrides InsertBeforeOrAfter..::..InsertPageBreakAfterSelf()()()().)
Public method | InsertPageBreakBeforeSelf | Insert a page break before a Table. (Overrides InsertBeforeOrAfter..::..InsertPageBreakBeforeSelf()()()().)
Public method | InsertParagraphAfterSelf(String) | Insert a new Paragraph after this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | Insert a Paragraph after this Table, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | Insert a new Paragraph after this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | Insert a new Paragraph after this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | Insert a new Paragraph before this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | Insert a Paragraph before this Table, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | Insert a new Paragraph before this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | Insert a new Paragraph before this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertRow()()()() | Insert a row at the end of this table.
Public method | InsertRow(Int32) | Insert a row into this table.
Public method | InsertRow(Row) | Insert a copy of a row at the end of this table.
Public method | InsertRow(Row, Int32) | Insert a copy of a row into this table.
Public method | InsertTableAfterSelf(Table) | Insert a new Table after this Table, this Table can be from this document or another document. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | Insert a new Table into this document after this Table. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | Insert a new Table before this Table, this Table can be from this document or another document. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | Insert a new Table into this document before this Table. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCellsInColumn | Merge cells in given column starting with startRow and ending with endRow.
Public method | Remove | Remove this Table from this document.
Public method | RemoveColumn()()()() | Remove the last column for this Table.
Public method | RemoveColumn(Int32) | Remove a column from this Table.
Public method | RemoveRow()()()() | Remove the last row from this Table.
Public method | RemoveRow(Int32) | Remove a row from this Table.
Public method | SetBorder | Set a table border Added by lckuiper @ 20101117
Public method | SetDirection | Set the direction of all content in this Table.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Table Class


Table.GetBorder Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..GetBorder Method
Table Class See Also Send Feedback
Get a table border Added by lckuiper @ 20101117

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Border GetBorder(
    TableBorderType borderType
)
Visual Basic
Public Function GetBorder (
    borderType As TableBorderType
) As Border
Visual C++
public:
Border^ GetBorder(
    TableBorderType borderType
)

Parameters

borderType
Type: Novacode..::..TableBorderType
The table border to get

Return Value

Type: Border

[Missing <returns> documentation for "M:Novacode.Table.GetBorder(Novacode.TableBorderType)"]

See Also

Table Class
Table Members


Table.InsertColumn Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertColumn Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertColumn()()()() | Insert a column to the right of a Table.
Public method | InsertColumn(Int32) | Insert a column into a table.

See Also

Table Class
Table Members


Table.InsertColumn Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertColumn Method
Table Class Example See Also Send Feedback
Insert a column to the right of a Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertColumn()
Visual Basic
Public Sub InsertColumn
Visual C++
public:
void InsertColumn()

Examples

Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Get the first Table in this document.
    Table table = document.Tables[0];

    // Insert a new column to this right of this table.
    table.InsertColumn();

    // Set the new columns text to "Row no."
    table.Rows[0].Cells[table.ColumnCount - 1].Paragraph.InsertText("Row no.", false);

    // Loop through each row in the table.
    for (int i = 1; i < table.Rows.Count; i++)
    {
        // The current row.
        Row row = table.Rows[i];

        // The cell in this row that belongs to the new column.
        Cell cell = row.Cells[table.ColumnCount - 1];

        // The first Paragraph that this cell houses.
        Paragraph p = cell.Paragraphs[0];

        // Insert this rows index.
        p.InsertText(i.ToString(), false);
    }

    document.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
InsertColumn Overload


Table.InsertColumn Method (Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertColumn Method (Int32)
Table Class Example See Also Send Feedback
Insert a column into a table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertColumn(
    int index
)
Visual Basic
Public Sub InsertColumn (
    index As Integer
)
Visual C++
public:
void InsertColumn(
    int index
)

Parameters

index
Type: System..::..Int32
The index to insert the column at.

Examples

Insert a column to the left of a table.
Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Get the first Table in this document.
    Table table = document.Tables[0];

    // Insert a new column to this left of this table.
    table.InsertColumn(0);

    // Set the new columns text to "Row no."
    table.Rows[0].Cells[table.ColumnCount - 1].Paragraph.InsertText("Row no.", false);

    // Loop through each row in the table.
    for (int i = 1; i < table.Rows.Count; i++)
    {
        // The current row.
        Row row = table.Rows[i];

        // The cell in this row that belongs to the new column.
        Cell cell = row.Cells[table.ColumnCount - 1];

        // The first Paragraph that this cell houses.
        Paragraph p = cell.Paragraphs[0];

        // Insert this rows index.
        p.InsertText(i.ToString(), false);
    }

    document.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
InsertColumn Overload


Table.InsertPageBreakAfterSelf Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertPageBreakAfterSelf Method
Table Class Example See Also Send Feedback
Insert a page break after a Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override void InsertPageBreakAfterSelf()
Visual Basic
Public Overrides Sub InsertPageBreakAfterSelf
Visual C++
public:
virtual void InsertPageBreakAfterSelf() override

Examples

Insert a Table and a Paragraph into a document with a page break between them.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Table.
    Table t1 = document.InsertTable(2, 2);
    t1.Design = TableDesign.LightShadingAccent1;

    // Insert a page break after this Table.
    t1.InsertPageBreakAfterSelf();

    // Insert a new Paragraph.
    Paragraph p1 = document.InsertParagraph("Paragraph", false);

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Table Class
Table Members


Table.InsertPageBreakBeforeSelf Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertPageBreakBeforeSelf Method
Table Class Example See Also Send Feedback
Insert a page break before a Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override void InsertPageBreakBeforeSelf()
Visual Basic
Public Overrides Sub InsertPageBreakBeforeSelf
Visual C++
public:
virtual void InsertPageBreakBeforeSelf() override

Examples

Insert a Table and a Paragraph into a document with a page break between them.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a new Paragraph.
    Paragraph p1 = document.InsertParagraph("Paragraph", false);

    // Insert a new Table.
    Table t1 = document.InsertTable(2, 2);
    t1.Design = TableDesign.LightShadingAccent1;

    // Insert a page break before this Table.
    t1.InsertPageBreakBeforeSelf();

    // Save this document.
    document.Save();
}// Release this document from memory.

See Also

Table Class
Table Members


Table.InsertParagraphAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphAfterSelf Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphAfterSelf(String) | Insert a new Paragraph after this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | Insert a Paragraph after this Table, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | Insert a new Paragraph after this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | Insert a new Paragraph after this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)

See Also

Table Class
Table Members


Table.InsertParagraphAfterSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphAfterSelf Method (String)
Table Class Example See Also Send Feedback
Insert a new Paragraph after this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.

Return Value

Type: Paragraph
A new Paragraph inserted after this Table.

Examples

Insert a new Paragraph after the first Table in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Table into this document.
    Table t = document.InsertTable(2, 2);

    t.InsertParagraphAfterSelf("I was inserted after the previous Table.");

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Table Class
Table Members
InsertParagraphAfterSelf Overload


Table.InsertParagraphAfterSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphAfterSelf Method (Paragraph)
Table Class Example See Also Send Feedback
Insert a Paragraph after this Table, this Paragraph may have come from the same or another document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    Paragraph^ p
) override

Parameters

p
Type: Novacode..::..Paragraph
The Paragraph to insert.

Return Value

Type: Paragraph
The Paragraph now associated with this document.

Examples

Take a Paragraph from document a, and insert it into document b after this Table.
Copy image Copy
// Place holder for a Paragraph.
Paragraph p;

// Load document a.
using (DocX documentA = DocX.Load(@"a.docx"))
{
    // Get the first paragraph from this document.
    p = documentA.Paragraphs[0];
}

// Load document b.
using (DocX documentB = DocX.Load(@"b.docx"))
{
    // Get the first Table in document b.
    Table t = documentB.Tables[0];

    // Insert the Paragraph from document a after this Table.
    Paragraph newParagraph = t.InsertParagraphAfterSelf(p);

    // Save all changes made to document b.
    documentB.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
InsertParagraphAfterSelf Overload


Table.InsertParagraphAfterSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphAfterSelf Method (String, Boolean)
Table Class Example See Also Send Feedback
Insert a new Paragraph after this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.
trackChanges
Type: System..::..Boolean
Should this insertion be tracked as a change?

Return Value

Type: Paragraph
A new Paragraph inserted after this Table.

Examples

Insert a new paragraph after the first Table in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Table into this document.
    Table t = document.InsertTable(2, 2);

    t.InsertParagraphAfterSelf("I was inserted after the previous Table.", false);

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Table Class
Table Members
InsertParagraphAfterSelf Overload


Table.InsertParagraphAfterSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphAfterSelf Method (String, Boolean, Formatting)
Table Class Example See Also Send Feedback
Insert a new Paragraph after this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.
trackChanges
Type: System..::..Boolean
Should this insertion be tracked as a change?
formatting
Type: Novacode..::..Formatting
The formatting to apply to this insertion.

Return Value

Type: Paragraph
A new Paragraph inserted after this Table.

Examples

Insert a new paragraph after the first Table in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Table into this document.
    Table t = document.InsertTable(2, 2);

    Formatting boldFormatting = new Formatting();
    boldFormatting.Bold = true;

    t.InsertParagraphAfterSelf("I was inserted after the previous Table.", false, boldFormatting);

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Table Class
Table Members
InsertParagraphAfterSelf Overload


Table.InsertParagraphBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphBeforeSelf Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphBeforeSelf(String) | Insert a new Paragraph before this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | Insert a Paragraph before this Table, this Paragraph may have come from the same or another document. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | Insert a new Paragraph before this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | Insert a new Paragraph before this Table. (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)

See Also

Table Class
Table Members


Table.InsertParagraphBeforeSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphBeforeSelf Method (String)
Table Class Example See Also Send Feedback
Insert a new Paragraph before this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.

Return Value

Type: Paragraph
A new Paragraph inserted before this Table.

Examples

Insert a new Paragraph before the first Table in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Table into this document.
    Table t = document.InsertTable(2, 2);

    t.InsertParagraphBeforeSelf("I was inserted before the next Table.");

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Table Class
Table Members
InsertParagraphBeforeSelf Overload


Table.InsertParagraphBeforeSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphBeforeSelf Method (Paragraph)
Table Class Example See Also Send Feedback
Insert a Paragraph before this Table, this Paragraph may have come from the same or another document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    Paragraph^ p
) override

Parameters

p
Type: Novacode..::..Paragraph
The Paragraph to insert.

Return Value

Type: Paragraph
The Paragraph now associated with this document.

Examples

Take a Paragraph from document a, and insert it into document b before this Table.
Copy image Copy
// Place holder for a Paragraph.
Paragraph p;

// Load document a.
using (DocX documentA = DocX.Load(@"a.docx"))
{
    // Get the first paragraph from this document.
    p = documentA.Paragraphs[0];
}

// Load document b.
using (DocX documentB = DocX.Load(@"b.docx"))
{
    // Get the first Table in document b.
    Table t = documentB.Tables[0];

    // Insert the Paragraph from document a before this Table.
    Paragraph newParagraph = t.InsertParagraphBeforeSelf(p);

    // Save all changes made to document b.
    documentB.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
InsertParagraphBeforeSelf Overload


Table.InsertParagraphBeforeSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphBeforeSelf Method (String, Boolean)
Table Class Example See Also Send Feedback
Insert a new Paragraph before this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.
trackChanges
Type: System..::..Boolean
Should this insertion be tracked as a change?

Return Value

Type: Paragraph
A new Paragraph inserted before this Table.

Examples

Insert a new paragraph before the first Table in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Table into this document.
    Table t = document.InsertTable(2, 2);

    t.InsertParagraphBeforeSelf("I was inserted before the next Table.", false);

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Table Class
Table Members
InsertParagraphBeforeSelf Overload


Table.InsertParagraphBeforeSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphBeforeSelf Method (String, Boolean, Formatting)
Table Class Example See Also Send Feedback
Insert a new Paragraph before this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override

Parameters

text
Type: System..::..String
The initial text for this new Paragraph.
trackChanges
Type: System..::..Boolean
Should this insertion be tracked as a change?
formatting
Type: Novacode..::..Formatting
The formatting to apply to this insertion.

Return Value

Type: Paragraph
A new Paragraph inserted before this Table.

Examples

Insert a new paragraph before the first Table in this document.
Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    // Insert a Table into this document.
    Table t = document.InsertTable(2, 2);

    Formatting boldFormatting = new Formatting();
    boldFormatting.Bold = true;

    t.InsertParagraphBeforeSelf("I was inserted before the next Table.", false, boldFormatting);

    // Save all changes made to this new document.
    document.Save();
   }// Release this new document form memory.

See Also

Table Class
Table Members
InsertParagraphBeforeSelf Overload


Table.InsertRow Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertRow Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertRow()()()() | Insert a row at the end of this table.
Public method | InsertRow(Int32) | Insert a row into this table.
Public method | InsertRow(Row) | Insert a copy of a row at the end of this table.
Public method | InsertRow(Row, Int32) | Insert a copy of a row into this table.

See Also

Table Class
Table Members


Table.InsertRow Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertRow Method
Table Class Example See Also Send Feedback
Insert a row at the end of this table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Row InsertRow()
Visual Basic
Public Function InsertRow As Row
Visual C++
public:
Row^ InsertRow()

Return Value

Type: Row
A new row.

Examples

Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Get the first table in this document.
    Table table = document.Tables[0];

    // Insert a new row at the end of this table.
    Row row = table.InsertRow();

    // Loop through each cell in this new row.
    foreach (Cell c in row.Cells)
    {
        // Set the text of each new cell to "Hello".
        c.Paragraphs[0].InsertText("Hello", false);
    }

    // Save the document to a new file.
    document.SaveAs(@"C:\Example\Test2.docx");
}// Release this document from memory.

See Also

Table Class
Table Members
InsertRow Overload


Table.InsertRow Method (Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertRow Method (Int32)
Table Class Example See Also Send Feedback
Insert a row into this table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Row InsertRow(
    int index
)
Visual Basic
Public Function InsertRow (
    index As Integer
) As Row
Visual C++
public:
Row^ InsertRow(
    int index
)

Parameters

index
Type: System..::..Int32
Index to insert row at.

Return Value

Type: Row
A new Row

Examples

Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Get the first table in this document.
    Table table = document.Tables[0];

    // Insert a new row at index 1 in this table.
    Row row = table.InsertRow(1);

    // Loop through each cell in this new row.
    foreach (Cell c in row.Cells)
    {
        // Set the text of each new cell to "Hello".
        c.Paragraphs[0].InsertText("Hello", false);
    }

    // Save the document to a new file.
    document.SaveAs(@"C:\Example\Test2.docx");
}// Release this document from memory.

See Also

Table Class
Table Members
InsertRow Overload


Table.InsertRow Method (Row)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertRow Method (Row)
Table Class See Also Send Feedback
Insert a copy of a row at the end of this table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Row InsertRow(
    Row row
)
Visual Basic
Public Function InsertRow (
    row As Row
) As Row
Visual C++
public:
Row^ InsertRow(
    Row^ row
)

Parameters

row
Type: Novacode..::..Row

[Missing <param name="row"/> documentation for "M:Novacode.Table.InsertRow(Novacode.Row)"]

Return Value

Type: Row
A new row.

See Also

Table Class
Table Members
InsertRow Overload


Table.InsertRow Method (Row, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertRow Method (Row, Int32)
Table Class See Also Send Feedback
Insert a copy of a row into this table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Row InsertRow(
    Row row,
    int index
)
Visual Basic
Public Function InsertRow (
    row As Row,
    index As Integer
) As Row
Visual C++
public:
Row^ InsertRow(
    Row^ row,
    int index
)

Parameters

row
Type: Novacode..::..Row
Row to copy and insert.
index
Type: System..::..Int32
Index to insert row at.

Return Value

Type: Row
A new Row

See Also

Table Class
Table Members
InsertRow Overload


Table.InsertTableAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableAfterSelf Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableAfterSelf(Table) | Insert a new Table after this Table, this Table can be from this document or another document. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | Insert a new Table into this document after this Table. (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)

See Also

Table Class
Table Members


Table.InsertTableAfterSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableAfterSelf Method (Table)
Table Class Example See Also Send Feedback
Insert a new Table after this Table, this Table can be from this document or another document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableAfterSelf(
    Table t
)
Visual Basic
Public Overrides Function InsertTableAfterSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    Table^ t
) override

Parameters

t
Type: Novacode..::..Table
The Table t to be inserted

Return Value

Type: Table
A new Table inserted after this Table.

Examples

Insert a new Table after this Table.
Copy image Copy
// Place holder for a Table.
Table t;

// Load document a.
using (DocX documentA = DocX.Load(@"a.docx"))
{
    // Get the first Table from this document.
    t = documentA.Tables[0];
}

// Load document b.
using (DocX documentB = DocX.Load(@"b.docx"))
{
    // Get the first Table in document b.
    Table t2 = documentB.Tables[0];

    // Insert the Table from document a after this Table.
    Table newTable = t2.InsertTableAfterSelf(t);

    // Save all changes made to document b.
    documentB.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
InsertTableAfterSelf Overload


Table.InsertTableAfterSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableAfterSelf Method (Int32, Int32)
Table Class Example See Also Send Feedback
Insert a new Table into this document after this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overrides Function InsertTableAfterSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    int rowCount,
    int columnCount
) override

Parameters

rowCount
Type: System..::..Int32
The number of rows this Table should have.
columnCount
Type: System..::..Int32
The number of columns this Table should have.

Return Value

Type: Table
A new Table inserted before this Table.

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    //Insert a Table into this document.
    Table t = document.InsertTable(2, 2);
    t.Design = TableDesign.LightShadingAccent1;
    t.Alignment = Alignment.center;

    // Insert a new Table after this Table.
    Table newTable = t.InsertTableAfterSelf(2, 2);
    newTable.Design = TableDesign.LightShadingAccent2;
    newTable.Alignment = Alignment.center;

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
InsertTableAfterSelf Overload


Table.InsertTableBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableBeforeSelf Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableBeforeSelf(Table) | Insert a new Table before this Table, this Table can be from this document or another document. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | Insert a new Table into this document before this Table. (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)

See Also

Table Class
Table Members


Table.InsertTableBeforeSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableBeforeSelf Method (Table)
Table Class Example See Also Send Feedback
Insert a new Table before this Table, this Table can be from this document or another document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableBeforeSelf(
    Table t
)
Visual Basic
Public Overrides Function InsertTableBeforeSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    Table^ t
) override

Parameters

t
Type: Novacode..::..Table
The Table t to be inserted

Return Value

Type: Table
A new Table inserted before this Table.

Examples

Insert a new Table before this Table.
Copy image Copy
// Place holder for a Table.
Table t;

// Load document a.
using (DocX documentA = DocX.Load(@"a.docx"))
{
    // Get the first Table from this document.
    t = documentA.Tables[0];
}

// Load document b.
using (DocX documentB = DocX.Load(@"b.docx"))
{
    // Get the first Table in document b.
    Table t2 = documentB.Tables[0];

    // Insert the Table from document a before this Table.
    Table newTable = t2.InsertTableBeforeSelf(t);

    // Save all changes made to document b.
    documentB.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
InsertTableBeforeSelf Overload


Table.InsertTableBeforeSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableBeforeSelf Method (Int32, Int32)
Table Class Example See Also Send Feedback
Insert a new Table into this document before this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overrides Function InsertTableBeforeSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    int rowCount,
    int columnCount
) override

Parameters

rowCount
Type: System..::..Int32
The number of rows this Table should have.
columnCount
Type: System..::..Int32
The number of columns this Table should have.

Return Value

Type: Table
A new Table inserted before this Table.

Examples

Copy image Copy
// Create a new document.
using (DocX document = DocX.Create(@"Test.docx"))
{
    //Insert a Table into this document.
    Table t = document.InsertTable(2, 2);
    t.Design = TableDesign.LightShadingAccent1;
    t.Alignment = Alignment.center;

    // Insert a new Table before this Table.
    Table newTable = t.InsertTableBeforeSelf(2, 2);
    newTable.Design = TableDesign.LightShadingAccent2;
    newTable.Alignment = Alignment.center;

    // Save all changes made to this document.
    document.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
InsertTableBeforeSelf Overload


Table.MergeCellsInColumn Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..MergeCellsInColumn Method
Table Class See Also Send Feedback
Merge cells in given column starting with startRow and ending with endRow.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void MergeCellsInColumn(
    int columnIndex,
    int startRow,
    int endRow
)
Visual Basic
Public Sub MergeCellsInColumn (
    columnIndex As Integer,
    startRow As Integer,
    endRow As Integer
)
Visual C++
public:
void MergeCellsInColumn(
    int columnIndex,
    int startRow,
    int endRow
)

Parameters

columnIndex
Type: System..::..Int32

[Missing <param name="columnIndex"/> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

startRow
Type: System..::..Int32

[Missing <param name="startRow"/> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

endRow
Type: System..::..Int32

[Missing <param name="endRow"/> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

Remarks

Added by arudoy patch: 11608

See Also

Table Class
Table Members


Table.Remove Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Remove Method
Table Class Example See Also Send Feedback
Remove this Table from this document.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Remove()
Visual Basic
Public Sub Remove
Visual C++
public:
void Remove()

Examples

Remove the first Table from this document.
Copy image Copy
// Load a document into memory.
using (DocX document = DocX.Load(@"Test.docx"))
{
    // Get the first Table in this document.
    Table t = d.Tables[0];

    // Remove this Table.
    t.Remove();

    // Save all changes made to the document.
    document.Save();
} // Release this document from memory.

See Also

Table Class
Table Members


Table.RemoveColumn Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveColumn Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveColumn()()()() | Remove the last column for this Table.
Public method | RemoveColumn(Int32) | Remove a column from this Table.

See Also

Table Class
Table Members


Table.RemoveColumn Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveColumn Method
Table Class Example See Also Send Feedback
Remove the last column for this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveColumn()
Visual Basic
Public Sub RemoveColumn
Visual C++
public:
void RemoveColumn()

Examples

Remove the last column from a Table.
Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Get the first table in this document.
    Table table = document.Tables[0];

    // Remove the last column from this table.
    table.RemoveColumn();

    // Save the document.
    document.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
RemoveColumn Overload


Table.RemoveColumn Method (Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveColumn Method (Int32)
Table Class Example See Also Send Feedback
Remove a column from this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveColumn(
    int index
)
Visual Basic
Public Sub RemoveColumn (
    index As Integer
)
Visual C++
public:
void RemoveColumn(
    int index
)

Parameters

index
Type: System..::..Int32
The column to remove.

Examples

Remove the first column from a Table.
Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Get the first table in this document.
    Table table = document.Tables[0];

    // Remove the first column from this table.
    table.RemoveColumn(0);

    // Save the document.
    document.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
RemoveColumn Overload


Table.RemoveRow Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveRow Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveRow()()()() | Remove the last row from this Table.
Public method | RemoveRow(Int32) | Remove a row from this Table.

See Also

Table Class
Table Members


Table.RemoveRow Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveRow Method
Table Class Example See Also Send Feedback
Remove the last row from this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveRow()
Visual Basic
Public Sub RemoveRow
Visual C++
public:
void RemoveRow()

Examples

Remove the last row from a Table.
Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Get the first table in this document.
    Table table = document.Tables[0];

    // Remove the last row from this table.
    table.RemoveRow();

    // Save the document.
    document.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
RemoveRow Overload


Table.RemoveRow Method (Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveRow Method (Int32)
Table Class Example See Also Send Feedback
Remove a row from this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveRow(
    int index
)
Visual Basic
Public Sub RemoveRow (
    index As Integer
)
Visual C++
public:
void RemoveRow(
    int index
)

Parameters

index
Type: System..::..Int32
The row to remove.

Examples

Remove the first row from a Table.
Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"C:\Example\Test.docx"))
{
    // Get the first table in this document.
    Table table = document.Tables[0];

    // Remove the first row from this table.
    table.RemoveRow(0);

    // Save the document.
    document.Save();
}// Release this document from memory.

See Also

Table Class
Table Members
RemoveRow Overload


Table.SetBorder Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..SetBorder Method
Table Class Example See Also Send Feedback
Set a table border Added by lckuiper @ 20101117

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetBorder(
    TableBorderType borderType,
    Border border
)
Visual Basic
Public Sub SetBorder (
    borderType As TableBorderType,
    border As Border
)
Visual C++
public:
void SetBorder(
    TableBorderType borderType,
    Border^ border
)

Parameters

borderType
Type: Novacode..::..TableBorderType
The table border to set
border
Type: Novacode..::..Border
Border object to set the table border

Examples

Copy image Copy
 // Create a new document.
using (DocX document = DocX.Create("Test.docx"))
{
    // Insert a table into this document.
    Table t = document.InsertTable(3, 3);

    // Create a large blue border.
    Border b = new Border(BorderStyle.Tcbs_single, BorderSize.seven, 0, Color.Blue);

    // Set the tables Top, Bottom, Left and Right Borders to b.
    t.SetBorder(TableBorderType.Top, b);
    t.SetBorder(TableBorderType.Bottom, b);
    t.SetBorder(TableBorderType.Left, b);
    t.SetBorder(TableBorderType.Right, b);

    // Save the document.
    document.Save();
}

See Also

Table Class
Table Members


Table.SetDirection Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..SetDirection Method
Table Class Example See Also Send Feedback
Set the direction of all content in this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetDirection(
    Direction direction
)
Visual Basic
Public Sub SetDirection (
    direction As Direction
)
Visual C++
public:
void SetDirection(
    Direction direction
)

Parameters

direction
Type: Novacode..::..Direction
(Left to Right) or (Right to Left)

Examples

Set the content direction for all content in a table to RightToLeft.
Copy image Copy
// Load a document.
using (DocX document = DocX.Load(@"Test.docx"))
{
    // Get the first table in a document.
    Table table = document.Tables[0];

    // Set the content direction for all content in this table to RightToLeft.
    table.SetDirection(Direction.RightToLeft);

    // Save all changes made to this document.
    document.Save();
}

See Also

Table Class
Table Members


Table Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Table Properties
Table Class See Also Send Feedback

The Table type exposes the following members.

Properties

 | Name | Description
Public property | Alignment |
Public property | AutoFit | Auto size this table according to some rule.
Public property | ColumnCount | Returns the number of columns in this table.
Public property | CustomTableDesignName | Extra property for Custom Table Style provided by carpfisher - Thanks
Public property | Design | The design\style to apply to this table. Patch1. Patch to code for Custom Table Style support by carpfisher
Public property | Hyperlinks |
Public property | Index | Returns the index of this Table.
Public property | Paragraphs | Returns a list of all Paragraphs inside this container.
Public property | Pictures |
Public property | RowCount | Returns the number of rows in this table.
Public property | Rows | Returns a list of rows in this table.
Public property | TableLook |
Public property | Xml | This is the actual Xml that gives this element substance. For example, a Paragraphs Xml might look something like the following Hello World! (Inherited from DocXElement.)

See Also

Table Class


Table.Alignment Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Alignment Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.Alignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Alignment Alignment { get; set; }
Visual Basic
Public Property Alignment As Alignment
    Get
    Set
Visual C++
public:
property Alignment Alignment {
    Alignment get ();
    void set (Alignment value);
}

Property Value

Type: Alignment

See Also

Table Class
Table Members


Table.AutoFit Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..AutoFit Property
Table Class See Also Send Feedback
Auto size this table according to some rule.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public AutoFit AutoFit { get; set; }
Visual Basic
Public Property AutoFit As AutoFit
    Get
    Set
Visual C++
public:
property AutoFit AutoFit {
    AutoFit get ();
    void set (AutoFit value);
}

Property Value

Type: AutoFit

Remarks

Added by Roger Saele, April 2012. Thank you for your contribution Roger.

See Also

Table Class
Table Members


Table.ColumnCount Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..ColumnCount Property
Table Class See Also Send Feedback
Returns the number of columns in this table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int ColumnCount { get; }
Visual Basic
Public ReadOnly Property ColumnCount As Integer
    Get
Visual C++
public:
property int ColumnCount {
    int get ();
}

Property Value

Type: Int32

See Also

Table Class
Table Members


Table.CustomTableDesignName Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..CustomTableDesignName Property
Table Class See Also Send Feedback
Extra property for Custom Table Style provided by carpfisher - Thanks

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string CustomTableDesignName { get; set; }
Visual Basic
Public Property CustomTableDesignName As String
    Get
    Set
Visual C++
public:
property String^ CustomTableDesignName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Table Class
Table Members


Table.Design Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Design Property
Table Class Example See Also Send Feedback
The design\style to apply to this table. Patch1. Patch to code for Custom Table Style support by carpfisher

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public TableDesign Design { get; set; }
Visual Basic
Public Property Design As TableDesign
    Get
    Set
Visual C++
public:
property TableDesign Design {
    TableDesign get ();
    void set (TableDesign value);
}

Property Value

Type: TableDesign

Examples

Example code for custom table style usage
Copy image Copy
Novacode.DocX document = Novacode.DocX.Load(“DOC01.doc”); // load document with custom table style defined
Novacode.Table t = document.AddTable(2, 2); // adds table
t.CustomTableDesignName = “MyStyle01”; // assigns Custom Table Design style to newly created table

See Also

Table Class
Table Members


Table.Hyperlinks Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Hyperlinks Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.Hyperlinks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Hyperlink> Hyperlinks { get; }
Visual Basic
Public ReadOnly Property Hyperlinks As List(Of Hyperlink)
    Get
Visual C++
public:
property List<Hyperlink^>^ Hyperlinks {
    List<Hyperlink^>^ get ();
}

Property Value

Type: List <(Of <(<' Hyperlink >)>)>

See Also

Table Class
Table Members


Table.Index Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Index Property
Table Class Example See Also Send Feedback
Returns the index of this Table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}

Property Value

Type: Int32

Examples

Replace the first table in this document with a new Table.
Copy image Copy
// Load a document into memory.
using (DocX document = DocX.Load(@"Test.docx"))
{
    // Get the first Table in this document.
    Table t = document.Tables[0];

    // Get the character index of Table t in this document.
    int index = t.Index;

    // Remove Table t.
    t.Remove();

    // Insert a new Table at the original index of Table t.
    Table newTable = document.InsertTable(index, 4, 4);

    // Set the design of this new Table, so that we can see it.
    newTable.Design = TableDesign.LightShadingAccent1;

    // Save all changes made to the document.
    document.Save();
} // Release this document from memory.

See Also

Table Class
Table Members


Table.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Paragraphs Property
Table Class See Also Send Feedback
Returns a list of all Paragraphs inside this container.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Paragraph> Paragraphs { get; }
Visual Basic
Public Overridable ReadOnly Property Paragraphs As List(Of Paragraph)
    Get
Visual C++
public:
virtual property List<Paragraph^>^ Paragraphs {
    List<Paragraph^>^ get ();
}

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

Table Class
Table Members


Table.Pictures Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Pictures Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.Pictures"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Picture> Pictures { get; }
Visual Basic
Public ReadOnly Property Pictures As List(Of Picture)
    Get
Visual C++
public:
property List<Picture^>^ Pictures {
    List<Picture^>^ get ();
}

Property Value

Type: List <(Of <(<' Picture >)>)>

See Also

Table Class
Table Members


Table.RowCount Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..RowCount Property
Table Class See Also Send Feedback
Returns the number of rows in this table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int RowCount { get; }
Visual Basic
Public ReadOnly Property RowCount As Integer
    Get
Visual C++
public:
property int RowCount {
    int get ();
}

Property Value

Type: Int32

See Also

Table Class
Table Members


Table.Rows Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Rows Property
Table Class See Also Send Feedback
Returns a list of rows in this table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Row> Rows { get; }
Visual Basic
Public ReadOnly Property Rows As List(Of Row)
    Get
Visual C++
public:
property List<Row^>^ Rows {
    List<Row^>^ get ();
}

Property Value

Type: List <(Of <(<' Row >)>)>

See Also

Table Class
Table Members


Table.TableLook Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..TableLook Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.TableLook"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public TableLook TableLook { get; set; }
Visual Basic
Public Property TableLook As TableLook
    Get
    Set
Visual C++
public:
property TableLook^ TableLook {
    TableLook^ get ();
    void set (TableLook^ value);
}

Property Value

Type: TableLook

See Also

Table Class
Table Members


TableBorderType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
TableBorderType Enumeration
See Also Send Feedback
Table Border Types Added by lckuiper @ 20101117 source: http://msdn.microsoft.com/en-us/library/documentformat.openxml.wordprocessing.tableborders.aspx

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum TableBorderType
Visual Basic
Public Enumeration TableBorderType
Visual C++
public enum class TableBorderType

Members

Member name | Value | Description
Top | 0 |
Bottom | 1 |
Left | 2 |
Right | 3 |
InsideH | 4 |
InsideV | 5 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


TableCellBorderType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
TableCellBorderType Enumeration
See Also Send Feedback
Table Cell Border Types Added by lckuiper @ 20101117 source: http://msdn.microsoft.com/en-us/library/documentformat.openxml.wordprocessing.tablecellborders.aspx

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum TableCellBorderType
Visual Basic
Public Enumeration TableCellBorderType
Visual C++
public enum class TableCellBorderType

Members

Member name | Value | Description
Top | 0 |
Bottom | 1 |
Left | 2 |
Right | 3 |
InsideH | 4 |
InsideV | 5 |
TopLeftToBottomRight | 6 |
TopRightToBottomLeft | 7 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


TableDesign Enumeration

[image]

DocX - A Sandcastle Documented Class Library
TableDesign Enumeration
See Also Send Feedback
Designs\Styles that can be applied to a table.

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum TableDesign
Visual Basic
Public Enumeration TableDesign
Visual C++
public enum class TableDesign

Members

Member name | Value | Description
Custom | 0 |
TableNormal | 1 |
TableGrid | 2 |
LightShading | 3 |
LightShadingAccent1 | 4 |
LightShadingAccent2 | 5 |
LightShadingAccent3 | 6 |
LightShadingAccent4 | 7 |
LightShadingAccent5 | 8 |
LightShadingAccent6 | 9 |
LightList | 10 |
LightListAccent1 | 11 |
LightListAccent2 | 12 |
LightListAccent3 | 13 |
LightListAccent4 | 14 |
LightListAccent5 | 15 |
LightListAccent6 | 16 |
LightGrid | 17 |
LightGridAccent1 | 18 |
LightGridAccent2 | 19 |
LightGridAccent3 | 20 |
LightGridAccent4 | 21 |
LightGridAccent5 | 22 |
LightGridAccent6 | 23 |
MediumShading1 | 24 |
MediumShading1Accent1 | 25 |
MediumShading1Accent2 | 26 |
MediumShading1Accent3 | 27 |
MediumShading1Accent4 | 28 |
MediumShading1Accent5 | 29 |
MediumShading1Accent6 | 30 |
MediumShading2 | 31 |
MediumShading2Accent1 | 32 |
MediumShading2Accent2 | 33 |
MediumShading2Accent3 | 34 |
MediumShading2Accent4 | 35 |
MediumShading2Accent5 | 36 |
MediumShading2Accent6 | 37 |
MediumList1 | 38 |
MediumList1Accent1 | 39 |
MediumList1Accent2 | 40 |
MediumList1Accent3 | 41 |
MediumList1Accent4 | 42 |
MediumList1Accent5 | 43 |
MediumList1Accent6 | 44 |
MediumList2 | 45 |
MediumList2Accent1 | 46 |
MediumList2Accent2 | 47 |
MediumList2Accent3 | 48 |
MediumList2Accent4 | 49 |
MediumList2Accent5 | 50 |
MediumList2Accent6 | 51 |
MediumGrid1 | 52 |
MediumGrid1Accent1 | 53 |
MediumGrid1Accent2 | 54 |
MediumGrid1Accent3 | 55 |
MediumGrid1Accent4 | 56 |
MediumGrid1Accent5 | 57 |
MediumGrid1Accent6 | 58 |
MediumGrid2 | 59 |
MediumGrid2Accent1 | 60 |
MediumGrid2Accent2 | 61 |
MediumGrid2Accent3 | 62 |
MediumGrid2Accent4 | 63 |
MediumGrid2Accent5 | 64 |
MediumGrid2Accent6 | 65 |
MediumGrid3 | 66 |
MediumGrid3Accent1 | 67 |
MediumGrid3Accent2 | 68 |
MediumGrid3Accent3 | 69 |
MediumGrid3Accent4 | 70 |
MediumGrid3Accent5 | 71 |
MediumGrid3Accent6 | 72 |
DarkList | 73 |
DarkListAccent1 | 74 |
DarkListAccent2 | 75 |
DarkListAccent3 | 76 |
DarkListAccent4 | 77 |
DarkListAccent5 | 78 |
DarkListAccent6 | 79 |
ColorfulShading | 80 |
ColorfulShadingAccent1 | 81 |
ColorfulShadingAccent2 | 82 |
ColorfulShadingAccent3 | 83 |
ColorfulShadingAccent4 | 84 |
ColorfulShadingAccent5 | 85 |
ColorfulShadingAccent6 | 86 |
ColorfulList | 87 |
ColorfulListAccent1 | 88 |
ColorfulListAccent2 | 89 |
ColorfulListAccent3 | 90 |
ColorfulListAccent4 | 91 |
ColorfulListAccent5 | 92 |
ColorfulListAccent6 | 93 |
ColorfulGrid | 94 |
ColorfulGridAccent1 | 95 |
ColorfulGridAccent2 | 96 |
ColorfulGridAccent3 | 97 |
ColorfulGridAccent4 | 98 |
ColorfulGridAccent5 | 99 |
ColorfulGridAccent6 | 100 |
None | 101 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


TableLook Class

[image]

DocX - A Sandcastle Documented Class Library
TableLook Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.TableLook"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class TableLook
Visual Basic
Public Class TableLook
Visual C++
public ref class TableLook

Inheritance Hierarchy

System..::..Object
Novacode..::..TableLook

See Also

TableLook Members


TableLook Members

[image] [image]

DocX - A Sandcastle Documented Class Library
TableLook Members
TableLook Class Constructors Methods Properties See Also Send Feedback

The TableLook type exposes the following members.

Constructors

 | Name | Description
Public method | TableLook | Initializes a new instance of the TableLook class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FirstColumn |
Public property | FirstRow |
Public property | LastColumn |
Public property | LastRow |
Public property | NoHorizontalBanding |
Public property | NoVerticalBanding |

See Also

TableLook Class


TableLook Constructor

[image]

DocX - A Sandcastle Documented Class Library
TableLook Constructor
TableLook Class See Also Send Feedback
Initializes a new instance of the TableLook class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public TableLook()
Visual Basic
Public Sub New
Visual C++
public:
TableLook()

See Also

TableLook Class
TableLook Members


TableLook Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
TableLook Methods
TableLook Class See Also Send Feedback

The TableLook type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableLook Class


TableLook Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
TableLook Properties
TableLook Class See Also Send Feedback

The TableLook type exposes the following members.

Properties

 | Name | Description
Public property | FirstColumn |
Public property | FirstRow |
Public property | LastColumn |
Public property | LastRow |
Public property | NoHorizontalBanding |
Public property | NoVerticalBanding |

See Also

TableLook Class


TableLook.FirstColumn Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..FirstColumn Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.FirstColumn"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool FirstColumn { get; set; }
Visual Basic
Public Property FirstColumn As Boolean
    Get
    Set
Visual C++
public:
property bool FirstColumn {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


TableLook.FirstRow Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..FirstRow Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.FirstRow"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool FirstRow { get; set; }
Visual Basic
Public Property FirstRow As Boolean
    Get
    Set
Visual C++
public:
property bool FirstRow {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


TableLook.LastColumn Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..LastColumn Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.LastColumn"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool LastColumn { get; set; }
Visual Basic
Public Property LastColumn As Boolean
    Get
    Set
Visual C++
public:
property bool LastColumn {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


TableLook.LastRow Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..LastRow Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.LastRow"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool LastRow { get; set; }
Visual Basic
Public Property LastRow As Boolean
    Get
    Set
Visual C++
public:
property bool LastRow {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


TableLook.NoHorizontalBanding Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..NoHorizontalBanding Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.NoHorizontalBanding"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool NoHorizontalBanding { get; set; }
Visual Basic
Public Property NoHorizontalBanding As Boolean
    Get
    Set
Visual C++
public:
property bool NoHorizontalBanding {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


TableLook.NoVerticalBanding Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..NoVerticalBanding Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.NoVerticalBanding"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool NoVerticalBanding { get; set; }
Visual Basic
Public Property NoVerticalBanding As Boolean
    Get
    Set
Visual C++
public:
property bool NoVerticalBanding {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


UnderlineStyle Enumeration

[image]

DocX - A Sandcastle Documented Class Library
UnderlineStyle Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.UnderlineStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum UnderlineStyle
Visual Basic
Public Enumeration UnderlineStyle
Visual C++
public enum class UnderlineStyle

Members

Member name | Value | Description
none | 0 |
singleLine | 1 |
doubleLine | 2 |
thick | 3 |
dotted | 4 |
dottedHeavy | 5 |
dash | 6 |
dashedHeavy | 7 |
dashLong | 8 |
dashLongHeavy | 9 |
dotDash | 10 |
dashDotHeavy | 11 |
dotDotDash | 12 |
dashDotDotHeavy | 13 |
wave | 14 |
wavyHeavy | 15 |
wavyDouble | 16 |
words | 17 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


ValueAxis Class

[image]

DocX - A Sandcastle Documented Class Library
ValueAxis Class
Members See Also Send Feedback
Represents Values Axes

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class ValueAxis : Axis
Visual Basic
Public Class ValueAxis
    Inherits Axis
Visual C++
public ref class ValueAxis : public Axis

Inheritance Hierarchy

System..::..Object
Novacode..::..Axis
Novacode..::..ValueAxis

See Also

ValueAxis Members


ValueAxis Members

[image] [image]

DocX - A Sandcastle Documented Class Library
ValueAxis Members
ValueAxis Class Constructors Methods Properties See Also Send Feedback

The ValueAxis type exposes the following members.

Constructors

 | Name | Description
Public method | ValueAxis | Initializes a new instance of the ValueAxis class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | ID of this Axis (Inherited from Axis.)
Public property | IsVisible | Return true if this axis is visible (Inherited from Axis.)

See Also

ValueAxis Class


ValueAxis Constructor

[image]

DocX - A Sandcastle Documented Class Library
ValueAxis Constructor
ValueAxis Class See Also Send Feedback
Initializes a new instance of the ValueAxis class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ValueAxis(
    string id
)
Visual Basic
Public Sub New (
    id As String
)
Visual C++
public:
ValueAxis(
    String^ id
)

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:Novacode.ValueAxis.#ctor(System.String)"]

See Also

ValueAxis Class
ValueAxis Members


ValueAxis Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
ValueAxis Methods
ValueAxis Class See Also Send Feedback

The ValueAxis type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueAxis Class


ValueAxis Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
ValueAxis Properties
ValueAxis Class See Also Send Feedback

The ValueAxis type exposes the following members.

Properties

 | Name | Description
Public property | Id | ID of this Axis (Inherited from Axis.)
Public property | IsVisible | Return true if this axis is visible (Inherited from Axis.)

See Also

ValueAxis Class


VerticalAlignment Enumeration

[image]

DocX - A Sandcastle Documented Class Library
VerticalAlignment Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.VerticalAlignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum VerticalAlignment
Visual Basic
Public Enumeration VerticalAlignment
Visual C++
public enum class VerticalAlignment

Members

Member name | Value | Description
Top | 0 |
Center | 1 |
Bottom | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


XmlDocument Enumeration

[image]

DocX - A Sandcastle Documented Class Library
XmlDocument Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.XmlDocument"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum XmlDocument
Visual Basic
Public Enumeration XmlDocument
Visual C++
public enum class XmlDocument

Members

Member name | Value | Description
Main | 0 |
HeaderOdd | 1 |
HeaderEven | 2 |
HeaderFirst | 3 |
FooterOdd | 4 |
FooterEven | 5 |
FooterFirst | 6 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com