Novacode Namespace

[image]

DocX - A Sandcastle Documented Class Library
Novacode Namespace
Send Feedback

[Missing <summary> documentation for "N:Novacode"]

Classes

 | Class | Description
Public class | Axis |
Public class | BarChart |
Public class | Bookmark |
Public class | Border |
Public class | CategoryAxis |
Public class | Cell |
Public class | Chart |
Public class | ChartLegend |
Public class | Container |
Public class | CustomProperty |
Public class | DocProperty |
Public class | DocX |
Public class | DocXElement |
Public class | Footer |
Public class | Footers |
Public class | FormattedText |
Public class | Formatting |
Public class | Header |
Public class | Headers |
Public class | Hyperlink |
Public class | Image |
Public class | InsertBeforeOrAfter |
Public class | LineChart |
Public class | List |
Public class | PageLayout |
Public class | Paragraph |
Public class | Picture |
Public class | PieChart |
Public class | Row |
Public class | Run |
Public class | Section |
Public class | Series |
Public class | Table |
Public class | TableLook |
Public class | ValueAxis |

Enumerations

 | Enumeration | Description
Public enumeration | Alignment |
Public enumeration | AutoFit |
Public enumeration | BarDirection |
Public enumeration | BarGrouping |
Public enumeration | BasicShapes |
Public enumeration | BlockArrowShapes |
Public enumeration | BorderSize |
Public enumeration | BorderStyle |
Public enumeration | CalloutShapes |
Public enumeration | CapsStyle |
Public enumeration | ChartLegendPosition |
Public enumeration | ContainerType |
Public enumeration | Direction |
Public enumeration | DisplayBlanksAs |
Public enumeration | DocumentTypes |
Public enumeration | EditRestrictions |
Public enumeration | EquationShapes |
Public enumeration | FlowchartShapes |
Public enumeration | Grouping |
Public enumeration | Highlight |
Public enumeration | LineSpacingType |
Public enumeration | LineSpacingTypeAuto |
Public enumeration | ListItemType |
Public enumeration | MatchFormattingOptions |
Public enumeration | Misc |
Public enumeration | Orientation |
Public enumeration | PageNumberFormat |
Public enumeration | RectangleShapes |
Public enumeration | RunTextType |
Public enumeration | Script |
Public enumeration | SectionBreakType |
Public enumeration | StarAndBannerShapes |
Public enumeration | StrikeThrough |
Public enumeration | TableBorderType |
Public enumeration | TableCellBorderType |
Public enumeration | TableDesign |
Public enumeration | UnderlineStyle |
Public enumeration | VerticalAlignment |
Public enumeration | XmlDocument |

Send comments on this topic to coffey.cathal@gmail.com


Alignment Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Alignment Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Alignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Alignment
Visual Basic
Public Enumeration Alignment
Visual C++
public enum class Alignment
F#
type Alignment

Members

Member name | Value | Description
left | 0 |
center | 1 |
right | 2 |
both | 3 |

See Also

Novacode Namespace


AutoFit Enumeration

[image]

DocX - A Sandcastle Documented Class Library
AutoFit Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.AutoFit"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum AutoFit
Visual Basic
Public Enumeration AutoFit
Visual C++
public enum class AutoFit
F#
type AutoFit

Members

Member name | Value | Description
Contents | 0 |
Window | 1 |
ColumnWidth | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Axis Class

[image]

DocX - A Sandcastle Documented Class Library
Axis Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Axis"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public abstract class Axis
Visual Basic
Public MustInherit Class Axis
Visual C++
public ref class Axis abstract
F#
[<AbstractClassAttribute>]
type Axis =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..Axis
Novacode..::..CategoryAxis
Novacode..::..ValueAxis

See Also

Axis Members


Axis Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Axis Members
Axis Class Constructors Methods Properties See Also Send Feedback

The Axis type exposes the following members.

Constructors

 | Name | Description
Public method | Axis | Initializes a new instance of the Axis class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id |
Public property | IsVisible |

See Also

Axis Class


Axis Constructor

[image]

DocX - A Sandcastle Documented Class Library
Axis Constructor
Axis Class See Also Send Feedback
Initializes a new instance of the Axis class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Axis(
    string id
)
Visual Basic
Public Sub New (
    id As String
)
Visual C++
public:
Axis(
    String^ id
)
F#
new :
        id : string -> Axis

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:Novacode.Axis.#ctor(System.String)"]

See Also

Axis Class
Axis Members


Axis Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Axis Methods
Axis Class See Also Send Feedback

The Axis type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Axis Class


Axis Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Axis Properties
Axis Class See Also Send Feedback

The Axis type exposes the following members.

Properties

 | Name | Description
Public property | Id |
Public property | IsVisible |

See Also

Axis Class


Axis.Id Property

[image]

DocX - A Sandcastle Documented Class Library
Axis..::..Id Property
Axis Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Axis.Id"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}
F#
member Id : string with get

Property Value

Type: String

See Also

Axis Class
Axis Members


Axis.IsVisible Property

[image]

DocX - A Sandcastle Documented Class Library
Axis..::..IsVisible Property
Axis Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Axis.IsVisible"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
F#
member IsVisible : bool with get, set

Property Value

Type: Boolean

See Also

Axis Class
Axis Members


BarChart Class

[image]

DocX - A Sandcastle Documented Class Library
BarChart Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.BarChart"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class BarChart : Chart
Visual Basic
Public Class BarChart
    Inherits Chart
Visual C++
public ref class BarChart : public Chart
F#
type BarChart =
    class
        inherit Chart
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..Chart
Novacode..::..BarChart

See Also

BarChart Members


BarChart Members

[image] [image]

DocX - A Sandcastle Documented Class Library
BarChart Members
BarChart Class Constructors Methods Properties See Also Send Feedback

The BarChart type exposes the following members.

Constructors

 | Name | Description
Public method | BarChart | Initializes a new instance of the BarChart class

Methods

 | Name | Description
Public method | AddLegend()()()() | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BarDirection |
Public property | BarGrouping |
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | GapWidth |
Public property | IsAxisExist | (Inherited from Chart.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Inherited from Chart.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)

See Also

BarChart Class


BarChart Constructor

[image]

DocX - A Sandcastle Documented Class Library
BarChart Constructor
BarChart Class See Also Send Feedback
Initializes a new instance of the BarChart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public BarChart()
Visual Basic
Public Sub New
Visual C++
public:
BarChart()
F#
new : unit -> BarChart

See Also

BarChart Class
BarChart Members


BarChart Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
BarChart Methods
BarChart Class See Also Send Feedback

The BarChart type exposes the following members.

Methods

 | Name | Description
Public method | AddLegend()()()() | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BarChart Class


BarChart.CreateChartXml Method

[image]

DocX - A Sandcastle Documented Class Library
BarChart..::..CreateChartXml Method
BarChart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.BarChart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected override XElement CreateChartXml()
Visual Basic
Protected Overrides Function CreateChartXml As XElement
Visual C++
protected:
virtual XElement^ CreateChartXml() override
F#
abstract CreateChartXml : unit -> XElement
override CreateChartXml : unit -> XElement

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.BarChart.CreateChartXml"]

See Also

BarChart Class
BarChart Members


BarChart Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
BarChart Properties
BarChart Class See Also Send Feedback

The BarChart type exposes the following members.

Properties

 | Name | Description
Public property | BarDirection |
Public property | BarGrouping |
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | GapWidth |
Public property | IsAxisExist | (Inherited from Chart.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Inherited from Chart.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)

See Also

BarChart Class


BarChart.BarDirection Property

[image]

DocX - A Sandcastle Documented Class Library
BarChart..::..BarDirection Property
BarChart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.BarChart.BarDirection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public BarDirection BarDirection { get; set; }
Visual Basic
Public Property BarDirection As BarDirection
    Get
    Set
Visual C++
public:
property BarDirection BarDirection {
    BarDirection get ();
    void set (BarDirection value);
}
F#
member BarDirection : BarDirection with get, set

Property Value

Type: BarDirection

See Also

BarChart Class
BarChart Members


BarChart.BarGrouping Property

[image]

DocX - A Sandcastle Documented Class Library
BarChart..::..BarGrouping Property
BarChart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.BarChart.BarGrouping"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public BarGrouping BarGrouping { get; set; }
Visual Basic
Public Property BarGrouping As BarGrouping
    Get
    Set
Visual C++
public:
property BarGrouping BarGrouping {
    BarGrouping get ();
    void set (BarGrouping value);
}
F#
member BarGrouping : BarGrouping with get, set

Property Value

Type: BarGrouping

See Also

BarChart Class
BarChart Members


BarChart.GapWidth Property

[image]

DocX - A Sandcastle Documented Class Library
BarChart..::..GapWidth Property
BarChart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.BarChart.GapWidth"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int GapWidth { get; set; }
Visual Basic
Public Property GapWidth As Integer
    Get
    Set
Visual C++
public:
property int GapWidth {
    int get ();
    void set (int value);
}
F#
member GapWidth : int with get, set

Property Value

Type: Int32

See Also

BarChart Class
BarChart Members


BarDirection Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BarDirection Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.BarDirection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BarDirection
Visual Basic
Public Enumeration BarDirection
Visual C++
public enum class BarDirection
F#
type BarDirection

Members

Member name | Value | Description
Column | 0 |
Bar | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


BarGrouping Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BarGrouping Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.BarGrouping"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BarGrouping
Visual Basic
Public Enumeration BarGrouping
Visual C++
public enum class BarGrouping
F#
type BarGrouping

Members

Member name | Value | Description
Clustered | 0 |
PercentStacked | 1 |
Stacked | 2 |
Standard | 3 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


BasicShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BasicShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.BasicShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BasicShapes
Visual Basic
Public Enumeration BasicShapes
Visual C++
public enum class BasicShapes
F#
type BasicShapes

Members

Member name | Value | Description
ellipse | 0 |
triangle | 1 |
rtTriangle | 2 |
parallelogram | 3 |
trapezoid | 4 |
diamond | 5 |
pentagon | 6 |
hexagon | 7 |
heptagon | 8 |
octagon | 9 |
decagon | 10 |
dodecagon | 11 |
pie | 12 |
chord | 13 |
teardrop | 14 |
frame | 15 |
halfFrame | 16 |
corner | 17 |
diagStripe | 18 |
plus | 19 |
plaque | 20 |
can | 21 |
cube | 22 |
bevel | 23 |
donut | 24 |
noSmoking | 25 |
blockArc | 26 |
foldedCorner | 27 |
smileyFace | 28 |
heart | 29 |
lightningBolt | 30 |
sun | 31 |
moon | 32 |
cloud | 33 |
arc | 34 |
backetPair | 35 |
bracePair | 36 |
leftBracket | 37 |
rightBracket | 38 |
leftBrace | 39 |
rightBrace | 40 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


BlockArrowShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BlockArrowShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.BlockArrowShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BlockArrowShapes
Visual Basic
Public Enumeration BlockArrowShapes
Visual C++
public enum class BlockArrowShapes
F#
type BlockArrowShapes

Members

Member name | Value | Description
rightArrow | 0 |
leftArrow | 1 |
upArrow | 2 |
downArrow | 3 |
leftRightArrow | 4 |
upDownArrow | 5 |
quadArrow | 6 |
leftRightUpArrow | 7 |
bentArrow | 8 |
uturnArrow | 9 |
leftUpArrow | 10 |
bentUpArrow | 11 |
curvedRightArrow | 12 |
curvedLeftArrow | 13 |
curvedUpArrow | 14 |
curvedDownArrow | 15 |
stripedRightArrow | 16 |
notchedRightArrow | 17 |
homePlate | 18 |
chevron | 19 |
rightArrowCallout | 20 |
downArrowCallout | 21 |
leftArrowCallout | 22 |
upArrowCallout | 23 |
leftRightArrowCallout | 24 |
quadArrowCallout | 25 |
circularArrow | 26 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Bookmark Class

[image]

DocX - A Sandcastle Documented Class Library
Bookmark Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Bookmark"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Bookmark
Visual Basic
Public Class Bookmark
Visual C++
public ref class Bookmark
F#
type Bookmark =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..Bookmark

See Also

Bookmark Members


Bookmark Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Bookmark Members
Bookmark Class Constructors Methods Properties See Also Send Feedback

The Bookmark type exposes the following members.

Constructors

 | Name | Description
Public method | Bookmark | Initializes a new instance of the Bookmark class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name |
Public property | Paragraph |

See Also

Bookmark Class


Bookmark Constructor

[image]

DocX - A Sandcastle Documented Class Library
Bookmark Constructor
Bookmark Class See Also Send Feedback
Initializes a new instance of the Bookmark class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Bookmark()
Visual Basic
Public Sub New
Visual C++
public:
Bookmark()
F#
new : unit -> Bookmark

See Also

Bookmark Class
Bookmark Members


Bookmark Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Bookmark Methods
Bookmark Class See Also Send Feedback

The Bookmark type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Bookmark Class


Bookmark Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Bookmark Properties
Bookmark Class See Also Send Feedback

The Bookmark type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | Paragraph |

See Also

Bookmark Class


Bookmark.Name Property

[image]

DocX - A Sandcastle Documented Class Library
Bookmark..::..Name Property
Bookmark Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Bookmark.Name"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
F#
member Name : string with get, set

Property Value

Type: String

See Also

Bookmark Class
Bookmark Members


Bookmark.Paragraph Property

[image]

DocX - A Sandcastle Documented Class Library
Bookmark..::..Paragraph Property
Bookmark Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Bookmark.Paragraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Paragraph { get; set; }
Visual Basic
Public Property Paragraph As Paragraph
    Get
    Set
Visual C++
public:
property Paragraph^ Paragraph {
    Paragraph^ get ();
    void set (Paragraph^ value);
}
F#
member Paragraph : Paragraph with get, set

Property Value

Type: Paragraph

See Also

Bookmark Class
Bookmark Members


Border Class

[image]

DocX - A Sandcastle Documented Class Library
Border Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Border"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Border
Visual Basic
Public Class Border
Visual C++
public ref class Border
F#
type Border =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..Border

See Also

Border Members


Border Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Border Members
Border Class Constructors Methods Properties See Also Send Feedback

The Border type exposes the following members.

Constructors

 | Name | Description
Public method | Border()()()() | Initializes a new instance of the Border class
Public method | Border(BorderStyle, BorderSize, Int32, Color) | Initializes a new instance of the Border class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color |
Public property | Size |
Public property | Space |
Public property | Tcbs |

See Also

Border Class


Border Constructor

[image] [image]

DocX - A Sandcastle Documented Class Library
Border Constructor
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Border()()()() | Initializes a new instance of the Border class
Public method | Border(BorderStyle, BorderSize, Int32, Color) | Initializes a new instance of the Border class

See Also

Border Class
Border Members


Border Constructor

[image]

DocX - A Sandcastle Documented Class Library
Border Constructor
Border Class See Also Send Feedback
Initializes a new instance of the Border class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Border()
Visual Basic
Public Sub New
Visual C++
public:
Border()
F#
new : unit -> Border

See Also

Border Class
Border Members
Border Overload


Border Constructor (BorderStyle, BorderSize, Int32, Color)

[image]

DocX - A Sandcastle Documented Class Library
Border Constructor (BorderStyle, BorderSize, Int32, Color)
Border Class See Also Send Feedback
Initializes a new instance of the Border class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Border(
    BorderStyle tcbs,
    BorderSize size,
    int space,
    Color color
)
Visual Basic
Public Sub New (
    tcbs As BorderStyle,
    size As BorderSize,
    space As Integer,
    color As Color
)
Visual C++
public:
Border(
    BorderStyle tcbs,
    BorderSize size,
    int space,
    Color color
)
F#
new :
        tcbs : BorderStyle *
        size : BorderSize *
        space : int *
        color : Color -> Border

Parameters

tcbs
Type: Novacode..::..BorderStyle

[Missing <param name="tcbs"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

size
Type: Novacode..::..BorderSize

[Missing <param name="size"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

space
Type: System..::..Int32

[Missing <param name="space"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

color
Type: System.Drawing..::..Color

[Missing <param name="color"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

See Also

Border Class
Border Members
Border Overload


Border Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Border Methods
Border Class See Also Send Feedback

The Border type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Border Class


Border Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Border Properties
Border Class See Also Send Feedback

The Border type exposes the following members.

Properties

 | Name | Description
Public property | Color |
Public property | Size |
Public property | Space |
Public property | Tcbs |

See Also

Border Class


Border.Color Property

[image]

DocX - A Sandcastle Documented Class Library
Border..::..Color Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Border.Color"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}
F#
member Color : Color with get, set

Property Value

Type: Color

See Also

Border Class
Border Members


Border.Size Property

[image]

DocX - A Sandcastle Documented Class Library
Border..::..Size Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Border.Size"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public BorderSize Size { get; set; }
Visual Basic
Public Property Size As BorderSize
    Get
    Set
Visual C++
public:
property BorderSize Size {
    BorderSize get ();
    void set (BorderSize value);
}
F#
member Size : BorderSize with get, set

Property Value

Type: BorderSize

See Also

Border Class
Border Members


Border.Space Property

[image]

DocX - A Sandcastle Documented Class Library
Border..::..Space Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Border.Space"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int Space { get; set; }
Visual Basic
Public Property Space As Integer
    Get
    Set
Visual C++
public:
property int Space {
    int get ();
    void set (int value);
}
F#
member Space : int with get, set

Property Value

Type: Int32

See Also

Border Class
Border Members


Border.Tcbs Property

[image]

DocX - A Sandcastle Documented Class Library
Border..::..Tcbs Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Border.Tcbs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public BorderStyle Tcbs { get; set; }
Visual Basic
Public Property Tcbs As BorderStyle
    Get
    Set
Visual C++
public:
property BorderStyle Tcbs {
    BorderStyle get ();
    void set (BorderStyle value);
}
F#
member Tcbs : BorderStyle with get, set

Property Value

Type: BorderStyle

See Also

Border Class
Border Members


BorderSize Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BorderSize Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.BorderSize"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BorderSize
Visual Basic
Public Enumeration BorderSize
Visual C++
public enum class BorderSize
F#
type BorderSize

Members

Member name | Value | Description
one | 0 |
two | 1 |
three | 2 |
four | 3 |
five | 4 |
six | 5 |
seven | 6 |
eight | 7 |
nine | 8 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


BorderStyle Enumeration

[image]

DocX - A Sandcastle Documented Class Library
BorderStyle Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.BorderStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum BorderStyle
Visual Basic
Public Enumeration BorderStyle
Visual C++
public enum class BorderStyle
F#
type BorderStyle

Members

Member name | Value | Description
Tcbs_none | 0 |
Tcbs_single | 1 |
Tcbs_thick | 2 |
Tcbs_double | 3 |
Tcbs_dotted | 4 |
Tcbs_dashed | 5 |
Tcbs_dotDash | 6 |
Tcbs_dotDotDash | 7 |
Tcbs_triple | 8 |
Tcbs_thinThickSmallGap | 9 |
Tcbs_thickThinSmallGap | 10 |
Tcbs_thinThickThinSmallGap | 11 |
Tcbs_thinThickMediumGap | 12 |
Tcbs_thickThinMediumGap | 13 |
Tcbs_thinThickThinMediumGap | 14 |
Tcbs_thinThickLargeGap | 15 |
Tcbs_thickThinLargeGap | 16 |
Tcbs_thinThickThinLargeGap | 17 |
Tcbs_wave | 18 |
Tcbs_doubleWave | 19 |
Tcbs_dashSmallGap | 20 |
Tcbs_dashDotStroked | 21 |
Tcbs_threeDEmboss | 22 |
Tcbs_threeDEngrave | 23 |
Tcbs_outset | 24 |
Tcbs_inset | 25 |
Tcbs_nil | 26 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


CalloutShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
CalloutShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.CalloutShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum CalloutShapes
Visual Basic
Public Enumeration CalloutShapes
Visual C++
public enum class CalloutShapes
F#
type CalloutShapes

Members

Member name | Value | Description
wedgeRectCallout | 0 |
wedgeRoundRectCallout | 1 |
wedgeEllipseCallout | 2 |
cloudCallout | 3 |
borderCallout1 | 4 |
borderCallout2 | 5 |
borderCallout3 | 6 |
accentCallout1 | 7 |
accentCallout2 | 8 |
accentCallout3 | 9 |
callout1 | 10 |
callout2 | 11 |
callout3 | 12 |
accentBorderCallout1 | 13 |
accentBorderCallout2 | 14 |
accentBorderCallout3 | 15 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


CapsStyle Enumeration

[image]

DocX - A Sandcastle Documented Class Library
CapsStyle Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.CapsStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum CapsStyle
Visual Basic
Public Enumeration CapsStyle
Visual C++
public enum class CapsStyle
F#
type CapsStyle

Members

Member name | Value | Description
none | 0 |
caps | 1 |
smallCaps | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


CategoryAxis Class

[image]

DocX - A Sandcastle Documented Class Library
CategoryAxis Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.CategoryAxis"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class CategoryAxis : Axis
Visual Basic
Public Class CategoryAxis
    Inherits Axis
Visual C++
public ref class CategoryAxis : public Axis
F#
type CategoryAxis =
    class
        inherit Axis
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..Axis
Novacode..::..CategoryAxis

See Also

CategoryAxis Members


CategoryAxis Members

[image] [image]

DocX - A Sandcastle Documented Class Library
CategoryAxis Members
CategoryAxis Class Constructors Methods Properties See Also Send Feedback

The CategoryAxis type exposes the following members.

Constructors

 | Name | Description
Public method | CategoryAxis | Initializes a new instance of the CategoryAxis class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | (Inherited from Axis.)
Public property | IsVisible | (Inherited from Axis.)

See Also

CategoryAxis Class


CategoryAxis Constructor

[image]

DocX - A Sandcastle Documented Class Library
CategoryAxis Constructor
CategoryAxis Class See Also Send Feedback
Initializes a new instance of the CategoryAxis class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CategoryAxis(
    string id
)
Visual Basic
Public Sub New (
    id As String
)
Visual C++
public:
CategoryAxis(
    String^ id
)
F#
new :
        id : string -> CategoryAxis

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:Novacode.CategoryAxis.#ctor(System.String)"]

See Also

CategoryAxis Class
CategoryAxis Members


CategoryAxis Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
CategoryAxis Methods
CategoryAxis Class See Also Send Feedback

The CategoryAxis type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CategoryAxis Class


CategoryAxis Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
CategoryAxis Properties
CategoryAxis Class See Also Send Feedback

The CategoryAxis type exposes the following members.

Properties

 | Name | Description
Public property | Id | (Inherited from Axis.)
Public property | IsVisible | (Inherited from Axis.)

See Also

CategoryAxis Class


Cell Class

[image]

DocX - A Sandcastle Documented Class Library
Cell Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Cell"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Cell : Container
Visual Basic
Public Class Cell
    Inherits Container
Visual C++
public ref class Cell : public Container
F#
type Cell =
    class
        inherit Container
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Cell

See Also

Cell Members


Cell Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Cell Members
Cell Class Methods Fields Properties See Also Send Feedback

The Cell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetBorder |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Overrides Container..::..InsertTable(Int32, Int32).)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetBorder |
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

Properties

 | Name | Description
Public property | FillColor |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | MarginBottom |
Public property | MarginLeft |
Public property | MarginRight |
Public property | MarginTop |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Shading |
Public property | Tables | (Inherited from Container.)
Public property | VerticalAlignment |
Public property | Width |
Public property | Xml | (Inherited from DocXElement.)

See Also

Cell Class


Cell Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Cell Fields
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

See Also

Cell Class


Cell Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Cell Methods
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetBorder |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Overrides Container..::..InsertTable(Int32, Int32).)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetBorder |
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Cell Class


Cell.GetBorder Method

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..GetBorder Method
Cell Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Cell.GetBorder(Novacode.TableCellBorderType)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Border GetBorder(
    TableCellBorderType borderType
)
Visual Basic
Public Function GetBorder (
    borderType As TableCellBorderType
) As Border
Visual C++
public:
Border^ GetBorder(
    TableCellBorderType borderType
)
F#
member GetBorder :
        borderType : TableCellBorderType -> Border

Parameters

borderType
Type: Novacode..::..TableCellBorderType

[Missing <param name="borderType"/> documentation for "M:Novacode.Cell.GetBorder(Novacode.TableCellBorderType)"]

Return Value

Type: Border

[Missing <returns> documentation for "M:Novacode.Cell.GetBorder(Novacode.TableCellBorderType)"]

See Also

Cell Class
Cell Members


Cell.InsertTable Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Cell..::..InsertTable Method
Cell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Overrides Container..::..InsertTable(Int32, Int32).)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)

See Also

Cell Class
Cell Members


Cell.InsertTable Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..InsertTable Method (Int32, Int32)
Cell Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTable(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overrides Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTable(
    int rowCount,
    int columnCount
) override
F#
abstract InsertTable :
        rowCount : int *
        columnCount : int -> Table
override InsertTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

See Also

Cell Class
Cell Members
InsertTable Overload


Cell.SetBorder Method

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..SetBorder Method
Cell Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Cell.SetBorder(Novacode.TableCellBorderType,Novacode.Border)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetBorder(
    TableCellBorderType borderType,
    Border border
)
Visual Basic
Public Sub SetBorder (
    borderType As TableCellBorderType,
    border As Border
)
Visual C++
public:
void SetBorder(
    TableCellBorderType borderType,
    Border^ border
)
F#
member SetBorder :
        borderType : TableCellBorderType *
        border : Border -> unit

Parameters

borderType
Type: Novacode..::..TableCellBorderType

[Missing <param name="borderType"/> documentation for "M:Novacode.Cell.SetBorder(Novacode.TableCellBorderType,Novacode.Border)"]

border
Type: Novacode..::..Border

[Missing <param name="border"/> documentation for "M:Novacode.Cell.SetBorder(Novacode.TableCellBorderType,Novacode.Border)"]

See Also

Cell Class
Cell Members


Cell Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Cell Properties
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Properties

 | Name | Description
Public property | FillColor |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | MarginBottom |
Public property | MarginLeft |
Public property | MarginRight |
Public property | MarginTop |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Shading |
Public property | Tables | (Inherited from Container.)
Public property | VerticalAlignment |
Public property | Width |
Public property | Xml | (Inherited from DocXElement.)

See Also

Cell Class


Cell.FillColor Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..FillColor Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.FillColor"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Color FillColor { get; set; }
Visual Basic
Public Property FillColor As Color
    Get
    Set
Visual C++
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}
F#
member FillColor : Color with get, set

Property Value

Type: Color

See Also

Cell Class
Cell Members


Cell.MarginBottom Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..MarginBottom Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.MarginBottom"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double MarginBottom { get; set; }
Visual Basic
Public Property MarginBottom As Double
    Get
    Set
Visual C++
public:
property double MarginBottom {
    double get ();
    void set (double value);
}
F#
member MarginBottom : float with get, set

Property Value

Type: Double

See Also

Cell Class
Cell Members


Cell.MarginLeft Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..MarginLeft Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.MarginLeft"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double MarginLeft { get; set; }
Visual Basic
Public Property MarginLeft As Double
    Get
    Set
Visual C++
public:
property double MarginLeft {
    double get ();
    void set (double value);
}
F#
member MarginLeft : float with get, set

Property Value

Type: Double

See Also

Cell Class
Cell Members


Cell.MarginRight Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..MarginRight Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.MarginRight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double MarginRight { get; set; }
Visual Basic
Public Property MarginRight As Double
    Get
    Set
Visual C++
public:
property double MarginRight {
    double get ();
    void set (double value);
}
F#
member MarginRight : float with get, set

Property Value

Type: Double

See Also

Cell Class
Cell Members


Cell.MarginTop Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..MarginTop Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.MarginTop"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double MarginTop { get; set; }
Visual Basic
Public Property MarginTop As Double
    Get
    Set
Visual C++
public:
property double MarginTop {
    double get ();
    void set (double value);
}
F#
member MarginTop : float with get, set

Property Value

Type: Double

See Also

Cell Class
Cell Members


Cell.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..Paragraphs Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override ReadOnlyCollection<Paragraph> Paragraphs { get; }
Visual Basic
Public Overrides ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
Visual C++
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get () override;
}
F#
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection <(Of <(<' Paragraph >)>)>

See Also

Cell Class
Cell Members


Cell.Shading Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..Shading Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.Shading"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Color Shading { get; set; }
Visual Basic
Public Property Shading As Color
    Get
    Set
Visual C++
public:
property Color Shading {
    Color get ();
    void set (Color value);
}
F#
member Shading : Color with get, set

Property Value

Type: Color

See Also

Cell Class
Cell Members


Cell.VerticalAlignment Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..VerticalAlignment Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.VerticalAlignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public VerticalAlignment VerticalAlignment { get; set; }
Visual Basic
Public Property VerticalAlignment As VerticalAlignment
    Get
    Set
Visual C++
public:
property VerticalAlignment VerticalAlignment {
    VerticalAlignment get ();
    void set (VerticalAlignment value);
}
F#
member VerticalAlignment : VerticalAlignment with get, set

Property Value

Type: VerticalAlignment

See Also

Cell Class
Cell Members


Cell.Width Property

[image]

DocX - A Sandcastle Documented Class Library
Cell..::..Width Property
Cell Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Cell.Width"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}
F#
member Width : float with get, set

Property Value

Type: Double

See Also

Cell Class
Cell Members


Chart Class

[image]

DocX - A Sandcastle Documented Class Library
Chart Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Chart"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public abstract class Chart
Visual Basic
Public MustInherit Class Chart
Visual C++
public ref class Chart abstract
F#
[<AbstractClassAttribute>]
type Chart =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..Chart
Novacode..::..BarChart
Novacode..::..LineChart
Novacode..::..PieChart

See Also

Chart Members


Chart Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Chart Members
Chart Class Constructors Methods Properties See Also Send Feedback

The Chart type exposes the following members.

Constructors

 | Name | Description
Public method | Chart | Initializes a new instance of the Chart class

Methods

 | Name | Description
Public method | AddLegend()()()() |
Public method | AddLegend(ChartLegendPosition, Boolean) |
Public method | AddSeries |
Protected method | CreateChartXml |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryAxis |
Protected property | ChartRootXml |
Protected property | ChartXml |
Public property | DisplayBlanksAs |
Public property | IsAxisExist |
Public property | Legend |
Public property | MaxSeriesCount |
Public property | Series |
Public property | ValueAxis |
Public property | View3D |
Public property | Xml |

See Also

Chart Class


Chart Constructor

[image]

DocX - A Sandcastle Documented Class Library
Chart Constructor
Chart Class See Also Send Feedback
Initializes a new instance of the Chart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Chart()
Visual Basic
Public Sub New
Visual C++
public:
Chart()
F#
new : unit -> Chart

See Also

Chart Class
Chart Members


Chart Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Chart Methods
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Methods

 | Name | Description
Public method | AddLegend()()()() |
Public method | AddLegend(ChartLegendPosition, Boolean) |
Public method | AddSeries |
Protected method | CreateChartXml |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Chart Class


Chart.AddLegend Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Chart..::..AddLegend Method
Chart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddLegend()()()() |
Public method | AddLegend(ChartLegendPosition, Boolean) |

See Also

Chart Class
Chart Members


Chart.AddLegend Method

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..AddLegend Method
Chart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Chart.AddLegend"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddLegend()
Visual Basic
Public Sub AddLegend
Visual C++
public:
void AddLegend()
F#
member AddLegend : unit -> unit

See Also

Chart Class
Chart Members
AddLegend Overload


Chart.AddLegend Method (ChartLegendPosition, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..AddLegend Method (ChartLegendPosition, Boolean)
Chart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Chart.AddLegend(Novacode.ChartLegendPosition,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddLegend(
    ChartLegendPosition position,
    bool overlay
)
Visual Basic
Public Sub AddLegend (
    position As ChartLegendPosition,
    overlay As Boolean
)
Visual C++
public:
void AddLegend(
    ChartLegendPosition position,
    bool overlay
)
F#
member AddLegend :
        position : ChartLegendPosition *
        overlay : bool -> unit

Parameters

position
Type: Novacode..::..ChartLegendPosition

[Missing <param name="position"/> documentation for "M:Novacode.Chart.AddLegend(Novacode.ChartLegendPosition,System.Boolean)"]

overlay
Type: System..::..Boolean

[Missing <param name="overlay"/> documentation for "M:Novacode.Chart.AddLegend(Novacode.ChartLegendPosition,System.Boolean)"]

See Also

Chart Class
Chart Members
AddLegend Overload


Chart.AddSeries Method

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..AddSeries Method
Chart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Chart.AddSeries(Novacode.Series)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddSeries(
    Series series
)
Visual Basic
Public Sub AddSeries (
    series As Series
)
Visual C++
public:
void AddSeries(
    Series^ series
)
F#
member AddSeries :
        series : Series -> unit

Parameters

series
Type: Novacode..::..Series

[Missing <param name="series"/> documentation for "M:Novacode.Chart.AddSeries(Novacode.Series)"]

See Also

Chart Class
Chart Members


Chart.CreateChartXml Method

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..CreateChartXml Method
Chart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Chart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected abstract XElement CreateChartXml()
Visual Basic
Protected MustOverride Function CreateChartXml As XElement
Visual C++
protected:
virtual XElement^ CreateChartXml() abstract
F#
abstract CreateChartXml : unit -> XElement

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.Chart.CreateChartXml"]

See Also

Chart Class
Chart Members


Chart.RemoveLegend Method

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..RemoveLegend Method
Chart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Chart.RemoveLegend"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveLegend()
Visual Basic
Public Sub RemoveLegend
Visual C++
public:
void RemoveLegend()
F#
member RemoveLegend : unit -> unit

See Also

Chart Class
Chart Members


Chart Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Chart Properties
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Properties

 | Name | Description
Public property | CategoryAxis |
Protected property | ChartRootXml |
Protected property | ChartXml |
Public property | DisplayBlanksAs |
Public property | IsAxisExist |
Public property | Legend |
Public property | MaxSeriesCount |
Public property | Series |
Public property | ValueAxis |
Public property | View3D |
Public property | Xml |

See Also

Chart Class


Chart.CategoryAxis Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..CategoryAxis Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.CategoryAxis"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CategoryAxis CategoryAxis { get; }
Visual Basic
Public ReadOnly Property CategoryAxis As CategoryAxis
    Get
Visual C++
public:
property CategoryAxis^ CategoryAxis {
    CategoryAxis^ get ();
}
F#
member CategoryAxis : CategoryAxis with get

Property Value

Type: CategoryAxis

See Also

Chart Class
Chart Members


Chart.ChartRootXml Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..ChartRootXml Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.ChartRootXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected XElement ChartRootXml { get; }
Visual Basic
Protected ReadOnly Property ChartRootXml As XElement
    Get
Visual C++
protected:
property XElement^ ChartRootXml {
    XElement^ get ();
}
F#
member ChartRootXml : XElement with get

Property Value

Type: XElement

See Also

Chart Class
Chart Members


Chart.ChartXml Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..ChartXml Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.ChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected XElement ChartXml { get; }
Visual Basic
Protected ReadOnly Property ChartXml As XElement
    Get
Visual C++
protected:
property XElement^ ChartXml {
    XElement^ get ();
}
F#
member ChartXml : XElement with get

Property Value

Type: XElement

See Also

Chart Class
Chart Members


Chart.DisplayBlanksAs Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..DisplayBlanksAs Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.DisplayBlanksAs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public DisplayBlanksAs DisplayBlanksAs { get; set; }
Visual Basic
Public Property DisplayBlanksAs As DisplayBlanksAs
    Get
    Set
Visual C++
public:
property DisplayBlanksAs DisplayBlanksAs {
    DisplayBlanksAs get ();
    void set (DisplayBlanksAs value);
}
F#
member DisplayBlanksAs : DisplayBlanksAs with get, set

Property Value

Type: DisplayBlanksAs

See Also

Chart Class
Chart Members


Chart.IsAxisExist Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..IsAxisExist Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.IsAxisExist"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual bool IsAxisExist { get; }
Visual Basic
Public Overridable ReadOnly Property IsAxisExist As Boolean
    Get
Visual C++
public:
virtual property bool IsAxisExist {
    bool get ();
}
F#
abstract IsAxisExist : bool with get
override IsAxisExist : bool with get

Property Value

Type: Boolean

See Also

Chart Class
Chart Members


Chart.Legend Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..Legend Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.Legend"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ChartLegend Legend { get; }
Visual Basic
Public ReadOnly Property Legend As ChartLegend
    Get
Visual C++
public:
property ChartLegend^ Legend {
    ChartLegend^ get ();
}
F#
member Legend : ChartLegend with get

Property Value

Type: ChartLegend

See Also

Chart Class
Chart Members


Chart.MaxSeriesCount Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..MaxSeriesCount Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.MaxSeriesCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual short MaxSeriesCount { get; }
Visual Basic
Public Overridable ReadOnly Property MaxSeriesCount As Short
    Get
Visual C++
public:
virtual property short MaxSeriesCount {
    short get ();
}
F#
abstract MaxSeriesCount : int16 with get
override MaxSeriesCount : int16 with get

Property Value

Type: Int16

See Also

Chart Class
Chart Members


Chart.Series Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..Series Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.Series"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Series> Series { get; }
Visual Basic
Public ReadOnly Property Series As List(Of Series)
    Get
Visual C++
public:
property List<Series^>^ Series {
    List<Series^>^ get ();
}
F#
member Series : List<Series> with get

Property Value

Type: List <(Of <(<' Series >)>)>

See Also

Chart Class
Chart Members


Chart.ValueAxis Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..ValueAxis Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.ValueAxis"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ValueAxis ValueAxis { get; }
Visual Basic
Public ReadOnly Property ValueAxis As ValueAxis
    Get
Visual C++
public:
property ValueAxis^ ValueAxis {
    ValueAxis^ get ();
}
F#
member ValueAxis : ValueAxis with get

Property Value

Type: ValueAxis

See Also

Chart Class
Chart Members


Chart.View3D Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..View3D Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.View3D"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool View3D { get; set; }
Visual Basic
Public Property View3D As Boolean
    Get
    Set
Visual C++
public:
property bool View3D {
    bool get ();
    void set (bool value);
}
F#
member View3D : bool with get, set

Property Value

Type: Boolean

See Also

Chart Class
Chart Members


Chart.Xml Property

[image]

DocX - A Sandcastle Documented Class Library
Chart..::..Xml Property
Chart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Chart.Xml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public XDocument Xml { get; }
Visual Basic
Public ReadOnly Property Xml As XDocument
    Get
Visual C++
public:
property XDocument^ Xml {
    XDocument^ get ();
}
F#
member Xml : XDocument with get

Property Value

Type: XDocument

See Also

Chart Class
Chart Members


ChartLegend Class

[image]

DocX - A Sandcastle Documented Class Library
ChartLegend Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.ChartLegend"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class ChartLegend
Visual Basic
Public Class ChartLegend
Visual C++
public ref class ChartLegend
F#
type ChartLegend =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..ChartLegend

See Also

ChartLegend Members


ChartLegend Members

[image] [image]

DocX - A Sandcastle Documented Class Library
ChartLegend Members
ChartLegend Class Methods Properties See Also Send Feedback

The ChartLegend type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Overlay |
Public property | Position |

See Also

ChartLegend Class


ChartLegend Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
ChartLegend Methods
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ChartLegend Class


ChartLegend Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
ChartLegend Properties
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Properties

 | Name | Description
Public property | Overlay |
Public property | Position |

See Also

ChartLegend Class


ChartLegend.Overlay Property

[image]

DocX - A Sandcastle Documented Class Library
ChartLegend..::..Overlay Property
ChartLegend Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.ChartLegend.Overlay"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool Overlay { get; set; }
Visual Basic
Public Property Overlay As Boolean
    Get
    Set
Visual C++
public:
property bool Overlay {
    bool get ();
    void set (bool value);
}
F#
member Overlay : bool with get, set

Property Value

Type: Boolean

See Also

ChartLegend Class
ChartLegend Members


ChartLegend.Position Property

[image]

DocX - A Sandcastle Documented Class Library
ChartLegend..::..Position Property
ChartLegend Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.ChartLegend.Position"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ChartLegendPosition Position { get; set; }
Visual Basic
Public Property Position As ChartLegendPosition
    Get
    Set
Visual C++
public:
property ChartLegendPosition Position {
    ChartLegendPosition get ();
    void set (ChartLegendPosition value);
}
F#
member Position : ChartLegendPosition with get, set

Property Value

Type: ChartLegendPosition

See Also

ChartLegend Class
ChartLegend Members


ChartLegendPosition Enumeration

[image]

DocX - A Sandcastle Documented Class Library
ChartLegendPosition Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.ChartLegendPosition"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum ChartLegendPosition
Visual Basic
Public Enumeration ChartLegendPosition
Visual C++
public enum class ChartLegendPosition
F#
type ChartLegendPosition

Members

Member name | Value | Description
Top | 0 |
Bottom | 1 |
Left | 2 |
Right | 3 |
TopRight | 4 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Container Class

[image]

DocX - A Sandcastle Documented Class Library
Container Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Container"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public abstract class Container : DocXElement
Visual Basic
Public MustInherit Class Container
    Inherits DocXElement
Visual C++
public ref class Container abstract : public DocXElement
F#
[<AbstractClassAttribute>]
type Container =
    class
        inherit DocXElement
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Cell
Novacode..::..DocX
Novacode..::..Footer
Novacode..::..Header
Novacode..::..Row
Novacode..::..Section

See Also

Container Members


Container Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Container Members
Container Class Methods Fields Properties See Also Send Feedback

The Container type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Public method | FindUniqueByPattern |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark |
Public method | InsertBookmark |
Public method | InsertEquation |
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |
Public method | InsertParagraph()()()() |
Public method | InsertParagraph(String) |
Public method | InsertParagraph(Paragraph) |
Public method | InsertParagraph(Int32, Paragraph) |
Public method | InsertParagraph(String, Boolean) |
Public method | InsertParagraph(Int32, String, Boolean) |
Public method | InsertParagraph(String, Boolean, Formatting) |
Public method | InsertParagraph(Int32, String, Boolean, Formatting) |
Public method | InsertSection()()()() |
Public method | InsertSection(Boolean) |
Public method | InsertSectionPageBreak |
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph |
Public method | RemoveParagraphAt |
Public method | RemoveTextInGivenFormat |
Public method | ReplaceText |
Public method | SetDirection |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer |

Properties

 | Name | Description
Public property | Hyperlinks |
Public property | Lists |
Public property | Paragraphs |
Public property | Pictures |
Public property | Sections |
Public property | Tables |
Public property | Xml | (Inherited from DocXElement.)

See Also

Container Class


Container Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Container Fields
Container Class See Also Send Feedback

The Container type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer |

See Also

Container Class


Container.ParentContainer Field

[image]

DocX - A Sandcastle Documented Class Library
Container..::..ParentContainer Field
Container Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Container.ParentContainer"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ContainerType ParentContainer
Visual Basic
Public ParentContainer As ContainerType
Visual C++
public:
ContainerType ParentContainer
F#
val mutable ParentContainer: ContainerType

Field Value

Type: ContainerType

See Also

Container Class
Container Members


Container Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Container Methods
Container Class See Also Send Feedback

The Container type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Public method | FindUniqueByPattern |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark |
Public method | InsertBookmark |
Public method | InsertEquation |
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |
Public method | InsertParagraph()()()() |
Public method | InsertParagraph(String) |
Public method | InsertParagraph(Paragraph) |
Public method | InsertParagraph(Int32, Paragraph) |
Public method | InsertParagraph(String, Boolean) |
Public method | InsertParagraph(Int32, String, Boolean) |
Public method | InsertParagraph(String, Boolean, Formatting) |
Public method | InsertParagraph(Int32, String, Boolean, Formatting) |
Public method | InsertSection()()()() |
Public method | InsertSection(Boolean) |
Public method | InsertSectionPageBreak |
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph |
Public method | RemoveParagraphAt |
Public method | RemoveTextInGivenFormat |
Public method | ReplaceText |
Public method | SetDirection |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Container Class


Container.FindAll Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Container..::..FindAll Method
Container Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |

See Also

Container Class
Container Members


Container.FindAll Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..FindAll Method (String)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.FindAll(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<int> FindAll(
    string str
)
Visual Basic
Public Overridable Function FindAll (
    str As String
) As List(Of Integer)
Visual C++
public:
virtual List<int>^ FindAll(
    String^ str
)
F#
abstract FindAll :
        str : string -> List<int>
override FindAll :
        str : string -> List<int>

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Novacode.Container.FindAll(System.String)"]

Return Value

Type: List <(Of <(<' Int32 >)>)>

[Missing <returns> documentation for "M:Novacode.Container.FindAll(System.String)"]

See Also

Container Class
Container Members
FindAll Overload


Container.FindAll Method (String, RegexOptions)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..FindAll Method (String, RegexOptions)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<int> FindAll(
    string str,
    RegexOptions options
)
Visual Basic
Public Overridable Function FindAll (
    str As String,
    options As RegexOptions
) As List(Of Integer)
Visual C++
public:
virtual List<int>^ FindAll(
    String^ str,
    RegexOptions options
)
F#
abstract FindAll :
        str : string *
        options : RegexOptions -> List<int>
override FindAll :
        str : string *
        options : RegexOptions -> List<int>

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressions..::..RegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List <(Of <(<' Int32 >)>)>

[Missing <returns> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Container Class
Container Members
FindAll Overload


Container.FindUniqueByPattern Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..FindUniqueByPattern Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<string> FindUniqueByPattern(
    string pattern,
    RegexOptions options
)
Visual Basic
Public Overridable Function FindUniqueByPattern (
    pattern As String,
    options As RegexOptions
) As List(Of String)
Visual C++
public:
virtual List<String^>^ FindUniqueByPattern(
    String^ pattern,
    RegexOptions options
)
F#
abstract FindUniqueByPattern :
        pattern : string *
        options : RegexOptions -> List<string>
override FindUniqueByPattern :
        pattern : string *
        options : RegexOptions -> List<string>

Parameters

pattern
Type: System..::..String

[Missing <param name="pattern"/> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressions..::..RegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List <(Of <(<' String >)>)>

[Missing <returns> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Container Class
Container Members


Container.InsertAtBookmark Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertAtBookmark Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertAtBookmark(System.String,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertAtBookmark(
    string toInsert,
    string bookmarkName
)
Visual Basic
Public Overridable Sub InsertAtBookmark (
    toInsert As String,
    bookmarkName As String
)
Visual C++
public:
virtual void InsertAtBookmark(
    String^ toInsert,
    String^ bookmarkName
)
F#
abstract InsertAtBookmark :
        toInsert : string *
        bookmarkName : string -> unit
override InsertAtBookmark :
        toInsert : string *
        bookmarkName : string -> unit

Parameters

toInsert
Type: System..::..String

[Missing <param name="toInsert"/> documentation for "M:Novacode.Container.InsertAtBookmark(System.String,System.String)"]

bookmarkName
Type: System..::..String

[Missing <param name="bookmarkName"/> documentation for "M:Novacode.Container.InsertAtBookmark(System.String,System.String)"]

See Also

Container Class
Container Members


Container.InsertBookmark Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertBookmark Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertBookmark(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertBookmark(
    string bookmarkName
)
Visual Basic
Public Overridable Function InsertBookmark (
    bookmarkName As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertBookmark(
    String^ bookmarkName
)
F#
abstract InsertBookmark :
        bookmarkName : string -> Paragraph
override InsertBookmark :
        bookmarkName : string -> Paragraph

Parameters

bookmarkName
Type: System..::..String

[Missing <param name="bookmarkName"/> documentation for "M:Novacode.Container.InsertBookmark(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertBookmark(System.String)"]

See Also

Container Class
Container Members


Container.InsertEquation Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertEquation Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertEquation(
    string equation
)
Visual Basic
Public Overridable Function InsertEquation (
    equation As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertEquation(
    String^ equation
)
F#
abstract InsertEquation :
        equation : string -> Paragraph
override InsertEquation :
        equation : string -> Paragraph

Parameters

equation
Type: System..::..String

[Missing <param name="equation"/> documentation for "M:Novacode.Container.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertEquation(System.String)"]

See Also

Container Class
Container Members


Container.InsertList Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertList Method
Container Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |

See Also

Container Class
Container Members


Container.InsertList Method (List)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertList Method (List)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertList(Novacode.List)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    List list
)
Visual Basic
Public Function InsertList (
    list As List
) As List
Visual C++
public:
List^ InsertList(
    List^ list
)
F#
member InsertList :
        list : List -> List

Parameters

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.Container.InsertList(Novacode.List)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.Container.InsertList(Novacode.List)"]

See Also

Container Class
Container Members
InsertList Overload


Container.InsertList Method (Int32, List)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertList Method (Int32, List)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    int index,
    List list
)
Visual Basic
Public Function InsertList (
    index As Integer,
    list As List
) As List
Visual C++
public:
List^ InsertList(
    int index,
    List^ list
)
F#
member InsertList :
        index : int *
        list : List -> List

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

See Also

Container Class
Container Members
InsertList Overload


Container.InsertList Method (List, Double)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertList Method (List, Double)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    List list,
    double fontSize
)
Visual Basic
Public Function InsertList (
    list As List,
    fontSize As Double
) As List
Visual C++
public:
List^ InsertList(
    List^ list,
    double fontSize
)
F#
member InsertList :
        list : List *
        fontSize : float -> List

Parameters

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Double)"]

fontSize
Type: System..::..Double

[Missing <param name="fontSize"/> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Double)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Double)"]

See Also

Container Class
Container Members
InsertList Overload


Container.InsertList Method (List, FontFamily, Double)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertList Method (List, FontFamily, Double)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    List list,
    FontFamily fontFamily,
    double fontSize
)
Visual Basic
Public Function InsertList (
    list As List,
    fontFamily As FontFamily,
    fontSize As Double
) As List
Visual C++
public:
List^ InsertList(
    List^ list,
    FontFamily^ fontFamily,
    double fontSize
)
F#
member InsertList :
        list : List *
        fontFamily : FontFamily *
        fontSize : float -> List

Parameters

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

fontFamily
Type: System.Drawing..::..FontFamily

[Missing <param name="fontFamily"/> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

fontSize
Type: System..::..Double

[Missing <param name="fontSize"/> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

See Also

Container Class
Container Members
InsertList Overload


Container.InsertParagraph Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method
Container Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraph()()()() |
Public method | InsertParagraph(String) |
Public method | InsertParagraph(Paragraph) |
Public method | InsertParagraph(Int32, Paragraph) |
Public method | InsertParagraph(String, Boolean) |
Public method | InsertParagraph(Int32, String, Boolean) |
Public method | InsertParagraph(String, Boolean, Formatting) |
Public method | InsertParagraph(Int32, String, Boolean, Formatting) |

See Also

Container Class
Container Members


Container.InsertParagraph Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph()
Visual Basic
Public Overridable Function InsertParagraph As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph()
F#
abstract InsertParagraph : unit -> Paragraph
override InsertParagraph : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (String)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    string text
)
Visual Basic
Public Overridable Function InsertParagraph (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text
)
F#
abstract InsertParagraph :
        text : string -> Paragraph
override InsertParagraph :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.String)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (Paragraph)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    Paragraph p
)
Visual Basic
Public Overridable Function InsertParagraph (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
)
F#
abstract InsertParagraph :
        p : Paragraph -> Paragraph
override InsertParagraph :
        p : Paragraph -> Paragraph

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Container.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(Novacode.Paragraph)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (Int32, Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (Int32, Paragraph)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Visual Basic
Public Overridable Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
)
F#
abstract InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph
override InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (String, Boolean)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Visual Basic
Public Overridable Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
)
F#
abstract InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (Int32, String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (Int32, String, Boolean)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Visual Basic
Public Overridable Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
)
F#
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (String, Boolean, Formatting)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overridable Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)
F#
abstract InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertParagraph Method (Int32, String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertParagraph Method (Int32, String, Boolean, Formatting)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overridable Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)
F#
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Container Class
Container Members
InsertParagraph Overload


Container.InsertSection Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertSection Method
Container Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertSection()()()() |
Public method | InsertSection(Boolean) |

See Also

Container Class
Container Members


Container.InsertSection Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertSection Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertSection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertSection()
Visual Basic
Public Overridable Sub InsertSection
Visual C++
public:
virtual void InsertSection()
F#
abstract InsertSection : unit -> unit
override InsertSection : unit -> unit

See Also

Container Class
Container Members
InsertSection Overload


Container.InsertSection Method (Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertSection Method (Boolean)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertSection(System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertSection(
    bool trackChanges
)
Visual Basic
Public Overridable Sub InsertSection (
    trackChanges As Boolean
)
Visual C++
public:
virtual void InsertSection(
    bool trackChanges
)
F#
abstract InsertSection :
        trackChanges : bool -> unit
override InsertSection :
        trackChanges : bool -> unit

Parameters

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertSection(System.Boolean)"]

See Also

Container Class
Container Members
InsertSection Overload


Container.InsertSectionPageBreak Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertSectionPageBreak Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertSectionPageBreak(System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertSectionPageBreak(
    bool trackChanges = false
)
Visual Basic
Public Overridable Sub InsertSectionPageBreak (
    Optional trackChanges As Boolean = false
)
Visual C++
public:
virtual void InsertSectionPageBreak(
    bool trackChanges = false
)
F#
abstract InsertSectionPageBreak :
        ?trackChanges : bool
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
*)
-> unit
override InsertSectionPageBreak :
        ?trackChanges : bool
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
*)
-> unit

Parameters

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertSectionPageBreak(System.Boolean)"]

See Also

Container Class
Container Members


Container.InsertTable Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertTable Method
Container Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |

See Also

Container Class
Container Members


Container.InsertTable Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertTable Method (Table)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    Table t
)
Visual Basic
Public Function InsertTable (
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    Table^ t
)
F#
member InsertTable :
        t : Table -> Table

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Container.InsertTable(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(Novacode.Table)"]

See Also

Container Class
Container Members
InsertTable Overload


Container.InsertTable Method (Int32, Table)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertTable Method (Int32, Table)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    Table t
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    Table^ t
)
F#
member InsertTable :
        index : int *
        t : Table -> Table

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

See Also

Container Class
Container Members
InsertTable Overload


Container.InsertTable Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertTable Method (Int32, Int32)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Table InsertTable(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overridable Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTable(
    int rowCount,
    int columnCount
)
F#
abstract InsertTable :
        rowCount : int *
        columnCount : int -> Table
override InsertTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

See Also

Container Class
Container Members
InsertTable Overload


Container.InsertTable Method (Int32, Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Container..::..InsertTable Method (Int32, Int32, Int32)
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    int rowCount,
    int columnCount
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    int rowCount,
    int columnCount
)
F#
member InsertTable :
        index : int *
        rowCount : int *
        columnCount : int -> Table

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

See Also

Container Class
Container Members
InsertTable Overload


Container.RemoveParagraph Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..RemoveParagraph Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.RemoveParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool RemoveParagraph(
    Paragraph p
)
Visual Basic
Public Function RemoveParagraph (
    p As Paragraph
) As Boolean
Visual C++
public:
bool RemoveParagraph(
    Paragraph^ p
)
F#
member RemoveParagraph :
        p : Paragraph -> bool

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Container.RemoveParagraph(Novacode.Paragraph)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.Container.RemoveParagraph(Novacode.Paragraph)"]

See Also

Container Class
Container Members


Container.RemoveParagraphAt Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..RemoveParagraphAt Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.RemoveParagraphAt(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool RemoveParagraphAt(
    int index
)
Visual Basic
Public Function RemoveParagraphAt (
    index As Integer
) As Boolean
Visual C++
public:
bool RemoveParagraphAt(
    int index
)
F#
member RemoveParagraphAt :
        index : int -> bool

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Container.RemoveParagraphAt(System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.Container.RemoveParagraphAt(System.Int32)"]

See Also

Container Class
Container Members


Container.RemoveTextInGivenFormat Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..RemoveTextInGivenFormat Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.RemoveTextInGivenFormat(Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int RemoveTextInGivenFormat(
    Formatting matchFormatting,
    MatchFormattingOptions fo = MatchFormattingOptions.SubsetMatch
)
Visual Basic
Public Function RemoveTextInGivenFormat (
    matchFormatting As Formatting,
    Optional fo As MatchFormattingOptions = MatchFormattingOptions.SubsetMatch
) As Integer
Visual C++
public:
int RemoveTextInGivenFormat(
    Formatting^ matchFormatting,
    MatchFormattingOptions fo = MatchFormattingOptions::SubsetMatch
)
F#
member RemoveTextInGivenFormat :
        matchFormatting : Formatting *
        ?fo : MatchFormattingOptions
(* Defaults:
        let _fo = defaultArg fo MatchFormattingOptions.SubsetMatch
*)
-> int

Parameters

matchFormatting
Type: Novacode..::..Formatting

[Missing <param name="matchFormatting"/> documentation for "M:Novacode.Container.RemoveTextInGivenFormat(Novacode.Formatting,Novacode.MatchFormattingOptions)"]

fo (Optional)
Type: Novacode..::..MatchFormattingOptions

[Missing <param name="fo"/> documentation for "M:Novacode.Container.RemoveTextInGivenFormat(Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Novacode.Container.RemoveTextInGivenFormat(Novacode.Formatting,Novacode.MatchFormattingOptions)"]

See Also

Container Class
Container Members


Container.ReplaceText Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..ReplaceText Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void ReplaceText(
    string oldValue,
    string newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions.None,
    Formatting newFormatting = null,
    Formatting matchFormatting = null,
    MatchFormattingOptions fo = MatchFormattingOptions.SubsetMatch
)
Visual Basic
Public Overridable Sub ReplaceText (
    oldValue As String,
    newValue As String,
    Optional trackChanges As Boolean = false,
    Optional options As RegexOptions = RegexOptions.None,
    Optional newFormatting As Formatting = Nothing,
    Optional matchFormatting As Formatting = Nothing,
    Optional fo As MatchFormattingOptions = MatchFormattingOptions.SubsetMatch
)
Visual C++
public:
virtual void ReplaceText(
    String^ oldValue,
    String^ newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions::None,
    Formatting^ newFormatting = nullptr,
    Formatting^ matchFormatting = nullptr,
    MatchFormattingOptions fo = MatchFormattingOptions::SubsetMatch
)
F#
abstract ReplaceText :
        oldValue : string *
        newValue : string *
        ?trackChanges : bool *
        ?options : RegexOptions *
        ?newFormatting : Formatting *
        ?matchFormatting : Formatting *
        ?fo : MatchFormattingOptions
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _options = defaultArg options RegexOptions.None
        let _newFormatting = defaultArg newFormatting null
        let _matchFormatting = defaultArg matchFormatting null
        let _fo = defaultArg fo MatchFormattingOptions.SubsetMatch
*)
-> unit
override ReplaceText :
        oldValue : string *
        newValue : string *
        ?trackChanges : bool *
        ?options : RegexOptions *
        ?newFormatting : Formatting *
        ?matchFormatting : Formatting *
        ?fo : MatchFormattingOptions
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _options = defaultArg options RegexOptions.None
        let _newFormatting = defaultArg newFormatting null
        let _matchFormatting = defaultArg matchFormatting null
        let _fo = defaultArg fo MatchFormattingOptions.SubsetMatch
*)
-> unit

Parameters

oldValue
Type: System..::..String

[Missing <param name="oldValue"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newValue
Type: System..::..String

[Missing <param name="newValue"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

options (Optional)
Type: System.Text.RegularExpressions..::..RegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newFormatting (Optional)
Type: Novacode..::..Formatting

[Missing <param name="newFormatting"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

matchFormatting (Optional)
Type: Novacode..::..Formatting

[Missing <param name="matchFormatting"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

fo (Optional)
Type: Novacode..::..MatchFormattingOptions

[Missing <param name="fo"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

See Also

Container Class
Container Members


Container.SetDirection Method

[image]

DocX - A Sandcastle Documented Class Library
Container..::..SetDirection Method
Container Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Container.SetDirection(Novacode.Direction)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void SetDirection(
    Direction direction
)
Visual Basic
Public Overridable Sub SetDirection (
    direction As Direction
)
Visual C++
public:
virtual void SetDirection(
    Direction direction
)
F#
abstract SetDirection :
        direction : Direction -> unit
override SetDirection :
        direction : Direction -> unit

Parameters

direction
Type: Novacode..::..Direction

[Missing <param name="direction"/> documentation for "M:Novacode.Container.SetDirection(Novacode.Direction)"]

See Also

Container Class
Container Members


Container Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Container Properties
Container Class See Also Send Feedback

The Container type exposes the following members.

Properties

 | Name | Description
Public property | Hyperlinks |
Public property | Lists |
Public property | Paragraphs |
Public property | Pictures |
Public property | Sections |
Public property | Tables |
Public property | Xml | (Inherited from DocXElement.)

See Also

Container Class


Container.Hyperlinks Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Hyperlinks Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Hyperlinks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Hyperlink> Hyperlinks { get; }
Visual Basic
Public Overridable ReadOnly Property Hyperlinks As List(Of Hyperlink)
    Get
Visual C++
public:
virtual property List<Hyperlink^>^ Hyperlinks {
    List<Hyperlink^>^ get ();
}
F#
abstract Hyperlinks : List<Hyperlink> with get
override Hyperlinks : List<Hyperlink> with get

Property Value

Type: List <(Of <(<' Hyperlink >)>)>

See Also

Container Class
Container Members


Container.Lists Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Lists Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Lists"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<List> Lists { get; }
Visual Basic
Public Overridable ReadOnly Property Lists As List(Of List)
    Get
Visual C++
public:
virtual property List<List^>^ Lists {
    List<List^>^ get ();
}
F#
abstract Lists : List<List> with get
override Lists : List<List> with get

Property Value

Type: List <(Of <(<' List >)>)>

See Also

Container Class
Container Members


Container.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Paragraphs Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual ReadOnlyCollection<Paragraph> Paragraphs { get; }
Visual Basic
Public Overridable ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
Visual C++
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get ();
}
F#
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection <(Of <(<' Paragraph >)>)>

See Also

Container Class
Container Members


Container.Pictures Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Pictures Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Pictures"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Picture> Pictures { get; }
Visual Basic
Public Overridable ReadOnly Property Pictures As List(Of Picture)
    Get
Visual C++
public:
virtual property List<Picture^>^ Pictures {
    List<Picture^>^ get ();
}
F#
abstract Pictures : List<Picture> with get
override Pictures : List<Picture> with get

Property Value

Type: List <(Of <(<' Picture >)>)>

See Also

Container Class
Container Members


Container.Sections Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Sections Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Sections"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Section> Sections { get; }
Visual Basic
Public Overridable ReadOnly Property Sections As List(Of Section)
    Get
Visual C++
public:
virtual property List<Section^>^ Sections {
    List<Section^>^ get ();
}
F#
abstract Sections : List<Section> with get
override Sections : List<Section> with get

Property Value

Type: List <(Of <(<' Section >)>)>

See Also

Container Class
Container Members


Container.Tables Property

[image]

DocX - A Sandcastle Documented Class Library
Container..::..Tables Property
Container Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Container.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Table> Tables { get; }
Visual Basic
Public Overridable ReadOnly Property Tables As List(Of Table)
    Get
Visual C++
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get ();
}
F#
abstract Tables : List<Table> with get
override Tables : List<Table> with get

Property Value

Type: List <(Of <(<' Table >)>)>

See Also

Container Class
Container Members


ContainerType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
ContainerType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.ContainerType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum ContainerType
Visual Basic
Public Enumeration ContainerType
Visual C++
public enum class ContainerType
F#
type ContainerType

Members

Member name | Value | Description
None | 0 |
TOC | 1 |
Section | 2 |
Cell | 3 |
Table | 4 |
Header | 5 |
Footer | 6 |
Paragraph | 7 |
Body | 8 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


CustomProperty Class

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.CustomProperty"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class CustomProperty
Visual Basic
Public Class CustomProperty
Visual C++
public ref class CustomProperty
F#
type CustomProperty =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..CustomProperty

See Also

CustomProperty Members


CustomProperty Members

[image] [image]

DocX - A Sandcastle Documented Class Library
CustomProperty Members
CustomProperty Class Constructors Methods Properties See Also Send Feedback

The CustomProperty type exposes the following members.

Constructors

 | Name | Description
Public method | CustomProperty(String, Boolean) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, DateTime) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, Double) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, Int32) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, String) | Initializes a new instance of the CustomProperty class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

CustomProperty Class


CustomProperty Constructor

[image] [image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor
CustomProperty Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomProperty(String, Boolean) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, DateTime) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, Double) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, Int32) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, String) | Initializes a new instance of the CustomProperty class

See Also

CustomProperty Class
CustomProperty Members


CustomProperty Constructor (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor (String, Boolean)
CustomProperty Class See Also Send Feedback
Initializes a new instance of the CustomProperty class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CustomProperty(
    string name,
    bool value
)
Visual Basic
Public Sub New (
    name As String,
    value As Boolean
)
Visual C++
public:
CustomProperty(
    String^ name,
    bool value
)
F#
new :
        name : string *
        value : bool -> CustomProperty

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Boolean)"]

value
Type: System..::..Boolean

[Missing <param name="value"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Boolean)"]

See Also

CustomProperty Class
CustomProperty Members
CustomProperty Overload


CustomProperty Constructor (String, DateTime)

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor (String, DateTime)
CustomProperty Class See Also Send Feedback
Initializes a new instance of the CustomProperty class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CustomProperty(
    string name,
    DateTime value
)
Visual Basic
Public Sub New (
    name As String,
    value As DateTime
)
Visual C++
public:
CustomProperty(
    String^ name,
    DateTime value
)
F#
new :
        name : string *
        value : DateTime -> CustomProperty

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.DateTime)"]

value
Type: System..::..DateTime

[Missing <param name="value"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.DateTime)"]

See Also

CustomProperty Class
CustomProperty Members
CustomProperty Overload


CustomProperty Constructor (String, Double)

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor (String, Double)
CustomProperty Class See Also Send Feedback
Initializes a new instance of the CustomProperty class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CustomProperty(
    string name,
    double value
)
Visual Basic
Public Sub New (
    name As String,
    value As Double
)
Visual C++
public:
CustomProperty(
    String^ name,
    double value
)
F#
new :
        name : string *
        value : float -> CustomProperty

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Double)"]

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Double)"]

See Also

CustomProperty Class
CustomProperty Members
CustomProperty Overload


CustomProperty Constructor (String, Int32)

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor (String, Int32)
CustomProperty Class See Also Send Feedback
Initializes a new instance of the CustomProperty class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CustomProperty(
    string name,
    int value
)
Visual Basic
Public Sub New (
    name As String,
    value As Integer
)
Visual C++
public:
CustomProperty(
    String^ name,
    int value
)
F#
new :
        name : string *
        value : int -> CustomProperty

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Int32)"]

value
Type: System..::..Int32

[Missing <param name="value"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Int32)"]

See Also

CustomProperty Class
CustomProperty Members
CustomProperty Overload


CustomProperty Constructor (String, String)

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty Constructor (String, String)
CustomProperty Class See Also Send Feedback
Initializes a new instance of the CustomProperty class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CustomProperty(
    string name,
    string value
)
Visual Basic
Public Sub New (
    name As String,
    value As String
)
Visual C++
public:
CustomProperty(
    String^ name,
    String^ value
)
F#
new :
        name : string *
        value : string -> CustomProperty

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.String)"]

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.String)"]

See Also

CustomProperty Class
CustomProperty Members
CustomProperty Overload


CustomProperty Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
CustomProperty Methods
CustomProperty Class See Also Send Feedback

The CustomProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CustomProperty Class


CustomProperty Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
CustomProperty Properties
CustomProperty Class See Also Send Feedback

The CustomProperty type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

CustomProperty Class


CustomProperty.Name Property

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty..::..Name Property
CustomProperty Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.CustomProperty.Name"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}
F#
member Name : string with get

Property Value

Type: String

See Also

CustomProperty Class
CustomProperty Members


CustomProperty.Value Property

[image]

DocX - A Sandcastle Documented Class Library
CustomProperty..::..Value Property
CustomProperty Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.CustomProperty.Value"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Object Value { get; }
Visual Basic
Public ReadOnly Property Value As Object
    Get
Visual C++
public:
property Object^ Value {
    Object^ get ();
}
F#
member Value : Object with get

Property Value

Type: Object

See Also

CustomProperty Class
CustomProperty Members


Direction Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Direction Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Direction"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Direction
Visual Basic
Public Enumeration Direction
Visual C++
public enum class Direction
F#
type Direction

Members

Member name | Value | Description
LeftToRight | 0 |
RightToLeft | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


DisplayBlanksAs Enumeration

[image]

DocX - A Sandcastle Documented Class Library
DisplayBlanksAs Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.DisplayBlanksAs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum DisplayBlanksAs
Visual Basic
Public Enumeration DisplayBlanksAs
Visual C++
public enum class DisplayBlanksAs
F#
type DisplayBlanksAs

Members

Member name | Value | Description
Gap | 0 |
Span | 1 |
Zero | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


DocProperty Class

[image]

DocX - A Sandcastle Documented Class Library
DocProperty Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.DocProperty"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class DocProperty : DocXElement
Visual Basic
Public Class DocProperty
    Inherits DocXElement
Visual C++
public ref class DocProperty : public DocXElement
F#
type DocProperty =
    class
        inherit DocXElement
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..DocProperty

See Also

DocProperty Members


DocProperty Members

[image] [image]

DocX - A Sandcastle Documented Class Library
DocProperty Members
DocProperty Class Methods Properties See Also Send Feedback

The DocProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name |
Public property | Xml | (Inherited from DocXElement.)

See Also

DocProperty Class


DocProperty Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
DocProperty Methods
DocProperty Class See Also Send Feedback

The DocProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocProperty Class


DocProperty Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
DocProperty Properties
DocProperty Class See Also Send Feedback

The DocProperty type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | Xml | (Inherited from DocXElement.)

See Also

DocProperty Class


DocProperty.Name Property

[image]

DocX - A Sandcastle Documented Class Library
DocProperty..::..Name Property
DocProperty Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocProperty.Name"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}
F#
member Name : string with get

Property Value

Type: String

See Also

DocProperty Class
DocProperty Members


DocumentTypes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
DocumentTypes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.DocumentTypes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum DocumentTypes
Visual Basic
Public Enumeration DocumentTypes
Visual C++
public enum class DocumentTypes
F#
type DocumentTypes

Members

Member name | Value | Description
Document | 0 |
Template | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


DocX Class

[image]

DocX - A Sandcastle Documented Class Library
DocX Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.DocX"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class DocX : Container, IDisposable
Visual Basic
Public Class DocX
    Inherits Container
    Implements IDisposable
Visual C++
public ref class DocX : public Container,
    IDisposable
F#
type DocX =
    class
        inherit Container
        interface IDisposable
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..DocX

See Also

DocX Members


DocX Members

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX Members
DocX Class Methods Fields Properties See Also Send Feedback

The DocX type exposes the following members.

Methods

 | Name | Description
Public method | AddCoreProperty |
Public method | AddCustomProperty |
Public method | AddFooters |
Public method | AddHeaders |
Public method | AddHyperlink |
Public method | AddImage(Stream) |
Public method | AddImage(String) |
Public method | AddList |
Public method | AddListItem |
Public method | AddProtection |
Public method | AddTable |
Public method | ApplyTemplate(Stream) |
Public method | ApplyTemplate(String) |
Public method | ApplyTemplate(Stream, Boolean) |
Public method | ApplyTemplate(String, Boolean) |
Protected method | clonePackagePart |
Protected method | clonePackageRelationship |
 | Create(Stream, DocumentTypes) |
 | Create(String, DocumentTypes) |
Public method | Dispose | Releases all resources used by the DocX
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMD5HashFromStream |
Public method | GetProtectionType |
Public method | GetSections |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertChart |
Public method | InsertDocument |
Public method | InsertEquation | (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertParagraphs |
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
 | Load(Stream) |
 | Load(String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveProtection |
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | Save |
Public method | SaveAs(Stream) |
Public method | SaveAs(String) |
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

Properties

 | Name | Description
Public property | CoreProperties |
Public property | CustomProperties |
Public property | DifferentFirstPage |
Public property | DifferentOddAndEvenPages |
Public property | Footers |
Public property | Headers |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images |
Public property | isProtected |
Public property | Lists | (Overrides Container..::..Lists.)
Public property | MarginBottom |
Public property | MarginLeft |
Public property | MarginRight |
Public property | MarginTop |
Public property | PageHeight |
Public property | PageLayout |
Public property | PageWidth |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Text |
Public property | Xml | (Inherited from DocXElement.)

See Also

DocX Class


DocX Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX Fields
DocX Class See Also Send Feedback

The DocX type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

See Also

DocX Class


DocX Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX Methods
DocX Class See Also Send Feedback

The DocX type exposes the following members.

Methods

 | Name | Description
Public method | AddCoreProperty |
Public method | AddCustomProperty |
Public method | AddFooters |
Public method | AddHeaders |
Public method | AddHyperlink |
Public method | AddImage(Stream) |
Public method | AddImage(String) |
Public method | AddList |
Public method | AddListItem |
Public method | AddProtection |
Public method | AddTable |
Public method | ApplyTemplate(Stream) |
Public method | ApplyTemplate(String) |
Public method | ApplyTemplate(Stream, Boolean) |
Public method | ApplyTemplate(String, Boolean) |
Protected method | clonePackagePart |
Protected method | clonePackageRelationship |
 | Create(Stream, DocumentTypes) |
 | Create(String, DocumentTypes) |
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMD5HashFromStream |
Public method | GetProtectionType |
Public method | GetSections |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertChart |
Public method | InsertDocument |
Public method | InsertEquation | (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertParagraphs |
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
 | Load(Stream) |
 | Load(String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveProtection |
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | Save |
Public method | SaveAs(Stream) |
Public method | SaveAs(String) |
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocX Class


DocX.AddCoreProperty Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddCoreProperty Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddCoreProperty(System.String,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddCoreProperty(
    string propertyName,
    string propertyValue
)
Visual Basic
Public Sub AddCoreProperty (
    propertyName As String,
    propertyValue As String
)
Visual C++
public:
void AddCoreProperty(
    String^ propertyName,
    String^ propertyValue
)
F#
member AddCoreProperty :
        propertyName : string *
        propertyValue : string -> unit

Parameters

propertyName
Type: System..::..String

[Missing <param name="propertyName"/> documentation for "M:Novacode.DocX.AddCoreProperty(System.String,System.String)"]

propertyValue
Type: System..::..String

[Missing <param name="propertyValue"/> documentation for "M:Novacode.DocX.AddCoreProperty(System.String,System.String)"]

See Also

DocX Class
DocX Members


DocX.AddCustomProperty Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddCustomProperty Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddCustomProperty(Novacode.CustomProperty)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddCustomProperty(
    CustomProperty cp
)
Visual Basic
Public Sub AddCustomProperty (
    cp As CustomProperty
)
Visual C++
public:
void AddCustomProperty(
    CustomProperty^ cp
)
F#
member AddCustomProperty :
        cp : CustomProperty -> unit

Parameters

cp
Type: Novacode..::..CustomProperty

[Missing <param name="cp"/> documentation for "M:Novacode.DocX.AddCustomProperty(Novacode.CustomProperty)"]

See Also

DocX Class
DocX Members


DocX.AddFooters Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddFooters Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddFooters"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddFooters()
Visual Basic
Public Sub AddFooters
Visual C++
public:
void AddFooters()
F#
member AddFooters : unit -> unit

See Also

DocX Class
DocX Members


DocX.AddHeaders Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddHeaders Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddHeaders"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddHeaders()
Visual Basic
Public Sub AddHeaders
Visual C++
public:
void AddHeaders()
F#
member AddHeaders : unit -> unit

See Also

DocX Class
DocX Members


DocX.AddHyperlink Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddHyperlink Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddHyperlink(System.String,System.Uri)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Hyperlink AddHyperlink(
    string text,
    Uri uri
)
Visual Basic
Public Function AddHyperlink (
    text As String,
    uri As Uri
) As Hyperlink
Visual C++
public:
Hyperlink^ AddHyperlink(
    String^ text,
    Uri^ uri
)
F#
member AddHyperlink :
        text : string *
        uri : Uri -> Hyperlink

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.AddHyperlink(System.String,System.Uri)"]

uri
Type: System..::..Uri

[Missing <param name="uri"/> documentation for "M:Novacode.DocX.AddHyperlink(System.String,System.Uri)"]

Return Value

Type: Hyperlink

[Missing <returns> documentation for "M:Novacode.DocX.AddHyperlink(System.String,System.Uri)"]

See Also

DocX Class
DocX Members


DocX.AddImage Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddImage Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddImage(Stream) |
Public method | AddImage(String) |

See Also

DocX Class
DocX Members


DocX.AddImage Method (Stream)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddImage Method (Stream)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddImage(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Image AddImage(
    Stream stream
)
Visual Basic
Public Function AddImage (
    stream As Stream
) As Image
Visual C++
public:
Image^ AddImage(
    Stream^ stream
)
F#
member AddImage :
        stream : Stream -> Image

Parameters

stream
Type: System.IO..::..Stream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.AddImage(System.IO.Stream)"]

Return Value

Type: Image

[Missing <returns> documentation for "M:Novacode.DocX.AddImage(System.IO.Stream)"]

See Also

DocX Class
DocX Members
AddImage Overload


DocX.AddImage Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddImage Method (String)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddImage(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Image AddImage(
    string filename
)
Visual Basic
Public Function AddImage (
    filename As String
) As Image
Visual C++
public:
Image^ AddImage(
    String^ filename
)
F#
member AddImage :
        filename : string -> Image

Parameters

filename
Type: System..::..String

[Missing <param name="filename"/> documentation for "M:Novacode.DocX.AddImage(System.String)"]

Return Value

Type: Image

[Missing <returns> documentation for "M:Novacode.DocX.AddImage(System.String)"]

See Also

DocX Class
DocX Members
AddImage Overload


DocX.AddList Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddList Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List AddList(
    string listText = null,
    int level = 0,
    ListItemType listType = ListItemType.Numbered,
    Nullable<int> startNumber = null,
    bool trackChanges = false
)
Visual Basic
Public Function AddList (
    Optional listText As String = Nothing,
    Optional level As Integer = 0,
    Optional listType As ListItemType = ListItemType.Numbered,
    Optional startNumber As Nullable(Of Integer) = Nothing,
    Optional trackChanges As Boolean = false
) As List
Visual C++
public:
List^ AddList(
    String^ listText = nullptr,
    int level = 0,
    ListItemType listType = ListItemType::Numbered,
    Nullable<int> startNumber = nullptr,
    bool trackChanges = false
)
F#
member AddList :
        ?listText : string *
        ?level : int *
        ?listType : ListItemType *
        ?startNumber : Nullable<int> *
        ?trackChanges : bool
(* Defaults:
        let _listText = defaultArg listText null
        let _level = defaultArg level 0
        let _listType = defaultArg listType ListItemType.Numbered
        let _startNumber = defaultArg startNumber null
        let _trackChanges = defaultArg trackChanges false
*)
-> List

Parameters

listText (Optional)
Type: System..::..String

[Missing <param name="listText"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

level (Optional)
Type: System..::..Int32

[Missing <param name="level"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

listType (Optional)
Type: Novacode..::..ListItemType

[Missing <param name="listType"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

startNumber (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>

[Missing <param name="startNumber"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

See Also

DocX Class
DocX Members


DocX.AddListItem Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddListItem Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List AddListItem(
    List list,
    string listText,
    int level = 0,
    ListItemType listType = ListItemType.Numbered,
    Nullable<int> startNumber = null,
    bool trackChanges = false
)
Visual Basic
Public Function AddListItem (
    list As List,
    listText As String,
    Optional level As Integer = 0,
    Optional listType As ListItemType = ListItemType.Numbered,
    Optional startNumber As Nullable(Of Integer) = Nothing,
    Optional trackChanges As Boolean = false
) As List
Visual C++
public:
List^ AddListItem(
    List^ list,
    String^ listText,
    int level = 0,
    ListItemType listType = ListItemType::Numbered,
    Nullable<int> startNumber = nullptr,
    bool trackChanges = false
)
F#
member AddListItem :
        list : List *
        listText : string *
        ?level : int *
        ?listType : ListItemType *
        ?startNumber : Nullable<int> *
        ?trackChanges : bool
(* Defaults:
        let _level = defaultArg level 0
        let _listType = defaultArg listType ListItemType.Numbered
        let _startNumber = defaultArg startNumber null
        let _trackChanges = defaultArg trackChanges false
*)
-> List

Parameters

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

listText
Type: System..::..String

[Missing <param name="listText"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

level (Optional)
Type: System..::..Int32

[Missing <param name="level"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

listType (Optional)
Type: Novacode..::..ListItemType

[Missing <param name="listType"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

startNumber (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>

[Missing <param name="startNumber"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean)"]

See Also

DocX Class
DocX Members


DocX.AddProtection Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddProtection Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddProtection(Novacode.EditRestrictions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddProtection(
    EditRestrictions er
)
Visual Basic
Public Sub AddProtection (
    er As EditRestrictions
)
Visual C++
public:
void AddProtection(
    EditRestrictions er
)
F#
member AddProtection :
        er : EditRestrictions -> unit

Parameters

er
Type: Novacode..::..EditRestrictions

[Missing <param name="er"/> documentation for "M:Novacode.DocX.AddProtection(Novacode.EditRestrictions)"]

See Also

DocX Class
DocX Members


DocX.AddTable Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..AddTable Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table AddTable(
    int rowCount,
    int columnCount
)
Visual Basic
Public Function AddTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ AddTable(
    int rowCount,
    int columnCount
)
F#
member AddTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

See Also

DocX Class
DocX Members


DocX.ApplyTemplate Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..ApplyTemplate Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyTemplate(Stream) |
Public method | ApplyTemplate(String) |
Public method | ApplyTemplate(Stream, Boolean) |
Public method | ApplyTemplate(String, Boolean) |

See Also

DocX Class
DocX Members


DocX.ApplyTemplate Method (Stream)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..ApplyTemplate Method (Stream)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.ApplyTemplate(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void ApplyTemplate(
    Stream templateStream
)
Visual Basic
Public Sub ApplyTemplate (
    templateStream As Stream
)
Visual C++
public:
void ApplyTemplate(
    Stream^ templateStream
)
F#
member ApplyTemplate :
        templateStream : Stream -> unit

Parameters

templateStream
Type: System.IO..::..Stream

[Missing <param name="templateStream"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.IO.Stream)"]

See Also

DocX Class
DocX Members
ApplyTemplate Overload


DocX.ApplyTemplate Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..ApplyTemplate Method (String)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.ApplyTemplate(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void ApplyTemplate(
    string templateFilePath
)
Visual Basic
Public Sub ApplyTemplate (
    templateFilePath As String
)
Visual C++
public:
void ApplyTemplate(
    String^ templateFilePath
)
F#
member ApplyTemplate :
        templateFilePath : string -> unit

Parameters

templateFilePath
Type: System..::..String

[Missing <param name="templateFilePath"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.String)"]

See Also

DocX Class
DocX Members
ApplyTemplate Overload


DocX.ApplyTemplate Method (Stream, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..ApplyTemplate Method (Stream, Boolean)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.ApplyTemplate(System.IO.Stream,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void ApplyTemplate(
    Stream templateStream,
    bool includeContent
)
Visual Basic
Public Sub ApplyTemplate (
    templateStream As Stream,
    includeContent As Boolean
)
Visual C++
public:
void ApplyTemplate(
    Stream^ templateStream,
    bool includeContent
)
F#
member ApplyTemplate :
        templateStream : Stream *
        includeContent : bool -> unit

Parameters

templateStream
Type: System.IO..::..Stream

[Missing <param name="templateStream"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.IO.Stream,System.Boolean)"]

includeContent
Type: System..::..Boolean

[Missing <param name="includeContent"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.IO.Stream,System.Boolean)"]

See Also

DocX Class
DocX Members
ApplyTemplate Overload


DocX.ApplyTemplate Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..ApplyTemplate Method (String, Boolean)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.ApplyTemplate(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void ApplyTemplate(
    string templateFilePath,
    bool includeContent
)
Visual Basic
Public Sub ApplyTemplate (
    templateFilePath As String,
    includeContent As Boolean
)
Visual C++
public:
void ApplyTemplate(
    String^ templateFilePath,
    bool includeContent
)
F#
member ApplyTemplate :
        templateFilePath : string *
        includeContent : bool -> unit

Parameters

templateFilePath
Type: System..::..String

[Missing <param name="templateFilePath"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.String,System.Boolean)"]

includeContent
Type: System..::..Boolean

[Missing <param name="includeContent"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.String,System.Boolean)"]

See Also

DocX Class
DocX Members
ApplyTemplate Overload


DocX.clonePackagePart Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..clonePackagePart Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.clonePackagePart(System.IO.Packaging.PackagePart)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected PackagePart clonePackagePart(
    PackagePart pp
)
Visual Basic
Protected Function clonePackagePart (
    pp As PackagePart
) As PackagePart
Visual C++
protected:
PackagePart^ clonePackagePart(
    PackagePart^ pp
)
F#
member clonePackagePart :
        pp : PackagePart -> PackagePart

Parameters

pp
Type: System.IO.Packaging..::..PackagePart

[Missing <param name="pp"/> documentation for "M:Novacode.DocX.clonePackagePart(System.IO.Packaging.PackagePart)"]

Return Value

Type: PackagePart

[Missing <returns> documentation for "M:Novacode.DocX.clonePackagePart(System.IO.Packaging.PackagePart)"]

See Also

DocX Class
DocX Members


DocX.clonePackageRelationship Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..clonePackageRelationship Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected void clonePackageRelationship(
    DocX remote_document,
    PackagePart pp,
    XDocument remote_mainDoc
)
Visual Basic
Protected Sub clonePackageRelationship (
    remote_document As DocX,
    pp As PackagePart,
    remote_mainDoc As XDocument
)
Visual C++
protected:
void clonePackageRelationship(
    DocX^ remote_document,
    PackagePart^ pp,
    XDocument^ remote_mainDoc
)
F#
member clonePackageRelationship :
        remote_document : DocX *
        pp : PackagePart *
        remote_mainDoc : XDocument -> unit

Parameters

remote_document
Type: Novacode..::..DocX

[Missing <param name="remote_document"/> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

pp
Type: System.IO.Packaging..::..PackagePart

[Missing <param name="pp"/> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

remote_mainDoc
Type: System.Xml.Linq..::..XDocument

[Missing <param name="remote_mainDoc"/> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

See Also

DocX Class
DocX Members


DocX.Create Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..Create Method
DocX Class See Also Send Feedback

Overload List

Name | Description
Create(Stream, DocumentTypes) |
Create(String, DocumentTypes) |

See Also

DocX Class
DocX Members


DocX.Create Method (Stream, DocumentTypes)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Create Method (Stream, DocumentTypes)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.Create(System.IO.Stream,Novacode.DocumentTypes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public static DocX Create(
    Stream stream,
    DocumentTypes documentType = DocumentTypes.Document
)
Visual Basic
Public Shared Function Create (
    stream As Stream,
    Optional documentType As DocumentTypes = DocumentTypes.Document
) As DocX
Visual C++
public:
static DocX^ Create(
    Stream^ stream,
    DocumentTypes documentType = DocumentTypes::Document
)
F#
static member Create :
        stream : Stream *
        ?documentType : DocumentTypes
(* Defaults:
        let _documentType = defaultArg documentType DocumentTypes.Document
*)
-> DocX

Parameters

stream
Type: System.IO..::..Stream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.Create(System.IO.Stream,Novacode.DocumentTypes)"]

documentType (Optional)
Type: Novacode..::..DocumentTypes

[Missing <param name="documentType"/> documentation for "M:Novacode.DocX.Create(System.IO.Stream,Novacode.DocumentTypes)"]

Return Value

Type: DocX

[Missing <returns> documentation for "M:Novacode.DocX.Create(System.IO.Stream,Novacode.DocumentTypes)"]

See Also

DocX Class
DocX Members
Create Overload


DocX.Create Method (String, DocumentTypes)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Create Method (String, DocumentTypes)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.Create(System.String,Novacode.DocumentTypes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public static DocX Create(
    string filename,
    DocumentTypes documentType = DocumentTypes.Document
)
Visual Basic
Public Shared Function Create (
    filename As String,
    Optional documentType As DocumentTypes = DocumentTypes.Document
) As DocX
Visual C++
public:
static DocX^ Create(
    String^ filename,
    DocumentTypes documentType = DocumentTypes::Document
)
F#
static member Create :
        filename : string *
        ?documentType : DocumentTypes
(* Defaults:
        let _documentType = defaultArg documentType DocumentTypes.Document
*)
-> DocX

Parameters

filename
Type: System..::..String

[Missing <param name="filename"/> documentation for "M:Novacode.DocX.Create(System.String,Novacode.DocumentTypes)"]

documentType (Optional)
Type: Novacode..::..DocumentTypes

[Missing <param name="documentType"/> documentation for "M:Novacode.DocX.Create(System.String,Novacode.DocumentTypes)"]

Return Value

Type: DocX

[Missing <returns> documentation for "M:Novacode.DocX.Create(System.String,Novacode.DocumentTypes)"]

See Also

DocX Class
DocX Members
Create Overload


DocX.Dispose Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Dispose Method
DocX Class See Also Send Feedback
Releases all resources used by the DocX

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed
F#
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposable..::..Dispose()()()()

See Also

DocX Class
DocX Members


DocX.GetMD5HashFromStream Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..GetMD5HashFromStream Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.GetMD5HashFromStream(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected string GetMD5HashFromStream(
    Stream stream
)
Visual Basic
Protected Function GetMD5HashFromStream (
    stream As Stream
) As String
Visual C++
protected:
String^ GetMD5HashFromStream(
    Stream^ stream
)
F#
member GetMD5HashFromStream :
        stream : Stream -> string

Parameters

stream
Type: System.IO..::..Stream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.GetMD5HashFromStream(System.IO.Stream)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Novacode.DocX.GetMD5HashFromStream(System.IO.Stream)"]

See Also

DocX Class
DocX Members


DocX.GetProtectionType Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..GetProtectionType Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.GetProtectionType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public EditRestrictions GetProtectionType()
Visual Basic
Public Function GetProtectionType As EditRestrictions
Visual C++
public:
EditRestrictions GetProtectionType()
F#
member GetProtectionType : unit -> EditRestrictions

Return Value

Type: EditRestrictions

[Missing <returns> documentation for "M:Novacode.DocX.GetProtectionType"]

See Also

DocX Class
DocX Members


DocX.GetSections Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..GetSections Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.GetSections"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Section> GetSections()
Visual Basic
Public Function GetSections As List(Of Section)
Visual C++
public:
List<Section^>^ GetSections()
F#
member GetSections : unit -> List<Section>

Return Value

Type: List <(Of <(<' Section >)>)>

[Missing <returns> documentation for "M:Novacode.DocX.GetSections"]

See Also

DocX Class
DocX Members


DocX.InsertChart Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertChart Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertChart(Novacode.Chart)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertChart(
    Chart chart
)
Visual Basic
Public Sub InsertChart (
    chart As Chart
)
Visual C++
public:
void InsertChart(
    Chart^ chart
)
F#
member InsertChart :
        chart : Chart -> unit

Parameters

chart
Type: Novacode..::..Chart

[Missing <param name="chart"/> documentation for "M:Novacode.DocX.InsertChart(Novacode.Chart)"]

See Also

DocX Class
DocX Members


DocX.InsertDocument Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertDocument Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertDocument(Novacode.DocX)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertDocument(
    DocX remote_document
)
Visual Basic
Public Sub InsertDocument (
    remote_document As DocX
)
Visual C++
public:
void InsertDocument(
    DocX^ remote_document
)
F#
member InsertDocument :
        remote_document : DocX -> unit

Parameters

remote_document
Type: Novacode..::..DocX

[Missing <param name="remote_document"/> documentation for "M:Novacode.DocX.InsertDocument(Novacode.DocX)"]

See Also

DocX Class
DocX Members


DocX.InsertEquation Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertEquation Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertEquation(
    string equation
)
Visual Basic
Public Overrides Function InsertEquation (
    equation As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertEquation(
    String^ equation
) override
F#
abstract InsertEquation :
        equation : string -> Paragraph
override InsertEquation :
        equation : string -> Paragraph

Parameters

equation
Type: System..::..String

[Missing <param name="equation"/> documentation for "M:Novacode.DocX.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertEquation(System.String)"]

See Also

DocX Class
DocX Members


DocX.InsertList Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertList Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |

See Also

DocX Class
DocX Members


DocX.InsertList Method (List)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertList Method (List)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertList(Novacode.List)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    List list
)
Visual Basic
Public Function InsertList (
    list As List
) As List
Visual C++
public:
List^ InsertList(
    List^ list
)
F#
member InsertList :
        list : List -> List

Parameters

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.InsertList(Novacode.List)"]

See Also

DocX Class
DocX Members
InsertList Overload


DocX.InsertList Method (Int32, List)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertList Method (Int32, List)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertList(System.Int32,Novacode.List)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    int index,
    List list
)
Visual Basic
Public Function InsertList (
    index As Integer,
    list As List
) As List
Visual C++
public:
List^ InsertList(
    int index,
    List^ list
)
F#
member InsertList :
        index : int *
        list : List -> List

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertList(System.Int32,Novacode.List)"]

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.DocX.InsertList(System.Int32,Novacode.List)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.InsertList(System.Int32,Novacode.List)"]

See Also

DocX Class
DocX Members
InsertList Overload


DocX.InsertList Method (List, Double)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertList Method (List, Double)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    List list,
    double fontSize
)
Visual Basic
Public Function InsertList (
    list As List,
    fontSize As Double
) As List
Visual C++
public:
List^ InsertList(
    List^ list,
    double fontSize
)
F#
member InsertList :
        list : List *
        fontSize : float -> List

Parameters

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Double)"]

fontSize
Type: System..::..Double

[Missing <param name="fontSize"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Double)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Double)"]

See Also

DocX Class
DocX Members
InsertList Overload


DocX.InsertList Method (List, FontFamily, Double)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertList Method (List, FontFamily, Double)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List InsertList(
    List list,
    FontFamily fontFamily,
    double fontSize
)
Visual Basic
Public Function InsertList (
    list As List,
    fontFamily As FontFamily,
    fontSize As Double
) As List
Visual C++
public:
List^ InsertList(
    List^ list,
    FontFamily^ fontFamily,
    double fontSize
)
F#
member InsertList :
        list : List *
        fontFamily : FontFamily *
        fontSize : float -> List

Parameters

list
Type: Novacode..::..List

[Missing <param name="list"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

fontFamily
Type: System.Drawing..::..FontFamily

[Missing <param name="fontFamily"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

fontSize
Type: System..::..Double

[Missing <param name="fontSize"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

See Also

DocX Class
DocX Members
InsertList Overload


DocX.InsertParagraph Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)

See Also

DocX Class
DocX Members


DocX.InsertParagraph Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph()
Visual Basic
Public Overrides Function InsertParagraph As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph() override
F#
abstract InsertParagraph : unit -> Paragraph
override InsertParagraph : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (String)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text
) override
F#
abstract InsertParagraph :
        text : string -> Paragraph
override InsertParagraph :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.String)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (Paragraph)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
) override
F#
abstract InsertParagraph :
        p : Paragraph -> Paragraph
override InsertParagraph :
        p : Paragraph -> Paragraph

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.DocX.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(Novacode.Paragraph)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (Int32, Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (Int32, Paragraph)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
) override
F#
abstract InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph
override InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (String, Boolean)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
) override
F#
abstract InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (Int32, String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (Int32, String, Boolean)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
) override
F#
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (String, Boolean, Formatting)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
F#
abstract InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraph Method (Int32, String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraph Method (Int32, String, Boolean, Formatting)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
F#
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

DocX Class
DocX Members
InsertParagraph Overload


DocX.InsertParagraphs Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertParagraphs Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraphs(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph[] InsertParagraphs(
    string text
)
Visual Basic
Public Function InsertParagraphs (
    text As String
) As Paragraph()
Visual C++
public:
array<Paragraph^>^ InsertParagraphs(
    String^ text
)
F#
member InsertParagraphs :
        text : string -> Paragraph[]

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraphs(System.String)"]

Return Value

Type: array< Paragraph >[]()[][]

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraphs(System.String)"]

See Also

DocX Class
DocX Members


DocX.InsertTable Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertTable Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |

See Also

DocX Class
DocX Members


DocX.InsertTable Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertTable Method (Table)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertTable(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    Table t
)
Visual Basic
Public Function InsertTable (
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    Table^ t
)
F#
member InsertTable :
        t : Table -> Table

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.DocX.InsertTable(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.InsertTable(Novacode.Table)"]

See Also

DocX Class
DocX Members
InsertTable Overload


DocX.InsertTable Method (Int32, Table)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertTable Method (Int32, Table)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertTable(System.Int32,Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    Table t
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    Table^ t
)
F#
member InsertTable :
        index : int *
        t : Table -> Table

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,Novacode.Table)"]

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.InsertTable(System.Int32,Novacode.Table)"]

See Also

DocX Class
DocX Members
InsertTable Overload


DocX.InsertTable Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertTable Method (Int32, Int32)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int rowCount,
    int columnCount
)
Visual Basic
Public Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ InsertTable(
    int rowCount,
    int columnCount
)
F#
member InsertTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32)"]

See Also

DocX Class
DocX Members
InsertTable Overload


DocX.InsertTable Method (Int32, Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..InsertTable Method (Int32, Int32, Int32)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    int rowCount,
    int columnCount
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    int rowCount,
    int columnCount
)
F#
member InsertTable :
        index : int *
        rowCount : int *
        columnCount : int -> Table

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32,System.Int32)"]

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32,System.Int32)"]

See Also

DocX Class
DocX Members
InsertTable Overload


DocX.Load Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..Load Method
DocX Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) |
Load(String) |

See Also

DocX Class
DocX Members


DocX.Load Method (Stream)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Load Method (Stream)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.Load(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public static DocX Load(
    Stream stream
)
Visual Basic
Public Shared Function Load (
    stream As Stream
) As DocX
Visual C++
public:
static DocX^ Load(
    Stream^ stream
)
F#
static member Load :
        stream : Stream -> DocX

Parameters

stream
Type: System.IO..::..Stream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.Load(System.IO.Stream)"]

Return Value

Type: DocX

[Missing <returns> documentation for "M:Novacode.DocX.Load(System.IO.Stream)"]

See Also

DocX Class
DocX Members
Load Overload


DocX.Load Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Load Method (String)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.Load(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public static DocX Load(
    string filename
)
Visual Basic
Public Shared Function Load (
    filename As String
) As DocX
Visual C++
public:
static DocX^ Load(
    String^ filename
)
F#
static member Load :
        filename : string -> DocX

Parameters

filename
Type: System..::..String

[Missing <param name="filename"/> documentation for "M:Novacode.DocX.Load(System.String)"]

Return Value

Type: DocX

[Missing <returns> documentation for "M:Novacode.DocX.Load(System.String)"]

See Also

DocX Class
DocX Members
Load Overload


DocX.RemoveProtection Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..RemoveProtection Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.RemoveProtection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveProtection()
Visual Basic
Public Sub RemoveProtection
Visual C++
public:
void RemoveProtection()
F#
member RemoveProtection : unit -> unit

See Also

DocX Class
DocX Members


DocX.Save Method

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Save Method
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.Save"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Save()
Visual Basic
Public Sub Save
Visual C++
public:
void Save()
F#
member Save : unit -> unit

See Also

DocX Class
DocX Members


DocX.SaveAs Method

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX..::..SaveAs Method
DocX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveAs(Stream) |
Public method | SaveAs(String) |

See Also

DocX Class
DocX Members


DocX.SaveAs Method (Stream)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..SaveAs Method (Stream)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.SaveAs(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SaveAs(
    Stream stream
)
Visual Basic
Public Sub SaveAs (
    stream As Stream
)
Visual C++
public:
void SaveAs(
    Stream^ stream
)
F#
member SaveAs :
        stream : Stream -> unit

Parameters

stream
Type: System.IO..::..Stream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.SaveAs(System.IO.Stream)"]

See Also

DocX Class
DocX Members
SaveAs Overload


DocX.SaveAs Method (String)

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..SaveAs Method (String)
DocX Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.DocX.SaveAs(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SaveAs(
    string filename
)
Visual Basic
Public Sub SaveAs (
    filename As String
)
Visual C++
public:
void SaveAs(
    String^ filename
)
F#
member SaveAs :
        filename : string -> unit

Parameters

filename
Type: System..::..String

[Missing <param name="filename"/> documentation for "M:Novacode.DocX.SaveAs(System.String)"]

See Also

DocX Class
DocX Members
SaveAs Overload


DocX Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
DocX Properties
DocX Class See Also Send Feedback

The DocX type exposes the following members.

Properties

 | Name | Description
Public property | CoreProperties |
Public property | CustomProperties |
Public property | DifferentFirstPage |
Public property | DifferentOddAndEvenPages |
Public property | Footers |
Public property | Headers |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images |
Public property | isProtected |
Public property | Lists | (Overrides Container..::..Lists.)
Public property | MarginBottom |
Public property | MarginLeft |
Public property | MarginRight |
Public property | MarginTop |
Public property | PageHeight |
Public property | PageLayout |
Public property | PageWidth |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Text |
Public property | Xml | (Inherited from DocXElement.)

See Also

DocX Class


DocX.CoreProperties Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..CoreProperties Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.CoreProperties"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Dictionary<string, string> CoreProperties { get; }
Visual Basic
Public ReadOnly Property CoreProperties As Dictionary(Of String, String)
    Get
Visual C++
public:
property Dictionary<String^, String^>^ CoreProperties {
    Dictionary<String^, String^>^ get ();
}
F#
member CoreProperties : Dictionary<string, string> with get

Property Value

Type: Dictionary <(Of <(<' String, String >)>)>

See Also

DocX Class
DocX Members


DocX.CustomProperties Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..CustomProperties Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.CustomProperties"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Dictionary<string, CustomProperty> CustomProperties { get; }
Visual Basic
Public ReadOnly Property CustomProperties As Dictionary(Of String, CustomProperty)
    Get
Visual C++
public:
property Dictionary<String^, CustomProperty^>^ CustomProperties {
    Dictionary<String^, CustomProperty^>^ get ();
}
F#
member CustomProperties : Dictionary<string, CustomProperty> with get

Property Value

Type: Dictionary <(Of <(<' String, CustomProperty >)>)>

See Also

DocX Class
DocX Members


DocX.DifferentFirstPage Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..DifferentFirstPage Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.DifferentFirstPage"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool DifferentFirstPage { get; set; }
Visual Basic
Public Property DifferentFirstPage As Boolean
    Get
    Set
Visual C++
public:
property bool DifferentFirstPage {
    bool get ();
    void set (bool value);
}
F#
member DifferentFirstPage : bool with get, set

Property Value

Type: Boolean

See Also

DocX Class
DocX Members


DocX.DifferentOddAndEvenPages Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..DifferentOddAndEvenPages Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.DifferentOddAndEvenPages"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool DifferentOddAndEvenPages { get; set; }
Visual Basic
Public Property DifferentOddAndEvenPages As Boolean
    Get
    Set
Visual C++
public:
property bool DifferentOddAndEvenPages {
    bool get ();
    void set (bool value);
}
F#
member DifferentOddAndEvenPages : bool with get, set

Property Value

Type: Boolean

See Also

DocX Class
DocX Members


DocX.Footers Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Footers Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.Footers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Footers Footers { get; }
Visual Basic
Public ReadOnly Property Footers As Footers
    Get
Visual C++
public:
property Footers^ Footers {
    Footers^ get ();
}
F#
member Footers : Footers with get

Property Value

Type: Footers

See Also

DocX Class
DocX Members


DocX.Headers Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Headers Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.Headers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Headers Headers { get; }
Visual Basic
Public ReadOnly Property Headers As Headers
    Get
Visual C++
public:
property Headers^ Headers {
    Headers^ get ();
}
F#
member Headers : Headers with get

Property Value

Type: Headers

See Also

DocX Class
DocX Members


DocX.Images Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Images Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.Images"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Image> Images { get; }
Visual Basic
Public ReadOnly Property Images As List(Of Image)
    Get
Visual C++
public:
property List<Image^>^ Images {
    List<Image^>^ get ();
}
F#
member Images : List<Image> with get

Property Value

Type: List <(Of <(<' Image >)>)>

See Also

DocX Class
DocX Members


DocX.isProtected Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..isProtected Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.isProtected"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool isProtected { get; }
Visual Basic
Public ReadOnly Property isProtected As Boolean
    Get
Visual C++
public:
property bool isProtected {
    bool get ();
}
F#
member isProtected : bool with get

Property Value

Type: Boolean

See Also

DocX Class
DocX Members


DocX.Lists Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Lists Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.Lists"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<List> Lists { get; }
Visual Basic
Public Overrides ReadOnly Property Lists As List(Of List)
    Get
Visual C++
public:
virtual property List<List^>^ Lists {
    List<List^>^ get () override;
}
F#
abstract Lists : List<List> with get
override Lists : List<List> with get

Property Value

Type: List <(Of <(<' List >)>)>

See Also

DocX Class
DocX Members


DocX.MarginBottom Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..MarginBottom Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.MarginBottom"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float MarginBottom { get; set; }
Visual Basic
Public Property MarginBottom As Single
    Get
    Set
Visual C++
public:
property float MarginBottom {
    float get ();
    void set (float value);
}
F#
member MarginBottom : float32 with get, set

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.MarginLeft Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..MarginLeft Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.MarginLeft"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float MarginLeft { get; set; }
Visual Basic
Public Property MarginLeft As Single
    Get
    Set
Visual C++
public:
property float MarginLeft {
    float get ();
    void set (float value);
}
F#
member MarginLeft : float32 with get, set

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.MarginRight Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..MarginRight Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.MarginRight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float MarginRight { get; set; }
Visual Basic
Public Property MarginRight As Single
    Get
    Set
Visual C++
public:
property float MarginRight {
    float get ();
    void set (float value);
}
F#
member MarginRight : float32 with get, set

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.MarginTop Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..MarginTop Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.MarginTop"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float MarginTop { get; set; }
Visual Basic
Public Property MarginTop As Single
    Get
    Set
Visual C++
public:
property float MarginTop {
    float get ();
    void set (float value);
}
F#
member MarginTop : float32 with get, set

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.PageHeight Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..PageHeight Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.PageHeight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float PageHeight { get; set; }
Visual Basic
Public Property PageHeight As Single
    Get
    Set
Visual C++
public:
property float PageHeight {
    float get ();
    void set (float value);
}
F#
member PageHeight : float32 with get, set

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.PageLayout Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..PageLayout Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.PageLayout"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public PageLayout PageLayout { get; }
Visual Basic
Public ReadOnly Property PageLayout As PageLayout
    Get
Visual C++
public:
property PageLayout^ PageLayout {
    PageLayout^ get ();
}
F#
member PageLayout : PageLayout with get

Property Value

Type: PageLayout

See Also

DocX Class
DocX Members


DocX.PageWidth Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..PageWidth Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.PageWidth"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float PageWidth { get; set; }
Visual Basic
Public Property PageWidth As Single
    Get
    Set
Visual C++
public:
property float PageWidth {
    float get ();
    void set (float value);
}
F#
member PageWidth : float32 with get, set

Property Value

Type: Single

See Also

DocX Class
DocX Members


DocX.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Paragraphs Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override ReadOnlyCollection<Paragraph> Paragraphs { get; }
Visual Basic
Public Overrides ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
Visual C++
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get () override;
}
F#
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection <(Of <(<' Paragraph >)>)>

See Also

DocX Class
DocX Members


DocX.Tables Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Tables Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Table> Tables { get; }
Visual Basic
Public Overrides ReadOnly Property Tables As List(Of Table)
    Get
Visual C++
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get () override;
}
F#
abstract Tables : List<Table> with get
override Tables : List<Table> with get

Property Value

Type: List <(Of <(<' Table >)>)>

See Also

DocX Class
DocX Members


DocX.Text Property

[image]

DocX - A Sandcastle Documented Class Library
DocX..::..Text Property
DocX Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocX.Text"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}
F#
member Text : string with get

Property Value

Type: String

See Also

DocX Class
DocX Members


DocXElement Class

[image]

DocX - A Sandcastle Documented Class Library
DocXElement Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.DocXElement"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public abstract class DocXElement
Visual Basic
Public MustInherit Class DocXElement
Visual C++
public ref class DocXElement abstract
F#
[<AbstractClassAttribute>]
type DocXElement =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..DocProperty
Novacode..::..Hyperlink
Novacode..::..InsertBeforeOrAfter
Novacode..::..PageLayout
Novacode..::..Picture
Novacode..::..Run

See Also

DocXElement Members


DocXElement Members

[image] [image]

DocX - A Sandcastle Documented Class Library
DocXElement Members
DocXElement Class Constructors Methods Properties See Also Send Feedback

The DocXElement type exposes the following members.

Constructors

 | Name | Description
Public method | DocXElement | Initializes a new instance of the DocXElement class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Xml |

See Also

DocXElement Class


DocXElement Constructor

[image]

DocX - A Sandcastle Documented Class Library
DocXElement Constructor
DocXElement Class See Also Send Feedback
Initializes a new instance of the DocXElement class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public DocXElement(
    DocX document,
    XElement xml
)
Visual Basic
Public Sub New (
    document As DocX,
    xml As XElement
)
Visual C++
public:
DocXElement(
    DocX^ document,
    XElement^ xml
)
F#
new :
        document : DocX *
        xml : XElement -> DocXElement

Parameters

document
Type: Novacode..::..DocX

[Missing <param name="document"/> documentation for "M:Novacode.DocXElement.#ctor(Novacode.DocX,System.Xml.Linq.XElement)"]

xml
Type: System.Xml.Linq..::..XElement

[Missing <param name="xml"/> documentation for "M:Novacode.DocXElement.#ctor(Novacode.DocX,System.Xml.Linq.XElement)"]

See Also

DocXElement Class
DocXElement Members


DocXElement Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
DocXElement Methods
DocXElement Class See Also Send Feedback

The DocXElement type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocXElement Class


DocXElement Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
DocXElement Properties
DocXElement Class See Also Send Feedback

The DocXElement type exposes the following members.

Properties

 | Name | Description
Public property | Xml |

See Also

DocXElement Class


DocXElement.Xml Property

[image]

DocX - A Sandcastle Documented Class Library
DocXElement..::..Xml Property
DocXElement Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.DocXElement.Xml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public XElement Xml { get; set; }
Visual Basic
Public Property Xml As XElement
    Get
    Set
Visual C++
public:
property XElement^ Xml {
    XElement^ get ();
    void set (XElement^ value);
}
F#
member Xml : XElement with get, set

Property Value

Type: XElement

See Also

DocXElement Class
DocXElement Members


EditRestrictions Enumeration

[image]

DocX - A Sandcastle Documented Class Library
EditRestrictions Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.EditRestrictions"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum EditRestrictions
Visual Basic
Public Enumeration EditRestrictions
Visual C++
public enum class EditRestrictions
F#
type EditRestrictions

Members

Member name | Value | Description
none | 0 |
readOnly | 1 |
forms | 2 |
comments | 3 |
trackedChanges | 4 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


EquationShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
EquationShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.EquationShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum EquationShapes
Visual Basic
Public Enumeration EquationShapes
Visual C++
public enum class EquationShapes
F#
type EquationShapes

Members

Member name | Value | Description
mathPlus | 0 |
mathMinus | 1 |
mathMultiply | 2 |
mathDivide | 3 |
mathEqual | 4 |
mathNotEqual | 5 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


FlowchartShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
FlowchartShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.FlowchartShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum FlowchartShapes
Visual Basic
Public Enumeration FlowchartShapes
Visual C++
public enum class FlowchartShapes
F#
type FlowchartShapes

Members

Member name | Value | Description
flowChartProcess | 0 |
flowChartAlternateProcess | 1 |
flowChartDecision | 2 |
flowChartInputOutput | 3 |
flowChartPredefinedProcess | 4 |
flowChartInternalStorage | 5 |
flowChartDocument | 6 |
flowChartMultidocument | 7 |
flowChartTerminator | 8 |
flowChartPreparation | 9 |
flowChartManualInput | 10 |
flowChartManualOperation | 11 |
flowChartConnector | 12 |
flowChartOffpageConnector | 13 |
flowChartPunchedCard | 14 |
flowChartPunchedTape | 15 |
flowChartSummingJunction | 16 |
flowChartOr | 17 |
flowChartCollate | 18 |
flowChartSort | 19 |
flowChartExtract | 20 |
flowChartMerge | 21 |
flowChartOnlineStorage | 22 |
flowChartDelay | 23 |
flowChartMagneticTape | 24 |
flowChartMagneticDisk | 25 |
flowChartMagneticDrum | 26 |
flowChartDisplay | 27 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Footer Class

[image]

DocX - A Sandcastle Documented Class Library
Footer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Footer"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Footer : Container
Visual Basic
Public Class Footer
    Inherits Container
Visual C++
public ref class Footer : public Container
F#
type Footer =
    class
        inherit Container
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Footer

See Also

Footer Members


Footer Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer Members
Footer Class Methods Fields Properties See Also Send Feedback

The Footer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Xml | (Inherited from DocXElement.)

See Also

Footer Class


Footer Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer Fields
Footer Class See Also Send Feedback

The Footer type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

See Also

Footer Class


Footer Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer Methods
Footer Class See Also Send Feedback

The Footer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Footer Class


Footer.InsertEquation Method

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertEquation Method
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertEquation(
    string equation
)
Visual Basic
Public Overrides Function InsertEquation (
    equation As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertEquation(
    String^ equation
) override
F#
abstract InsertEquation :
        equation : string -> Paragraph
override InsertEquation :
        equation : string -> Paragraph

Parameters

equation
Type: System..::..String

[Missing <param name="equation"/> documentation for "M:Novacode.Footer.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertEquation(System.String)"]

See Also

Footer Class
Footer Members


Footer.InsertParagraph Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method
Footer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)

See Also

Footer Class
Footer Members


Footer.InsertParagraph Method

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph()
Visual Basic
Public Overrides Function InsertParagraph As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph() override
F#
abstract InsertParagraph : unit -> Paragraph
override InsertParagraph : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (String)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text
) override
F#
abstract InsertParagraph :
        text : string -> Paragraph
override InsertParagraph :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.String)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (Paragraph)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
) override
F#
abstract InsertParagraph :
        p : Paragraph -> Paragraph
override InsertParagraph :
        p : Paragraph -> Paragraph

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Footer.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(Novacode.Paragraph)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (Int32, Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (Int32, Paragraph)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
) override
F#
abstract InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph
override InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (String, Boolean)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
) override
F#
abstract InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (Int32, String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (Int32, String, Boolean)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
) override
F#
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (String, Boolean, Formatting)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
F#
abstract InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertParagraph Method (Int32, String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertParagraph Method (Int32, String, Boolean, Formatting)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
F#
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Footer Class
Footer Members
InsertParagraph Overload


Footer.InsertTable Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertTable Method
Footer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |

See Also

Footer Class
Footer Members


Footer.InsertTable Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertTable Method (Table)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertTable(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    Table t
)
Visual Basic
Public Function InsertTable (
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    Table^ t
)
F#
member InsertTable :
        t : Table -> Table

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Footer.InsertTable(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Footer.InsertTable(Novacode.Table)"]

See Also

Footer Class
Footer Members
InsertTable Overload


Footer.InsertTable Method (Int32, Table)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertTable Method (Int32, Table)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertTable(System.Int32,Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    Table t
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    Table^ t
)
F#
member InsertTable :
        index : int *
        t : Table -> Table

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,Novacode.Table)"]

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Footer.InsertTable(System.Int32,Novacode.Table)"]

See Also

Footer Class
Footer Members
InsertTable Overload


Footer.InsertTable Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertTable Method (Int32, Int32)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int rowCount,
    int columnCount
)
Visual Basic
Public Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ InsertTable(
    int rowCount,
    int columnCount
)
F#
member InsertTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32)"]

See Also

Footer Class
Footer Members
InsertTable Overload


Footer.InsertTable Method (Int32, Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..InsertTable Method (Int32, Int32, Int32)
Footer Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    int rowCount,
    int columnCount
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    int rowCount,
    int columnCount
)
F#
member InsertTable :
        index : int *
        rowCount : int *
        columnCount : int -> Table

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32,System.Int32)"]

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32,System.Int32)"]

See Also

Footer Class
Footer Members
InsertTable Overload


Footer Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Footer Properties
Footer Class See Also Send Feedback

The Footer type exposes the following members.

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Xml | (Inherited from DocXElement.)

See Also

Footer Class


Footer.PageNumbers Property

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..PageNumbers Property
Footer Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Footer.PageNumbers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool PageNumbers { get; set; }
Visual Basic
Public Property PageNumbers As Boolean
    Get
    Set
Visual C++
public:
property bool PageNumbers {
    bool get ();
    void set (bool value);
}
F#
member PageNumbers : bool with get, set

Property Value

Type: Boolean

See Also

Footer Class
Footer Members


Footer.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..Paragraphs Property
Footer Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Footer.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override ReadOnlyCollection<Paragraph> Paragraphs { get; }
Visual Basic
Public Overrides ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
Visual C++
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get () override;
}
F#
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection <(Of <(<' Paragraph >)>)>

See Also

Footer Class
Footer Members


Footer.Tables Property

[image]

DocX - A Sandcastle Documented Class Library
Footer..::..Tables Property
Footer Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Footer.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Table> Tables { get; }
Visual Basic
Public Overrides ReadOnly Property Tables As List(Of Table)
    Get
Visual C++
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get () override;
}
F#
abstract Tables : List<Table> with get
override Tables : List<Table> with get

Property Value

Type: List <(Of <(<' Table >)>)>

See Also

Footer Class
Footer Members


Footers Class

[image]

DocX - A Sandcastle Documented Class Library
Footers Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Footers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Footers
Visual Basic
Public Class Footers
Visual C++
public ref class Footers
F#
type Footers =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..Footers

See Also

Footers Members


Footers Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Footers Members
Footers Class Methods Fields See Also Send Feedback

The Footers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | even |
Public field | first |
Public field | odd |

See Also

Footers Class


Footers Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Footers Fields
Footers Class See Also Send Feedback

The Footers type exposes the following members.

Fields

 | Name | Description
Public field | even |
Public field | first |
Public field | odd |

See Also

Footers Class


Footers.even Field

[image]

DocX - A Sandcastle Documented Class Library
Footers..::..even Field
Footers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Footers.even"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Footer even
Visual Basic
Public even As Footer
Visual C++
public:
Footer^ even
F#
val mutable even: Footer

Field Value

Type: Footer

See Also

Footers Class
Footers Members


Footers.first Field

[image]

DocX - A Sandcastle Documented Class Library
Footers..::..first Field
Footers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Footers.first"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Footer first
Visual Basic
Public first As Footer
Visual C++
public:
Footer^ first
F#
val mutable first: Footer

Field Value

Type: Footer

See Also

Footers Class
Footers Members


Footers.odd Field

[image]

DocX - A Sandcastle Documented Class Library
Footers..::..odd Field
Footers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Footers.odd"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Footer odd
Visual Basic
Public odd As Footer
Visual C++
public:
Footer^ odd
F#
val mutable odd: Footer

Field Value

Type: Footer

See Also

Footers Class
Footers Members


Footers Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Footers Methods
Footers Class See Also Send Feedback

The Footers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Footers Class


FormattedText Class

[image]

DocX - A Sandcastle Documented Class Library
FormattedText Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.FormattedText"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class FormattedText : IComparable
Visual Basic
Public Class FormattedText
    Implements IComparable
Visual C++
public ref class FormattedText : IComparable
F#
type FormattedText =
    class
        interface IComparable
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..FormattedText

See Also

FormattedText Members


FormattedText Members

[image] [image]

DocX - A Sandcastle Documented Class Library
FormattedText Members
FormattedText Class Constructors Methods Fields See Also Send Feedback

The FormattedText type exposes the following members.

Constructors

 | Name | Description
Public method | FormattedText | Initializes a new instance of the FormattedText class

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | formatting |
Public field | index |
Public field | text |

See Also

FormattedText Class


FormattedText Constructor

[image]

DocX - A Sandcastle Documented Class Library
FormattedText Constructor
FormattedText Class See Also Send Feedback
Initializes a new instance of the FormattedText class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public FormattedText()
Visual Basic
Public Sub New
Visual C++
public:
FormattedText()
F#
new : unit -> FormattedText

See Also

FormattedText Class
FormattedText Members


FormattedText Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
FormattedText Fields
FormattedText Class See Also Send Feedback

The FormattedText type exposes the following members.

Fields

 | Name | Description
Public field | formatting |
Public field | index |
Public field | text |

See Also

FormattedText Class


FormattedText.formatting Field

[image]

DocX - A Sandcastle Documented Class Library
FormattedText..::..formatting Field
FormattedText Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.FormattedText.formatting"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Formatting formatting
Visual Basic
Public formatting As Formatting
Visual C++
public:
Formatting^ formatting
F#
val mutable formatting: Formatting

Field Value

Type: Formatting

See Also

FormattedText Class
FormattedText Members


FormattedText.index Field

[image]

DocX - A Sandcastle Documented Class Library
FormattedText..::..index Field
FormattedText Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.FormattedText.index"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int index
Visual Basic
Public index As Integer
Visual C++
public:
int index
F#
val mutable index: int

Field Value

Type: Int32

See Also

FormattedText Class
FormattedText Members


FormattedText.text Field

[image]

DocX - A Sandcastle Documented Class Library
FormattedText..::..text Field
FormattedText Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.FormattedText.text"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string text
Visual Basic
Public text As String
Visual C++
public:
String^ text
F#
val mutable text: string

Field Value

Type: String

See Also

FormattedText Class
FormattedText Members


FormattedText Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
FormattedText Methods
FormattedText Class See Also Send Feedback

The FormattedText type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FormattedText Class


FormattedText.CompareTo Method

[image]

DocX - A Sandcastle Documented Class Library
FormattedText..::..CompareTo Method
FormattedText Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.FormattedText.CompareTo(System.Object)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo (
    obj As Object
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed
F#
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Novacode.FormattedText.CompareTo(System.Object)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Novacode.FormattedText.CompareTo(System.Object)"]

Implements

IComparable..::..CompareTo(Object)

See Also

FormattedText Class
FormattedText Members


Formatting Class

[image]

DocX - A Sandcastle Documented Class Library
Formatting Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Formatting"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Formatting : IComparable
Visual Basic
Public Class Formatting
    Implements IComparable
Visual C++
public ref class Formatting : IComparable
F#
type Formatting =
    class
        interface IComparable
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..Formatting

See Also

Formatting Members


Formatting Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Formatting Members
Formatting Class Constructors Methods Properties See Also Send Feedback

The Formatting type exposes the following members.

Constructors

 | Name | Description
Public method | Formatting | Initializes a new instance of the Formatting class

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bold |
Public property | CapsStyle |
Public property | FontColor |
Public property | FontFamily |
Public property | Hidden |
Public property | Highlight |
Public property | Italic |
Public property | Kerning |
Public property | Language |
Public property | Misc |
Public property | PercentageScale |
Public property | Position |
Public property | Script |
Public property | Size |
Public property | Spacing |
Public property | StrikeThrough |
Public property | UnderlineColor |
Public property | UnderlineStyle |

See Also

Formatting Class


Formatting Constructor

[image]

DocX - A Sandcastle Documented Class Library
Formatting Constructor
Formatting Class See Also Send Feedback
Initializes a new instance of the Formatting class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Formatting()
Visual Basic
Public Sub New
Visual C++
public:
Formatting()
F#
new : unit -> Formatting

See Also

Formatting Class
Formatting Members


Formatting Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Formatting Methods
Formatting Class See Also Send Feedback

The Formatting type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Formatting Class


Formatting.CompareTo Method

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..CompareTo Method
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Formatting.CompareTo(System.Object)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo (
    obj As Object
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed
F#
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Novacode.Formatting.CompareTo(System.Object)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Novacode.Formatting.CompareTo(System.Object)"]

Implements

IComparable..::..CompareTo(Object)

See Also

Formatting Class
Formatting Members


Formatting.Parse Method

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Parse Method
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Formatting.Parse(System.Xml.Linq.XElement)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public static Formatting Parse(
    XElement rPr
)
Visual Basic
Public Shared Function Parse (
    rPr As XElement
) As Formatting
Visual C++
public:
static Formatting^ Parse(
    XElement^ rPr
)
F#
static member Parse :
        rPr : XElement -> Formatting

Parameters

rPr
Type: System.Xml.Linq..::..XElement

[Missing <param name="rPr"/> documentation for "M:Novacode.Formatting.Parse(System.Xml.Linq.XElement)"]

Return Value

Type: Formatting

[Missing <returns> documentation for "M:Novacode.Formatting.Parse(System.Xml.Linq.XElement)"]

See Also

Formatting Class
Formatting Members


Formatting Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Formatting Properties
Formatting Class See Also Send Feedback

The Formatting type exposes the following members.

Properties

 | Name | Description
Public property | Bold |
Public property | CapsStyle |
Public property | FontColor |
Public property | FontFamily |
Public property | Hidden |
Public property | Highlight |
Public property | Italic |
Public property | Kerning |
Public property | Language |
Public property | Misc |
Public property | PercentageScale |
Public property | Position |
Public property | Script |
Public property | Size |
Public property | Spacing |
Public property | StrikeThrough |
Public property | UnderlineColor |
Public property | UnderlineStyle |

See Also

Formatting Class


Formatting.Bold Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Bold Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Bold"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool Bold { get; set; }
Visual Basic
Public Property Bold As Boolean
    Get
    Set
Visual C++
public:
property bool Bold {
    bool get ();
    void set (bool value);
}
F#
member Bold : bool with get, set

Property Value

Type: Boolean

See Also

Formatting Class
Formatting Members


Formatting.CapsStyle Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..CapsStyle Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.CapsStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CapsStyle CapsStyle { get; set; }
Visual Basic
Public Property CapsStyle As CapsStyle
    Get
    Set
Visual C++
public:
property CapsStyle CapsStyle {
    CapsStyle get ();
    void set (CapsStyle value);
}
F#
member CapsStyle : CapsStyle with get, set

Property Value

Type: CapsStyle

See Also

Formatting Class
Formatting Members


Formatting.FontColor Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..FontColor Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.FontColor"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<Color> FontColor { get; set; }
Visual Basic
Public Property FontColor As Nullable(Of Color)
    Get
    Set
Visual C++
public:
property Nullable<Color> FontColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}
F#
member FontColor : Nullable<Color> with get, set

Property Value

Type: Nullable <(Of <(<' Color >)>)>

See Also

Formatting Class
Formatting Members


Formatting.FontFamily Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..FontFamily Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.FontFamily"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public FontFamily FontFamily { get; set; }
Visual Basic
Public Property FontFamily As FontFamily
    Get
    Set
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}
F#
member FontFamily : FontFamily with get, set

Property Value

Type: FontFamily

See Also

Formatting Class
Formatting Members


Formatting.Hidden Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Hidden Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Hidden"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool Hidden { get; set; }
Visual Basic
Public Property Hidden As Boolean
    Get
    Set
Visual C++
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
F#
member Hidden : bool with get, set

Property Value

Type: Boolean

See Also

Formatting Class
Formatting Members


Formatting.Highlight Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Highlight Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Highlight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Highlight Highlight { get; set; }
Visual Basic
Public Property Highlight As Highlight
    Get
    Set
Visual C++
public:
property Highlight Highlight {
    Highlight get ();
    void set (Highlight value);
}
F#
member Highlight : Highlight with get, set

Property Value

Type: Highlight

See Also

Formatting Class
Formatting Members


Formatting.Italic Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Italic Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Italic"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool Italic { get; set; }
Visual Basic
Public Property Italic As Boolean
    Get
    Set
Visual C++
public:
property bool Italic {
    bool get ();
    void set (bool value);
}
F#
member Italic : bool with get, set

Property Value

Type: Boolean

See Also

Formatting Class
Formatting Members


Formatting.Kerning Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Kerning Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Kerning"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<int> Kerning { get; set; }
Visual Basic
Public Property Kerning As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> Kerning {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
F#
member Kerning : Nullable<int> with get, set

Property Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

Formatting Class
Formatting Members


Formatting.Language Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Language Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Language"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public CultureInfo Language { get; set; }
Visual Basic
Public Property Language As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ Language {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}
F#
member Language : CultureInfo with get, set

Property Value

Type: CultureInfo

See Also

Formatting Class
Formatting Members


Formatting.Misc Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Misc Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Misc"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Misc Misc { get; set; }
Visual Basic
Public Property Misc As Misc
    Get
    Set
Visual C++
public:
property Misc Misc {
    Misc get ();
    void set (Misc value);
}
F#
member Misc : Misc with get, set

Property Value

Type: Misc

See Also

Formatting Class
Formatting Members


Formatting.PercentageScale Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..PercentageScale Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.PercentageScale"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<int> PercentageScale { get; set; }
Visual Basic
Public Property PercentageScale As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> PercentageScale {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
F#
member PercentageScale : Nullable<int> with get, set

Property Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

Formatting Class
Formatting Members


Formatting.Position Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Position Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Position"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<int> Position { get; set; }
Visual Basic
Public Property Position As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> Position {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
F#
member Position : Nullable<int> with get, set

Property Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

Formatting Class
Formatting Members


Formatting.Script Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Script Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Script"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Script Script { get; set; }
Visual Basic
Public Property Script As Script
    Get
    Set
Visual C++
public:
property Script Script {
    Script get ();
    void set (Script value);
}
F#
member Script : Script with get, set

Property Value

Type: Script

See Also

Formatting Class
Formatting Members


Formatting.Size Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Size Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Size"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<double> Size { get; set; }
Visual Basic
Public Property Size As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> Size {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
F#
member Size : Nullable<float> with get, set

Property Value

Type: Nullable <(Of <(<' Double >)>)>

See Also

Formatting Class
Formatting Members


Formatting.Spacing Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..Spacing Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.Spacing"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<double> Spacing { get; set; }
Visual Basic
Public Property Spacing As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> Spacing {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
F#
member Spacing : Nullable<float> with get, set

Property Value

Type: Nullable <(Of <(<' Double >)>)>

See Also

Formatting Class
Formatting Members


Formatting.StrikeThrough Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..StrikeThrough Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.StrikeThrough"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public StrikeThrough StrikeThrough { get; set; }
Visual Basic
Public Property StrikeThrough As StrikeThrough
    Get
    Set
Visual C++
public:
property StrikeThrough StrikeThrough {
    StrikeThrough get ();
    void set (StrikeThrough value);
}
F#
member StrikeThrough : StrikeThrough with get, set

Property Value

Type: StrikeThrough

See Also

Formatting Class
Formatting Members


Formatting.UnderlineColor Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..UnderlineColor Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.UnderlineColor"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<Color> UnderlineColor { get; set; }
Visual Basic
Public Property UnderlineColor As Nullable(Of Color)
    Get
    Set
Visual C++
public:
property Nullable<Color> UnderlineColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}
F#
member UnderlineColor : Nullable<Color> with get, set

Property Value

Type: Nullable <(Of <(<' Color >)>)>

See Also

Formatting Class
Formatting Members


Formatting.UnderlineStyle Property

[image]

DocX - A Sandcastle Documented Class Library
Formatting..::..UnderlineStyle Property
Formatting Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Formatting.UnderlineStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public UnderlineStyle UnderlineStyle { get; set; }
Visual Basic
Public Property UnderlineStyle As UnderlineStyle
    Get
    Set
Visual C++
public:
property UnderlineStyle UnderlineStyle {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}
F#
member UnderlineStyle : UnderlineStyle with get, set

Property Value

Type: UnderlineStyle

See Also

Formatting Class
Formatting Members


Grouping Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Grouping Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Grouping"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Grouping
Visual Basic
Public Enumeration Grouping
Visual C++
public enum class Grouping
F#
type Grouping

Members

Member name | Value | Description
PercentStacked | 0 |
Stacked | 1 |
Standard | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Header Class

[image]

DocX - A Sandcastle Documented Class Library
Header Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Header"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Header : Container
Visual Basic
Public Class Header
    Inherits Container
Visual C++
public ref class Header : public Container
F#
type Header =
    class
        inherit Container
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Header

See Also

Header Members


Header Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Header Members
Header Class Methods Fields Properties See Also Send Feedback

The Header type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | PageNumberParagraph |
Public field | ParentContainer | (Inherited from Container.)

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images |
Public property | Lists | (Inherited from Container.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Xml | (Inherited from DocXElement.)

See Also

Header Class


Header Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Header Fields
Header Class See Also Send Feedback

The Header type exposes the following members.

Fields

 | Name | Description
Public field | PageNumberParagraph |
Public field | ParentContainer | (Inherited from Container.)

See Also

Header Class


Header.PageNumberParagraph Field

[image]

DocX - A Sandcastle Documented Class Library
Header..::..PageNumberParagraph Field
Header Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Header.PageNumberParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph PageNumberParagraph
Visual Basic
Public PageNumberParagraph As Paragraph
Visual C++
public:
Paragraph^ PageNumberParagraph
F#
val mutable PageNumberParagraph: Paragraph

Field Value

Type: Paragraph

See Also

Header Class
Header Members


Header Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Header Methods
Header Class See Also Send Feedback

The Header type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Overrides Container..::..InsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Header Class


Header.InsertEquation Method

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertEquation Method
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertEquation(
    string equation
)
Visual Basic
Public Overrides Function InsertEquation (
    equation As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertEquation(
    String^ equation
) override
F#
abstract InsertEquation :
        equation : string -> Paragraph
override InsertEquation :
        equation : string -> Paragraph

Parameters

equation
Type: System..::..String

[Missing <param name="equation"/> documentation for "M:Novacode.Header.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertEquation(System.String)"]

See Also

Header Class
Header Members


Header.InsertParagraph Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method
Header Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraph()()()() | (Overrides Container..::..InsertParagraph()()()().)
Public method | InsertParagraph(String) | (Overrides Container..::..InsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides Container..::..InsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides Container..::..InsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides Container..::..InsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides Container..::..InsertParagraph(Int32, String, Boolean, Formatting).)

See Also

Header Class
Header Members


Header.InsertParagraph Method

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph()
Visual Basic
Public Overrides Function InsertParagraph As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph() override
F#
abstract InsertParagraph : unit -> Paragraph
override InsertParagraph : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (String)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text
) override
F#
abstract InsertParagraph :
        text : string -> Paragraph
override InsertParagraph :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.String)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (Paragraph)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
) override
F#
abstract InsertParagraph :
        p : Paragraph -> Paragraph
override InsertParagraph :
        p : Paragraph -> Paragraph

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Header.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(Novacode.Paragraph)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (Int32, Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (Int32, Paragraph)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
) override
F#
abstract InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph
override InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (String, Boolean)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
) override
F#
abstract InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (Int32, String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (Int32, String, Boolean)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
) override
F#
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (String, Boolean, Formatting)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
F#
abstract InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertParagraph Method (Int32, String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertParagraph Method (Int32, String, Boolean, Formatting)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
F#
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Header Class
Header Members
InsertParagraph Overload


Header.InsertTable Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertTable Method
Header Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |

See Also

Header Class
Header Members


Header.InsertTable Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertTable Method (Table)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertTable(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    Table t
)
Visual Basic
Public Function InsertTable (
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    Table^ t
)
F#
member InsertTable :
        t : Table -> Table

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Header.InsertTable(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Header.InsertTable(Novacode.Table)"]

See Also

Header Class
Header Members
InsertTable Overload


Header.InsertTable Method (Int32, Table)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertTable Method (Int32, Table)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertTable(System.Int32,Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    Table t
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    t As Table
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    Table^ t
)
F#
member InsertTable :
        index : int *
        t : Table -> Table

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,Novacode.Table)"]

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Header.InsertTable(System.Int32,Novacode.Table)"]

See Also

Header Class
Header Members
InsertTable Overload


Header.InsertTable Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertTable Method (Int32, Int32)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int rowCount,
    int columnCount
)
Visual Basic
Public Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ InsertTable(
    int rowCount,
    int columnCount
)
F#
member InsertTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32)"]

See Also

Header Class
Header Members
InsertTable Overload


Header.InsertTable Method (Int32, Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Header..::..InsertTable Method (Int32, Int32, Int32)
Header Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table InsertTable(
    int index,
    int rowCount,
    int columnCount
)
Visual Basic
Public Function InsertTable (
    index As Integer,
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
Table^ InsertTable(
    int index,
    int rowCount,
    int columnCount
)
F#
member InsertTable :
        index : int *
        rowCount : int *
        columnCount : int -> Table

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32,System.Int32)"]

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32,System.Int32)"]

See Also

Header Class
Header Members
InsertTable Overload


Header Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Header Properties
Header Class See Also Send Feedback

The Header type exposes the following members.

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images |
Public property | Lists | (Inherited from Container.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides Container..::..Tables.)
Public property | Xml | (Inherited from DocXElement.)

See Also

Header Class


Header.Images Property

[image]

DocX - A Sandcastle Documented Class Library
Header..::..Images Property
Header Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Header.Images"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Image> Images { get; }
Visual Basic
Public ReadOnly Property Images As List(Of Image)
    Get
Visual C++
public:
property List<Image^>^ Images {
    List<Image^>^ get ();
}
F#
member Images : List<Image> with get

Property Value

Type: List <(Of <(<' Image >)>)>

See Also

Header Class
Header Members


Header.PageNumbers Property

[image]

DocX - A Sandcastle Documented Class Library
Header..::..PageNumbers Property
Header Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Header.PageNumbers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool PageNumbers { get; set; }
Visual Basic
Public Property PageNumbers As Boolean
    Get
    Set
Visual C++
public:
property bool PageNumbers {
    bool get ();
    void set (bool value);
}
F#
member PageNumbers : bool with get, set

Property Value

Type: Boolean

See Also

Header Class
Header Members


Header.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Header..::..Paragraphs Property
Header Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Header.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override ReadOnlyCollection<Paragraph> Paragraphs { get; }
Visual Basic
Public Overrides ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
Visual C++
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get () override;
}
F#
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection <(Of <(<' Paragraph >)>)>

See Also

Header Class
Header Members


Header.Tables Property

[image]

DocX - A Sandcastle Documented Class Library
Header..::..Tables Property
Header Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Header.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override List<Table> Tables { get; }
Visual Basic
Public Overrides ReadOnly Property Tables As List(Of Table)
    Get
Visual C++
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get () override;
}
F#
abstract Tables : List<Table> with get
override Tables : List<Table> with get

Property Value

Type: List <(Of <(<' Table >)>)>

See Also

Header Class
Header Members


Headers Class

[image]

DocX - A Sandcastle Documented Class Library
Headers Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Headers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Headers
Visual Basic
Public Class Headers
Visual C++
public ref class Headers
F#
type Headers =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..Headers

See Also

Headers Members


Headers Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Headers Members
Headers Class Methods Fields See Also Send Feedback

The Headers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | even |
Public field | first |
Public field | odd |

See Also

Headers Class


Headers Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Headers Fields
Headers Class See Also Send Feedback

The Headers type exposes the following members.

Fields

 | Name | Description
Public field | even |
Public field | first |
Public field | odd |

See Also

Headers Class


Headers.even Field

[image]

DocX - A Sandcastle Documented Class Library
Headers..::..even Field
Headers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Headers.even"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Header even
Visual Basic
Public even As Header
Visual C++
public:
Header^ even
F#
val mutable even: Header

Field Value

Type: Header

See Also

Headers Class
Headers Members


Headers.first Field

[image]

DocX - A Sandcastle Documented Class Library
Headers..::..first Field
Headers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Headers.first"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Header first
Visual Basic
Public first As Header
Visual C++
public:
Header^ first
F#
val mutable first: Header

Field Value

Type: Header

See Also

Headers Class
Headers Members


Headers.odd Field

[image]

DocX - A Sandcastle Documented Class Library
Headers..::..odd Field
Headers Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Headers.odd"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Header odd
Visual Basic
Public odd As Header
Visual C++
public:
Header^ odd
F#
val mutable odd: Header

Field Value

Type: Header

See Also

Headers Class
Headers Members


Headers Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Headers Methods
Headers Class See Also Send Feedback

The Headers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Headers Class


Highlight Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Highlight Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Highlight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Highlight
Visual Basic
Public Enumeration Highlight
Visual C++
public enum class Highlight
F#
type Highlight

Members

Member name | Value | Description
yellow | 0 |
green | 1 |
cyan | 2 |
magenta | 3 |
blue | 4 |
red | 5 |
darkBlue | 6 |
darkCyan | 7 |
darkGreen | 8 |
darkMagenta | 9 |
darkRed | 10 |
darkYellow | 11 |
darkGray | 12 |
lightGray | 13 |
black | 14 |
none | 15 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Hyperlink Class

[image]

DocX - A Sandcastle Documented Class Library
Hyperlink Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Hyperlink"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Hyperlink : DocXElement
Visual Basic
Public Class Hyperlink
    Inherits DocXElement
Visual C++
public ref class Hyperlink : public DocXElement
F#
type Hyperlink =
    class
        inherit DocXElement
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Hyperlink

See Also

Hyperlink Members


Hyperlink Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Hyperlink Members
Hyperlink Class Methods Fields Properties See Also Send Feedback

The Hyperlink type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | mainPart |

Properties

 | Name | Description
Public property | Text |
Public property | Uri |
Public property | Xml | (Inherited from DocXElement.)

See Also

Hyperlink Class


Hyperlink Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Hyperlink Fields
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Fields

 | Name | Description
Public field | mainPart |

See Also

Hyperlink Class


Hyperlink.mainPart Field

[image]

DocX - A Sandcastle Documented Class Library
Hyperlink..::..mainPart Field
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Hyperlink.mainPart"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public PackagePart mainPart
Visual Basic
Public mainPart As PackagePart
Visual C++
public:
PackagePart^ mainPart
F#
val mutable mainPart: PackagePart

Field Value

Type: PackagePart

See Also

Hyperlink Class
Hyperlink Members


Hyperlink Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Hyperlink Methods
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Hyperlink Class


Hyperlink.Remove Method

[image]

DocX - A Sandcastle Documented Class Library
Hyperlink..::..Remove Method
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Hyperlink.Remove"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Remove()
Visual Basic
Public Sub Remove
Visual C++
public:
void Remove()
F#
member Remove : unit -> unit

See Also

Hyperlink Class
Hyperlink Members


Hyperlink Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Hyperlink Properties
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Properties

 | Name | Description
Public property | Text |
Public property | Uri |
Public property | Xml | (Inherited from DocXElement.)

See Also

Hyperlink Class


Hyperlink.Text Property

[image]

DocX - A Sandcastle Documented Class Library
Hyperlink..::..Text Property
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Hyperlink.Text"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
F#
member Text : string with get, set

Property Value

Type: String

See Also

Hyperlink Class
Hyperlink Members


Hyperlink.Uri Property

[image]

DocX - A Sandcastle Documented Class Library
Hyperlink..::..Uri Property
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Hyperlink.Uri"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Uri Uri { get; set; }
Visual Basic
Public Property Uri As Uri
    Get
    Set
Visual C++
public:
property Uri^ Uri {
    Uri^ get ();
    void set (Uri^ value);
}
F#
member Uri : Uri with get, set

Property Value

Type: Uri

See Also

Hyperlink Class
Hyperlink Members


Image Class

[image]

DocX - A Sandcastle Documented Class Library
Image Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Image"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Image
Visual Basic
Public Class Image
Visual C++
public ref class Image
F#
type Image =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..Image

See Also

Image Members


Image Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Image Members
Image Class Methods Properties See Also Send Feedback

The Image type exposes the following members.

Methods

 | Name | Description
Public method | CreatePicture()()()() |
Public method | CreatePicture(Int32, Int32) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FileName |
Public property | Id |

See Also

Image Class


Image Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Image Methods
Image Class See Also Send Feedback

The Image type exposes the following members.

Methods

 | Name | Description
Public method | CreatePicture()()()() |
Public method | CreatePicture(Int32, Int32) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Image Class


Image.CreatePicture Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Image..::..CreatePicture Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreatePicture()()()() |
Public method | CreatePicture(Int32, Int32) |

See Also

Image Class
Image Members


Image.CreatePicture Method

[image]

DocX - A Sandcastle Documented Class Library
Image..::..CreatePicture Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Image.CreatePicture"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Picture CreatePicture()
Visual Basic
Public Function CreatePicture As Picture
Visual C++
public:
Picture^ CreatePicture()
F#
member CreatePicture : unit -> Picture

Return Value

Type: Picture

[Missing <returns> documentation for "M:Novacode.Image.CreatePicture"]

See Also

Image Class
Image Members
CreatePicture Overload


Image.CreatePicture Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Image..::..CreatePicture Method (Int32, Int32)
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Picture CreatePicture(
    int height,
    int width
)
Visual Basic
Public Function CreatePicture (
    height As Integer,
    width As Integer
) As Picture
Visual C++
public:
Picture^ CreatePicture(
    int height,
    int width
)
F#
member CreatePicture :
        height : int *
        width : int -> Picture

Parameters

height
Type: System..::..Int32

[Missing <param name="height"/> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

Return Value

Type: Picture

[Missing <returns> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

See Also

Image Class
Image Members
CreatePicture Overload


Image.GetStream Method

[image]

DocX - A Sandcastle Documented Class Library
Image..::..GetStream Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Stream GetStream(
    FileMode mode,
    FileAccess access
)
Visual Basic
Public Function GetStream (
    mode As FileMode,
    access As FileAccess
) As Stream
Visual C++
public:
Stream^ GetStream(
    FileMode mode,
    FileAccess access
)
F#
member GetStream :
        mode : FileMode *
        access : FileAccess -> Stream

Parameters

mode
Type: System.IO..::..FileMode

[Missing <param name="mode"/> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

access
Type: System.IO..::..FileAccess

[Missing <param name="access"/> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

Return Value

Type: Stream

[Missing <returns> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

See Also

Image Class
Image Members


Image Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Image Properties
Image Class See Also Send Feedback

The Image type exposes the following members.

Properties

 | Name | Description
Public property | FileName |
Public property | Id |

See Also

Image Class


Image.FileName Property

[image]

DocX - A Sandcastle Documented Class Library
Image..::..FileName Property
Image Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Image.FileName"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get
Visual C++
public:
property String^ FileName {
    String^ get ();
}
F#
member FileName : string with get

Property Value

Type: String

See Also

Image Class
Image Members


Image.Id Property

[image]

DocX - A Sandcastle Documented Class Library
Image..::..Id Property
Image Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Image.Id"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}
F#
member Id : string with get

Property Value

Type: String

See Also

Image Class
Image Members


InsertBeforeOrAfter Class

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.InsertBeforeOrAfter"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public abstract class InsertBeforeOrAfter : DocXElement
Visual Basic
Public MustInherit Class InsertBeforeOrAfter
    Inherits DocXElement
Visual C++
public ref class InsertBeforeOrAfter abstract : public DocXElement
F#
[<AbstractClassAttribute>]
type InsertBeforeOrAfter =
    class
        inherit DocXElement
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..InsertBeforeOrAfter
Novacode..::..List
Novacode..::..Paragraph
Novacode..::..Table

See Also

InsertBeforeOrAfter Members


InsertBeforeOrAfter Members

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter Members
InsertBeforeOrAfter Class Constructors Methods Properties See Also Send Feedback

The InsertBeforeOrAfter type exposes the following members.

Constructors

 | Name | Description
Public method | InsertBeforeOrAfter | Initializes a new instance of the InsertBeforeOrAfter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf |
Public method | InsertPageBreakBeforeSelf |
Public method | InsertParagraphAfterSelf(String) |
Public method | InsertParagraphAfterSelf(Paragraph) |
Public method | InsertParagraphAfterSelf(String, Boolean) |
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) |
Public method | InsertParagraphBeforeSelf(String) |
Public method | InsertParagraphBeforeSelf(Paragraph) |
Public method | InsertParagraphBeforeSelf(String, Boolean) |
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) |
Public method | InsertTableAfterSelf(Table) |
Public method | InsertTableAfterSelf(Int32, Int32) |
Public method | InsertTableBeforeSelf(Table) |
Public method | InsertTableBeforeSelf(Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Xml | (Inherited from DocXElement.)

See Also

InsertBeforeOrAfter Class


InsertBeforeOrAfter Constructor

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter Constructor
InsertBeforeOrAfter Class See Also Send Feedback
Initializes a new instance of the InsertBeforeOrAfter class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public InsertBeforeOrAfter(
    DocX document,
    XElement xml
)
Visual Basic
Public Sub New (
    document As DocX,
    xml As XElement
)
Visual C++
public:
InsertBeforeOrAfter(
    DocX^ document,
    XElement^ xml
)
F#
new :
        document : DocX *
        xml : XElement -> InsertBeforeOrAfter

Parameters

document
Type: Novacode..::..DocX

[Missing <param name="document"/> documentation for "M:Novacode.InsertBeforeOrAfter.#ctor(Novacode.DocX,System.Xml.Linq.XElement)"]

xml
Type: System.Xml.Linq..::..XElement

[Missing <param name="xml"/> documentation for "M:Novacode.InsertBeforeOrAfter.#ctor(Novacode.DocX,System.Xml.Linq.XElement)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter Methods
InsertBeforeOrAfter Class See Also Send Feedback

The InsertBeforeOrAfter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf |
Public method | InsertPageBreakBeforeSelf |
Public method | InsertParagraphAfterSelf(String) |
Public method | InsertParagraphAfterSelf(Paragraph) |
Public method | InsertParagraphAfterSelf(String, Boolean) |
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) |
Public method | InsertParagraphBeforeSelf(String) |
Public method | InsertParagraphBeforeSelf(Paragraph) |
Public method | InsertParagraphBeforeSelf(String, Boolean) |
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) |
Public method | InsertTableAfterSelf(Table) |
Public method | InsertTableAfterSelf(Int32, Int32) |
Public method | InsertTableBeforeSelf(Table) |
Public method | InsertTableBeforeSelf(Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InsertBeforeOrAfter Class


InsertBeforeOrAfter.InsertPageBreakAfterSelf Method

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertPageBreakAfterSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertPageBreakAfterSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertPageBreakAfterSelf()
Visual Basic
Public Overridable Sub InsertPageBreakAfterSelf
Visual C++
public:
virtual void InsertPageBreakAfterSelf()
F#
abstract InsertPageBreakAfterSelf : unit -> unit
override InsertPageBreakAfterSelf : unit -> unit

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertPageBreakBeforeSelf Method

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertPageBreakBeforeSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertPageBreakBeforeSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual void InsertPageBreakBeforeSelf()
Visual Basic
Public Overridable Sub InsertPageBreakBeforeSelf
Visual C++
public:
virtual void InsertPageBreakBeforeSelf()
F#
abstract InsertPageBreakBeforeSelf : unit -> unit
override InsertPageBreakBeforeSelf : unit -> unit

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertParagraphAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphAfterSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphAfterSelf(String) |
Public method | InsertParagraphAfterSelf(Paragraph) |
Public method | InsertParagraphAfterSelf(String, Boolean) |
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) |

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphAfterSelf Method (String)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphAfterSelf(
    string text
)
Visual Basic
Public Overridable Function InsertParagraphAfterSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text
)
F#
abstract InsertParagraphAfterSelf :
        text : string -> Paragraph
override InsertParagraphAfterSelf :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphAfterSelf Method (Paragraph)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphAfterSelf(
    Paragraph p
)
Visual Basic
Public Overridable Function InsertParagraphAfterSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    Paragraph^ p
)
F#
abstract InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph
override InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(Novacode.Paragraph)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphAfterSelf Method (String, Boolean)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overridable Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges
)
F#
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphAfterSelf Method (String, Boolean, Formatting)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overridable Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)
F#
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphBeforeSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphBeforeSelf(String) |
Public method | InsertParagraphBeforeSelf(Paragraph) |
Public method | InsertParagraphBeforeSelf(String, Boolean) |
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) |

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphBeforeSelf Method (String)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphBeforeSelf(
    string text
)
Visual Basic
Public Overridable Function InsertParagraphBeforeSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text
)
F#
abstract InsertParagraphBeforeSelf :
        text : string -> Paragraph
override InsertParagraphBeforeSelf :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphBeforeSelf Method (Paragraph)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphBeforeSelf(
    Paragraph p
)
Visual Basic
Public Overridable Function InsertParagraphBeforeSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    Paragraph^ p
)
F#
abstract InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph
override InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphBeforeSelf Method (String, Boolean)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overridable Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges
)
F#
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertParagraphBeforeSelf Method (String, Boolean, Formatting)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overridable Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)
F#
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertTableAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableAfterSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableAfterSelf(Table) |
Public method | InsertTableAfterSelf(Int32, Int32) |

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertTableAfterSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableAfterSelf Method (Table)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Table InsertTableAfterSelf(
    Table t
)
Visual Basic
Public Overridable Function InsertTableAfterSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    Table^ t
)
F#
abstract InsertTableAfterSelf :
        t : Table -> Table
override InsertTableAfterSelf :
        t : Table -> Table

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(Novacode.Table)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertTableAfterSelf Overload


InsertBeforeOrAfter.InsertTableAfterSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableAfterSelf Method (Int32, Int32)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Table InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overridable Function InsertTableAfterSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
F#
abstract InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertTableAfterSelf Overload


InsertBeforeOrAfter.InsertTableBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableBeforeSelf Method
InsertBeforeOrAfter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableBeforeSelf(Table) |
Public method | InsertTableBeforeSelf(Int32, Int32) |

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members


InsertBeforeOrAfter.InsertTableBeforeSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableBeforeSelf Method (Table)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Table InsertTableBeforeSelf(
    Table t
)
Visual Basic
Public Overridable Function InsertTableBeforeSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    Table^ t
)
F#
abstract InsertTableBeforeSelf :
        t : Table -> Table
override InsertTableBeforeSelf :
        t : Table -> Table

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(Novacode.Table)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertTableBeforeSelf Overload


InsertBeforeOrAfter.InsertTableBeforeSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter..::..InsertTableBeforeSelf Method (Int32, Int32)
InsertBeforeOrAfter Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual Table InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overridable Function InsertTableBeforeSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
F#
abstract InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

See Also

InsertBeforeOrAfter Class
InsertBeforeOrAfter Members
InsertTableBeforeSelf Overload


InsertBeforeOrAfter Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
InsertBeforeOrAfter Properties
InsertBeforeOrAfter Class See Also Send Feedback

The InsertBeforeOrAfter type exposes the following members.

Properties

 | Name | Description
Public property | Xml | (Inherited from DocXElement.)

See Also

InsertBeforeOrAfter Class


LineChart Class

[image]

DocX - A Sandcastle Documented Class Library
LineChart Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.LineChart"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class LineChart : Chart
Visual Basic
Public Class LineChart
    Inherits Chart
Visual C++
public ref class LineChart : public Chart
F#
type LineChart =
    class
        inherit Chart
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..Chart
Novacode..::..LineChart

See Also

LineChart Members


LineChart Members

[image] [image]

DocX - A Sandcastle Documented Class Library
LineChart Members
LineChart Class Constructors Methods Properties See Also Send Feedback

The LineChart type exposes the following members.

Constructors

 | Name | Description
Public method | LineChart | Initializes a new instance of the LineChart class

Methods

 | Name | Description
Public method | AddLegend()()()() | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | Grouping |
Public property | IsAxisExist | (Inherited from Chart.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Inherited from Chart.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)

See Also

LineChart Class


LineChart Constructor

[image]

DocX - A Sandcastle Documented Class Library
LineChart Constructor
LineChart Class See Also Send Feedback
Initializes a new instance of the LineChart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public LineChart()
Visual Basic
Public Sub New
Visual C++
public:
LineChart()
F#
new : unit -> LineChart

See Also

LineChart Class
LineChart Members


LineChart Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
LineChart Methods
LineChart Class See Also Send Feedback

The LineChart type exposes the following members.

Methods

 | Name | Description
Public method | AddLegend()()()() | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LineChart Class


LineChart.CreateChartXml Method

[image]

DocX - A Sandcastle Documented Class Library
LineChart..::..CreateChartXml Method
LineChart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.LineChart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected override XElement CreateChartXml()
Visual Basic
Protected Overrides Function CreateChartXml As XElement
Visual C++
protected:
virtual XElement^ CreateChartXml() override
F#
abstract CreateChartXml : unit -> XElement
override CreateChartXml : unit -> XElement

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.LineChart.CreateChartXml"]

See Also

LineChart Class
LineChart Members


LineChart Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
LineChart Properties
LineChart Class See Also Send Feedback

The LineChart type exposes the following members.

Properties

 | Name | Description
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | Grouping |
Public property | IsAxisExist | (Inherited from Chart.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Inherited from Chart.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)

See Also

LineChart Class


LineChart.Grouping Property

[image]

DocX - A Sandcastle Documented Class Library
LineChart..::..Grouping Property
LineChart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.LineChart.Grouping"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Grouping Grouping { get; set; }
Visual Basic
Public Property Grouping As Grouping
    Get
    Set
Visual C++
public:
property Grouping Grouping {
    Grouping get ();
    void set (Grouping value);
}
F#
member Grouping : Grouping with get, set

Property Value

Type: Grouping

See Also

LineChart Class
LineChart Members


LineSpacingType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
LineSpacingType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.LineSpacingType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum LineSpacingType
Visual Basic
Public Enumeration LineSpacingType
Visual C++
public enum class LineSpacingType
F#
type LineSpacingType

Members

Member name | Value | Description
Line | 0 |
Before | 1 |
After | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


LineSpacingTypeAuto Enumeration

[image]

DocX - A Sandcastle Documented Class Library
LineSpacingTypeAuto Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.LineSpacingTypeAuto"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum LineSpacingTypeAuto
Visual Basic
Public Enumeration LineSpacingTypeAuto
Visual C++
public enum class LineSpacingTypeAuto
F#
type LineSpacingTypeAuto

Members

Member name | Value | Description
AutoBefore | 0 |
AutoAfter | 1 |
Auto | 2 |
None | 3 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


List Class

[image]

DocX - A Sandcastle Documented Class Library
List Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.List"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class List : InsertBeforeOrAfter
Visual Basic
Public Class List
    Inherits InsertBeforeOrAfter
Visual C++
public ref class List : public InsertBeforeOrAfter
F#
type List =
    class
        inherit InsertBeforeOrAfter
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..InsertBeforeOrAfter
Novacode..::..List

See Also

List Members


List Members

[image] [image]

DocX - A Sandcastle Documented Class Library
List Members
List Class Methods Properties See Also Send Feedback

The List type exposes the following members.

Methods

 | Name | Description
Public method | AddItem |
Public method | AddItemWithStartValue |
Public method | CanAddListItem |
Public method | ContainsLevel |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertPageBreakBeforeSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Items |
Public property | ListType |
Public property | NumId |
Public property | Xml | (Inherited from DocXElement.)

See Also

List Class


List Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
List Methods
List Class See Also Send Feedback

The List type exposes the following members.

Methods

 | Name | Description
Public method | AddItem |
Public method | AddItemWithStartValue |
Public method | CanAddListItem |
Public method | ContainsLevel |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertPageBreakBeforeSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

List Class


List.AddItem Method

[image]

DocX - A Sandcastle Documented Class Library
List..::..AddItem Method
List Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.List.AddItem(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddItem(
    Paragraph paragraph
)
Visual Basic
Public Sub AddItem (
    paragraph As Paragraph
)
Visual C++
public:
void AddItem(
    Paragraph^ paragraph
)
F#
member AddItem :
        paragraph : Paragraph -> unit

Parameters

paragraph
Type: Novacode..::..Paragraph

[Missing <param name="paragraph"/> documentation for "M:Novacode.List.AddItem(Novacode.Paragraph)"]

See Also

List Class
List Members


List.AddItemWithStartValue Method

[image]

DocX - A Sandcastle Documented Class Library
List..::..AddItemWithStartValue Method
List Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.List.AddItemWithStartValue(Novacode.Paragraph,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AddItemWithStartValue(
    Paragraph paragraph,
    int start
)
Visual Basic
Public Sub AddItemWithStartValue (
    paragraph As Paragraph,
    start As Integer
)
Visual C++
public:
void AddItemWithStartValue(
    Paragraph^ paragraph,
    int start
)
F#
member AddItemWithStartValue :
        paragraph : Paragraph *
        start : int -> unit

Parameters

paragraph
Type: Novacode..::..Paragraph

[Missing <param name="paragraph"/> documentation for "M:Novacode.List.AddItemWithStartValue(Novacode.Paragraph,System.Int32)"]

start
Type: System..::..Int32

[Missing <param name="start"/> documentation for "M:Novacode.List.AddItemWithStartValue(Novacode.Paragraph,System.Int32)"]

See Also

List Class
List Members


List.CanAddListItem Method

[image]

DocX - A Sandcastle Documented Class Library
List..::..CanAddListItem Method
List Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.List.CanAddListItem(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool CanAddListItem(
    Paragraph paragraph
)
Visual Basic
Public Function CanAddListItem (
    paragraph As Paragraph
) As Boolean
Visual C++
public:
bool CanAddListItem(
    Paragraph^ paragraph
)
F#
member CanAddListItem :
        paragraph : Paragraph -> bool

Parameters

paragraph
Type: Novacode..::..Paragraph

[Missing <param name="paragraph"/> documentation for "M:Novacode.List.CanAddListItem(Novacode.Paragraph)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.List.CanAddListItem(Novacode.Paragraph)"]

See Also

List Class
List Members


List.ContainsLevel Method

[image]

DocX - A Sandcastle Documented Class Library
List..::..ContainsLevel Method
List Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.List.ContainsLevel(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool ContainsLevel(
    int ilvl
)
Visual Basic
Public Function ContainsLevel (
    ilvl As Integer
) As Boolean
Visual C++
public:
bool ContainsLevel(
    int ilvl
)
F#
member ContainsLevel :
        ilvl : int -> bool

Parameters

ilvl
Type: System..::..Int32

[Missing <param name="ilvl"/> documentation for "M:Novacode.List.ContainsLevel(System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.List.ContainsLevel(System.Int32)"]

See Also

List Class
List Members


List Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
List Properties
List Class See Also Send Feedback

The List type exposes the following members.

Properties

 | Name | Description
Public property | Items |
Public property | ListType |
Public property | NumId |
Public property | Xml | (Inherited from DocXElement.)

See Also

List Class


List.Items Property

[image]

DocX - A Sandcastle Documented Class Library
List..::..Items Property
List Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.List.Items"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Paragraph> Items { get; }
Visual Basic
Public ReadOnly Property Items As List(Of Paragraph)
    Get
Visual C++
public:
property List<Paragraph^>^ Items {
    List<Paragraph^>^ get ();
}
F#
member Items : List<Paragraph> with get

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

List Class
List Members


List.ListType Property

[image]

DocX - A Sandcastle Documented Class Library
List..::..ListType Property
List Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.List.ListType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<ListItemType> ListType { get; }
Visual Basic
Public ReadOnly Property ListType As Nullable(Of ListItemType)
    Get
Visual C++
public:
property Nullable<ListItemType> ListType {
    Nullable<ListItemType> get ();
}
F#
member ListType : Nullable<ListItemType> with get

Property Value

Type: Nullable <(Of <(<' ListItemType >)>)>

See Also

List Class
List Members


List.NumId Property

[image]

DocX - A Sandcastle Documented Class Library
List..::..NumId Property
List Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.List.NumId"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int NumId { get; }
Visual Basic
Public ReadOnly Property NumId As Integer
    Get
Visual C++
public:
property int NumId {
    int get ();
}
F#
member NumId : int with get

Property Value

Type: Int32

See Also

List Class
List Members


ListItemType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
ListItemType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.ListItemType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum ListItemType
Visual Basic
Public Enumeration ListItemType
Visual C++
public enum class ListItemType
F#
type ListItemType

Members

Member name | Value | Description
Bulleted | 0 |
Numbered | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


MatchFormattingOptions Enumeration

[image]

DocX - A Sandcastle Documented Class Library
MatchFormattingOptions Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.MatchFormattingOptions"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum MatchFormattingOptions
Visual Basic
Public Enumeration MatchFormattingOptions
Visual C++
public enum class MatchFormattingOptions
F#
type MatchFormattingOptions

Members

Member name | Value | Description
ExactMatch | 0 |
SubsetMatch | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Misc Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Misc Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Misc"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Misc
Visual Basic
Public Enumeration Misc
Visual C++
public enum class Misc
F#
type Misc

Members

Member name | Value | Description
none | 0 |
shadow | 1 |
outline | 2 |
outlineShadow | 3 |
emboss | 4 |
engrave | 5 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Orientation Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Orientation Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Orientation"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Orientation
Visual Basic
Public Enumeration Orientation
Visual C++
public enum class Orientation
F#
type Orientation

Members

Member name | Value | Description
Portrait | 0 |
Landscape | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


PageLayout Class

[image]

DocX - A Sandcastle Documented Class Library
PageLayout Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.PageLayout"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class PageLayout : DocXElement
Visual Basic
Public Class PageLayout
    Inherits DocXElement
Visual C++
public ref class PageLayout : public DocXElement
F#
type PageLayout =
    class
        inherit DocXElement
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..PageLayout

See Also

PageLayout Members


PageLayout Members

[image] [image]

DocX - A Sandcastle Documented Class Library
PageLayout Members
PageLayout Class Methods Properties See Also Send Feedback

The PageLayout type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Orientation |
Public property | Xml | (Inherited from DocXElement.)

See Also

PageLayout Class


PageLayout Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
PageLayout Methods
PageLayout Class See Also Send Feedback

The PageLayout type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PageLayout Class


PageLayout Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
PageLayout Properties
PageLayout Class See Also Send Feedback

The PageLayout type exposes the following members.

Properties

 | Name | Description
Public property | Orientation |
Public property | Xml | (Inherited from DocXElement.)

See Also

PageLayout Class


PageLayout.Orientation Property

[image]

DocX - A Sandcastle Documented Class Library
PageLayout..::..Orientation Property
PageLayout Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.PageLayout.Orientation"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}
F#
member Orientation : Orientation with get, set

Property Value

Type: Orientation

See Also

PageLayout Class
PageLayout Members


PageNumberFormat Enumeration

[image]

DocX - A Sandcastle Documented Class Library
PageNumberFormat Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.PageNumberFormat"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum PageNumberFormat
Visual Basic
Public Enumeration PageNumberFormat
Visual C++
public enum class PageNumberFormat
F#
type PageNumberFormat

Members

Member name | Value | Description
normal | 0 |
roman | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Paragraph Class

[image]

DocX - A Sandcastle Documented Class Library
Paragraph Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Paragraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Paragraph : InsertBeforeOrAfter
Visual Basic
Public Class Paragraph
    Inherits InsertBeforeOrAfter
Visual C++
public ref class Paragraph : public InsertBeforeOrAfter
F#
type Paragraph =
    class
        inherit InsertBeforeOrAfter
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..InsertBeforeOrAfter
Novacode..::..Paragraph

See Also

Paragraph Members


Paragraph Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph Members
Paragraph Class Methods Fields Properties See Also Send Feedback

The Paragraph type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | AppendBookmark |
Public method | AppendDocProperty |
Public method | AppendEquation |
Public method | AppendHyperlink |
Public method | AppendLine()()()() |
Public method | AppendLine(String) |
Public method | AppendPageCount |
Public method | AppendPageNumber |
Public method | AppendPicture |
Public method | Bold |
Public method | CapsStyle |
Public method | Color |
Public method | Culture |
Public method | CurentCulture |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Public method | FindAllByPattern |
Public method | Font |
Public method | FontSize |
Public method | GetBookmarks |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide |
Public method | Highlight |
Public method | InsertAtBookmark |
Public method | InsertDocProperty |
Public method | InsertHyperlink(Int32, Hyperlink) | Obsolete.
Public method | InsertHyperlink(Hyperlink, Int32) |
Public method | InsertPageBreakAfterSelf | (Overrides InsertBeforeOrAfter..::..InsertPageBreakAfterSelf()()()().)
Public method | InsertPageBreakBeforeSelf | (Overrides InsertBeforeOrAfter..::..InsertPageBreakBeforeSelf()()()().)
Public method | InsertPageCount |
Public method | InsertPageNumber |
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertPicture |
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)
Public method | InsertText(String, Boolean, Formatting) |
Public method | InsertText(Int32, String, Boolean, Formatting) |
Public method | Italic |
Public method | Kerning |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Misc |
Public method | PercentageScale |
Public method | Position |
Public method | Remove |
Public method | RemoveHyperlink |
Public method | RemoveText(Int32, Boolean) |
Public method | RemoveText(Int32, Int32, Boolean) |
Public method | ReplaceText |
Public method | Script |
Public method | SetLineSpacing(LineSpacingTypeAuto) |
Public method | SetLineSpacing(LineSpacingType, Single) |
Public method | Spacing |
Public method | SpacingAfter |
Public method | SpacingBefore |
Public method | StrikeThrough |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnderlineColor |
Public method | UnderlineStyle |

Fields

 | Name | Description
Public field | ListItemType |
Public field | ParentContainer |

Properties

 | Name | Description
Public property | Alignment |
Public property | Direction |
Public property | DocumentProperties |
Public property | FollowingTable |
Public property | Hyperlinks |
Public property | IndentationAfter |
Public property | IndentationBefore |
Public property | IndentationFirstLine |
Public property | IndentationHanging |
Public property | IndentLevel |
Public property | IsListItem |
Public property | LineSpacing |
Public property | LineSpacingAfter |
Public property | LineSpacingBefore |
Public property | MagicText |
Public property | PackagePart |
Public property | ParagraphNumberProperties |
Public property | Pictures |
Public property | StyleName |
Public property | Text |
Public property | Xml | (Inherited from DocXElement.)

See Also

Paragraph Class


Paragraph Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph Fields
Paragraph Class See Also Send Feedback

The Paragraph type exposes the following members.

Fields

 | Name | Description
Public field | ListItemType |
Public field | ParentContainer |

See Also

Paragraph Class


Paragraph.ListItemType Field

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..ListItemType Field
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Paragraph.ListItemType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ListItemType ListItemType
Visual Basic
Public ListItemType As ListItemType
Visual C++
public:
ListItemType ListItemType
F#
val mutable ListItemType: ListItemType

Field Value

Type: ListItemType

See Also

Paragraph Class
Paragraph Members


Paragraph.ParentContainer Field

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..ParentContainer Field
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Paragraph.ParentContainer"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ContainerType ParentContainer
Visual Basic
Public ParentContainer As ContainerType
Visual C++
public:
ContainerType ParentContainer
F#
val mutable ParentContainer: ContainerType

Field Value

Type: ContainerType

See Also

Paragraph Class
Paragraph Members


Paragraph Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph Methods
Paragraph Class See Also Send Feedback

The Paragraph type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | AppendBookmark |
Public method | AppendDocProperty |
Public method | AppendEquation |
Public method | AppendHyperlink |
Public method | AppendLine()()()() |
Public method | AppendLine(String) |
Public method | AppendPageCount |
Public method | AppendPageNumber |
Public method | AppendPicture |
Public method | Bold |
Public method | CapsStyle |
Public method | Color |
Public method | Culture |
Public method | CurentCulture |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Public method | FindAllByPattern |
Public method | Font |
Public method | FontSize |
Public method | GetBookmarks |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide |
Public method | Highlight |
Public method | InsertAtBookmark |
Public method | InsertDocProperty |
Public method | InsertHyperlink(Int32, Hyperlink) | Obsolete.
Public method | InsertHyperlink(Hyperlink, Int32) |
Public method | InsertPageBreakAfterSelf | (Overrides InsertBeforeOrAfter..::..InsertPageBreakAfterSelf()()()().)
Public method | InsertPageBreakBeforeSelf | (Overrides InsertBeforeOrAfter..::..InsertPageBreakBeforeSelf()()()().)
Public method | InsertPageCount |
Public method | InsertPageNumber |
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertPicture |
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)
Public method | InsertText(String, Boolean, Formatting) |
Public method | InsertText(Int32, String, Boolean, Formatting) |
Public method | Italic |
Public method | Kerning |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Misc |
Public method | PercentageScale |
Public method | Position |
Public method | Remove |
Public method | RemoveHyperlink |
Public method | RemoveText(Int32, Boolean) |
Public method | RemoveText(Int32, Int32, Boolean) |
Public method | ReplaceText |
Public method | Script |
Public method | SetLineSpacing(LineSpacingTypeAuto) |
Public method | SetLineSpacing(LineSpacingType, Single) |
Public method | Spacing |
Public method | SpacingAfter |
Public method | SpacingBefore |
Public method | StrikeThrough |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnderlineColor |
Public method | UnderlineStyle |

See Also

Paragraph Class


Paragraph.Append Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Append Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Append(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Append(
    string text
)
Visual Basic
Public Function Append (
    text As String
) As Paragraph
Visual C++
public:
Paragraph^ Append(
    String^ text
)
F#
member Append :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.Append(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Append(System.String)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendBookmark Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendBookmark Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendBookmark(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendBookmark(
    string bookmarkName
)
Visual Basic
Public Function AppendBookmark (
    bookmarkName As String
) As Paragraph
Visual C++
public:
Paragraph^ AppendBookmark(
    String^ bookmarkName
)
F#
member AppendBookmark :
        bookmarkName : string -> Paragraph

Parameters

bookmarkName
Type: System..::..String

[Missing <param name="bookmarkName"/> documentation for "M:Novacode.Paragraph.AppendBookmark(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendBookmark(System.String)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendDocProperty Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendDocProperty Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendDocProperty(
    CustomProperty cp,
    bool trackChanges = false,
    Formatting f = null
)
Visual Basic
Public Function AppendDocProperty (
    cp As CustomProperty,
    Optional trackChanges As Boolean = false,
    Optional f As Formatting = Nothing
) As Paragraph
Visual C++
public:
Paragraph^ AppendDocProperty(
    CustomProperty^ cp,
    bool trackChanges = false,
    Formatting^ f = nullptr
)
F#
member AppendDocProperty :
        cp : CustomProperty *
        ?trackChanges : bool *
        ?f : Formatting
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _f = defaultArg f null
*)
-> Paragraph

Parameters

cp
Type: Novacode..::..CustomProperty

[Missing <param name="cp"/> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

f (Optional)
Type: Novacode..::..Formatting

[Missing <param name="f"/> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendEquation Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendEquation Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendEquation(
    string equation
)
Visual Basic
Public Function AppendEquation (
    equation As String
) As Paragraph
Visual C++
public:
Paragraph^ AppendEquation(
    String^ equation
)
F#
member AppendEquation :
        equation : string -> Paragraph

Parameters

equation
Type: System..::..String

[Missing <param name="equation"/> documentation for "M:Novacode.Paragraph.AppendEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendEquation(System.String)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendHyperlink Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendHyperlink Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendHyperlink(Novacode.Hyperlink)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendHyperlink(
    Hyperlink h
)
Visual Basic
Public Function AppendHyperlink (
    h As Hyperlink
) As Paragraph
Visual C++
public:
Paragraph^ AppendHyperlink(
    Hyperlink^ h
)
F#
member AppendHyperlink :
        h : Hyperlink -> Paragraph

Parameters

h
Type: Novacode..::..Hyperlink

[Missing <param name="h"/> documentation for "M:Novacode.Paragraph.AppendHyperlink(Novacode.Hyperlink)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendHyperlink(Novacode.Hyperlink)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendLine Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendLine Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AppendLine()()()() |
Public method | AppendLine(String) |

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendLine Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendLine Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendLine"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendLine()
Visual Basic
Public Function AppendLine As Paragraph
Visual C++
public:
Paragraph^ AppendLine()
F#
member AppendLine : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendLine"]

See Also

Paragraph Class
Paragraph Members
AppendLine Overload


Paragraph.AppendLine Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendLine Method (String)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendLine(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendLine(
    string text
)
Visual Basic
Public Function AppendLine (
    text As String
) As Paragraph
Visual C++
public:
Paragraph^ AppendLine(
    String^ text
)
F#
member AppendLine :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.AppendLine(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendLine(System.String)"]

See Also

Paragraph Class
Paragraph Members
AppendLine Overload


Paragraph.AppendPageCount Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendPageCount Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendPageCount(Novacode.PageNumberFormat)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AppendPageCount(
    PageNumberFormat pnf
)
Visual Basic
Public Sub AppendPageCount (
    pnf As PageNumberFormat
)
Visual C++
public:
void AppendPageCount(
    PageNumberFormat pnf
)
F#
member AppendPageCount :
        pnf : PageNumberFormat -> unit

Parameters

pnf
Type: Novacode..::..PageNumberFormat

[Missing <param name="pnf"/> documentation for "M:Novacode.Paragraph.AppendPageCount(Novacode.PageNumberFormat)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendPageNumber Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendPageNumber Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendPageNumber(Novacode.PageNumberFormat)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void AppendPageNumber(
    PageNumberFormat pnf
)
Visual Basic
Public Sub AppendPageNumber (
    pnf As PageNumberFormat
)
Visual C++
public:
void AppendPageNumber(
    PageNumberFormat pnf
)
F#
member AppendPageNumber :
        pnf : PageNumberFormat -> unit

Parameters

pnf
Type: Novacode..::..PageNumberFormat

[Missing <param name="pnf"/> documentation for "M:Novacode.Paragraph.AppendPageNumber(Novacode.PageNumberFormat)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.AppendPicture Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..AppendPicture Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendPicture(Novacode.Picture)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph AppendPicture(
    Picture p
)
Visual Basic
Public Function AppendPicture (
    p As Picture
) As Paragraph
Visual C++
public:
Paragraph^ AppendPicture(
    Picture^ p
)
F#
member AppendPicture :
        p : Picture -> Paragraph

Parameters

p
Type: Novacode..::..Picture

[Missing <param name="p"/> documentation for "M:Novacode.Paragraph.AppendPicture(Novacode.Picture)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendPicture(Novacode.Picture)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Bold Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Bold Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Bold"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Bold()
Visual Basic
Public Function Bold As Paragraph
Visual C++
public:
Paragraph^ Bold()
F#
member Bold : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Bold"]

See Also

Paragraph Class
Paragraph Members


Paragraph.CapsStyle Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..CapsStyle Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.CapsStyle(Novacode.CapsStyle)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph CapsStyle(
    CapsStyle capsStyle
)
Visual Basic
Public Function CapsStyle (
    capsStyle As CapsStyle
) As Paragraph
Visual C++
public:
Paragraph^ CapsStyle(
    CapsStyle capsStyle
)
F#
member CapsStyle :
        capsStyle : CapsStyle -> Paragraph

Parameters

capsStyle
Type: Novacode..::..CapsStyle

[Missing <param name="capsStyle"/> documentation for "M:Novacode.Paragraph.CapsStyle(Novacode.CapsStyle)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.CapsStyle(Novacode.CapsStyle)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Color Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Color Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Color(System.Drawing.Color)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Color(
    Color c
)
Visual Basic
Public Function Color (
    c As Color
) As Paragraph
Visual C++
public:
Paragraph^ Color(
    Color c
)
F#
member Color :
        c : Color -> Paragraph

Parameters

c
Type: System.Drawing..::..Color

[Missing <param name="c"/> documentation for "M:Novacode.Paragraph.Color(System.Drawing.Color)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Color(System.Drawing.Color)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Culture Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Culture Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Culture(System.Globalization.CultureInfo)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Culture(
    CultureInfo culture
)
Visual Basic
Public Function Culture (
    culture As CultureInfo
) As Paragraph
Visual C++
public:
Paragraph^ Culture(
    CultureInfo^ culture
)
F#
member Culture :
        culture : CultureInfo -> Paragraph

Parameters

culture
Type: System.Globalization..::..CultureInfo

[Missing <param name="culture"/> documentation for "M:Novacode.Paragraph.Culture(System.Globalization.CultureInfo)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Culture(System.Globalization.CultureInfo)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.CurentCulture Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..CurentCulture Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.CurentCulture"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph CurentCulture()
Visual Basic
Public Function CurentCulture As Paragraph
Visual C++
public:
Paragraph^ CurentCulture()
F#
member CurentCulture : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.CurentCulture"]

See Also

Paragraph Class
Paragraph Members


Paragraph.FindAll Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FindAll Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |

See Also

Paragraph Class
Paragraph Members


Paragraph.FindAll Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FindAll Method (String)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.FindAll(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<int> FindAll(
    string str
)
Visual Basic
Public Function FindAll (
    str As String
) As List(Of Integer)
Visual C++
public:
List<int>^ FindAll(
    String^ str
)
F#
member FindAll :
        str : string -> List<int>

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Novacode.Paragraph.FindAll(System.String)"]

Return Value

Type: List <(Of <(<' Int32 >)>)>

[Missing <returns> documentation for "M:Novacode.Paragraph.FindAll(System.String)"]

See Also

Paragraph Class
Paragraph Members
FindAll Overload


Paragraph.FindAll Method (String, RegexOptions)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FindAll Method (String, RegexOptions)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<int> FindAll(
    string str,
    RegexOptions options
)
Visual Basic
Public Function FindAll (
    str As String,
    options As RegexOptions
) As List(Of Integer)
Visual C++
public:
List<int>^ FindAll(
    String^ str,
    RegexOptions options
)
F#
member FindAll :
        str : string *
        options : RegexOptions -> List<int>

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Novacode.Paragraph.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressions..::..RegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Paragraph.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List <(Of <(<' Int32 >)>)>

[Missing <returns> documentation for "M:Novacode.Paragraph.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Paragraph Class
Paragraph Members
FindAll Overload


Paragraph.FindAllByPattern Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FindAllByPattern Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<string> FindAllByPattern(
    string str,
    RegexOptions options
)
Visual Basic
Public Function FindAllByPattern (
    str As String,
    options As RegexOptions
) As List(Of String)
Visual C++
public:
List<String^>^ FindAllByPattern(
    String^ str,
    RegexOptions options
)
F#
member FindAllByPattern :
        str : string *
        options : RegexOptions -> List<string>

Parameters

str
Type: System..::..String

[Missing <param name="str"/> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressions..::..RegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List <(Of <(<' String >)>)>

[Missing <returns> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Font Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Font Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Font(System.Drawing.FontFamily)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Font(
    FontFamily fontFamily
)
Visual Basic
Public Function Font (
    fontFamily As FontFamily
) As Paragraph
Visual C++
public:
Paragraph^ Font(
    FontFamily^ fontFamily
)
F#
member Font :
        fontFamily : FontFamily -> Paragraph

Parameters

fontFamily
Type: System.Drawing..::..FontFamily

[Missing <param name="fontFamily"/> documentation for "M:Novacode.Paragraph.Font(System.Drawing.FontFamily)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Font(System.Drawing.FontFamily)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.FontSize Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FontSize Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.FontSize(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph FontSize(
    double fontSize
)
Visual Basic
Public Function FontSize (
    fontSize As Double
) As Paragraph
Visual C++
public:
Paragraph^ FontSize(
    double fontSize
)
F#
member FontSize :
        fontSize : float -> Paragraph

Parameters

fontSize
Type: System..::..Double

[Missing <param name="fontSize"/> documentation for "M:Novacode.Paragraph.FontSize(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.FontSize(System.Double)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.GetBookmarks Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..GetBookmarks Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.GetBookmarks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public IEnumerable<Bookmark> GetBookmarks()
Visual Basic
Public Function GetBookmarks As IEnumerable(Of Bookmark)
Visual C++
public:
IEnumerable<Bookmark^>^ GetBookmarks()
F#
member GetBookmarks : unit -> IEnumerable<Bookmark>

Return Value

Type: IEnumerable <(Of <(<' Bookmark >)>)>

[Missing <returns> documentation for "M:Novacode.Paragraph.GetBookmarks"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Hide Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Hide Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Hide"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Hide()
Visual Basic
Public Function Hide As Paragraph
Visual C++
public:
Paragraph^ Hide()
F#
member Hide : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Hide"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Highlight Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Highlight Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Highlight(Novacode.Highlight)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Highlight(
    Highlight highlight
)
Visual Basic
Public Function Highlight (
    highlight As Highlight
) As Paragraph
Visual C++
public:
Paragraph^ Highlight(
    Highlight highlight
)
F#
member Highlight :
        highlight : Highlight -> Paragraph

Parameters

highlight
Type: Novacode..::..Highlight

[Missing <param name="highlight"/> documentation for "M:Novacode.Paragraph.Highlight(Novacode.Highlight)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Highlight(Novacode.Highlight)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertAtBookmark Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertAtBookmark Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertAtBookmark(System.String,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertAtBookmark(
    string toInsert,
    string bookmarkName
)
Visual Basic
Public Sub InsertAtBookmark (
    toInsert As String,
    bookmarkName As String
)
Visual C++
public:
void InsertAtBookmark(
    String^ toInsert,
    String^ bookmarkName
)
F#
member InsertAtBookmark :
        toInsert : string *
        bookmarkName : string -> unit

Parameters

toInsert
Type: System..::..String

[Missing <param name="toInsert"/> documentation for "M:Novacode.Paragraph.InsertAtBookmark(System.String,System.String)"]

bookmarkName
Type: System..::..String

[Missing <param name="bookmarkName"/> documentation for "M:Novacode.Paragraph.InsertAtBookmark(System.String,System.String)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertDocProperty Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertDocProperty Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public DocProperty InsertDocProperty(
    CustomProperty cp,
    bool trackChanges = false,
    Formatting f = null
)
Visual Basic
Public Function InsertDocProperty (
    cp As CustomProperty,
    Optional trackChanges As Boolean = false,
    Optional f As Formatting = Nothing
) As DocProperty
Visual C++
public:
DocProperty^ InsertDocProperty(
    CustomProperty^ cp,
    bool trackChanges = false,
    Formatting^ f = nullptr
)
F#
member InsertDocProperty :
        cp : CustomProperty *
        ?trackChanges : bool *
        ?f : Formatting
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _f = defaultArg f null
*)
-> DocProperty

Parameters

cp
Type: Novacode..::..CustomProperty

[Missing <param name="cp"/> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

f (Optional)
Type: Novacode..::..Formatting

[Missing <param name="f"/> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Return Value

Type: DocProperty

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertHyperlink Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertHyperlink Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertHyperlink(Int32, Hyperlink) | Obsolete.
Public method | InsertHyperlink(Hyperlink, Int32) |

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertHyperlink Method (Int32, Hyperlink)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertHyperlink Method (Int32, Hyperlink)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
[ObsoleteAttribute("Instead use: InsertHyperlink(Hyperlink h, int index)")]
public Paragraph InsertHyperlink(
    int index,
    Hyperlink h
)
Visual Basic
<ObsoleteAttribute("Instead use: InsertHyperlink(Hyperlink h, int index)")>
Public Function InsertHyperlink (
    index As Integer,
    h As Hyperlink
) As Paragraph
Visual C++
public:
[ObsoleteAttribute(L"Instead use: InsertHyperlink(Hyperlink h, int index)")]
Paragraph^ InsertHyperlink(
    int index,
    Hyperlink^ h
)
F#
[<ObsoleteAttribute("Instead use: InsertHyperlink(Hyperlink h, int index)")>]
member InsertHyperlink :
        index : int *
        h : Hyperlink -> Paragraph

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

h
Type: Novacode..::..Hyperlink

[Missing <param name="h"/> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

See Also

Paragraph Class
Paragraph Members
InsertHyperlink Overload


Paragraph.InsertHyperlink Method (Hyperlink, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertHyperlink Method (Hyperlink, Int32)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertHyperlink(Novacode.Hyperlink,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph InsertHyperlink(
    Hyperlink h,
    int index = 0
)
Visual Basic
Public Function InsertHyperlink (
    h As Hyperlink,
    Optional index As Integer = 0
) As Paragraph
Visual C++
public:
Paragraph^ InsertHyperlink(
    Hyperlink^ h,
    int index = 0
)
F#
member InsertHyperlink :
        h : Hyperlink *
        ?index : int
(* Defaults:
        let _index = defaultArg index 0
*)
-> Paragraph

Parameters

h
Type: Novacode..::..Hyperlink

[Missing <param name="h"/> documentation for "M:Novacode.Paragraph.InsertHyperlink(Novacode.Hyperlink,System.Int32)"]

index (Optional)
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertHyperlink(Novacode.Hyperlink,System.Int32)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertHyperlink(Novacode.Hyperlink,System.Int32)"]

See Also

Paragraph Class
Paragraph Members
InsertHyperlink Overload


Paragraph.InsertPageBreakAfterSelf Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertPageBreakAfterSelf Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertPageBreakAfterSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override void InsertPageBreakAfterSelf()
Visual Basic
Public Overrides Sub InsertPageBreakAfterSelf
Visual C++
public:
virtual void InsertPageBreakAfterSelf() override
F#
abstract InsertPageBreakAfterSelf : unit -> unit
override InsertPageBreakAfterSelf : unit -> unit

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertPageBreakBeforeSelf Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertPageBreakBeforeSelf Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertPageBreakBeforeSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override void InsertPageBreakBeforeSelf()
Visual Basic
Public Overrides Sub InsertPageBreakBeforeSelf
Visual C++
public:
virtual void InsertPageBreakBeforeSelf() override
F#
abstract InsertPageBreakBeforeSelf : unit -> unit
override InsertPageBreakBeforeSelf : unit -> unit

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertPageCount Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertPageCount Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertPageCount(Novacode.PageNumberFormat,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertPageCount(
    PageNumberFormat pnf,
    int index = 0
)
Visual Basic
Public Sub InsertPageCount (
    pnf As PageNumberFormat,
    Optional index As Integer = 0
)
Visual C++
public:
void InsertPageCount(
    PageNumberFormat pnf,
    int index = 0
)
F#
member InsertPageCount :
        pnf : PageNumberFormat *
        ?index : int
(* Defaults:
        let _index = defaultArg index 0
*)
-> unit

Parameters

pnf
Type: Novacode..::..PageNumberFormat

[Missing <param name="pnf"/> documentation for "M:Novacode.Paragraph.InsertPageCount(Novacode.PageNumberFormat,System.Int32)"]

index (Optional)
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertPageCount(Novacode.PageNumberFormat,System.Int32)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertPageNumber Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertPageNumber Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertPageNumber(Novacode.PageNumberFormat,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertPageNumber(
    PageNumberFormat pnf,
    int index = 0
)
Visual Basic
Public Sub InsertPageNumber (
    pnf As PageNumberFormat,
    Optional index As Integer = 0
)
Visual C++
public:
void InsertPageNumber(
    PageNumberFormat pnf,
    int index = 0
)
F#
member InsertPageNumber :
        pnf : PageNumberFormat *
        ?index : int
(* Defaults:
        let _index = defaultArg index 0
*)
-> unit

Parameters

pnf
Type: Novacode..::..PageNumberFormat

[Missing <param name="pnf"/> documentation for "M:Novacode.Paragraph.InsertPageNumber(Novacode.PageNumberFormat,System.Int32)"]

index (Optional)
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertPageNumber(Novacode.PageNumberFormat,System.Int32)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertParagraphAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphAfterSelf Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertParagraphAfterSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphAfterSelf Method (String)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text
) override
F#
abstract InsertParagraphAfterSelf :
        text : string -> Paragraph
override InsertParagraphAfterSelf :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String)"]

See Also

Paragraph Class
Paragraph Members
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphAfterSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphAfterSelf Method (Paragraph)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    Paragraph^ p
) override
F#
abstract InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph
override InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(Novacode.Paragraph)"]

See Also

Paragraph Class
Paragraph Members
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphAfterSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphAfterSelf Method (String, Boolean)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges
) override
F#
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean)"]

See Also

Paragraph Class
Paragraph Members
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphAfterSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphAfterSelf Method (String, Boolean, Formatting)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
F#
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Paragraph Class
Paragraph Members
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphBeforeSelf Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertParagraphBeforeSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphBeforeSelf Method (String)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text
) override
F#
abstract InsertParagraphBeforeSelf :
        text : string -> Paragraph
override InsertParagraphBeforeSelf :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String)"]

See Also

Paragraph Class
Paragraph Members
InsertParagraphBeforeSelf Overload


Paragraph.InsertParagraphBeforeSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphBeforeSelf Method (Paragraph)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    Paragraph^ p
) override
F#
abstract InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph
override InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

See Also

Paragraph Class
Paragraph Members
InsertParagraphBeforeSelf Overload


Paragraph.InsertParagraphBeforeSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphBeforeSelf Method (String, Boolean)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges
) override
F#
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

See Also

Paragraph Class
Paragraph Members
InsertParagraphBeforeSelf Overload


Paragraph.InsertParagraphBeforeSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertParagraphBeforeSelf Method (String, Boolean, Formatting)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
F#
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Paragraph Class
Paragraph Members
InsertParagraphBeforeSelf Overload


Paragraph.InsertPicture Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertPicture Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertPicture(Novacode.Picture,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph InsertPicture(
    Picture p,
    int index = 0
)
Visual Basic
Public Function InsertPicture (
    p As Picture,
    Optional index As Integer = 0
) As Paragraph
Visual C++
public:
Paragraph^ InsertPicture(
    Picture^ p,
    int index = 0
)
F#
member InsertPicture :
        p : Picture *
        ?index : int
(* Defaults:
        let _index = defaultArg index 0
*)
-> Paragraph

Parameters

p
Type: Novacode..::..Picture

[Missing <param name="p"/> documentation for "M:Novacode.Paragraph.InsertPicture(Novacode.Picture,System.Int32)"]

index (Optional)
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertPicture(Novacode.Picture,System.Int32)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertPicture(Novacode.Picture,System.Int32)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertTableAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableAfterSelf Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertTableAfterSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableAfterSelf Method (Table)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableAfterSelf(
    Table t
)
Visual Basic
Public Overrides Function InsertTableAfterSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    Table^ t
) override
F#
abstract InsertTableAfterSelf :
        t : Table -> Table
override InsertTableAfterSelf :
        t : Table -> Table

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(Novacode.Table)"]

See Also

Paragraph Class
Paragraph Members
InsertTableAfterSelf Overload


Paragraph.InsertTableAfterSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableAfterSelf Method (Int32, Int32)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overrides Function InsertTableAfterSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    int rowCount,
    int columnCount
) override
F#
abstract InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(System.Int32,System.Int32)"]

See Also

Paragraph Class
Paragraph Members
InsertTableAfterSelf Overload


Paragraph.InsertTableBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableBeforeSelf Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertTableBeforeSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableBeforeSelf Method (Table)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableBeforeSelf(
    Table t
)
Visual Basic
Public Overrides Function InsertTableBeforeSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    Table^ t
) override
F#
abstract InsertTableBeforeSelf :
        t : Table -> Table
override InsertTableBeforeSelf :
        t : Table -> Table

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(Novacode.Table)"]

See Also

Paragraph Class
Paragraph Members
InsertTableBeforeSelf Overload


Paragraph.InsertTableBeforeSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertTableBeforeSelf Method (Int32, Int32)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overrides Function InsertTableBeforeSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    int rowCount,
    int columnCount
) override
F#
abstract InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(System.Int32,System.Int32)"]

See Also

Paragraph Class
Paragraph Members
InsertTableBeforeSelf Overload


Paragraph.InsertText Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertText Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertText(String, Boolean, Formatting) |
Public method | InsertText(Int32, String, Boolean, Formatting) |

See Also

Paragraph Class
Paragraph Members


Paragraph.InsertText Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertText Method (String, Boolean, Formatting)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertText(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertText(
    string value,
    bool trackChanges = false,
    Formatting formatting = null
)
Visual Basic
Public Sub InsertText (
    value As String,
    Optional trackChanges As Boolean = false,
    Optional formatting As Formatting = Nothing
)
Visual C++
public:
void InsertText(
    String^ value,
    bool trackChanges = false,
    Formatting^ formatting = nullptr
)
F#
member InsertText :
        value : string *
        ?trackChanges : bool *
        ?formatting : Formatting
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _formatting = defaultArg formatting null
*)
-> unit

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:Novacode.Paragraph.InsertText(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertText(System.String,System.Boolean,Novacode.Formatting)"]

formatting (Optional)
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Paragraph.InsertText(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Paragraph Class
Paragraph Members
InsertText Overload


Paragraph.InsertText Method (Int32, String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..InsertText Method (Int32, String, Boolean, Formatting)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertText(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertText(
    int index,
    string value,
    bool trackChanges = false,
    Formatting formatting = null
)
Visual Basic
Public Sub InsertText (
    index As Integer,
    value As String,
    Optional trackChanges As Boolean = false,
    Optional formatting As Formatting = Nothing
)
Visual C++
public:
void InsertText(
    int index,
    String^ value,
    bool trackChanges = false,
    Formatting^ formatting = nullptr
)
F#
member InsertText :
        index : int *
        value : string *
        ?trackChanges : bool *
        ?formatting : Formatting
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _formatting = defaultArg formatting null
*)
-> unit

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertText(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:Novacode.Paragraph.InsertText(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertText(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting (Optional)
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Paragraph.InsertText(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Paragraph Class
Paragraph Members
InsertText Overload


Paragraph.Italic Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Italic Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Italic"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Italic()
Visual Basic
Public Function Italic As Paragraph
Visual C++
public:
Paragraph^ Italic()
F#
member Italic : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Italic"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Kerning Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Kerning Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Kerning(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Kerning(
    int kerning
)
Visual Basic
Public Function Kerning (
    kerning As Integer
) As Paragraph
Visual C++
public:
Paragraph^ Kerning(
    int kerning
)
F#
member Kerning :
        kerning : int -> Paragraph

Parameters

kerning
Type: System..::..Int32

[Missing <param name="kerning"/> documentation for "M:Novacode.Paragraph.Kerning(System.Int32)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Kerning(System.Int32)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Misc Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Misc Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Misc(Novacode.Misc)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Misc(
    Misc misc
)
Visual Basic
Public Function Misc (
    misc As Misc
) As Paragraph
Visual C++
public:
Paragraph^ Misc(
    Misc misc
)
F#
member Misc :
        misc : Misc -> Paragraph

Parameters

misc
Type: Novacode..::..Misc

[Missing <param name="misc"/> documentation for "M:Novacode.Paragraph.Misc(Novacode.Misc)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Misc(Novacode.Misc)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.PercentageScale Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..PercentageScale Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.PercentageScale(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph PercentageScale(
    int percentageScale
)
Visual Basic
Public Function PercentageScale (
    percentageScale As Integer
) As Paragraph
Visual C++
public:
Paragraph^ PercentageScale(
    int percentageScale
)
F#
member PercentageScale :
        percentageScale : int -> Paragraph

Parameters

percentageScale
Type: System..::..Int32

[Missing <param name="percentageScale"/> documentation for "M:Novacode.Paragraph.PercentageScale(System.Int32)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.PercentageScale(System.Int32)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Position Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Position Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Position(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Position(
    double position
)
Visual Basic
Public Function Position (
    position As Double
) As Paragraph
Visual C++
public:
Paragraph^ Position(
    double position
)
F#
member Position :
        position : float -> Paragraph

Parameters

position
Type: System..::..Double

[Missing <param name="position"/> documentation for "M:Novacode.Paragraph.Position(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Position(System.Double)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Remove Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Remove Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Remove(System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Remove(
    bool trackChanges
)
Visual Basic
Public Sub Remove (
    trackChanges As Boolean
)
Visual C++
public:
void Remove(
    bool trackChanges
)
F#
member Remove :
        trackChanges : bool -> unit

Parameters

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.Remove(System.Boolean)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.RemoveHyperlink Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..RemoveHyperlink Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.RemoveHyperlink(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveHyperlink(
    int index
)
Visual Basic
Public Sub RemoveHyperlink (
    index As Integer
)
Visual C++
public:
void RemoveHyperlink(
    int index
)
F#
member RemoveHyperlink :
        index : int -> unit

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.RemoveHyperlink(System.Int32)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.RemoveText Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..RemoveText Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveText(Int32, Boolean) |
Public method | RemoveText(Int32, Int32, Boolean) |

See Also

Paragraph Class
Paragraph Members


Paragraph.RemoveText Method (Int32, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..RemoveText Method (Int32, Boolean)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveText(
    int index,
    bool trackChanges = false
)
Visual Basic
Public Sub RemoveText (
    index As Integer,
    Optional trackChanges As Boolean = false
)
Visual C++
public:
void RemoveText(
    int index,
    bool trackChanges = false
)
F#
member RemoveText :
        index : int *
        ?trackChanges : bool
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
*)
-> unit

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Boolean)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Boolean)"]

See Also

Paragraph Class
Paragraph Members
RemoveText Overload


Paragraph.RemoveText Method (Int32, Int32, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..RemoveText Method (Int32, Int32, Boolean)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Int32,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveText(
    int index,
    int count,
    bool trackChanges = false
)
Visual Basic
Public Sub RemoveText (
    index As Integer,
    count As Integer,
    Optional trackChanges As Boolean = false
)
Visual C++
public:
void RemoveText(
    int index,
    int count,
    bool trackChanges = false
)
F#
member RemoveText :
        index : int *
        count : int *
        ?trackChanges : bool
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
*)
-> unit

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Int32,System.Boolean)"]

count
Type: System..::..Int32

[Missing <param name="count"/> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Int32,System.Boolean)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Int32,System.Boolean)"]

See Also

Paragraph Class
Paragraph Members
RemoveText Overload


Paragraph.ReplaceText Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..ReplaceText Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void ReplaceText(
    string oldValue,
    string newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions.None,
    Formatting newFormatting = null,
    Formatting matchFormatting = null,
    MatchFormattingOptions fo = MatchFormattingOptions.SubsetMatch
)
Visual Basic
Public Sub ReplaceText (
    oldValue As String,
    newValue As String,
    Optional trackChanges As Boolean = false,
    Optional options As RegexOptions = RegexOptions.None,
    Optional newFormatting As Formatting = Nothing,
    Optional matchFormatting As Formatting = Nothing,
    Optional fo As MatchFormattingOptions = MatchFormattingOptions.SubsetMatch
)
Visual C++
public:
void ReplaceText(
    String^ oldValue,
    String^ newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions::None,
    Formatting^ newFormatting = nullptr,
    Formatting^ matchFormatting = nullptr,
    MatchFormattingOptions fo = MatchFormattingOptions::SubsetMatch
)
F#
member ReplaceText :
        oldValue : string *
        newValue : string *
        ?trackChanges : bool *
        ?options : RegexOptions *
        ?newFormatting : Formatting *
        ?matchFormatting : Formatting *
        ?fo : MatchFormattingOptions
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _options = defaultArg options RegexOptions.None
        let _newFormatting = defaultArg newFormatting null
        let _matchFormatting = defaultArg matchFormatting null
        let _fo = defaultArg fo MatchFormattingOptions.SubsetMatch
*)
-> unit

Parameters

oldValue
Type: System..::..String

[Missing <param name="oldValue"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newValue
Type: System..::..String

[Missing <param name="newValue"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

trackChanges (Optional)
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

options (Optional)
Type: System.Text.RegularExpressions..::..RegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newFormatting (Optional)
Type: Novacode..::..Formatting

[Missing <param name="newFormatting"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

matchFormatting (Optional)
Type: Novacode..::..Formatting

[Missing <param name="matchFormatting"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

fo (Optional)
Type: Novacode..::..MatchFormattingOptions

[Missing <param name="fo"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.Script Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Script Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Script(Novacode.Script)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Script(
    Script script
)
Visual Basic
Public Function Script (
    script As Script
) As Paragraph
Visual C++
public:
Paragraph^ Script(
    Script script
)
F#
member Script :
        script : Script -> Paragraph

Parameters

script
Type: Novacode..::..Script

[Missing <param name="script"/> documentation for "M:Novacode.Paragraph.Script(Novacode.Script)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Script(Novacode.Script)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.SetLineSpacing Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..SetLineSpacing Method
Paragraph Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetLineSpacing(LineSpacingTypeAuto) |
Public method | SetLineSpacing(LineSpacingType, Single) |

See Also

Paragraph Class
Paragraph Members


Paragraph.SetLineSpacing Method (LineSpacingTypeAuto)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..SetLineSpacing Method (LineSpacingTypeAuto)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.SetLineSpacing(Novacode.LineSpacingTypeAuto)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetLineSpacing(
    LineSpacingTypeAuto spacingType
)
Visual Basic
Public Sub SetLineSpacing (
    spacingType As LineSpacingTypeAuto
)
Visual C++
public:
void SetLineSpacing(
    LineSpacingTypeAuto spacingType
)
F#
member SetLineSpacing :
        spacingType : LineSpacingTypeAuto -> unit

Parameters

spacingType
Type: Novacode..::..LineSpacingTypeAuto

[Missing <param name="spacingType"/> documentation for "M:Novacode.Paragraph.SetLineSpacing(Novacode.LineSpacingTypeAuto)"]

See Also

Paragraph Class
Paragraph Members
SetLineSpacing Overload


Paragraph.SetLineSpacing Method (LineSpacingType, Single)

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..SetLineSpacing Method (LineSpacingType, Single)
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.SetLineSpacing(Novacode.LineSpacingType,System.Single)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetLineSpacing(
    LineSpacingType spacingType,
    float spacingFloat
)
Visual Basic
Public Sub SetLineSpacing (
    spacingType As LineSpacingType,
    spacingFloat As Single
)
Visual C++
public:
void SetLineSpacing(
    LineSpacingType spacingType,
    float spacingFloat
)
F#
member SetLineSpacing :
        spacingType : LineSpacingType *
        spacingFloat : float32 -> unit

Parameters

spacingType
Type: Novacode..::..LineSpacingType

[Missing <param name="spacingType"/> documentation for "M:Novacode.Paragraph.SetLineSpacing(Novacode.LineSpacingType,System.Single)"]

spacingFloat
Type: System..::..Single

[Missing <param name="spacingFloat"/> documentation for "M:Novacode.Paragraph.SetLineSpacing(Novacode.LineSpacingType,System.Single)"]

See Also

Paragraph Class
Paragraph Members
SetLineSpacing Overload


Paragraph.Spacing Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Spacing Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.Spacing(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph Spacing(
    double spacing
)
Visual Basic
Public Function Spacing (
    spacing As Double
) As Paragraph
Visual C++
public:
Paragraph^ Spacing(
    double spacing
)
F#
member Spacing :
        spacing : float -> Paragraph

Parameters

spacing
Type: System..::..Double

[Missing <param name="spacing"/> documentation for "M:Novacode.Paragraph.Spacing(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Spacing(System.Double)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.SpacingAfter Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..SpacingAfter Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.SpacingAfter(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph SpacingAfter(
    double spacingAfter
)
Visual Basic
Public Function SpacingAfter (
    spacingAfter As Double
) As Paragraph
Visual C++
public:
Paragraph^ SpacingAfter(
    double spacingAfter
)
F#
member SpacingAfter :
        spacingAfter : float -> Paragraph

Parameters

spacingAfter
Type: System..::..Double

[Missing <param name="spacingAfter"/> documentation for "M:Novacode.Paragraph.SpacingAfter(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.SpacingAfter(System.Double)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.SpacingBefore Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..SpacingBefore Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.SpacingBefore(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph SpacingBefore(
    double spacingBefore
)
Visual Basic
Public Function SpacingBefore (
    spacingBefore As Double
) As Paragraph
Visual C++
public:
Paragraph^ SpacingBefore(
    double spacingBefore
)
F#
member SpacingBefore :
        spacingBefore : float -> Paragraph

Parameters

spacingBefore
Type: System..::..Double

[Missing <param name="spacingBefore"/> documentation for "M:Novacode.Paragraph.SpacingBefore(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.SpacingBefore(System.Double)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.StrikeThrough Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..StrikeThrough Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.StrikeThrough(Novacode.StrikeThrough)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph StrikeThrough(
    StrikeThrough strikeThrough
)
Visual Basic
Public Function StrikeThrough (
    strikeThrough As StrikeThrough
) As Paragraph
Visual C++
public:
Paragraph^ StrikeThrough(
    StrikeThrough strikeThrough
)
F#
member StrikeThrough :
        strikeThrough : StrikeThrough -> Paragraph

Parameters

strikeThrough
Type: Novacode..::..StrikeThrough

[Missing <param name="strikeThrough"/> documentation for "M:Novacode.Paragraph.StrikeThrough(Novacode.StrikeThrough)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.StrikeThrough(Novacode.StrikeThrough)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.UnderlineColor Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..UnderlineColor Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.UnderlineColor(System.Drawing.Color)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph UnderlineColor(
    Color underlineColor
)
Visual Basic
Public Function UnderlineColor (
    underlineColor As Color
) As Paragraph
Visual C++
public:
Paragraph^ UnderlineColor(
    Color underlineColor
)
F#
member UnderlineColor :
        underlineColor : Color -> Paragraph

Parameters

underlineColor
Type: System.Drawing..::..Color

[Missing <param name="underlineColor"/> documentation for "M:Novacode.Paragraph.UnderlineColor(System.Drawing.Color)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.UnderlineColor(System.Drawing.Color)"]

See Also

Paragraph Class
Paragraph Members


Paragraph.UnderlineStyle Method

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..UnderlineStyle Method
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Paragraph.UnderlineStyle(Novacode.UnderlineStyle)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Paragraph UnderlineStyle(
    UnderlineStyle underlineStyle
)
Visual Basic
Public Function UnderlineStyle (
    underlineStyle As UnderlineStyle
) As Paragraph
Visual C++
public:
Paragraph^ UnderlineStyle(
    UnderlineStyle underlineStyle
)
F#
member UnderlineStyle :
        underlineStyle : UnderlineStyle -> Paragraph

Parameters

underlineStyle
Type: Novacode..::..UnderlineStyle

[Missing <param name="underlineStyle"/> documentation for "M:Novacode.Paragraph.UnderlineStyle(Novacode.UnderlineStyle)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.UnderlineStyle(Novacode.UnderlineStyle)"]

See Also

Paragraph Class
Paragraph Members


Paragraph Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Paragraph Properties
Paragraph Class See Also Send Feedback

The Paragraph type exposes the following members.

Properties

 | Name | Description
Public property | Alignment |
Public property | Direction |
Public property | DocumentProperties |
Public property | FollowingTable |
Public property | Hyperlinks |
Public property | IndentationAfter |
Public property | IndentationBefore |
Public property | IndentationFirstLine |
Public property | IndentationHanging |
Public property | IndentLevel |
Public property | IsListItem |
Public property | LineSpacing |
Public property | LineSpacingAfter |
Public property | LineSpacingBefore |
Public property | MagicText |
Public property | PackagePart |
Public property | ParagraphNumberProperties |
Public property | Pictures |
Public property | StyleName |
Public property | Text |
Public property | Xml | (Inherited from DocXElement.)

See Also

Paragraph Class


Paragraph.Alignment Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Alignment Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.Alignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Alignment Alignment { get; set; }
Visual Basic
Public Property Alignment As Alignment
    Get
    Set
Visual C++
public:
property Alignment Alignment {
    Alignment get ();
    void set (Alignment value);
}
F#
member Alignment : Alignment with get, set

Property Value

Type: Alignment

See Also

Paragraph Class
Paragraph Members


Paragraph.Direction Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Direction Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.Direction"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Direction Direction { get; set; }
Visual Basic
Public Property Direction As Direction
    Get
    Set
Visual C++
public:
property Direction Direction {
    Direction get ();
    void set (Direction value);
}
F#
member Direction : Direction with get, set

Property Value

Type: Direction

See Also

Paragraph Class
Paragraph Members


Paragraph.DocumentProperties Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..DocumentProperties Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.DocumentProperties"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<DocProperty> DocumentProperties { get; }
Visual Basic
Public ReadOnly Property DocumentProperties As List(Of DocProperty)
    Get
Visual C++
public:
property List<DocProperty^>^ DocumentProperties {
    List<DocProperty^>^ get ();
}
F#
member DocumentProperties : List<DocProperty> with get

Property Value

Type: List <(Of <(<' DocProperty >)>)>

See Also

Paragraph Class
Paragraph Members


Paragraph.FollowingTable Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..FollowingTable Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.FollowingTable"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Table FollowingTable { get; }
Visual Basic
Public ReadOnly Property FollowingTable As Table
    Get
Visual C++
public:
property Table^ FollowingTable {
    Table^ get ();
}
F#
member FollowingTable : Table with get

Property Value

Type: Table

See Also

Paragraph Class
Paragraph Members


Paragraph.Hyperlinks Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Hyperlinks Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.Hyperlinks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Hyperlink> Hyperlinks { get; }
Visual Basic
Public ReadOnly Property Hyperlinks As List(Of Hyperlink)
    Get
Visual C++
public:
property List<Hyperlink^>^ Hyperlinks {
    List<Hyperlink^>^ get ();
}
F#
member Hyperlinks : List<Hyperlink> with get

Property Value

Type: List <(Of <(<' Hyperlink >)>)>

See Also

Paragraph Class
Paragraph Members


Paragraph.IndentationAfter Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IndentationAfter Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.IndentationAfter"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float IndentationAfter { get; set; }
Visual Basic
Public Property IndentationAfter As Single
    Get
    Set
Visual C++
public:
property float IndentationAfter {
    float get ();
    void set (float value);
}
F#
member IndentationAfter : float32 with get, set

Property Value

Type: Single

See Also

Paragraph Class
Paragraph Members


Paragraph.IndentationBefore Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IndentationBefore Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.IndentationBefore"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float IndentationBefore { get; set; }
Visual Basic
Public Property IndentationBefore As Single
    Get
    Set
Visual C++
public:
property float IndentationBefore {
    float get ();
    void set (float value);
}
F#
member IndentationBefore : float32 with get, set

Property Value

Type: Single

See Also

Paragraph Class
Paragraph Members


Paragraph.IndentationFirstLine Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IndentationFirstLine Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.IndentationFirstLine"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float IndentationFirstLine { get; set; }
Visual Basic
Public Property IndentationFirstLine As Single
    Get
    Set
Visual C++
public:
property float IndentationFirstLine {
    float get ();
    void set (float value);
}
F#
member IndentationFirstLine : float32 with get, set

Property Value

Type: Single

See Also

Paragraph Class
Paragraph Members


Paragraph.IndentationHanging Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IndentationHanging Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.IndentationHanging"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float IndentationHanging { get; set; }
Visual Basic
Public Property IndentationHanging As Single
    Get
    Set
Visual C++
public:
property float IndentationHanging {
    float get ();
    void set (float value);
}
F#
member IndentationHanging : float32 with get, set

Property Value

Type: Single

See Also

Paragraph Class
Paragraph Members


Paragraph.IndentLevel Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IndentLevel Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.IndentLevel"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Nullable<int> IndentLevel { get; }
Visual Basic
Public ReadOnly Property IndentLevel As Nullable(Of Integer)
    Get
Visual C++
public:
property Nullable<int> IndentLevel {
    Nullable<int> get ();
}
F#
member IndentLevel : Nullable<int> with get

Property Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

Paragraph Class
Paragraph Members


Paragraph.IsListItem Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..IsListItem Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.IsListItem"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool IsListItem { get; }
Visual Basic
Public ReadOnly Property IsListItem As Boolean
    Get
Visual C++
public:
property bool IsListItem {
    bool get ();
}
F#
member IsListItem : bool with get

Property Value

Type: Boolean

See Also

Paragraph Class
Paragraph Members


Paragraph.LineSpacing Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..LineSpacing Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.LineSpacing"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float LineSpacing { get; set; }
Visual Basic
Public Property LineSpacing As Single
    Get
    Set
Visual C++
public:
property float LineSpacing {
    float get ();
    void set (float value);
}
F#
member LineSpacing : float32 with get, set

Property Value

Type: Single

See Also

Paragraph Class
Paragraph Members


Paragraph.LineSpacingAfter Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..LineSpacingAfter Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.LineSpacingAfter"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float LineSpacingAfter { get; set; }
Visual Basic
Public Property LineSpacingAfter As Single
    Get
    Set
Visual C++
public:
property float LineSpacingAfter {
    float get ();
    void set (float value);
}
F#
member LineSpacingAfter : float32 with get, set

Property Value

Type: Single

See Also

Paragraph Class
Paragraph Members


Paragraph.LineSpacingBefore Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..LineSpacingBefore Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.LineSpacingBefore"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public float LineSpacingBefore { get; set; }
Visual Basic
Public Property LineSpacingBefore As Single
    Get
    Set
Visual C++
public:
property float LineSpacingBefore {
    float get ();
    void set (float value);
}
F#
member LineSpacingBefore : float32 with get, set

Property Value

Type: Single

See Also

Paragraph Class
Paragraph Members


Paragraph.MagicText Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..MagicText Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.MagicText"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<FormattedText> MagicText { get; }
Visual Basic
Public ReadOnly Property MagicText As List(Of FormattedText)
    Get
Visual C++
public:
property List<FormattedText^>^ MagicText {
    List<FormattedText^>^ get ();
}
F#
member MagicText : List<FormattedText> with get

Property Value

Type: List <(Of <(<' FormattedText >)>)>

See Also

Paragraph Class
Paragraph Members


Paragraph.PackagePart Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..PackagePart Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.PackagePart"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public PackagePart PackagePart { get; set; }
Visual Basic
Public Property PackagePart As PackagePart
    Get
    Set
Visual C++
public:
property PackagePart^ PackagePart {
    PackagePart^ get ();
    void set (PackagePart^ value);
}
F#
member PackagePart : PackagePart with get, set

Property Value

Type: PackagePart

See Also

Paragraph Class
Paragraph Members


Paragraph.ParagraphNumberProperties Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..ParagraphNumberProperties Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.ParagraphNumberProperties"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public XElement ParagraphNumberProperties { get; }
Visual Basic
Public ReadOnly Property ParagraphNumberProperties As XElement
    Get
Visual C++
public:
property XElement^ ParagraphNumberProperties {
    XElement^ get ();
}
F#
member ParagraphNumberProperties : XElement with get

Property Value

Type: XElement

See Also

Paragraph Class
Paragraph Members


Paragraph.Pictures Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Pictures Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.Pictures"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Picture> Pictures { get; }
Visual Basic
Public ReadOnly Property Pictures As List(Of Picture)
    Get
Visual C++
public:
property List<Picture^>^ Pictures {
    List<Picture^>^ get ();
}
F#
member Pictures : List<Picture> with get

Property Value

Type: List <(Of <(<' Picture >)>)>

See Also

Paragraph Class
Paragraph Members


Paragraph.StyleName Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..StyleName Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.StyleName"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string StyleName { get; set; }
Visual Basic
Public Property StyleName As String
    Get
    Set
Visual C++
public:
property String^ StyleName {
    String^ get ();
    void set (String^ value);
}
F#
member StyleName : string with get, set

Property Value

Type: String

See Also

Paragraph Class
Paragraph Members


Paragraph.Text Property

[image]

DocX - A Sandcastle Documented Class Library
Paragraph..::..Text Property
Paragraph Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Paragraph.Text"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}
F#
member Text : string with get

Property Value

Type: String

See Also

Paragraph Class
Paragraph Members


Picture Class

[image]

DocX - A Sandcastle Documented Class Library
Picture Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Picture"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Picture : DocXElement
Visual Basic
Public Class Picture
    Inherits DocXElement
Visual C++
public ref class Picture : public DocXElement
F#
type Picture =
    class
        inherit DocXElement
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Picture

See Also

Picture Members


Picture Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Picture Members
Picture Class Methods Properties See Also Send Feedback

The Picture type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | SetPictureShape(BasicShapes) |
Public method | SetPictureShape(BlockArrowShapes) |
Public method | SetPictureShape(CalloutShapes) |
Public method | SetPictureShape(EquationShapes) |
Public method | SetPictureShape(FlowchartShapes) |
Public method | SetPictureShape(RectangleShapes) |
Public method | SetPictureShape(StarAndBannerShapes) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description |
Public property | FileName |
Public property | FlipHorizontal |
Public property | FlipVertical |
Public property | Height |
Public property | Id |
Public property | Name |
Public property | Rotation |
Public property | Width |
Public property | Xml | (Inherited from DocXElement.)

See Also

Picture Class


Picture Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Picture Methods
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | SetPictureShape(BasicShapes) |
Public method | SetPictureShape(BlockArrowShapes) |
Public method | SetPictureShape(CalloutShapes) |
Public method | SetPictureShape(EquationShapes) |
Public method | SetPictureShape(FlowchartShapes) |
Public method | SetPictureShape(RectangleShapes) |
Public method | SetPictureShape(StarAndBannerShapes) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Picture Class


Picture.Remove Method

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Remove Method
Picture Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Picture.Remove"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Remove()
Visual Basic
Public Sub Remove
Visual C++
public:
void Remove()
F#
member Remove : unit -> unit

See Also

Picture Class
Picture Members


Picture.SetPictureShape Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method
Picture Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPictureShape(BasicShapes) |
Public method | SetPictureShape(BlockArrowShapes) |
Public method | SetPictureShape(CalloutShapes) |
Public method | SetPictureShape(EquationShapes) |
Public method | SetPictureShape(FlowchartShapes) |
Public method | SetPictureShape(RectangleShapes) |
Public method | SetPictureShape(StarAndBannerShapes) |

See Also

Picture Class
Picture Members


Picture.SetPictureShape Method (BasicShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (BasicShapes)
Picture Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.BasicShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    BasicShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As BasicShapes
)
Visual C++
public:
void SetPictureShape(
    BasicShapes shape
)
F#
member SetPictureShape :
        shape : BasicShapes -> unit

Parameters

shape
Type: Novacode..::..BasicShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.BasicShapes)"]

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (BlockArrowShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (BlockArrowShapes)
Picture Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.BlockArrowShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    BlockArrowShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As BlockArrowShapes
)
Visual C++
public:
void SetPictureShape(
    BlockArrowShapes shape
)
F#
member SetPictureShape :
        shape : BlockArrowShapes -> unit

Parameters

shape
Type: Novacode..::..BlockArrowShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.BlockArrowShapes)"]

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (CalloutShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (CalloutShapes)
Picture Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.CalloutShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    CalloutShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As CalloutShapes
)
Visual C++
public:
void SetPictureShape(
    CalloutShapes shape
)
F#
member SetPictureShape :
        shape : CalloutShapes -> unit

Parameters

shape
Type: Novacode..::..CalloutShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.CalloutShapes)"]

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (EquationShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (EquationShapes)
Picture Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.EquationShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    EquationShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As EquationShapes
)
Visual C++
public:
void SetPictureShape(
    EquationShapes shape
)
F#
member SetPictureShape :
        shape : EquationShapes -> unit

Parameters

shape
Type: Novacode..::..EquationShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.EquationShapes)"]

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (FlowchartShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (FlowchartShapes)
Picture Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.FlowchartShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    FlowchartShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As FlowchartShapes
)
Visual C++
public:
void SetPictureShape(
    FlowchartShapes shape
)
F#
member SetPictureShape :
        shape : FlowchartShapes -> unit

Parameters

shape
Type: Novacode..::..FlowchartShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.FlowchartShapes)"]

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (RectangleShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (RectangleShapes)
Picture Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.RectangleShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    RectangleShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As RectangleShapes
)
Visual C++
public:
void SetPictureShape(
    RectangleShapes shape
)
F#
member SetPictureShape :
        shape : RectangleShapes -> unit

Parameters

shape
Type: Novacode..::..RectangleShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.RectangleShapes)"]

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture.SetPictureShape Method (StarAndBannerShapes)

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..SetPictureShape Method (StarAndBannerShapes)
Picture Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.StarAndBannerShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetPictureShape(
    StarAndBannerShapes shape
)
Visual Basic
Public Sub SetPictureShape (
    shape As StarAndBannerShapes
)
Visual C++
public:
void SetPictureShape(
    StarAndBannerShapes shape
)
F#
member SetPictureShape :
        shape : StarAndBannerShapes -> unit

Parameters

shape
Type: Novacode..::..StarAndBannerShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.StarAndBannerShapes)"]

See Also

Picture Class
Picture Members
SetPictureShape Overload


Picture Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Picture Properties
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Properties

 | Name | Description
Public property | Description |
Public property | FileName |
Public property | FlipHorizontal |
Public property | FlipVertical |
Public property | Height |
Public property | Id |
Public property | Name |
Public property | Rotation |
Public property | Width |
Public property | Xml | (Inherited from DocXElement.)

See Also

Picture Class


Picture.Description Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Description Property
Picture Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Picture.Description"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
F#
member Description : string with get, set

Property Value

Type: String

See Also

Picture Class
Picture Members


Picture.FileName Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..FileName Property
Picture Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Picture.FileName"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get
Visual C++
public:
property String^ FileName {
    String^ get ();
}
F#
member FileName : string with get

Property Value

Type: String

See Also

Picture Class
Picture Members


Picture.FlipHorizontal Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..FlipHorizontal Property
Picture Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Picture.FlipHorizontal"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool FlipHorizontal { get; set; }
Visual Basic
Public Property FlipHorizontal As Boolean
    Get
    Set
Visual C++
public:
property bool FlipHorizontal {
    bool get ();
    void set (bool value);
}
F#
member FlipHorizontal : bool with get, set

Property Value

Type: Boolean

See Also

Picture Class
Picture Members


Picture.FlipVertical Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..FlipVertical Property
Picture Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Picture.FlipVertical"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool FlipVertical { get; set; }
Visual Basic
Public Property FlipVertical As Boolean
    Get
    Set
Visual C++
public:
property bool FlipVertical {
    bool get ();
    void set (bool value);
}
F#
member FlipVertical : bool with get, set

Property Value

Type: Boolean

See Also

Picture Class
Picture Members


Picture.Height Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Height Property
Picture Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Picture.Height"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int Height { get; set; }
Visual Basic
Public Property Height As Integer
    Get
    Set
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}
F#
member Height : int with get, set

Property Value

Type: Int32

See Also

Picture Class
Picture Members


Picture.Id Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Id Property
Picture Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Picture.Id"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}
F#
member Id : string with get

Property Value

Type: String

See Also

Picture Class
Picture Members


Picture.Name Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Name Property
Picture Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Picture.Name"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
F#
member Name : string with get, set

Property Value

Type: String

See Also

Picture Class
Picture Members


Picture.Rotation Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Rotation Property
Picture Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Picture.Rotation"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public uint Rotation { get; set; }
Visual Basic
Public Property Rotation As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Rotation {
    unsigned int get ();
    void set (unsigned int value);
}
F#
member Rotation : uint32 with get, set

Property Value

Type: UInt32

See Also

Picture Class
Picture Members


Picture.Width Property

[image]

DocX - A Sandcastle Documented Class Library
Picture..::..Width Property
Picture Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Picture.Width"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}
F#
member Width : int with get, set

Property Value

Type: Int32

See Also

Picture Class
Picture Members


PieChart Class

[image]

DocX - A Sandcastle Documented Class Library
PieChart Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.PieChart"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class PieChart : Chart
Visual Basic
Public Class PieChart
    Inherits Chart
Visual C++
public ref class PieChart : public Chart
F#
type PieChart =
    class
        inherit Chart
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..Chart
Novacode..::..PieChart

See Also

PieChart Members


PieChart Members

[image] [image]

DocX - A Sandcastle Documented Class Library
PieChart Members
PieChart Class Constructors Methods Properties See Also Send Feedback

The PieChart type exposes the following members.

Constructors

 | Name | Description
Public method | PieChart | Initializes a new instance of the PieChart class

Methods

 | Name | Description
Public method | AddLegend()()()() | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | IsAxisExist | (Overrides Chart..::..IsAxisExist.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Overrides Chart..::..MaxSeriesCount.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)

See Also

PieChart Class


PieChart Constructor

[image]

DocX - A Sandcastle Documented Class Library
PieChart Constructor
PieChart Class See Also Send Feedback
Initializes a new instance of the PieChart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public PieChart()
Visual Basic
Public Sub New
Visual C++
public:
PieChart()
F#
new : unit -> PieChart

See Also

PieChart Class
PieChart Members


PieChart Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
PieChart Methods
PieChart Class See Also Send Feedback

The PieChart type exposes the following members.

Methods

 | Name | Description
Public method | AddLegend()()()() | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides Chart..::..CreateChartXml()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PieChart Class


PieChart.CreateChartXml Method

[image]

DocX - A Sandcastle Documented Class Library
PieChart..::..CreateChartXml Method
PieChart Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.PieChart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
protected override XElement CreateChartXml()
Visual Basic
Protected Overrides Function CreateChartXml As XElement
Visual C++
protected:
virtual XElement^ CreateChartXml() override
F#
abstract CreateChartXml : unit -> XElement
override CreateChartXml : unit -> XElement

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.PieChart.CreateChartXml"]

See Also

PieChart Class
PieChart Members


PieChart Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
PieChart Properties
PieChart Class See Also Send Feedback

The PieChart type exposes the following members.

Properties

 | Name | Description
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | IsAxisExist | (Overrides Chart..::..IsAxisExist.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Overrides Chart..::..MaxSeriesCount.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)

See Also

PieChart Class


PieChart.IsAxisExist Property

[image]

DocX - A Sandcastle Documented Class Library
PieChart..::..IsAxisExist Property
PieChart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.PieChart.IsAxisExist"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override bool IsAxisExist { get; }
Visual Basic
Public Overrides ReadOnly Property IsAxisExist As Boolean
    Get
Visual C++
public:
virtual property bool IsAxisExist {
    bool get () override;
}
F#
abstract IsAxisExist : bool with get
override IsAxisExist : bool with get

Property Value

Type: Boolean

See Also

PieChart Class
PieChart Members


PieChart.MaxSeriesCount Property

[image]

DocX - A Sandcastle Documented Class Library
PieChart..::..MaxSeriesCount Property
PieChart Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.PieChart.MaxSeriesCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override short MaxSeriesCount { get; }
Visual Basic
Public Overrides ReadOnly Property MaxSeriesCount As Short
    Get
Visual C++
public:
virtual property short MaxSeriesCount {
    short get () override;
}
F#
abstract MaxSeriesCount : int16 with get
override MaxSeriesCount : int16 with get

Property Value

Type: Int16

See Also

PieChart Class
PieChart Members


RectangleShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
RectangleShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.RectangleShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum RectangleShapes
Visual Basic
Public Enumeration RectangleShapes
Visual C++
public enum class RectangleShapes
F#
type RectangleShapes

Members

Member name | Value | Description
rect | 0 |
roundRect | 1 |
snip1Rect | 2 |
snip2SameRect | 3 |
snip2DiagRect | 4 |
snipRoundRect | 5 |
round1Rect | 6 |
round2SameRect | 7 |
round2DiagRect | 8 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Row Class

[image]

DocX - A Sandcastle Documented Class Library
Row Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Row"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Row : Container
Visual Basic
Public Class Row
    Inherits Container
Visual C++
public ref class Row : public Container
F#
type Row =
    class
        inherit Container
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Row

See Also

Row Members


Row Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Row Members
Row Class Methods Fields Properties See Also Send Feedback

The Row type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCells |
Public method | Remove |
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

Properties

 | Name | Description
Public property | BreakAcrossPages |
Public property | Cells |
Public property | ColumnCount |
Public property | Height |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | TableHeader |
Public property | Tables | (Inherited from Container.)
Public property | Xml | (Inherited from DocXElement.)

See Also

Row Class


Row Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Row Fields
Row Class See Also Send Feedback

The Row type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)

See Also

Row Class


Row Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Row Methods
Row Class See Also Send Feedback

The Row type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCells |
Public method | Remove |
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Row Class


Row.MergeCells Method

[image]

DocX - A Sandcastle Documented Class Library
Row..::..MergeCells Method
Row Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Row.MergeCells(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void MergeCells(
    int startIndex,
    int endIndex
)
Visual Basic
Public Sub MergeCells (
    startIndex As Integer,
    endIndex As Integer
)
Visual C++
public:
void MergeCells(
    int startIndex,
    int endIndex
)
F#
member MergeCells :
        startIndex : int *
        endIndex : int -> unit

Parameters

startIndex
Type: System..::..Int32

[Missing <param name="startIndex"/> documentation for "M:Novacode.Row.MergeCells(System.Int32,System.Int32)"]

endIndex
Type: System..::..Int32

[Missing <param name="endIndex"/> documentation for "M:Novacode.Row.MergeCells(System.Int32,System.Int32)"]

See Also

Row Class
Row Members


Row.Remove Method

[image]

DocX - A Sandcastle Documented Class Library
Row..::..Remove Method
Row Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Row.Remove"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Remove()
Visual Basic
Public Sub Remove
Visual C++
public:
void Remove()
F#
member Remove : unit -> unit

See Also

Row Class
Row Members


Row Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Row Properties
Row Class See Also Send Feedback

The Row type exposes the following members.

Properties

 | Name | Description
Public property | BreakAcrossPages |
Public property | Cells |
Public property | ColumnCount |
Public property | Height |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | Paragraphs | (Overrides Container..::..Paragraphs.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | TableHeader |
Public property | Tables | (Inherited from Container.)
Public property | Xml | (Inherited from DocXElement.)

See Also

Row Class


Row.BreakAcrossPages Property

[image]

DocX - A Sandcastle Documented Class Library
Row..::..BreakAcrossPages Property
Row Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Row.BreakAcrossPages"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool BreakAcrossPages { get; set; }
Visual Basic
Public Property BreakAcrossPages As Boolean
    Get
    Set
Visual C++
public:
property bool BreakAcrossPages {
    bool get ();
    void set (bool value);
}
F#
member BreakAcrossPages : bool with get, set

Property Value

Type: Boolean

See Also

Row Class
Row Members


Row.Cells Property

[image]

DocX - A Sandcastle Documented Class Library
Row..::..Cells Property
Row Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Row.Cells"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Cell> Cells { get; }
Visual Basic
Public ReadOnly Property Cells As List(Of Cell)
    Get
Visual C++
public:
property List<Cell^>^ Cells {
    List<Cell^>^ get ();
}
F#
member Cells : List<Cell> with get

Property Value

Type: List <(Of <(<' Cell >)>)>

See Also

Row Class
Row Members


Row.ColumnCount Property

[image]

DocX - A Sandcastle Documented Class Library
Row..::..ColumnCount Property
Row Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Row.ColumnCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int ColumnCount { get; }
Visual Basic
Public ReadOnly Property ColumnCount As Integer
    Get
Visual C++
public:
property int ColumnCount {
    int get ();
}
F#
member ColumnCount : int with get

Property Value

Type: Int32

See Also

Row Class
Row Members


Row.Height Property

[image]

DocX - A Sandcastle Documented Class Library
Row..::..Height Property
Row Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Row.Height"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}
F#
member Height : float with get, set

Property Value

Type: Double

See Also

Row Class
Row Members


Row.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Row..::..Paragraphs Property
Row Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Row.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override ReadOnlyCollection<Paragraph> Paragraphs { get; }
Visual Basic
Public Overrides ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
Visual C++
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get () override;
}
F#
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection <(Of <(<' Paragraph >)>)>

See Also

Row Class
Row Members


Row.TableHeader Property

[image]

DocX - A Sandcastle Documented Class Library
Row..::..TableHeader Property
Row Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Row.TableHeader"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool TableHeader { get; set; }
Visual Basic
Public Property TableHeader As Boolean
    Get
    Set
Visual C++
public:
property bool TableHeader {
    bool get ();
    void set (bool value);
}
F#
member TableHeader : bool with get, set

Property Value

Type: Boolean

See Also

Row Class
Row Members


Run Class

[image]

DocX - A Sandcastle Documented Class Library
Run Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Run"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Run : DocXElement
Visual Basic
Public Class Run
    Inherits DocXElement
Visual C++
public ref class Run : public DocXElement
F#
type Run =
    class
        inherit DocXElement
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Run

See Also

Run Members


Run Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Run Members
Run Class Methods Properties See Also Send Feedback

The Run type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndIndex |
Public property | StartIndex |
Public property | Xml | (Inherited from DocXElement.)

See Also

Run Class


Run Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Run Methods
Run Class See Also Send Feedback

The Run type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Run Class


Run Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Run Properties
Run Class See Also Send Feedback

The Run type exposes the following members.

Properties

 | Name | Description
Public property | EndIndex |
Public property | StartIndex |
Public property | Xml | (Inherited from DocXElement.)

See Also

Run Class


Run.EndIndex Property

[image]

DocX - A Sandcastle Documented Class Library
Run..::..EndIndex Property
Run Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Run.EndIndex"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int EndIndex { get; }
Visual Basic
Public ReadOnly Property EndIndex As Integer
    Get
Visual C++
public:
property int EndIndex {
    int get ();
}
F#
member EndIndex : int with get

Property Value

Type: Int32

See Also

Run Class
Run Members


Run.StartIndex Property

[image]

DocX - A Sandcastle Documented Class Library
Run..::..StartIndex Property
Run Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Run.StartIndex"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int StartIndex { get; }
Visual Basic
Public ReadOnly Property StartIndex As Integer
    Get
Visual C++
public:
property int StartIndex {
    int get ();
}
F#
member StartIndex : int with get

Property Value

Type: Int32

See Also

Run Class
Run Members


RunTextType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
RunTextType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.RunTextType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum RunTextType
Visual Basic
Public Enumeration RunTextType
Visual C++
public enum class RunTextType
F#
type RunTextType

Members

Member name | Value | Description
Text | 0 |
DelText | 1 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Script Enumeration

[image]

DocX - A Sandcastle Documented Class Library
Script Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Script"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum Script
Visual Basic
Public Enumeration Script
Visual C++
public enum class Script
F#
type Script

Members

Member name | Value | Description
superscript | 0 |
subscript | 1 |
none | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Section Class

[image]

DocX - A Sandcastle Documented Class Library
Section Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Section"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Section : Container
Visual Basic
Public Class Section
    Inherits Container
Visual C++
public ref class Section : public Container
F#
type Section =
    class
        inherit Container
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..Container
Novacode..::..Section

See Also

Section Members


Section Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Section Members
Section Class Methods Fields Properties See Also Send Feedback

The Section type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Public field | SectionBreakType |

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | Paragraphs | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | SectionParagraphs |
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Inherited from Container.)
Public property | Xml | (Inherited from DocXElement.)

See Also

Section Class


Section Fields

[image] [image]

DocX - A Sandcastle Documented Class Library
Section Fields
Section Class See Also Send Feedback

The Section type exposes the following members.

Fields

 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Public field | SectionBreakType |

See Also

Section Class


Section.SectionBreakType Field

[image]

DocX - A Sandcastle Documented Class Library
Section..::..SectionBreakType Field
Section Class See Also Send Feedback

[Missing <summary> documentation for "F:Novacode.Section.SectionBreakType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public SectionBreakType SectionBreakType
Visual Basic
Public SectionBreakType As SectionBreakType
Visual C++
public:
SectionBreakType SectionBreakType
F#
val mutable SectionBreakType: SectionBreakType

Field Value

Type: SectionBreakType

See Also

Section Class
Section Members


Section Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Section Methods
Section Class See Also Send Feedback

The Section type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph()()()() | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection()()()() | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Section Class


Section Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Section Properties
Section Class See Also Send Feedback

The Section type exposes the following members.

Properties

 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | Paragraphs | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | SectionParagraphs |
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Inherited from Container.)
Public property | Xml | (Inherited from DocXElement.)

See Also

Section Class


Section.SectionParagraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Section..::..SectionParagraphs Property
Section Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Section.SectionParagraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Paragraph> SectionParagraphs { get; set; }
Visual Basic
Public Property SectionParagraphs As List(Of Paragraph)
    Get
    Set
Visual C++
public:
property List<Paragraph^>^ SectionParagraphs {
    List<Paragraph^>^ get ();
    void set (List<Paragraph^>^ value);
}
F#
member SectionParagraphs : List<Paragraph> with get, set

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

Section Class
Section Members


SectionBreakType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
SectionBreakType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.SectionBreakType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum SectionBreakType
Visual Basic
Public Enumeration SectionBreakType
Visual C++
public enum class SectionBreakType
F#
type SectionBreakType

Members

Member name | Value | Description
defaultNextPage | 0 |
evenPage | 1 |
oddPage | 2 |
continuous | 3 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Series Class

[image]

DocX - A Sandcastle Documented Class Library
Series Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Series"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Series
Visual Basic
Public Class Series
Visual C++
public ref class Series
F#
type Series =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..Series

See Also

Series Members


Series Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Series Members
Series Class Constructors Methods Properties See Also Send Feedback

The Series type exposes the following members.

Constructors

 | Name | Description
Public method | Series | Initializes a new instance of the Series class

Methods

 | Name | Description
Public method | Bind(IList, IList) |
Public method | Bind(ICollection, String, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color |

See Also

Series Class


Series Constructor

[image]

DocX - A Sandcastle Documented Class Library
Series Constructor
Series Class See Also Send Feedback
Initializes a new instance of the Series class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Series(
    string name
)
Visual Basic
Public Sub New (
    name As String
)
Visual C++
public:
Series(
    String^ name
)
F#
new :
        name : string -> Series

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Novacode.Series.#ctor(System.String)"]

See Also

Series Class
Series Members


Series Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Series Methods
Series Class See Also Send Feedback

The Series type exposes the following members.

Methods

 | Name | Description
Public method | Bind(IList, IList) |
Public method | Bind(ICollection, String, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Series Class


Series.Bind Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Series..::..Bind Method
Series Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Bind(IList, IList) |
Public method | Bind(ICollection, String, String) |

See Also

Series Class
Series Members


Series.Bind Method (IList, IList)

[image]

DocX - A Sandcastle Documented Class Library
Series..::..Bind Method (IList, IList)
Series Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Series.Bind(System.Collections.IList,System.Collections.IList)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Bind(
    IList categories,
    IList values
)
Visual Basic
Public Sub Bind (
    categories As IList,
    values As IList
)
Visual C++
public:
void Bind(
    IList^ categories,
    IList^ values
)
F#
member Bind :
        categories : IList *
        values : IList -> unit

Parameters

categories
Type: System.Collections..::..IList

[Missing <param name="categories"/> documentation for "M:Novacode.Series.Bind(System.Collections.IList,System.Collections.IList)"]

values
Type: System.Collections..::..IList

[Missing <param name="values"/> documentation for "M:Novacode.Series.Bind(System.Collections.IList,System.Collections.IList)"]

See Also

Series Class
Series Members
Bind Overload


Series.Bind Method (ICollection, String, String)

[image]

DocX - A Sandcastle Documented Class Library
Series..::..Bind Method (ICollection, String, String)
Series Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Bind(
    ICollection list,
    string categoryPropertyName,
    string valuePropertyName
)
Visual Basic
Public Sub Bind (
    list As ICollection,
    categoryPropertyName As String,
    valuePropertyName As String
)
Visual C++
public:
void Bind(
    ICollection^ list,
    String^ categoryPropertyName,
    String^ valuePropertyName
)
F#
member Bind :
        list : ICollection *
        categoryPropertyName : string *
        valuePropertyName : string -> unit

Parameters

list
Type: System.Collections..::..ICollection

[Missing <param name="list"/> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

categoryPropertyName
Type: System..::..String

[Missing <param name="categoryPropertyName"/> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

valuePropertyName
Type: System..::..String

[Missing <param name="valuePropertyName"/> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

See Also

Series Class
Series Members
Bind Overload


Series Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Series Properties
Series Class See Also Send Feedback

The Series type exposes the following members.

Properties

 | Name | Description
Public property | Color |

See Also

Series Class


Series.Color Property

[image]

DocX - A Sandcastle Documented Class Library
Series..::..Color Property
Series Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Series.Color"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}
F#
member Color : Color with get, set

Property Value

Type: Color

See Also

Series Class
Series Members


StarAndBannerShapes Enumeration

[image]

DocX - A Sandcastle Documented Class Library
StarAndBannerShapes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.StarAndBannerShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum StarAndBannerShapes
Visual Basic
Public Enumeration StarAndBannerShapes
Visual C++
public enum class StarAndBannerShapes
F#
type StarAndBannerShapes

Members

Member name | Value | Description
irregularSeal1 | 0 |
irregularSeal2 | 1 |
star4 | 2 |
star5 | 3 |
star6 | 4 |
star7 | 5 |
star8 | 6 |
star10 | 7 |
star12 | 8 |
star16 | 9 |
star24 | 10 |
star32 | 11 |
ribbon | 12 |
ribbon2 | 13 |
ellipseRibbon | 14 |
ellipseRibbon2 | 15 |
verticalScroll | 16 |
horizontalScroll | 17 |
wave | 18 |
doubleWave | 19 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


StrikeThrough Enumeration

[image]

DocX - A Sandcastle Documented Class Library
StrikeThrough Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.StrikeThrough"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum StrikeThrough
Visual Basic
Public Enumeration StrikeThrough
Visual C++
public enum class StrikeThrough
F#
type StrikeThrough

Members

Member name | Value | Description
none | 0 |
strike | 1 |
doubleStrike | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


Table Class

[image]

DocX - A Sandcastle Documented Class Library
Table Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.Table"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class Table : InsertBeforeOrAfter
Visual Basic
Public Class Table
    Inherits InsertBeforeOrAfter
Visual C++
public ref class Table : public InsertBeforeOrAfter
F#
type Table =
    class
        inherit InsertBeforeOrAfter
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..DocXElement
Novacode..::..InsertBeforeOrAfter
Novacode..::..Table

See Also

Table Members


Table Members

[image] [image]

DocX - A Sandcastle Documented Class Library
Table Members
Table Class Methods Properties See Also Send Feedback

The Table type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBorder |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertColumn()()()() |
Public method | InsertColumn(Int32) |
Public method | InsertPageBreakAfterSelf | (Overrides InsertBeforeOrAfter..::..InsertPageBreakAfterSelf()()()().)
Public method | InsertPageBreakBeforeSelf | (Overrides InsertBeforeOrAfter..::..InsertPageBreakBeforeSelf()()()().)
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertRow()()()() |
Public method | InsertRow(Int32) |
Public method | InsertRow(Row) |
Public method | InsertRow(Row, Int32) |
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCellsInColumn |
Public method | Remove |
Public method | RemoveColumn()()()() |
Public method | RemoveColumn(Int32) |
Public method | RemoveRow()()()() |
Public method | RemoveRow(Int32) |
Public method | SetBorder |
Public method | SetDirection |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Alignment |
Public property | AutoFit |
Public property | ColumnCount |
Public property | CustomTableDesignName |
Public property | Design |
Public property | Hyperlinks |
Public property | Index |
Public property | Paragraphs |
Public property | Pictures |
Public property | RowCount |
Public property | Rows |
Public property | TableCaption |
Public property | TableDescription |
Public property | TableLook |
Public property | Xml | (Inherited from DocXElement.)

See Also

Table Class


Table Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
Table Methods
Table Class See Also Send Feedback

The Table type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBorder |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertColumn()()()() |
Public method | InsertColumn(Int32) |
Public method | InsertPageBreakAfterSelf | (Overrides InsertBeforeOrAfter..::..InsertPageBreakAfterSelf()()()().)
Public method | InsertPageBreakBeforeSelf | (Overrides InsertBeforeOrAfter..::..InsertPageBreakBeforeSelf()()()().)
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertRow()()()() |
Public method | InsertRow(Int32) |
Public method | InsertRow(Row) |
Public method | InsertRow(Row, Int32) |
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCellsInColumn |
Public method | Remove |
Public method | RemoveColumn()()()() |
Public method | RemoveColumn(Int32) |
Public method | RemoveRow()()()() |
Public method | RemoveRow(Int32) |
Public method | SetBorder |
Public method | SetDirection |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Table Class


Table.GetBorder Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..GetBorder Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.GetBorder(Novacode.TableBorderType)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Border GetBorder(
    TableBorderType borderType
)
Visual Basic
Public Function GetBorder (
    borderType As TableBorderType
) As Border
Visual C++
public:
Border^ GetBorder(
    TableBorderType borderType
)
F#
member GetBorder :
        borderType : TableBorderType -> Border

Parameters

borderType
Type: Novacode..::..TableBorderType

[Missing <param name="borderType"/> documentation for "M:Novacode.Table.GetBorder(Novacode.TableBorderType)"]

Return Value

Type: Border

[Missing <returns> documentation for "M:Novacode.Table.GetBorder(Novacode.TableBorderType)"]

See Also

Table Class
Table Members


Table.InsertColumn Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertColumn Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertColumn()()()() |
Public method | InsertColumn(Int32) |

See Also

Table Class
Table Members


Table.InsertColumn Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertColumn Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertColumn"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertColumn()
Visual Basic
Public Sub InsertColumn
Visual C++
public:
void InsertColumn()
F#
member InsertColumn : unit -> unit

See Also

Table Class
Table Members
InsertColumn Overload


Table.InsertColumn Method (Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertColumn Method (Int32)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertColumn(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void InsertColumn(
    int index
)
Visual Basic
Public Sub InsertColumn (
    index As Integer
)
Visual C++
public:
void InsertColumn(
    int index
)
F#
member InsertColumn :
        index : int -> unit

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Table.InsertColumn(System.Int32)"]

See Also

Table Class
Table Members
InsertColumn Overload


Table.InsertPageBreakAfterSelf Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertPageBreakAfterSelf Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertPageBreakAfterSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override void InsertPageBreakAfterSelf()
Visual Basic
Public Overrides Sub InsertPageBreakAfterSelf
Visual C++
public:
virtual void InsertPageBreakAfterSelf() override
F#
abstract InsertPageBreakAfterSelf : unit -> unit
override InsertPageBreakAfterSelf : unit -> unit

See Also

Table Class
Table Members


Table.InsertPageBreakBeforeSelf Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertPageBreakBeforeSelf Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertPageBreakBeforeSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override void InsertPageBreakBeforeSelf()
Visual Basic
Public Overrides Sub InsertPageBreakBeforeSelf
Visual C++
public:
virtual void InsertPageBreakBeforeSelf() override
F#
abstract InsertPageBreakBeforeSelf : unit -> unit
override InsertPageBreakBeforeSelf : unit -> unit

See Also

Table Class
Table Members


Table.InsertParagraphAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphAfterSelf Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphAfterSelf(String, Boolean, Formatting).)

See Also

Table Class
Table Members


Table.InsertParagraphAfterSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphAfterSelf Method (String)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text
) override
F#
abstract InsertParagraphAfterSelf :
        text : string -> Paragraph
override InsertParagraphAfterSelf :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String)"]

See Also

Table Class
Table Members
InsertParagraphAfterSelf Overload


Table.InsertParagraphAfterSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphAfterSelf Method (Paragraph)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    Paragraph^ p
) override
F#
abstract InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph
override InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(Novacode.Paragraph)"]

See Also

Table Class
Table Members
InsertParagraphAfterSelf Overload


Table.InsertParagraphAfterSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphAfterSelf Method (String, Boolean)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges
) override
F#
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean)"]

See Also

Table Class
Table Members
InsertParagraphAfterSelf Overload


Table.InsertParagraphAfterSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphAfterSelf Method (String, Boolean, Formatting)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
F#
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Table Class
Table Members
InsertParagraphAfterSelf Overload


Table.InsertParagraphBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphBeforeSelf Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfter..::..InsertParagraphBeforeSelf(String, Boolean, Formatting).)

See Also

Table Class
Table Members


Table.InsertParagraphBeforeSelf Method (String)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphBeforeSelf Method (String)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text
) override
F#
abstract InsertParagraphBeforeSelf :
        text : string -> Paragraph
override InsertParagraphBeforeSelf :
        text : string -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String)"]

See Also

Table Class
Table Members
InsertParagraphBeforeSelf Overload


Table.InsertParagraphBeforeSelf Method (Paragraph)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphBeforeSelf Method (Paragraph)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    Paragraph p
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    p As Paragraph
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    Paragraph^ p
) override
F#
abstract InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph
override InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: Novacode..::..Paragraph

[Missing <param name="p"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

See Also

Table Class
Table Members
InsertParagraphBeforeSelf Overload


Table.InsertParagraphBeforeSelf Method (String, Boolean)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphBeforeSelf Method (String, Boolean)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges
) override
F#
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

See Also

Table Class
Table Members
InsertParagraphBeforeSelf Overload


Table.InsertParagraphBeforeSelf Method (String, Boolean, Formatting)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertParagraphBeforeSelf Method (String, Boolean, Formatting)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Visual Basic
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
Visual C++
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
F#
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: System..::..Boolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: Novacode..::..Formatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Table Class
Table Members
InsertParagraphBeforeSelf Overload


Table.InsertRow Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertRow Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertRow()()()() |
Public method | InsertRow(Int32) |
Public method | InsertRow(Row) |
Public method | InsertRow(Row, Int32) |

See Also

Table Class
Table Members


Table.InsertRow Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertRow Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertRow"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Row InsertRow()
Visual Basic
Public Function InsertRow As Row
Visual C++
public:
Row^ InsertRow()
F#
member InsertRow : unit -> Row

Return Value

Type: Row

[Missing <returns> documentation for "M:Novacode.Table.InsertRow"]

See Also

Table Class
Table Members
InsertRow Overload


Table.InsertRow Method (Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertRow Method (Int32)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertRow(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Row InsertRow(
    int index
)
Visual Basic
Public Function InsertRow (
    index As Integer
) As Row
Visual C++
public:
Row^ InsertRow(
    int index
)
F#
member InsertRow :
        index : int -> Row

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Table.InsertRow(System.Int32)"]

Return Value

Type: Row

[Missing <returns> documentation for "M:Novacode.Table.InsertRow(System.Int32)"]

See Also

Table Class
Table Members
InsertRow Overload


Table.InsertRow Method (Row)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertRow Method (Row)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertRow(Novacode.Row)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Row InsertRow(
    Row row
)
Visual Basic
Public Function InsertRow (
    row As Row
) As Row
Visual C++
public:
Row^ InsertRow(
    Row^ row
)
F#
member InsertRow :
        row : Row -> Row

Parameters

row
Type: Novacode..::..Row

[Missing <param name="row"/> documentation for "M:Novacode.Table.InsertRow(Novacode.Row)"]

Return Value

Type: Row

[Missing <returns> documentation for "M:Novacode.Table.InsertRow(Novacode.Row)"]

See Also

Table Class
Table Members
InsertRow Overload


Table.InsertRow Method (Row, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertRow Method (Row, Int32)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertRow(Novacode.Row,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Row InsertRow(
    Row row,
    int index
)
Visual Basic
Public Function InsertRow (
    row As Row,
    index As Integer
) As Row
Visual C++
public:
Row^ InsertRow(
    Row^ row,
    int index
)
F#
member InsertRow :
        row : Row *
        index : int -> Row

Parameters

row
Type: Novacode..::..Row

[Missing <param name="row"/> documentation for "M:Novacode.Table.InsertRow(Novacode.Row,System.Int32)"]

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Table.InsertRow(Novacode.Row,System.Int32)"]

Return Value

Type: Row

[Missing <returns> documentation for "M:Novacode.Table.InsertRow(Novacode.Row,System.Int32)"]

See Also

Table Class
Table Members
InsertRow Overload


Table.InsertTableAfterSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableAfterSelf Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableAfterSelf(Int32, Int32).)

See Also

Table Class
Table Members


Table.InsertTableAfterSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableAfterSelf Method (Table)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertTableAfterSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableAfterSelf(
    Table t
)
Visual Basic
Public Overrides Function InsertTableAfterSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    Table^ t
) override
F#
abstract InsertTableAfterSelf :
        t : Table -> Table
override InsertTableAfterSelf :
        t : Table -> Table

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Table.InsertTableAfterSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Table.InsertTableAfterSelf(Novacode.Table)"]

See Also

Table Class
Table Members
InsertTableAfterSelf Overload


Table.InsertTableAfterSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableAfterSelf Method (Int32, Int32)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertTableAfterSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overrides Function InsertTableAfterSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableAfterSelf(
    int rowCount,
    int columnCount
) override
F#
abstract InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Table.InsertTableAfterSelf(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Table.InsertTableAfterSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Table.InsertTableAfterSelf(System.Int32,System.Int32)"]

See Also

Table Class
Table Members
InsertTableAfterSelf Overload


Table.InsertTableBeforeSelf Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableBeforeSelf Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfter..::..InsertTableBeforeSelf(Int32, Int32).)

See Also

Table Class
Table Members


Table.InsertTableBeforeSelf Method (Table)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableBeforeSelf Method (Table)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertTableBeforeSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableBeforeSelf(
    Table t
)
Visual Basic
Public Overrides Function InsertTableBeforeSelf (
    t As Table
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    Table^ t
) override
F#
abstract InsertTableBeforeSelf :
        t : Table -> Table
override InsertTableBeforeSelf :
        t : Table -> Table

Parameters

t
Type: Novacode..::..Table

[Missing <param name="t"/> documentation for "M:Novacode.Table.InsertTableBeforeSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Table.InsertTableBeforeSelf(Novacode.Table)"]

See Also

Table Class
Table Members
InsertTableBeforeSelf Overload


Table.InsertTableBeforeSelf Method (Int32, Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..InsertTableBeforeSelf Method (Int32, Int32)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public override Table InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
Visual Basic
Public Overrides Function InsertTableBeforeSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
Visual C++
public:
virtual Table^ InsertTableBeforeSelf(
    int rowCount,
    int columnCount
) override
F#
abstract InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: System..::..Int32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Table.InsertTableBeforeSelf(System.Int32,System.Int32)"]

columnCount
Type: System..::..Int32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Table.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Table.InsertTableBeforeSelf(System.Int32,System.Int32)"]

See Also

Table Class
Table Members
InsertTableBeforeSelf Overload


Table.MergeCellsInColumn Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..MergeCellsInColumn Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void MergeCellsInColumn(
    int columnIndex,
    int startRow,
    int endRow
)
Visual Basic
Public Sub MergeCellsInColumn (
    columnIndex As Integer,
    startRow As Integer,
    endRow As Integer
)
Visual C++
public:
void MergeCellsInColumn(
    int columnIndex,
    int startRow,
    int endRow
)
F#
member MergeCellsInColumn :
        columnIndex : int *
        startRow : int *
        endRow : int -> unit

Parameters

columnIndex
Type: System..::..Int32

[Missing <param name="columnIndex"/> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

startRow
Type: System..::..Int32

[Missing <param name="startRow"/> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

endRow
Type: System..::..Int32

[Missing <param name="endRow"/> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

See Also

Table Class
Table Members


Table.Remove Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Remove Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.Remove"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void Remove()
Visual Basic
Public Sub Remove
Visual C++
public:
void Remove()
F#
member Remove : unit -> unit

See Also

Table Class
Table Members


Table.RemoveColumn Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveColumn Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveColumn()()()() |
Public method | RemoveColumn(Int32) |

See Also

Table Class
Table Members


Table.RemoveColumn Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveColumn Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.RemoveColumn"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveColumn()
Visual Basic
Public Sub RemoveColumn
Visual C++
public:
void RemoveColumn()
F#
member RemoveColumn : unit -> unit

See Also

Table Class
Table Members
RemoveColumn Overload


Table.RemoveColumn Method (Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveColumn Method (Int32)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.RemoveColumn(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveColumn(
    int index
)
Visual Basic
Public Sub RemoveColumn (
    index As Integer
)
Visual C++
public:
void RemoveColumn(
    int index
)
F#
member RemoveColumn :
        index : int -> unit

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Table.RemoveColumn(System.Int32)"]

See Also

Table Class
Table Members
RemoveColumn Overload


Table.RemoveRow Method

[image] [image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveRow Method
Table Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveRow()()()() |
Public method | RemoveRow(Int32) |

See Also

Table Class
Table Members


Table.RemoveRow Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveRow Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.RemoveRow"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveRow()
Visual Basic
Public Sub RemoveRow
Visual C++
public:
void RemoveRow()
F#
member RemoveRow : unit -> unit

See Also

Table Class
Table Members
RemoveRow Overload


Table.RemoveRow Method (Int32)

[image]

DocX - A Sandcastle Documented Class Library
Table..::..RemoveRow Method (Int32)
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.RemoveRow(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void RemoveRow(
    int index
)
Visual Basic
Public Sub RemoveRow (
    index As Integer
)
Visual C++
public:
void RemoveRow(
    int index
)
F#
member RemoveRow :
        index : int -> unit

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Novacode.Table.RemoveRow(System.Int32)"]

See Also

Table Class
Table Members
RemoveRow Overload


Table.SetBorder Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..SetBorder Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.SetBorder(Novacode.TableBorderType,Novacode.Border)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetBorder(
    TableBorderType borderType,
    Border border
)
Visual Basic
Public Sub SetBorder (
    borderType As TableBorderType,
    border As Border
)
Visual C++
public:
void SetBorder(
    TableBorderType borderType,
    Border^ border
)
F#
member SetBorder :
        borderType : TableBorderType *
        border : Border -> unit

Parameters

borderType
Type: Novacode..::..TableBorderType

[Missing <param name="borderType"/> documentation for "M:Novacode.Table.SetBorder(Novacode.TableBorderType,Novacode.Border)"]

border
Type: Novacode..::..Border

[Missing <param name="border"/> documentation for "M:Novacode.Table.SetBorder(Novacode.TableBorderType,Novacode.Border)"]

See Also

Table Class
Table Members


Table.SetDirection Method

[image]

DocX - A Sandcastle Documented Class Library
Table..::..SetDirection Method
Table Class See Also Send Feedback

[Missing <summary> documentation for "M:Novacode.Table.SetDirection(Novacode.Direction)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public void SetDirection(
    Direction direction
)
Visual Basic
Public Sub SetDirection (
    direction As Direction
)
Visual C++
public:
void SetDirection(
    Direction direction
)
F#
member SetDirection :
        direction : Direction -> unit

Parameters

direction
Type: Novacode..::..Direction

[Missing <param name="direction"/> documentation for "M:Novacode.Table.SetDirection(Novacode.Direction)"]

See Also

Table Class
Table Members


Table Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
Table Properties
Table Class See Also Send Feedback

The Table type exposes the following members.

Properties

 | Name | Description
Public property | Alignment |
Public property | AutoFit |
Public property | ColumnCount |
Public property | CustomTableDesignName |
Public property | Design |
Public property | Hyperlinks |
Public property | Index |
Public property | Paragraphs |
Public property | Pictures |
Public property | RowCount |
Public property | Rows |
Public property | TableCaption |
Public property | TableDescription |
Public property | TableLook |
Public property | Xml | (Inherited from DocXElement.)

See Also

Table Class


Table.Alignment Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Alignment Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.Alignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public Alignment Alignment { get; set; }
Visual Basic
Public Property Alignment As Alignment
    Get
    Set
Visual C++
public:
property Alignment Alignment {
    Alignment get ();
    void set (Alignment value);
}
F#
member Alignment : Alignment with get, set

Property Value

Type: Alignment

See Also

Table Class
Table Members


Table.AutoFit Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..AutoFit Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.AutoFit"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public AutoFit AutoFit { get; set; }
Visual Basic
Public Property AutoFit As AutoFit
    Get
    Set
Visual C++
public:
property AutoFit AutoFit {
    AutoFit get ();
    void set (AutoFit value);
}
F#
member AutoFit : AutoFit with get, set

Property Value

Type: AutoFit

See Also

Table Class
Table Members


Table.ColumnCount Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..ColumnCount Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.ColumnCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int ColumnCount { get; }
Visual Basic
Public ReadOnly Property ColumnCount As Integer
    Get
Visual C++
public:
property int ColumnCount {
    int get ();
}
F#
member ColumnCount : int with get

Property Value

Type: Int32

See Also

Table Class
Table Members


Table.CustomTableDesignName Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..CustomTableDesignName Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.CustomTableDesignName"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string CustomTableDesignName { get; set; }
Visual Basic
Public Property CustomTableDesignName As String
    Get
    Set
Visual C++
public:
property String^ CustomTableDesignName {
    String^ get ();
    void set (String^ value);
}
F#
member CustomTableDesignName : string with get, set

Property Value

Type: String

See Also

Table Class
Table Members


Table.Design Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Design Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.Design"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public TableDesign Design { get; set; }
Visual Basic
Public Property Design As TableDesign
    Get
    Set
Visual C++
public:
property TableDesign Design {
    TableDesign get ();
    void set (TableDesign value);
}
F#
member Design : TableDesign with get, set

Property Value

Type: TableDesign

See Also

Table Class
Table Members


Table.Hyperlinks Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Hyperlinks Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.Hyperlinks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Hyperlink> Hyperlinks { get; }
Visual Basic
Public ReadOnly Property Hyperlinks As List(Of Hyperlink)
    Get
Visual C++
public:
property List<Hyperlink^>^ Hyperlinks {
    List<Hyperlink^>^ get ();
}
F#
member Hyperlinks : List<Hyperlink> with get

Property Value

Type: List <(Of <(<' Hyperlink >)>)>

See Also

Table Class
Table Members


Table.Index Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Index Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.Index"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}
F#
member Index : int with get

Property Value

Type: Int32

See Also

Table Class
Table Members


Table.Paragraphs Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Paragraphs Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public virtual List<Paragraph> Paragraphs { get; }
Visual Basic
Public Overridable ReadOnly Property Paragraphs As List(Of Paragraph)
    Get
Visual C++
public:
virtual property List<Paragraph^>^ Paragraphs {
    List<Paragraph^>^ get ();
}
F#
abstract Paragraphs : List<Paragraph> with get
override Paragraphs : List<Paragraph> with get

Property Value

Type: List <(Of <(<' Paragraph >)>)>

See Also

Table Class
Table Members


Table.Pictures Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Pictures Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.Pictures"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Picture> Pictures { get; }
Visual Basic
Public ReadOnly Property Pictures As List(Of Picture)
    Get
Visual C++
public:
property List<Picture^>^ Pictures {
    List<Picture^>^ get ();
}
F#
member Pictures : List<Picture> with get

Property Value

Type: List <(Of <(<' Picture >)>)>

See Also

Table Class
Table Members


Table.RowCount Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..RowCount Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.RowCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public int RowCount { get; }
Visual Basic
Public ReadOnly Property RowCount As Integer
    Get
Visual C++
public:
property int RowCount {
    int get ();
}
F#
member RowCount : int with get

Property Value

Type: Int32

See Also

Table Class
Table Members


Table.Rows Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..Rows Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.Rows"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public List<Row> Rows { get; }
Visual Basic
Public ReadOnly Property Rows As List(Of Row)
    Get
Visual C++
public:
property List<Row^>^ Rows {
    List<Row^>^ get ();
}
F#
member Rows : List<Row> with get

Property Value

Type: List <(Of <(<' Row >)>)>

See Also

Table Class
Table Members


Table.TableCaption Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..TableCaption Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.TableCaption"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string TableCaption { get; set; }
Visual Basic
Public Property TableCaption As String
    Get
    Set
Visual C++
public:
property String^ TableCaption {
    String^ get ();
    void set (String^ value);
}
F#
member TableCaption : string with get, set

Property Value

Type: String

See Also

Table Class
Table Members


Table.TableDescription Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..TableDescription Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.TableDescription"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public string TableDescription { get; set; }
Visual Basic
Public Property TableDescription As String
    Get
    Set
Visual C++
public:
property String^ TableDescription {
    String^ get ();
    void set (String^ value);
}
F#
member TableDescription : string with get, set

Property Value

Type: String

See Also

Table Class
Table Members


Table.TableLook Property

[image]

DocX - A Sandcastle Documented Class Library
Table..::..TableLook Property
Table Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.Table.TableLook"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public TableLook TableLook { get; set; }
Visual Basic
Public Property TableLook As TableLook
    Get
    Set
Visual C++
public:
property TableLook^ TableLook {
    TableLook^ get ();
    void set (TableLook^ value);
}
F#
member TableLook : TableLook with get, set

Property Value

Type: TableLook

See Also

Table Class
Table Members


TableBorderType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
TableBorderType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.TableBorderType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum TableBorderType
Visual Basic
Public Enumeration TableBorderType
Visual C++
public enum class TableBorderType
F#
type TableBorderType

Members

Member name | Value | Description
Top | 0 |
Bottom | 1 |
Left | 2 |
Right | 3 |
InsideH | 4 |
InsideV | 5 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


TableCellBorderType Enumeration

[image]

DocX - A Sandcastle Documented Class Library
TableCellBorderType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.TableCellBorderType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum TableCellBorderType
Visual Basic
Public Enumeration TableCellBorderType
Visual C++
public enum class TableCellBorderType
F#
type TableCellBorderType

Members

Member name | Value | Description
Top | 0 |
Bottom | 1 |
Left | 2 |
Right | 3 |
InsideH | 4 |
InsideV | 5 |
TopLeftToBottomRight | 6 |
TopRightToBottomLeft | 7 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


TableDesign Enumeration

[image]

DocX - A Sandcastle Documented Class Library
TableDesign Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.TableDesign"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum TableDesign
Visual Basic
Public Enumeration TableDesign
Visual C++
public enum class TableDesign
F#
type TableDesign

Members

Member name | Value | Description
Custom | 0 |
TableNormal | 1 |
TableGrid | 2 |
LightShading | 3 |
LightShadingAccent1 | 4 |
LightShadingAccent2 | 5 |
LightShadingAccent3 | 6 |
LightShadingAccent4 | 7 |
LightShadingAccent5 | 8 |
LightShadingAccent6 | 9 |
LightList | 10 |
LightListAccent1 | 11 |
LightListAccent2 | 12 |
LightListAccent3 | 13 |
LightListAccent4 | 14 |
LightListAccent5 | 15 |
LightListAccent6 | 16 |
LightGrid | 17 |
LightGridAccent1 | 18 |
LightGridAccent2 | 19 |
LightGridAccent3 | 20 |
LightGridAccent4 | 21 |
LightGridAccent5 | 22 |
LightGridAccent6 | 23 |
MediumShading1 | 24 |
MediumShading1Accent1 | 25 |
MediumShading1Accent2 | 26 |
MediumShading1Accent3 | 27 |
MediumShading1Accent4 | 28 |
MediumShading1Accent5 | 29 |
MediumShading1Accent6 | 30 |
MediumShading2 | 31 |
MediumShading2Accent1 | 32 |
MediumShading2Accent2 | 33 |
MediumShading2Accent3 | 34 |
MediumShading2Accent4 | 35 |
MediumShading2Accent5 | 36 |
MediumShading2Accent6 | 37 |
MediumList1 | 38 |
MediumList1Accent1 | 39 |
MediumList1Accent2 | 40 |
MediumList1Accent3 | 41 |
MediumList1Accent4 | 42 |
MediumList1Accent5 | 43 |
MediumList1Accent6 | 44 |
MediumList2 | 45 |
MediumList2Accent1 | 46 |
MediumList2Accent2 | 47 |
MediumList2Accent3 | 48 |
MediumList2Accent4 | 49 |
MediumList2Accent5 | 50 |
MediumList2Accent6 | 51 |
MediumGrid1 | 52 |
MediumGrid1Accent1 | 53 |
MediumGrid1Accent2 | 54 |
MediumGrid1Accent3 | 55 |
MediumGrid1Accent4 | 56 |
MediumGrid1Accent5 | 57 |
MediumGrid1Accent6 | 58 |
MediumGrid2 | 59 |
MediumGrid2Accent1 | 60 |
MediumGrid2Accent2 | 61 |
MediumGrid2Accent3 | 62 |
MediumGrid2Accent4 | 63 |
MediumGrid2Accent5 | 64 |
MediumGrid2Accent6 | 65 |
MediumGrid3 | 66 |
MediumGrid3Accent1 | 67 |
MediumGrid3Accent2 | 68 |
MediumGrid3Accent3 | 69 |
MediumGrid3Accent4 | 70 |
MediumGrid3Accent5 | 71 |
MediumGrid3Accent6 | 72 |
DarkList | 73 |
DarkListAccent1 | 74 |
DarkListAccent2 | 75 |
DarkListAccent3 | 76 |
DarkListAccent4 | 77 |
DarkListAccent5 | 78 |
DarkListAccent6 | 79 |
ColorfulShading | 80 |
ColorfulShadingAccent1 | 81 |
ColorfulShadingAccent2 | 82 |
ColorfulShadingAccent3 | 83 |
ColorfulShadingAccent4 | 84 |
ColorfulShadingAccent5 | 85 |
ColorfulShadingAccent6 | 86 |
ColorfulList | 87 |
ColorfulListAccent1 | 88 |
ColorfulListAccent2 | 89 |
ColorfulListAccent3 | 90 |
ColorfulListAccent4 | 91 |
ColorfulListAccent5 | 92 |
ColorfulListAccent6 | 93 |
ColorfulGrid | 94 |
ColorfulGridAccent1 | 95 |
ColorfulGridAccent2 | 96 |
ColorfulGridAccent3 | 97 |
ColorfulGridAccent4 | 98 |
ColorfulGridAccent5 | 99 |
ColorfulGridAccent6 | 100 |
None | 101 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


TableLook Class

[image]

DocX - A Sandcastle Documented Class Library
TableLook Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.TableLook"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class TableLook
Visual Basic
Public Class TableLook
Visual C++
public ref class TableLook
F#
type TableLook =  class end

Inheritance Hierarchy

System..::..Object
Novacode..::..TableLook

See Also

TableLook Members


TableLook Members

[image] [image]

DocX - A Sandcastle Documented Class Library
TableLook Members
TableLook Class Constructors Methods Properties See Also Send Feedback

The TableLook type exposes the following members.

Constructors

 | Name | Description
Public method | TableLook | Initializes a new instance of the TableLook class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FirstColumn |
Public property | FirstRow |
Public property | LastColumn |
Public property | LastRow |
Public property | NoHorizontalBanding |
Public property | NoVerticalBanding |

See Also

TableLook Class


TableLook Constructor

[image]

DocX - A Sandcastle Documented Class Library
TableLook Constructor
TableLook Class See Also Send Feedback
Initializes a new instance of the TableLook class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public TableLook()
Visual Basic
Public Sub New
Visual C++
public:
TableLook()
F#
new : unit -> TableLook

See Also

TableLook Class
TableLook Members


TableLook Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
TableLook Methods
TableLook Class See Also Send Feedback

The TableLook type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TableLook Class


TableLook Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
TableLook Properties
TableLook Class See Also Send Feedback

The TableLook type exposes the following members.

Properties

 | Name | Description
Public property | FirstColumn |
Public property | FirstRow |
Public property | LastColumn |
Public property | LastRow |
Public property | NoHorizontalBanding |
Public property | NoVerticalBanding |

See Also

TableLook Class


TableLook.FirstColumn Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..FirstColumn Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.FirstColumn"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool FirstColumn { get; set; }
Visual Basic
Public Property FirstColumn As Boolean
    Get
    Set
Visual C++
public:
property bool FirstColumn {
    bool get ();
    void set (bool value);
}
F#
member FirstColumn : bool with get, set

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


TableLook.FirstRow Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..FirstRow Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.FirstRow"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool FirstRow { get; set; }
Visual Basic
Public Property FirstRow As Boolean
    Get
    Set
Visual C++
public:
property bool FirstRow {
    bool get ();
    void set (bool value);
}
F#
member FirstRow : bool with get, set

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


TableLook.LastColumn Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..LastColumn Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.LastColumn"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool LastColumn { get; set; }
Visual Basic
Public Property LastColumn As Boolean
    Get
    Set
Visual C++
public:
property bool LastColumn {
    bool get ();
    void set (bool value);
}
F#
member LastColumn : bool with get, set

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


TableLook.LastRow Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..LastRow Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.LastRow"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool LastRow { get; set; }
Visual Basic
Public Property LastRow As Boolean
    Get
    Set
Visual C++
public:
property bool LastRow {
    bool get ();
    void set (bool value);
}
F#
member LastRow : bool with get, set

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


TableLook.NoHorizontalBanding Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..NoHorizontalBanding Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.NoHorizontalBanding"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool NoHorizontalBanding { get; set; }
Visual Basic
Public Property NoHorizontalBanding As Boolean
    Get
    Set
Visual C++
public:
property bool NoHorizontalBanding {
    bool get ();
    void set (bool value);
}
F#
member NoHorizontalBanding : bool with get, set

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


TableLook.NoVerticalBanding Property

[image]

DocX - A Sandcastle Documented Class Library
TableLook..::..NoVerticalBanding Property
TableLook Class See Also Send Feedback

[Missing <summary> documentation for "P:Novacode.TableLook.NoVerticalBanding"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public bool NoVerticalBanding { get; set; }
Visual Basic
Public Property NoVerticalBanding As Boolean
    Get
    Set
Visual C++
public:
property bool NoVerticalBanding {
    bool get ();
    void set (bool value);
}
F#
member NoVerticalBanding : bool with get, set

Property Value

Type: Boolean

See Also

TableLook Class
TableLook Members


UnderlineStyle Enumeration

[image]

DocX - A Sandcastle Documented Class Library
UnderlineStyle Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.UnderlineStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum UnderlineStyle
Visual Basic
Public Enumeration UnderlineStyle
Visual C++
public enum class UnderlineStyle
F#
type UnderlineStyle

Members

Member name | Value | Description
none | 0 |
singleLine | 1 |
doubleLine | 2 |
thick | 3 |
dotted | 4 |
dottedHeavy | 5 |
dash | 6 |
dashedHeavy | 7 |
dashLong | 8 |
dashLongHeavy | 9 |
dotDash | 10 |
dashDotHeavy | 11 |
dotDotDash | 12 |
dashDotDotHeavy | 13 |
wave | 14 |
wavyHeavy | 15 |
wavyDouble | 16 |
words | 17 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


ValueAxis Class

[image]

DocX - A Sandcastle Documented Class Library
ValueAxis Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.ValueAxis"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public class ValueAxis : Axis
Visual Basic
Public Class ValueAxis
    Inherits Axis
Visual C++
public ref class ValueAxis : public Axis
F#
type ValueAxis =
    class
        inherit Axis
    end

Inheritance Hierarchy

System..::..Object
Novacode..::..Axis
Novacode..::..ValueAxis

See Also

ValueAxis Members


ValueAxis Members

[image] [image]

DocX - A Sandcastle Documented Class Library
ValueAxis Members
ValueAxis Class Constructors Methods Properties See Also Send Feedback

The ValueAxis type exposes the following members.

Constructors

 | Name | Description
Public method | ValueAxis | Initializes a new instance of the ValueAxis class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | (Inherited from Axis.)
Public property | IsVisible | (Inherited from Axis.)

See Also

ValueAxis Class


ValueAxis Constructor

[image]

DocX - A Sandcastle Documented Class Library
ValueAxis Constructor
ValueAxis Class See Also Send Feedback
Initializes a new instance of the ValueAxis class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public ValueAxis(
    string id
)
Visual Basic
Public Sub New (
    id As String
)
Visual C++
public:
ValueAxis(
    String^ id
)
F#
new :
        id : string -> ValueAxis

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:Novacode.ValueAxis.#ctor(System.String)"]

See Also

ValueAxis Class
ValueAxis Members


ValueAxis Methods

[image] [image]

DocX - A Sandcastle Documented Class Library
ValueAxis Methods
ValueAxis Class See Also Send Feedback

The ValueAxis type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValueAxis Class


ValueAxis Properties

[image] [image]

DocX - A Sandcastle Documented Class Library
ValueAxis Properties
ValueAxis Class See Also Send Feedback

The ValueAxis type exposes the following members.

Properties

 | Name | Description
Public property | Id | (Inherited from Axis.)
Public property | IsVisible | (Inherited from Axis.)

See Also

ValueAxis Class


VerticalAlignment Enumeration

[image]

DocX - A Sandcastle Documented Class Library
VerticalAlignment Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.VerticalAlignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum VerticalAlignment
Visual Basic
Public Enumeration VerticalAlignment
Visual C++
public enum class VerticalAlignment
F#
type VerticalAlignment

Members

Member name | Value | Description
Top | 0 |
Center | 1 |
Bottom | 2 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com


XmlDocument Enumeration

[image]

DocX - A Sandcastle Documented Class Library
XmlDocument Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Novacode.XmlDocument"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.1.13 (1.0.1.13)

Syntax

C#
public enum XmlDocument
Visual Basic
Public Enumeration XmlDocument
Visual C++
public enum class XmlDocument
F#
type XmlDocument

Members

Member name | Value | Description
Main | 0 |
HeaderOdd | 1 |
HeaderEven | 2 |
HeaderFirst | 3 |
FooterOdd | 4 |
FooterEven | 5 |
FooterFirst | 6 |

See Also

Novacode Namespace

Send comments on this topic to coffey.cathal@gmail.com