Novacode Namespace

DocX - A Sandcastle Documented Class Library
Novacode Namespace

[Missing <summary> documentation for "N:Novacode"]

Classes
 | Class | Description
Public class | Axis |
Public class | BarChart |
Public class | Bookmark |
Public class | BookmarkCollection |
Public class | Border |
Public class | CategoryAxis |
Public class | Cell |
Public class | Chart |
Public class | ChartLegend |
Public class | Container |
Public class | CustomProperty |
Public class | DocProperty |
Public class | DocX |
Public class | DocXElement |
Public class | ExtensionsHeadings |
Public class | Footer |
Public class | Footers |
Public class | FormattedText |
Public class | Formatting |
Public class | Header |
Public class | Headers |
Public class | Hyperlink |
Public class | Image |
Public class | InsertBeforeOrAfter |
Public class | LineChart |
Public class | List |
Public class | PageLayout |
Public class | Paragraph |
Public class | Picture |
Public class | PieChart |
Public class | Row |
Public class | Run |
Public class | Section |
Public class | Series |
Public class | Table |
Public class | TableLook |
Public class | TableOfContents |
Public class | ValueAxis |
Public class | XmlTemplateBases |
Interfaces
 | Interface | Description
Public interface | IParagraphContainer |
Enumerations
 | Enumeration | Description
Public enumeration | Alignment |
Public enumeration | AutoFit |
Public enumeration | BarDirection |
Public enumeration | BarGrouping |
Public enumeration | BasicShapes |
Public enumeration | BlockArrowShapes |
Public enumeration | BorderSize |
Public enumeration | BorderStyle |
Public enumeration | CalloutShapes |
Public enumeration | CapsStyle |
Public enumeration | ChartLegendPosition |
Public enumeration | ContainerType |
Public enumeration | Direction |
Public enumeration | DisplayBlanksAs |
Public enumeration | DocumentTypes |
Public enumeration | EditRestrictions |
Public enumeration | EquationShapes |
Public enumeration | FlowchartShapes |
Public enumeration | Grouping |
Public enumeration | HeadingType |
Public enumeration | Highlight |
Public enumeration | LineSpacingType |
Public enumeration | LineSpacingTypeAuto |
Public enumeration | ListItemType |
Public enumeration | MatchFormattingOptions |
Public enumeration | Misc |
Public enumeration | Orientation |
Public enumeration | PageNumberFormat |
Public enumeration | RectangleShapes |
Public enumeration | RunTextType |
Public enumeration | Script |
Public enumeration | SectionBreakType |
Public enumeration | StarAndBannerShapes |
Public enumeration | StrikeThrough |
Public enumeration | TableBorderType |
Public enumeration | TableCellBorderType |
Public enumeration | TableDesign |
Public enumeration | TableOfContentsSwitches |
Public enumeration | TextDirection |
Public enumeration | UnderlineStyle |
Public enumeration | VerticalAlignment |
Public enumeration | XmlDocument |
Send comments on this topic to coffey.cathal@gmail.com


Alignment Enumeration

Alignment Enumeration

[Missing <summary> documentation for "T:Novacode.Alignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum Alignment
Public Enumeration Alignment
public enum class Alignment
type Alignment
Members
Member name | Value | Description
left | 0 |
center | 1 |
right | 2 |
both | 3 |
See Also

Reference

Novacode Namespace


AutoFit Enumeration

AutoFit Enumeration

[Missing <summary> documentation for "T:Novacode.AutoFit"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum AutoFit
Public Enumeration AutoFit
public enum class AutoFit
type AutoFit
Members
Member name | Value | Description
Contents | 0 |
Window | 1 |
ColumnWidth | 2 |
Fixed | 3 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Axis Class

Axis Class

[Missing <summary> documentation for "T:Novacode.Axis"]

Inheritance Hierarchy
SystemObject
NovacodeAxis
NovacodeCategoryAxis
NovacodeValueAxis

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public abstract class Axis
Public MustInherit Class Axis
public ref class Axis abstract
[<AbstractClassAttribute>]
type Axis =  class end

The Axis type exposes the following members.

Constructors
 | Name | Description
Public method | Axis | Initializes a new instance of the Axis class
Top
Properties
 | Name | Description
Public property | Id |
Public property | IsVisible |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Axis Constructor

Axis Constructor
Initializes a new instance of the Axis class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Axis(
    string id
)
Public Sub New (
    id As String
)
public:
Axis(
    String^ id
)
new :
        id : string -> Axis

Parameters

id
Type: SystemString

[Missing <param name="id"/> documentation for "M:Novacode.Axis.#ctor(System.String)"]

See Also

Reference

Axis Class


Axis Properties

Axis Properties

The Axis type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | IsVisible |
Top
See Also

Reference

Axis Class


Axis.Id Property

AxisId Property

[Missing <summary> documentation for "P:Novacode.Axis.Id"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get
public:
property String^ Id {
    String^ get ();
}
member Id : string with get

Property Value

Type: String
See Also

Reference

Axis Class


Axis.IsVisible Property

AxisIsVisible Property

[Missing <summary> documentation for "P:Novacode.Axis.IsVisible"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool IsVisible { get; set; }
Public Property IsVisible As Boolean
    Get
    Set
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
member IsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Axis Class


Axis Methods

Axis Methods

The Axis type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Axis Class


BarChart Class

BarChart Class

[Missing <summary> documentation for "T:Novacode.BarChart"]

Inheritance Hierarchy
SystemObject
NovacodeChart
NovacodeBarChart

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class BarChart : Chart
Public Class BarChart
    Inherits Chart
public ref class BarChart : public Chart
type BarChart =
    class
        inherit Chart
    end

The BarChart type exposes the following members.

Constructors
 | Name | Description
Public method | BarChart | Initializes a new instance of the BarChart class
Top
Properties
 | Name | Description
Public property | BarDirection |
Public property | BarGrouping |
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | GapWidth |
Public property | IsAxisExist | (Inherited from Chart.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Inherited from Chart.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)
Top
Methods
 | Name | Description
Public method | AddLegend | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides ChartCreateChartXml.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


BarChart Constructor

BarChart Constructor
Initializes a new instance of the BarChart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public BarChart()
Public Sub New
public:
BarChart()
new : unit -> BarChart
See Also

Reference

BarChart Class


BarChart Properties

BarChart Properties

The BarChart type exposes the following members.

Properties
 | Name | Description
Public property | BarDirection |
Public property | BarGrouping |
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | GapWidth |
Public property | IsAxisExist | (Inherited from Chart.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Inherited from Chart.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)
Top
See Also

Reference

BarChart Class


BarChart.BarDirection Property

BarChartBarDirection Property

[Missing <summary> documentation for "P:Novacode.BarChart.BarDirection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public BarDirection BarDirection { get; set; }
Public Property BarDirection As BarDirection
    Get
    Set
public:
property BarDirection BarDirection {
    BarDirection get ();
    void set (BarDirection value);
}
member BarDirection : BarDirection with get, set

Property Value

Type: BarDirection
See Also

Reference

BarChart Class


BarChart.BarGrouping Property

BarChartBarGrouping Property

[Missing <summary> documentation for "P:Novacode.BarChart.BarGrouping"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public BarGrouping BarGrouping { get; set; }
Public Property BarGrouping As BarGrouping
    Get
    Set
public:
property BarGrouping BarGrouping {
    BarGrouping get ();
    void set (BarGrouping value);
}
member BarGrouping : BarGrouping with get, set

Property Value

Type: BarGrouping
See Also

Reference

BarChart Class


BarChart.GapWidth Property

BarChartGapWidth Property

[Missing <summary> documentation for "P:Novacode.BarChart.GapWidth"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int GapWidth { get; set; }
Public Property GapWidth As Integer
    Get
    Set
public:
property int GapWidth {
    int get ();
    void set (int value);
}
member GapWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

BarChart Class


BarChart Methods

BarChart Methods

The BarChart type exposes the following members.

Methods
 | Name | Description
Public method | AddLegend | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides ChartCreateChartXml.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BarChart Class


BarChart.CreateChartXml Method

BarChartCreateChartXml Method

[Missing <summary> documentation for "M:Novacode.BarChart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
protected override XElement CreateChartXml()
Protected Overrides Function CreateChartXml As XElement
protected:
virtual XElement^ CreateChartXml() override
abstract CreateChartXml : unit -> XElement
override CreateChartXml : unit -> XElement

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.BarChart.CreateChartXml"]

See Also

Reference

BarChart Class


BarDirection Enumeration

BarDirection Enumeration

[Missing <summary> documentation for "T:Novacode.BarDirection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum BarDirection
Public Enumeration BarDirection
public enum class BarDirection
type BarDirection
Members
Member name | Value | Description
Column | 0 |
Bar | 1 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


BarGrouping Enumeration

BarGrouping Enumeration

[Missing <summary> documentation for "T:Novacode.BarGrouping"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum BarGrouping
Public Enumeration BarGrouping
public enum class BarGrouping
type BarGrouping
Members
Member name | Value | Description
Clustered | 0 |
PercentStacked | 1 |
Stacked | 2 |
Standard | 3 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


BasicShapes Enumeration

BasicShapes Enumeration

[Missing <summary> documentation for "T:Novacode.BasicShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum BasicShapes
Public Enumeration BasicShapes
public enum class BasicShapes
type BasicShapes
Members
Member name | Value | Description
ellipse | 0 |
triangle | 1 |
rtTriangle | 2 |
parallelogram | 3 |
trapezoid | 4 |
diamond | 5 |
pentagon | 6 |
hexagon | 7 |
heptagon | 8 |
octagon | 9 |
decagon | 10 |
dodecagon | 11 |
pie | 12 |
chord | 13 |
teardrop | 14 |
frame | 15 |
halfFrame | 16 |
corner | 17 |
diagStripe | 18 |
plus | 19 |
plaque | 20 |
can | 21 |
cube | 22 |
bevel | 23 |
donut | 24 |
noSmoking | 25 |
blockArc | 26 |
foldedCorner | 27 |
smileyFace | 28 |
heart | 29 |
lightningBolt | 30 |
sun | 31 |
moon | 32 |
cloud | 33 |
arc | 34 |
backetPair | 35 |
bracePair | 36 |
leftBracket | 37 |
rightBracket | 38 |
leftBrace | 39 |
rightBrace | 40 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


BlockArrowShapes Enumeration

BlockArrowShapes Enumeration

[Missing <summary> documentation for "T:Novacode.BlockArrowShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum BlockArrowShapes
Public Enumeration BlockArrowShapes
public enum class BlockArrowShapes
type BlockArrowShapes
Members
Member name | Value | Description
rightArrow | 0 |
leftArrow | 1 |
upArrow | 2 |
downArrow | 3 |
leftRightArrow | 4 |
upDownArrow | 5 |
quadArrow | 6 |
leftRightUpArrow | 7 |
bentArrow | 8 |
uturnArrow | 9 |
leftUpArrow | 10 |
bentUpArrow | 11 |
curvedRightArrow | 12 |
curvedLeftArrow | 13 |
curvedUpArrow | 14 |
curvedDownArrow | 15 |
stripedRightArrow | 16 |
notchedRightArrow | 17 |
homePlate | 18 |
chevron | 19 |
rightArrowCallout | 20 |
downArrowCallout | 21 |
leftArrowCallout | 22 |
upArrowCallout | 23 |
leftRightArrowCallout | 24 |
quadArrowCallout | 25 |
circularArrow | 26 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Bookmark Class

Bookmark Class

[Missing <summary> documentation for "T:Novacode.Bookmark"]

Inheritance Hierarchy
SystemObject
NovacodeBookmark

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Bookmark
Public Class Bookmark
public ref class Bookmark
type Bookmark =  class end

The Bookmark type exposes the following members.

Constructors
 | Name | Description
Public method | Bookmark | Initializes a new instance of the Bookmark class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Paragraph |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetText |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Bookmark Constructor

Bookmark Constructor
Initializes a new instance of the Bookmark class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Bookmark()
Public Sub New
public:
Bookmark()
new : unit -> Bookmark
See Also

Reference

Bookmark Class


Bookmark Properties

Bookmark Properties

The Bookmark type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Paragraph |
Top
See Also

Reference

Bookmark Class


Bookmark.Name Property

BookmarkName Property

[Missing <summary> documentation for "P:Novacode.Bookmark.Name"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

Bookmark Class


Bookmark.Paragraph Property

BookmarkParagraph Property

[Missing <summary> documentation for "P:Novacode.Bookmark.Paragraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Paragraph { get; set; }
Public Property Paragraph As Paragraph
    Get
    Set
public:
property Paragraph^ Paragraph {
    Paragraph^ get ();
    void set (Paragraph^ value);
}
member Paragraph : Paragraph with get, set

Property Value

Type: Paragraph
See Also

Reference

Bookmark Class


Bookmark Methods

Bookmark Methods

The Bookmark type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetText |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bookmark Class


Bookmark.SetText Method

BookmarkSetText Method

[Missing <summary> documentation for "M:Novacode.Bookmark.SetText(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetText(
    string newText
)
Public Sub SetText (
    newText As String
)
public:
void SetText(
    String^ newText
)
member SetText :
        newText : string -> unit

Parameters

newText
Type: SystemString

[Missing <param name="newText"/> documentation for "M:Novacode.Bookmark.SetText(System.String)"]

See Also

Reference

Bookmark Class


BookmarkCollection Class

BookmarkCollection Class

[Missing <summary> documentation for "T:Novacode.BookmarkCollection"]

Inheritance Hierarchy
SystemObject
System.Collections.GenericList Bookmark
NovacodeBookmarkCollection

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class BookmarkCollection : List<Bookmark>
Public Class BookmarkCollection
    Inherits List(Of Bookmark)
public ref class BookmarkCollection : public List<Bookmark^>
type BookmarkCollection =
    class
        inherit List<Bookmark>
    end

The BookmarkCollection type exposes the following members.

Constructors
 | Name | Description
Public method | BookmarkCollection | Initializes a new instance of the BookmarkCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List Bookmark .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List Bookmark .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from List Bookmark .)
Public property | ItemString |
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List Bookmark .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List Bookmark .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List Bookmark .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List Bookmark .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Bookmark .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Bookmark .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List Bookmark .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List Bookmark .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List Bookmark .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List Bookmark .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Bookmark .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Bookmark .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List Bookmark .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List Bookmark .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Bookmark .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Bookmark .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Bookmark .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Bookmark .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List Bookmark .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List Bookmark .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List Bookmark .)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Bookmark .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Bookmark .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List Bookmark .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List Bookmark .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Bookmark .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Bookmark .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List Bookmark .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List Bookmark .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List Bookmark .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List Bookmark .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List Bookmark .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List Bookmark .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List Bookmark .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List Bookmark .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List Bookmark .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List Bookmark .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List Bookmark .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List Bookmark .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List Bookmark .)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


BookmarkCollection Constructor

BookmarkCollection Constructor
Initializes a new instance of the BookmarkCollection class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public BookmarkCollection()
Public Sub New
public:
BookmarkCollection()
new : unit -> BookmarkCollection
See Also

Reference

BookmarkCollection Class


BookmarkCollection Properties

BookmarkCollection Properties

The BookmarkCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List Bookmark .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List Bookmark .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from List Bookmark .)
Public property | ItemString |
Top
See Also

Reference

BookmarkCollection Class


BookmarkCollection.Item Property

BookmarkCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from List Bookmark .)
Public property | ItemString |
Top
See Also

Reference

BookmarkCollection Class


BookmarkCollection.Item Property (String)

BookmarkCollectionItem Property (String)

[Missing <summary> documentation for "P:Novacode.BookmarkCollection.Item(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Bookmark this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As Bookmark
    Get
public:
property Bookmark^ default[String^ name] {
    Bookmark^ get (String^ name);
}
member Item : Bookmark with get

Parameters

name
Type: SystemString

Property Value

Type: Bookmark
See Also

Reference

BookmarkCollection Class
Item Overload


BookmarkCollection Methods

BookmarkCollection Methods

The BookmarkCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List Bookmark .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List Bookmark .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List Bookmark .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List Bookmark .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Bookmark .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List Bookmark .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List Bookmark .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List Bookmark .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List Bookmark .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List Bookmark .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Bookmark .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List Bookmark .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List Bookmark .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List Bookmark .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Bookmark .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Bookmark .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Bookmark .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Bookmark .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List Bookmark .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List Bookmark .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List Bookmark .)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List Bookmark .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List Bookmark .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List Bookmark .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List Bookmark .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List Bookmark .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List Bookmark .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List Bookmark .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List Bookmark .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List Bookmark .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List Bookmark .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List Bookmark .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List Bookmark .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List Bookmark .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List Bookmark .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List Bookmark .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List Bookmark .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List Bookmark .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List Bookmark .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List Bookmark .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List Bookmark .)
Top
See Also

Reference

BookmarkCollection Class


Border Class

Border Class

[Missing <summary> documentation for "T:Novacode.Border"]

Inheritance Hierarchy
SystemObject
NovacodeBorder

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Border
Public Class Border
public ref class Border
type Border =  class end

The Border type exposes the following members.

Constructors
 | Name | Description
Public method | Border | Initializes a new instance of the Border class
Public method | Border(BorderStyle, BorderSize, Int32, Color) | Initializes a new instance of the Border class
Top
Properties
 | Name | Description
Public property | Color |
Public property | Size |
Public property | Space |
Public property | Tcbs |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Border Constructor

Border Constructor
Overload List
 | Name | Description
Public method | Border | Initializes a new instance of the Border class
Public method | Border(BorderStyle, BorderSize, Int32, Color) | Initializes a new instance of the Border class
Top
See Also

Reference

Border Class


Border Constructor

Border Constructor
Initializes a new instance of the Border class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Border()
Public Sub New
public:
Border()
new : unit -> Border
See Also

Reference

Border Class
Border Overload


Border Constructor (BorderStyle, BorderSize, Int32, Color)

Border Constructor (BorderStyle, BorderSize, Int32, Color)
Initializes a new instance of the Border class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Border(
    BorderStyle tcbs,
    BorderSize size,
    int space,
    Color color
)
Public Sub New (
    tcbs As BorderStyle,
    size As BorderSize,
    space As Integer,
    color As Color
)
public:
Border(
    BorderStyle tcbs,
    BorderSize size,
    int space,
    Color color
)
new :
        tcbs : BorderStyle *
        size : BorderSize *
        space : int *
        color : Color -> Border

Parameters

tcbs
Type: NovacodeBorderStyle

[Missing <param name="tcbs"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

size
Type: NovacodeBorderSize

[Missing <param name="size"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

space
Type: SystemInt32

[Missing <param name="space"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

color
Type: System.DrawingColor

[Missing <param name="color"/> documentation for "M:Novacode.Border.#ctor(Novacode.BorderStyle,Novacode.BorderSize,System.Int32,System.Drawing.Color)"]

See Also

Reference

Border Class
Border Overload


Border Properties

Border Properties

The Border type exposes the following members.

Properties
 | Name | Description
Public property | Color |
Public property | Size |
Public property | Space |
Public property | Tcbs |
Top
See Also

Reference

Border Class


Border.Color Property

BorderColor Property

[Missing <summary> documentation for "P:Novacode.Border.Color"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color Color {
    Color get ();
    void set (Color value);
}
member Color : Color with get, set

Property Value

Type: Color
See Also

Reference

Border Class


Border.Size Property

BorderSize Property

[Missing <summary> documentation for "P:Novacode.Border.Size"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public BorderSize Size { get; set; }
Public Property Size As BorderSize
    Get
    Set
public:
property BorderSize Size {
    BorderSize get ();
    void set (BorderSize value);
}
member Size : BorderSize with get, set

Property Value

Type: BorderSize
See Also

Reference

Border Class


Border.Space Property

BorderSpace Property

[Missing <summary> documentation for "P:Novacode.Border.Space"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int Space { get; set; }
Public Property Space As Integer
    Get
    Set
public:
property int Space {
    int get ();
    void set (int value);
}
member Space : int with get, set

Property Value

Type: Int32
See Also

Reference

Border Class


Border.Tcbs Property

BorderTcbs Property

[Missing <summary> documentation for "P:Novacode.Border.Tcbs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public BorderStyle Tcbs { get; set; }
Public Property Tcbs As BorderStyle
    Get
    Set
public:
property BorderStyle Tcbs {
    BorderStyle get ();
    void set (BorderStyle value);
}
member Tcbs : BorderStyle with get, set

Property Value

Type: BorderStyle
See Also

Reference

Border Class


Border Methods

Border Methods

The Border type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Border Class


BorderSize Enumeration

BorderSize Enumeration

[Missing <summary> documentation for "T:Novacode.BorderSize"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum BorderSize
Public Enumeration BorderSize
public enum class BorderSize
type BorderSize
Members
Member name | Value | Description
one | 0 |
two | 1 |
three | 2 |
four | 3 |
five | 4 |
six | 5 |
seven | 6 |
eight | 7 |
nine | 8 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


BorderStyle Enumeration

BorderStyle Enumeration

[Missing <summary> documentation for "T:Novacode.BorderStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum BorderStyle
Public Enumeration BorderStyle
public enum class BorderStyle
type BorderStyle
Members
Member name | Value | Description
Tcbs_none | 0 |
Tcbs_single | 1 |
Tcbs_thick | 2 |
Tcbs_double | 3 |
Tcbs_dotted | 4 |
Tcbs_dashed | 5 |
Tcbs_dotDash | 6 |
Tcbs_dotDotDash | 7 |
Tcbs_triple | 8 |
Tcbs_thinThickSmallGap | 9 |
Tcbs_thickThinSmallGap | 10 |
Tcbs_thinThickThinSmallGap | 11 |
Tcbs_thinThickMediumGap | 12 |
Tcbs_thickThinMediumGap | 13 |
Tcbs_thinThickThinMediumGap | 14 |
Tcbs_thinThickLargeGap | 15 |
Tcbs_thickThinLargeGap | 16 |
Tcbs_thinThickThinLargeGap | 17 |
Tcbs_wave | 18 |
Tcbs_doubleWave | 19 |
Tcbs_dashSmallGap | 20 |
Tcbs_dashDotStroked | 21 |
Tcbs_threeDEmboss | 22 |
Tcbs_threeDEngrave | 23 |
Tcbs_outset | 24 |
Tcbs_inset | 25 |
Tcbs_nil | 26 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


CalloutShapes Enumeration

CalloutShapes Enumeration

[Missing <summary> documentation for "T:Novacode.CalloutShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum CalloutShapes
Public Enumeration CalloutShapes
public enum class CalloutShapes
type CalloutShapes
Members
Member name | Value | Description
wedgeRectCallout | 0 |
wedgeRoundRectCallout | 1 |
wedgeEllipseCallout | 2 |
cloudCallout | 3 |
borderCallout1 | 4 |
borderCallout2 | 5 |
borderCallout3 | 6 |
accentCallout1 | 7 |
accentCallout2 | 8 |
accentCallout3 | 9 |
callout1 | 10 |
callout2 | 11 |
callout3 | 12 |
accentBorderCallout1 | 13 |
accentBorderCallout2 | 14 |
accentBorderCallout3 | 15 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


CapsStyle Enumeration

CapsStyle Enumeration

[Missing <summary> documentation for "T:Novacode.CapsStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum CapsStyle
Public Enumeration CapsStyle
public enum class CapsStyle
type CapsStyle
Members
Member name | Value | Description
none | 0 |
caps | 1 |
smallCaps | 2 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


CategoryAxis Class

CategoryAxis Class

[Missing <summary> documentation for "T:Novacode.CategoryAxis"]

Inheritance Hierarchy
SystemObject
NovacodeAxis
NovacodeCategoryAxis

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class CategoryAxis : Axis
Public Class CategoryAxis
    Inherits Axis
public ref class CategoryAxis : public Axis
type CategoryAxis =
    class
        inherit Axis
    end

The CategoryAxis type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryAxis | Initializes a new instance of the CategoryAxis class
Top
Properties
 | Name | Description
Public property | Id | (Inherited from Axis.)
Public property | IsVisible | (Inherited from Axis.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


CategoryAxis Constructor

CategoryAxis Constructor
Initializes a new instance of the CategoryAxis class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public CategoryAxis(
    string id
)
Public Sub New (
    id As String
)
public:
CategoryAxis(
    String^ id
)
new :
        id : string -> CategoryAxis

Parameters

id
Type: SystemString

[Missing <param name="id"/> documentation for "M:Novacode.CategoryAxis.#ctor(System.String)"]

See Also

Reference

CategoryAxis Class


CategoryAxis Properties

CategoryAxis Properties

The CategoryAxis type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from Axis.)
Public property | IsVisible | (Inherited from Axis.)
Top
See Also

Reference

CategoryAxis Class


CategoryAxis Methods

CategoryAxis Methods

The CategoryAxis type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CategoryAxis Class


Cell Class

Cell Class

[Missing <summary> documentation for "T:Novacode.Cell"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeContainer
NovacodeCell

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Cell : Container
Public Class Cell
    Inherits Container
public ref class Cell : public Container
type Cell =
    class
        inherit Container
    end

The Cell type exposes the following members.

Properties
 | Name | Description
Public property | FillColor |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | MarginBottom |
Public property | MarginLeft |
Public property | MarginRight |
Public property | MarginTop |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Paragraphs | (Overrides ContainerParagraphs.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Shading |
Public property | Tables | (Inherited from Container.)
Public property | TextDirection |
Public property | VerticalAlignment |
Public property | Width |
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetBorder |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Overrides ContainerInsertTable(Int32, Int32).)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | SetBorder |
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
Fields
 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Cell Properties

Cell Properties

The Cell type exposes the following members.

Properties
 | Name | Description
Public property | FillColor |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | MarginBottom |
Public property | MarginLeft |
Public property | MarginRight |
Public property | MarginTop |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Paragraphs | (Overrides ContainerParagraphs.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Shading |
Public property | Tables | (Inherited from Container.)
Public property | TextDirection |
Public property | VerticalAlignment |
Public property | Width |
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Cell Class


Cell.FillColor Property

CellFillColor Property

[Missing <summary> documentation for "P:Novacode.Cell.FillColor"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Color FillColor { get; set; }
Public Property FillColor As Color
    Get
    Set
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}
member FillColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Cell Class


Cell.MarginBottom Property

CellMarginBottom Property

[Missing <summary> documentation for "P:Novacode.Cell.MarginBottom"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public double MarginBottom { get; set; }
Public Property MarginBottom As Double
    Get
    Set
public:
property double MarginBottom {
    double get ();
    void set (double value);
}
member MarginBottom : float with get, set

Property Value

Type: Double
See Also

Reference

Cell Class


Cell.MarginLeft Property

CellMarginLeft Property

[Missing <summary> documentation for "P:Novacode.Cell.MarginLeft"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public double MarginLeft { get; set; }
Public Property MarginLeft As Double
    Get
    Set
public:
property double MarginLeft {
    double get ();
    void set (double value);
}
member MarginLeft : float with get, set

Property Value

Type: Double
See Also

Reference

Cell Class


Cell.MarginRight Property

CellMarginRight Property

[Missing <summary> documentation for "P:Novacode.Cell.MarginRight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public double MarginRight { get; set; }
Public Property MarginRight As Double
    Get
    Set
public:
property double MarginRight {
    double get ();
    void set (double value);
}
member MarginRight : float with get, set

Property Value

Type: Double
See Also

Reference

Cell Class


Cell.MarginTop Property

CellMarginTop Property

[Missing <summary> documentation for "P:Novacode.Cell.MarginTop"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public double MarginTop { get; set; }
Public Property MarginTop As Double
    Get
    Set
public:
property double MarginTop {
    double get ();
    void set (double value);
}
member MarginTop : float with get, set

Property Value

Type: Double
See Also

Reference

Cell Class


Cell.Paragraphs Property

CellParagraphs Property

[Missing <summary> documentation for "P:Novacode.Cell.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override ReadOnlyCollection<Paragraph> Paragraphs { get; }
Public Overrides ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get () override;
}
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection Paragraph
See Also

Reference

Cell Class


Cell.Shading Property

CellShading Property

[Missing <summary> documentation for "P:Novacode.Cell.Shading"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Color Shading { get; set; }
Public Property Shading As Color
    Get
    Set
public:
property Color Shading {
    Color get ();
    void set (Color value);
}
member Shading : Color with get, set

Property Value

Type: Color
See Also

Reference

Cell Class


Cell.TextDirection Property

CellTextDirection Property

[Missing <summary> documentation for "P:Novacode.Cell.TextDirection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public TextDirection TextDirection { get; set; }
Public Property TextDirection As TextDirection
    Get
    Set
public:
property TextDirection TextDirection {
    TextDirection get ();
    void set (TextDirection value);
}
member TextDirection : TextDirection with get, set

Property Value

Type: TextDirection
See Also

Reference

Cell Class


Cell.VerticalAlignment Property

CellVerticalAlignment Property

[Missing <summary> documentation for "P:Novacode.Cell.VerticalAlignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public VerticalAlignment VerticalAlignment { get; set; }
Public Property VerticalAlignment As VerticalAlignment
    Get
    Set
public:
property VerticalAlignment VerticalAlignment {
    VerticalAlignment get ();
    void set (VerticalAlignment value);
}
member VerticalAlignment : VerticalAlignment with get, set

Property Value

Type: VerticalAlignment
See Also

Reference

Cell Class


Cell.Width Property

CellWidth Property

[Missing <summary> documentation for "P:Novacode.Cell.Width"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}
member Width : float with get, set

Property Value

Type: Double
See Also

Reference

Cell Class


Cell Methods

Cell Methods

The Cell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetBorder |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Overrides ContainerInsertTable(Int32, Int32).)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | SetBorder |
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
See Also

Reference

Cell Class


Cell.GetBorder Method

CellGetBorder Method

[Missing <summary> documentation for "M:Novacode.Cell.GetBorder(Novacode.TableCellBorderType)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Border GetBorder(
    TableCellBorderType borderType
)
Public Function GetBorder (
    borderType As TableCellBorderType
) As Border
public:
Border^ GetBorder(
    TableCellBorderType borderType
)
member GetBorder :
        borderType : TableCellBorderType -> Border

Parameters

borderType
Type: NovacodeTableCellBorderType

[Missing <param name="borderType"/> documentation for "M:Novacode.Cell.GetBorder(Novacode.TableCellBorderType)"]

Return Value

Type: Border

[Missing <returns> documentation for "M:Novacode.Cell.GetBorder(Novacode.TableCellBorderType)"]

See Also

Reference

Cell Class


Cell.InsertTable Method

CellInsertTable Method
Overload List
 | Name | Description
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Overrides ContainerInsertTable(Int32, Int32).)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Top
See Also

Reference

Cell Class


Cell.InsertTable Method (Int32, Int32)

CellInsertTable Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Table InsertTable(
    int rowCount,
    int columnCount
)
Public Overrides Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
virtual Table^ InsertTable(
    int rowCount,
    int columnCount
) override
abstract InsertTable :
        rowCount : int *
        columnCount : int -> Table
override InsertTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Cell.InsertTable(System.Int32,System.Int32)"]

See Also

Reference

Cell Class
InsertTable Overload


Cell.SetBorder Method

CellSetBorder Method

[Missing <summary> documentation for "M:Novacode.Cell.SetBorder(Novacode.TableCellBorderType,Novacode.Border)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetBorder(
    TableCellBorderType borderType,
    Border border
)
Public Sub SetBorder (
    borderType As TableCellBorderType,
    border As Border
)
public:
void SetBorder(
    TableCellBorderType borderType,
    Border^ border
)
member SetBorder :
        borderType : TableCellBorderType *
        border : Border -> unit

Parameters

borderType
Type: NovacodeTableCellBorderType

[Missing <param name="borderType"/> documentation for "M:Novacode.Cell.SetBorder(Novacode.TableCellBorderType,Novacode.Border)"]

border
Type: NovacodeBorder

[Missing <param name="border"/> documentation for "M:Novacode.Cell.SetBorder(Novacode.TableCellBorderType,Novacode.Border)"]

See Also

Reference

Cell Class


Cell Fields

Cell Fields

The Cell type exposes the following members.

Fields
 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Top
See Also

Reference

Cell Class


Chart Class

Chart Class

[Missing <summary> documentation for "T:Novacode.Chart"]

Inheritance Hierarchy
SystemObject
NovacodeChart
NovacodeBarChart
NovacodeLineChart
NovacodePieChart

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public abstract class Chart
Public MustInherit Class Chart
public ref class Chart abstract
[<AbstractClassAttribute>]
type Chart =  class end

The Chart type exposes the following members.

Constructors
 | Name | Description
Public method | Chart | Initializes a new instance of the Chart class
Top
Properties
 | Name | Description
Public property | CategoryAxis |
Protected property | ChartRootXml |
Protected property | ChartXml |
Public property | DisplayBlanksAs |
Public property | IsAxisExist |
Public property | Legend |
Public property | MaxSeriesCount |
Public property | Series |
Public property | ValueAxis |
Public property | View3D |
Public property | Xml |
Top
Methods
 | Name | Description
Public method | AddLegend |
Public method | AddLegend(ChartLegendPosition, Boolean) |
Public method | AddSeries |
Protected method | CreateChartXml |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Chart Constructor

Chart Constructor
Initializes a new instance of the Chart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Chart()
Public Sub New
public:
Chart()
new : unit -> Chart
See Also

Reference

Chart Class


Chart Properties

Chart Properties

The Chart type exposes the following members.

Properties
 | Name | Description
Public property | CategoryAxis |
Protected property | ChartRootXml |
Protected property | ChartXml |
Public property | DisplayBlanksAs |
Public property | IsAxisExist |
Public property | Legend |
Public property | MaxSeriesCount |
Public property | Series |
Public property | ValueAxis |
Public property | View3D |
Public property | Xml |
Top
See Also

Reference

Chart Class


Chart.CategoryAxis Property

ChartCategoryAxis Property

[Missing <summary> documentation for "P:Novacode.Chart.CategoryAxis"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public CategoryAxis CategoryAxis { get; }
Public ReadOnly Property CategoryAxis As CategoryAxis
    Get
public:
property CategoryAxis^ CategoryAxis {
    CategoryAxis^ get ();
}
member CategoryAxis : CategoryAxis with get

Property Value

Type: CategoryAxis
See Also

Reference

Chart Class


Chart.ChartRootXml Property

ChartChartRootXml Property

[Missing <summary> documentation for "P:Novacode.Chart.ChartRootXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
protected XElement ChartRootXml { get; }
Protected ReadOnly Property ChartRootXml As XElement
    Get
protected:
property XElement^ ChartRootXml {
    XElement^ get ();
}
member ChartRootXml : XElement with get

Property Value

Type: XElement
See Also

Reference

Chart Class


Chart.ChartXml Property

ChartChartXml Property

[Missing <summary> documentation for "P:Novacode.Chart.ChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
protected XElement ChartXml { get; }
Protected ReadOnly Property ChartXml As XElement
    Get
protected:
property XElement^ ChartXml {
    XElement^ get ();
}
member ChartXml : XElement with get

Property Value

Type: XElement
See Also

Reference

Chart Class


Chart.DisplayBlanksAs Property

ChartDisplayBlanksAs Property

[Missing <summary> documentation for "P:Novacode.Chart.DisplayBlanksAs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public DisplayBlanksAs DisplayBlanksAs { get; set; }
Public Property DisplayBlanksAs As DisplayBlanksAs
    Get
    Set
public:
property DisplayBlanksAs DisplayBlanksAs {
    DisplayBlanksAs get ();
    void set (DisplayBlanksAs value);
}
member DisplayBlanksAs : DisplayBlanksAs with get, set

Property Value

Type: DisplayBlanksAs
See Also

Reference

Chart Class


Chart.IsAxisExist Property

ChartIsAxisExist Property

[Missing <summary> documentation for "P:Novacode.Chart.IsAxisExist"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsAxisExist { get; }
Public Overridable ReadOnly Property IsAxisExist As Boolean
    Get
public:
virtual property bool IsAxisExist {
    bool get ();
}
abstract IsAxisExist : bool with get
override IsAxisExist : bool with get

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.Legend Property

ChartLegend Property

[Missing <summary> documentation for "P:Novacode.Chart.Legend"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public ChartLegend Legend { get; }
Public ReadOnly Property Legend As ChartLegend
    Get
public:
property ChartLegend^ Legend {
    ChartLegend^ get ();
}
member Legend : ChartLegend with get

Property Value

Type: ChartLegend
See Also

Reference

Chart Class


Chart.MaxSeriesCount Property

ChartMaxSeriesCount Property

[Missing <summary> documentation for "P:Novacode.Chart.MaxSeriesCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual short MaxSeriesCount { get; }
Public Overridable ReadOnly Property MaxSeriesCount As Short
    Get
public:
virtual property short MaxSeriesCount {
    short get ();
}
abstract MaxSeriesCount : int16 with get
override MaxSeriesCount : int16 with get

Property Value

Type: Int16
See Also

Reference

Chart Class


Chart.Series Property

ChartSeries Property

[Missing <summary> documentation for "P:Novacode.Chart.Series"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Series> Series { get; }
Public ReadOnly Property Series As List(Of Series)
    Get
public:
property List<Series^>^ Series {
    List<Series^>^ get ();
}
member Series : List<Series> with get

Property Value

Type: List Series
See Also

Reference

Chart Class


Chart.ValueAxis Property

ChartValueAxis Property

[Missing <summary> documentation for "P:Novacode.Chart.ValueAxis"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public ValueAxis ValueAxis { get; }
Public ReadOnly Property ValueAxis As ValueAxis
    Get
public:
property ValueAxis^ ValueAxis {
    ValueAxis^ get ();
}
member ValueAxis : ValueAxis with get

Property Value

Type: ValueAxis
See Also

Reference

Chart Class


Chart.View3D Property

ChartView3D Property

[Missing <summary> documentation for "P:Novacode.Chart.View3D"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool View3D { get; set; }
Public Property View3D As Boolean
    Get
    Set
public:
property bool View3D {
    bool get ();
    void set (bool value);
}
member View3D : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.Xml Property

ChartXml Property

[Missing <summary> documentation for "P:Novacode.Chart.Xml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public XDocument Xml { get; }
Public ReadOnly Property Xml As XDocument
    Get
public:
property XDocument^ Xml {
    XDocument^ get ();
}
member Xml : XDocument with get

Property Value

Type: XDocument
See Also

Reference

Chart Class


Chart Methods

Chart Methods

The Chart type exposes the following members.

Methods
 | Name | Description
Public method | AddLegend |
Public method | AddLegend(ChartLegendPosition, Boolean) |
Public method | AddSeries |
Protected method | CreateChartXml |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Chart Class


Chart.AddLegend Method

ChartAddLegend Method
Overload List
 | Name | Description
Public method | AddLegend |
Public method | AddLegend(ChartLegendPosition, Boolean) |
Top
See Also

Reference

Chart Class


Chart.AddLegend Method

ChartAddLegend Method

[Missing <summary> documentation for "M:Novacode.Chart.AddLegend"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddLegend()
Public Sub AddLegend
public:
void AddLegend()
member AddLegend : unit -> unit
See Also

Reference

Chart Class
AddLegend Overload


Chart.AddLegend Method (ChartLegendPosition, Boolean)

ChartAddLegend Method (ChartLegendPosition, Boolean)

[Missing <summary> documentation for "M:Novacode.Chart.AddLegend(Novacode.ChartLegendPosition,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddLegend(
    ChartLegendPosition position,
    bool overlay
)
Public Sub AddLegend (
    position As ChartLegendPosition,
    overlay As Boolean
)
public:
void AddLegend(
    ChartLegendPosition position,
    bool overlay
)
member AddLegend :
        position : ChartLegendPosition *
        overlay : bool -> unit

Parameters

position
Type: NovacodeChartLegendPosition

[Missing <param name="position"/> documentation for "M:Novacode.Chart.AddLegend(Novacode.ChartLegendPosition,System.Boolean)"]

overlay
Type: SystemBoolean

[Missing <param name="overlay"/> documentation for "M:Novacode.Chart.AddLegend(Novacode.ChartLegendPosition,System.Boolean)"]

See Also

Reference

Chart Class
AddLegend Overload


Chart.AddSeries Method

ChartAddSeries Method

[Missing <summary> documentation for "M:Novacode.Chart.AddSeries(Novacode.Series)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddSeries(
    Series series
)
Public Sub AddSeries (
    series As Series
)
public:
void AddSeries(
    Series^ series
)
member AddSeries :
        series : Series -> unit

Parameters

series
Type: NovacodeSeries

[Missing <param name="series"/> documentation for "M:Novacode.Chart.AddSeries(Novacode.Series)"]

See Also

Reference

Chart Class


Chart.CreateChartXml Method

ChartCreateChartXml Method

[Missing <summary> documentation for "M:Novacode.Chart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
protected abstract XElement CreateChartXml()
Protected MustOverride Function CreateChartXml As XElement
protected:
virtual XElement^ CreateChartXml() abstract
abstract CreateChartXml : unit -> XElement

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.Chart.CreateChartXml"]

See Also

Reference

Chart Class


Chart.RemoveLegend Method

ChartRemoveLegend Method

[Missing <summary> documentation for "M:Novacode.Chart.RemoveLegend"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void RemoveLegend()
Public Sub RemoveLegend
public:
void RemoveLegend()
member RemoveLegend : unit -> unit
See Also

Reference

Chart Class


ChartLegend Class

ChartLegend Class

[Missing <summary> documentation for "T:Novacode.ChartLegend"]

Inheritance Hierarchy
SystemObject
NovacodeChartLegend

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class ChartLegend
Public Class ChartLegend
public ref class ChartLegend
type ChartLegend =  class end

The ChartLegend type exposes the following members.

Properties
 | Name | Description
Public property | Overlay |
Public property | Position |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


ChartLegend Properties

ChartLegend Properties

The ChartLegend type exposes the following members.

Properties
 | Name | Description
Public property | Overlay |
Public property | Position |
Top
See Also

Reference

ChartLegend Class


ChartLegend.Overlay Property

ChartLegendOverlay Property

[Missing <summary> documentation for "P:Novacode.ChartLegend.Overlay"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool Overlay { get; set; }
Public Property Overlay As Boolean
    Get
    Set
public:
property bool Overlay {
    bool get ();
    void set (bool value);
}
member Overlay : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ChartLegend Class


ChartLegend.Position Property

ChartLegendPosition Property

[Missing <summary> documentation for "P:Novacode.ChartLegend.Position"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public ChartLegendPosition Position { get; set; }
Public Property Position As ChartLegendPosition
    Get
    Set
public:
property ChartLegendPosition Position {
    ChartLegendPosition get ();
    void set (ChartLegendPosition value);
}
member Position : ChartLegendPosition with get, set

Property Value

Type: ChartLegendPosition
See Also

Reference

ChartLegend Class


ChartLegend Methods

ChartLegend Methods

The ChartLegend type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChartLegend Class


ChartLegendPosition Enumeration

ChartLegendPosition Enumeration

[Missing <summary> documentation for "T:Novacode.ChartLegendPosition"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum ChartLegendPosition
Public Enumeration ChartLegendPosition
public enum class ChartLegendPosition
type ChartLegendPosition
Members
Member name | Value | Description
Top | 0 |
Bottom | 1 |
Left | 2 |
Right | 3 |
TopRight | 4 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Container Class

Container Class

[Missing <summary> documentation for "T:Novacode.Container"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeContainer
More...

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public abstract class Container : DocXElement
Public MustInherit Class Container
    Inherits DocXElement
public ref class Container abstract : public DocXElement
[<AbstractClassAttribute>]
type Container =
    class
        inherit DocXElement
    end

The Container type exposes the following members.

Properties
 | Name | Description
Public property | Hyperlinks |
Public property | Lists |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Paragraphs |
Public property | ParagraphsDeepSearch |
Public property | Pictures |
Public property | Sections |
Public property | Tables |
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Public method | FindUniqueByPattern |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark |
Public method | InsertBookmark |
Public method | InsertEquation |
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |
Public method | InsertParagraph |
Public method | InsertParagraph(String) |
Public method | InsertParagraph(Paragraph) |
Public method | InsertParagraph(Int32, Paragraph) |
Public method | InsertParagraph(String, Boolean) |
Public method | InsertParagraph(Int32, String, Boolean) |
Public method | InsertParagraph(String, Boolean, Formatting) |
Public method | InsertParagraph(Int32, String, Boolean, Formatting) |
Public method | InsertSection |
Public method | InsertSection(Boolean) |
Public method | InsertSectionPageBreak |
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph |
Public method | RemoveParagraphAt |
Public method | RemoveTextInGivenFormat |
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Public method | SetDirection |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks |
Top
Fields
 | Name | Description
Public field | ParentContainer |
Top
See Also

Reference

Novacode Namespace
Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeContainer
NovacodeCell
NovacodeDocX
NovacodeFooter
NovacodeHeader
NovacodeRow
NovacodeSection


Container Properties

Container Properties

The Container type exposes the following members.

Properties
 | Name | Description
Public property | Hyperlinks |
Public property | Lists |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Paragraphs |
Public property | ParagraphsDeepSearch |
Public property | Pictures |
Public property | Sections |
Public property | Tables |
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Container Class


Container.Hyperlinks Property

ContainerHyperlinks Property

[Missing <summary> documentation for "P:Novacode.Container.Hyperlinks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual List<Hyperlink> Hyperlinks { get; }
Public Overridable ReadOnly Property Hyperlinks As List(Of Hyperlink)
    Get
public:
virtual property List<Hyperlink^>^ Hyperlinks {
    List<Hyperlink^>^ get ();
}
abstract Hyperlinks : List<Hyperlink> with get
override Hyperlinks : List<Hyperlink> with get

Property Value

Type: List Hyperlink
See Also

Reference

Container Class


Container.Lists Property

ContainerLists Property

[Missing <summary> documentation for "P:Novacode.Container.Lists"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual List<List> Lists { get; }
Public Overridable ReadOnly Property Lists As List(Of List)
    Get
public:
virtual property List<List^>^ Lists {
    List<List^>^ get ();
}
abstract Lists : List<List> with get
override Lists : List<List> with get

Property Value

Type: List List
See Also

Reference

Container Class


Container.Paragraphs Property

ContainerParagraphs Property

[Missing <summary> documentation for "P:Novacode.Container.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual ReadOnlyCollection<Paragraph> Paragraphs { get; }
Public Overridable ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get ();
}
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection Paragraph
See Also

Reference

Container Class


Container.ParagraphsDeepSearch Property

ContainerParagraphsDeepSearch Property

[Missing <summary> documentation for "P:Novacode.Container.ParagraphsDeepSearch"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual ReadOnlyCollection<Paragraph> ParagraphsDeepSearch { get; }
Public Overridable ReadOnly Property ParagraphsDeepSearch As ReadOnlyCollection(Of Paragraph)
    Get
public:
virtual property ReadOnlyCollection<Paragraph^>^ ParagraphsDeepSearch {
    ReadOnlyCollection<Paragraph^>^ get ();
}
abstract ParagraphsDeepSearch : ReadOnlyCollection<Paragraph> with get
override ParagraphsDeepSearch : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection Paragraph
See Also

Reference

Container Class


Container.Pictures Property

ContainerPictures Property

[Missing <summary> documentation for "P:Novacode.Container.Pictures"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual List<Picture> Pictures { get; }
Public Overridable ReadOnly Property Pictures As List(Of Picture)
    Get
public:
virtual property List<Picture^>^ Pictures {
    List<Picture^>^ get ();
}
abstract Pictures : List<Picture> with get
override Pictures : List<Picture> with get

Property Value

Type: List Picture
See Also

Reference

Container Class


Container.Sections Property

ContainerSections Property

[Missing <summary> documentation for "P:Novacode.Container.Sections"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual List<Section> Sections { get; }
Public Overridable ReadOnly Property Sections As List(Of Section)
    Get
public:
virtual property List<Section^>^ Sections {
    List<Section^>^ get ();
}
abstract Sections : List<Section> with get
override Sections : List<Section> with get

Property Value

Type: List Section
See Also

Reference

Container Class


Container.Tables Property

ContainerTables Property

[Missing <summary> documentation for "P:Novacode.Container.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual List<Table> Tables { get; }
Public Overridable ReadOnly Property Tables As List(Of Table)
    Get
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get ();
}
abstract Tables : List<Table> with get
override Tables : List<Table> with get

Property Value

Type: List Table
See Also

Reference

Container Class


Container Methods

Container Methods

The Container type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Public method | FindUniqueByPattern |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark |
Public method | InsertBookmark |
Public method | InsertEquation |
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |
Public method | InsertParagraph |
Public method | InsertParagraph(String) |
Public method | InsertParagraph(Paragraph) |
Public method | InsertParagraph(Int32, Paragraph) |
Public method | InsertParagraph(String, Boolean) |
Public method | InsertParagraph(Int32, String, Boolean) |
Public method | InsertParagraph(String, Boolean, Formatting) |
Public method | InsertParagraph(Int32, String, Boolean, Formatting) |
Public method | InsertSection |
Public method | InsertSection(Boolean) |
Public method | InsertSectionPageBreak |
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph |
Public method | RemoveParagraphAt |
Public method | RemoveTextInGivenFormat |
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Public method | SetDirection |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks |
Top
See Also

Reference

Container Class


Container.FindAll Method

ContainerFindAll Method
Overload List
 | Name | Description
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Top
See Also

Reference

Container Class


Container.FindAll Method (String)

ContainerFindAll Method (String)

[Missing <summary> documentation for "M:Novacode.Container.FindAll(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual List<int> FindAll(
    string str
)
Public Overridable Function FindAll (
    str As String
) As List(Of Integer)
public:
virtual List<int>^ FindAll(
    String^ str
)
abstract FindAll :
        str : string -> List<int>
override FindAll :
        str : string -> List<int>

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:Novacode.Container.FindAll(System.String)"]

Return Value

Type: List Int32

[Missing <returns> documentation for "M:Novacode.Container.FindAll(System.String)"]

See Also

Reference

Container Class
FindAll Overload


Container.FindAll Method (String, RegexOptions)

ContainerFindAll Method (String, RegexOptions)

[Missing <summary> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual List<int> FindAll(
    string str,
    RegexOptions options
)
Public Overridable Function FindAll (
    str As String,
    options As RegexOptions
) As List(Of Integer)
public:
virtual List<int>^ FindAll(
    String^ str,
    RegexOptions options
)
abstract FindAll :
        str : string *
        options : RegexOptions -> List<int>
override FindAll :
        str : string *
        options : RegexOptions -> List<int>

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressionsRegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List Int32

[Missing <returns> documentation for "M:Novacode.Container.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Reference

Container Class
FindAll Overload


Container.FindUniqueByPattern Method

ContainerFindUniqueByPattern Method

[Missing <summary> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual List<string> FindUniqueByPattern(
    string pattern,
    RegexOptions options
)
Public Overridable Function FindUniqueByPattern (
    pattern As String,
    options As RegexOptions
) As List(Of String)
public:
virtual List<String^>^ FindUniqueByPattern(
    String^ pattern,
    RegexOptions options
)
abstract FindUniqueByPattern :
        pattern : string *
        options : RegexOptions -> List<string>
override FindUniqueByPattern :
        pattern : string *
        options : RegexOptions -> List<string>

Parameters

pattern
Type: SystemString

[Missing <param name="pattern"/> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressionsRegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List String

[Missing <returns> documentation for "M:Novacode.Container.FindUniqueByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Reference

Container Class


Container.InsertAtBookmark Method

ContainerInsertAtBookmark Method

[Missing <summary> documentation for "M:Novacode.Container.InsertAtBookmark(System.String,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual void InsertAtBookmark(
    string toInsert,
    string bookmarkName
)
Public Overridable Sub InsertAtBookmark (
    toInsert As String,
    bookmarkName As String
)
public:
virtual void InsertAtBookmark(
    String^ toInsert,
    String^ bookmarkName
)
abstract InsertAtBookmark :
        toInsert : string *
        bookmarkName : string -> unit
override InsertAtBookmark :
        toInsert : string *
        bookmarkName : string -> unit

Parameters

toInsert
Type: SystemString

[Missing <param name="toInsert"/> documentation for "M:Novacode.Container.InsertAtBookmark(System.String,System.String)"]

bookmarkName
Type: SystemString

[Missing <param name="bookmarkName"/> documentation for "M:Novacode.Container.InsertAtBookmark(System.String,System.String)"]

See Also

Reference

Container Class


Container.InsertBookmark Method

ContainerInsertBookmark Method

[Missing <summary> documentation for "M:Novacode.Container.InsertBookmark(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertBookmark(
    string bookmarkName
)
Public Overridable Function InsertBookmark (
    bookmarkName As String
) As Paragraph
public:
virtual Paragraph^ InsertBookmark(
    String^ bookmarkName
)
abstract InsertBookmark :
        bookmarkName : string -> Paragraph
override InsertBookmark :
        bookmarkName : string -> Paragraph

Parameters

bookmarkName
Type: SystemString

[Missing <param name="bookmarkName"/> documentation for "M:Novacode.Container.InsertBookmark(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertBookmark(System.String)"]

See Also

Reference

Container Class


Container.InsertEquation Method

ContainerInsertEquation Method

[Missing <summary> documentation for "M:Novacode.Container.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertEquation(
    string equation
)
Public Overridable Function InsertEquation (
    equation As String
) As Paragraph
public:
virtual Paragraph^ InsertEquation(
    String^ equation
)
abstract InsertEquation :
        equation : string -> Paragraph
override InsertEquation :
        equation : string -> Paragraph

Parameters

equation
Type: SystemString

[Missing <param name="equation"/> documentation for "M:Novacode.Container.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertEquation(System.String)"]

See Also

Reference

Container Class


Container.InsertList Method

ContainerInsertList Method
Overload List
 | Name | Description
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |
Top
See Also

Reference

Container Class


Container.InsertList Method (List)

ContainerInsertList Method (List)

[Missing <summary> documentation for "M:Novacode.Container.InsertList(Novacode.List)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List InsertList(
    List list
)
Public Function InsertList (
    list As List
) As List
public:
List^ InsertList(
    List^ list
)
member InsertList :
        list : List -> List

Parameters

list
Type: NovacodeList

[Missing <param name="list"/> documentation for "M:Novacode.Container.InsertList(Novacode.List)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.Container.InsertList(Novacode.List)"]

See Also

Reference

Container Class
InsertList Overload


Container.InsertList Method (Int32, List)

ContainerInsertList Method (Int32, List)

[Missing <summary> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List InsertList(
    int index,
    List list
)
Public Function InsertList (
    index As Integer,
    list As List
) As List
public:
List^ InsertList(
    int index,
    List^ list
)
member InsertList :
        index : int *
        list : List -> List

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

list
Type: NovacodeList

[Missing <param name="list"/> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.Container.InsertList(System.Int32,Novacode.List)"]

See Also

Reference

Container Class
InsertList Overload


Container.InsertList Method (List, Double)

ContainerInsertList Method (List, Double)

[Missing <summary> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List InsertList(
    List list,
    double fontSize
)
Public Function InsertList (
    list As List,
    fontSize As Double
) As List
public:
List^ InsertList(
    List^ list,
    double fontSize
)
member InsertList :
        list : List *
        fontSize : float -> List

Parameters

list
Type: NovacodeList

[Missing <param name="list"/> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Double)"]

fontSize
Type: SystemDouble

[Missing <param name="fontSize"/> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Double)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Double)"]

See Also

Reference

Container Class
InsertList Overload


Container.InsertList Method (List, FontFamily, Double)

ContainerInsertList Method (List, FontFamily, Double)

[Missing <summary> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List InsertList(
    List list,
    FontFamily fontFamily,
    double fontSize
)
Public Function InsertList (
    list As List,
    fontFamily As FontFamily,
    fontSize As Double
) As List
public:
List^ InsertList(
    List^ list,
    FontFamily^ fontFamily,
    double fontSize
)
member InsertList :
        list : List *
        fontFamily : FontFamily *
        fontSize : float -> List

Parameters

list
Type: NovacodeList

[Missing <param name="list"/> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

fontFamily
Type: System.DrawingFontFamily

[Missing <param name="fontFamily"/> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

fontSize
Type: SystemDouble

[Missing <param name="fontSize"/> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.Container.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

See Also

Reference

Container Class
InsertList Overload


Container.InsertParagraph Method

ContainerInsertParagraph Method
Overload List
 | Name | Description
Public method | InsertParagraph |
Public method | InsertParagraph(String) |
Public method | InsertParagraph(Paragraph) |
Public method | InsertParagraph(Int32, Paragraph) |
Public method | InsertParagraph(String, Boolean) |
Public method | InsertParagraph(Int32, String, Boolean) |
Public method | InsertParagraph(String, Boolean, Formatting) |
Public method | InsertParagraph(Int32, String, Boolean, Formatting) |
Top
See Also

Reference

Container Class


Container.InsertParagraph Method

ContainerInsertParagraph Method

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraph()
Public Overridable Function InsertParagraph As Paragraph
public:
virtual Paragraph^ InsertParagraph()
abstract InsertParagraph : unit -> Paragraph
override InsertParagraph : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph"]

See Also

Reference

Container Class
InsertParagraph Overload


Container.InsertParagraph Method (String)

ContainerInsertParagraph Method (String)

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraph(
    string text
)
Public Overridable Function InsertParagraph (
    text As String
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text
)
abstract InsertParagraph :
        text : string -> Paragraph
override InsertParagraph :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.String)"]

See Also

Reference

Container Class
InsertParagraph Overload


Container.InsertParagraph Method (Paragraph)

ContainerInsertParagraph Method (Paragraph)

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraph(
    Paragraph p
)
Public Overridable Function InsertParagraph (
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
)
abstract InsertParagraph :
        p : Paragraph -> Paragraph
override InsertParagraph :
        p : Paragraph -> Paragraph

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Container.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(Novacode.Paragraph)"]

See Also

Reference

Container Class
InsertParagraph Overload


Container.InsertParagraph Method (Int32, Paragraph)

ContainerInsertParagraph Method (Int32, Paragraph)

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Public Overridable Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
)
abstract InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph
override InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

Reference

Container Class
InsertParagraph Overload


Container.InsertParagraph Method (String, Boolean)

ContainerInsertParagraph Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Public Overridable Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
)
abstract InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean)"]

See Also

Reference

Container Class
InsertParagraph Overload


Container.InsertParagraph Method (Int32, String, Boolean)

ContainerInsertParagraph Method (Int32, String, Boolean)

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Public Overridable Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
)
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

Reference

Container Class
InsertParagraph Overload


Container.InsertParagraph Method (String, Boolean, Formatting)

ContainerInsertParagraph Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overridable Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)
abstract InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Container Class
InsertParagraph Overload


Container.InsertParagraph Method (Int32, String, Boolean, Formatting)

ContainerInsertParagraph Method (Int32, String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overridable Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Container.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Container Class
InsertParagraph Overload


Container.InsertSection Method

ContainerInsertSection Method
Overload List
 | Name | Description
Public method | InsertSection |
Public method | InsertSection(Boolean) |
Top
See Also

Reference

Container Class


Container.InsertSection Method

ContainerInsertSection Method

[Missing <summary> documentation for "M:Novacode.Container.InsertSection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual void InsertSection()
Public Overridable Sub InsertSection
public:
virtual void InsertSection()
abstract InsertSection : unit -> unit
override InsertSection : unit -> unit
See Also

Reference

Container Class
InsertSection Overload


Container.InsertSection Method (Boolean)

ContainerInsertSection Method (Boolean)

[Missing <summary> documentation for "M:Novacode.Container.InsertSection(System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual void InsertSection(
    bool trackChanges
)
Public Overridable Sub InsertSection (
    trackChanges As Boolean
)
public:
virtual void InsertSection(
    bool trackChanges
)
abstract InsertSection :
        trackChanges : bool -> unit
override InsertSection :
        trackChanges : bool -> unit

Parameters

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertSection(System.Boolean)"]

See Also

Reference

Container Class
InsertSection Overload


Container.InsertSectionPageBreak Method

ContainerInsertSectionPageBreak Method

[Missing <summary> documentation for "M:Novacode.Container.InsertSectionPageBreak(System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual void InsertSectionPageBreak(
    bool trackChanges = false
)
Public Overridable Sub InsertSectionPageBreak (
    Optional trackChanges As Boolean = false
)
public:
virtual void InsertSectionPageBreak(
    bool trackChanges = false
)
abstract InsertSectionPageBreak :
        ?trackChanges : bool
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
*)
-> unit
override InsertSectionPageBreak :
        ?trackChanges : bool
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
*)
-> unit

Parameters

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.InsertSectionPageBreak(System.Boolean)"]

See Also

Reference

Container Class


Container.InsertTable Method

ContainerInsertTable Method
Overload List
 | Name | Description
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Top
See Also

Reference

Container Class


Container.InsertTable Method (Table)

ContainerInsertTable Method (Table)

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    Table t
)
Public Function InsertTable (
    t As Table
) As Table
public:
Table^ InsertTable(
    Table^ t
)
member InsertTable :
        t : Table -> Table

Parameters

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.Container.InsertTable(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(Novacode.Table)"]

See Also

Reference

Container Class
InsertTable Overload


Container.InsertTable Method (Int32, Table)

ContainerInsertTable Method (Int32, Table)

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int index,
    Table t
)
Public Function InsertTable (
    index As Integer,
    t As Table
) As Table
public:
Table^ InsertTable(
    int index,
    Table^ t
)
member InsertTable :
        index : int *
        t : Table -> Table

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(System.Int32,Novacode.Table)"]

See Also

Reference

Container Class
InsertTable Overload


Container.InsertTable Method (Int32, Int32)

ContainerInsertTable Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Table InsertTable(
    int rowCount,
    int columnCount
)
Public Overridable Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
virtual Table^ InsertTable(
    int rowCount,
    int columnCount
)
abstract InsertTable :
        rowCount : int *
        columnCount : int -> Table
override InsertTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32)"]

See Also

Reference

Container Class
InsertTable Overload


Container.InsertTable Method (Int32, Int32, Int32)

ContainerInsertTable Method (Int32, Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int index,
    int rowCount,
    int columnCount
)
Public Function InsertTable (
    index As Integer,
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
Table^ InsertTable(
    int index,
    int rowCount,
    int columnCount
)
member InsertTable :
        index : int *
        rowCount : int *
        columnCount : int -> Table

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Container.InsertTable(System.Int32,System.Int32,System.Int32)"]

See Also

Reference

Container Class
InsertTable Overload


Container.RemoveParagraph Method

ContainerRemoveParagraph Method

[Missing <summary> documentation for "M:Novacode.Container.RemoveParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveParagraph(
    Paragraph p
)
Public Function RemoveParagraph (
    p As Paragraph
) As Boolean
public:
bool RemoveParagraph(
    Paragraph^ p
)
member RemoveParagraph :
        p : Paragraph -> bool

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Container.RemoveParagraph(Novacode.Paragraph)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.Container.RemoveParagraph(Novacode.Paragraph)"]

See Also

Reference

Container Class


Container.RemoveParagraphAt Method

ContainerRemoveParagraphAt Method

[Missing <summary> documentation for "M:Novacode.Container.RemoveParagraphAt(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveParagraphAt(
    int index
)
Public Function RemoveParagraphAt (
    index As Integer
) As Boolean
public:
bool RemoveParagraphAt(
    int index
)
member RemoveParagraphAt :
        index : int -> bool

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Container.RemoveParagraphAt(System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.Container.RemoveParagraphAt(System.Int32)"]

See Also

Reference

Container Class


Container.RemoveTextInGivenFormat Method

ContainerRemoveTextInGivenFormat Method

[Missing <summary> documentation for "M:Novacode.Container.RemoveTextInGivenFormat(Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int RemoveTextInGivenFormat(
    Formatting matchFormatting,
    MatchFormattingOptions fo = MatchFormattingOptions.SubsetMatch
)
Public Function RemoveTextInGivenFormat (
    matchFormatting As Formatting,
    Optional fo As MatchFormattingOptions = MatchFormattingOptions.SubsetMatch
) As Integer
public:
int RemoveTextInGivenFormat(
    Formatting^ matchFormatting,
    MatchFormattingOptions fo = MatchFormattingOptions::SubsetMatch
)
member RemoveTextInGivenFormat :
        matchFormatting : Formatting *
        ?fo : MatchFormattingOptions
(* Defaults:
        let _fo = defaultArg fo MatchFormattingOptions.SubsetMatch
*)
-> int

Parameters

matchFormatting
Type: NovacodeFormatting

[Missing <param name="matchFormatting"/> documentation for "M:Novacode.Container.RemoveTextInGivenFormat(Novacode.Formatting,Novacode.MatchFormattingOptions)"]

fo (Optional)
Type: NovacodeMatchFormattingOptions

[Missing <param name="fo"/> documentation for "M:Novacode.Container.RemoveTextInGivenFormat(Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Novacode.Container.RemoveTextInGivenFormat(Novacode.Formatting,Novacode.MatchFormattingOptions)"]

See Also

Reference

Container Class


Container.ReplaceText Method

ContainerReplaceText Method
Overload List
 | Name | Description
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Top
See Also

Reference

Container Class


Container.ReplaceText Method (String, Func(String, String), Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions)

ContainerReplaceText Method (String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions)

[Missing <summary> documentation for "M:Novacode.Container.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual void ReplaceText(
    string searchValue,
    Func<string, string> regexMatchHandler,
    bool trackChanges = false,
    RegexOptions options = RegexOptions.None,
    Formatting newFormatting = null,
    Formatting matchFormatting = null,
    MatchFormattingOptions formattingOptions = MatchFormattingOptions.SubsetMatch
)
Public Overridable Sub ReplaceText (
    searchValue As String,
    regexMatchHandler As Func(Of String, String),
    Optional trackChanges As Boolean = false,
    Optional options As RegexOptions = RegexOptions.None,
    Optional newFormatting As Formatting = Nothing,
    Optional matchFormatting As Formatting = Nothing,
    Optional formattingOptions As MatchFormattingOptions = MatchFormattingOptions.SubsetMatch
)
public:
virtual void ReplaceText(
    String^ searchValue,
    Func<String^, String^>^ regexMatchHandler,
    bool trackChanges = false,
    RegexOptions options = RegexOptions::None,
    Formatting^ newFormatting = nullptr,
    Formatting^ matchFormatting = nullptr,
    MatchFormattingOptions formattingOptions = MatchFormattingOptions::SubsetMatch
)
abstract ReplaceText :
        searchValue : string *
        regexMatchHandler : Func<string, string> *
        ?trackChanges : bool *
        ?options : RegexOptions *
        ?newFormatting : Formatting *
        ?matchFormatting : Formatting *
        ?formattingOptions : MatchFormattingOptions
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _options = defaultArg options RegexOptions.None
        let _newFormatting = defaultArg newFormatting null
        let _matchFormatting = defaultArg matchFormatting null
        let _formattingOptions = defaultArg formattingOptions MatchFormattingOptions.SubsetMatch
*)
-> unit
override ReplaceText :
        searchValue : string *
        regexMatchHandler : Func<string, string> *
        ?trackChanges : bool *
        ?options : RegexOptions *
        ?newFormatting : Formatting *
        ?matchFormatting : Formatting *
        ?formattingOptions : MatchFormattingOptions
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _options = defaultArg options RegexOptions.None
        let _newFormatting = defaultArg newFormatting null
        let _matchFormatting = defaultArg matchFormatting null
        let _formattingOptions = defaultArg formattingOptions MatchFormattingOptions.SubsetMatch
*)
-> unit

Parameters

searchValue
Type: SystemString

[Missing <param name="searchValue"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

regexMatchHandler
Type: SystemFunc String, String

[Missing <param name="regexMatchHandler"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

options (Optional)
Type: System.Text.RegularExpressionsRegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newFormatting (Optional)
Type: NovacodeFormatting

[Missing <param name="newFormatting"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

matchFormatting (Optional)
Type: NovacodeFormatting

[Missing <param name="matchFormatting"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

formattingOptions (Optional)
Type: NovacodeMatchFormattingOptions

[Missing <param name="formattingOptions"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

See Also

Reference

Container Class
ReplaceText Overload


Container.ReplaceText Method (String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions)

ContainerReplaceText Method (String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions)

[Missing <summary> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual void ReplaceText(
    string searchValue,
    string newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions.None,
    Formatting newFormatting = null,
    Formatting matchFormatting = null,
    MatchFormattingOptions formattingOptions = MatchFormattingOptions.SubsetMatch
)
Public Overridable Sub ReplaceText (
    searchValue As String,
    newValue As String,
    Optional trackChanges As Boolean = false,
    Optional options As RegexOptions = RegexOptions.None,
    Optional newFormatting As Formatting = Nothing,
    Optional matchFormatting As Formatting = Nothing,
    Optional formattingOptions As MatchFormattingOptions = MatchFormattingOptions.SubsetMatch
)
public:
virtual void ReplaceText(
    String^ searchValue,
    String^ newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions::None,
    Formatting^ newFormatting = nullptr,
    Formatting^ matchFormatting = nullptr,
    MatchFormattingOptions formattingOptions = MatchFormattingOptions::SubsetMatch
)
abstract ReplaceText :
        searchValue : string *
        newValue : string *
        ?trackChanges : bool *
        ?options : RegexOptions *
        ?newFormatting : Formatting *
        ?matchFormatting : Formatting *
        ?formattingOptions : MatchFormattingOptions
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _options = defaultArg options RegexOptions.None
        let _newFormatting = defaultArg newFormatting null
        let _matchFormatting = defaultArg matchFormatting null
        let _formattingOptions = defaultArg formattingOptions MatchFormattingOptions.SubsetMatch
*)
-> unit
override ReplaceText :
        searchValue : string *
        newValue : string *
        ?trackChanges : bool *
        ?options : RegexOptions *
        ?newFormatting : Formatting *
        ?matchFormatting : Formatting *
        ?formattingOptions : MatchFormattingOptions
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _options = defaultArg options RegexOptions.None
        let _newFormatting = defaultArg newFormatting null
        let _matchFormatting = defaultArg matchFormatting null
        let _formattingOptions = defaultArg formattingOptions MatchFormattingOptions.SubsetMatch
*)
-> unit

Parameters

searchValue
Type: SystemString

[Missing <param name="searchValue"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newValue
Type: SystemString

[Missing <param name="newValue"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

options (Optional)
Type: System.Text.RegularExpressionsRegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newFormatting (Optional)
Type: NovacodeFormatting

[Missing <param name="newFormatting"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

matchFormatting (Optional)
Type: NovacodeFormatting

[Missing <param name="matchFormatting"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

formattingOptions (Optional)
Type: NovacodeMatchFormattingOptions

[Missing <param name="formattingOptions"/> documentation for "M:Novacode.Container.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

See Also

Reference

Container Class
ReplaceText Overload


Container.SetDirection Method

ContainerSetDirection Method

[Missing <summary> documentation for "M:Novacode.Container.SetDirection(Novacode.Direction)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetDirection(
    Direction direction
)
Public Overridable Sub SetDirection (
    direction As Direction
)
public:
virtual void SetDirection(
    Direction direction
)
abstract SetDirection :
        direction : Direction -> unit
override SetDirection :
        direction : Direction -> unit

Parameters

direction
Type: NovacodeDirection

[Missing <param name="direction"/> documentation for "M:Novacode.Container.SetDirection(Novacode.Direction)"]

See Also

Reference

Container Class


Container.ValidateBookmarks Method

ContainerValidateBookmarks Method

[Missing <summary> documentation for "M:Novacode.Container.ValidateBookmarks(System.String[])"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string[] ValidateBookmarks(
    params string[] bookmarkNames
)
Public Function ValidateBookmarks (
    ParamArray bookmarkNames As String()
) As String()
public:
array<String^>^ ValidateBookmarks(
    ... array<String^>^ bookmarkNames
)
member ValidateBookmarks :
        bookmarkNames : string[] -> string[]

Parameters

bookmarkNames
Type: SystemString

[Missing <param name="bookmarkNames"/> documentation for "M:Novacode.Container.ValidateBookmarks(System.String[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Novacode.Container.ValidateBookmarks(System.String[])"]

See Also

Reference

Container Class


Container Fields

Container Fields

The Container type exposes the following members.

Fields
 | Name | Description
Public field | ParentContainer |
Top
See Also

Reference

Container Class


Container.ParentContainer Field

ContainerParentContainer Field

[Missing <summary> documentation for "F:Novacode.Container.ParentContainer"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public ContainerType ParentContainer
Public ParentContainer As ContainerType
public:
ContainerType ParentContainer
val mutable ParentContainer: ContainerType

Field Value

Type: ContainerType
See Also

Reference

Container Class


ContainerType Enumeration

ContainerType Enumeration

[Missing <summary> documentation for "T:Novacode.ContainerType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum ContainerType
Public Enumeration ContainerType
public enum class ContainerType
type ContainerType
Members
Member name | Value | Description
None | 0 |
TOC | 1 |
Section | 2 |
Cell | 3 |
Table | 4 |
Header | 5 |
Footer | 6 |
Paragraph | 7 |
Body | 8 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


CustomProperty Class

CustomProperty Class

[Missing <summary> documentation for "T:Novacode.CustomProperty"]

Inheritance Hierarchy
SystemObject
NovacodeCustomProperty

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class CustomProperty
Public Class CustomProperty
public ref class CustomProperty
type CustomProperty =  class end

The CustomProperty type exposes the following members.

Constructors
 | Name | Description
Public method | CustomProperty(String, Boolean) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, DateTime) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, Double) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, Int32) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, String) | Initializes a new instance of the CustomProperty class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


CustomProperty Constructor

CustomProperty Constructor
Overload List
 | Name | Description
Public method | CustomProperty(String, Boolean) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, DateTime) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, Double) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, Int32) | Initializes a new instance of the CustomProperty class
Public method | CustomProperty(String, String) | Initializes a new instance of the CustomProperty class
Top
See Also

Reference

CustomProperty Class


CustomProperty Constructor (String, Boolean)

CustomProperty Constructor (String, Boolean)
Initializes a new instance of the CustomProperty class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public CustomProperty(
    string name,
    bool value
)
Public Sub New (
    name As String,
    value As Boolean
)
public:
CustomProperty(
    String^ name,
    bool value
)
new :
        name : string *
        value : bool -> CustomProperty

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Boolean)"]

value
Type: SystemBoolean

[Missing <param name="value"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Boolean)"]

See Also

Reference

CustomProperty Class
CustomProperty Overload


CustomProperty Constructor (String, DateTime)

CustomProperty Constructor (String, DateTime)
Initializes a new instance of the CustomProperty class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public CustomProperty(
    string name,
    DateTime value
)
Public Sub New (
    name As String,
    value As DateTime
)
public:
CustomProperty(
    String^ name,
    DateTime value
)
new :
        name : string *
        value : DateTime -> CustomProperty

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.DateTime)"]

value
Type: SystemDateTime

[Missing <param name="value"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.DateTime)"]

See Also

Reference

CustomProperty Class
CustomProperty Overload


CustomProperty Constructor (String, Double)

CustomProperty Constructor (String, Double)
Initializes a new instance of the CustomProperty class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public CustomProperty(
    string name,
    double value
)
Public Sub New (
    name As String,
    value As Double
)
public:
CustomProperty(
    String^ name,
    double value
)
new :
        name : string *
        value : float -> CustomProperty

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Double)"]

value
Type: SystemDouble

[Missing <param name="value"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Double)"]

See Also

Reference

CustomProperty Class
CustomProperty Overload


CustomProperty Constructor (String, Int32)

CustomProperty Constructor (String, Int32)
Initializes a new instance of the CustomProperty class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public CustomProperty(
    string name,
    int value
)
Public Sub New (
    name As String,
    value As Integer
)
public:
CustomProperty(
    String^ name,
    int value
)
new :
        name : string *
        value : int -> CustomProperty

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Int32)"]

value
Type: SystemInt32

[Missing <param name="value"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.Int32)"]

See Also

Reference

CustomProperty Class
CustomProperty Overload


CustomProperty Constructor (String, String)

CustomProperty Constructor (String, String)
Initializes a new instance of the CustomProperty class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public CustomProperty(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
CustomProperty(
    String^ name,
    String^ value
)
new :
        name : string *
        value : string -> CustomProperty

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Novacode.CustomProperty.#ctor(System.String,System.String)"]

See Also

Reference

CustomProperty Class
CustomProperty Overload


CustomProperty Properties

CustomProperty Properties

The CustomProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

CustomProperty Class


CustomProperty.Name Property

CustomPropertyName Property

[Missing <summary> documentation for "P:Novacode.CustomProperty.Name"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

CustomProperty Class


CustomProperty.Value Property

CustomPropertyValue Property

[Missing <summary> documentation for "P:Novacode.CustomProperty.Value"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
public:
property Object^ Value {
    Object^ get ();
}
member Value : Object with get

Property Value

Type: Object
See Also

Reference

CustomProperty Class


CustomProperty Methods

CustomProperty Methods

The CustomProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomProperty Class


Direction Enumeration

Direction Enumeration

[Missing <summary> documentation for "T:Novacode.Direction"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum Direction
Public Enumeration Direction
public enum class Direction
type Direction
Members
Member name | Value | Description
LeftToRight | 0 |
RightToLeft | 1 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


DisplayBlanksAs Enumeration

DisplayBlanksAs Enumeration

[Missing <summary> documentation for "T:Novacode.DisplayBlanksAs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum DisplayBlanksAs
Public Enumeration DisplayBlanksAs
public enum class DisplayBlanksAs
type DisplayBlanksAs
Members
Member name | Value | Description
Gap | 0 |
Span | 1 |
Zero | 2 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


DocProperty Class

DocProperty Class

[Missing <summary> documentation for "T:Novacode.DocProperty"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeDocProperty

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class DocProperty : DocXElement
Public Class DocProperty
    Inherits DocXElement
public ref class DocProperty : public DocXElement
type DocProperty =
    class
        inherit DocXElement
    end

The DocProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


DocProperty Properties

DocProperty Properties

The DocProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

DocProperty Class


DocProperty.Name Property

DocPropertyName Property

[Missing <summary> documentation for "P:Novacode.DocProperty.Name"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

DocProperty Class


DocProperty Methods

DocProperty Methods

The DocProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocProperty Class


DocumentTypes Enumeration

DocumentTypes Enumeration

[Missing <summary> documentation for "T:Novacode.DocumentTypes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum DocumentTypes
Public Enumeration DocumentTypes
public enum class DocumentTypes
type DocumentTypes
Members
Member name | Value | Description
Document | 0 |
Template | 1 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


DocX Class

DocX Class

[Missing <summary> documentation for "T:Novacode.DocX"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeContainer
NovacodeDocX

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class DocX : Container, IDisposable
Public Class DocX
    Inherits Container
    Implements IDisposable
public ref class DocX : public Container,
    IDisposable
type DocX =
    class
        inherit Container
        interface IDisposable
    end

The DocX type exposes the following members.

Properties
 | Name | Description
Public property | Bookmarks |
Public property | CoreProperties |
Public property | CustomProperties |
Public property | DifferentFirstPage |
Public property | DifferentOddAndEvenPages |
Public property | EndnotesText |
Public property | Footers |
Public property | FootnotesText |
Public property | Headers |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images |
Public property | isProtected |
Public property | Lists | (Overrides ContainerLists.)
Public property | MarginBottom |
Public property | MarginLeft |
Public property | MarginRight |
Public property | MarginTop |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | PageHeight |
Public property | PageLayout |
Public property | PageWidth |
Public property | Paragraphs | (Overrides ContainerParagraphs.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides ContainerTables.)
Public property | Text |
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | AddCoreProperty |
Public method | AddCustomProperty |
Public method | AddFooters |
Public method | AddHeaders |
Public method | AddHyperlink |
Public method | AddImage(Stream) |
Public method | AddImage(String) |
Public method | AddList |
Public method | AddListItem |
Public method | AddProtection(EditRestrictions) |
Public method | AddProtection(EditRestrictions, String) |
Public method | AddTable |
Public method | ApplyTemplate(Stream) |
Public method | ApplyTemplate(String) |
Public method | ApplyTemplate(Stream, Boolean) |
Public method | ApplyTemplate(String, Boolean) |
Protected method | clonePackagePart |
Protected method | clonePackageRelationship |
Public method | Copy |
 | Create(Stream, DocumentTypes) |
 | Create(String, DocumentTypes) |
Public method | Dispose | Releases all resources used by the DocX
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMD5HashFromStream |
Public method | GetProtectionType |
Public method | GetSections |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertChart |
Public method | InsertDefaultTableOfContents |
Public method | InsertDocument |
Public method | InsertEquation | (Overrides ContainerInsertEquation(String).)
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |
Public method | InsertParagraph | (Overrides ContainerInsertParagraph.)
Public method | InsertParagraph(String) | (Overrides ContainerInsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides ContainerInsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides ContainerInsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides ContainerInsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides ContainerInsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertParagraphs |
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Public method | InsertTableOfContents(String, TableOfContentsSwitches, String, Int32, NullableInt32) |
Public method | InsertTableOfContents(Paragraph, String, TableOfContentsSwitches, String, Int32, NullableInt32) |
 | Load(Stream) |
 | Load(String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveProtection |
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | Save |
Public method | SaveAs(Stream) |
Public method | SaveAs(String) |
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
Fields
 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


DocX Properties

DocX Properties

The DocX type exposes the following members.

Properties
 | Name | Description
Public property | Bookmarks |
Public property | CoreProperties |
Public property | CustomProperties |
Public property | DifferentFirstPage |
Public property | DifferentOddAndEvenPages |
Public property | EndnotesText |
Public property | Footers |
Public property | FootnotesText |
Public property | Headers |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images |
Public property | isProtected |
Public property | Lists | (Overrides ContainerLists.)
Public property | MarginBottom |
Public property | MarginLeft |
Public property | MarginRight |
Public property | MarginTop |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | PageHeight |
Public property | PageLayout |
Public property | PageWidth |
Public property | Paragraphs | (Overrides ContainerParagraphs.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides ContainerTables.)
Public property | Text |
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

DocX Class


DocX.Bookmarks Property

DocXBookmarks Property

[Missing <summary> documentation for "P:Novacode.DocX.Bookmarks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public BookmarkCollection Bookmarks { get; }
Public ReadOnly Property Bookmarks As BookmarkCollection
    Get
public:
property BookmarkCollection^ Bookmarks {
    BookmarkCollection^ get ();
}
member Bookmarks : BookmarkCollection with get

Property Value

Type: BookmarkCollection
See Also

Reference

DocX Class


DocX.CoreProperties Property

DocXCoreProperties Property

[Missing <summary> documentation for "P:Novacode.DocX.CoreProperties"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> CoreProperties { get; }
Public ReadOnly Property CoreProperties As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ CoreProperties {
    Dictionary<String^, String^>^ get ();
}
member CoreProperties : Dictionary<string, string> with get

Property Value

Type: Dictionary String, String
See Also

Reference

DocX Class


DocX.CustomProperties Property

DocXCustomProperties Property

[Missing <summary> documentation for "P:Novacode.DocX.CustomProperties"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, CustomProperty> CustomProperties { get; }
Public ReadOnly Property CustomProperties As Dictionary(Of String, CustomProperty)
    Get
public:
property Dictionary<String^, CustomProperty^>^ CustomProperties {
    Dictionary<String^, CustomProperty^>^ get ();
}
member CustomProperties : Dictionary<string, CustomProperty> with get

Property Value

Type: Dictionary String, CustomProperty
See Also

Reference

DocX Class


DocX.DifferentFirstPage Property

DocXDifferentFirstPage Property

[Missing <summary> documentation for "P:Novacode.DocX.DifferentFirstPage"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool DifferentFirstPage { get; set; }
Public Property DifferentFirstPage As Boolean
    Get
    Set
public:
property bool DifferentFirstPage {
    bool get ();
    void set (bool value);
}
member DifferentFirstPage : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DocX Class


DocX.DifferentOddAndEvenPages Property

DocXDifferentOddAndEvenPages Property

[Missing <summary> documentation for "P:Novacode.DocX.DifferentOddAndEvenPages"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool DifferentOddAndEvenPages { get; set; }
Public Property DifferentOddAndEvenPages As Boolean
    Get
    Set
public:
property bool DifferentOddAndEvenPages {
    bool get ();
    void set (bool value);
}
member DifferentOddAndEvenPages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DocX Class


DocX.EndnotesText Property

DocXEndnotesText Property

[Missing <summary> documentation for "P:Novacode.DocX.EndnotesText"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> EndnotesText { get; }
Public ReadOnly Property EndnotesText As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ EndnotesText {
    IEnumerable<String^>^ get ();
}
member EndnotesText : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

DocX Class


DocX.Footers Property

DocXFooters Property

[Missing <summary> documentation for "P:Novacode.DocX.Footers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Footers Footers { get; }
Public ReadOnly Property Footers As Footers
    Get
public:
property Footers^ Footers {
    Footers^ get ();
}
member Footers : Footers with get

Property Value

Type: Footers
See Also

Reference

DocX Class


DocX.FootnotesText Property

DocXFootnotesText Property

[Missing <summary> documentation for "P:Novacode.DocX.FootnotesText"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> FootnotesText { get; }
Public ReadOnly Property FootnotesText As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ FootnotesText {
    IEnumerable<String^>^ get ();
}
member FootnotesText : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

DocX Class


DocX.Headers Property

DocXHeaders Property

[Missing <summary> documentation for "P:Novacode.DocX.Headers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Headers Headers { get; }
Public ReadOnly Property Headers As Headers
    Get
public:
property Headers^ Headers {
    Headers^ get ();
}
member Headers : Headers with get

Property Value

Type: Headers
See Also

Reference

DocX Class


DocX.Images Property

DocXImages Property

[Missing <summary> documentation for "P:Novacode.DocX.Images"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Image> Images { get; }
Public ReadOnly Property Images As List(Of Image)
    Get
public:
property List<Image^>^ Images {
    List<Image^>^ get ();
}
member Images : List<Image> with get

Property Value

Type: List Image
See Also

Reference

DocX Class


DocX.isProtected Property

DocXisProtected Property

[Missing <summary> documentation for "P:Novacode.DocX.isProtected"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool isProtected { get; }
Public ReadOnly Property isProtected As Boolean
    Get
public:
property bool isProtected {
    bool get ();
}
member isProtected : bool with get

Property Value

Type: Boolean
See Also

Reference

DocX Class


DocX.Lists Property

DocXLists Property

[Missing <summary> documentation for "P:Novacode.DocX.Lists"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override List<List> Lists { get; }
Public Overrides ReadOnly Property Lists As List(Of List)
    Get
public:
virtual property List<List^>^ Lists {
    List<List^>^ get () override;
}
abstract Lists : List<List> with get
override Lists : List<List> with get

Property Value

Type: List List
See Also

Reference

DocX Class


DocX.MarginBottom Property

DocXMarginBottom Property

[Missing <summary> documentation for "P:Novacode.DocX.MarginBottom"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float MarginBottom { get; set; }
Public Property MarginBottom As Single
    Get
    Set
public:
property float MarginBottom {
    float get ();
    void set (float value);
}
member MarginBottom : float32 with get, set

Property Value

Type: Single
See Also

Reference

DocX Class


DocX.MarginLeft Property

DocXMarginLeft Property

[Missing <summary> documentation for "P:Novacode.DocX.MarginLeft"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float MarginLeft { get; set; }
Public Property MarginLeft As Single
    Get
    Set
public:
property float MarginLeft {
    float get ();
    void set (float value);
}
member MarginLeft : float32 with get, set

Property Value

Type: Single
See Also

Reference

DocX Class


DocX.MarginRight Property

DocXMarginRight Property

[Missing <summary> documentation for "P:Novacode.DocX.MarginRight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float MarginRight { get; set; }
Public Property MarginRight As Single
    Get
    Set
public:
property float MarginRight {
    float get ();
    void set (float value);
}
member MarginRight : float32 with get, set

Property Value

Type: Single
See Also

Reference

DocX Class


DocX.MarginTop Property

DocXMarginTop Property

[Missing <summary> documentation for "P:Novacode.DocX.MarginTop"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float MarginTop { get; set; }
Public Property MarginTop As Single
    Get
    Set
public:
property float MarginTop {
    float get ();
    void set (float value);
}
member MarginTop : float32 with get, set

Property Value

Type: Single
See Also

Reference

DocX Class


DocX.PageHeight Property

DocXPageHeight Property

[Missing <summary> documentation for "P:Novacode.DocX.PageHeight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float PageHeight { get; set; }
Public Property PageHeight As Single
    Get
    Set
public:
property float PageHeight {
    float get ();
    void set (float value);
}
member PageHeight : float32 with get, set

Property Value

Type: Single
See Also

Reference

DocX Class


DocX.PageLayout Property

DocXPageLayout Property

[Missing <summary> documentation for "P:Novacode.DocX.PageLayout"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public PageLayout PageLayout { get; }
Public ReadOnly Property PageLayout As PageLayout
    Get
public:
property PageLayout^ PageLayout {
    PageLayout^ get ();
}
member PageLayout : PageLayout with get

Property Value

Type: PageLayout
See Also

Reference

DocX Class


DocX.PageWidth Property

DocXPageWidth Property

[Missing <summary> documentation for "P:Novacode.DocX.PageWidth"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float PageWidth { get; set; }
Public Property PageWidth As Single
    Get
    Set
public:
property float PageWidth {
    float get ();
    void set (float value);
}
member PageWidth : float32 with get, set

Property Value

Type: Single
See Also

Reference

DocX Class


DocX.Paragraphs Property

DocXParagraphs Property

[Missing <summary> documentation for "P:Novacode.DocX.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override ReadOnlyCollection<Paragraph> Paragraphs { get; }
Public Overrides ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get () override;
}
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection Paragraph
See Also

Reference

DocX Class


DocX.Tables Property

DocXTables Property

[Missing <summary> documentation for "P:Novacode.DocX.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override List<Table> Tables { get; }
Public Overrides ReadOnly Property Tables As List(Of Table)
    Get
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get () override;
}
abstract Tables : List<Table> with get
override Tables : List<Table> with get

Property Value

Type: List Table
See Also

Reference

DocX Class


DocX.Text Property

DocXText Property

[Missing <summary> documentation for "P:Novacode.DocX.Text"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}
member Text : string with get

Property Value

Type: String
See Also

Reference

DocX Class


DocX Methods

DocX Methods

The DocX type exposes the following members.

Methods
 | Name | Description
Public method | AddCoreProperty |
Public method | AddCustomProperty |
Public method | AddFooters |
Public method | AddHeaders |
Public method | AddHyperlink |
Public method | AddImage(Stream) |
Public method | AddImage(String) |
Public method | AddList |
Public method | AddListItem |
Public method | AddProtection(EditRestrictions) |
Public method | AddProtection(EditRestrictions, String) |
Public method | AddTable |
Public method | ApplyTemplate(Stream) |
Public method | ApplyTemplate(String) |
Public method | ApplyTemplate(Stream, Boolean) |
Public method | ApplyTemplate(String, Boolean) |
Protected method | clonePackagePart |
Protected method | clonePackageRelationship |
Public method | Copy |
 | Create(Stream, DocumentTypes) |
 | Create(String, DocumentTypes) |
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMD5HashFromStream |
Public method | GetProtectionType |
Public method | GetSections |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertChart |
Public method | InsertDefaultTableOfContents |
Public method | InsertDocument |
Public method | InsertEquation | (Overrides ContainerInsertEquation(String).)
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |
Public method | InsertParagraph | (Overrides ContainerInsertParagraph.)
Public method | InsertParagraph(String) | (Overrides ContainerInsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides ContainerInsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides ContainerInsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides ContainerInsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides ContainerInsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertParagraphs |
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Public method | InsertTableOfContents(String, TableOfContentsSwitches, String, Int32, NullableInt32) |
Public method | InsertTableOfContents(Paragraph, String, TableOfContentsSwitches, String, Int32, NullableInt32) |
 | Load(Stream) |
 | Load(String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveProtection |
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | Save |
Public method | SaveAs(Stream) |
Public method | SaveAs(String) |
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
See Also

Reference

DocX Class


DocX.AddCoreProperty Method

DocXAddCoreProperty Method

[Missing <summary> documentation for "M:Novacode.DocX.AddCoreProperty(System.String,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddCoreProperty(
    string propertyName,
    string propertyValue
)
Public Sub AddCoreProperty (
    propertyName As String,
    propertyValue As String
)
public:
void AddCoreProperty(
    String^ propertyName,
    String^ propertyValue
)
member AddCoreProperty :
        propertyName : string *
        propertyValue : string -> unit

Parameters

propertyName
Type: SystemString

[Missing <param name="propertyName"/> documentation for "M:Novacode.DocX.AddCoreProperty(System.String,System.String)"]

propertyValue
Type: SystemString

[Missing <param name="propertyValue"/> documentation for "M:Novacode.DocX.AddCoreProperty(System.String,System.String)"]

See Also

Reference

DocX Class


DocX.AddCustomProperty Method

DocXAddCustomProperty Method

[Missing <summary> documentation for "M:Novacode.DocX.AddCustomProperty(Novacode.CustomProperty)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddCustomProperty(
    CustomProperty cp
)
Public Sub AddCustomProperty (
    cp As CustomProperty
)
public:
void AddCustomProperty(
    CustomProperty^ cp
)
member AddCustomProperty :
        cp : CustomProperty -> unit

Parameters

cp
Type: NovacodeCustomProperty

[Missing <param name="cp"/> documentation for "M:Novacode.DocX.AddCustomProperty(Novacode.CustomProperty)"]

See Also

Reference

DocX Class


DocX.AddFooters Method

DocXAddFooters Method

[Missing <summary> documentation for "M:Novacode.DocX.AddFooters"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddFooters()
Public Sub AddFooters
public:
void AddFooters()
member AddFooters : unit -> unit
See Also

Reference

DocX Class


DocX.AddHeaders Method

DocXAddHeaders Method

[Missing <summary> documentation for "M:Novacode.DocX.AddHeaders"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddHeaders()
Public Sub AddHeaders
public:
void AddHeaders()
member AddHeaders : unit -> unit
See Also

Reference

DocX Class


DocX.AddHyperlink Method

DocXAddHyperlink Method

[Missing <summary> documentation for "M:Novacode.DocX.AddHyperlink(System.String,System.Uri)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Hyperlink AddHyperlink(
    string text,
    Uri uri
)
Public Function AddHyperlink (
    text As String,
    uri As Uri
) As Hyperlink
public:
Hyperlink^ AddHyperlink(
    String^ text,
    Uri^ uri
)
member AddHyperlink :
        text : string *
        uri : Uri -> Hyperlink

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.DocX.AddHyperlink(System.String,System.Uri)"]

uri
Type: SystemUri

[Missing <param name="uri"/> documentation for "M:Novacode.DocX.AddHyperlink(System.String,System.Uri)"]

Return Value

Type: Hyperlink

[Missing <returns> documentation for "M:Novacode.DocX.AddHyperlink(System.String,System.Uri)"]

See Also

Reference

DocX Class


DocX.AddImage Method

DocXAddImage Method
Overload List
 | Name | Description
Public method | AddImage(Stream) |
Public method | AddImage(String) |
Top
See Also

Reference

DocX Class


DocX.AddImage Method (Stream)

DocXAddImage Method (Stream)

[Missing <summary> documentation for "M:Novacode.DocX.AddImage(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Image AddImage(
    Stream stream
)
Public Function AddImage (
    stream As Stream
) As Image
public:
Image^ AddImage(
    Stream^ stream
)
member AddImage :
        stream : Stream -> Image

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.AddImage(System.IO.Stream)"]

Return Value

Type: Image

[Missing <returns> documentation for "M:Novacode.DocX.AddImage(System.IO.Stream)"]

See Also

Reference

DocX Class
AddImage Overload


DocX.AddImage Method (String)

DocXAddImage Method (String)

[Missing <summary> documentation for "M:Novacode.DocX.AddImage(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Image AddImage(
    string filename
)
Public Function AddImage (
    filename As String
) As Image
public:
Image^ AddImage(
    String^ filename
)
member AddImage :
        filename : string -> Image

Parameters

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:Novacode.DocX.AddImage(System.String)"]

Return Value

Type: Image

[Missing <returns> documentation for "M:Novacode.DocX.AddImage(System.String)"]

See Also

Reference

DocX Class
AddImage Overload


DocX.AddList Method

DocXAddList Method

[Missing <summary> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List AddList(
    string listText = null,
    int level = 0,
    ListItemType listType = ListItemType.Numbered,
    Nullable<int> startNumber = null,
    bool trackChanges = false,
    bool continueNumbering = false
)
Public Function AddList (
    Optional listText As String = Nothing,
    Optional level As Integer = 0,
    Optional listType As ListItemType = ListItemType.Numbered,
    Optional startNumber As Nullable(Of Integer) = Nothing,
    Optional trackChanges As Boolean = false,
    Optional continueNumbering As Boolean = false
) As List
public:
List^ AddList(
    String^ listText = nullptr,
    int level = 0,
    ListItemType listType = ListItemType::Numbered,
    Nullable<int> startNumber = nullptr,
    bool trackChanges = false,
    bool continueNumbering = false
)
member AddList :
        ?listText : string *
        ?level : int *
        ?listType : ListItemType *
        ?startNumber : Nullable<int> *
        ?trackChanges : bool *
        ?continueNumbering : bool
(* Defaults:
        let _listText = defaultArg listText null
        let _level = defaultArg level 0
        let _listType = defaultArg listType ListItemType.Numbered
        let _startNumber = defaultArg startNumber null
        let _trackChanges = defaultArg trackChanges false
        let _continueNumbering = defaultArg continueNumbering false
*)
-> List

Parameters

listText (Optional)
Type: SystemString

[Missing <param name="listText"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

level (Optional)
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

listType (Optional)
Type: NovacodeListItemType

[Missing <param name="listType"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

startNumber (Optional)
Type: SystemNullable Int32

[Missing <param name="startNumber"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

continueNumbering (Optional)
Type: SystemBoolean

[Missing <param name="continueNumbering"/> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.AddList(System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

See Also

Reference

DocX Class


DocX.AddListItem Method

DocXAddListItem Method

[Missing <summary> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List AddListItem(
    List list,
    string listText,
    int level = 0,
    ListItemType listType = ListItemType.Numbered,
    Nullable<int> startNumber = null,
    bool trackChanges = false,
    bool continueNumbering = false
)
Public Function AddListItem (
    list As List,
    listText As String,
    Optional level As Integer = 0,
    Optional listType As ListItemType = ListItemType.Numbered,
    Optional startNumber As Nullable(Of Integer) = Nothing,
    Optional trackChanges As Boolean = false,
    Optional continueNumbering As Boolean = false
) As List
public:
List^ AddListItem(
    List^ list,
    String^ listText,
    int level = 0,
    ListItemType listType = ListItemType::Numbered,
    Nullable<int> startNumber = nullptr,
    bool trackChanges = false,
    bool continueNumbering = false
)
member AddListItem :
        list : List *
        listText : string *
        ?level : int *
        ?listType : ListItemType *
        ?startNumber : Nullable<int> *
        ?trackChanges : bool *
        ?continueNumbering : bool
(* Defaults:
        let _level = defaultArg level 0
        let _listType = defaultArg listType ListItemType.Numbered
        let _startNumber = defaultArg startNumber null
        let _trackChanges = defaultArg trackChanges false
        let _continueNumbering = defaultArg continueNumbering false
*)
-> List

Parameters

list
Type: NovacodeList

[Missing <param name="list"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

listText
Type: SystemString

[Missing <param name="listText"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

level (Optional)
Type: SystemInt32

[Missing <param name="level"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

listType (Optional)
Type: NovacodeListItemType

[Missing <param name="listType"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

startNumber (Optional)
Type: SystemNullable Int32

[Missing <param name="startNumber"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

continueNumbering (Optional)
Type: SystemBoolean

[Missing <param name="continueNumbering"/> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.AddListItem(Novacode.List,System.String,System.Int32,Novacode.ListItemType,System.Nullable{System.Int32},System.Boolean,System.Boolean)"]

See Also

Reference

DocX Class


DocX.AddProtection Method

DocXAddProtection Method
Overload List
 | Name | Description
Public method | AddProtection(EditRestrictions) |
Public method | AddProtection(EditRestrictions, String) |
Top
See Also

Reference

DocX Class


DocX.AddProtection Method (EditRestrictions)

DocXAddProtection Method (EditRestrictions)

[Missing <summary> documentation for "M:Novacode.DocX.AddProtection(Novacode.EditRestrictions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddProtection(
    EditRestrictions er
)
Public Sub AddProtection (
    er As EditRestrictions
)
public:
void AddProtection(
    EditRestrictions er
)
member AddProtection :
        er : EditRestrictions -> unit

Parameters

er
Type: NovacodeEditRestrictions

[Missing <param name="er"/> documentation for "M:Novacode.DocX.AddProtection(Novacode.EditRestrictions)"]

See Also

Reference

DocX Class
AddProtection Overload


DocX.AddProtection Method (EditRestrictions, String)

DocXAddProtection Method (EditRestrictions, String)

[Missing <summary> documentation for "M:Novacode.DocX.AddProtection(Novacode.EditRestrictions,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddProtection(
    EditRestrictions er,
    string strPassword
)
Public Sub AddProtection (
    er As EditRestrictions,
    strPassword As String
)
public:
void AddProtection(
    EditRestrictions er,
    String^ strPassword
)
member AddProtection :
        er : EditRestrictions *
        strPassword : string -> unit

Parameters

er
Type: NovacodeEditRestrictions

[Missing <param name="er"/> documentation for "M:Novacode.DocX.AddProtection(Novacode.EditRestrictions,System.String)"]

strPassword
Type: SystemString

[Missing <param name="strPassword"/> documentation for "M:Novacode.DocX.AddProtection(Novacode.EditRestrictions,System.String)"]

See Also

Reference

DocX Class
AddProtection Overload


DocX.AddTable Method

DocXAddTable Method

[Missing <summary> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table AddTable(
    int rowCount,
    int columnCount
)
Public Function AddTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
Table^ AddTable(
    int rowCount,
    int columnCount
)
member AddTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.AddTable(System.Int32,System.Int32)"]

See Also

Reference

DocX Class


DocX.ApplyTemplate Method

DocXApplyTemplate Method
Overload List
 | Name | Description
Public method | ApplyTemplate(Stream) |
Public method | ApplyTemplate(String) |
Public method | ApplyTemplate(Stream, Boolean) |
Public method | ApplyTemplate(String, Boolean) |
Top
See Also

Reference

DocX Class


DocX.ApplyTemplate Method (Stream)

DocXApplyTemplate Method (Stream)

[Missing <summary> documentation for "M:Novacode.DocX.ApplyTemplate(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void ApplyTemplate(
    Stream templateStream
)
Public Sub ApplyTemplate (
    templateStream As Stream
)
public:
void ApplyTemplate(
    Stream^ templateStream
)
member ApplyTemplate :
        templateStream : Stream -> unit

Parameters

templateStream
Type: System.IOStream

[Missing <param name="templateStream"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.IO.Stream)"]

See Also

Reference

DocX Class
ApplyTemplate Overload


DocX.ApplyTemplate Method (String)

DocXApplyTemplate Method (String)

[Missing <summary> documentation for "M:Novacode.DocX.ApplyTemplate(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void ApplyTemplate(
    string templateFilePath
)
Public Sub ApplyTemplate (
    templateFilePath As String
)
public:
void ApplyTemplate(
    String^ templateFilePath
)
member ApplyTemplate :
        templateFilePath : string -> unit

Parameters

templateFilePath
Type: SystemString

[Missing <param name="templateFilePath"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.String)"]

See Also

Reference

DocX Class
ApplyTemplate Overload


DocX.ApplyTemplate Method (Stream, Boolean)

DocXApplyTemplate Method (Stream, Boolean)

[Missing <summary> documentation for "M:Novacode.DocX.ApplyTemplate(System.IO.Stream,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void ApplyTemplate(
    Stream templateStream,
    bool includeContent
)
Public Sub ApplyTemplate (
    templateStream As Stream,
    includeContent As Boolean
)
public:
void ApplyTemplate(
    Stream^ templateStream,
    bool includeContent
)
member ApplyTemplate :
        templateStream : Stream *
        includeContent : bool -> unit

Parameters

templateStream
Type: System.IOStream

[Missing <param name="templateStream"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.IO.Stream,System.Boolean)"]

includeContent
Type: SystemBoolean

[Missing <param name="includeContent"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.IO.Stream,System.Boolean)"]

See Also

Reference

DocX Class
ApplyTemplate Overload


DocX.ApplyTemplate Method (String, Boolean)

DocXApplyTemplate Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.DocX.ApplyTemplate(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void ApplyTemplate(
    string templateFilePath,
    bool includeContent
)
Public Sub ApplyTemplate (
    templateFilePath As String,
    includeContent As Boolean
)
public:
void ApplyTemplate(
    String^ templateFilePath,
    bool includeContent
)
member ApplyTemplate :
        templateFilePath : string *
        includeContent : bool -> unit

Parameters

templateFilePath
Type: SystemString

[Missing <param name="templateFilePath"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.String,System.Boolean)"]

includeContent
Type: SystemBoolean

[Missing <param name="includeContent"/> documentation for "M:Novacode.DocX.ApplyTemplate(System.String,System.Boolean)"]

See Also

Reference

DocX Class
ApplyTemplate Overload


DocX.clonePackagePart Method

DocXclonePackagePart Method

[Missing <summary> documentation for "M:Novacode.DocX.clonePackagePart(System.IO.Packaging.PackagePart)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
protected PackagePart clonePackagePart(
    PackagePart pp
)
Protected Function clonePackagePart (
    pp As PackagePart
) As PackagePart
protected:
PackagePart^ clonePackagePart(
    PackagePart^ pp
)
member clonePackagePart :
        pp : PackagePart -> PackagePart

Parameters

pp
Type: System.IO.PackagingPackagePart

[Missing <param name="pp"/> documentation for "M:Novacode.DocX.clonePackagePart(System.IO.Packaging.PackagePart)"]

Return Value

Type: PackagePart

[Missing <returns> documentation for "M:Novacode.DocX.clonePackagePart(System.IO.Packaging.PackagePart)"]

See Also

Reference

DocX Class


DocX.clonePackageRelationship Method

DocXclonePackageRelationship Method

[Missing <summary> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
protected void clonePackageRelationship(
    DocX remote_document,
    PackagePart pp,
    XDocument remote_mainDoc
)
Protected Sub clonePackageRelationship (
    remote_document As DocX,
    pp As PackagePart,
    remote_mainDoc As XDocument
)
protected:
void clonePackageRelationship(
    DocX^ remote_document,
    PackagePart^ pp,
    XDocument^ remote_mainDoc
)
member clonePackageRelationship :
        remote_document : DocX *
        pp : PackagePart *
        remote_mainDoc : XDocument -> unit

Parameters

remote_document
Type: NovacodeDocX

[Missing <param name="remote_document"/> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

pp
Type: System.IO.PackagingPackagePart

[Missing <param name="pp"/> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

remote_mainDoc
Type: System.Xml.LinqXDocument

[Missing <param name="remote_mainDoc"/> documentation for "M:Novacode.DocX.clonePackageRelationship(Novacode.DocX,System.IO.Packaging.PackagePart,System.Xml.Linq.XDocument)"]

See Also

Reference

DocX Class


DocX.Copy Method

DocXCopy Method

[Missing <summary> documentation for "M:Novacode.DocX.Copy"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public DocX Copy()
Public Function Copy As DocX
public:
DocX^ Copy()
member Copy : unit -> DocX

Return Value

Type: DocX

[Missing <returns> documentation for "M:Novacode.DocX.Copy"]

See Also

Reference

DocX Class


DocX.Create Method

DocXCreate Method
Overload List
Name | Description
Create(Stream, DocumentTypes) |
Create(String, DocumentTypes) |
Top
See Also

Reference

DocX Class


DocX.Create Method (Stream, DocumentTypes)

DocXCreate Method (Stream, DocumentTypes)

[Missing <summary> documentation for "M:Novacode.DocX.Create(System.IO.Stream,Novacode.DocumentTypes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public static DocX Create(
    Stream stream,
    DocumentTypes documentType = DocumentTypes.Document
)
Public Shared Function Create (
    stream As Stream,
    Optional documentType As DocumentTypes = DocumentTypes.Document
) As DocX
public:
static DocX^ Create(
    Stream^ stream,
    DocumentTypes documentType = DocumentTypes::Document
)
static member Create :
        stream : Stream *
        ?documentType : DocumentTypes
(* Defaults:
        let _documentType = defaultArg documentType DocumentTypes.Document
*)
-> DocX

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.Create(System.IO.Stream,Novacode.DocumentTypes)"]

documentType (Optional)
Type: NovacodeDocumentTypes

[Missing <param name="documentType"/> documentation for "M:Novacode.DocX.Create(System.IO.Stream,Novacode.DocumentTypes)"]

Return Value

Type: DocX

[Missing <returns> documentation for "M:Novacode.DocX.Create(System.IO.Stream,Novacode.DocumentTypes)"]

See Also

Reference

DocX Class
Create Overload


DocX.Create Method (String, DocumentTypes)

DocXCreate Method (String, DocumentTypes)

[Missing <summary> documentation for "M:Novacode.DocX.Create(System.String,Novacode.DocumentTypes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public static DocX Create(
    string filename,
    DocumentTypes documentType = DocumentTypes.Document
)
Public Shared Function Create (
    filename As String,
    Optional documentType As DocumentTypes = DocumentTypes.Document
) As DocX
public:
static DocX^ Create(
    String^ filename,
    DocumentTypes documentType = DocumentTypes::Document
)
static member Create :
        filename : string *
        ?documentType : DocumentTypes
(* Defaults:
        let _documentType = defaultArg documentType DocumentTypes.Document
*)
-> DocX

Parameters

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:Novacode.DocX.Create(System.String,Novacode.DocumentTypes)"]

documentType (Optional)
Type: NovacodeDocumentTypes

[Missing <param name="documentType"/> documentation for "M:Novacode.DocX.Create(System.String,Novacode.DocumentTypes)"]

Return Value

Type: DocX

[Missing <returns> documentation for "M:Novacode.DocX.Create(System.String,Novacode.DocumentTypes)"]

See Also

Reference

DocX Class
Create Overload


DocX.Dispose Method

DocXDispose Method
Releases all resources used by the DocX

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DocX Class


DocX.GetMD5HashFromStream Method

DocXGetMD5HashFromStream Method

[Missing <summary> documentation for "M:Novacode.DocX.GetMD5HashFromStream(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
protected string GetMD5HashFromStream(
    Stream stream
)
Protected Function GetMD5HashFromStream (
    stream As Stream
) As String
protected:
String^ GetMD5HashFromStream(
    Stream^ stream
)
member GetMD5HashFromStream :
        stream : Stream -> string

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.GetMD5HashFromStream(System.IO.Stream)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Novacode.DocX.GetMD5HashFromStream(System.IO.Stream)"]

See Also

Reference

DocX Class


DocX.GetProtectionType Method

DocXGetProtectionType Method

[Missing <summary> documentation for "M:Novacode.DocX.GetProtectionType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public EditRestrictions GetProtectionType()
Public Function GetProtectionType As EditRestrictions
public:
EditRestrictions GetProtectionType()
member GetProtectionType : unit -> EditRestrictions

Return Value

Type: EditRestrictions

[Missing <returns> documentation for "M:Novacode.DocX.GetProtectionType"]

See Also

Reference

DocX Class


DocX.GetSections Method

DocXGetSections Method

[Missing <summary> documentation for "M:Novacode.DocX.GetSections"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Section> GetSections()
Public Function GetSections As List(Of Section)
public:
List<Section^>^ GetSections()
member GetSections : unit -> List<Section>

Return Value

Type: List Section

[Missing <returns> documentation for "M:Novacode.DocX.GetSections"]

See Also

Reference

DocX Class


DocX.InsertChart Method

DocXInsertChart Method

[Missing <summary> documentation for "M:Novacode.DocX.InsertChart(Novacode.Chart)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void InsertChart(
    Chart chart
)
Public Sub InsertChart (
    chart As Chart
)
public:
void InsertChart(
    Chart^ chart
)
member InsertChart :
        chart : Chart -> unit

Parameters

chart
Type: NovacodeChart

[Missing <param name="chart"/> documentation for "M:Novacode.DocX.InsertChart(Novacode.Chart)"]

See Also

Reference

DocX Class


DocX.InsertDefaultTableOfContents Method

DocXInsertDefaultTableOfContents Method

[Missing <summary> documentation for "M:Novacode.DocX.InsertDefaultTableOfContents"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public TableOfContents InsertDefaultTableOfContents()
Public Function InsertDefaultTableOfContents As TableOfContents
public:
TableOfContents^ InsertDefaultTableOfContents()
member InsertDefaultTableOfContents : unit -> TableOfContents

Return Value

Type: TableOfContents

[Missing <returns> documentation for "M:Novacode.DocX.InsertDefaultTableOfContents"]

See Also

Reference

DocX Class


DocX.InsertDocument Method

DocXInsertDocument Method

[Missing <summary> documentation for "M:Novacode.DocX.InsertDocument(Novacode.DocX)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void InsertDocument(
    DocX remote_document
)
Public Sub InsertDocument (
    remote_document As DocX
)
public:
void InsertDocument(
    DocX^ remote_document
)
member InsertDocument :
        remote_document : DocX -> unit

Parameters

remote_document
Type: NovacodeDocX

[Missing <param name="remote_document"/> documentation for "M:Novacode.DocX.InsertDocument(Novacode.DocX)"]

See Also

Reference

DocX Class


DocX.InsertEquation Method

DocXInsertEquation Method

[Missing <summary> documentation for "M:Novacode.DocX.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertEquation(
    string equation
)
Public Overrides Function InsertEquation (
    equation As String
) As Paragraph
public:
virtual Paragraph^ InsertEquation(
    String^ equation
) override
abstract InsertEquation :
        equation : string -> Paragraph
override InsertEquation :
        equation : string -> Paragraph

Parameters

equation
Type: SystemString

[Missing <param name="equation"/> documentation for "M:Novacode.DocX.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertEquation(System.String)"]

See Also

Reference

DocX Class


DocX.InsertList Method

DocXInsertList Method
Overload List
 | Name | Description
Public method | InsertList(List) |
Public method | InsertList(Int32, List) |
Public method | InsertList(List, Double) |
Public method | InsertList(List, FontFamily, Double) |
Top
See Also

Reference

DocX Class


DocX.InsertList Method (List)

DocXInsertList Method (List)

[Missing <summary> documentation for "M:Novacode.DocX.InsertList(Novacode.List)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List InsertList(
    List list
)
Public Function InsertList (
    list As List
) As List
public:
List^ InsertList(
    List^ list
)
member InsertList :
        list : List -> List

Parameters

list
Type: NovacodeList

[Missing <param name="list"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.InsertList(Novacode.List)"]

See Also

Reference

DocX Class
InsertList Overload


DocX.InsertList Method (Int32, List)

DocXInsertList Method (Int32, List)

[Missing <summary> documentation for "M:Novacode.DocX.InsertList(System.Int32,Novacode.List)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List InsertList(
    int index,
    List list
)
Public Function InsertList (
    index As Integer,
    list As List
) As List
public:
List^ InsertList(
    int index,
    List^ list
)
member InsertList :
        index : int *
        list : List -> List

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertList(System.Int32,Novacode.List)"]

list
Type: NovacodeList

[Missing <param name="list"/> documentation for "M:Novacode.DocX.InsertList(System.Int32,Novacode.List)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.InsertList(System.Int32,Novacode.List)"]

See Also

Reference

DocX Class
InsertList Overload


DocX.InsertList Method (List, Double)

DocXInsertList Method (List, Double)

[Missing <summary> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List InsertList(
    List list,
    double fontSize
)
Public Function InsertList (
    list As List,
    fontSize As Double
) As List
public:
List^ InsertList(
    List^ list,
    double fontSize
)
member InsertList :
        list : List *
        fontSize : float -> List

Parameters

list
Type: NovacodeList

[Missing <param name="list"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Double)"]

fontSize
Type: SystemDouble

[Missing <param name="fontSize"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Double)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Double)"]

See Also

Reference

DocX Class
InsertList Overload


DocX.InsertList Method (List, FontFamily, Double)

DocXInsertList Method (List, FontFamily, Double)

[Missing <summary> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List InsertList(
    List list,
    FontFamily fontFamily,
    double fontSize
)
Public Function InsertList (
    list As List,
    fontFamily As FontFamily,
    fontSize As Double
) As List
public:
List^ InsertList(
    List^ list,
    FontFamily^ fontFamily,
    double fontSize
)
member InsertList :
        list : List *
        fontFamily : FontFamily *
        fontSize : float -> List

Parameters

list
Type: NovacodeList

[Missing <param name="list"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

fontFamily
Type: System.DrawingFontFamily

[Missing <param name="fontFamily"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

fontSize
Type: SystemDouble

[Missing <param name="fontSize"/> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

Return Value

Type: List

[Missing <returns> documentation for "M:Novacode.DocX.InsertList(Novacode.List,System.Drawing.FontFamily,System.Double)"]

See Also

Reference

DocX Class
InsertList Overload


DocX.InsertParagraph Method

DocXInsertParagraph Method
Overload List
 | Name | Description
Public method | InsertParagraph | (Overrides ContainerInsertParagraph.)
Public method | InsertParagraph(String) | (Overrides ContainerInsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides ContainerInsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides ContainerInsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides ContainerInsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides ContainerInsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(Int32, String, Boolean, Formatting).)
Top
See Also

Reference

DocX Class


DocX.InsertParagraph Method

DocXInsertParagraph Method

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph()
Public Overrides Function InsertParagraph As Paragraph
public:
virtual Paragraph^ InsertParagraph() override
abstract InsertParagraph : unit -> Paragraph
override InsertParagraph : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph"]

See Also

Reference

DocX Class
InsertParagraph Overload


DocX.InsertParagraph Method (String)

DocXInsertParagraph Method (String)

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    string text
)
Public Overrides Function InsertParagraph (
    text As String
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text
) override
abstract InsertParagraph :
        text : string -> Paragraph
override InsertParagraph :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.String)"]

See Also

Reference

DocX Class
InsertParagraph Overload


DocX.InsertParagraph Method (Paragraph)

DocXInsertParagraph Method (Paragraph)

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    Paragraph p
)
Public Overrides Function InsertParagraph (
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
) override
abstract InsertParagraph :
        p : Paragraph -> Paragraph
override InsertParagraph :
        p : Paragraph -> Paragraph

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.DocX.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(Novacode.Paragraph)"]

See Also

Reference

DocX Class
InsertParagraph Overload


DocX.InsertParagraph Method (Int32, Paragraph)

DocXInsertParagraph Method (Int32, Paragraph)

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Public Overrides Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
) override
abstract InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph
override InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

Reference

DocX Class
InsertParagraph Overload


DocX.InsertParagraph Method (String, Boolean)

DocXInsertParagraph Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
) override
abstract InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean)"]

See Also

Reference

DocX Class
InsertParagraph Overload


DocX.InsertParagraph Method (Int32, String, Boolean)

DocXInsertParagraph Method (Int32, String, Boolean)

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
) override
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

Reference

DocX Class
InsertParagraph Overload


DocX.InsertParagraph Method (String, Boolean, Formatting)

DocXInsertParagraph Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
abstract InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

DocX Class
InsertParagraph Overload


DocX.InsertParagraph Method (Int32, String, Boolean, Formatting)

DocXInsertParagraph Method (Int32, String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

DocX Class
InsertParagraph Overload


DocX.InsertParagraphs Method

DocXInsertParagraphs Method

[Missing <summary> documentation for "M:Novacode.DocX.InsertParagraphs(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph[] InsertParagraphs(
    string text
)
Public Function InsertParagraphs (
    text As String
) As Paragraph()
public:
array<Paragraph^>^ InsertParagraphs(
    String^ text
)
member InsertParagraphs :
        text : string -> Paragraph[]

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.DocX.InsertParagraphs(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.DocX.InsertParagraphs(System.String)"]

See Also

Reference

DocX Class


DocX.InsertTable Method

DocXInsertTable Method
Overload List
 | Name | Description
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Top
See Also

Reference

DocX Class


DocX.InsertTable Method (Table)

DocXInsertTable Method (Table)

[Missing <summary> documentation for "M:Novacode.DocX.InsertTable(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    Table t
)
Public Function InsertTable (
    t As Table
) As Table
public:
Table^ InsertTable(
    Table^ t
)
member InsertTable :
        t : Table -> Table

Parameters

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.DocX.InsertTable(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.InsertTable(Novacode.Table)"]

See Also

Reference

DocX Class
InsertTable Overload


DocX.InsertTable Method (Int32, Table)

DocXInsertTable Method (Int32, Table)

[Missing <summary> documentation for "M:Novacode.DocX.InsertTable(System.Int32,Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int index,
    Table t
)
Public Function InsertTable (
    index As Integer,
    t As Table
) As Table
public:
Table^ InsertTable(
    int index,
    Table^ t
)
member InsertTable :
        index : int *
        t : Table -> Table

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,Novacode.Table)"]

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.InsertTable(System.Int32,Novacode.Table)"]

See Also

Reference

DocX Class
InsertTable Overload


DocX.InsertTable Method (Int32, Int32)

DocXInsertTable Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int rowCount,
    int columnCount
)
Public Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
Table^ InsertTable(
    int rowCount,
    int columnCount
)
member InsertTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32)"]

See Also

Reference

DocX Class
InsertTable Overload


DocX.InsertTable Method (Int32, Int32, Int32)

DocXInsertTable Method (Int32, Int32, Int32)

[Missing <summary> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int index,
    int rowCount,
    int columnCount
)
Public Function InsertTable (
    index As Integer,
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
Table^ InsertTable(
    int index,
    int rowCount,
    int columnCount
)
member InsertTable :
        index : int *
        rowCount : int *
        columnCount : int -> Table

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32,System.Int32)"]

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.DocX.InsertTable(System.Int32,System.Int32,System.Int32)"]

See Also

Reference

DocX Class
InsertTable Overload


DocX.InsertTableOfContents Method

DocXInsertTableOfContents Method
Overload List
 | Name | Description
Public method | InsertTableOfContents(String, TableOfContentsSwitches, String, Int32, NullableInt32) |
Public method | InsertTableOfContents(Paragraph, String, TableOfContentsSwitches, String, Int32, NullableInt32) |
Top
See Also

Reference

DocX Class


DocX.InsertTableOfContents Method (String, TableOfContentsSwitches, String, Int32, Nullable(Int32))

DocXInsertTableOfContents Method (String, TableOfContentsSwitches, String, Int32, NullableInt32)

[Missing <summary> documentation for "M:Novacode.DocX.InsertTableOfContents(System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public TableOfContents InsertTableOfContents(
    string title,
    TableOfContentsSwitches switches,
    string headerStyle = null,
    int maxIncludeLevel = 3,
    Nullable<int> rightTabPos = null
)
Public Function InsertTableOfContents (
    title As String,
    switches As TableOfContentsSwitches,
    Optional headerStyle As String = Nothing,
    Optional maxIncludeLevel As Integer = 3,
    Optional rightTabPos As Nullable(Of Integer) = Nothing
) As TableOfContents
public:
TableOfContents^ InsertTableOfContents(
    String^ title,
    TableOfContentsSwitches switches,
    String^ headerStyle = nullptr,
    int maxIncludeLevel = 3,
    Nullable<int> rightTabPos = nullptr
)
member InsertTableOfContents :
        title : string *
        switches : TableOfContentsSwitches *
        ?headerStyle : string *
        ?maxIncludeLevel : int *
        ?rightTabPos : Nullable<int>
(* Defaults:
        let _headerStyle = defaultArg headerStyle null
        let _maxIncludeLevel = defaultArg maxIncludeLevel 3
        let _rightTabPos = defaultArg rightTabPos null
*)
-> TableOfContents

Parameters

title
Type: SystemString

[Missing <param name="title"/> documentation for "M:Novacode.DocX.InsertTableOfContents(System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

switches
Type: NovacodeTableOfContentsSwitches

[Missing <param name="switches"/> documentation for "M:Novacode.DocX.InsertTableOfContents(System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

headerStyle (Optional)
Type: SystemString

[Missing <param name="headerStyle"/> documentation for "M:Novacode.DocX.InsertTableOfContents(System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

maxIncludeLevel (Optional)
Type: SystemInt32

[Missing <param name="maxIncludeLevel"/> documentation for "M:Novacode.DocX.InsertTableOfContents(System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

rightTabPos (Optional)
Type: SystemNullable Int32

[Missing <param name="rightTabPos"/> documentation for "M:Novacode.DocX.InsertTableOfContents(System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

Return Value

Type: TableOfContents

[Missing <returns> documentation for "M:Novacode.DocX.InsertTableOfContents(System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

See Also

Reference

DocX Class
InsertTableOfContents Overload


DocX.InsertTableOfContents Method (Paragraph, String, TableOfContentsSwitches, String, Int32, Nullable(Int32))

DocXInsertTableOfContents Method (Paragraph, String, TableOfContentsSwitches, String, Int32, NullableInt32)

[Missing <summary> documentation for "M:Novacode.DocX.InsertTableOfContents(Novacode.Paragraph,System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public TableOfContents InsertTableOfContents(
    Paragraph reference,
    string title,
    TableOfContentsSwitches switches,
    string headerStyle = null,
    int maxIncludeLevel = 3,
    Nullable<int> rightTabPos = null
)
Public Function InsertTableOfContents (
    reference As Paragraph,
    title As String,
    switches As TableOfContentsSwitches,
    Optional headerStyle As String = Nothing,
    Optional maxIncludeLevel As Integer = 3,
    Optional rightTabPos As Nullable(Of Integer) = Nothing
) As TableOfContents
public:
TableOfContents^ InsertTableOfContents(
    Paragraph^ reference,
    String^ title,
    TableOfContentsSwitches switches,
    String^ headerStyle = nullptr,
    int maxIncludeLevel = 3,
    Nullable<int> rightTabPos = nullptr
)
member InsertTableOfContents :
        reference : Paragraph *
        title : string *
        switches : TableOfContentsSwitches *
        ?headerStyle : string *
        ?maxIncludeLevel : int *
        ?rightTabPos : Nullable<int>
(* Defaults:
        let _headerStyle = defaultArg headerStyle null
        let _maxIncludeLevel = defaultArg maxIncludeLevel 3
        let _rightTabPos = defaultArg rightTabPos null
*)
-> TableOfContents

Parameters

reference
Type: NovacodeParagraph

[Missing <param name="reference"/> documentation for "M:Novacode.DocX.InsertTableOfContents(Novacode.Paragraph,System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

title
Type: SystemString

[Missing <param name="title"/> documentation for "M:Novacode.DocX.InsertTableOfContents(Novacode.Paragraph,System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

switches
Type: NovacodeTableOfContentsSwitches

[Missing <param name="switches"/> documentation for "M:Novacode.DocX.InsertTableOfContents(Novacode.Paragraph,System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

headerStyle (Optional)
Type: SystemString

[Missing <param name="headerStyle"/> documentation for "M:Novacode.DocX.InsertTableOfContents(Novacode.Paragraph,System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

maxIncludeLevel (Optional)
Type: SystemInt32

[Missing <param name="maxIncludeLevel"/> documentation for "M:Novacode.DocX.InsertTableOfContents(Novacode.Paragraph,System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

rightTabPos (Optional)
Type: SystemNullable Int32

[Missing <param name="rightTabPos"/> documentation for "M:Novacode.DocX.InsertTableOfContents(Novacode.Paragraph,System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

Return Value

Type: TableOfContents

[Missing <returns> documentation for "M:Novacode.DocX.InsertTableOfContents(Novacode.Paragraph,System.String,Novacode.TableOfContentsSwitches,System.String,System.Int32,System.Nullable{System.Int32})"]

See Also

Reference

DocX Class
InsertTableOfContents Overload


DocX.Load Method

DocXLoad Method
Overload List
Name | Description
Load(Stream) |
Load(String) |
Top
See Also

Reference

DocX Class


DocX.Load Method (Stream)

DocXLoad Method (Stream)

[Missing <summary> documentation for "M:Novacode.DocX.Load(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public static DocX Load(
    Stream stream
)
Public Shared Function Load (
    stream As Stream
) As DocX
public:
static DocX^ Load(
    Stream^ stream
)
static member Load :
        stream : Stream -> DocX

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.Load(System.IO.Stream)"]

Return Value

Type: DocX

[Missing <returns> documentation for "M:Novacode.DocX.Load(System.IO.Stream)"]

See Also

Reference

DocX Class
Load Overload


DocX.Load Method (String)

DocXLoad Method (String)

[Missing <summary> documentation for "M:Novacode.DocX.Load(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public static DocX Load(
    string filename
)
Public Shared Function Load (
    filename As String
) As DocX
public:
static DocX^ Load(
    String^ filename
)
static member Load :
        filename : string -> DocX

Parameters

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:Novacode.DocX.Load(System.String)"]

Return Value

Type: DocX

[Missing <returns> documentation for "M:Novacode.DocX.Load(System.String)"]

See Also

Reference

DocX Class
Load Overload


DocX.RemoveProtection Method

DocXRemoveProtection Method

[Missing <summary> documentation for "M:Novacode.DocX.RemoveProtection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void RemoveProtection()
Public Sub RemoveProtection
public:
void RemoveProtection()
member RemoveProtection : unit -> unit
See Also

Reference

DocX Class


DocX.Save Method

DocXSave Method

[Missing <summary> documentation for "M:Novacode.DocX.Save"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
See Also

Reference

DocX Class


DocX.SaveAs Method

DocXSaveAs Method
Overload List
 | Name | Description
Public method | SaveAs(Stream) |
Public method | SaveAs(String) |
Top
See Also

Reference

DocX Class


DocX.SaveAs Method (Stream)

DocXSaveAs Method (Stream)

[Missing <summary> documentation for "M:Novacode.DocX.SaveAs(System.IO.Stream)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SaveAs(
    Stream stream
)
Public Sub SaveAs (
    stream As Stream
)
public:
void SaveAs(
    Stream^ stream
)
member SaveAs :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:Novacode.DocX.SaveAs(System.IO.Stream)"]

See Also

Reference

DocX Class
SaveAs Overload


DocX.SaveAs Method (String)

DocXSaveAs Method (String)

[Missing <summary> documentation for "M:Novacode.DocX.SaveAs(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SaveAs(
    string filename
)
Public Sub SaveAs (
    filename As String
)
public:
void SaveAs(
    String^ filename
)
member SaveAs :
        filename : string -> unit

Parameters

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:Novacode.DocX.SaveAs(System.String)"]

See Also

Reference

DocX Class
SaveAs Overload


DocX Fields

DocX Fields

The DocX type exposes the following members.

Fields
 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Top
See Also

Reference

DocX Class


DocXElement Class

DocXElement Class

[Missing <summary> documentation for "T:Novacode.DocXElement"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
More...

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public abstract class DocXElement
Public MustInherit Class DocXElement
public ref class DocXElement abstract
[<AbstractClassAttribute>]
type DocXElement =  class end

The DocXElement type exposes the following members.

Constructors
 | Name | Description
Public method | DocXElement | Initializes a new instance of the DocXElement class
Top
Properties
 | Name | Description
Public property | PackagePart |
Public property | Xml |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeContainer
NovacodeDocProperty
NovacodeHyperlink
NovacodeInsertBeforeOrAfter
NovacodePageLayout
NovacodePicture
NovacodeRun
NovacodeTableOfContents


DocXElement Constructor

DocXElement Constructor
Initializes a new instance of the DocXElement class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public DocXElement(
    DocX document,
    XElement xml
)
Public Sub New (
    document As DocX,
    xml As XElement
)
public:
DocXElement(
    DocX^ document,
    XElement^ xml
)
new :
        document : DocX *
        xml : XElement -> DocXElement

Parameters

document
Type: NovacodeDocX

[Missing <param name="document"/> documentation for "M:Novacode.DocXElement.#ctor(Novacode.DocX,System.Xml.Linq.XElement)"]

xml
Type: System.Xml.LinqXElement

[Missing <param name="xml"/> documentation for "M:Novacode.DocXElement.#ctor(Novacode.DocX,System.Xml.Linq.XElement)"]

See Also

Reference

DocXElement Class


DocXElement Properties

DocXElement Properties

The DocXElement type exposes the following members.

Properties
 | Name | Description
Public property | PackagePart |
Public property | Xml |
Top
See Also

Reference

DocXElement Class


DocXElement.PackagePart Property

DocXElementPackagePart Property

[Missing <summary> documentation for "P:Novacode.DocXElement.PackagePart"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public PackagePart PackagePart { get; set; }
Public Property PackagePart As PackagePart
    Get
    Set
public:
property PackagePart^ PackagePart {
    PackagePart^ get ();
    void set (PackagePart^ value);
}
member PackagePart : PackagePart with get, set

Property Value

Type: PackagePart
See Also

Reference

DocXElement Class


DocXElement.Xml Property

DocXElementXml Property

[Missing <summary> documentation for "P:Novacode.DocXElement.Xml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public XElement Xml { get; set; }
Public Property Xml As XElement
    Get
    Set
public:
property XElement^ Xml {
    XElement^ get ();
    void set (XElement^ value);
}
member Xml : XElement with get, set

Property Value

Type: XElement
See Also

Reference

DocXElement Class


DocXElement Methods

DocXElement Methods

The DocXElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocXElement Class


EditRestrictions Enumeration

EditRestrictions Enumeration

[Missing <summary> documentation for "T:Novacode.EditRestrictions"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum EditRestrictions
Public Enumeration EditRestrictions
public enum class EditRestrictions
type EditRestrictions
Members
Member name | Value | Description
none | 0 |
readOnly | 1 |
forms | 2 |
comments | 3 |
trackedChanges | 4 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


EquationShapes Enumeration

EquationShapes Enumeration

[Missing <summary> documentation for "T:Novacode.EquationShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum EquationShapes
Public Enumeration EquationShapes
public enum class EquationShapes
type EquationShapes
Members
Member name | Value | Description
mathPlus | 0 |
mathMinus | 1 |
mathMultiply | 2 |
mathDivide | 3 |
mathEqual | 4 |
mathNotEqual | 5 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


ExtensionsHeadings Class

ExtensionsHeadings Class

[Missing <summary> documentation for "T:Novacode.ExtensionsHeadings"]

Inheritance Hierarchy
SystemObject
NovacodeExtensionsHeadings

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public static class ExtensionsHeadings
<ExtensionAttribute>
Public NotInheritable Class ExtensionsHeadings
[ExtensionAttribute]
public ref class ExtensionsHeadings abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type ExtensionsHeadings =  class end

The ExtensionsHeadings type exposes the following members.

Methods
Name | Description
EnumDescription |
HasFlag |
Heading |
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


ExtensionsHeadings Methods

ExtensionsHeadings Methods

The ExtensionsHeadings type exposes the following members.

Methods
Name | Description
EnumDescription |
HasFlag |
Heading |
Top
See Also

Reference

ExtensionsHeadings Class


ExtensionsHeadings.EnumDescription Method

ExtensionsHeadingsEnumDescription Method

[Missing <summary> documentation for "M:Novacode.ExtensionsHeadings.EnumDescription(System.Enum)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public static string EnumDescription(
    this Enum enumValue
)
<ExtensionAttribute>
Public Shared Function EnumDescription (
    enumValue As Enum
) As String
public:
[ExtensionAttribute]
static String^ EnumDescription(
    Enum^ enumValue
)
[<ExtensionAttribute>]
static member EnumDescription :
        enumValue : Enum -> string

Parameters

enumValue
Type: SystemEnum

[Missing <param name="enumValue"/> documentation for "M:Novacode.ExtensionsHeadings.EnumDescription(System.Enum)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Novacode.ExtensionsHeadings.EnumDescription(System.Enum)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Enum. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ExtensionsHeadings Class


ExtensionsHeadings.HasFlag Method

ExtensionsHeadingsHasFlag Method

[Missing <summary> documentation for "M:Novacode.ExtensionsHeadings.HasFlag(System.Enum,System.Enum)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public static bool HasFlag(
    this Enum variable,
    Enum value
)
<ExtensionAttribute>
Public Shared Function HasFlag (
    variable As Enum,
    value As Enum
) As Boolean
public:
[ExtensionAttribute]
static bool HasFlag(
    Enum^ variable,
    Enum^ value
)
[<ExtensionAttribute>]
static member HasFlag :
        variable : Enum *
        value : Enum -> bool

Parameters

variable
Type: SystemEnum

[Missing <param name="variable"/> documentation for "M:Novacode.ExtensionsHeadings.HasFlag(System.Enum,System.Enum)"]

value
Type: SystemEnum

[Missing <param name="value"/> documentation for "M:Novacode.ExtensionsHeadings.HasFlag(System.Enum,System.Enum)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.ExtensionsHeadings.HasFlag(System.Enum,System.Enum)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Enum. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ExtensionsHeadings Class


ExtensionsHeadings.Heading Method

ExtensionsHeadingsHeading Method

[Missing <summary> documentation for "M:Novacode.ExtensionsHeadings.Heading(Novacode.Paragraph,Novacode.HeadingType)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public static Paragraph Heading(
    this Paragraph paragraph,
    HeadingType headingType
)
<ExtensionAttribute>
Public Shared Function Heading (
    paragraph As Paragraph,
    headingType As HeadingType
) As Paragraph
public:
[ExtensionAttribute]
static Paragraph^ Heading(
    Paragraph^ paragraph,
    HeadingType headingType
)
[<ExtensionAttribute>]
static member Heading :
        paragraph : Paragraph *
        headingType : HeadingType -> Paragraph

Parameters

paragraph
Type: NovacodeParagraph

[Missing <param name="paragraph"/> documentation for "M:Novacode.ExtensionsHeadings.Heading(Novacode.Paragraph,Novacode.HeadingType)"]

headingType
Type: NovacodeHeadingType

[Missing <param name="headingType"/> documentation for "M:Novacode.ExtensionsHeadings.Heading(Novacode.Paragraph,Novacode.HeadingType)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.ExtensionsHeadings.Heading(Novacode.Paragraph,Novacode.HeadingType)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Paragraph. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ExtensionsHeadings Class


FlowchartShapes Enumeration

FlowchartShapes Enumeration

[Missing <summary> documentation for "T:Novacode.FlowchartShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum FlowchartShapes
Public Enumeration FlowchartShapes
public enum class FlowchartShapes
type FlowchartShapes
Members
Member name | Value | Description
flowChartProcess | 0 |
flowChartAlternateProcess | 1 |
flowChartDecision | 2 |
flowChartInputOutput | 3 |
flowChartPredefinedProcess | 4 |
flowChartInternalStorage | 5 |
flowChartDocument | 6 |
flowChartMultidocument | 7 |
flowChartTerminator | 8 |
flowChartPreparation | 9 |
flowChartManualInput | 10 |
flowChartManualOperation | 11 |
flowChartConnector | 12 |
flowChartOffpageConnector | 13 |
flowChartPunchedCard | 14 |
flowChartPunchedTape | 15 |
flowChartSummingJunction | 16 |
flowChartOr | 17 |
flowChartCollate | 18 |
flowChartSort | 19 |
flowChartExtract | 20 |
flowChartMerge | 21 |
flowChartOnlineStorage | 22 |
flowChartDelay | 23 |
flowChartMagneticTape | 24 |
flowChartMagneticDisk | 25 |
flowChartMagneticDrum | 26 |
flowChartDisplay | 27 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Footer Class

Footer Class

[Missing <summary> documentation for "T:Novacode.Footer"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeContainer
NovacodeFooter

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Footer : Container, IParagraphContainer
Public Class Footer
    Inherits Container
    Implements IParagraphContainer
public ref class Footer : public Container,
    IParagraphContainer
type Footer =
    class
        inherit Container
        interface IParagraphContainer
    end

The Footer type exposes the following members.

Properties
 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | PackagePart | (Inherited from DocXElement.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides ContainerParagraphs.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides ContainerTables.)
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Overrides ContainerInsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph | (Overrides ContainerInsertParagraph.)
Public method | InsertParagraph(String) | (Overrides ContainerInsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides ContainerInsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides ContainerInsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides ContainerInsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides ContainerInsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
Fields
 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Footer Properties

Footer Properties

The Footer type exposes the following members.

Properties
 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | PackagePart | (Inherited from DocXElement.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides ContainerParagraphs.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides ContainerTables.)
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Footer Class


Footer.PageNumbers Property

FooterPageNumbers Property

[Missing <summary> documentation for "P:Novacode.Footer.PageNumbers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool PageNumbers { get; set; }
Public Property PageNumbers As Boolean
    Get
    Set
public:
property bool PageNumbers {
    bool get ();
    void set (bool value);
}
member PageNumbers : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Footer Class


Footer.Paragraphs Property

FooterParagraphs Property

[Missing <summary> documentation for "P:Novacode.Footer.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override ReadOnlyCollection<Paragraph> Paragraphs { get; }
Public Overrides ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get () override;
}
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection Paragraph

Implements

IParagraphContainerParagraphs
See Also

Reference

Footer Class


Footer.Tables Property

FooterTables Property

[Missing <summary> documentation for "P:Novacode.Footer.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override List<Table> Tables { get; }
Public Overrides ReadOnly Property Tables As List(Of Table)
    Get
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get () override;
}
abstract Tables : List<Table> with get
override Tables : List<Table> with get

Property Value

Type: List Table
See Also

Reference

Footer Class


Footer Methods

Footer Methods

The Footer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Overrides ContainerInsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph | (Overrides ContainerInsertParagraph.)
Public method | InsertParagraph(String) | (Overrides ContainerInsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides ContainerInsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides ContainerInsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides ContainerInsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides ContainerInsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
See Also

Reference

Footer Class


Footer.InsertEquation Method

FooterInsertEquation Method

[Missing <summary> documentation for "M:Novacode.Footer.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertEquation(
    string equation
)
Public Overrides Function InsertEquation (
    equation As String
) As Paragraph
public:
virtual Paragraph^ InsertEquation(
    String^ equation
) override
abstract InsertEquation :
        equation : string -> Paragraph
override InsertEquation :
        equation : string -> Paragraph

Parameters

equation
Type: SystemString

[Missing <param name="equation"/> documentation for "M:Novacode.Footer.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertEquation(System.String)"]

See Also

Reference

Footer Class


Footer.InsertParagraph Method

FooterInsertParagraph Method
Overload List
 | Name | Description
Public method | InsertParagraph | (Overrides ContainerInsertParagraph.)
Public method | InsertParagraph(String) | (Overrides ContainerInsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides ContainerInsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides ContainerInsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides ContainerInsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides ContainerInsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(Int32, String, Boolean, Formatting).)
Top
See Also

Reference

Footer Class


Footer.InsertParagraph Method

FooterInsertParagraph Method

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph()
Public Overrides Function InsertParagraph As Paragraph
public:
virtual Paragraph^ InsertParagraph() override
abstract InsertParagraph : unit -> Paragraph
override InsertParagraph : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph"]

See Also

Reference

Footer Class
InsertParagraph Overload


Footer.InsertParagraph Method (String)

FooterInsertParagraph Method (String)

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    string text
)
Public Overrides Function InsertParagraph (
    text As String
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text
) override
abstract InsertParagraph :
        text : string -> Paragraph
override InsertParagraph :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.String)"]

See Also

Reference

Footer Class
InsertParagraph Overload


Footer.InsertParagraph Method (Paragraph)

FooterInsertParagraph Method (Paragraph)

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    Paragraph p
)
Public Overrides Function InsertParagraph (
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
) override
abstract InsertParagraph :
        p : Paragraph -> Paragraph
override InsertParagraph :
        p : Paragraph -> Paragraph

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Footer.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(Novacode.Paragraph)"]

See Also

Reference

Footer Class
InsertParagraph Overload


Footer.InsertParagraph Method (Int32, Paragraph)

FooterInsertParagraph Method (Int32, Paragraph)

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Public Overrides Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
) override
abstract InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph
override InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

Reference

Footer Class
InsertParagraph Overload


Footer.InsertParagraph Method (String, Boolean)

FooterInsertParagraph Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
) override
abstract InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean)"]

See Also

Reference

Footer Class
InsertParagraph Overload


Footer.InsertParagraph Method (Int32, String, Boolean)

FooterInsertParagraph Method (Int32, String, Boolean)

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
) override
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

Reference

Footer Class
InsertParagraph Overload


Footer.InsertParagraph Method (String, Boolean, Formatting)

FooterInsertParagraph Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
abstract InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Footer Class
InsertParagraph Overload


Footer.InsertParagraph Method (Int32, String, Boolean, Formatting)

FooterInsertParagraph Method (Int32, String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Footer.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Footer Class
InsertParagraph Overload


Footer.InsertTable Method

FooterInsertTable Method
Overload List
 | Name | Description
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Top
See Also

Reference

Footer Class


Footer.InsertTable Method (Table)

FooterInsertTable Method (Table)

[Missing <summary> documentation for "M:Novacode.Footer.InsertTable(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    Table t
)
Public Function InsertTable (
    t As Table
) As Table
public:
Table^ InsertTable(
    Table^ t
)
member InsertTable :
        t : Table -> Table

Parameters

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.Footer.InsertTable(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Footer.InsertTable(Novacode.Table)"]

See Also

Reference

Footer Class
InsertTable Overload


Footer.InsertTable Method (Int32, Table)

FooterInsertTable Method (Int32, Table)

[Missing <summary> documentation for "M:Novacode.Footer.InsertTable(System.Int32,Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int index,
    Table t
)
Public Function InsertTable (
    index As Integer,
    t As Table
) As Table
public:
Table^ InsertTable(
    int index,
    Table^ t
)
member InsertTable :
        index : int *
        t : Table -> Table

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,Novacode.Table)"]

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Footer.InsertTable(System.Int32,Novacode.Table)"]

See Also

Reference

Footer Class
InsertTable Overload


Footer.InsertTable Method (Int32, Int32)

FooterInsertTable Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int rowCount,
    int columnCount
)
Public Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
Table^ InsertTable(
    int rowCount,
    int columnCount
)
member InsertTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32)"]

See Also

Reference

Footer Class
InsertTable Overload


Footer.InsertTable Method (Int32, Int32, Int32)

FooterInsertTable Method (Int32, Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int index,
    int rowCount,
    int columnCount
)
Public Function InsertTable (
    index As Integer,
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
Table^ InsertTable(
    int index,
    int rowCount,
    int columnCount
)
member InsertTable :
        index : int *
        rowCount : int *
        columnCount : int -> Table

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32,System.Int32)"]

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Footer.InsertTable(System.Int32,System.Int32,System.Int32)"]

See Also

Reference

Footer Class
InsertTable Overload


Footer Fields

Footer Fields

The Footer type exposes the following members.

Fields
 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Top
See Also

Reference

Footer Class


Footers Class

Footers Class

[Missing <summary> documentation for "T:Novacode.Footers"]

Inheritance Hierarchy
SystemObject
NovacodeFooters

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Footers
Public Class Footers
public ref class Footers
type Footers =  class end

The Footers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | even |
Public field | first |
Public field | odd |
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Footers Methods

Footers Methods

The Footers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Footers Class


Footers Fields

Footers Fields

The Footers type exposes the following members.

Fields
 | Name | Description
Public field | even |
Public field | first |
Public field | odd |
Top
See Also

Reference

Footers Class


Footers.even Field

Footerseven Field

[Missing <summary> documentation for "F:Novacode.Footers.even"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Footer even
Public even As Footer
public:
Footer^ even
val mutable even: Footer

Field Value

Type: Footer
See Also

Reference

Footers Class


Footers.first Field

Footersfirst Field

[Missing <summary> documentation for "F:Novacode.Footers.first"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Footer first
Public first As Footer
public:
Footer^ first
val mutable first: Footer

Field Value

Type: Footer
See Also

Reference

Footers Class


Footers.odd Field

Footersodd Field

[Missing <summary> documentation for "F:Novacode.Footers.odd"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Footer odd
Public odd As Footer
public:
Footer^ odd
val mutable odd: Footer

Field Value

Type: Footer
See Also

Reference

Footers Class


FormattedText Class

FormattedText Class

[Missing <summary> documentation for "T:Novacode.FormattedText"]

Inheritance Hierarchy
SystemObject
NovacodeFormattedText

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class FormattedText : IComparable
Public Class FormattedText
    Implements IComparable
public ref class FormattedText : IComparable
type FormattedText =
    class
        interface IComparable
    end

The FormattedText type exposes the following members.

Constructors
 | Name | Description
Public method | FormattedText | Initializes a new instance of the FormattedText class
Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | formatting |
Public field | index |
Public field | text |
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


FormattedText Constructor

FormattedText Constructor
Initializes a new instance of the FormattedText class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public FormattedText()
Public Sub New
public:
FormattedText()
new : unit -> FormattedText
See Also

Reference

FormattedText Class


FormattedText Methods

FormattedText Methods

The FormattedText type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormattedText Class


FormattedText.CompareTo Method

FormattedTextCompareTo Method

[Missing <summary> documentation for "M:Novacode.FormattedText.CompareTo(System.Object)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Novacode.FormattedText.CompareTo(System.Object)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Novacode.FormattedText.CompareTo(System.Object)"]

Implements

IComparableCompareTo(Object)
See Also

Reference

FormattedText Class


FormattedText Fields

FormattedText Fields

The FormattedText type exposes the following members.

Fields
 | Name | Description
Public field | formatting |
Public field | index |
Public field | text |
Top
See Also

Reference

FormattedText Class


FormattedText.formatting Field

FormattedTextformatting Field

[Missing <summary> documentation for "F:Novacode.FormattedText.formatting"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Formatting formatting
Public formatting As Formatting
public:
Formatting^ formatting
val mutable formatting: Formatting

Field Value

Type: Formatting
See Also

Reference

FormattedText Class


FormattedText.index Field

FormattedTextindex Field

[Missing <summary> documentation for "F:Novacode.FormattedText.index"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int index
Public index As Integer
public:
int index
val mutable index: int

Field Value

Type: Int32
See Also

Reference

FormattedText Class


FormattedText.text Field

FormattedTexttext Field

[Missing <summary> documentation for "F:Novacode.FormattedText.text"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string text
Public text As String
public:
String^ text
val mutable text: string

Field Value

Type: String
See Also

Reference

FormattedText Class


Formatting Class

Formatting Class

[Missing <summary> documentation for "T:Novacode.Formatting"]

Inheritance Hierarchy
SystemObject
NovacodeFormatting

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Formatting : IComparable
Public Class Formatting
    Implements IComparable
public ref class Formatting : IComparable
type Formatting =
    class
        interface IComparable
    end

The Formatting type exposes the following members.

Constructors
 | Name | Description
Public method | Formatting | Initializes a new instance of the Formatting class
Top
Properties
 | Name | Description
Public property | Bold |
Public property | CapsStyle |
Public property | FontColor |
Public property | FontFamily |
Public property | Hidden |
Public property | Highlight |
Public property | Italic |
Public property | Kerning |
Public property | Language |
Public property | Misc |
Public property | PercentageScale |
Public property | Position |
Public property | Script |
Public property | Size |
Public property | Spacing |
Public property | StrikeThrough |
Public property | UnderlineColor |
Public property | UnderlineStyle |
Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Formatting Constructor

Formatting Constructor
Initializes a new instance of the Formatting class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Formatting()
Public Sub New
public:
Formatting()
new : unit -> Formatting
See Also

Reference

Formatting Class


Formatting Properties

Formatting Properties

The Formatting type exposes the following members.

Properties
 | Name | Description
Public property | Bold |
Public property | CapsStyle |
Public property | FontColor |
Public property | FontFamily |
Public property | Hidden |
Public property | Highlight |
Public property | Italic |
Public property | Kerning |
Public property | Language |
Public property | Misc |
Public property | PercentageScale |
Public property | Position |
Public property | Script |
Public property | Size |
Public property | Spacing |
Public property | StrikeThrough |
Public property | UnderlineColor |
Public property | UnderlineStyle |
Top
See Also

Reference

Formatting Class


Formatting.Bold Property

FormattingBold Property

[Missing <summary> documentation for "P:Novacode.Formatting.Bold"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool Bold { get; set; }
Public Property Bold As Boolean
    Get
    Set
public:
property bool Bold {
    bool get ();
    void set (bool value);
}
member Bold : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Formatting Class


Formatting.CapsStyle Property

FormattingCapsStyle Property

[Missing <summary> documentation for "P:Novacode.Formatting.CapsStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public CapsStyle CapsStyle { get; set; }
Public Property CapsStyle As CapsStyle
    Get
    Set
public:
property CapsStyle CapsStyle {
    CapsStyle get ();
    void set (CapsStyle value);
}
member CapsStyle : CapsStyle with get, set

Property Value

Type: CapsStyle
See Also

Reference

Formatting Class


Formatting.FontColor Property

FormattingFontColor Property

[Missing <summary> documentation for "P:Novacode.Formatting.FontColor"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Nullable<Color> FontColor { get; set; }
Public Property FontColor As Nullable(Of Color)
    Get
    Set
public:
property Nullable<Color> FontColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}
member FontColor : Nullable<Color> with get, set

Property Value

Type: Nullable Color
See Also

Reference

Formatting Class


Formatting.FontFamily Property

FormattingFontFamily Property

[Missing <summary> documentation for "P:Novacode.Formatting.FontFamily"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public FontFamily FontFamily { get; set; }
Public Property FontFamily As FontFamily
    Get
    Set
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}
member FontFamily : FontFamily with get, set

Property Value

Type: FontFamily
See Also

Reference

Formatting Class


Formatting.Hidden Property

FormattingHidden Property

[Missing <summary> documentation for "P:Novacode.Formatting.Hidden"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
member Hidden : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Formatting Class


Formatting.Highlight Property

FormattingHighlight Property

[Missing <summary> documentation for "P:Novacode.Formatting.Highlight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Highlight Highlight { get; set; }
Public Property Highlight As Highlight
    Get
    Set
public:
property Highlight Highlight {
    Highlight get ();
    void set (Highlight value);
}
member Highlight : Highlight with get, set

Property Value

Type: Highlight
See Also

Reference

Formatting Class


Formatting.Italic Property

FormattingItalic Property

[Missing <summary> documentation for "P:Novacode.Formatting.Italic"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool Italic { get; set; }
Public Property Italic As Boolean
    Get
    Set
public:
property bool Italic {
    bool get ();
    void set (bool value);
}
member Italic : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Formatting Class


Formatting.Kerning Property

FormattingKerning Property

[Missing <summary> documentation for "P:Novacode.Formatting.Kerning"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Kerning { get; set; }
Public Property Kerning As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Kerning {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Kerning : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

Formatting Class


Formatting.Language Property

FormattingLanguage Property

[Missing <summary> documentation for "P:Novacode.Formatting.Language"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public CultureInfo Language { get; set; }
Public Property Language As CultureInfo
    Get
    Set
public:
property CultureInfo^ Language {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}
member Language : CultureInfo with get, set

Property Value

Type: CultureInfo
See Also

Reference

Formatting Class


Formatting.Misc Property

FormattingMisc Property

[Missing <summary> documentation for "P:Novacode.Formatting.Misc"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Misc Misc { get; set; }
Public Property Misc As Misc
    Get
    Set
public:
property Misc Misc {
    Misc get ();
    void set (Misc value);
}
member Misc : Misc with get, set

Property Value

Type: Misc
See Also

Reference

Formatting Class


Formatting.PercentageScale Property

FormattingPercentageScale Property

[Missing <summary> documentation for "P:Novacode.Formatting.PercentageScale"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> PercentageScale { get; set; }
Public Property PercentageScale As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> PercentageScale {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member PercentageScale : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

Formatting Class


Formatting.Position Property

FormattingPosition Property

[Missing <summary> documentation for "P:Novacode.Formatting.Position"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Position { get; set; }
Public Property Position As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Position {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Position : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

Formatting Class


Formatting.Script Property

FormattingScript Property

[Missing <summary> documentation for "P:Novacode.Formatting.Script"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Script Script { get; set; }
Public Property Script As Script
    Get
    Set
public:
property Script Script {
    Script get ();
    void set (Script value);
}
member Script : Script with get, set

Property Value

Type: Script
See Also

Reference

Formatting Class


Formatting.Size Property

FormattingSize Property

[Missing <summary> documentation for "P:Novacode.Formatting.Size"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Size { get; set; }
Public Property Size As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Size {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Size : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

Formatting Class


Formatting.Spacing Property

FormattingSpacing Property

[Missing <summary> documentation for "P:Novacode.Formatting.Spacing"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Spacing { get; set; }
Public Property Spacing As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Spacing {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Spacing : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

Formatting Class


Formatting.StrikeThrough Property

FormattingStrikeThrough Property

[Missing <summary> documentation for "P:Novacode.Formatting.StrikeThrough"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public StrikeThrough StrikeThrough { get; set; }
Public Property StrikeThrough As StrikeThrough
    Get
    Set
public:
property StrikeThrough StrikeThrough {
    StrikeThrough get ();
    void set (StrikeThrough value);
}
member StrikeThrough : StrikeThrough with get, set

Property Value

Type: StrikeThrough
See Also

Reference

Formatting Class


Formatting.UnderlineColor Property

FormattingUnderlineColor Property

[Missing <summary> documentation for "P:Novacode.Formatting.UnderlineColor"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Nullable<Color> UnderlineColor { get; set; }
Public Property UnderlineColor As Nullable(Of Color)
    Get
    Set
public:
property Nullable<Color> UnderlineColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}
member UnderlineColor : Nullable<Color> with get, set

Property Value

Type: Nullable Color
See Also

Reference

Formatting Class


Formatting.UnderlineStyle Property

FormattingUnderlineStyle Property

[Missing <summary> documentation for "P:Novacode.Formatting.UnderlineStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public UnderlineStyle UnderlineStyle { get; set; }
Public Property UnderlineStyle As UnderlineStyle
    Get
    Set
public:
property UnderlineStyle UnderlineStyle {
    UnderlineStyle get ();
    void set (UnderlineStyle value);
}
member UnderlineStyle : UnderlineStyle with get, set

Property Value

Type: UnderlineStyle
See Also

Reference

Formatting Class


Formatting Methods

Formatting Methods

The Formatting type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Formatting Class


Formatting.CompareTo Method

FormattingCompareTo Method

[Missing <summary> documentation for "M:Novacode.Formatting.CompareTo(System.Object)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Novacode.Formatting.CompareTo(System.Object)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Novacode.Formatting.CompareTo(System.Object)"]

Implements

IComparableCompareTo(Object)
See Also

Reference

Formatting Class


Formatting.Parse Method

FormattingParse Method

[Missing <summary> documentation for "M:Novacode.Formatting.Parse(System.Xml.Linq.XElement)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public static Formatting Parse(
    XElement rPr
)
Public Shared Function Parse (
    rPr As XElement
) As Formatting
public:
static Formatting^ Parse(
    XElement^ rPr
)
static member Parse :
        rPr : XElement -> Formatting

Parameters

rPr
Type: System.Xml.LinqXElement

[Missing <param name="rPr"/> documentation for "M:Novacode.Formatting.Parse(System.Xml.Linq.XElement)"]

Return Value

Type: Formatting

[Missing <returns> documentation for "M:Novacode.Formatting.Parse(System.Xml.Linq.XElement)"]

See Also

Reference

Formatting Class


Grouping Enumeration

Grouping Enumeration

[Missing <summary> documentation for "T:Novacode.Grouping"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum Grouping
Public Enumeration Grouping
public enum class Grouping
type Grouping
Members
Member name | Value | Description
PercentStacked | 0 |
Stacked | 1 |
Standard | 2 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Header Class

Header Class

[Missing <summary> documentation for "T:Novacode.Header"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeContainer
NovacodeHeader

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Header : Container, IParagraphContainer
Public Class Header
    Inherits Container
    Implements IParagraphContainer
public ref class Header : public Container,
    IParagraphContainer
type Header =
    class
        inherit Container
        interface IParagraphContainer
    end

The Header type exposes the following members.

Properties
 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images |
Public property | Lists | (Inherited from Container.)
Public property | PackagePart | (Inherited from DocXElement.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides ContainerParagraphs.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides ContainerTables.)
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Overrides ContainerInsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph | (Overrides ContainerInsertParagraph.)
Public method | InsertParagraph(String) | (Overrides ContainerInsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides ContainerInsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides ContainerInsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides ContainerInsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides ContainerInsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
Fields
 | Name | Description
Public field | PageNumberParagraph |
Public field | ParentContainer | (Inherited from Container.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Header Properties

Header Properties

The Header type exposes the following members.

Properties
 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Images |
Public property | Lists | (Inherited from Container.)
Public property | PackagePart | (Inherited from DocXElement.)
Public property | PageNumbers |
Public property | Paragraphs | (Overrides ContainerParagraphs.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Overrides ContainerTables.)
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Header Class


Header.Images Property

HeaderImages Property

[Missing <summary> documentation for "P:Novacode.Header.Images"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Image> Images { get; }
Public ReadOnly Property Images As List(Of Image)
    Get
public:
property List<Image^>^ Images {
    List<Image^>^ get ();
}
member Images : List<Image> with get

Property Value

Type: List Image
See Also

Reference

Header Class


Header.PageNumbers Property

HeaderPageNumbers Property

[Missing <summary> documentation for "P:Novacode.Header.PageNumbers"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool PageNumbers { get; set; }
Public Property PageNumbers As Boolean
    Get
    Set
public:
property bool PageNumbers {
    bool get ();
    void set (bool value);
}
member PageNumbers : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Header Class


Header.Paragraphs Property

HeaderParagraphs Property

[Missing <summary> documentation for "P:Novacode.Header.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override ReadOnlyCollection<Paragraph> Paragraphs { get; }
Public Overrides ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get () override;
}
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection Paragraph

Implements

IParagraphContainerParagraphs
See Also

Reference

Header Class


Header.Tables Property

HeaderTables Property

[Missing <summary> documentation for "P:Novacode.Header.Tables"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override List<Table> Tables { get; }
Public Overrides ReadOnly Property Tables As List(Of Table)
    Get
public:
virtual property List<Table^>^ Tables {
    List<Table^>^ get () override;
}
abstract Tables : List<Table> with get
override Tables : List<Table> with get

Property Value

Type: List Table
See Also

Reference

Header Class


Header Methods

Header Methods

The Header type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Overrides ContainerInsertEquation(String).)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph | (Overrides ContainerInsertParagraph.)
Public method | InsertParagraph(String) | (Overrides ContainerInsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides ContainerInsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides ContainerInsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides ContainerInsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides ContainerInsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(Int32, String, Boolean, Formatting).)
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
See Also

Reference

Header Class


Header.InsertEquation Method

HeaderInsertEquation Method

[Missing <summary> documentation for "M:Novacode.Header.InsertEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertEquation(
    string equation
)
Public Overrides Function InsertEquation (
    equation As String
) As Paragraph
public:
virtual Paragraph^ InsertEquation(
    String^ equation
) override
abstract InsertEquation :
        equation : string -> Paragraph
override InsertEquation :
        equation : string -> Paragraph

Parameters

equation
Type: SystemString

[Missing <param name="equation"/> documentation for "M:Novacode.Header.InsertEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertEquation(System.String)"]

See Also

Reference

Header Class


Header.InsertParagraph Method

HeaderInsertParagraph Method
Overload List
 | Name | Description
Public method | InsertParagraph | (Overrides ContainerInsertParagraph.)
Public method | InsertParagraph(String) | (Overrides ContainerInsertParagraph(String).)
Public method | InsertParagraph(Paragraph) | (Overrides ContainerInsertParagraph(Paragraph).)
Public method | InsertParagraph(Int32, Paragraph) | (Overrides ContainerInsertParagraph(Int32, Paragraph).)
Public method | InsertParagraph(String, Boolean) | (Overrides ContainerInsertParagraph(String, Boolean).)
Public method | InsertParagraph(Int32, String, Boolean) | (Overrides ContainerInsertParagraph(Int32, String, Boolean).)
Public method | InsertParagraph(String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(String, Boolean, Formatting).)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Overrides ContainerInsertParagraph(Int32, String, Boolean, Formatting).)
Top
See Also

Reference

Header Class


Header.InsertParagraph Method

HeaderInsertParagraph Method

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph()
Public Overrides Function InsertParagraph As Paragraph
public:
virtual Paragraph^ InsertParagraph() override
abstract InsertParagraph : unit -> Paragraph
override InsertParagraph : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph"]

See Also

Reference

Header Class
InsertParagraph Overload


Header.InsertParagraph Method (String)

HeaderInsertParagraph Method (String)

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    string text
)
Public Overrides Function InsertParagraph (
    text As String
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text
) override
abstract InsertParagraph :
        text : string -> Paragraph
override InsertParagraph :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.String)"]

See Also

Reference

Header Class
InsertParagraph Overload


Header.InsertParagraph Method (Paragraph)

HeaderInsertParagraph Method (Paragraph)

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    Paragraph p
)
Public Overrides Function InsertParagraph (
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    Paragraph^ p
) override
abstract InsertParagraph :
        p : Paragraph -> Paragraph
override InsertParagraph :
        p : Paragraph -> Paragraph

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Header.InsertParagraph(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(Novacode.Paragraph)"]

See Also

Reference

Header Class
InsertParagraph Overload


Header.InsertParagraph Method (Int32, Paragraph)

HeaderInsertParagraph Method (Int32, Paragraph)

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    int index,
    Paragraph p
)
Public Overrides Function InsertParagraph (
    index As Integer,
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    Paragraph^ p
) override
abstract InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph
override InsertParagraph :
        index : int *
        p : Paragraph -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,Novacode.Paragraph)"]

See Also

Reference

Header Class
InsertParagraph Overload


Header.InsertParagraph Method (String, Boolean)

HeaderInsertParagraph Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges
)
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges
) override
abstract InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean)"]

See Also

Reference

Header Class
InsertParagraph Overload


Header.InsertParagraph Method (Int32, String, Boolean)

HeaderInsertParagraph Method (Int32, String, Boolean)

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges
)
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges
) override
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean)"]

See Also

Reference

Header Class
InsertParagraph Overload


Header.InsertParagraph Method (String, Boolean, Formatting)

HeaderInsertParagraph Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overrides Function InsertParagraph (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
abstract InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Header Class
InsertParagraph Overload


Header.InsertParagraph Method (Int32, String, Boolean, Formatting)

HeaderInsertParagraph Method (Int32, String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraph(
    int index,
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overrides Function InsertParagraph (
    index As Integer,
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraph(
    int index,
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
abstract InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraph :
        index : int *
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Header.InsertParagraph(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Header Class
InsertParagraph Overload


Header.InsertTable Method

HeaderInsertTable Method
Overload List
 | Name | Description
Public method | InsertTable(Table) |
Public method | InsertTable(Int32, Table) |
Public method | InsertTable(Int32, Int32) |
Public method | InsertTable(Int32, Int32, Int32) |
Top
See Also

Reference

Header Class


Header.InsertTable Method (Table)

HeaderInsertTable Method (Table)

[Missing <summary> documentation for "M:Novacode.Header.InsertTable(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    Table t
)
Public Function InsertTable (
    t As Table
) As Table
public:
Table^ InsertTable(
    Table^ t
)
member InsertTable :
        t : Table -> Table

Parameters

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.Header.InsertTable(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Header.InsertTable(Novacode.Table)"]

See Also

Reference

Header Class
InsertTable Overload


Header.InsertTable Method (Int32, Table)

HeaderInsertTable Method (Int32, Table)

[Missing <summary> documentation for "M:Novacode.Header.InsertTable(System.Int32,Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int index,
    Table t
)
Public Function InsertTable (
    index As Integer,
    t As Table
) As Table
public:
Table^ InsertTable(
    int index,
    Table^ t
)
member InsertTable :
        index : int *
        t : Table -> Table

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,Novacode.Table)"]

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Header.InsertTable(System.Int32,Novacode.Table)"]

See Also

Reference

Header Class
InsertTable Overload


Header.InsertTable Method (Int32, Int32)

HeaderInsertTable Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int rowCount,
    int columnCount
)
Public Function InsertTable (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
Table^ InsertTable(
    int rowCount,
    int columnCount
)
member InsertTable :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32)"]

See Also

Reference

Header Class
InsertTable Overload


Header.InsertTable Method (Int32, Int32, Int32)

HeaderInsertTable Method (Int32, Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table InsertTable(
    int index,
    int rowCount,
    int columnCount
)
Public Function InsertTable (
    index As Integer,
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
Table^ InsertTable(
    int index,
    int rowCount,
    int columnCount
)
member InsertTable :
        index : int *
        rowCount : int *
        columnCount : int -> Table

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32,System.Int32)"]

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Header.InsertTable(System.Int32,System.Int32,System.Int32)"]

See Also

Reference

Header Class
InsertTable Overload


Header Fields

Header Fields

The Header type exposes the following members.

Fields
 | Name | Description
Public field | PageNumberParagraph |
Public field | ParentContainer | (Inherited from Container.)
Top
See Also

Reference

Header Class


Header.PageNumberParagraph Field

HeaderPageNumberParagraph Field

[Missing <summary> documentation for "F:Novacode.Header.PageNumberParagraph"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph PageNumberParagraph
Public PageNumberParagraph As Paragraph
public:
Paragraph^ PageNumberParagraph
val mutable PageNumberParagraph: Paragraph

Field Value

Type: Paragraph
See Also

Reference

Header Class


Headers Class

Headers Class

[Missing <summary> documentation for "T:Novacode.Headers"]

Inheritance Hierarchy
SystemObject
NovacodeHeaders

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Headers
Public Class Headers
public ref class Headers
type Headers =  class end

The Headers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | even |
Public field | first |
Public field | odd |
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Headers Methods

Headers Methods

The Headers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Headers Class


Headers Fields

Headers Fields

The Headers type exposes the following members.

Fields
 | Name | Description
Public field | even |
Public field | first |
Public field | odd |
Top
See Also

Reference

Headers Class


Headers.even Field

Headerseven Field

[Missing <summary> documentation for "F:Novacode.Headers.even"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Header even
Public even As Header
public:
Header^ even
val mutable even: Header

Field Value

Type: Header
See Also

Reference

Headers Class


Headers.first Field

Headersfirst Field

[Missing <summary> documentation for "F:Novacode.Headers.first"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Header first
Public first As Header
public:
Header^ first
val mutable first: Header

Field Value

Type: Header
See Also

Reference

Headers Class


Headers.odd Field

Headersodd Field

[Missing <summary> documentation for "F:Novacode.Headers.odd"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Header odd
Public odd As Header
public:
Header^ odd
val mutable odd: Header

Field Value

Type: Header
See Also

Reference

Headers Class


HeadingType Enumeration

HeadingType Enumeration

[Missing <summary> documentation for "T:Novacode.HeadingType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum HeadingType
Public Enumeration HeadingType
public enum class HeadingType
type HeadingType
Members
Member name | Value | Description
Heading1 | 0 |
Heading2 | 1 |
Heading3 | 2 |
Heading4 | 3 |
Heading5 | 4 |
Heading6 | 5 |
Heading7 | 6 |
Heading8 | 7 |
Heading9 | 8 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Highlight Enumeration

Highlight Enumeration

[Missing <summary> documentation for "T:Novacode.Highlight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum Highlight
Public Enumeration Highlight
public enum class Highlight
type Highlight
Members
Member name | Value | Description
yellow | 0 |
green | 1 |
cyan | 2 |
magenta | 3 |
blue | 4 |
red | 5 |
darkBlue | 6 |
darkCyan | 7 |
darkGreen | 8 |
darkMagenta | 9 |
darkRed | 10 |
darkYellow | 11 |
darkGray | 12 |
lightGray | 13 |
black | 14 |
none | 15 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Hyperlink Class

Hyperlink Class

[Missing <summary> documentation for "T:Novacode.Hyperlink"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeHyperlink

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Hyperlink : DocXElement
Public Class Hyperlink
    Inherits DocXElement
public ref class Hyperlink : public DocXElement
type Hyperlink =
    class
        inherit DocXElement
    end

The Hyperlink type exposes the following members.

Properties
 | Name | Description
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Text |
Public property | Uri |
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Hyperlink Properties

Hyperlink Properties

The Hyperlink type exposes the following members.

Properties
 | Name | Description
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Text |
Public property | Uri |
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Hyperlink Class


Hyperlink.Text Property

HyperlinkText Property

[Missing <summary> documentation for "P:Novacode.Hyperlink.Text"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

Hyperlink Class


Hyperlink.Uri Property

HyperlinkUri Property

[Missing <summary> documentation for "P:Novacode.Hyperlink.Uri"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Uri Uri { get; set; }
Public Property Uri As Uri
    Get
    Set
public:
property Uri^ Uri {
    Uri^ get ();
    void set (Uri^ value);
}
member Uri : Uri with get, set

Property Value

Type: Uri
See Also

Reference

Hyperlink Class


Hyperlink Methods

Hyperlink Methods

The Hyperlink type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Hyperlink Class


Hyperlink.Remove Method

HyperlinkRemove Method

[Missing <summary> documentation for "M:Novacode.Hyperlink.Remove"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

Hyperlink Class


Image Class

Image Class

[Missing <summary> documentation for "T:Novacode.Image"]

Inheritance Hierarchy
SystemObject
NovacodeImage

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Image
Public Class Image
public ref class Image
type Image =  class end

The Image type exposes the following members.

Properties
 | Name | Description
Public property | FileName |
Public property | Id |
Top
Methods
 | Name | Description
Public method | CreatePicture |
Public method | CreatePicture(Int32, Int32) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Image Properties

Image Properties

The Image type exposes the following members.

Properties
 | Name | Description
Public property | FileName |
Public property | Id |
Top
See Also

Reference

Image Class


Image.FileName Property

ImageFileName Property

[Missing <summary> documentation for "P:Novacode.Image.FileName"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

Image Class


Image.Id Property

ImageId Property

[Missing <summary> documentation for "P:Novacode.Image.Id"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get
public:
property String^ Id {
    String^ get ();
}
member Id : string with get

Property Value

Type: String
See Also

Reference

Image Class


Image Methods

Image Methods

The Image type exposes the following members.

Methods
 | Name | Description
Public method | CreatePicture |
Public method | CreatePicture(Int32, Int32) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Image Class


Image.CreatePicture Method

ImageCreatePicture Method
Overload List
 | Name | Description
Public method | CreatePicture |
Public method | CreatePicture(Int32, Int32) |
Top
See Also

Reference

Image Class


Image.CreatePicture Method

ImageCreatePicture Method

[Missing <summary> documentation for "M:Novacode.Image.CreatePicture"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Picture CreatePicture()
Public Function CreatePicture As Picture
public:
Picture^ CreatePicture()
member CreatePicture : unit -> Picture

Return Value

Type: Picture

[Missing <returns> documentation for "M:Novacode.Image.CreatePicture"]

See Also

Reference

Image Class
CreatePicture Overload


Image.CreatePicture Method (Int32, Int32)

ImageCreatePicture Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Picture CreatePicture(
    int height,
    int width
)
Public Function CreatePicture (
    height As Integer,
    width As Integer
) As Picture
public:
Picture^ CreatePicture(
    int height,
    int width
)
member CreatePicture :
        height : int *
        width : int -> Picture

Parameters

height
Type: SystemInt32

[Missing <param name="height"/> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

width
Type: SystemInt32

[Missing <param name="width"/> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

Return Value

Type: Picture

[Missing <returns> documentation for "M:Novacode.Image.CreatePicture(System.Int32,System.Int32)"]

See Also

Reference

Image Class
CreatePicture Overload


Image.GetStream Method

ImageGetStream Method

[Missing <summary> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Stream GetStream(
    FileMode mode,
    FileAccess access
)
Public Function GetStream (
    mode As FileMode,
    access As FileAccess
) As Stream
public:
Stream^ GetStream(
    FileMode mode,
    FileAccess access
)
member GetStream :
        mode : FileMode *
        access : FileAccess -> Stream

Parameters

mode
Type: System.IOFileMode

[Missing <param name="mode"/> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

access
Type: System.IOFileAccess

[Missing <param name="access"/> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

Return Value

Type: Stream

[Missing <returns> documentation for "M:Novacode.Image.GetStream(System.IO.FileMode,System.IO.FileAccess)"]

See Also

Reference

Image Class


InsertBeforeOrAfter Class

InsertBeforeOrAfter Class

[Missing <summary> documentation for "T:Novacode.InsertBeforeOrAfter"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeInsertBeforeOrAfter
NovacodeList
NovacodeParagraph
NovacodeTable

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public abstract class InsertBeforeOrAfter : DocXElement
Public MustInherit Class InsertBeforeOrAfter
    Inherits DocXElement
public ref class InsertBeforeOrAfter abstract : public DocXElement
[<AbstractClassAttribute>]
type InsertBeforeOrAfter =
    class
        inherit DocXElement
    end

The InsertBeforeOrAfter type exposes the following members.

Constructors
 | Name | Description
Public method | InsertBeforeOrAfter | Initializes a new instance of the InsertBeforeOrAfter class
Top
Properties
 | Name | Description
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf |
Public method | InsertPageBreakBeforeSelf |
Public method | InsertParagraphAfterSelf(String) |
Public method | InsertParagraphAfterSelf(Paragraph) |
Public method | InsertParagraphAfterSelf(String, Boolean) |
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) |
Public method | InsertParagraphBeforeSelf(String) |
Public method | InsertParagraphBeforeSelf(Paragraph) |
Public method | InsertParagraphBeforeSelf(String, Boolean) |
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) |
Public method | InsertTableAfterSelf(Table) |
Public method | InsertTableAfterSelf(Int32, Int32) |
Public method | InsertTableBeforeSelf(Table) |
Public method | InsertTableBeforeSelf(Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


InsertBeforeOrAfter Constructor

InsertBeforeOrAfter Constructor
Initializes a new instance of the InsertBeforeOrAfter class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public InsertBeforeOrAfter(
    DocX document,
    XElement xml
)
Public Sub New (
    document As DocX,
    xml As XElement
)
public:
InsertBeforeOrAfter(
    DocX^ document,
    XElement^ xml
)
new :
        document : DocX *
        xml : XElement -> InsertBeforeOrAfter

Parameters

document
Type: NovacodeDocX

[Missing <param name="document"/> documentation for "M:Novacode.InsertBeforeOrAfter.#ctor(Novacode.DocX,System.Xml.Linq.XElement)"]

xml
Type: System.Xml.LinqXElement

[Missing <param name="xml"/> documentation for "M:Novacode.InsertBeforeOrAfter.#ctor(Novacode.DocX,System.Xml.Linq.XElement)"]

See Also

Reference

InsertBeforeOrAfter Class


InsertBeforeOrAfter Properties

InsertBeforeOrAfter Properties

The InsertBeforeOrAfter type exposes the following members.

Properties
 | Name | Description
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

InsertBeforeOrAfter Class


InsertBeforeOrAfter Methods

InsertBeforeOrAfter Methods

The InsertBeforeOrAfter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf |
Public method | InsertPageBreakBeforeSelf |
Public method | InsertParagraphAfterSelf(String) |
Public method | InsertParagraphAfterSelf(Paragraph) |
Public method | InsertParagraphAfterSelf(String, Boolean) |
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) |
Public method | InsertParagraphBeforeSelf(String) |
Public method | InsertParagraphBeforeSelf(Paragraph) |
Public method | InsertParagraphBeforeSelf(String, Boolean) |
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) |
Public method | InsertTableAfterSelf(Table) |
Public method | InsertTableAfterSelf(Int32, Int32) |
Public method | InsertTableBeforeSelf(Table) |
Public method | InsertTableBeforeSelf(Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InsertBeforeOrAfter Class


InsertBeforeOrAfter.InsertPageBreakAfterSelf Method

InsertBeforeOrAfterInsertPageBreakAfterSelf Method

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertPageBreakAfterSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual void InsertPageBreakAfterSelf()
Public Overridable Sub InsertPageBreakAfterSelf
public:
virtual void InsertPageBreakAfterSelf()
abstract InsertPageBreakAfterSelf : unit -> unit
override InsertPageBreakAfterSelf : unit -> unit
See Also

Reference

InsertBeforeOrAfter Class


InsertBeforeOrAfter.InsertPageBreakBeforeSelf Method

InsertBeforeOrAfterInsertPageBreakBeforeSelf Method

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertPageBreakBeforeSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual void InsertPageBreakBeforeSelf()
Public Overridable Sub InsertPageBreakBeforeSelf
public:
virtual void InsertPageBreakBeforeSelf()
abstract InsertPageBreakBeforeSelf : unit -> unit
override InsertPageBreakBeforeSelf : unit -> unit
See Also

Reference

InsertBeforeOrAfter Class


InsertBeforeOrAfter.InsertParagraphAfterSelf Method

InsertBeforeOrAfterInsertParagraphAfterSelf Method
Overload List
 | Name | Description
Public method | InsertParagraphAfterSelf(String) |
Public method | InsertParagraphAfterSelf(Paragraph) |
Public method | InsertParagraphAfterSelf(String, Boolean) |
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) |
Top
See Also

Reference

InsertBeforeOrAfter Class


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (String)

InsertBeforeOrAfterInsertParagraphAfterSelf Method (String)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraphAfterSelf(
    string text
)
Public Overridable Function InsertParagraphAfterSelf (
    text As String
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text
)
abstract InsertParagraphAfterSelf :
        text : string -> Paragraph
override InsertParagraphAfterSelf :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (Paragraph)

InsertBeforeOrAfterInsertParagraphAfterSelf Method (Paragraph)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraphAfterSelf(
    Paragraph p
)
Public Overridable Function InsertParagraphAfterSelf (
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    Paragraph^ p
)
abstract InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph
override InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(Novacode.Paragraph)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (String, Boolean)

InsertBeforeOrAfterInsertParagraphAfterSelf Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges
)
Public Overridable Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges
)
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphAfterSelf Method (String, Boolean, Formatting)

InsertBeforeOrAfterInsertParagraphAfterSelf Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overridable Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertParagraphAfterSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method

InsertBeforeOrAfterInsertParagraphBeforeSelf Method
Overload List
 | Name | Description
Public method | InsertParagraphBeforeSelf(String) |
Public method | InsertParagraphBeforeSelf(Paragraph) |
Public method | InsertParagraphBeforeSelf(String, Boolean) |
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) |
Top
See Also

Reference

InsertBeforeOrAfter Class


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (String)

InsertBeforeOrAfterInsertParagraphBeforeSelf Method (String)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraphBeforeSelf(
    string text
)
Public Overridable Function InsertParagraphBeforeSelf (
    text As String
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text
)
abstract InsertParagraphBeforeSelf :
        text : string -> Paragraph
override InsertParagraphBeforeSelf :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (Paragraph)

InsertBeforeOrAfterInsertParagraphBeforeSelf Method (Paragraph)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraphBeforeSelf(
    Paragraph p
)
Public Overridable Function InsertParagraphBeforeSelf (
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    Paragraph^ p
)
abstract InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph
override InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (String, Boolean)

InsertBeforeOrAfterInsertParagraphBeforeSelf Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges
)
Public Overridable Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges
)
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertParagraphBeforeSelf Method (String, Boolean, Formatting)

InsertBeforeOrAfterInsertParagraphBeforeSelf Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overridable Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
)
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertParagraphBeforeSelf Overload


InsertBeforeOrAfter.InsertTableAfterSelf Method

InsertBeforeOrAfterInsertTableAfterSelf Method
Overload List
 | Name | Description
Public method | InsertTableAfterSelf(Table) |
Public method | InsertTableAfterSelf(Int32, Int32) |
Top
See Also

Reference

InsertBeforeOrAfter Class


InsertBeforeOrAfter.InsertTableAfterSelf Method (Table)

InsertBeforeOrAfterInsertTableAfterSelf Method (Table)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Table InsertTableAfterSelf(
    Table t
)
Public Overridable Function InsertTableAfterSelf (
    t As Table
) As Table
public:
virtual Table^ InsertTableAfterSelf(
    Table^ t
)
abstract InsertTableAfterSelf :
        t : Table -> Table
override InsertTableAfterSelf :
        t : Table -> Table

Parameters

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(Novacode.Table)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertTableAfterSelf Overload


InsertBeforeOrAfter.InsertTableAfterSelf Method (Int32, Int32)

InsertBeforeOrAfterInsertTableAfterSelf Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Table InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
Public Overridable Function InsertTableAfterSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
virtual Table^ InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
abstract InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableAfterSelf(System.Int32,System.Int32)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertTableAfterSelf Overload


InsertBeforeOrAfter.InsertTableBeforeSelf Method

InsertBeforeOrAfterInsertTableBeforeSelf Method
Overload List
 | Name | Description
Public method | InsertTableBeforeSelf(Table) |
Public method | InsertTableBeforeSelf(Int32, Int32) |
Top
See Also

Reference

InsertBeforeOrAfter Class


InsertBeforeOrAfter.InsertTableBeforeSelf Method (Table)

InsertBeforeOrAfterInsertTableBeforeSelf Method (Table)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Table InsertTableBeforeSelf(
    Table t
)
Public Overridable Function InsertTableBeforeSelf (
    t As Table
) As Table
public:
virtual Table^ InsertTableBeforeSelf(
    Table^ t
)
abstract InsertTableBeforeSelf :
        t : Table -> Table
override InsertTableBeforeSelf :
        t : Table -> Table

Parameters

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(Novacode.Table)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertTableBeforeSelf Overload


InsertBeforeOrAfter.InsertTableBeforeSelf Method (Int32, Int32)

InsertBeforeOrAfterInsertTableBeforeSelf Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual Table InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
Public Overridable Function InsertTableBeforeSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
virtual Table^ InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
abstract InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.InsertBeforeOrAfter.InsertTableBeforeSelf(System.Int32,System.Int32)"]

See Also

Reference

InsertBeforeOrAfter Class
InsertTableBeforeSelf Overload


IParagraphContainer Interface

IParagraphContainer Interface

[Missing <summary> documentation for "T:Novacode.IParagraphContainer"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public interface IParagraphContainer
Public Interface IParagraphContainer
public interface class IParagraphContainer
type IParagraphContainer =  interface end

The IParagraphContainer type exposes the following members.

Properties
 | Name | Description
Public property | Paragraphs |
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


IParagraphContainer Properties

IParagraphContainer Properties

The IParagraphContainer type exposes the following members.

Properties
 | Name | Description
Public property | Paragraphs |
Top
See Also

Reference

IParagraphContainer Interface


IParagraphContainer.Paragraphs Property

IParagraphContainerParagraphs Property

[Missing <summary> documentation for "P:Novacode.IParagraphContainer.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<Paragraph> Paragraphs { get; }
ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get ();
}
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection Paragraph
See Also

Reference

IParagraphContainer Interface


LineChart Class

LineChart Class

[Missing <summary> documentation for "T:Novacode.LineChart"]

Inheritance Hierarchy
SystemObject
NovacodeChart
NovacodeLineChart

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class LineChart : Chart
Public Class LineChart
    Inherits Chart
public ref class LineChart : public Chart
type LineChart =
    class
        inherit Chart
    end

The LineChart type exposes the following members.

Constructors
 | Name | Description
Public method | LineChart | Initializes a new instance of the LineChart class
Top
Properties
 | Name | Description
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | Grouping |
Public property | IsAxisExist | (Inherited from Chart.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Inherited from Chart.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)
Top
Methods
 | Name | Description
Public method | AddLegend | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides ChartCreateChartXml.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


LineChart Constructor

LineChart Constructor
Initializes a new instance of the LineChart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public LineChart()
Public Sub New
public:
LineChart()
new : unit -> LineChart
See Also

Reference

LineChart Class


LineChart Properties

LineChart Properties

The LineChart type exposes the following members.

Properties
 | Name | Description
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | Grouping |
Public property | IsAxisExist | (Inherited from Chart.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Inherited from Chart.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)
Top
See Also

Reference

LineChart Class


LineChart.Grouping Property

LineChartGrouping Property

[Missing <summary> documentation for "P:Novacode.LineChart.Grouping"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Grouping Grouping { get; set; }
Public Property Grouping As Grouping
    Get
    Set
public:
property Grouping Grouping {
    Grouping get ();
    void set (Grouping value);
}
member Grouping : Grouping with get, set

Property Value

Type: Grouping
See Also

Reference

LineChart Class


LineChart Methods

LineChart Methods

The LineChart type exposes the following members.

Methods
 | Name | Description
Public method | AddLegend | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides ChartCreateChartXml.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineChart Class


LineChart.CreateChartXml Method

LineChartCreateChartXml Method

[Missing <summary> documentation for "M:Novacode.LineChart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
protected override XElement CreateChartXml()
Protected Overrides Function CreateChartXml As XElement
protected:
virtual XElement^ CreateChartXml() override
abstract CreateChartXml : unit -> XElement
override CreateChartXml : unit -> XElement

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.LineChart.CreateChartXml"]

See Also

Reference

LineChart Class


LineSpacingType Enumeration

LineSpacingType Enumeration

[Missing <summary> documentation for "T:Novacode.LineSpacingType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum LineSpacingType
Public Enumeration LineSpacingType
public enum class LineSpacingType
type LineSpacingType
Members
Member name | Value | Description
Line | 0 |
Before | 1 |
After | 2 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


LineSpacingTypeAuto Enumeration

LineSpacingTypeAuto Enumeration

[Missing <summary> documentation for "T:Novacode.LineSpacingTypeAuto"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum LineSpacingTypeAuto
Public Enumeration LineSpacingTypeAuto
public enum class LineSpacingTypeAuto
type LineSpacingTypeAuto
Members
Member name | Value | Description
AutoBefore | 0 |
AutoAfter | 1 |
Auto | 2 |
None | 3 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


List Class

List Class

[Missing <summary> documentation for "T:Novacode.List"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeInsertBeforeOrAfter
NovacodeList

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class List : InsertBeforeOrAfter
Public Class List
    Inherits InsertBeforeOrAfter
public ref class List : public InsertBeforeOrAfter
type List =
    class
        inherit InsertBeforeOrAfter
    end

The List type exposes the following members.

Properties
 | Name | Description
Public property | Items |
Public property | ListType |
Public property | NumId |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | AddItem |
Public method | AddItemWithStartValue |
Public method | CanAddListItem |
Public method | ContainsLevel |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertPageBreakBeforeSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


List Properties

List Properties

The List type exposes the following members.

Properties
 | Name | Description
Public property | Items |
Public property | ListType |
Public property | NumId |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

List Class


List.Items Property

ListItems Property

[Missing <summary> documentation for "P:Novacode.List.Items"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Paragraph> Items { get; }
Public ReadOnly Property Items As List(Of Paragraph)
    Get
public:
property List<Paragraph^>^ Items {
    List<Paragraph^>^ get ();
}
member Items : List<Paragraph> with get

Property Value

Type: List Paragraph
See Also

Reference

List Class


List.ListType Property

ListListType Property

[Missing <summary> documentation for "P:Novacode.List.ListType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Nullable<ListItemType> ListType { get; }
Public ReadOnly Property ListType As Nullable(Of ListItemType)
    Get
public:
property Nullable<ListItemType> ListType {
    Nullable<ListItemType> get ();
}
member ListType : Nullable<ListItemType> with get

Property Value

Type: Nullable ListItemType
See Also

Reference

List Class


List.NumId Property

ListNumId Property

[Missing <summary> documentation for "P:Novacode.List.NumId"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int NumId { get; }
Public ReadOnly Property NumId As Integer
    Get
public:
property int NumId {
    int get ();
}
member NumId : int with get

Property Value

Type: Int32
See Also

Reference

List Class


List Methods

List Methods

The List type exposes the following members.

Methods
 | Name | Description
Public method | AddItem |
Public method | AddItemWithStartValue |
Public method | CanAddListItem |
Public method | ContainsLevel |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertPageBreakAfterSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertPageBreakBeforeSelf | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableAfterSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Table) | (Inherited from InsertBeforeOrAfter.)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Inherited from InsertBeforeOrAfter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

List Class


List.AddItem Method

ListAddItem Method

[Missing <summary> documentation for "M:Novacode.List.AddItem(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddItem(
    Paragraph paragraph
)
Public Sub AddItem (
    paragraph As Paragraph
)
public:
void AddItem(
    Paragraph^ paragraph
)
member AddItem :
        paragraph : Paragraph -> unit

Parameters

paragraph
Type: NovacodeParagraph

[Missing <param name="paragraph"/> documentation for "M:Novacode.List.AddItem(Novacode.Paragraph)"]

See Also

Reference

List Class


List.AddItemWithStartValue Method

ListAddItemWithStartValue Method

[Missing <summary> documentation for "M:Novacode.List.AddItemWithStartValue(Novacode.Paragraph,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AddItemWithStartValue(
    Paragraph paragraph,
    int start
)
Public Sub AddItemWithStartValue (
    paragraph As Paragraph,
    start As Integer
)
public:
void AddItemWithStartValue(
    Paragraph^ paragraph,
    int start
)
member AddItemWithStartValue :
        paragraph : Paragraph *
        start : int -> unit

Parameters

paragraph
Type: NovacodeParagraph

[Missing <param name="paragraph"/> documentation for "M:Novacode.List.AddItemWithStartValue(Novacode.Paragraph,System.Int32)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Novacode.List.AddItemWithStartValue(Novacode.Paragraph,System.Int32)"]

See Also

Reference

List Class


List.CanAddListItem Method

ListCanAddListItem Method

[Missing <summary> documentation for "M:Novacode.List.CanAddListItem(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool CanAddListItem(
    Paragraph paragraph
)
Public Function CanAddListItem (
    paragraph As Paragraph
) As Boolean
public:
bool CanAddListItem(
    Paragraph^ paragraph
)
member CanAddListItem :
        paragraph : Paragraph -> bool

Parameters

paragraph
Type: NovacodeParagraph

[Missing <param name="paragraph"/> documentation for "M:Novacode.List.CanAddListItem(Novacode.Paragraph)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.List.CanAddListItem(Novacode.Paragraph)"]

See Also

Reference

List Class


List.ContainsLevel Method

ListContainsLevel Method

[Missing <summary> documentation for "M:Novacode.List.ContainsLevel(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsLevel(
    int ilvl
)
Public Function ContainsLevel (
    ilvl As Integer
) As Boolean
public:
bool ContainsLevel(
    int ilvl
)
member ContainsLevel :
        ilvl : int -> bool

Parameters

ilvl
Type: SystemInt32

[Missing <param name="ilvl"/> documentation for "M:Novacode.List.ContainsLevel(System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.List.ContainsLevel(System.Int32)"]

See Also

Reference

List Class


ListItemType Enumeration

ListItemType Enumeration

[Missing <summary> documentation for "T:Novacode.ListItemType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum ListItemType
Public Enumeration ListItemType
public enum class ListItemType
type ListItemType
Members
Member name | Value | Description
Bulleted | 0 |
Numbered | 1 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


MatchFormattingOptions Enumeration

MatchFormattingOptions Enumeration

[Missing <summary> documentation for "T:Novacode.MatchFormattingOptions"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum MatchFormattingOptions
Public Enumeration MatchFormattingOptions
public enum class MatchFormattingOptions
type MatchFormattingOptions
Members
Member name | Value | Description
ExactMatch | 0 |
SubsetMatch | 1 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Misc Enumeration

Misc Enumeration

[Missing <summary> documentation for "T:Novacode.Misc"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum Misc
Public Enumeration Misc
public enum class Misc
type Misc
Members
Member name | Value | Description
none | 0 |
shadow | 1 |
outline | 2 |
outlineShadow | 3 |
emboss | 4 |
engrave | 5 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Orientation Enumeration

Orientation Enumeration

[Missing <summary> documentation for "T:Novacode.Orientation"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum Orientation
Public Enumeration Orientation
public enum class Orientation
type Orientation
Members
Member name | Value | Description
Portrait | 0 |
Landscape | 1 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


PageLayout Class

PageLayout Class

[Missing <summary> documentation for "T:Novacode.PageLayout"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodePageLayout

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class PageLayout : DocXElement
Public Class PageLayout
    Inherits DocXElement
public ref class PageLayout : public DocXElement
type PageLayout =
    class
        inherit DocXElement
    end

The PageLayout type exposes the following members.

Properties
 | Name | Description
Public property | Orientation |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


PageLayout Properties

PageLayout Properties

The PageLayout type exposes the following members.

Properties
 | Name | Description
Public property | Orientation |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

PageLayout Class


PageLayout.Orientation Property

PageLayoutOrientation Property

[Missing <summary> documentation for "P:Novacode.PageLayout.Orientation"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}
member Orientation : Orientation with get, set

Property Value

Type: Orientation
See Also

Reference

PageLayout Class


PageLayout Methods

PageLayout Methods

The PageLayout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageLayout Class


PageNumberFormat Enumeration

PageNumberFormat Enumeration

[Missing <summary> documentation for "T:Novacode.PageNumberFormat"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum PageNumberFormat
Public Enumeration PageNumberFormat
public enum class PageNumberFormat
type PageNumberFormat
Members
Member name | Value | Description
normal | 0 |
roman | 1 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Paragraph Class

Paragraph Class

[Missing <summary> documentation for "T:Novacode.Paragraph"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeInsertBeforeOrAfter
NovacodeParagraph

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Paragraph : InsertBeforeOrAfter
Public Class Paragraph
    Inherits InsertBeforeOrAfter
public ref class Paragraph : public InsertBeforeOrAfter
type Paragraph =
    class
        inherit InsertBeforeOrAfter
    end

The Paragraph type exposes the following members.

Properties
 | Name | Description
Public property | Alignment |
Public property | Direction |
Public property | DocumentProperties |
Public property | FollowingTable |
Public property | Hyperlinks |
Public property | IndentationAfter |
Public property | IndentationBefore |
Public property | IndentationFirstLine |
Public property | IndentationHanging |
Public property | IndentLevel |
Public property | IsKeepWithNext |
Public property | IsListItem |
Public property | LineSpacing |
Public property | LineSpacingAfter |
Public property | LineSpacingBefore |
Public property | MagicText |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | ParagraphNumberProperties |
Public property | Pictures |
Public property | StyleName |
Public property | Text |
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Append |
Public method | AppendBookmark |
Public method | AppendDocProperty |
Public method | AppendEquation |
Public method | AppendHyperlink |
Public method | AppendLine |
Public method | AppendLine(String) |
Public method | AppendPageCount |
Public method | AppendPageNumber |
Public method | AppendPicture |
Public method | Bold |
Public method | CapsStyle |
Public method | Color |
Public method | Culture |
Public method | CurentCulture |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Public method | FindAllByPattern |
Public method | Font |
Public method | FontSize |
Public method | GetBookmarks |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Hide |
Public method | Highlight |
Public method | InsertAtBookmark |
Public method | InsertDocProperty |
Public method | InsertHyperlink(Int32, Hyperlink) | Obsolete.
Public method | InsertHyperlink(Hyperlink, Int32) |
Public method | InsertPageBreakAfterSelf | (Overrides InsertBeforeOrAfterInsertPageBreakAfterSelf.)
Public method | InsertPageBreakBeforeSelf | (Overrides InsertBeforeOrAfterInsertPageBreakBeforeSelf.)
Public method | InsertPageCount |
Public method | InsertPageNumber |
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertPicture |
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Int32, Int32).)
Public method | InsertText(String, Boolean, Formatting) |
Public method | InsertText(Int32, String, Boolean, Formatting) |
Public method | Italic |
Public method | KeepLinesTogether |
Public method | KeepWithNext |
Public method | Kerning |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Misc |
Public method | PercentageScale |
Public method | Position |
Public method | Remove |
Public method | RemoveHyperlink |
Public method | RemoveText(Int32, Boolean) |
Public method | RemoveText(Int32, Int32, Boolean) |
Public method | ReplaceAtBookmark |
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Public method | Script |
Public method | SetLineSpacing(LineSpacingTypeAuto) |
Public method | SetLineSpacing(LineSpacingType, Single) |
Public method | Spacing |
Public method | SpacingAfter |
Public method | SpacingBefore |
Public method | StrikeThrough |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnderlineColor |
Public method | UnderlineStyle |
Public method | ValidateBookmark |
Top
Fields
 | Name | Description
Public field | ListItemType |
Public field | ParentContainer |
Top
Extension Methods
 | Name | Description
Public Extension Method | Heading | (Defined by ExtensionsHeadings.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Paragraph Properties

Paragraph Properties

The Paragraph type exposes the following members.

Properties
 | Name | Description
Public property | Alignment |
Public property | Direction |
Public property | DocumentProperties |
Public property | FollowingTable |
Public property | Hyperlinks |
Public property | IndentationAfter |
Public property | IndentationBefore |
Public property | IndentationFirstLine |
Public property | IndentationHanging |
Public property | IndentLevel |
Public property | IsKeepWithNext |
Public property | IsListItem |
Public property | LineSpacing |
Public property | LineSpacingAfter |
Public property | LineSpacingBefore |
Public property | MagicText |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | ParagraphNumberProperties |
Public property | Pictures |
Public property | StyleName |
Public property | Text |
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Paragraph Class


Paragraph.Alignment Property

ParagraphAlignment Property

[Missing <summary> documentation for "P:Novacode.Paragraph.Alignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Alignment Alignment { get; set; }
Public Property Alignment As Alignment
    Get
    Set
public:
property Alignment Alignment {
    Alignment get ();
    void set (Alignment value);
}
member Alignment : Alignment with get, set

Property Value

Type: Alignment
See Also

Reference

Paragraph Class


Paragraph.Direction Property

ParagraphDirection Property

[Missing <summary> documentation for "P:Novacode.Paragraph.Direction"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Direction Direction { get; set; }
Public Property Direction As Direction
    Get
    Set
public:
property Direction Direction {
    Direction get ();
    void set (Direction value);
}
member Direction : Direction with get, set

Property Value

Type: Direction
See Also

Reference

Paragraph Class


Paragraph.DocumentProperties Property

ParagraphDocumentProperties Property

[Missing <summary> documentation for "P:Novacode.Paragraph.DocumentProperties"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<DocProperty> DocumentProperties { get; }
Public ReadOnly Property DocumentProperties As List(Of DocProperty)
    Get
public:
property List<DocProperty^>^ DocumentProperties {
    List<DocProperty^>^ get ();
}
member DocumentProperties : List<DocProperty> with get

Property Value

Type: List DocProperty
See Also

Reference

Paragraph Class


Paragraph.FollowingTable Property

ParagraphFollowingTable Property

[Missing <summary> documentation for "P:Novacode.Paragraph.FollowingTable"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Table FollowingTable { get; }
Public ReadOnly Property FollowingTable As Table
    Get
public:
property Table^ FollowingTable {
    Table^ get ();
}
member FollowingTable : Table with get

Property Value

Type: Table
See Also

Reference

Paragraph Class


Paragraph.Hyperlinks Property

ParagraphHyperlinks Property

[Missing <summary> documentation for "P:Novacode.Paragraph.Hyperlinks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Hyperlink> Hyperlinks { get; }
Public ReadOnly Property Hyperlinks As List(Of Hyperlink)
    Get
public:
property List<Hyperlink^>^ Hyperlinks {
    List<Hyperlink^>^ get ();
}
member Hyperlinks : List<Hyperlink> with get

Property Value

Type: List Hyperlink
See Also

Reference

Paragraph Class


Paragraph.IndentationAfter Property

ParagraphIndentationAfter Property

[Missing <summary> documentation for "P:Novacode.Paragraph.IndentationAfter"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float IndentationAfter { get; set; }
Public Property IndentationAfter As Single
    Get
    Set
public:
property float IndentationAfter {
    float get ();
    void set (float value);
}
member IndentationAfter : float32 with get, set

Property Value

Type: Single
See Also

Reference

Paragraph Class


Paragraph.IndentationBefore Property

ParagraphIndentationBefore Property

[Missing <summary> documentation for "P:Novacode.Paragraph.IndentationBefore"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float IndentationBefore { get; set; }
Public Property IndentationBefore As Single
    Get
    Set
public:
property float IndentationBefore {
    float get ();
    void set (float value);
}
member IndentationBefore : float32 with get, set

Property Value

Type: Single
See Also

Reference

Paragraph Class


Paragraph.IndentationFirstLine Property

ParagraphIndentationFirstLine Property

[Missing <summary> documentation for "P:Novacode.Paragraph.IndentationFirstLine"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float IndentationFirstLine { get; set; }
Public Property IndentationFirstLine As Single
    Get
    Set
public:
property float IndentationFirstLine {
    float get ();
    void set (float value);
}
member IndentationFirstLine : float32 with get, set

Property Value

Type: Single
See Also

Reference

Paragraph Class


Paragraph.IndentationHanging Property

ParagraphIndentationHanging Property

[Missing <summary> documentation for "P:Novacode.Paragraph.IndentationHanging"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float IndentationHanging { get; set; }
Public Property IndentationHanging As Single
    Get
    Set
public:
property float IndentationHanging {
    float get ();
    void set (float value);
}
member IndentationHanging : float32 with get, set

Property Value

Type: Single
See Also

Reference

Paragraph Class


Paragraph.IndentLevel Property

ParagraphIndentLevel Property

[Missing <summary> documentation for "P:Novacode.Paragraph.IndentLevel"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> IndentLevel { get; }
Public ReadOnly Property IndentLevel As Nullable(Of Integer)
    Get
public:
property Nullable<int> IndentLevel {
    Nullable<int> get ();
}
member IndentLevel : Nullable<int> with get

Property Value

Type: Nullable Int32
See Also

Reference

Paragraph Class


Paragraph.IsKeepWithNext Property

ParagraphIsKeepWithNext Property

[Missing <summary> documentation for "P:Novacode.Paragraph.IsKeepWithNext"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool IsKeepWithNext { get; }
Public ReadOnly Property IsKeepWithNext As Boolean
    Get
public:
property bool IsKeepWithNext {
    bool get ();
}
member IsKeepWithNext : bool with get

Property Value

Type: Boolean
See Also

Reference

Paragraph Class


Paragraph.IsListItem Property

ParagraphIsListItem Property

[Missing <summary> documentation for "P:Novacode.Paragraph.IsListItem"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool IsListItem { get; }
Public ReadOnly Property IsListItem As Boolean
    Get
public:
property bool IsListItem {
    bool get ();
}
member IsListItem : bool with get

Property Value

Type: Boolean
See Also

Reference

Paragraph Class


Paragraph.LineSpacing Property

ParagraphLineSpacing Property

[Missing <summary> documentation for "P:Novacode.Paragraph.LineSpacing"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float LineSpacing { get; set; }
Public Property LineSpacing As Single
    Get
    Set
public:
property float LineSpacing {
    float get ();
    void set (float value);
}
member LineSpacing : float32 with get, set

Property Value

Type: Single
See Also

Reference

Paragraph Class


Paragraph.LineSpacingAfter Property

ParagraphLineSpacingAfter Property

[Missing <summary> documentation for "P:Novacode.Paragraph.LineSpacingAfter"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float LineSpacingAfter { get; set; }
Public Property LineSpacingAfter As Single
    Get
    Set
public:
property float LineSpacingAfter {
    float get ();
    void set (float value);
}
member LineSpacingAfter : float32 with get, set

Property Value

Type: Single
See Also

Reference

Paragraph Class


Paragraph.LineSpacingBefore Property

ParagraphLineSpacingBefore Property

[Missing <summary> documentation for "P:Novacode.Paragraph.LineSpacingBefore"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public float LineSpacingBefore { get; set; }
Public Property LineSpacingBefore As Single
    Get
    Set
public:
property float LineSpacingBefore {
    float get ();
    void set (float value);
}
member LineSpacingBefore : float32 with get, set

Property Value

Type: Single
See Also

Reference

Paragraph Class


Paragraph.MagicText Property

ParagraphMagicText Property

[Missing <summary> documentation for "P:Novacode.Paragraph.MagicText"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<FormattedText> MagicText { get; }
Public ReadOnly Property MagicText As List(Of FormattedText)
    Get
public:
property List<FormattedText^>^ MagicText {
    List<FormattedText^>^ get ();
}
member MagicText : List<FormattedText> with get

Property Value

Type: List FormattedText
See Also

Reference

Paragraph Class


Paragraph.ParagraphNumberProperties Property

ParagraphParagraphNumberProperties Property

[Missing <summary> documentation for "P:Novacode.Paragraph.ParagraphNumberProperties"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public XElement ParagraphNumberProperties { get; }
Public ReadOnly Property ParagraphNumberProperties As XElement
    Get
public:
property XElement^ ParagraphNumberProperties {
    XElement^ get ();
}
member ParagraphNumberProperties : XElement with get

Property Value

Type: XElement
See Also

Reference

Paragraph Class


Paragraph.Pictures Property

ParagraphPictures Property

[Missing <summary> documentation for "P:Novacode.Paragraph.Pictures"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Picture> Pictures { get; }
Public ReadOnly Property Pictures As List(Of Picture)
    Get
public:
property List<Picture^>^ Pictures {
    List<Picture^>^ get ();
}
member Pictures : List<Picture> with get

Property Value

Type: List Picture
See Also

Reference

Paragraph Class


Paragraph.StyleName Property

ParagraphStyleName Property

[Missing <summary> documentation for "P:Novacode.Paragraph.StyleName"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string StyleName { get; set; }
Public Property StyleName As String
    Get
    Set
public:
property String^ StyleName {
    String^ get ();
    void set (String^ value);
}
member StyleName : string with get, set

Property Value

Type: String
See Also

Reference

Paragraph Class


Paragraph.Text Property

ParagraphText Property

[Missing <summary> documentation for "P:Novacode.Paragraph.Text"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}
member Text : string with get

Property Value

Type: String
See Also

Reference

Paragraph Class


Paragraph Methods

Paragraph Methods

The Paragraph type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | AppendBookmark |
Public method | AppendDocProperty |
Public method | AppendEquation |
Public method | AppendHyperlink |
Public method | AppendLine |
Public method | AppendLine(String) |
Public method | AppendPageCount |
Public method | AppendPageNumber |
Public method | AppendPicture |
Public method | Bold |
Public method | CapsStyle |
Public method | Color |
Public method | Culture |
Public method | CurentCulture |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Public method | FindAllByPattern |
Public method | Font |
Public method | FontSize |
Public method | GetBookmarks |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Hide |
Public method | Highlight |
Public method | InsertAtBookmark |
Public method | InsertDocProperty |
Public method | InsertHyperlink(Int32, Hyperlink) | Obsolete.
Public method | InsertHyperlink(Hyperlink, Int32) |
Public method | InsertPageBreakAfterSelf | (Overrides InsertBeforeOrAfterInsertPageBreakAfterSelf.)
Public method | InsertPageBreakBeforeSelf | (Overrides InsertBeforeOrAfterInsertPageBreakBeforeSelf.)
Public method | InsertPageCount |
Public method | InsertPageNumber |
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertPicture |
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Int32, Int32).)
Public method | InsertText(String, Boolean, Formatting) |
Public method | InsertText(Int32, String, Boolean, Formatting) |
Public method | Italic |
Public method | KeepLinesTogether |
Public method | KeepWithNext |
Public method | Kerning |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Misc |
Public method | PercentageScale |
Public method | Position |
Public method | Remove |
Public method | RemoveHyperlink |
Public method | RemoveText(Int32, Boolean) |
Public method | RemoveText(Int32, Int32, Boolean) |
Public method | ReplaceAtBookmark |
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Public method | Script |
Public method | SetLineSpacing(LineSpacingTypeAuto) |
Public method | SetLineSpacing(LineSpacingType, Single) |
Public method | Spacing |
Public method | SpacingAfter |
Public method | SpacingBefore |
Public method | StrikeThrough |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnderlineColor |
Public method | UnderlineStyle |
Public method | ValidateBookmark |
Top
Extension Methods
 | Name | Description
Public Extension Method | Heading | (Defined by ExtensionsHeadings.)
Top
See Also

Reference

Paragraph Class


Paragraph.Append Method

ParagraphAppend Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Append(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Append(
    string text
)
Public Function Append (
    text As String
) As Paragraph
public:
Paragraph^ Append(
    String^ text
)
member Append :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.Append(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Append(System.String)"]

See Also

Reference

Paragraph Class


Paragraph.AppendBookmark Method

ParagraphAppendBookmark Method

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendBookmark(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph AppendBookmark(
    string bookmarkName
)
Public Function AppendBookmark (
    bookmarkName As String
) As Paragraph
public:
Paragraph^ AppendBookmark(
    String^ bookmarkName
)
member AppendBookmark :
        bookmarkName : string -> Paragraph

Parameters

bookmarkName
Type: SystemString

[Missing <param name="bookmarkName"/> documentation for "M:Novacode.Paragraph.AppendBookmark(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendBookmark(System.String)"]

See Also

Reference

Paragraph Class


Paragraph.AppendDocProperty Method

ParagraphAppendDocProperty Method

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph AppendDocProperty(
    CustomProperty cp,
    bool trackChanges = false,
    Formatting f = null
)
Public Function AppendDocProperty (
    cp As CustomProperty,
    Optional trackChanges As Boolean = false,
    Optional f As Formatting = Nothing
) As Paragraph
public:
Paragraph^ AppendDocProperty(
    CustomProperty^ cp,
    bool trackChanges = false,
    Formatting^ f = nullptr
)
member AppendDocProperty :
        cp : CustomProperty *
        ?trackChanges : bool *
        ?f : Formatting
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _f = defaultArg f null
*)
-> Paragraph

Parameters

cp
Type: NovacodeCustomProperty

[Missing <param name="cp"/> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

f (Optional)
Type: NovacodeFormatting

[Missing <param name="f"/> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Paragraph Class


Paragraph.AppendEquation Method

ParagraphAppendEquation Method

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendEquation(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph AppendEquation(
    string equation
)
Public Function AppendEquation (
    equation As String
) As Paragraph
public:
Paragraph^ AppendEquation(
    String^ equation
)
member AppendEquation :
        equation : string -> Paragraph

Parameters

equation
Type: SystemString

[Missing <param name="equation"/> documentation for "M:Novacode.Paragraph.AppendEquation(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendEquation(System.String)"]

See Also

Reference

Paragraph Class


Paragraph.AppendHyperlink Method

ParagraphAppendHyperlink Method

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendHyperlink(Novacode.Hyperlink)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph AppendHyperlink(
    Hyperlink h
)
Public Function AppendHyperlink (
    h As Hyperlink
) As Paragraph
public:
Paragraph^ AppendHyperlink(
    Hyperlink^ h
)
member AppendHyperlink :
        h : Hyperlink -> Paragraph

Parameters

h
Type: NovacodeHyperlink

[Missing <param name="h"/> documentation for "M:Novacode.Paragraph.AppendHyperlink(Novacode.Hyperlink)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendHyperlink(Novacode.Hyperlink)"]

See Also

Reference

Paragraph Class


Paragraph.AppendLine Method

ParagraphAppendLine Method
Overload List
 | Name | Description
Public method | AppendLine |
Public method | AppendLine(String) |
Top
See Also

Reference

Paragraph Class


Paragraph.AppendLine Method

ParagraphAppendLine Method

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendLine"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph AppendLine()
Public Function AppendLine As Paragraph
public:
Paragraph^ AppendLine()
member AppendLine : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendLine"]

See Also

Reference

Paragraph Class
AppendLine Overload


Paragraph.AppendLine Method (String)

ParagraphAppendLine Method (String)

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendLine(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph AppendLine(
    string text
)
Public Function AppendLine (
    text As String
) As Paragraph
public:
Paragraph^ AppendLine(
    String^ text
)
member AppendLine :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.AppendLine(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendLine(System.String)"]

See Also

Reference

Paragraph Class
AppendLine Overload


Paragraph.AppendPageCount Method

ParagraphAppendPageCount Method

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendPageCount(Novacode.PageNumberFormat)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AppendPageCount(
    PageNumberFormat pnf
)
Public Sub AppendPageCount (
    pnf As PageNumberFormat
)
public:
void AppendPageCount(
    PageNumberFormat pnf
)
member AppendPageCount :
        pnf : PageNumberFormat -> unit

Parameters

pnf
Type: NovacodePageNumberFormat

[Missing <param name="pnf"/> documentation for "M:Novacode.Paragraph.AppendPageCount(Novacode.PageNumberFormat)"]

See Also

Reference

Paragraph Class


Paragraph.AppendPageNumber Method

ParagraphAppendPageNumber Method

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendPageNumber(Novacode.PageNumberFormat)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void AppendPageNumber(
    PageNumberFormat pnf
)
Public Sub AppendPageNumber (
    pnf As PageNumberFormat
)
public:
void AppendPageNumber(
    PageNumberFormat pnf
)
member AppendPageNumber :
        pnf : PageNumberFormat -> unit

Parameters

pnf
Type: NovacodePageNumberFormat

[Missing <param name="pnf"/> documentation for "M:Novacode.Paragraph.AppendPageNumber(Novacode.PageNumberFormat)"]

See Also

Reference

Paragraph Class


Paragraph.AppendPicture Method

ParagraphAppendPicture Method

[Missing <summary> documentation for "M:Novacode.Paragraph.AppendPicture(Novacode.Picture)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph AppendPicture(
    Picture p
)
Public Function AppendPicture (
    p As Picture
) As Paragraph
public:
Paragraph^ AppendPicture(
    Picture^ p
)
member AppendPicture :
        p : Picture -> Paragraph

Parameters

p
Type: NovacodePicture

[Missing <param name="p"/> documentation for "M:Novacode.Paragraph.AppendPicture(Novacode.Picture)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.AppendPicture(Novacode.Picture)"]

See Also

Reference

Paragraph Class


Paragraph.Bold Method

ParagraphBold Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Bold"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Bold()
Public Function Bold As Paragraph
public:
Paragraph^ Bold()
member Bold : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Bold"]

See Also

Reference

Paragraph Class


Paragraph.CapsStyle Method

ParagraphCapsStyle Method

[Missing <summary> documentation for "M:Novacode.Paragraph.CapsStyle(Novacode.CapsStyle)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph CapsStyle(
    CapsStyle capsStyle
)
Public Function CapsStyle (
    capsStyle As CapsStyle
) As Paragraph
public:
Paragraph^ CapsStyle(
    CapsStyle capsStyle
)
member CapsStyle :
        capsStyle : CapsStyle -> Paragraph

Parameters

capsStyle
Type: NovacodeCapsStyle

[Missing <param name="capsStyle"/> documentation for "M:Novacode.Paragraph.CapsStyle(Novacode.CapsStyle)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.CapsStyle(Novacode.CapsStyle)"]

See Also

Reference

Paragraph Class


Paragraph.Color Method

ParagraphColor Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Color(System.Drawing.Color)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Color(
    Color c
)
Public Function Color (
    c As Color
) As Paragraph
public:
Paragraph^ Color(
    Color c
)
member Color :
        c : Color -> Paragraph

Parameters

c
Type: System.DrawingColor

[Missing <param name="c"/> documentation for "M:Novacode.Paragraph.Color(System.Drawing.Color)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Color(System.Drawing.Color)"]

See Also

Reference

Paragraph Class


Paragraph.Culture Method

ParagraphCulture Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Culture(System.Globalization.CultureInfo)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Culture(
    CultureInfo culture
)
Public Function Culture (
    culture As CultureInfo
) As Paragraph
public:
Paragraph^ Culture(
    CultureInfo^ culture
)
member Culture :
        culture : CultureInfo -> Paragraph

Parameters

culture
Type: System.GlobalizationCultureInfo

[Missing <param name="culture"/> documentation for "M:Novacode.Paragraph.Culture(System.Globalization.CultureInfo)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Culture(System.Globalization.CultureInfo)"]

See Also

Reference

Paragraph Class


Paragraph.CurentCulture Method

ParagraphCurentCulture Method

[Missing <summary> documentation for "M:Novacode.Paragraph.CurentCulture"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph CurentCulture()
Public Function CurentCulture As Paragraph
public:
Paragraph^ CurentCulture()
member CurentCulture : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.CurentCulture"]

See Also

Reference

Paragraph Class


Paragraph.FindAll Method

ParagraphFindAll Method
Overload List
 | Name | Description
Public method | FindAll(String) |
Public method | FindAll(String, RegexOptions) |
Top
See Also

Reference

Paragraph Class


Paragraph.FindAll Method (String)

ParagraphFindAll Method (String)

[Missing <summary> documentation for "M:Novacode.Paragraph.FindAll(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<int> FindAll(
    string str
)
Public Function FindAll (
    str As String
) As List(Of Integer)
public:
List<int>^ FindAll(
    String^ str
)
member FindAll :
        str : string -> List<int>

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:Novacode.Paragraph.FindAll(System.String)"]

Return Value

Type: List Int32

[Missing <returns> documentation for "M:Novacode.Paragraph.FindAll(System.String)"]

See Also

Reference

Paragraph Class
FindAll Overload


Paragraph.FindAll Method (String, RegexOptions)

ParagraphFindAll Method (String, RegexOptions)

[Missing <summary> documentation for "M:Novacode.Paragraph.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<int> FindAll(
    string str,
    RegexOptions options
)
Public Function FindAll (
    str As String,
    options As RegexOptions
) As List(Of Integer)
public:
List<int>^ FindAll(
    String^ str,
    RegexOptions options
)
member FindAll :
        str : string *
        options : RegexOptions -> List<int>

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:Novacode.Paragraph.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressionsRegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Paragraph.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List Int32

[Missing <returns> documentation for "M:Novacode.Paragraph.FindAll(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Reference

Paragraph Class
FindAll Overload


Paragraph.FindAllByPattern Method

ParagraphFindAllByPattern Method

[Missing <summary> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<string> FindAllByPattern(
    string str,
    RegexOptions options
)
Public Function FindAllByPattern (
    str As String,
    options As RegexOptions
) As List(Of String)
public:
List<String^>^ FindAllByPattern(
    String^ str,
    RegexOptions options
)
member FindAllByPattern :
        str : string *
        options : RegexOptions -> List<string>

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

options
Type: System.Text.RegularExpressionsRegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

Return Value

Type: List String

[Missing <returns> documentation for "M:Novacode.Paragraph.FindAllByPattern(System.String,System.Text.RegularExpressions.RegexOptions)"]

See Also

Reference

Paragraph Class


Paragraph.Font Method

ParagraphFont Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Font(System.Drawing.FontFamily)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Font(
    FontFamily fontFamily
)
Public Function Font (
    fontFamily As FontFamily
) As Paragraph
public:
Paragraph^ Font(
    FontFamily^ fontFamily
)
member Font :
        fontFamily : FontFamily -> Paragraph

Parameters

fontFamily
Type: System.DrawingFontFamily

[Missing <param name="fontFamily"/> documentation for "M:Novacode.Paragraph.Font(System.Drawing.FontFamily)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Font(System.Drawing.FontFamily)"]

See Also

Reference

Paragraph Class


Paragraph.FontSize Method

ParagraphFontSize Method

[Missing <summary> documentation for "M:Novacode.Paragraph.FontSize(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph FontSize(
    double fontSize
)
Public Function FontSize (
    fontSize As Double
) As Paragraph
public:
Paragraph^ FontSize(
    double fontSize
)
member FontSize :
        fontSize : float -> Paragraph

Parameters

fontSize
Type: SystemDouble

[Missing <param name="fontSize"/> documentation for "M:Novacode.Paragraph.FontSize(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.FontSize(System.Double)"]

See Also

Reference

Paragraph Class


Paragraph.GetBookmarks Method

ParagraphGetBookmarks Method

[Missing <summary> documentation for "M:Novacode.Paragraph.GetBookmarks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Bookmark> GetBookmarks()
Public Function GetBookmarks As IEnumerable(Of Bookmark)
public:
IEnumerable<Bookmark^>^ GetBookmarks()
member GetBookmarks : unit -> IEnumerable<Bookmark>

Return Value

Type: IEnumerable Bookmark

[Missing <returns> documentation for "M:Novacode.Paragraph.GetBookmarks"]

See Also

Reference

Paragraph Class


Paragraph.Hide Method

ParagraphHide Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Hide"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Hide()
Public Function Hide As Paragraph
public:
Paragraph^ Hide()
member Hide : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Hide"]

See Also

Reference

Paragraph Class


Paragraph.Highlight Method

ParagraphHighlight Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Highlight(Novacode.Highlight)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Highlight(
    Highlight highlight
)
Public Function Highlight (
    highlight As Highlight
) As Paragraph
public:
Paragraph^ Highlight(
    Highlight highlight
)
member Highlight :
        highlight : Highlight -> Paragraph

Parameters

highlight
Type: NovacodeHighlight

[Missing <param name="highlight"/> documentation for "M:Novacode.Paragraph.Highlight(Novacode.Highlight)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Highlight(Novacode.Highlight)"]

See Also

Reference

Paragraph Class


Paragraph.InsertAtBookmark Method

ParagraphInsertAtBookmark Method

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertAtBookmark(System.String,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void InsertAtBookmark(
    string toInsert,
    string bookmarkName
)
Public Sub InsertAtBookmark (
    toInsert As String,
    bookmarkName As String
)
public:
void InsertAtBookmark(
    String^ toInsert,
    String^ bookmarkName
)
member InsertAtBookmark :
        toInsert : string *
        bookmarkName : string -> unit

Parameters

toInsert
Type: SystemString

[Missing <param name="toInsert"/> documentation for "M:Novacode.Paragraph.InsertAtBookmark(System.String,System.String)"]

bookmarkName
Type: SystemString

[Missing <param name="bookmarkName"/> documentation for "M:Novacode.Paragraph.InsertAtBookmark(System.String,System.String)"]

See Also

Reference

Paragraph Class


Paragraph.InsertDocProperty Method

ParagraphInsertDocProperty Method

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public DocProperty InsertDocProperty(
    CustomProperty cp,
    bool trackChanges = false,
    Formatting f = null
)
Public Function InsertDocProperty (
    cp As CustomProperty,
    Optional trackChanges As Boolean = false,
    Optional f As Formatting = Nothing
) As DocProperty
public:
DocProperty^ InsertDocProperty(
    CustomProperty^ cp,
    bool trackChanges = false,
    Formatting^ f = nullptr
)
member InsertDocProperty :
        cp : CustomProperty *
        ?trackChanges : bool *
        ?f : Formatting
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _f = defaultArg f null
*)
-> DocProperty

Parameters

cp
Type: NovacodeCustomProperty

[Missing <param name="cp"/> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

f (Optional)
Type: NovacodeFormatting

[Missing <param name="f"/> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

Return Value

Type: DocProperty

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertDocProperty(Novacode.CustomProperty,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Paragraph Class


Paragraph.InsertHyperlink Method

ParagraphInsertHyperlink Method
Overload List
 | Name | Description
Public method | InsertHyperlink(Int32, Hyperlink) | Obsolete.
Public method | InsertHyperlink(Hyperlink, Int32) |
Top
See Also

Reference

Paragraph Class


Paragraph.InsertHyperlink Method (Int32, Hyperlink)

ParagraphInsertHyperlink Method (Int32, Hyperlink)

Note: This API is now obsolete.

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Instead use: InsertHyperlink(Hyperlink h, int index)")]
public Paragraph InsertHyperlink(
    int index,
    Hyperlink h
)
<ObsoleteAttribute("Instead use: InsertHyperlink(Hyperlink h, int index)")>
Public Function InsertHyperlink (
    index As Integer,
    h As Hyperlink
) As Paragraph
public:
[ObsoleteAttribute(L"Instead use: InsertHyperlink(Hyperlink h, int index)")]
Paragraph^ InsertHyperlink(
    int index,
    Hyperlink^ h
)
[<ObsoleteAttribute("Instead use: InsertHyperlink(Hyperlink h, int index)")>]
member InsertHyperlink :
        index : int *
        h : Hyperlink -> Paragraph

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

h
Type: NovacodeHyperlink

[Missing <param name="h"/> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertHyperlink(System.Int32,Novacode.Hyperlink)"]

See Also

Reference

Paragraph Class
InsertHyperlink Overload


Paragraph.InsertHyperlink Method (Hyperlink, Int32)

ParagraphInsertHyperlink Method (Hyperlink, Int32)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertHyperlink(Novacode.Hyperlink,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph InsertHyperlink(
    Hyperlink h,
    int index = 0
)
Public Function InsertHyperlink (
    h As Hyperlink,
    Optional index As Integer = 0
) As Paragraph
public:
Paragraph^ InsertHyperlink(
    Hyperlink^ h,
    int index = 0
)
member InsertHyperlink :
        h : Hyperlink *
        ?index : int
(* Defaults:
        let _index = defaultArg index 0
*)
-> Paragraph

Parameters

h
Type: NovacodeHyperlink

[Missing <param name="h"/> documentation for "M:Novacode.Paragraph.InsertHyperlink(Novacode.Hyperlink,System.Int32)"]

index (Optional)
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertHyperlink(Novacode.Hyperlink,System.Int32)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertHyperlink(Novacode.Hyperlink,System.Int32)"]

See Also

Reference

Paragraph Class
InsertHyperlink Overload


Paragraph.InsertPageBreakAfterSelf Method

ParagraphInsertPageBreakAfterSelf Method

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertPageBreakAfterSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override void InsertPageBreakAfterSelf()
Public Overrides Sub InsertPageBreakAfterSelf
public:
virtual void InsertPageBreakAfterSelf() override
abstract InsertPageBreakAfterSelf : unit -> unit
override InsertPageBreakAfterSelf : unit -> unit
See Also

Reference

Paragraph Class


Paragraph.InsertPageBreakBeforeSelf Method

ParagraphInsertPageBreakBeforeSelf Method

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertPageBreakBeforeSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override void InsertPageBreakBeforeSelf()
Public Overrides Sub InsertPageBreakBeforeSelf
public:
virtual void InsertPageBreakBeforeSelf() override
abstract InsertPageBreakBeforeSelf : unit -> unit
override InsertPageBreakBeforeSelf : unit -> unit
See Also

Reference

Paragraph Class


Paragraph.InsertPageCount Method

ParagraphInsertPageCount Method

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertPageCount(Novacode.PageNumberFormat,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void InsertPageCount(
    PageNumberFormat pnf,
    int index = 0
)
Public Sub InsertPageCount (
    pnf As PageNumberFormat,
    Optional index As Integer = 0
)
public:
void InsertPageCount(
    PageNumberFormat pnf,
    int index = 0
)
member InsertPageCount :
        pnf : PageNumberFormat *
        ?index : int
(* Defaults:
        let _index = defaultArg index 0
*)
-> unit

Parameters

pnf
Type: NovacodePageNumberFormat

[Missing <param name="pnf"/> documentation for "M:Novacode.Paragraph.InsertPageCount(Novacode.PageNumberFormat,System.Int32)"]

index (Optional)
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertPageCount(Novacode.PageNumberFormat,System.Int32)"]

See Also

Reference

Paragraph Class


Paragraph.InsertPageNumber Method

ParagraphInsertPageNumber Method

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertPageNumber(Novacode.PageNumberFormat,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void InsertPageNumber(
    PageNumberFormat pnf,
    int index = 0
)
Public Sub InsertPageNumber (
    pnf As PageNumberFormat,
    Optional index As Integer = 0
)
public:
void InsertPageNumber(
    PageNumberFormat pnf,
    int index = 0
)
member InsertPageNumber :
        pnf : PageNumberFormat *
        ?index : int
(* Defaults:
        let _index = defaultArg index 0
*)
-> unit

Parameters

pnf
Type: NovacodePageNumberFormat

[Missing <param name="pnf"/> documentation for "M:Novacode.Paragraph.InsertPageNumber(Novacode.PageNumberFormat,System.Int32)"]

index (Optional)
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertPageNumber(Novacode.PageNumberFormat,System.Int32)"]

See Also

Reference

Paragraph Class


Paragraph.InsertParagraphAfterSelf Method

ParagraphInsertParagraphAfterSelf Method
Overload List
 | Name | Description
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean, Formatting).)
Top
See Also

Reference

Paragraph Class


Paragraph.InsertParagraphAfterSelf Method (String)

ParagraphInsertParagraphAfterSelf Method (String)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphAfterSelf(
    string text
)
Public Overrides Function InsertParagraphAfterSelf (
    text As String
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text
) override
abstract InsertParagraphAfterSelf :
        text : string -> Paragraph
override InsertParagraphAfterSelf :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String)"]

See Also

Reference

Paragraph Class
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphAfterSelf Method (Paragraph)

ParagraphInsertParagraphAfterSelf Method (Paragraph)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphAfterSelf(
    Paragraph p
)
Public Overrides Function InsertParagraphAfterSelf (
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    Paragraph^ p
) override
abstract InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph
override InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(Novacode.Paragraph)"]

See Also

Reference

Paragraph Class
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphAfterSelf Method (String, Boolean)

ParagraphInsertParagraphAfterSelf Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges
)
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges
) override
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean)"]

See Also

Reference

Paragraph Class
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphAfterSelf Method (String, Boolean, Formatting)

ParagraphInsertParagraphAfterSelf Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Paragraph Class
InsertParagraphAfterSelf Overload


Paragraph.InsertParagraphBeforeSelf Method

ParagraphInsertParagraphBeforeSelf Method
Overload List
 | Name | Description
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean, Formatting).)
Top
See Also

Reference

Paragraph Class


Paragraph.InsertParagraphBeforeSelf Method (String)

ParagraphInsertParagraphBeforeSelf Method (String)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphBeforeSelf(
    string text
)
Public Overrides Function InsertParagraphBeforeSelf (
    text As String
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text
) override
abstract InsertParagraphBeforeSelf :
        text : string -> Paragraph
override InsertParagraphBeforeSelf :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String)"]

See Also

Reference

Paragraph Class
InsertParagraphBeforeSelf Overload


Paragraph.InsertParagraphBeforeSelf Method (Paragraph)

ParagraphInsertParagraphBeforeSelf Method (Paragraph)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphBeforeSelf(
    Paragraph p
)
Public Overrides Function InsertParagraphBeforeSelf (
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    Paragraph^ p
) override
abstract InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph
override InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

See Also

Reference

Paragraph Class
InsertParagraphBeforeSelf Overload


Paragraph.InsertParagraphBeforeSelf Method (String, Boolean)

ParagraphInsertParagraphBeforeSelf Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges
)
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges
) override
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

See Also

Reference

Paragraph Class
InsertParagraphBeforeSelf Overload


Paragraph.InsertParagraphBeforeSelf Method (String, Boolean, Formatting)

ParagraphInsertParagraphBeforeSelf Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Paragraph Class
InsertParagraphBeforeSelf Overload


Paragraph.InsertPicture Method

ParagraphInsertPicture Method

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertPicture(Novacode.Picture,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph InsertPicture(
    Picture p,
    int index = 0
)
Public Function InsertPicture (
    p As Picture,
    Optional index As Integer = 0
) As Paragraph
public:
Paragraph^ InsertPicture(
    Picture^ p,
    int index = 0
)
member InsertPicture :
        p : Picture *
        ?index : int
(* Defaults:
        let _index = defaultArg index 0
*)
-> Paragraph

Parameters

p
Type: NovacodePicture

[Missing <param name="p"/> documentation for "M:Novacode.Paragraph.InsertPicture(Novacode.Picture,System.Int32)"]

index (Optional)
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertPicture(Novacode.Picture,System.Int32)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertPicture(Novacode.Picture,System.Int32)"]

See Also

Reference

Paragraph Class


Paragraph.InsertTableAfterSelf Method

ParagraphInsertTableAfterSelf Method
Overload List
 | Name | Description
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Int32, Int32).)
Top
See Also

Reference

Paragraph Class


Paragraph.InsertTableAfterSelf Method (Table)

ParagraphInsertTableAfterSelf Method (Table)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Table InsertTableAfterSelf(
    Table t
)
Public Overrides Function InsertTableAfterSelf (
    t As Table
) As Table
public:
virtual Table^ InsertTableAfterSelf(
    Table^ t
) override
abstract InsertTableAfterSelf :
        t : Table -> Table
override InsertTableAfterSelf :
        t : Table -> Table

Parameters

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(Novacode.Table)"]

See Also

Reference

Paragraph Class
InsertTableAfterSelf Overload


Paragraph.InsertTableAfterSelf Method (Int32, Int32)

ParagraphInsertTableAfterSelf Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Table InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
Public Overrides Function InsertTableAfterSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
virtual Table^ InsertTableAfterSelf(
    int rowCount,
    int columnCount
) override
abstract InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertTableAfterSelf(System.Int32,System.Int32)"]

See Also

Reference

Paragraph Class
InsertTableAfterSelf Overload


Paragraph.InsertTableBeforeSelf Method

ParagraphInsertTableBeforeSelf Method
Overload List
 | Name | Description
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Int32, Int32).)
Top
See Also

Reference

Paragraph Class


Paragraph.InsertTableBeforeSelf Method (Table)

ParagraphInsertTableBeforeSelf Method (Table)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Table InsertTableBeforeSelf(
    Table t
)
Public Overrides Function InsertTableBeforeSelf (
    t As Table
) As Table
public:
virtual Table^ InsertTableBeforeSelf(
    Table^ t
) override
abstract InsertTableBeforeSelf :
        t : Table -> Table
override InsertTableBeforeSelf :
        t : Table -> Table

Parameters

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(Novacode.Table)"]

See Also

Reference

Paragraph Class
InsertTableBeforeSelf Overload


Paragraph.InsertTableBeforeSelf Method (Int32, Int32)

ParagraphInsertTableBeforeSelf Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Table InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
Public Overrides Function InsertTableBeforeSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
virtual Table^ InsertTableBeforeSelf(
    int rowCount,
    int columnCount
) override
abstract InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Paragraph.InsertTableBeforeSelf(System.Int32,System.Int32)"]

See Also

Reference

Paragraph Class
InsertTableBeforeSelf Overload


Paragraph.InsertText Method

ParagraphInsertText Method
Overload List
 | Name | Description
Public method | InsertText(String, Boolean, Formatting) |
Public method | InsertText(Int32, String, Boolean, Formatting) |
Top
See Also

Reference

Paragraph Class


Paragraph.InsertText Method (String, Boolean, Formatting)

ParagraphInsertText Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertText(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void InsertText(
    string value,
    bool trackChanges = false,
    Formatting formatting = null
)
Public Sub InsertText (
    value As String,
    Optional trackChanges As Boolean = false,
    Optional formatting As Formatting = Nothing
)
public:
void InsertText(
    String^ value,
    bool trackChanges = false,
    Formatting^ formatting = nullptr
)
member InsertText :
        value : string *
        ?trackChanges : bool *
        ?formatting : Formatting
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _formatting = defaultArg formatting null
*)
-> unit

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Novacode.Paragraph.InsertText(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertText(System.String,System.Boolean,Novacode.Formatting)"]

formatting (Optional)
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Paragraph.InsertText(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Paragraph Class
InsertText Overload


Paragraph.InsertText Method (Int32, String, Boolean, Formatting)

ParagraphInsertText Method (Int32, String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Paragraph.InsertText(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void InsertText(
    int index,
    string value,
    bool trackChanges = false,
    Formatting formatting = null
)
Public Sub InsertText (
    index As Integer,
    value As String,
    Optional trackChanges As Boolean = false,
    Optional formatting As Formatting = Nothing
)
public:
void InsertText(
    int index,
    String^ value,
    bool trackChanges = false,
    Formatting^ formatting = nullptr
)
member InsertText :
        index : int *
        value : string *
        ?trackChanges : bool *
        ?formatting : Formatting
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _formatting = defaultArg formatting null
*)
-> unit

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.InsertText(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Novacode.Paragraph.InsertText(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.InsertText(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

formatting (Optional)
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Paragraph.InsertText(System.Int32,System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Paragraph Class
InsertText Overload


Paragraph.Italic Method

ParagraphItalic Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Italic"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Italic()
Public Function Italic As Paragraph
public:
Paragraph^ Italic()
member Italic : unit -> Paragraph

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Italic"]

See Also

Reference

Paragraph Class


Paragraph.KeepLinesTogether Method

ParagraphKeepLinesTogether Method

[Missing <summary> documentation for "M:Novacode.Paragraph.KeepLinesTogether(System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph KeepLinesTogether(
    bool keepTogether = true
)
Public Function KeepLinesTogether (
    Optional keepTogether As Boolean = true
) As Paragraph
public:
Paragraph^ KeepLinesTogether(
    bool keepTogether = true
)
member KeepLinesTogether :
        ?keepTogether : bool
(* Defaults:
        let _keepTogether = defaultArg keepTogether true
*)
-> Paragraph

Parameters

keepTogether (Optional)
Type: SystemBoolean

[Missing <param name="keepTogether"/> documentation for "M:Novacode.Paragraph.KeepLinesTogether(System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.KeepLinesTogether(System.Boolean)"]

See Also

Reference

Paragraph Class


Paragraph.KeepWithNext Method

ParagraphKeepWithNext Method

[Missing <summary> documentation for "M:Novacode.Paragraph.KeepWithNext(System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph KeepWithNext(
    bool keepWithNext = true
)
Public Function KeepWithNext (
    Optional keepWithNext As Boolean = true
) As Paragraph
public:
Paragraph^ KeepWithNext(
    bool keepWithNext = true
)
member KeepWithNext :
        ?keepWithNext : bool
(* Defaults:
        let _keepWithNext = defaultArg keepWithNext true
*)
-> Paragraph

Parameters

keepWithNext (Optional)
Type: SystemBoolean

[Missing <param name="keepWithNext"/> documentation for "M:Novacode.Paragraph.KeepWithNext(System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.KeepWithNext(System.Boolean)"]

See Also

Reference

Paragraph Class


Paragraph.Kerning Method

ParagraphKerning Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Kerning(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Kerning(
    int kerning
)
Public Function Kerning (
    kerning As Integer
) As Paragraph
public:
Paragraph^ Kerning(
    int kerning
)
member Kerning :
        kerning : int -> Paragraph

Parameters

kerning
Type: SystemInt32

[Missing <param name="kerning"/> documentation for "M:Novacode.Paragraph.Kerning(System.Int32)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Kerning(System.Int32)"]

See Also

Reference

Paragraph Class


Paragraph.Misc Method

ParagraphMisc Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Misc(Novacode.Misc)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Misc(
    Misc misc
)
Public Function Misc (
    misc As Misc
) As Paragraph
public:
Paragraph^ Misc(
    Misc misc
)
member Misc :
        misc : Misc -> Paragraph

Parameters

misc
Type: NovacodeMisc

[Missing <param name="misc"/> documentation for "M:Novacode.Paragraph.Misc(Novacode.Misc)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Misc(Novacode.Misc)"]

See Also

Reference

Paragraph Class


Paragraph.PercentageScale Method

ParagraphPercentageScale Method

[Missing <summary> documentation for "M:Novacode.Paragraph.PercentageScale(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph PercentageScale(
    int percentageScale
)
Public Function PercentageScale (
    percentageScale As Integer
) As Paragraph
public:
Paragraph^ PercentageScale(
    int percentageScale
)
member PercentageScale :
        percentageScale : int -> Paragraph

Parameters

percentageScale
Type: SystemInt32

[Missing <param name="percentageScale"/> documentation for "M:Novacode.Paragraph.PercentageScale(System.Int32)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.PercentageScale(System.Int32)"]

See Also

Reference

Paragraph Class


Paragraph.Position Method

ParagraphPosition Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Position(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Position(
    double position
)
Public Function Position (
    position As Double
) As Paragraph
public:
Paragraph^ Position(
    double position
)
member Position :
        position : float -> Paragraph

Parameters

position
Type: SystemDouble

[Missing <param name="position"/> documentation for "M:Novacode.Paragraph.Position(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Position(System.Double)"]

See Also

Reference

Paragraph Class


Paragraph.Remove Method

ParagraphRemove Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Remove(System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    bool trackChanges
)
Public Sub Remove (
    trackChanges As Boolean
)
public:
void Remove(
    bool trackChanges
)
member Remove :
        trackChanges : bool -> unit

Parameters

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.Remove(System.Boolean)"]

See Also

Reference

Paragraph Class


Paragraph.RemoveHyperlink Method

ParagraphRemoveHyperlink Method

[Missing <summary> documentation for "M:Novacode.Paragraph.RemoveHyperlink(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void RemoveHyperlink(
    int index
)
Public Sub RemoveHyperlink (
    index As Integer
)
public:
void RemoveHyperlink(
    int index
)
member RemoveHyperlink :
        index : int -> unit

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.RemoveHyperlink(System.Int32)"]

See Also

Reference

Paragraph Class


Paragraph.RemoveText Method

ParagraphRemoveText Method
Overload List
 | Name | Description
Public method | RemoveText(Int32, Boolean) |
Public method | RemoveText(Int32, Int32, Boolean) |
Top
See Also

Reference

Paragraph Class


Paragraph.RemoveText Method (Int32, Boolean)

ParagraphRemoveText Method (Int32, Boolean)

[Missing <summary> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void RemoveText(
    int index,
    bool trackChanges = false
)
Public Sub RemoveText (
    index As Integer,
    Optional trackChanges As Boolean = false
)
public:
void RemoveText(
    int index,
    bool trackChanges = false
)
member RemoveText :
        index : int *
        ?trackChanges : bool
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
*)
-> unit

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Boolean)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Boolean)"]

See Also

Reference

Paragraph Class
RemoveText Overload


Paragraph.RemoveText Method (Int32, Int32, Boolean)

ParagraphRemoveText Method (Int32, Int32, Boolean)

[Missing <summary> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Int32,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void RemoveText(
    int index,
    int count,
    bool trackChanges = false
)
Public Sub RemoveText (
    index As Integer,
    count As Integer,
    Optional trackChanges As Boolean = false
)
public:
void RemoveText(
    int index,
    int count,
    bool trackChanges = false
)
member RemoveText :
        index : int *
        count : int *
        ?trackChanges : bool
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
*)
-> unit

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Int32,System.Boolean)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Int32,System.Boolean)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.RemoveText(System.Int32,System.Int32,System.Boolean)"]

See Also

Reference

Paragraph Class
RemoveText Overload


Paragraph.ReplaceAtBookmark Method

ParagraphReplaceAtBookmark Method

[Missing <summary> documentation for "M:Novacode.Paragraph.ReplaceAtBookmark(System.String,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void ReplaceAtBookmark(
    string toInsert,
    string bookmarkName
)
Public Sub ReplaceAtBookmark (
    toInsert As String,
    bookmarkName As String
)
public:
void ReplaceAtBookmark(
    String^ toInsert,
    String^ bookmarkName
)
member ReplaceAtBookmark :
        toInsert : string *
        bookmarkName : string -> unit

Parameters

toInsert
Type: SystemString

[Missing <param name="toInsert"/> documentation for "M:Novacode.Paragraph.ReplaceAtBookmark(System.String,System.String)"]

bookmarkName
Type: SystemString

[Missing <param name="bookmarkName"/> documentation for "M:Novacode.Paragraph.ReplaceAtBookmark(System.String,System.String)"]

See Also

Reference

Paragraph Class


Paragraph.ReplaceText Method

ParagraphReplaceText Method
Overload List
 | Name | Description
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) |
Top
See Also

Reference

Paragraph Class


Paragraph.ReplaceText Method (String, Func(String, String), Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions)

ParagraphReplaceText Method (String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions)

[Missing <summary> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void ReplaceText(
    string findPattern,
    Func<string, string> regexMatchHandler,
    bool trackChanges = false,
    RegexOptions options = RegexOptions.None,
    Formatting newFormatting = null,
    Formatting matchFormatting = null,
    MatchFormattingOptions fo = MatchFormattingOptions.SubsetMatch
)
Public Sub ReplaceText (
    findPattern As String,
    regexMatchHandler As Func(Of String, String),
    Optional trackChanges As Boolean = false,
    Optional options As RegexOptions = RegexOptions.None,
    Optional newFormatting As Formatting = Nothing,
    Optional matchFormatting As Formatting = Nothing,
    Optional fo As MatchFormattingOptions = MatchFormattingOptions.SubsetMatch
)
public:
void ReplaceText(
    String^ findPattern,
    Func<String^, String^>^ regexMatchHandler,
    bool trackChanges = false,
    RegexOptions options = RegexOptions::None,
    Formatting^ newFormatting = nullptr,
    Formatting^ matchFormatting = nullptr,
    MatchFormattingOptions fo = MatchFormattingOptions::SubsetMatch
)
member ReplaceText :
        findPattern : string *
        regexMatchHandler : Func<string, string> *
        ?trackChanges : bool *
        ?options : RegexOptions *
        ?newFormatting : Formatting *
        ?matchFormatting : Formatting *
        ?fo : MatchFormattingOptions
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _options = defaultArg options RegexOptions.None
        let _newFormatting = defaultArg newFormatting null
        let _matchFormatting = defaultArg matchFormatting null
        let _fo = defaultArg fo MatchFormattingOptions.SubsetMatch
*)
-> unit

Parameters

findPattern
Type: SystemString

[Missing <param name="findPattern"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

regexMatchHandler
Type: SystemFunc String, String

[Missing <param name="regexMatchHandler"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

options (Optional)
Type: System.Text.RegularExpressionsRegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newFormatting (Optional)
Type: NovacodeFormatting

[Missing <param name="newFormatting"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

matchFormatting (Optional)
Type: NovacodeFormatting

[Missing <param name="matchFormatting"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

fo (Optional)
Type: NovacodeMatchFormattingOptions

[Missing <param name="fo"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.Func{System.String,System.String},System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

See Also

Reference

Paragraph Class
ReplaceText Overload


Paragraph.ReplaceText Method (String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions)

ParagraphReplaceText Method (String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions)

[Missing <summary> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void ReplaceText(
    string oldValue,
    string newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions.None,
    Formatting newFormatting = null,
    Formatting matchFormatting = null,
    MatchFormattingOptions fo = MatchFormattingOptions.SubsetMatch
)
Public Sub ReplaceText (
    oldValue As String,
    newValue As String,
    Optional trackChanges As Boolean = false,
    Optional options As RegexOptions = RegexOptions.None,
    Optional newFormatting As Formatting = Nothing,
    Optional matchFormatting As Formatting = Nothing,
    Optional fo As MatchFormattingOptions = MatchFormattingOptions.SubsetMatch
)
public:
void ReplaceText(
    String^ oldValue,
    String^ newValue,
    bool trackChanges = false,
    RegexOptions options = RegexOptions::None,
    Formatting^ newFormatting = nullptr,
    Formatting^ matchFormatting = nullptr,
    MatchFormattingOptions fo = MatchFormattingOptions::SubsetMatch
)
member ReplaceText :
        oldValue : string *
        newValue : string *
        ?trackChanges : bool *
        ?options : RegexOptions *
        ?newFormatting : Formatting *
        ?matchFormatting : Formatting *
        ?fo : MatchFormattingOptions
(* Defaults:
        let _trackChanges = defaultArg trackChanges false
        let _options = defaultArg options RegexOptions.None
        let _newFormatting = defaultArg newFormatting null
        let _matchFormatting = defaultArg matchFormatting null
        let _fo = defaultArg fo MatchFormattingOptions.SubsetMatch
*)
-> unit

Parameters

oldValue
Type: SystemString

[Missing <param name="oldValue"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newValue
Type: SystemString

[Missing <param name="newValue"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

trackChanges (Optional)
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

options (Optional)
Type: System.Text.RegularExpressionsRegexOptions

[Missing <param name="options"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

newFormatting (Optional)
Type: NovacodeFormatting

[Missing <param name="newFormatting"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

matchFormatting (Optional)
Type: NovacodeFormatting

[Missing <param name="matchFormatting"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

fo (Optional)
Type: NovacodeMatchFormattingOptions

[Missing <param name="fo"/> documentation for "M:Novacode.Paragraph.ReplaceText(System.String,System.String,System.Boolean,System.Text.RegularExpressions.RegexOptions,Novacode.Formatting,Novacode.Formatting,Novacode.MatchFormattingOptions)"]

See Also

Reference

Paragraph Class
ReplaceText Overload


Paragraph.Script Method

ParagraphScript Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Script(Novacode.Script)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Script(
    Script script
)
Public Function Script (
    script As Script
) As Paragraph
public:
Paragraph^ Script(
    Script script
)
member Script :
        script : Script -> Paragraph

Parameters

script
Type: NovacodeScript

[Missing <param name="script"/> documentation for "M:Novacode.Paragraph.Script(Novacode.Script)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Script(Novacode.Script)"]

See Also

Reference

Paragraph Class


Paragraph.SetLineSpacing Method

ParagraphSetLineSpacing Method
Overload List
 | Name | Description
Public method | SetLineSpacing(LineSpacingTypeAuto) |
Public method | SetLineSpacing(LineSpacingType, Single) |
Top
See Also

Reference

Paragraph Class


Paragraph.SetLineSpacing Method (LineSpacingTypeAuto)

ParagraphSetLineSpacing Method (LineSpacingTypeAuto)

[Missing <summary> documentation for "M:Novacode.Paragraph.SetLineSpacing(Novacode.LineSpacingTypeAuto)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetLineSpacing(
    LineSpacingTypeAuto spacingType
)
Public Sub SetLineSpacing (
    spacingType As LineSpacingTypeAuto
)
public:
void SetLineSpacing(
    LineSpacingTypeAuto spacingType
)
member SetLineSpacing :
        spacingType : LineSpacingTypeAuto -> unit

Parameters

spacingType
Type: NovacodeLineSpacingTypeAuto

[Missing <param name="spacingType"/> documentation for "M:Novacode.Paragraph.SetLineSpacing(Novacode.LineSpacingTypeAuto)"]

See Also

Reference

Paragraph Class
SetLineSpacing Overload


Paragraph.SetLineSpacing Method (LineSpacingType, Single)

ParagraphSetLineSpacing Method (LineSpacingType, Single)

[Missing <summary> documentation for "M:Novacode.Paragraph.SetLineSpacing(Novacode.LineSpacingType,System.Single)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetLineSpacing(
    LineSpacingType spacingType,
    float spacingFloat
)
Public Sub SetLineSpacing (
    spacingType As LineSpacingType,
    spacingFloat As Single
)
public:
void SetLineSpacing(
    LineSpacingType spacingType,
    float spacingFloat
)
member SetLineSpacing :
        spacingType : LineSpacingType *
        spacingFloat : float32 -> unit

Parameters

spacingType
Type: NovacodeLineSpacingType

[Missing <param name="spacingType"/> documentation for "M:Novacode.Paragraph.SetLineSpacing(Novacode.LineSpacingType,System.Single)"]

spacingFloat
Type: SystemSingle

[Missing <param name="spacingFloat"/> documentation for "M:Novacode.Paragraph.SetLineSpacing(Novacode.LineSpacingType,System.Single)"]

See Also

Reference

Paragraph Class
SetLineSpacing Overload


Paragraph.Spacing Method

ParagraphSpacing Method

[Missing <summary> documentation for "M:Novacode.Paragraph.Spacing(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph Spacing(
    double spacing
)
Public Function Spacing (
    spacing As Double
) As Paragraph
public:
Paragraph^ Spacing(
    double spacing
)
member Spacing :
        spacing : float -> Paragraph

Parameters

spacing
Type: SystemDouble

[Missing <param name="spacing"/> documentation for "M:Novacode.Paragraph.Spacing(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.Spacing(System.Double)"]

See Also

Reference

Paragraph Class


Paragraph.SpacingAfter Method

ParagraphSpacingAfter Method

[Missing <summary> documentation for "M:Novacode.Paragraph.SpacingAfter(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph SpacingAfter(
    double spacingAfter
)
Public Function SpacingAfter (
    spacingAfter As Double
) As Paragraph
public:
Paragraph^ SpacingAfter(
    double spacingAfter
)
member SpacingAfter :
        spacingAfter : float -> Paragraph

Parameters

spacingAfter
Type: SystemDouble

[Missing <param name="spacingAfter"/> documentation for "M:Novacode.Paragraph.SpacingAfter(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.SpacingAfter(System.Double)"]

See Also

Reference

Paragraph Class


Paragraph.SpacingBefore Method

ParagraphSpacingBefore Method

[Missing <summary> documentation for "M:Novacode.Paragraph.SpacingBefore(System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph SpacingBefore(
    double spacingBefore
)
Public Function SpacingBefore (
    spacingBefore As Double
) As Paragraph
public:
Paragraph^ SpacingBefore(
    double spacingBefore
)
member SpacingBefore :
        spacingBefore : float -> Paragraph

Parameters

spacingBefore
Type: SystemDouble

[Missing <param name="spacingBefore"/> documentation for "M:Novacode.Paragraph.SpacingBefore(System.Double)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.SpacingBefore(System.Double)"]

See Also

Reference

Paragraph Class


Paragraph.StrikeThrough Method

ParagraphStrikeThrough Method

[Missing <summary> documentation for "M:Novacode.Paragraph.StrikeThrough(Novacode.StrikeThrough)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph StrikeThrough(
    StrikeThrough strikeThrough
)
Public Function StrikeThrough (
    strikeThrough As StrikeThrough
) As Paragraph
public:
Paragraph^ StrikeThrough(
    StrikeThrough strikeThrough
)
member StrikeThrough :
        strikeThrough : StrikeThrough -> Paragraph

Parameters

strikeThrough
Type: NovacodeStrikeThrough

[Missing <param name="strikeThrough"/> documentation for "M:Novacode.Paragraph.StrikeThrough(Novacode.StrikeThrough)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.StrikeThrough(Novacode.StrikeThrough)"]

See Also

Reference

Paragraph Class


Paragraph.UnderlineColor Method

ParagraphUnderlineColor Method

[Missing <summary> documentation for "M:Novacode.Paragraph.UnderlineColor(System.Drawing.Color)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph UnderlineColor(
    Color underlineColor
)
Public Function UnderlineColor (
    underlineColor As Color
) As Paragraph
public:
Paragraph^ UnderlineColor(
    Color underlineColor
)
member UnderlineColor :
        underlineColor : Color -> Paragraph

Parameters

underlineColor
Type: System.DrawingColor

[Missing <param name="underlineColor"/> documentation for "M:Novacode.Paragraph.UnderlineColor(System.Drawing.Color)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.UnderlineColor(System.Drawing.Color)"]

See Also

Reference

Paragraph Class


Paragraph.UnderlineStyle Method

ParagraphUnderlineStyle Method

[Missing <summary> documentation for "M:Novacode.Paragraph.UnderlineStyle(Novacode.UnderlineStyle)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Paragraph UnderlineStyle(
    UnderlineStyle underlineStyle
)
Public Function UnderlineStyle (
    underlineStyle As UnderlineStyle
) As Paragraph
public:
Paragraph^ UnderlineStyle(
    UnderlineStyle underlineStyle
)
member UnderlineStyle :
        underlineStyle : UnderlineStyle -> Paragraph

Parameters

underlineStyle
Type: NovacodeUnderlineStyle

[Missing <param name="underlineStyle"/> documentation for "M:Novacode.Paragraph.UnderlineStyle(Novacode.UnderlineStyle)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Paragraph.UnderlineStyle(Novacode.UnderlineStyle)"]

See Also

Reference

Paragraph Class


Paragraph.ValidateBookmark Method

ParagraphValidateBookmark Method

[Missing <summary> documentation for "M:Novacode.Paragraph.ValidateBookmark(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool ValidateBookmark(
    string bookmarkName
)
Public Function ValidateBookmark (
    bookmarkName As String
) As Boolean
public:
bool ValidateBookmark(
    String^ bookmarkName
)
member ValidateBookmark :
        bookmarkName : string -> bool

Parameters

bookmarkName
Type: SystemString

[Missing <param name="bookmarkName"/> documentation for "M:Novacode.Paragraph.ValidateBookmark(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Novacode.Paragraph.ValidateBookmark(System.String)"]

See Also

Reference

Paragraph Class


Paragraph Fields

Paragraph Fields

The Paragraph type exposes the following members.

Fields
 | Name | Description
Public field | ListItemType |
Public field | ParentContainer |
Top
See Also

Reference

Paragraph Class


Paragraph.ListItemType Field

ParagraphListItemType Field

[Missing <summary> documentation for "F:Novacode.Paragraph.ListItemType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public ListItemType ListItemType
Public ListItemType As ListItemType
public:
ListItemType ListItemType
val mutable ListItemType: ListItemType

Field Value

Type: ListItemType
See Also

Reference

Paragraph Class


Paragraph.ParentContainer Field

ParagraphParentContainer Field

[Missing <summary> documentation for "F:Novacode.Paragraph.ParentContainer"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public ContainerType ParentContainer
Public ParentContainer As ContainerType
public:
ContainerType ParentContainer
val mutable ParentContainer: ContainerType

Field Value

Type: ContainerType
See Also

Reference

Paragraph Class


Picture Class

Picture Class

[Missing <summary> documentation for "T:Novacode.Picture"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodePicture

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Picture : DocXElement
Public Class Picture
    Inherits DocXElement
public ref class Picture : public DocXElement
type Picture =
    class
        inherit DocXElement
    end

The Picture type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | FileName |
Public property | FlipHorizontal |
Public property | FlipVertical |
Public property | Height |
Public property | Id |
Public property | Name |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Rotation |
Public property | Width |
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | SetPictureShape(BasicShapes) |
Public method | SetPictureShape(BlockArrowShapes) |
Public method | SetPictureShape(CalloutShapes) |
Public method | SetPictureShape(EquationShapes) |
Public method | SetPictureShape(FlowchartShapes) |
Public method | SetPictureShape(RectangleShapes) |
Public method | SetPictureShape(StarAndBannerShapes) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Picture Properties

Picture Properties

The Picture type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | FileName |
Public property | FlipHorizontal |
Public property | FlipVertical |
Public property | Height |
Public property | Id |
Public property | Name |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Rotation |
Public property | Width |
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Picture Class


Picture.Description Property

PictureDescription Property

[Missing <summary> documentation for "P:Novacode.Picture.Description"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

Picture Class


Picture.FileName Property

PictureFileName Property

[Missing <summary> documentation for "P:Novacode.Picture.FileName"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

Picture Class


Picture.FlipHorizontal Property

PictureFlipHorizontal Property

[Missing <summary> documentation for "P:Novacode.Picture.FlipHorizontal"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool FlipHorizontal { get; set; }
Public Property FlipHorizontal As Boolean
    Get
    Set
public:
property bool FlipHorizontal {
    bool get ();
    void set (bool value);
}
member FlipHorizontal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Picture Class


Picture.FlipVertical Property

PictureFlipVertical Property

[Missing <summary> documentation for "P:Novacode.Picture.FlipVertical"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool FlipVertical { get; set; }
Public Property FlipVertical As Boolean
    Get
    Set
public:
property bool FlipVertical {
    bool get ();
    void set (bool value);
}
member FlipVertical : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Picture Class


Picture.Height Property

PictureHeight Property

[Missing <summary> documentation for "P:Novacode.Picture.Height"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
public:
property int Height {
    int get ();
    void set (int value);
}
member Height : int with get, set

Property Value

Type: Int32
See Also

Reference

Picture Class


Picture.Id Property

PictureId Property

[Missing <summary> documentation for "P:Novacode.Picture.Id"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get
public:
property String^ Id {
    String^ get ();
}
member Id : string with get

Property Value

Type: String
See Also

Reference

Picture Class


Picture.Name Property

PictureName Property

[Missing <summary> documentation for "P:Novacode.Picture.Name"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

Picture Class


Picture.Rotation Property

PictureRotation Property

[Missing <summary> documentation for "P:Novacode.Picture.Rotation"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public uint Rotation { get; set; }
Public Property Rotation As UInteger
    Get
    Set
public:
property unsigned int Rotation {
    unsigned int get ();
    void set (unsigned int value);
}
member Rotation : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Picture Class


Picture.Width Property

PictureWidth Property

[Missing <summary> documentation for "P:Novacode.Picture.Width"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
public:
property int Width {
    int get ();
    void set (int value);
}
member Width : int with get, set

Property Value

Type: Int32
See Also

Reference

Picture Class


Picture Methods

Picture Methods

The Picture type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | SetPictureShape(BasicShapes) |
Public method | SetPictureShape(BlockArrowShapes) |
Public method | SetPictureShape(CalloutShapes) |
Public method | SetPictureShape(EquationShapes) |
Public method | SetPictureShape(FlowchartShapes) |
Public method | SetPictureShape(RectangleShapes) |
Public method | SetPictureShape(StarAndBannerShapes) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Picture Class


Picture.Remove Method

PictureRemove Method

[Missing <summary> documentation for "M:Novacode.Picture.Remove"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

Picture Class


Picture.SetPictureShape Method

PictureSetPictureShape Method
Overload List
 | Name | Description
Public method | SetPictureShape(BasicShapes) |
Public method | SetPictureShape(BlockArrowShapes) |
Public method | SetPictureShape(CalloutShapes) |
Public method | SetPictureShape(EquationShapes) |
Public method | SetPictureShape(FlowchartShapes) |
Public method | SetPictureShape(RectangleShapes) |
Public method | SetPictureShape(StarAndBannerShapes) |
Top
See Also

Reference

Picture Class


Picture.SetPictureShape Method (BasicShapes)

PictureSetPictureShape Method (BasicShapes)

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.BasicShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetPictureShape(
    BasicShapes shape
)
Public Sub SetPictureShape (
    shape As BasicShapes
)
public:
void SetPictureShape(
    BasicShapes shape
)
member SetPictureShape :
        shape : BasicShapes -> unit

Parameters

shape
Type: NovacodeBasicShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.BasicShapes)"]

See Also

Reference

Picture Class
SetPictureShape Overload


Picture.SetPictureShape Method (BlockArrowShapes)

PictureSetPictureShape Method (BlockArrowShapes)

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.BlockArrowShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetPictureShape(
    BlockArrowShapes shape
)
Public Sub SetPictureShape (
    shape As BlockArrowShapes
)
public:
void SetPictureShape(
    BlockArrowShapes shape
)
member SetPictureShape :
        shape : BlockArrowShapes -> unit

Parameters

shape
Type: NovacodeBlockArrowShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.BlockArrowShapes)"]

See Also

Reference

Picture Class
SetPictureShape Overload


Picture.SetPictureShape Method (CalloutShapes)

PictureSetPictureShape Method (CalloutShapes)

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.CalloutShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetPictureShape(
    CalloutShapes shape
)
Public Sub SetPictureShape (
    shape As CalloutShapes
)
public:
void SetPictureShape(
    CalloutShapes shape
)
member SetPictureShape :
        shape : CalloutShapes -> unit

Parameters

shape
Type: NovacodeCalloutShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.CalloutShapes)"]

See Also

Reference

Picture Class
SetPictureShape Overload


Picture.SetPictureShape Method (EquationShapes)

PictureSetPictureShape Method (EquationShapes)

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.EquationShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetPictureShape(
    EquationShapes shape
)
Public Sub SetPictureShape (
    shape As EquationShapes
)
public:
void SetPictureShape(
    EquationShapes shape
)
member SetPictureShape :
        shape : EquationShapes -> unit

Parameters

shape
Type: NovacodeEquationShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.EquationShapes)"]

See Also

Reference

Picture Class
SetPictureShape Overload


Picture.SetPictureShape Method (FlowchartShapes)

PictureSetPictureShape Method (FlowchartShapes)

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.FlowchartShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetPictureShape(
    FlowchartShapes shape
)
Public Sub SetPictureShape (
    shape As FlowchartShapes
)
public:
void SetPictureShape(
    FlowchartShapes shape
)
member SetPictureShape :
        shape : FlowchartShapes -> unit

Parameters

shape
Type: NovacodeFlowchartShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.FlowchartShapes)"]

See Also

Reference

Picture Class
SetPictureShape Overload


Picture.SetPictureShape Method (RectangleShapes)

PictureSetPictureShape Method (RectangleShapes)

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.RectangleShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetPictureShape(
    RectangleShapes shape
)
Public Sub SetPictureShape (
    shape As RectangleShapes
)
public:
void SetPictureShape(
    RectangleShapes shape
)
member SetPictureShape :
        shape : RectangleShapes -> unit

Parameters

shape
Type: NovacodeRectangleShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.RectangleShapes)"]

See Also

Reference

Picture Class
SetPictureShape Overload


Picture.SetPictureShape Method (StarAndBannerShapes)

PictureSetPictureShape Method (StarAndBannerShapes)

[Missing <summary> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.StarAndBannerShapes)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetPictureShape(
    StarAndBannerShapes shape
)
Public Sub SetPictureShape (
    shape As StarAndBannerShapes
)
public:
void SetPictureShape(
    StarAndBannerShapes shape
)
member SetPictureShape :
        shape : StarAndBannerShapes -> unit

Parameters

shape
Type: NovacodeStarAndBannerShapes

[Missing <param name="shape"/> documentation for "M:Novacode.Picture.SetPictureShape(Novacode.StarAndBannerShapes)"]

See Also

Reference

Picture Class
SetPictureShape Overload


PieChart Class

PieChart Class

[Missing <summary> documentation for "T:Novacode.PieChart"]

Inheritance Hierarchy
SystemObject
NovacodeChart
NovacodePieChart

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class PieChart : Chart
Public Class PieChart
    Inherits Chart
public ref class PieChart : public Chart
type PieChart =
    class
        inherit Chart
    end

The PieChart type exposes the following members.

Constructors
 | Name | Description
Public method | PieChart | Initializes a new instance of the PieChart class
Top
Properties
 | Name | Description
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | IsAxisExist | (Overrides ChartIsAxisExist.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Overrides ChartMaxSeriesCount.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)
Top
Methods
 | Name | Description
Public method | AddLegend | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides ChartCreateChartXml.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


PieChart Constructor

PieChart Constructor
Initializes a new instance of the PieChart class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public PieChart()
Public Sub New
public:
PieChart()
new : unit -> PieChart
See Also

Reference

PieChart Class


PieChart Properties

PieChart Properties

The PieChart type exposes the following members.

Properties
 | Name | Description
Public property | CategoryAxis | (Inherited from Chart.)
Protected property | ChartRootXml | (Inherited from Chart.)
Protected property | ChartXml | (Inherited from Chart.)
Public property | DisplayBlanksAs | (Inherited from Chart.)
Public property | IsAxisExist | (Overrides ChartIsAxisExist.)
Public property | Legend | (Inherited from Chart.)
Public property | MaxSeriesCount | (Overrides ChartMaxSeriesCount.)
Public property | Series | (Inherited from Chart.)
Public property | ValueAxis | (Inherited from Chart.)
Public property | View3D | (Inherited from Chart.)
Public property | Xml | (Inherited from Chart.)
Top
See Also

Reference

PieChart Class


PieChart.IsAxisExist Property

PieChartIsAxisExist Property

[Missing <summary> documentation for "P:Novacode.PieChart.IsAxisExist"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override bool IsAxisExist { get; }
Public Overrides ReadOnly Property IsAxisExist As Boolean
    Get
public:
virtual property bool IsAxisExist {
    bool get () override;
}
abstract IsAxisExist : bool with get
override IsAxisExist : bool with get

Property Value

Type: Boolean
See Also

Reference

PieChart Class


PieChart.MaxSeriesCount Property

PieChartMaxSeriesCount Property

[Missing <summary> documentation for "P:Novacode.PieChart.MaxSeriesCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override short MaxSeriesCount { get; }
Public Overrides ReadOnly Property MaxSeriesCount As Short
    Get
public:
virtual property short MaxSeriesCount {
    short get () override;
}
abstract MaxSeriesCount : int16 with get
override MaxSeriesCount : int16 with get

Property Value

Type: Int16
See Also

Reference

PieChart Class


PieChart Methods

PieChart Methods

The PieChart type exposes the following members.

Methods
 | Name | Description
Public method | AddLegend | (Inherited from Chart.)
Public method | AddLegend(ChartLegendPosition, Boolean) | (Inherited from Chart.)
Public method | AddSeries | (Inherited from Chart.)
Protected method | CreateChartXml | (Overrides ChartCreateChartXml.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveLegend | (Inherited from Chart.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PieChart Class


PieChart.CreateChartXml Method

PieChartCreateChartXml Method

[Missing <summary> documentation for "M:Novacode.PieChart.CreateChartXml"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
protected override XElement CreateChartXml()
Protected Overrides Function CreateChartXml As XElement
protected:
virtual XElement^ CreateChartXml() override
abstract CreateChartXml : unit -> XElement
override CreateChartXml : unit -> XElement

Return Value

Type: XElement

[Missing <returns> documentation for "M:Novacode.PieChart.CreateChartXml"]

See Also

Reference

PieChart Class


RectangleShapes Enumeration

RectangleShapes Enumeration

[Missing <summary> documentation for "T:Novacode.RectangleShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum RectangleShapes
Public Enumeration RectangleShapes
public enum class RectangleShapes
type RectangleShapes
Members
Member name | Value | Description
rect | 0 |
roundRect | 1 |
snip1Rect | 2 |
snip2SameRect | 3 |
snip2DiagRect | 4 |
snipRoundRect | 5 |
round1Rect | 6 |
round2SameRect | 7 |
round2DiagRect | 8 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Row Class

Row Class

[Missing <summary> documentation for "T:Novacode.Row"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeContainer
NovacodeRow

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Row : Container
Public Class Row
    Inherits Container
public ref class Row : public Container
type Row =
    class
        inherit Container
    end

The Row type exposes the following members.

Properties
 | Name | Description
Public property | BreakAcrossPages |
Public property | Cells |
Public property | ColumnCount |
Public property | Height |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | MinHeight |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Paragraphs | (Overrides ContainerParagraphs.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | TableHeader |
Public property | Tables | (Inherited from Container.)
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCells |
Public method | Remove |
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
Fields
 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Row Properties

Row Properties

The Row type exposes the following members.

Properties
 | Name | Description
Public property | BreakAcrossPages |
Public property | Cells |
Public property | ColumnCount |
Public property | Height |
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | MinHeight |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Paragraphs | (Overrides ContainerParagraphs.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | Sections | (Inherited from Container.)
Public property | TableHeader |
Public property | Tables | (Inherited from Container.)
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Row Class


Row.BreakAcrossPages Property

RowBreakAcrossPages Property

[Missing <summary> documentation for "P:Novacode.Row.BreakAcrossPages"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool BreakAcrossPages { get; set; }
Public Property BreakAcrossPages As Boolean
    Get
    Set
public:
property bool BreakAcrossPages {
    bool get ();
    void set (bool value);
}
member BreakAcrossPages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Row Class


Row.Cells Property

RowCells Property

[Missing <summary> documentation for "P:Novacode.Row.Cells"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Cell> Cells { get; }
Public ReadOnly Property Cells As List(Of Cell)
    Get
public:
property List<Cell^>^ Cells {
    List<Cell^>^ get ();
}
member Cells : List<Cell> with get

Property Value

Type: List Cell
See Also

Reference

Row Class


Row.ColumnCount Property

RowColumnCount Property

[Missing <summary> documentation for "P:Novacode.Row.ColumnCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int ColumnCount { get; }
Public ReadOnly Property ColumnCount As Integer
    Get
public:
property int ColumnCount {
    int get ();
}
member ColumnCount : int with get

Property Value

Type: Int32
See Also

Reference

Row Class


Row.Height Property

RowHeight Property

[Missing <summary> documentation for "P:Novacode.Row.Height"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}
member Height : float with get, set

Property Value

Type: Double
See Also

Reference

Row Class


Row.MinHeight Property

RowMinHeight Property

[Missing <summary> documentation for "P:Novacode.Row.MinHeight"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public double MinHeight { get; set; }
Public Property MinHeight As Double
    Get
    Set
public:
property double MinHeight {
    double get ();
    void set (double value);
}
member MinHeight : float with get, set

Property Value

Type: Double
See Also

Reference

Row Class


Row.Paragraphs Property

RowParagraphs Property

[Missing <summary> documentation for "P:Novacode.Row.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override ReadOnlyCollection<Paragraph> Paragraphs { get; }
Public Overrides ReadOnly Property Paragraphs As ReadOnlyCollection(Of Paragraph)
    Get
public:
virtual property ReadOnlyCollection<Paragraph^>^ Paragraphs {
    ReadOnlyCollection<Paragraph^>^ get () override;
}
abstract Paragraphs : ReadOnlyCollection<Paragraph> with get
override Paragraphs : ReadOnlyCollection<Paragraph> with get

Property Value

Type: ReadOnlyCollection Paragraph
See Also

Reference

Row Class


Row.TableHeader Property

RowTableHeader Property

[Missing <summary> documentation for "P:Novacode.Row.TableHeader"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool TableHeader { get; set; }
Public Property TableHeader As Boolean
    Get
    Set
public:
property bool TableHeader {
    bool get ();
    void set (bool value);
}
member TableHeader : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Row Class


Row Methods

Row Methods

The Row type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCells |
Public method | Remove |
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
See Also

Reference

Row Class


Row.MergeCells Method

RowMergeCells Method

[Missing <summary> documentation for "M:Novacode.Row.MergeCells(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void MergeCells(
    int startIndex,
    int endIndex
)
Public Sub MergeCells (
    startIndex As Integer,
    endIndex As Integer
)
public:
void MergeCells(
    int startIndex,
    int endIndex
)
member MergeCells :
        startIndex : int *
        endIndex : int -> unit

Parameters

startIndex
Type: SystemInt32

[Missing <param name="startIndex"/> documentation for "M:Novacode.Row.MergeCells(System.Int32,System.Int32)"]

endIndex
Type: SystemInt32

[Missing <param name="endIndex"/> documentation for "M:Novacode.Row.MergeCells(System.Int32,System.Int32)"]

See Also

Reference

Row Class


Row.Remove Method

RowRemove Method

[Missing <summary> documentation for "M:Novacode.Row.Remove"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

Row Class


Row Fields

Row Fields

The Row type exposes the following members.

Fields
 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Top
See Also

Reference

Row Class


Run Class

Run Class

[Missing <summary> documentation for "T:Novacode.Run"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeRun

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Run : DocXElement
Public Class Run
    Inherits DocXElement
public ref class Run : public DocXElement
type Run =
    class
        inherit DocXElement
    end

The Run type exposes the following members.

Properties
 | Name | Description
Public property | EndIndex |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | StartIndex |
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Run Properties

Run Properties

The Run type exposes the following members.

Properties
 | Name | Description
Public property | EndIndex |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | StartIndex |
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Run Class


Run.EndIndex Property

RunEndIndex Property

[Missing <summary> documentation for "P:Novacode.Run.EndIndex"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int EndIndex { get; }
Public ReadOnly Property EndIndex As Integer
    Get
public:
property int EndIndex {
    int get ();
}
member EndIndex : int with get

Property Value

Type: Int32
See Also

Reference

Run Class


Run.StartIndex Property

RunStartIndex Property

[Missing <summary> documentation for "P:Novacode.Run.StartIndex"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int StartIndex { get; }
Public ReadOnly Property StartIndex As Integer
    Get
public:
property int StartIndex {
    int get ();
}
member StartIndex : int with get

Property Value

Type: Int32
See Also

Reference

Run Class


Run Methods

Run Methods

The Run type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Run Class


RunTextType Enumeration

RunTextType Enumeration

[Missing <summary> documentation for "T:Novacode.RunTextType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum RunTextType
Public Enumeration RunTextType
public enum class RunTextType
type RunTextType
Members
Member name | Value | Description
Text | 0 |
DelText | 1 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Script Enumeration

Script Enumeration

[Missing <summary> documentation for "T:Novacode.Script"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum Script
Public Enumeration Script
public enum class Script
type Script
Members
Member name | Value | Description
superscript | 0 |
subscript | 1 |
none | 2 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Section Class

Section Class

[Missing <summary> documentation for "T:Novacode.Section"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeContainer
NovacodeSection

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Section : Container
Public Class Section
    Inherits Container
public ref class Section : public Container
type Section =
    class
        inherit Container
    end

The Section type exposes the following members.

Properties
 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Paragraphs | (Inherited from Container.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | SectionParagraphs |
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Inherited from Container.)
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
Fields
 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Public field | SectionBreakType |
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Section Properties

Section Properties

The Section type exposes the following members.

Properties
 | Name | Description
Public property | Hyperlinks | (Inherited from Container.)
Public property | Lists | (Inherited from Container.)
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Paragraphs | (Inherited from Container.)
Public property | ParagraphsDeepSearch | (Inherited from Container.)
Public property | Pictures | (Inherited from Container.)
Public property | SectionParagraphs |
Public property | Sections | (Inherited from Container.)
Public property | Tables | (Inherited from Container.)
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Section Class


Section.SectionParagraphs Property

SectionSectionParagraphs Property

[Missing <summary> documentation for "P:Novacode.Section.SectionParagraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Paragraph> SectionParagraphs { get; set; }
Public Property SectionParagraphs As List(Of Paragraph)
    Get
    Set
public:
property List<Paragraph^>^ SectionParagraphs {
    List<Paragraph^>^ get ();
    void set (List<Paragraph^>^ value);
}
member SectionParagraphs : List<Paragraph> with get, set

Property Value

Type: List Paragraph
See Also

Reference

Section Class


Section Methods

Section Methods

The Section type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindAll(String) | (Inherited from Container.)
Public method | FindAll(String, RegexOptions) | (Inherited from Container.)
Public method | FindUniqueByPattern | (Inherited from Container.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertAtBookmark | (Inherited from Container.)
Public method | InsertBookmark | (Inherited from Container.)
Public method | InsertEquation | (Inherited from Container.)
Public method | InsertList(List) | (Inherited from Container.)
Public method | InsertList(Int32, List) | (Inherited from Container.)
Public method | InsertList(List, Double) | (Inherited from Container.)
Public method | InsertList(List, FontFamily, Double) | (Inherited from Container.)
Public method | InsertParagraph | (Inherited from Container.)
Public method | InsertParagraph(String) | (Inherited from Container.)
Public method | InsertParagraph(Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(Int32, Paragraph) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean) | (Inherited from Container.)
Public method | InsertParagraph(String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertParagraph(Int32, String, Boolean, Formatting) | (Inherited from Container.)
Public method | InsertSection | (Inherited from Container.)
Public method | InsertSection(Boolean) | (Inherited from Container.)
Public method | InsertSectionPageBreak | (Inherited from Container.)
Public method | InsertTable(Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Table) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32) | (Inherited from Container.)
Public method | InsertTable(Int32, Int32, Int32) | (Inherited from Container.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParagraph | (Inherited from Container.)
Public method | RemoveParagraphAt | (Inherited from Container.)
Public method | RemoveTextInGivenFormat | (Inherited from Container.)
Public method | ReplaceText(String, FuncString, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | ReplaceText(String, String, Boolean, RegexOptions, Formatting, Formatting, MatchFormattingOptions) | (Inherited from Container.)
Public method | SetDirection | (Inherited from Container.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateBookmarks | (Inherited from Container.)
Top
See Also

Reference

Section Class


Section Fields

Section Fields

The Section type exposes the following members.

Fields
 | Name | Description
Public field | ParentContainer | (Inherited from Container.)
Public field | SectionBreakType |
Top
See Also

Reference

Section Class


Section.SectionBreakType Field

SectionSectionBreakType Field

[Missing <summary> documentation for "F:Novacode.Section.SectionBreakType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public SectionBreakType SectionBreakType
Public SectionBreakType As SectionBreakType
public:
SectionBreakType SectionBreakType
val mutable SectionBreakType: SectionBreakType

Field Value

Type: SectionBreakType
See Also

Reference

Section Class


SectionBreakType Enumeration

SectionBreakType Enumeration

[Missing <summary> documentation for "T:Novacode.SectionBreakType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum SectionBreakType
Public Enumeration SectionBreakType
public enum class SectionBreakType
type SectionBreakType
Members
Member name | Value | Description
defaultNextPage | 0 |
evenPage | 1 |
oddPage | 2 |
continuous | 3 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Series Class

Series Class

[Missing <summary> documentation for "T:Novacode.Series"]

Inheritance Hierarchy
SystemObject
NovacodeSeries

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Series
Public Class Series
public ref class Series
type Series =  class end

The Series type exposes the following members.

Constructors
 | Name | Description
Public method | Series | Initializes a new instance of the Series class
Top
Properties
 | Name | Description
Public property | Color |
Top
Methods
 | Name | Description
Public method | Bind(IList, IList) |
Public method | Bind(ICollection, String, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Series Constructor

Series Constructor
Initializes a new instance of the Series class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Series(
    string name
)
Public Sub New (
    name As String
)
public:
Series(
    String^ name
)
new :
        name : string -> Series

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Novacode.Series.#ctor(System.String)"]

See Also

Reference

Series Class


Series Properties

Series Properties

The Series type exposes the following members.

Properties
 | Name | Description
Public property | Color |
Top
See Also

Reference

Series Class


Series.Color Property

SeriesColor Property

[Missing <summary> documentation for "P:Novacode.Series.Color"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color Color {
    Color get ();
    void set (Color value);
}
member Color : Color with get, set

Property Value

Type: Color
See Also

Reference

Series Class


Series Methods

Series Methods

The Series type exposes the following members.

Methods
 | Name | Description
Public method | Bind(IList, IList) |
Public method | Bind(ICollection, String, String) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Series Class


Series.Bind Method

SeriesBind Method
Overload List
 | Name | Description
Public method | Bind(IList, IList) |
Public method | Bind(ICollection, String, String) |
Top
See Also

Reference

Series Class


Series.Bind Method (IList, IList)

SeriesBind Method (IList, IList)

[Missing <summary> documentation for "M:Novacode.Series.Bind(System.Collections.IList,System.Collections.IList)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void Bind(
    IList categories,
    IList values
)
Public Sub Bind (
    categories As IList,
    values As IList
)
public:
void Bind(
    IList^ categories,
    IList^ values
)
member Bind :
        categories : IList *
        values : IList -> unit

Parameters

categories
Type: System.CollectionsIList

[Missing <param name="categories"/> documentation for "M:Novacode.Series.Bind(System.Collections.IList,System.Collections.IList)"]

values
Type: System.CollectionsIList

[Missing <param name="values"/> documentation for "M:Novacode.Series.Bind(System.Collections.IList,System.Collections.IList)"]

See Also

Reference

Series Class
Bind Overload


Series.Bind Method (ICollection, String, String)

SeriesBind Method (ICollection, String, String)

[Missing <summary> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void Bind(
    ICollection list,
    string categoryPropertyName,
    string valuePropertyName
)
Public Sub Bind (
    list As ICollection,
    categoryPropertyName As String,
    valuePropertyName As String
)
public:
void Bind(
    ICollection^ list,
    String^ categoryPropertyName,
    String^ valuePropertyName
)
member Bind :
        list : ICollection *
        categoryPropertyName : string *
        valuePropertyName : string -> unit

Parameters

list
Type: System.CollectionsICollection

[Missing <param name="list"/> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

categoryPropertyName
Type: SystemString

[Missing <param name="categoryPropertyName"/> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

valuePropertyName
Type: SystemString

[Missing <param name="valuePropertyName"/> documentation for "M:Novacode.Series.Bind(System.Collections.ICollection,System.String,System.String)"]

See Also

Reference

Series Class
Bind Overload


StarAndBannerShapes Enumeration

StarAndBannerShapes Enumeration

[Missing <summary> documentation for "T:Novacode.StarAndBannerShapes"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum StarAndBannerShapes
Public Enumeration StarAndBannerShapes
public enum class StarAndBannerShapes
type StarAndBannerShapes
Members
Member name | Value | Description
irregularSeal1 | 0 |
irregularSeal2 | 1 |
star4 | 2 |
star5 | 3 |
star6 | 4 |
star7 | 5 |
star8 | 6 |
star10 | 7 |
star12 | 8 |
star16 | 9 |
star24 | 10 |
star32 | 11 |
ribbon | 12 |
ribbon2 | 13 |
ellipseRibbon | 14 |
ellipseRibbon2 | 15 |
verticalScroll | 16 |
horizontalScroll | 17 |
wave | 18 |
doubleWave | 19 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


StrikeThrough Enumeration

StrikeThrough Enumeration

[Missing <summary> documentation for "T:Novacode.StrikeThrough"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum StrikeThrough
Public Enumeration StrikeThrough
public enum class StrikeThrough
type StrikeThrough
Members
Member name | Value | Description
none | 0 |
strike | 1 |
doubleStrike | 2 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Table Class

Table Class

[Missing <summary> documentation for "T:Novacode.Table"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeInsertBeforeOrAfter
NovacodeTable

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class Table : InsertBeforeOrAfter
Public Class Table
    Inherits InsertBeforeOrAfter
public ref class Table : public InsertBeforeOrAfter
type Table =
    class
        inherit InsertBeforeOrAfter
    end

The Table type exposes the following members.

Properties
 | Name | Description
Public property | Alignment |
Public property | AutoFit |
Public property | ColumnCount |
Public property | ColumnWidths |
Public property | CustomTableDesignName |
Public property | Design |
Public property | Hyperlinks |
Public property | Index |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Paragraphs |
Public property | Pictures |
Public property | RowCount |
Public property | Rows |
Public property | TableCaption |
Public property | TableDescription |
Public property | TableLook |
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBorder |
Public method | GetColumnWidth |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertColumn |
Public method | InsertColumn(Int32) |
Public method | InsertPageBreakAfterSelf | (Overrides InsertBeforeOrAfterInsertPageBreakAfterSelf.)
Public method | InsertPageBreakBeforeSelf | (Overrides InsertBeforeOrAfterInsertPageBreakBeforeSelf.)
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertRow |
Public method | InsertRow(Int32) |
Public method | InsertRow(Row) |
Public method | InsertRow(Row, Int32) |
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Int32, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCellsInColumn |
Public method | Remove |
Public method | RemoveColumn |
Public method | RemoveColumn(Int32) |
Public method | RemoveRow |
Public method | RemoveRow(Int32) |
Public method | SetBorder |
Public method | SetColumnWidth |
Public method | SetDirection |
Public method | SetWidths |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


Table Properties

Table Properties

The Table type exposes the following members.

Properties
 | Name | Description
Public property | Alignment |
Public property | AutoFit |
Public property | ColumnCount |
Public property | ColumnWidths |
Public property | CustomTableDesignName |
Public property | Design |
Public property | Hyperlinks |
Public property | Index |
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Paragraphs |
Public property | Pictures |
Public property | RowCount |
Public property | Rows |
Public property | TableCaption |
Public property | TableDescription |
Public property | TableLook |
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

Table Class


Table.Alignment Property

TableAlignment Property

[Missing <summary> documentation for "P:Novacode.Table.Alignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Alignment Alignment { get; set; }
Public Property Alignment As Alignment
    Get
    Set
public:
property Alignment Alignment {
    Alignment get ();
    void set (Alignment value);
}
member Alignment : Alignment with get, set

Property Value

Type: Alignment
See Also

Reference

Table Class


Table.AutoFit Property

TableAutoFit Property

[Missing <summary> documentation for "P:Novacode.Table.AutoFit"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public AutoFit AutoFit { get; set; }
Public Property AutoFit As AutoFit
    Get
    Set
public:
property AutoFit AutoFit {
    AutoFit get ();
    void set (AutoFit value);
}
member AutoFit : AutoFit with get, set

Property Value

Type: AutoFit
See Also

Reference

Table Class


Table.ColumnCount Property

TableColumnCount Property

[Missing <summary> documentation for "P:Novacode.Table.ColumnCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int ColumnCount { get; }
Public ReadOnly Property ColumnCount As Integer
    Get
public:
property int ColumnCount {
    int get ();
}
member ColumnCount : int with get

Property Value

Type: Int32
See Also

Reference

Table Class


Table.ColumnWidths Property

TableColumnWidths Property

[Missing <summary> documentation for "P:Novacode.Table.ColumnWidths"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<double> ColumnWidths { get; }
Public ReadOnly Property ColumnWidths As List(Of Double)
    Get
public:
property List<double>^ ColumnWidths {
    List<double>^ get ();
}
member ColumnWidths : List<float> with get

Property Value

Type: List Double
See Also

Reference

Table Class


Table.CustomTableDesignName Property

TableCustomTableDesignName Property

[Missing <summary> documentation for "P:Novacode.Table.CustomTableDesignName"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string CustomTableDesignName { get; set; }
Public Property CustomTableDesignName As String
    Get
    Set
public:
property String^ CustomTableDesignName {
    String^ get ();
    void set (String^ value);
}
member CustomTableDesignName : string with get, set

Property Value

Type: String
See Also

Reference

Table Class


Table.Design Property

TableDesign Property

[Missing <summary> documentation for "P:Novacode.Table.Design"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public TableDesign Design { get; set; }
Public Property Design As TableDesign
    Get
    Set
public:
property TableDesign Design {
    TableDesign get ();
    void set (TableDesign value);
}
member Design : TableDesign with get, set

Property Value

Type: TableDesign
See Also

Reference

Table Class


Table.Hyperlinks Property

TableHyperlinks Property

[Missing <summary> documentation for "P:Novacode.Table.Hyperlinks"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Hyperlink> Hyperlinks { get; }
Public ReadOnly Property Hyperlinks As List(Of Hyperlink)
    Get
public:
property List<Hyperlink^>^ Hyperlinks {
    List<Hyperlink^>^ get ();
}
member Hyperlinks : List<Hyperlink> with get

Property Value

Type: List Hyperlink
See Also

Reference

Table Class


Table.Index Property

TableIndex Property

[Missing <summary> documentation for "P:Novacode.Table.Index"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
See Also

Reference

Table Class


Table.Paragraphs Property

TableParagraphs Property

[Missing <summary> documentation for "P:Novacode.Table.Paragraphs"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public virtual List<Paragraph> Paragraphs { get; }
Public Overridable ReadOnly Property Paragraphs As List(Of Paragraph)
    Get
public:
virtual property List<Paragraph^>^ Paragraphs {
    List<Paragraph^>^ get ();
}
abstract Paragraphs : List<Paragraph> with get
override Paragraphs : List<Paragraph> with get

Property Value

Type: List Paragraph
See Also

Reference

Table Class


Table.Pictures Property

TablePictures Property

[Missing <summary> documentation for "P:Novacode.Table.Pictures"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Picture> Pictures { get; }
Public ReadOnly Property Pictures As List(Of Picture)
    Get
public:
property List<Picture^>^ Pictures {
    List<Picture^>^ get ();
}
member Pictures : List<Picture> with get

Property Value

Type: List Picture
See Also

Reference

Table Class


Table.RowCount Property

TableRowCount Property

[Missing <summary> documentation for "P:Novacode.Table.RowCount"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public int RowCount { get; }
Public ReadOnly Property RowCount As Integer
    Get
public:
property int RowCount {
    int get ();
}
member RowCount : int with get

Property Value

Type: Int32
See Also

Reference

Table Class


Table.Rows Property

TableRows Property

[Missing <summary> documentation for "P:Novacode.Table.Rows"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public List<Row> Rows { get; }
Public ReadOnly Property Rows As List(Of Row)
    Get
public:
property List<Row^>^ Rows {
    List<Row^>^ get ();
}
member Rows : List<Row> with get

Property Value

Type: List Row
See Also

Reference

Table Class


Table.TableCaption Property

TableTableCaption Property

[Missing <summary> documentation for "P:Novacode.Table.TableCaption"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string TableCaption { get; set; }
Public Property TableCaption As String
    Get
    Set
public:
property String^ TableCaption {
    String^ get ();
    void set (String^ value);
}
member TableCaption : string with get, set

Property Value

Type: String
See Also

Reference

Table Class


Table.TableDescription Property

TableTableDescription Property

[Missing <summary> documentation for "P:Novacode.Table.TableDescription"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public string TableDescription { get; set; }
Public Property TableDescription As String
    Get
    Set
public:
property String^ TableDescription {
    String^ get ();
    void set (String^ value);
}
member TableDescription : string with get, set

Property Value

Type: String
See Also

Reference

Table Class


Table.TableLook Property

TableTableLook Property

[Missing <summary> documentation for "P:Novacode.Table.TableLook"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public TableLook TableLook { get; set; }
Public Property TableLook As TableLook
    Get
    Set
public:
property TableLook^ TableLook {
    TableLook^ get ();
    void set (TableLook^ value);
}
member TableLook : TableLook with get, set

Property Value

Type: TableLook
See Also

Reference

Table Class


Table Methods

Table Methods

The Table type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBorder |
Public method | GetColumnWidth |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InsertColumn |
Public method | InsertColumn(Int32) |
Public method | InsertPageBreakAfterSelf | (Overrides InsertBeforeOrAfterInsertPageBreakAfterSelf.)
Public method | InsertPageBreakBeforeSelf | (Overrides InsertBeforeOrAfterInsertPageBreakBeforeSelf.)
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean, Formatting).)
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean, Formatting).)
Public method | InsertRow |
Public method | InsertRow(Int32) |
Public method | InsertRow(Row) |
Public method | InsertRow(Row, Int32) |
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Int32, Int32).)
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Int32, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeCellsInColumn |
Public method | Remove |
Public method | RemoveColumn |
Public method | RemoveColumn(Int32) |
Public method | RemoveRow |
Public method | RemoveRow(Int32) |
Public method | SetBorder |
Public method | SetColumnWidth |
Public method | SetDirection |
Public method | SetWidths |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Table Class


Table.GetBorder Method

TableGetBorder Method

[Missing <summary> documentation for "M:Novacode.Table.GetBorder(Novacode.TableBorderType)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Border GetBorder(
    TableBorderType borderType
)
Public Function GetBorder (
    borderType As TableBorderType
) As Border
public:
Border^ GetBorder(
    TableBorderType borderType
)
member GetBorder :
        borderType : TableBorderType -> Border

Parameters

borderType
Type: NovacodeTableBorderType

[Missing <param name="borderType"/> documentation for "M:Novacode.Table.GetBorder(Novacode.TableBorderType)"]

Return Value

Type: Border

[Missing <returns> documentation for "M:Novacode.Table.GetBorder(Novacode.TableBorderType)"]

See Also

Reference

Table Class


Table.GetColumnWidth Method

TableGetColumnWidth Method

[Missing <summary> documentation for "M:Novacode.Table.GetColumnWidth(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public double GetColumnWidth(
    int index
)
Public Function GetColumnWidth (
    index As Integer
) As Double
public:
double GetColumnWidth(
    int index
)
member GetColumnWidth :
        index : int -> float

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Table.GetColumnWidth(System.Int32)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Novacode.Table.GetColumnWidth(System.Int32)"]

See Also

Reference

Table Class


Table.InsertColumn Method

TableInsertColumn Method
Overload List
 | Name | Description
Public method | InsertColumn |
Public method | InsertColumn(Int32) |
Top
See Also

Reference

Table Class


Table.InsertColumn Method

TableInsertColumn Method

[Missing <summary> documentation for "M:Novacode.Table.InsertColumn"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void InsertColumn()
Public Sub InsertColumn
public:
void InsertColumn()
member InsertColumn : unit -> unit
See Also

Reference

Table Class
InsertColumn Overload


Table.InsertColumn Method (Int32)

TableInsertColumn Method (Int32)

[Missing <summary> documentation for "M:Novacode.Table.InsertColumn(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void InsertColumn(
    int index
)
Public Sub InsertColumn (
    index As Integer
)
public:
void InsertColumn(
    int index
)
member InsertColumn :
        index : int -> unit

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Table.InsertColumn(System.Int32)"]

See Also

Reference

Table Class
InsertColumn Overload


Table.InsertPageBreakAfterSelf Method

TableInsertPageBreakAfterSelf Method

[Missing <summary> documentation for "M:Novacode.Table.InsertPageBreakAfterSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override void InsertPageBreakAfterSelf()
Public Overrides Sub InsertPageBreakAfterSelf
public:
virtual void InsertPageBreakAfterSelf() override
abstract InsertPageBreakAfterSelf : unit -> unit
override InsertPageBreakAfterSelf : unit -> unit
See Also

Reference

Table Class


Table.InsertPageBreakBeforeSelf Method

TableInsertPageBreakBeforeSelf Method

[Missing <summary> documentation for "M:Novacode.Table.InsertPageBreakBeforeSelf"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override void InsertPageBreakBeforeSelf()
Public Overrides Sub InsertPageBreakBeforeSelf
public:
virtual void InsertPageBreakBeforeSelf() override
abstract InsertPageBreakBeforeSelf : unit -> unit
override InsertPageBreakBeforeSelf : unit -> unit
See Also

Reference

Table Class


Table.InsertParagraphAfterSelf Method

TableInsertParagraphAfterSelf Method
Overload List
 | Name | Description
Public method | InsertParagraphAfterSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String).)
Public method | InsertParagraphAfterSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(Paragraph).)
Public method | InsertParagraphAfterSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean).)
Public method | InsertParagraphAfterSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphAfterSelf(String, Boolean, Formatting).)
Top
See Also

Reference

Table Class


Table.InsertParagraphAfterSelf Method (String)

TableInsertParagraphAfterSelf Method (String)

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphAfterSelf(
    string text
)
Public Overrides Function InsertParagraphAfterSelf (
    text As String
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text
) override
abstract InsertParagraphAfterSelf :
        text : string -> Paragraph
override InsertParagraphAfterSelf :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String)"]

See Also

Reference

Table Class
InsertParagraphAfterSelf Overload


Table.InsertParagraphAfterSelf Method (Paragraph)

TableInsertParagraphAfterSelf Method (Paragraph)

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphAfterSelf(
    Paragraph p
)
Public Overrides Function InsertParagraphAfterSelf (
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    Paragraph^ p
) override
abstract InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph
override InsertParagraphAfterSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(Novacode.Paragraph)"]

See Also

Reference

Table Class
InsertParagraphAfterSelf Overload


Table.InsertParagraphAfterSelf Method (String, Boolean)

TableInsertParagraphAfterSelf Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges
)
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges
) override
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean)"]

See Also

Reference

Table Class
InsertParagraphAfterSelf Overload


Table.InsertParagraphAfterSelf Method (String, Boolean, Formatting)

TableInsertParagraphAfterSelf Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphAfterSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overrides Function InsertParagraphAfterSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraphAfterSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
abstract InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphAfterSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphAfterSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Table Class
InsertParagraphAfterSelf Overload


Table.InsertParagraphBeforeSelf Method

TableInsertParagraphBeforeSelf Method
Overload List
 | Name | Description
Public method | InsertParagraphBeforeSelf(String) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String).)
Public method | InsertParagraphBeforeSelf(Paragraph) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(Paragraph).)
Public method | InsertParagraphBeforeSelf(String, Boolean) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean).)
Public method | InsertParagraphBeforeSelf(String, Boolean, Formatting) | (Overrides InsertBeforeOrAfterInsertParagraphBeforeSelf(String, Boolean, Formatting).)
Top
See Also

Reference

Table Class


Table.InsertParagraphBeforeSelf Method (String)

TableInsertParagraphBeforeSelf Method (String)

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphBeforeSelf(
    string text
)
Public Overrides Function InsertParagraphBeforeSelf (
    text As String
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text
) override
abstract InsertParagraphBeforeSelf :
        text : string -> Paragraph
override InsertParagraphBeforeSelf :
        text : string -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String)"]

See Also

Reference

Table Class
InsertParagraphBeforeSelf Overload


Table.InsertParagraphBeforeSelf Method (Paragraph)

TableInsertParagraphBeforeSelf Method (Paragraph)

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphBeforeSelf(
    Paragraph p
)
Public Overrides Function InsertParagraphBeforeSelf (
    p As Paragraph
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    Paragraph^ p
) override
abstract InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph
override InsertParagraphBeforeSelf :
        p : Paragraph -> Paragraph

Parameters

p
Type: NovacodeParagraph

[Missing <param name="p"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(Novacode.Paragraph)"]

See Also

Reference

Table Class
InsertParagraphBeforeSelf Overload


Table.InsertParagraphBeforeSelf Method (String, Boolean)

TableInsertParagraphBeforeSelf Method (String, Boolean)

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges
)
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges
) override
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean)"]

See Also

Reference

Table Class
InsertParagraphBeforeSelf Overload


Table.InsertParagraphBeforeSelf Method (String, Boolean, Formatting)

TableInsertParagraphBeforeSelf Method (String, Boolean, Formatting)

[Missing <summary> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Paragraph InsertParagraphBeforeSelf(
    string text,
    bool trackChanges,
    Formatting formatting
)
Public Overrides Function InsertParagraphBeforeSelf (
    text As String,
    trackChanges As Boolean,
    formatting As Formatting
) As Paragraph
public:
virtual Paragraph^ InsertParagraphBeforeSelf(
    String^ text,
    bool trackChanges,
    Formatting^ formatting
) override
abstract InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph
override InsertParagraphBeforeSelf :
        text : string *
        trackChanges : bool *
        formatting : Formatting -> Paragraph

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

trackChanges
Type: SystemBoolean

[Missing <param name="trackChanges"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

formatting
Type: NovacodeFormatting

[Missing <param name="formatting"/> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

Return Value

Type: Paragraph

[Missing <returns> documentation for "M:Novacode.Table.InsertParagraphBeforeSelf(System.String,System.Boolean,Novacode.Formatting)"]

See Also

Reference

Table Class
InsertParagraphBeforeSelf Overload


Table.InsertRow Method

TableInsertRow Method
Overload List
 | Name | Description
Public method | InsertRow |
Public method | InsertRow(Int32) |
Public method | InsertRow(Row) |
Public method | InsertRow(Row, Int32) |
Top
See Also

Reference

Table Class


Table.InsertRow Method

TableInsertRow Method

[Missing <summary> documentation for "M:Novacode.Table.InsertRow"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Row InsertRow()
Public Function InsertRow As Row
public:
Row^ InsertRow()
member InsertRow : unit -> Row

Return Value

Type: Row

[Missing <returns> documentation for "M:Novacode.Table.InsertRow"]

See Also

Reference

Table Class
InsertRow Overload


Table.InsertRow Method (Int32)

TableInsertRow Method (Int32)

[Missing <summary> documentation for "M:Novacode.Table.InsertRow(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Row InsertRow(
    int index
)
Public Function InsertRow (
    index As Integer
) As Row
public:
Row^ InsertRow(
    int index
)
member InsertRow :
        index : int -> Row

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Table.InsertRow(System.Int32)"]

Return Value

Type: Row

[Missing <returns> documentation for "M:Novacode.Table.InsertRow(System.Int32)"]

See Also

Reference

Table Class
InsertRow Overload


Table.InsertRow Method (Row)

TableInsertRow Method (Row)

[Missing <summary> documentation for "M:Novacode.Table.InsertRow(Novacode.Row)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Row InsertRow(
    Row row
)
Public Function InsertRow (
    row As Row
) As Row
public:
Row^ InsertRow(
    Row^ row
)
member InsertRow :
        row : Row -> Row

Parameters

row
Type: NovacodeRow

[Missing <param name="row"/> documentation for "M:Novacode.Table.InsertRow(Novacode.Row)"]

Return Value

Type: Row

[Missing <returns> documentation for "M:Novacode.Table.InsertRow(Novacode.Row)"]

See Also

Reference

Table Class
InsertRow Overload


Table.InsertRow Method (Row, Int32)

TableInsertRow Method (Row, Int32)

[Missing <summary> documentation for "M:Novacode.Table.InsertRow(Novacode.Row,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public Row InsertRow(
    Row row,
    int index
)
Public Function InsertRow (
    row As Row,
    index As Integer
) As Row
public:
Row^ InsertRow(
    Row^ row,
    int index
)
member InsertRow :
        row : Row *
        index : int -> Row

Parameters

row
Type: NovacodeRow

[Missing <param name="row"/> documentation for "M:Novacode.Table.InsertRow(Novacode.Row,System.Int32)"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Table.InsertRow(Novacode.Row,System.Int32)"]

Return Value

Type: Row

[Missing <returns> documentation for "M:Novacode.Table.InsertRow(Novacode.Row,System.Int32)"]

See Also

Reference

Table Class
InsertRow Overload


Table.InsertTableAfterSelf Method

TableInsertTableAfterSelf Method
Overload List
 | Name | Description
Public method | InsertTableAfterSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Table).)
Public method | InsertTableAfterSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableAfterSelf(Int32, Int32).)
Top
See Also

Reference

Table Class


Table.InsertTableAfterSelf Method (Table)

TableInsertTableAfterSelf Method (Table)

[Missing <summary> documentation for "M:Novacode.Table.InsertTableAfterSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Table InsertTableAfterSelf(
    Table t
)
Public Overrides Function InsertTableAfterSelf (
    t As Table
) As Table
public:
virtual Table^ InsertTableAfterSelf(
    Table^ t
) override
abstract InsertTableAfterSelf :
        t : Table -> Table
override InsertTableAfterSelf :
        t : Table -> Table

Parameters

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.Table.InsertTableAfterSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Table.InsertTableAfterSelf(Novacode.Table)"]

See Also

Reference

Table Class
InsertTableAfterSelf Overload


Table.InsertTableAfterSelf Method (Int32, Int32)

TableInsertTableAfterSelf Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Table.InsertTableAfterSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Table InsertTableAfterSelf(
    int rowCount,
    int columnCount
)
Public Overrides Function InsertTableAfterSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
virtual Table^ InsertTableAfterSelf(
    int rowCount,
    int columnCount
) override
abstract InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableAfterSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Table.InsertTableAfterSelf(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Table.InsertTableAfterSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Table.InsertTableAfterSelf(System.Int32,System.Int32)"]

See Also

Reference

Table Class
InsertTableAfterSelf Overload


Table.InsertTableBeforeSelf Method

TableInsertTableBeforeSelf Method
Overload List
 | Name | Description
Public method | InsertTableBeforeSelf(Table) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Table).)
Public method | InsertTableBeforeSelf(Int32, Int32) | (Overrides InsertBeforeOrAfterInsertTableBeforeSelf(Int32, Int32).)
Top
See Also

Reference

Table Class


Table.InsertTableBeforeSelf Method (Table)

TableInsertTableBeforeSelf Method (Table)

[Missing <summary> documentation for "M:Novacode.Table.InsertTableBeforeSelf(Novacode.Table)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Table InsertTableBeforeSelf(
    Table t
)
Public Overrides Function InsertTableBeforeSelf (
    t As Table
) As Table
public:
virtual Table^ InsertTableBeforeSelf(
    Table^ t
) override
abstract InsertTableBeforeSelf :
        t : Table -> Table
override InsertTableBeforeSelf :
        t : Table -> Table

Parameters

t
Type: NovacodeTable

[Missing <param name="t"/> documentation for "M:Novacode.Table.InsertTableBeforeSelf(Novacode.Table)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Table.InsertTableBeforeSelf(Novacode.Table)"]

See Also

Reference

Table Class
InsertTableBeforeSelf Overload


Table.InsertTableBeforeSelf Method (Int32, Int32)

TableInsertTableBeforeSelf Method (Int32, Int32)

[Missing <summary> documentation for "M:Novacode.Table.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public override Table InsertTableBeforeSelf(
    int rowCount,
    int columnCount
)
Public Overrides Function InsertTableBeforeSelf (
    rowCount As Integer,
    columnCount As Integer
) As Table
public:
virtual Table^ InsertTableBeforeSelf(
    int rowCount,
    int columnCount
) override
abstract InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table
override InsertTableBeforeSelf :
        rowCount : int *
        columnCount : int -> Table

Parameters

rowCount
Type: SystemInt32

[Missing <param name="rowCount"/> documentation for "M:Novacode.Table.InsertTableBeforeSelf(System.Int32,System.Int32)"]

columnCount
Type: SystemInt32

[Missing <param name="columnCount"/> documentation for "M:Novacode.Table.InsertTableBeforeSelf(System.Int32,System.Int32)"]

Return Value

Type: Table

[Missing <returns> documentation for "M:Novacode.Table.InsertTableBeforeSelf(System.Int32,System.Int32)"]

See Also

Reference

Table Class
InsertTableBeforeSelf Overload


Table.MergeCellsInColumn Method

TableMergeCellsInColumn Method

[Missing <summary> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void MergeCellsInColumn(
    int columnIndex,
    int startRow,
    int endRow
)
Public Sub MergeCellsInColumn (
    columnIndex As Integer,
    startRow As Integer,
    endRow As Integer
)
public:
void MergeCellsInColumn(
    int columnIndex,
    int startRow,
    int endRow
)
member MergeCellsInColumn :
        columnIndex : int *
        startRow : int *
        endRow : int -> unit

Parameters

columnIndex
Type: SystemInt32

[Missing <param name="columnIndex"/> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

startRow
Type: SystemInt32

[Missing <param name="startRow"/> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

endRow
Type: SystemInt32

[Missing <param name="endRow"/> documentation for "M:Novacode.Table.MergeCellsInColumn(System.Int32,System.Int32,System.Int32)"]

See Also

Reference

Table Class


Table.Remove Method

TableRemove Method

[Missing <summary> documentation for "M:Novacode.Table.Remove"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

Table Class


Table.RemoveColumn Method

TableRemoveColumn Method
Overload List
 | Name | Description
Public method | RemoveColumn |
Public method | RemoveColumn(Int32) |
Top
See Also

Reference

Table Class


Table.RemoveColumn Method

TableRemoveColumn Method

[Missing <summary> documentation for "M:Novacode.Table.RemoveColumn"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void RemoveColumn()
Public Sub RemoveColumn
public:
void RemoveColumn()
member RemoveColumn : unit -> unit
See Also

Reference

Table Class
RemoveColumn Overload


Table.RemoveColumn Method (Int32)

TableRemoveColumn Method (Int32)

[Missing <summary> documentation for "M:Novacode.Table.RemoveColumn(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void RemoveColumn(
    int index
)
Public Sub RemoveColumn (
    index As Integer
)
public:
void RemoveColumn(
    int index
)
member RemoveColumn :
        index : int -> unit

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Table.RemoveColumn(System.Int32)"]

See Also

Reference

Table Class
RemoveColumn Overload


Table.RemoveRow Method

TableRemoveRow Method
Overload List
 | Name | Description
Public method | RemoveRow |
Public method | RemoveRow(Int32) |
Top
See Also

Reference

Table Class


Table.RemoveRow Method

TableRemoveRow Method

[Missing <summary> documentation for "M:Novacode.Table.RemoveRow"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void RemoveRow()
Public Sub RemoveRow
public:
void RemoveRow()
member RemoveRow : unit -> unit
See Also

Reference

Table Class
RemoveRow Overload


Table.RemoveRow Method (Int32)

TableRemoveRow Method (Int32)

[Missing <summary> documentation for "M:Novacode.Table.RemoveRow(System.Int32)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void RemoveRow(
    int index
)
Public Sub RemoveRow (
    index As Integer
)
public:
void RemoveRow(
    int index
)
member RemoveRow :
        index : int -> unit

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Table.RemoveRow(System.Int32)"]

See Also

Reference

Table Class
RemoveRow Overload


Table.SetBorder Method

TableSetBorder Method

[Missing <summary> documentation for "M:Novacode.Table.SetBorder(Novacode.TableBorderType,Novacode.Border)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetBorder(
    TableBorderType borderType,
    Border border
)
Public Sub SetBorder (
    borderType As TableBorderType,
    border As Border
)
public:
void SetBorder(
    TableBorderType borderType,
    Border^ border
)
member SetBorder :
        borderType : TableBorderType *
        border : Border -> unit

Parameters

borderType
Type: NovacodeTableBorderType

[Missing <param name="borderType"/> documentation for "M:Novacode.Table.SetBorder(Novacode.TableBorderType,Novacode.Border)"]

border
Type: NovacodeBorder

[Missing <param name="border"/> documentation for "M:Novacode.Table.SetBorder(Novacode.TableBorderType,Novacode.Border)"]

See Also

Reference

Table Class


Table.SetColumnWidth Method

TableSetColumnWidth Method

[Missing <summary> documentation for "M:Novacode.Table.SetColumnWidth(System.Int32,System.Double)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetColumnWidth(
    int index,
    double width
)
Public Sub SetColumnWidth (
    index As Integer,
    width As Double
)
public:
void SetColumnWidth(
    int index,
    double width
)
member SetColumnWidth :
        index : int *
        width : float -> unit

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Novacode.Table.SetColumnWidth(System.Int32,System.Double)"]

width
Type: SystemDouble

[Missing <param name="width"/> documentation for "M:Novacode.Table.SetColumnWidth(System.Int32,System.Double)"]

See Also

Reference

Table Class


Table.SetDirection Method

TableSetDirection Method

[Missing <summary> documentation for "M:Novacode.Table.SetDirection(Novacode.Direction)"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetDirection(
    Direction direction
)
Public Sub SetDirection (
    direction As Direction
)
public:
void SetDirection(
    Direction direction
)
member SetDirection :
        direction : Direction -> unit

Parameters

direction
Type: NovacodeDirection

[Missing <param name="direction"/> documentation for "M:Novacode.Table.SetDirection(Novacode.Direction)"]

See Also

Reference

Table Class


Table.SetWidths Method

TableSetWidths Method

[Missing <summary> documentation for "M:Novacode.Table.SetWidths(System.Single[])"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public void SetWidths(
    float[] widths
)
Public Sub SetWidths (
    widths As Single()
)
public:
void SetWidths(
    array<float>^ widths
)
member SetWidths :
        widths : float32[] -> unit

Parameters

widths
Type: SystemSingle

[Missing <param name="widths"/> documentation for "M:Novacode.Table.SetWidths(System.Single[])"]

See Also

Reference

Table Class


TableBorderType Enumeration

TableBorderType Enumeration

[Missing <summary> documentation for "T:Novacode.TableBorderType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum TableBorderType
Public Enumeration TableBorderType
public enum class TableBorderType
type TableBorderType
Members
Member name | Value | Description
Top | 0 |
Bottom | 1 |
Left | 2 |
Right | 3 |
InsideH | 4 |
InsideV | 5 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


TableCellBorderType Enumeration

TableCellBorderType Enumeration

[Missing <summary> documentation for "T:Novacode.TableCellBorderType"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum TableCellBorderType
Public Enumeration TableCellBorderType
public enum class TableCellBorderType
type TableCellBorderType
Members
Member name | Value | Description
Top | 0 |
Bottom | 1 |
Left | 2 |
Right | 3 |
InsideH | 4 |
InsideV | 5 |
TopLeftToBottomRight | 6 |
TopRightToBottomLeft | 7 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


TableDesign Enumeration

TableDesign Enumeration

[Missing <summary> documentation for "T:Novacode.TableDesign"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum TableDesign
Public Enumeration TableDesign
public enum class TableDesign
type TableDesign
Members
Member name | Value | Description
Custom | 0 |
TableNormal | 1 |
TableGrid | 2 |
LightShading | 3 |
LightShadingAccent1 | 4 |
LightShadingAccent2 | 5 |
LightShadingAccent3 | 6 |
LightShadingAccent4 | 7 |
LightShadingAccent5 | 8 |
LightShadingAccent6 | 9 |
LightList | 10 |
LightListAccent1 | 11 |
LightListAccent2 | 12 |
LightListAccent3 | 13 |
LightListAccent4 | 14 |
LightListAccent5 | 15 |
LightListAccent6 | 16 |
LightGrid | 17 |
LightGridAccent1 | 18 |
LightGridAccent2 | 19 |
LightGridAccent3 | 20 |
LightGridAccent4 | 21 |
LightGridAccent5 | 22 |
LightGridAccent6 | 23 |
MediumShading1 | 24 |
MediumShading1Accent1 | 25 |
MediumShading1Accent2 | 26 |
MediumShading1Accent3 | 27 |
MediumShading1Accent4 | 28 |
MediumShading1Accent5 | 29 |
MediumShading1Accent6 | 30 |
MediumShading2 | 31 |
MediumShading2Accent1 | 32 |
MediumShading2Accent2 | 33 |
MediumShading2Accent3 | 34 |
MediumShading2Accent4 | 35 |
MediumShading2Accent5 | 36 |
MediumShading2Accent6 | 37 |
MediumList1 | 38 |
MediumList1Accent1 | 39 |
MediumList1Accent2 | 40 |
MediumList1Accent3 | 41 |
MediumList1Accent4 | 42 |
MediumList1Accent5 | 43 |
MediumList1Accent6 | 44 |
MediumList2 | 45 |
MediumList2Accent1 | 46 |
MediumList2Accent2 | 47 |
MediumList2Accent3 | 48 |
MediumList2Accent4 | 49 |
MediumList2Accent5 | 50 |
MediumList2Accent6 | 51 |
MediumGrid1 | 52 |
MediumGrid1Accent1 | 53 |
MediumGrid1Accent2 | 54 |
MediumGrid1Accent3 | 55 |
MediumGrid1Accent4 | 56 |
MediumGrid1Accent5 | 57 |
MediumGrid1Accent6 | 58 |
MediumGrid2 | 59 |
MediumGrid2Accent1 | 60 |
MediumGrid2Accent2 | 61 |
MediumGrid2Accent3 | 62 |
MediumGrid2Accent4 | 63 |
MediumGrid2Accent5 | 64 |
MediumGrid2Accent6 | 65 |
MediumGrid3 | 66 |
MediumGrid3Accent1 | 67 |
MediumGrid3Accent2 | 68 |
MediumGrid3Accent3 | 69 |
MediumGrid3Accent4 | 70 |
MediumGrid3Accent5 | 71 |
MediumGrid3Accent6 | 72 |
DarkList | 73 |
DarkListAccent1 | 74 |
DarkListAccent2 | 75 |
DarkListAccent3 | 76 |
DarkListAccent4 | 77 |
DarkListAccent5 | 78 |
DarkListAccent6 | 79 |
ColorfulShading | 80 |
ColorfulShadingAccent1 | 81 |
ColorfulShadingAccent2 | 82 |
ColorfulShadingAccent3 | 83 |
ColorfulShadingAccent4 | 84 |
ColorfulShadingAccent5 | 85 |
ColorfulShadingAccent6 | 86 |
ColorfulList | 87 |
ColorfulListAccent1 | 88 |
ColorfulListAccent2 | 89 |
ColorfulListAccent3 | 90 |
ColorfulListAccent4 | 91 |
ColorfulListAccent5 | 92 |
ColorfulListAccent6 | 93 |
ColorfulGrid | 94 |
ColorfulGridAccent1 | 95 |
ColorfulGridAccent2 | 96 |
ColorfulGridAccent3 | 97 |
ColorfulGridAccent4 | 98 |
ColorfulGridAccent5 | 99 |
ColorfulGridAccent6 | 100 |
None | 101 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


TableLook Class

TableLook Class

[Missing <summary> documentation for "T:Novacode.TableLook"]

Inheritance Hierarchy
SystemObject
NovacodeTableLook

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class TableLook
Public Class TableLook
public ref class TableLook
type TableLook =  class end

The TableLook type exposes the following members.

Constructors
 | Name | Description
Public method | TableLook | Initializes a new instance of the TableLook class
Top
Properties
 | Name | Description
Public property | FirstColumn |
Public property | FirstRow |
Public property | LastColumn |
Public property | LastRow |
Public property | NoHorizontalBanding |
Public property | NoVerticalBanding |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


TableLook Constructor

TableLook Constructor
Initializes a new instance of the TableLook class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public TableLook()
Public Sub New
public:
TableLook()
new : unit -> TableLook
See Also

Reference

TableLook Class


TableLook Properties

TableLook Properties

The TableLook type exposes the following members.

Properties
 | Name | Description
Public property | FirstColumn |
Public property | FirstRow |
Public property | LastColumn |
Public property | LastRow |
Public property | NoHorizontalBanding |
Public property | NoVerticalBanding |
Top
See Also

Reference

TableLook Class


TableLook.FirstColumn Property

TableLookFirstColumn Property

[Missing <summary> documentation for "P:Novacode.TableLook.FirstColumn"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool FirstColumn { get; set; }
Public Property FirstColumn As Boolean
    Get
    Set
public:
property bool FirstColumn {
    bool get ();
    void set (bool value);
}
member FirstColumn : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TableLook Class


TableLook.FirstRow Property

TableLookFirstRow Property

[Missing <summary> documentation for "P:Novacode.TableLook.FirstRow"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool FirstRow { get; set; }
Public Property FirstRow As Boolean
    Get
    Set
public:
property bool FirstRow {
    bool get ();
    void set (bool value);
}
member FirstRow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TableLook Class


TableLook.LastColumn Property

TableLookLastColumn Property

[Missing <summary> documentation for "P:Novacode.TableLook.LastColumn"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool LastColumn { get; set; }
Public Property LastColumn As Boolean
    Get
    Set
public:
property bool LastColumn {
    bool get ();
    void set (bool value);
}
member LastColumn : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TableLook Class


TableLook.LastRow Property

TableLookLastRow Property

[Missing <summary> documentation for "P:Novacode.TableLook.LastRow"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool LastRow { get; set; }
Public Property LastRow As Boolean
    Get
    Set
public:
property bool LastRow {
    bool get ();
    void set (bool value);
}
member LastRow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TableLook Class


TableLook.NoHorizontalBanding Property

TableLookNoHorizontalBanding Property

[Missing <summary> documentation for "P:Novacode.TableLook.NoHorizontalBanding"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool NoHorizontalBanding { get; set; }
Public Property NoHorizontalBanding As Boolean
    Get
    Set
public:
property bool NoHorizontalBanding {
    bool get ();
    void set (bool value);
}
member NoHorizontalBanding : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TableLook Class


TableLook.NoVerticalBanding Property

TableLookNoVerticalBanding Property

[Missing <summary> documentation for "P:Novacode.TableLook.NoVerticalBanding"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public bool NoVerticalBanding { get; set; }
Public Property NoVerticalBanding As Boolean
    Get
    Set
public:
property bool NoVerticalBanding {
    bool get ();
    void set (bool value);
}
member NoVerticalBanding : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TableLook Class


TableLook Methods

TableLook Methods

The TableLook type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TableLook Class


TableOfContents Class

TableOfContents Class

[Missing <summary> documentation for "T:Novacode.TableOfContents"]

Inheritance Hierarchy
SystemObject
NovacodeDocXElement
NovacodeTableOfContents

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class TableOfContents : DocXElement
Public Class TableOfContents
    Inherits DocXElement
public ref class TableOfContents : public DocXElement
type TableOfContents =
    class
        inherit DocXElement
    end

The TableOfContents type exposes the following members.

Properties
 | Name | Description
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Xml | (Inherited from DocXElement.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


TableOfContents Properties

TableOfContents Properties

The TableOfContents type exposes the following members.

Properties
 | Name | Description
Public property | PackagePart | (Inherited from DocXElement.)
Public property | Xml | (Inherited from DocXElement.)
Top
See Also

Reference

TableOfContents Class


TableOfContents Methods

TableOfContents Methods

The TableOfContents type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TableOfContents Class


TableOfContentsSwitches Enumeration

TableOfContentsSwitches Enumeration

[Missing <summary> documentation for "T:Novacode.TableOfContentsSwitches"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum TableOfContentsSwitches
<FlagsAttribute>
Public Enumeration TableOfContentsSwitches
[FlagsAttribute]
public enum class TableOfContentsSwitches
[<FlagsAttribute>]
type TableOfContentsSwitches
Members
Member name | Value | Description
None | 0 |
A | 1 |
B | 2 |
C | 4 |
D | 8 |
F | 16 |
H | 32 |
L | 64 |
N | 128 |
O | 256 |
P | 512 |
S | 1024 |
T | 2048 |
U | 4096 |
W | 8192 |
X | 16384 |
Z | 32768 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


TextDirection Enumeration

TextDirection Enumeration

[Missing <summary> documentation for "T:Novacode.TextDirection"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum TextDirection
Public Enumeration TextDirection
public enum class TextDirection
type TextDirection
Members
Member name | Value | Description
btLr | 0 |
right | 1 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


UnderlineStyle Enumeration

UnderlineStyle Enumeration

[Missing <summary> documentation for "T:Novacode.UnderlineStyle"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum UnderlineStyle
Public Enumeration UnderlineStyle
public enum class UnderlineStyle
type UnderlineStyle
Members
Member name | Value | Description
none | 0 |
singleLine | 1 |
words | 2 |
doubleLine | 3 |
dotted | 4 |
thick | 6 |
dash | 7 |
dotDash | 9 |
dotDotDash | 10 |
wave | 11 |
dottedHeavy | 20 |
dashedHeavy | 23 |
dashDotHeavy | 25 |
dashDotDotHeavy | 26 |
dashLongHeavy | 27 |
dashLong | 39 |
wavyDouble | 43 |
wavyHeavy | 55 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


ValueAxis Class

ValueAxis Class

[Missing <summary> documentation for "T:Novacode.ValueAxis"]

Inheritance Hierarchy
SystemObject
NovacodeAxis
NovacodeValueAxis

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public class ValueAxis : Axis
Public Class ValueAxis
    Inherits Axis
public ref class ValueAxis : public Axis
type ValueAxis =
    class
        inherit Axis
    end

The ValueAxis type exposes the following members.

Constructors
 | Name | Description
Public method | ValueAxis | Initializes a new instance of the ValueAxis class
Top
Properties
 | Name | Description
Public property | Id | (Inherited from Axis.)
Public property | IsVisible | (Inherited from Axis.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


ValueAxis Constructor

ValueAxis Constructor
Initializes a new instance of the ValueAxis class

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public ValueAxis(
    string id
)
Public Sub New (
    id As String
)
public:
ValueAxis(
    String^ id
)
new :
        id : string -> ValueAxis

Parameters

id
Type: SystemString

[Missing <param name="id"/> documentation for "M:Novacode.ValueAxis.#ctor(System.String)"]

See Also

Reference

ValueAxis Class


ValueAxis Properties

ValueAxis Properties

The ValueAxis type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from Axis.)
Public property | IsVisible | (Inherited from Axis.)
Top
See Also

Reference

ValueAxis Class


ValueAxis Methods

ValueAxis Methods

The ValueAxis type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ValueAxis Class


VerticalAlignment Enumeration

VerticalAlignment Enumeration

[Missing <summary> documentation for "T:Novacode.VerticalAlignment"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum VerticalAlignment
Public Enumeration VerticalAlignment
public enum class VerticalAlignment
type VerticalAlignment
Members
Member name | Value | Description
Top | 0 |
Center | 1 |
Bottom | 2 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


XmlDocument Enumeration

XmlDocument Enumeration

[Missing <summary> documentation for "T:Novacode.XmlDocument"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public enum XmlDocument
Public Enumeration XmlDocument
public enum class XmlDocument
type XmlDocument
Members
Member name | Value | Description
Main | 0 |
HeaderOdd | 1 |
HeaderEven | 2 |
HeaderFirst | 3 |
FooterOdd | 4 |
FooterEven | 5 |
FooterFirst | 6 |
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


XmlTemplateBases Class

XmlTemplateBases Class

[Missing <summary> documentation for "T:Novacode.XmlTemplateBases"]

Inheritance Hierarchy
SystemObject
NovacodeXmlTemplateBases

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public static class XmlTemplateBases
Public NotInheritable Class XmlTemplateBases
public ref class XmlTemplateBases abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XmlTemplateBases =  class end

The XmlTemplateBases type exposes the following members.

Fields
Name | Description
TocElementStyleBase |
TocHeadingStyleBase |
TocHyperLinkStyleBase |
TocXmlBase |
Top
See Also

Reference

Novacode Namespace
Send comments on this topic to coffey.cathal@gmail.com


XmlTemplateBases Fields

XmlTemplateBases Fields

The XmlTemplateBases type exposes the following members.

Fields
Name | Description
TocElementStyleBase |
TocHeadingStyleBase |
TocHyperLinkStyleBase |
TocXmlBase |
Top
See Also

Reference

XmlTemplateBases Class


XmlTemplateBases.TocElementStyleBase Field

XmlTemplateBasesTocElementStyleBase Field

[Missing <summary> documentation for "F:Novacode.XmlTemplateBases.TocElementStyleBase"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public const string TocElementStyleBase = ""
Public Const TocElementStyleBase As String = ""
public:
literal String^ TocElementStyleBase = ""
static val mutable TocElementStyleBase: string

Field Value

Type: String
See Also

Reference

XmlTemplateBases Class


XmlTemplateBases.TocHeadingStyleBase Field

XmlTemplateBasesTocHeadingStyleBase Field

[Missing <summary> documentation for "F:Novacode.XmlTemplateBases.TocHeadingStyleBase"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public const string TocHeadingStyleBase = ""
Public Const TocHeadingStyleBase As String = ""
public:
literal String^ TocHeadingStyleBase = ""
static val mutable TocHeadingStyleBase: string

Field Value

Type: String
See Also

Reference

XmlTemplateBases Class


XmlTemplateBases.TocHyperLinkStyleBase Field

XmlTemplateBasesTocHyperLinkStyleBase Field

[Missing <summary> documentation for "F:Novacode.XmlTemplateBases.TocHyperLinkStyleBase"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public const string TocHyperLinkStyleBase = ""
Public Const TocHyperLinkStyleBase As String = ""
public:
literal String^ TocHyperLinkStyleBase = ""
static val mutable TocHyperLinkStyleBase: string

Field Value

Type: String
See Also

Reference

XmlTemplateBases Class


XmlTemplateBases.TocXmlBase Field

XmlTemplateBasesTocXmlBase Field

[Missing <summary> documentation for "F:Novacode.XmlTemplateBases.TocXmlBase"]

Namespace: Novacode
Assembly: DocX (in DocX.dll) Version: 1.0.0.21 (1.0.0.21)
Syntax
C#
VB
C++
F#
Copy
public const string TocXmlBase = ""
Public Const TocXmlBase As String = ""
public:
literal String^ TocXmlBase = ""
static val mutable TocXmlBase: string

Field Value

Type: String
See Also

Reference

XmlTemplateBases Class